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About this document

About this document
Purpose
This manual is intended as a guide to the configuration procedures for the integration
of SiPass Access Control system in the DMS8000 systems: MM8000 management
station and MK8000 OPC server.
This guide is part of the general DMS8000 documentation set which includes the
Composer Technical Manual, the other DMS8000 Connectivity Guides (Network, Fire,
Intrusion, Video, and OPC), and the Installation, Configuration and Commissioning
manual (ICC) for each specific product.

Scope
This document applies to DMS8000 MP4.81.

Target audience
This documentation is intended for the following users:
l Project Managers
l Project Engineers
l Commissioning Personnel
It is assumed that individuals performing the operations described in this manual have
prior expertise and training in the field of safety and security, at least a moderate level
of familiarity with the Siemens Building Technologies product line, and experience with
the installation, configuration, and commissioning of security management systems.

Documentation resource information
The DMS8000 Documentation Resource Information and Glossary Guide assembles
important information regarding documentation resources. This document contains the
following:
l Comprehensive definitions of the target audiences for Siemens FS DMS
documents
l Training program information including the Siemens intranet link
l A complete list of all available DMS8000 documents
l Instructions for how to obtain a document via the Siemens intranet using the
Siemens Asset Portal
l A map of relevant documents for each target audience group
l Customer Support links & resources
l A glossary containing definitions of all terms and acronyms used in DMS8000
documentation
To access the DMS8000 Documentation Resource Information and Glossary Guide
(document no. A6V10089056), go to the link and follow the document search
instructions below:
http://assetportal.bt.siemens.com/portal/index.html
1. In the Search column on the left, set:
–

Segment: 04 Fire -3F

–

Document Type: All

–

Image Type: All
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–

Advanced search criteria: Select Brochure No. and enter the document number
to search for (A6V10089056). Alternatively, select Title and enter the product
name (DMS8000).

2. Click Search to start.
3. In the resulting area on the right, click on Contents link to show the list of search
results.
For more information such as Siemens news and announcements, visit the STEP Web
portal at:
https://workspace.sbt.siemens.com/content/00001123/default.aspx

Operational and safety regulations
Before groups of persons begin work on the system, they must have read and
understood the Safety Regulations [➙ 7] section in this manual.

Liability disclaimer for damage or injuries
Before products are delivered, they are tested to ensure they function correctly when
used properly. Siemens disclaims all liability for damage or injuries caused by the
incorrect application of the instructions, or the disregard of danger advisories. This
disclaimer applies in particular to personal injuries or damage caused by:
l Improper and/or incorrect use.
l Disregard of safety instructions in the documentation or on the product.
l Poor maintenance or a lack of maintenance.
We have checked the contents of this manual for agreement with the hardware and
software described. Since deviations cannot be precluded entirely, we cannot
guarantee full agreement. However, the data in this manual are reviewed regularly and
any necessary corrections are included in subsequent editions. Suggestions for
improvement are welcome.

Copyrights and registered trademarks
Brand or product names mentioned in this document may be names protected by
copyright law or registered trademarks of other companies. These are mentioned only
for identification purposes and have no recommendatory character in regard to the
product or manufacturer, unless otherwise stated.

Documentation Conventions
The following table lists conventions to help you use this document in a quick and
efficient manner.
Convention

Examples

Numbered Lists (1, 2, 3…) indicate a
procedure with sequential steps.

1. Turn OFF power to the field panel.
2. Disconnect the power cord.
3. Open the cabinet.

One-step procedures are indicated by a bullet
point.

l

Conditions that you must complete or must be
met before beginning a procedure are
designated with a ⊳.
Results, after completing a step or at the end

⊳ The report you want to print is open.

Expand the Event List.

1. Click the Print icon

.

5
Building Technologies
Fire Safety & Security Products

A6V10062451_a_en
30.09.2016

About this document

of the entire procedure, are designated with a
⇨.

⇨ The Print dialog box appears.
2. Select the printer and click Print.
⇨ The print confirmation appears.

Bold font in a procedure indicates something
you should select or type.

Type F for Field panels.
Click OK to save changes and close the dialog
box.

Menu paths are indicated in bold.

Select File > Text, Copy > Group, which
means from the File menu, then select Text,
Copy and finally Group.

Error and system messages are displayed in
Courier New font.

The message Definition successfully
renamed displays in the status bar.

Italics are used to emphasize a term.

The Open Processor continuously executes a
user-defined set of instructions called the
control program.
This symbol signifies a Note. Notes provide
additional information or helpful hints.

Caution

This is a Caution message and indicates that
minor or moderate injury or property damage
may occur if a procedure is not followed.

Warning

This is a Warning message and indicates that
a serious injury or a severe equipment and
property damage may occur if a procedure is
not followed.

Cross references to other information in
printed material are indicated with an arrow
and the page number, enclosed in brackets:
[→92]

For more information on creating flowcharts,
see Flowcharts [→92].

Modification index
Note: For versions more than four years old, please visit the Siemens Asset Portal.
Version

Date

Notes

A6V10062451_a_en

09.2016

DMS8000 MP4.81:
Username and password configuration required in the SiPass
server configuration [➙ 11].

A6V10062451_a_en

06.2013

DMS8000 MP4.60 through 4.80

A6V10062451_a_en

06.2012

DMS8000 MP4.50.

A6V10062451_a_en

06.2011

DMS8000 MP4.40.

A6V10062451_a_en

06.2010

DMS8000 MP4.30.
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1 Safety regulations
This section describes the danger levels and the relevant safety regulations applicable
to the use of the products described in this manual. Please read the following work
instructions as well as the preceding section About this document thoroughly before
beginning any work.

1.1

Country-specific standards
Siemens products are developed and produced in compliance with the relevant
international and European safety standards. Should additional country-specific, and/or
local safety standards or regulations concerning project planning, installation, and/or
operation of the product(s) apply, then these standards and/or regulations must also be
taken into account, in addition to the safety regulations mentioned in the product
documentation.

1.2

Assembly and installation
The NK8000 units and NE8000 cabinets should always be installed in a clean and
stable environment; see the specific requirements given in the Technical Data section
of the specific NK823x datasheets.
In particular, keep units and cabinets away from the following:
l High levels of dust
l High temperature and humidity
l Locations where it might became wet
l Vibration and impact
Also, abide by the safety regulations of the connected devices.

1.3

Commissioning and testing
l
l

l
l

1.4

Activate security-, fire- and third party systems or devices only in the presence of
the person responsible.
Abide by the safety regulations of the connected sub-systems when working on
management stations. This especially applies when switching-off system
components.
Inform people before the testing of alarm devices; take the possibility of panic
reactions into account.
Inform the alarm and fault receiving stations connected to the system before
carrying out any tests.

Disposal and recycling
The NK8000 units include electrical and electronic components and must not be
disposed of as domestic waste. Current local legislation must be observed.
These devices have been manufactured as much as possible from materials that can
be recycled or disposed of in a manner that is not environmentally damaging.
However, they contain parts (batteries) that require disposal in a controlled waste
stream according to local environmental standards and/or regulations.
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1.5

Modifications to system design and products
Modifications to a system or to individual products may cause faults or
malfunctioning.
Please request written approval from Siemens Building Technologies, FS-DMS, and
the relevant authorities concerning intended system modifications and system
extensions.

1.6

Data Privacy and Protection
Make sure that the configuration of the MM8000 system complies with local data
privacy and protection regulations.
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2 Introduction
SiPass Access Control System
SiPass is an access control system that monitors and controls access to a site. It is a
complete system that packages all access control needs into a single application.
DMS8000 products and SiPass can coexist in the same installation; SiPass and
MM8000/MK8000 servers can run on the same machine or on different networked
PCs. Client functions may also be combined on the same PC.
l Detailed compatibility notes about SiPass software version(s) are available in the
latest MM8000 or MK8000 Release Notes.

Software License
A specific license id required for enabling the SiPass integration functions in MM8000.
l Please refer to the local sales support for more details about MM8000 licenses.

2.1

What’s new
Here is the list of modifications for new functions and software improvements.
Section

Modifications

Configuration procedure [➙ 11]

Username and password are required in the SiPass
subsystem configuration to secure the connection to
the SiPass server.
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SiPass integration
The DMS8000 systems MM8000 and MK8000 can support the integration of SiPass
access control system in order to provide for a comprehensive security solution.
Currently, the integrated solution with MM8000 management station can:
l Substitute the existing MM8000 functionalities for the SiPass functions related to
door event management, thus harmonising the entire event treatment of the safety
and security devices.
l Handle the AC users and access permissions configuration using the SiPass
software integrated into the MM8000 user interface.
l Allow for basic door statuses and control commands from the MM8000 text pages
and graphic maps.
l Store the security-relevant AC transactions (e.g. access denied) in the MM8000
history database.
l Support the connectivity to ACC controllers over a LAN network.
The integrated solution with MK8000 OPC server can:
l Allow for door statuses and control commands to be mapped in OPC items.

3.1

SiPass Driver
The Access Control integration requires a basic communication infrastructure between
MM8000/MK8000 and SiPass software; this is actually a software driver.
In Composer, the SiPass Driver should be added to the MM8000/MK8000 main station
in order to enable the SiPass configuration functions.
To add the SiPass driver to the MM8000 configuration do the following:
1. In the MM8000 physical configuration, select the main station name:
Supervisor System Settings > MM8000 System > Physical configuration > <Station
name>
In the MK8000 project, the selection is quite similar:
MK8000 System > MK8000 > Physical configuration > <Station name>
2. Click the SiPass Driver icon

.

a A new node is added. No further configuration is required by the driver.
Note: The Composer plug-in #252401 is required.
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Configuration checklist
Verify that you have satisfied the items needed in the first checklist before proceeding
to the configuration checklist that follows.

Items needed for configuration
l

l

l

The SiPass system should be configured and reachable, either locally (on the
same PC as MM8000/MK8000) or over the network, for importing the SiPass
database into the Composer structure.
Alternatively, the SiPass export file (.XML) should be created, using the utility
available in MM8000/MK8000 (SiPass Export Tool), and then imported off-line into
Composer.
Username and password to access the SiPass server from MM8000/MK8000. The
user account must belong to the administrators group.
NOTE: on installation migrated from earlier MM8000/MK8000 versions, make sure
to modify the default password.
Plug-ins needed:
– #252501

Note: Plug-ins are installed during the software setup procedure. You can check that
the Plug-ins are actually available using the Composer Plug-in Installer in the
DMS8000 start menu.

Configuration overview
1.
2.
3.
4.
5.
6.
7.
8.

3.3

Add the SiPass driver.
Add the folder for the Access Control.
Add the SiPass node.
Link the SiPass subsystem to the SiPass Driver.
Set the SiPass server address.
Set up the SiPass configuration structure.
Import the SiPass configuration (on-line mode or off-line mode).
Customise the SiPass configuration point (MM8000 only)

Configuration procedure
The following are the configuration procedures for SiPass.

Adding the SiPass Driver
1. Open the Composer project.
2. If not already done, add the SiPass Driver [➙ 10].

Adding the folder for the Access Control
l

Optionally, add one or more folders.

11
Building Technologies
Fire Safety & Security Products

A6V10062451_a_en
30.09.2016

3

Configuring SiPass
Configuration procedure

Adding the SiPass subsystem
1. Select the destination folder.
2. In the left-hand bar, select the Access Control folder
Subsystem icon

and then the SiPass

.

Adding the SiPass subsystem

Note: You can customise the default name of the new node typing in a new name in
the Description field of the Node tab.

Linking the SiPass subsystem to the SiPass Driver
You have now to link the subsystem to the Driver.
1. Select the SiPass subsystem node.
2. Drag and drop it on the SiPass Driver.
a A new link node appears.

Linking the SiPass subsystem
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Setting the SiPass server address
In this step, you have to specify the network name or address of the SiPass server.
1. Select the SiPass Subsystem node.
2. Select the Node tab.
3. In the Computer Name field of the SiPass Server Address section, enter the IP
address of the SiPass server PC.
There are two possible cases:
a) The SiPass server is the same as for MM8000/MK8000. In this case, the default
IP address 127.0.0.1 is valid in any case.
b) The SiPass server is another PC on the network. If so, enter the IP address or
the PC name.
4. In the Login parameters section, enter Username and Password to access the
SiPass server. The user account with the (case-sensitive) password must be
defined in SiPass.
NOTE: In case of user-authentication problems, the username or password error
are reported in the Connection Status line.

Setting the SiPass Server parameters

Setting up the SiPass configuration structure
The SiPass configuration can be imported into Composer in order to allow a fast and
seamless alignment process between the two systems.
There are two ways to import the configuration:
A. On-line mode: the SiPass server is accessible over the network and the
configuration data can be acquired directly.
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B. Off-line mode: the SiPass server is not yet accessible over the network and the
configuration data can be acquired by means of an export file.
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Importing the SiPass configuration: on-line mode
In the first case, once the SiPass server name is properly set, you can proceed as
follows:
1. Click the Connect button.
a A connection with the SiPass server is established.
In a few seconds, the Connection Status will indicate the successful
connection.
If the connection fails, the following error message appears.

In this case, Check that:
- The network connection is working (e.g. use the Ping command).
- On the server machine, the SiPass software is running properly.
2. Click the Align button.
a The SiPass configuration data is transferred over the network to Composer. In
a few seconds, the configuration status message will show “system is aligned”
and the SiPass structure will become available in the Composer tree.

Transferring SiPass configuration

3. While the connection with SiPass stays active, any modification in the SiPass
configuration is detected by Composer. If the configuration status shows “system
not aligned” again, it means that a new import is necessary: click the Align button
as described above. The modified objects will be imported without affecting the
remaining part of the structure.
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Importing the SiPass configuration: off-line mode
If the SiPass server cannot be directly connected to the PC running Composer, an offline mode is available. On the SiPass server, you need to run the utility program
SiPass Export Tool, available on the MM8000/MK8000 CD, and create an export file
(there is no need to install the entire MM8000 or MK8000 on the SiPass server).
The SiPass Export Tool can create an XML file containing the SiPass configuration,
which can then be imported into Composer. The following figure shows the simple
utility interface:

Exporting SiPass configuration

1. Indicate the SiPass IP address or name (the default value 127.0.0.1 is valid if
running locally on the server) and the export file name.
2. Click Create file to proceed.
Then, the resulting XML file can be imported into Composer with the following
procedure:
1. Select the SiPass Subsystem node.
2. Select Tools > Import or right-click the SiPass node and select Import.

Start SiPass off-line import
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a After a confirmation request, the software presents a browsing window to
search for the file to import (a file with extension XML is expected).
3. Using standard Windows controls, locate the file and select it and click Open.

Selecting the SiPass XML file

a In a few moments, the SiPass structure is imported, and the node is represented in
the Composer tree.
Selecting the Import tab results in a page report being displayed. This page contains
the detailed logs of the latest import procedure, including all the added (or removed)
objects.

Customising the SiPass configuration point (MM8000 only)
Once the SiPass structure is imported, it is ready to be downloaded. However, in
MM8000, customisations are possible as for the other points. Namely:
l In the Point Extensor tab of each individual point, customise the description and
icon.

Customising individual SiPass points
l

In the Event and OP Extensor tab of each individual point, customise the options of
an event (e.g.: modifying the event settings for the properties as in the following
figure).
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Customising individual SiPass points event settings
l

In the Transaction Extensor tab of each individual point and transaction, customise
the log options (e.g.: enabling/disabling properties as in the following figure).

Customising individual SiPass log options
l

In the Style tab of MM8000 system - Logical configuration - User Data - Event and
Points - Style, customise the options of a class of points (e.g.: modifying the event
settings for the properties of Door points as in the following figure).
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Customising event setting of SiPass Doors
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3.4.1

Further SiPass configuration notes
Tips and hints
l

l

SiPass configuration (MM8000 only). In order to work with MM8000, the SiPass
configuration must include the following:
– Users authorised on both MM8000 and SiPass have to be configured in both
environments with balanced permissions (MM8000 security profiles and SiPass
Operator Group functions).
– In SiPass, the common Operator(s) must be enabled to Automatic Logon as
Windows users. In the Operator form, click the Use the Windows logon option
and then select the correspondent MM8000 Domain and User.
SiPass license. In order to work with MM8000 or MK8000, SiPass requires a
software license. Please refer to the SiPass documentation.

Known issues and limitations
SQL Server. In the integrated system on the same server PC, the SQL Server has
to be installed by SiPass, which must therefore be installed first.
If you have installed MM8000/MK8000 before SiPass, do the following:
l

1. Uninstall MM8000 or MK8000 and reboot.
2. Uninstall SQL Server.
3. Install SiPass.
4. Re-install MM8000 or MK8000 (refer to the ICC manual).
l

l

l

Reader name, FLN name and structure. This information cannot be acquired from
SiPass; this prevents MM8000 and MK8000 from representing the entire physical
structure of the devices.
The SiPass functions which are also available in MM8000 - e.g. event notification
(message forwarding in SiPass), reactions and sequences (event tasks in SiPass) should be clearly assigned to either of the two systems, according to specific
requirements, thus preventing any functional overlap.
In case of communication problems between MM8000 and SiPass, make sure not
to check the Windows Explorer folder option: Use Simple File Sharing (select Tools
> Folder Options in the Explorer menu and then click the View tab as illustrated
here below). This option should NOT be enabled on the SiPass server PC.
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Folder Options
l

If the SiPass server does not run on the same PC as MM8000, then specific
installation steps are required on the networked PC where SiPass is installed:
1) In the Windows user list, the SiPass PC should include the MM8000 Internal
User, by default DMS8000_Proc. Use the same username and password as on the
MM8000 PC. Refer to MM8000 ICC Manual (doc.no. A6V10062413).
2) In the SiPass Server Properties, modify the Logon option in order to use the
MM8000 Internal User as Logon account.
Perform the following steps:
1. Log on to the PC with the SiPass server.
2. Right-click on My Computer and select:
System Tools > Local User and Groups → Users
3. Add the new user DMS8000_PROC and assign administrator rights
(for detailed instructions, please refer to the Windows documentation).
4. Right-click again on My Computer and select:
Services and Applications > Services
5.

Double-click on the SiPass service and select the Log On tab.
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6.
7.
8.
9.
10.

3.4.2

Click the This Account button and then select Browse.
In the Select User window, select the Advanced button.
Select Find Now and then DMS8000_PROC.
Restart the PC.
From MM8000, select Change Server in the Composer Properties Management window, and select
the SiPass server to connect.

SiPass alarm classes
In the integrated system, the use of SiPass Alarm Classes requires a special attention.
In fact, MM8000/MK8000 can receive and then present the SiPass events only if:
l Alarm Class Type is Input (no Outputs, Access or any other type)
l Alarm Handling is set to “Require Acknowledging”
l Alarm Options do not include the “Restorable Alarm”
l The definition includes all the possible input states of the object (e.g.: Door forced
and Door held, etc.)
In general, whenever possible, we recommend not configuring any Alarm Classes in
SiPass. When necessary, specific needs cases can be handled as follows:
l For Input Alarm events, use SiPass Input activation status, assigning a category,
e.g. Alarm, in the Event and OP Extensor tab of the Composer point.
l In other cases, you can use controller event tasks to activate an assigned input
and then, in turn, use this input to generate a message to MM8000/MK8000.
This approach allows getting the current Input state properly displayed in MM8000 (or
processed by MK8000) and the event being closed only when the corresponding Input
is in quiet state. Also, the same event is used for subsequent triggers, i.e. if the input is
re-activated while the event is still open. The event handling in MM8000 is therefore
fully standard.
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The following table presents the possible scenarios and the results for the system
operator. Refer to this table for any further needs of Alarm Classes when discussing
the issue with SiPass specialists.
Effect in MM8000/MK8000

Effect in SiPass

Event generation and transactions
(within the documented limitations) as
configured in Composer by default.
Door alarms received and displayed as
Severe Alarm.

No alarm pop-ups.

Alarm Class of any point type
configured as:
No Acknowledge required

No additional event.

No alarm pop-up.

Input Alarm Class configured as:
- Acknowledge required
- Not Restorable

No alarm pop-up of this input.
Event generation; point status is not
visible.
Event closing always possible
Registrations in audit trail.
regardless of the point status.
Subsequent events from this point are
displayed as new events.
Input activation Advisory never receives
and displays the Inactive point state.

Input Alarm Class configured as:
- Acknowledge required
- Restorable

Event generation; point status is not
visible.
Event closing always possible
regardless of the point status.
Re-activated events (triggered by the
Restorable “Once actioned … ” option)
are no more received.
Input activation Advisory receives and
displays the Inactive point state.

No alarm pop-up of this input initial event.
Re-activated pop-ups are displayed if the
input remains active.
Registrations in audit trail.

Alarm Class of any other type but
Input configured as:
- Acknowledge required
- Restorable

None

Alarm pop-up not removable → “freezing”
SiPass client.

Alarm Class of any other type but
Input configured as:
- Acknowledge required
- Not Restorable

None

Alarm pop-up
Registrations in audit trail.

No Alarm Classes defined

Registrations in audit trail.

Registrations in audit trail.

Check latest MM8000 Release Notes for version compatibility and limitations.
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3.4.3

SiPass Field Simulator
A simulation function is available for simulating the SiPass events in MM8000.
However, this is not part of the Field Simulator described in the Appendix A of MM8000
Installation, Configuration, and Commissioning manual (MM8000 ICC, doc.no.
A6V10062413).

Activating the SiPass simulator
The SiPass field simulator can be activated by selecting the Children tab of the SiPass
driver’s parent node and clicking the Simulation checkbox. The simulator is started
automatically when MM8000 server restarts. It can also be started manually from the
folder:
<installation folder>\Utilities\Field Simulator\SiPassSimulator.exe
WARNING
The SiPass Simulators only works properly when:
- The actual SiPass server is NOT running. Make sure to stop the SiPassServer
service in the Windows service list.
- The PC is physically connected to a LAN network (valid network cable plugged in).
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