Copyright Notice

Notice
Document information is subject to change without notice by Siemens Switzerland Ltd. Companies, names, and various data used in examples are fictitious unless otherwise noted. No part of this document may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Siemens Switzerland Ltd.
All software described in this document is furnished under a license agreement and may be used or copied only in accordance with license terms.
For further information, contact your nearest Siemens Switzerland Ltd. representative.
© Siemens Switzerland Ltd, 2015

Credits
Desigo, Desigo CC, Cerberus DMS, Cerberus PRO, and Sinteso are registered trademarks of Siemens Switzerland Ltd.
Other product or company names mentioned herein may be the trademarks of their respective owners.
Edition: 2015-07-15
Document ID: A6V10415471_en_a_21
## Table of Contents

About this Document ...................................................................................................... 11
Document Revision History ............................................................................................. 15
1 Introduction .............................................................................................................. 16
2 User Interface ........................................................................................................... 17
3 System Manager ....................................................................................................... 18
   3.1 Navigation Bar .................................................................................................... 20
      3.1.1 Navigating Through Recently Viewed Selections ............................... 20
      3.1.2 Setting the Favorite Location .............................................................. 21
   3.2 System Browser ................................................................................................. 21
      3.2.1 Overview of System Browser .............................................................. 21
      3.2.2 System Browser Workspace ............................................................... 23
      3.2.3 Working with System Browser ............................................................ 24
   3.3 Textual Viewer .................................................................................................... 26
      3.3.1 Overview of Textual Viewer ................................................................ 26
      3.3.2 Textual Viewer Workspace ................................................................. 26
      3.3.3 Working with Textual Viewer............................................................... 28
   3.4 Operation/Extended Operation ......................................................................... 29
      3.4.1 Overview of Operation/Extended Operation ....................................... 29
      3.4.2 Operation/Extended Operation Workspace ........................................ 32
      3.4.3 Working with Operation/Extended Operation ..................................... 34
   3.5 Related Items ..................................................................................................... 35
      3.5.1 Overview of Related Items .................................................................. 35
      3.5.2 Related Items Workspace ................................................................... 36
      3.5.3 Working with Related Items ................................................................ 37
   3.6 Recently Viewed ................................................................................................. 38
      3.6.1 Recently Viewed Workspace ................................................................ 38
      3.6.2 Working With Recently Viewed ........................................................... 39
4 Graphics .................................................................................................................... 40
   4.1 Overview of Graphics ......................................................................................... 40
      4.1.1 Graphic Libraries and Folders .............................................................. 41
      4.1.2 Graphics Related Folders ................................................................... 41
      4.1.3 Graphics Viewer: Operating and Engineering Mode ........................... 42
      4.1.4 Graphics Library Browser - Operating and Engineering Mode ........... 42
      4.1.5 Graphics Editor - Operating and Engineering Mode ........................... 43
      4.1.6 Security and Graphics Overview ........................................................ 43
      4.1.7 Scopes and Data Point Access ............................................................ 44
      4.1.8 User Settings Overview ...................................................................... 45
   4.2 Navigation in Graphics ....................................................................................... 45
      4.2.1 Accessing the Graphics Editor ............................................................ 45
      4.2.2 Drag-and-Drop Overview .................................................................... 46
      4.2.3 Table of Graphics Drop Targets .......................................................... 48
   4.3 Overview of Graphics Viewer ............................................................................. 48
4.3.1  Point Centered Mode ................................................................. 49
4.3.2  Status and Commands Overview ............................................... 50
4.3.3  Viewing Graphic Objects .............................................................. 50
4.3.4  Viewing a Coverage Area ............................................................. 52
4.3.5  Zooming and Panning ................................................................. 53
4.3.6  Graphics Viewer Components ..................................................... 53
4.3.7  Working with the Graphics Viewer ............................................... 60
4.3.8  Graphics Viewer Appendix .......................................................... 68

5  Alarm Management ................................................................. 70
5.1  Overview of Summary Bar ............................................................... 71
  5.1.1  Summary Bar Workspace ............................................................ 71
  5.1.2  Summary Bar and Client Profiles ................................................. 76
  5.1.3  Working with the Summary Bar .................................................... 77
5.2  Overview of Event Detail Bar ........................................................... 80
  5.2.1  Event Detail Bar and Client Profiles ............................................. 81
5.3  Overview of Event List ................................................................. 81
  5.3.1  Event List Workspace ................................................................. 81
  5.3.2  Event List and Client Profiles ...................................................... 87
  5.3.3  Working with Event List .............................................................. 88
5.4  Overview of Event Filters ............................................................... 91
  5.4.1  Filter Icon .................................................................................... 92
  5.4.2  Filter Menu .................................................................................. 92
  5.4.3  Advanced Filter Window ............................................................... 93
  5.4.4  Working with Event Filters .......................................................... 94
5.5  Overview of Alarm Handling .......................................................... 98
  5.5.1  Event Categories ........................................................................... 99
  5.5.2  Event Disciplines ........................................................................ 100
  5.5.3  Event Status .............................................................................. 100
  5.5.4  Source Status ........................................................................... 103
  5.5.5  Suggested Action ...................................................................... 103
  5.5.6  Alarm-handling Commands ....................................................... 103
  5.5.7  Investigative Treatment ............................................................... 105
  5.5.8  Assisted Treatment .................................................................... 106
  5.5.9  Handling Events ........................................................................ 111
  5.5.10 Using Fast Treatment ................................................................. 117
  5.5.11 Using Investigative Treatment ................................................... 118
  5.5.12 Using Assisted Treatment .......................................................... 119
  5.5.13 Managing Recurring Events ....................................................... 124

6  Remote Notifications ............................................................... 127
6.1  Remote Notification Messages Workspace ....................................... 128
6.2  New Remote Notification Workspace ............................................. 134
6.3  Working with Remote Notifications ............................................... 137
  6.3.1  Viewing the RENO Messages List ............................................... 137
  6.3.2  Enabling a Remote Notification ................................................. 138
  6.3.3  Disabling a Remote Notification ................................................. 139
  6.3.4  Handling an Automatic Alarm-Based Remote Notification ........ 139
6.3.5 Handling a Manual Alarm-based Remote Notification .......................... 140
6.3.6 Editing, Sending, and Handling a New Remote Notification ................ 141
6.3.7 Acknowledging Remote Notifications .............................................. 142

7 Scheduler ........................................................................................................ 143
7.1 Overview of Scheduler .................................................................................. 143
7.2 Overview of Timeline Viewer ........................................................................ 143
  7.2.1 Timeline Viewer Workspace ............................................................. 144
  7.2.2 Working with Timeline Viewer ......................................................... 145
7.3 Management Station Scheduling .................................................................. 146
  7.3.1 Management Station Calendars ....................................................... 147
  7.3.2 Management Station Schedules ....................................................... 149
  7.3.3 Management Station Time Triggers ................................................. 153
7.4 BACnet Scheduling ...................................................................................... 155
  7.4.1 Example of BACnet Scheduling ........................................................ 155
  7.4.2 BACnet Calendars ............................................................................ 159
  7.4.3 BACnet Schedules ............................................................................ 161
  7.4.4 BACnet Commands .......................................................................... 167

8 Trends .............................................................................................................. 169
8.1 Overview of Trend Application ...................................................................... 170
8.2 What is Online/Offline Trend? ....................................................................... 171
8.3 Trend Data Storage ........................................................................................ 172
8.4 Working with Trends...................................................................................... 174
  8.4.1 Trend View Properties ........................................................................ 174
  8.4.2 Compare View .................................................................................. 178
  8.4.3 Trend View ........................................................................................ 179
  8.4.4 Data Point Key .................................................................................. 186
  8.4.5 Toolbar .............................................................................................. 188
  8.4.6 System Browser ................................................................................ 189
  8.4.7 Quality Attributes ............................................................................. 190
  8.4.8 Table View ........................................................................................ 191
8.5 Defining Trend Views .................................................................................... 192
  8.5.1 Creating Trend View definition .......................................................... 193
  8.5.2 Creating New Trend Folder ............................................................... 194
  8.5.3 Creating New Trend View from System Browser ............................. 194
  8.5.4 Creating and Saving New Trend View ............................................. 195
  8.5.5 Creating New Trend View from Related Items ............................... 195
  8.5.6 Defining Chart Properties ................................................................. 196
  8.5.7 Defining Axis Properties .................................................................... 196
  8.5.8 Positioning Legend ........................................................................... 196
  8.5.9 Defining Line Properties .................................................................... 197
  8.5.10 Displaying Markers ........................................................................ 197
  8.5.11 Displaying Measured Values in Trend View .................................... 198
  8.5.12 Displaying Quality Attributes ........................................................ 198
  8.5.13 Positioning the Y-Axis ...................................................................... 199
  8.5.14 Editing Background or Line Colors ................................................. 199
  8.5.15 Showing, Hiding and Arranging Columns ......................................... 200
8.5.16 Deleting Trend View ................................................................. 201
8.6 Offline Trendlog Objects ............................................................... 201
  8.6.1 Creating Offline Trendlog Object ........................................... 202
  8.6.2 Creating Offline Trendlog Multiple Object ......................... 202
  8.6.3 Upload Offline Trendlog Data Manually .............................. 203
  8.6.4 Automating Execution for Upload Trendlog Data ............... 204
  8.6.5 Assigning or Replacing a New Trendlog Reference ............ 206
  8.6.6 Delete Offline Trendlog Object ............................................. 206
8.7 Analyzing Trend Data ................................................................. 207
  8.7.1 Switching between Automatic and Stop Mode .................... 207
  8.7.2 Selecting the Time Range using the Time Range Scrollbar .... 207
  8.7.3 Selecting Absolute Time Range ............................................ 208
  8.7.4 Selecting Relative Time Range from a Start Date .............. 209
  8.7.5 Selecting Relative Time Range from a Stop Date ............... 209
  8.7.6 Selecting Relative Time Range from a Current Date......... 210
  8.7.7 Selecting Time Range from Predefined Time Ranges ...... 211
  8.7.8 Using Comparative View ..................................................... 211
  8.7.9 Using Mouse Zoom .............................................................. 212
  8.7.10 Selecting Table View .......................................................... 212
  8.7.11 Temporarily Highlighting Data Series .............................. 213
  8.7.12 Temporarily Hiding Data Series ....................................... 213
  8.7.13 Removing Data Series from Trend View ........................... 214
8.8 Exporting Trend Data ................................................................. 214
  8.8.1 CSV Format ......................................................................... 214
8.9 Printing ...................................................................................... 216
  8.9.1 Print Preview and Properties ............................................... 217
  8.9.2 Printing Trend View ............................................................. 218
9 Reports ......................................................................................... 219
  9.1 Overview of Reports ............................................................... 219
    9.1.1 Reports for Operating Procedures .................................... 220
  9.2 Reports Workspace ................................................................. 221
    9.2.1 Reports Toolbar ................................................................. 222
    9.2.2 Reports Ribbon — Home Tab ............................................ 224
    9.2.3 Reports Ribbon — Filter Tab ............................................. 237
    9.2.4 Reports Ribbon — Layout Tab .......................................... 245
    9.2.5 Reports Ribbon — Data Tab ............................................. 248
    9.2.6 Reports Ribbon — Settings Tab ....................................... 249
    9.2.7 Report Management Section ............................................ 255
    9.2.8 Related Items Tab ............................................................ 256
  9.3 Reports Modes ....................................................................... 257
    9.3.1 Edit Mode ......................................................................... 258
    9.3.2 Run Mode ......................................................................... 258
  9.4 Reports Workflow ................................................................. 260
    9.4.1 Primary Pane ..................................................................... 260
    9.4.2 Secondary Pane ............................................................... 261
    9.4.3 Contextual Pane — Extended Operation Tab ................... 262
9.5 Creating a New Report Definition.................................................................262
9.6 Managing Reports Folders..............................................................................263
9.7 Configuring a Report Definition.......................................................................263
  9.7.1 Inserting a Table ..................................................................................263
  9.7.2 Inserting a Plot ...................................................................................266
  9.7.3 Inserting Text (Label) ..........................................................................266
  9.7.4 Inserting a Keyword ...........................................................................267
  9.7.5 Inserting a Logo ................................................................................268
  9.7.6 Configuring Form Controls ....................................................................269
  9.7.7 Applying a Name Filter .........................................................................272
  9.7.8 Applying a Condition Filter ....................................................................273
  9.7.9 Applying a Time Filter ...........................................................................274
  9.7.10 Applying a Row Filter .........................................................................275
  9.7.11 Applying the Graphics Filter ................................................................275
  9.7.12 Setting Page Layout ...........................................................................275
  9.7.13 Formatting Report Elements .............................................................277
9.8 Saving a Report Definition............................................................................278
9.9 Creating a New Report Definition from an Existing One ..................................279
9.10 Modifying a Report Definition .....................................................................279
9.11 Saving a Report Definition as the Default Template ......................................279
9.12 Generating a Report from a Report Definition ................................................280
  9.12.1 Generating a Report Manually using Run or Run as ................................280
  9.12.2 Generating a Report Manually from Related Items Tab .....................281
  9.12.3 Generating a Report Automatically ....................................................282
9.13 Printing Reports ..........................................................................................282
  9.13.1 Automatically Generated Reports .....................................................282
  9.13.2 Manually Generated Reports ............................................................282
9.14 Working with Reports in Run Mode.............................................................283
  9.14.1 Adding comments to the Comments Table ........................................283
  9.14.2 Modifying comments in the Comments table ....................................283
  9.14.3 Deleting comments from the Comments table ................................283
  9.14.4 Selecting Rows in Tables....................................................................283
9.15 Creating and Viewing a Report as a PDF or Excel .........................................284
  9.15.1 Generating a PDF .............................................................................287
  9.15.2 Generating an Excel (XLSX) ...............................................................288
9.16 Routing Reports ..........................................................................................290
  9.16.1 Configuring Report Destination Types ..............................................290
  9.16.2 Configuring a Report Output Definition .............................................292
9.17 Exporting a Report Definition ......................................................................295
9.18 Importing a Report Definition.......................................................................295
9.19 Deleting a Report Definition ........................................................................296
9.20 Aborting a Running Report Definition ........................................................297
9.21 Reports References .....................................................................................297
  9.21.1 Validating a Report Definition ............................................................297
  9.21.2 Report Events Logged in the History Database ...............................298
  9.21.3 Reports – Scope Rights ......................................................................298
9.21.4 Working with Reports for Operating Procedures ........................................... 299
9.22 Examples ........................................................................................................ 300
9.22.1 Objects Report .......................................................................................... 301
9.22.2 Activities Report ....................................................................................... 304
9.22.3 Event Details Report ............................................................................... 307
9.22.4 Events Report .......................................................................................... 313
9.22.5 Trends Plot ................................................................................................ 314
9.22.6 All Logs Report ........................................................................................ 316
9.22.7 In Operator ............................................................................................... 317

10 Log Viewer ...................................................................................................... 319
10.1 Overview of Log Viewer ................................................................................ 319
10.2 Log Viewer Workspace .............................................................................. 320
10.2.1 Log Viewer Toolbar ................................................................................ 321
10.2.2 Select Columns Dialog Box ................................................................ 322
10.2.3 Custom Filter .......................................................................................... 323
10.2.4 Contextual Pane - Detailed Log Tab ..................................................... 328
10.2.5 Search Filter Dialog Box ....................................................................... 330
10.3 Log Viewer Workflow .................................................................................. 332
10.3.1 Accessing Log Viewer from System Browser ...................................... 332
10.3.2 Viewing Log Data ................................................................................... 332
10.4 Working with Log Viewer .......................................................................... 333
10.4.1 Creating a Log View Definition ............................................................. 333
10.4.2 Configuring a Log View Definition ....................................................... 333
10.4.3 Saving a Log View Definition ............................................................... 343
10.4.4 Creating a New Log View Definition from an Existing One ............... 344
10.4.5 Saving Log View Definition as a Report Definition ............................. 344
10.4.6 Deleting a Log View Definition ............................................................. 344
10.4.7 Exporting a Log View Definition .......................................................... 345
10.4.8 Importing a Log View Definition ......................................................... 345
10.4.9 Refreshing a Log View ......................................................................... 345
10.4.10 Managing Log View Folders ............................................................... 345
10.4.11 Viewing Object Properties and Hierarchy ........................................ 346
10.4.12 Creating a Default Log View Template ............................................. 347

11 Macros ............................................................................................................ 348
11.1 Macros Workspace ....................................................................................... 348
11.1.1 Macro Properties and Control Commands ........................................ 349
11.2 Working with Macros ................................................................................. 350
11.2.1 Enabling a Macro .................................................................................. 351
11.2.2 Disabling a Macro ............................................................................... 351
11.2.3 Executing a Macro .............................................................................. 352
11.2.4 Aborting a Macro ................................................................................ 352

12 Reactions ........................................................................................................ 353
12.1 Reactions Workspace ................................................................................... 353
12.1.1 Reaction Properties and Control Commands ..................................... 354
12.2 Working with Reactions ............................................................................. 355
12.2.1 Enabling a Reaction ............................................................................ 355
<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>12.2.2</td>
<td>Disabling a Reaction</td>
<td>355</td>
</tr>
<tr>
<td>13</td>
<td>Address Book</td>
<td>356</td>
</tr>
<tr>
<td>13.1</td>
<td>Address Book Workspace</td>
<td>357</td>
</tr>
<tr>
<td>13.2</td>
<td>Working with the Address Book</td>
<td>359</td>
</tr>
<tr>
<td>13.2.1</td>
<td>Importing Contacts to the Address Book</td>
<td>359</td>
</tr>
<tr>
<td>13.2.2</td>
<td>Adding a Contact</td>
<td>360</td>
</tr>
<tr>
<td>13.2.3</td>
<td>Filtering the Address Book</td>
<td>361</td>
</tr>
<tr>
<td>13.2.4</td>
<td>Modifying a Contact</td>
<td>361</td>
</tr>
<tr>
<td>13.2.5</td>
<td>Deleting Contacts</td>
<td>362</td>
</tr>
<tr>
<td>14</td>
<td>Documents</td>
<td>363</td>
</tr>
<tr>
<td>14.1</td>
<td>Documents Operating Workflows</td>
<td>364</td>
</tr>
<tr>
<td>14.2</td>
<td>Documents Workspace</td>
<td>364</td>
</tr>
<tr>
<td>14.3</td>
<td>Working with Documents</td>
<td>365</td>
</tr>
<tr>
<td>14.3.1</td>
<td>Creating a New Document from an Existing One</td>
<td>365</td>
</tr>
<tr>
<td>14.3.2</td>
<td>Modifying a Document</td>
<td>366</td>
</tr>
<tr>
<td>14.3.3</td>
<td>Creating a Document Related Item</td>
<td>366</td>
</tr>
<tr>
<td>14.3.4</td>
<td>Modifying a Document Related Item</td>
<td>367</td>
</tr>
<tr>
<td>14.3.5</td>
<td>Zooming In/out and Printing a PDF Document</td>
<td>368</td>
</tr>
<tr>
<td>14.3.6</td>
<td>Deleting a Document</td>
<td>368</td>
</tr>
<tr>
<td>15</td>
<td>System-related Functions</td>
<td>369</td>
</tr>
<tr>
<td>15.1</td>
<td>User Password Change</td>
<td>369</td>
</tr>
<tr>
<td>15.1.1</td>
<td>Changing Your Password</td>
<td>369</td>
</tr>
<tr>
<td>15.2</td>
<td>Operator Switchover</td>
<td>369</td>
</tr>
<tr>
<td>15.2.1</td>
<td>Changing Operators</td>
<td>369</td>
</tr>
<tr>
<td>15.3</td>
<td>Auto Logoff</td>
<td>370</td>
</tr>
<tr>
<td>15.3.1</td>
<td>Interrupting the Auto Log Off</td>
<td>370</td>
</tr>
<tr>
<td>15.4</td>
<td>Logging On and Off in Closed Mode</td>
<td>370</td>
</tr>
<tr>
<td>15.4.1</td>
<td>Logging Off Default User and Logging On Operator</td>
<td>371</td>
</tr>
<tr>
<td>15.4.2</td>
<td>Logging Off Operator and Logging On Default User</td>
<td>371</td>
</tr>
<tr>
<td>15.5</td>
<td>Multiple Monitor Management</td>
<td>371</td>
</tr>
<tr>
<td>15.5.1</td>
<td>Moving a System Window to a Second Monitor</td>
<td>372</td>
</tr>
<tr>
<td>15.6</td>
<td>Print Feature</td>
<td>372</td>
</tr>
<tr>
<td>15.6.1</td>
<td>Printouts Selection Dialog Box</td>
<td>372</td>
</tr>
<tr>
<td>15.6.2</td>
<td>Print Preview Dialog Box</td>
<td>373</td>
</tr>
<tr>
<td>15.6.3</td>
<td>Printing from the Menu</td>
<td>374</td>
</tr>
<tr>
<td>15.6.4</td>
<td>Printing Data from a System Application</td>
<td>374</td>
</tr>
<tr>
<td>15.7</td>
<td>Displaying System Information</td>
<td>375</td>
</tr>
<tr>
<td>15.8</td>
<td>Windows Shortcut Keys Behavior</td>
<td>375</td>
</tr>
<tr>
<td>15.9</td>
<td>Client Application Supervision</td>
<td>376</td>
</tr>
<tr>
<td>15.10</td>
<td>Licensing</td>
<td>376</td>
</tr>
<tr>
<td>15.10.1</td>
<td>License Modes</td>
<td>378</td>
</tr>
<tr>
<td>15.11</td>
<td>Help System</td>
<td>381</td>
</tr>
<tr>
<td>15.11.1</td>
<td>Help Workspace</td>
<td>381</td>
</tr>
<tr>
<td>15.11.2</td>
<td>Working with Help</td>
<td>383</td>
</tr>
<tr>
<td>16</td>
<td>Backup</td>
<td>385</td>
</tr>
<tr>
<td>16.1</td>
<td>Project Backup ................................................................................................................. 385</td>
<td></td>
</tr>
<tr>
<td>------</td>
<td>--------------------------------------------------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>16.1.1</td>
<td>Manual Project Backup .......................................................................................... 386</td>
<td></td>
</tr>
<tr>
<td>16.2</td>
<td>History Database ........................................................................................................... 388</td>
<td></td>
</tr>
<tr>
<td>16.2.1</td>
<td>Backing up Data ........................................................................................................ 388</td>
<td></td>
</tr>
<tr>
<td>16.2.2</td>
<td>Automating Data Backup .......................................................................................... 390</td>
<td></td>
</tr>
<tr>
<td>16.2.3</td>
<td>Automatically Deleting Data Entries .................................................................. 391</td>
<td></td>
</tr>
<tr>
<td>16.2.4</td>
<td>Checking the Database Size ................................................................................... 392</td>
<td></td>
</tr>
<tr>
<td>16.2.5</td>
<td>Creating an Alarm Message ..................................................................................... 393</td>
<td></td>
</tr>
<tr>
<td>16.2.6</td>
<td>Troubleshooting ....................................................................................................... 394</td>
<td></td>
</tr>
<tr>
<td>16.2.7</td>
<td>Values and Data Capacity Settings ........................................................................ 394</td>
<td></td>
</tr>
</tbody>
</table>

**Appendix A: Client Profiles Extensions** .................................................................... 396

DMS_AT Extension ........................................................................................................... 396
About this Document

Purpose
This manual describes the features of the Desigo CC management station. It provides casual users with in-depth reference information for the different system features, including workflows, and is designed to support users in their daily site-related monitoring and controlling activities.

Scope
This document applies to Desigo CC Version 2.1.

Target Audience
End-Users are the primary users of the system. Depending on the specific application, end users can be a building services engineer, a security guard, a member of the fire brigade, the facility manager, and so on. They are responsible for monitoring and managing the facility and any related events. They have the appropriate training for operating the management station.
Liability Disclaimer
We have checked the contents of this manual for agreement with the hardware and software described. Since deviations cannot be precluded entirely, we cannot guarantee full agreement. However, the data in this manual are reviewed regularly and any necessary corrections included in subsequent editions. Suggestions for improvement are welcome.

Product Security Disclaimer
Siemens products and solutions provide IT-specific security functions to ensure the secure operation of building comfort, fire safety, security management and physical security systems. The security functions on these products and solutions are important components of a comprehensive security concept.

However, it is necessary to implement and maintain a comprehensive, state-of-the-art security concept that is customized to individual security needs. Such a security concept may result in additional site-specific preventive action to ensure that the building comfort, fire safety, security management or physical security systems for your site are operated in a secure manner. These measures may include, but are not limited to, separating networks, physically protecting system components, user awareness programs, in-depth security, and so on.

For additional information on building technology security and our offerings, contact your Siemens sales or project department. We strongly recommend signing up for our security advisories, which provide information on the latest security threats, patches and other mitigation measures.

### Document Conventions

The following table lists conventions to help you use this document in a quick and efficient manner.

<table>
<thead>
<tr>
<th>Convention</th>
<th>Examples</th>
</tr>
</thead>
</table>
| Numbered Lists (1, 2, 3…) indicate a procedure with sequential steps. | 1. Turn OFF power to the field panel.  
2. Turn ON power to the field panel.  
3. Open the panel. |
| One-step procedures are indicated by a bullet point. | ● Expand the Event List. |
| Conditions that you must complete or must be met before beginning a procedure are designated with a △. Intermediate results (what will happen following the execution of a procedure step), are designated with an indented ⇨. Results, after completing a procedure, are designated with a ⇨. | △ The report you want to print is open.  
1. Click Print 📄.  
⇨ The Print dialog box displays.  
2. Select the printer and click Print.  
⇨ The print confirmation displays. |
| **Bold** font indicates something you should type or select, or when a dialog box or window is specified. | Type F for field panels.  
Click OK to save changes and close the dialog box.  
The Create a New Project dialog box displays. |
| Menu paths in procedures are indicated in **bold**. | Select File > Text, Copy > Group, which means from the File menu, select Text, Copy and then Group. |
| File paths containing placeholders display the placeholders in *italics* enclosed in square brackets. | \[installation drive:\]\[installation folder\]\[project\]… |
| Error and system messages are displayed in **Courier New** font. | The message Report Definition successfully renamed displays in the status bar. |
| *Italics* are used to emphasize new or important terms. | The reaction processor continuously executes a user-defined set of instructions called the control program. |
| This symbol signifies a Note. Notes provide additional information or helpful hints. | This symbol signifies a Note. Notes provide additional information or helpful hints. |
| Cross references to other information in printed material are indicated with an arrow and the page number, enclosed in brackets: [→ 92] | For more information on creating flowcharts, see Flowcharts [→ 92]. |

### Getting Help

For more information about the Desigo CC products, contact your local sales representative.
Safety Messages According ANSI Z535.6

The following examples show the ANSI standard safety messages used in this document to draw the reader’s attention to important information. ANSI distinguishes between personal injury safety messages and property damage warning messages. The personal injury safety messages have safety alert symbols and the following alert level labels: DANGER!, WARNING!, CAUTION! The label for property damage messages is: NOTICE.

Examples:

<table>
<thead>
<tr>
<th>![Notice]</th>
<th><strong>NOTICE</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Property Damage Warning Message</strong></td>
<td></td>
</tr>
<tr>
<td>Equipment damage or loss of data may occur if you do not follow a procedure or instruction as specified.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>![Caution]</th>
<th><strong>CAUTION</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Caution Safety Message</strong></td>
<td></td>
</tr>
<tr>
<td>Minor or moderate injury may occur if you do not follow a procedure or instruction as specified.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>![Warning]</th>
<th><strong>WARNING</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Warning Safety Message</strong></td>
<td></td>
</tr>
<tr>
<td>Personal injury or property damage may occur if you do not follow a procedure as specified.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>![Danger]</th>
<th><strong>DANGER</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Danger Safety Message</strong></td>
<td></td>
</tr>
<tr>
<td>Electric shock, death, or severe property damage may occur if you do not perform a procedure as specified.</td>
<td></td>
</tr>
</tbody>
</table>
### Document Revision History

#### Document Identification

The document ID is structured as follows:

ID-Language(COUNTRY)_ModificationIndex_ProductVersionIndex

Example: A6Vnnnnnnnn_en_a_02

<table>
<thead>
<tr>
<th>Modification Index</th>
<th>Edition Date</th>
<th>Brief Description</th>
</tr>
</thead>
</table>
1 Introduction

The Desigo CC management station presents a single face to the customer for building automation, fire safety and security systems, or a combination thereof. Offering scalability of all configurations and allowing need-based expansion from small and medium to large and complex systems, Desigo CC provides customer and market-specific solutions.
2 User Interface

The exact screen layout will vary depending on your particular system's configuration, and you may not see all the components described.

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Summary bar</td>
<td>The main point of entry to all the functions of the software. Provides an overview of the events in the system. It includes a set of indicators (event lamps) organized by event category, the system menu, icons for switching between windows and silencing alarms, and other general status information. For some configurations only, when expanded, it also provides an Event Detail bar that highlights the most critical events in the system.</td>
</tr>
<tr>
<td>2</td>
<td>Work area</td>
<td>Large central portion of the screen below the Summary bar assigned to other management system windows or to the operating system desktop (such as Windows desktop) or to external applications (for example, Microsoft Internet Explorer, Microsoft Office programs, and so on).</td>
</tr>
</tbody>
</table>

In particular, depending on the operational workflow, the following windows can display in the work area:

- **Event List**
  A list of all the events in the building-control system. This is the starting point for viewing and handling events. The Event List is hidden and you can open it in the work area when needed by clicking its icon in the Summary bar.

- **System Manager**
  A multi-pane window for navigating, monitoring, and controlling all the components and subsystems of the site. Each pane contains a functional component of the management system (for example, a browser for navigating and selecting system objects, a viewer for displaying site floor plans, tools for scheduling tasks, and so on).

- **Investigative Treatment or Assisted Treatment**
  When you start to process an event, one of these dedicated alarm-handling windows may open in the main work area to help you take the correct actions.
3 System Manager

System Manager is a multi-pane window for navigating, monitoring, and controlling all the components and subsystems of your site. For example, you can inspect properties and states of objects, send commands, browse the architecture of the installation, consult floor plan graphics, and so on. A typical layout has a Selection pane on the left where you can locate and select system objects from a hierarchical tree view, and multiple working panes on the right that display object properties, commands, and associated applications based on the current selection.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Selection pane. Typically contains System Browser, for locating and selecting system objects in a hierarchical tree view. A drop-down menu lets you switch between different tree views (for example, Management View, Application View or other customizable views). Your selection here is propagated to the Primary pane on the right, and to the Contextual pane below it. At the bottom of this pane, the Recently Viewed stacked tab lets you access the recent views navigation option. This lets you return to a previously visited view in the Primary pane.</td>
<td></td>
</tr>
</tbody>
</table>
| 2 Primary pane. Contains one or more tabs associated with the object you selected in the Selection pane. These tabs can include:  
  - Textual Viewer. Displays information about the object such as its path, status, and so on.  
  - Default: If the selected object has an associated default application (for example a graphics viewer, or a tool for reporting), it displays in this tab).  
If the selected object has more than one associated application, tabs corresponding to those applications also display (for example, the Graphics viewer displays in the Default tab while the remote notification tool displays in the RENO Messages tab).  
If you have appropriate user rights, a button is available at the top of the pane to switch System Manager from Operating to Engineering mode to perform configuration tasks. |
| 3 Secondary pane. Opens when you click on a Related Item (by default), so that you can view it without losing the current information on the Primary and Contextual panes. |
| 4 Contextual pane. Provides additional information, actions, and resources for the object you most recently selected (in the Selection pane, or in one of the other panes). It is divided into two parts:  
  - Operation/Extended Operation tabs (left side): Lets you inspect all the properties of the selected object, and view and execute... |
any commands/actions available for that object.

- Related Items tab (middle): Provides links to additional resources (for example, reports or alarm-handling procedures) that are relevant to the selected object. If you click on a related item it opens by default in the Secondary pane. (You can also opt to direct Related Items to the Primary pane instead.)
- Detailed Log (right side): Lets you view a detailed history log about the selected object, and handle the log data.

Interacting with System Manager

You can interact with System Manager to perform actions and change what currently displays in the other panes in a variety of ways. These include:

- Click on an object in the Selection or Secondary pane to propagate its information, properties and commands to the Primary and Contextual panes.
- Click on the secondary header of a pane to select the corresponding object in the Selection pane.
- Right-click on an object (or group of objects) and choose whether to propagate (send) its information to the Primary or Secondary pane.
- Click on an object in the Related Items tab to open it in the Secondary (or Primary) pane.
- Drag-and-drop objects from the Selection or Contextual pane to perform certain tasks.

- Click to open the Navigation bar [20].

Example Workflow

The following is a typical workflow that illustrates how the different System Manager panes work together:

1. Select an object in the Selection pane.
2. Information and commands for that object display in the Primary pane and in the Contextual pane. You can immediately monitor and control the selected object.
3. Click the Primary pane to select a new object. The Contextual pane updates to let you monitor and control the new selection.
4. Click one of the links in the Related items list to open it in the Secondary (or Primary) pane. This provides additional information or resources relevant to the selected object.
5. Continue making selections, in both the Primary and Secondary pane, to immediately view the associated information and commands in the Contextual pane.
The following sections describe the most common applications included in System Manager.

3.1 Navigation Bar

The Navigation bar displays at the top of System Manager [➙ 18] and allows you to navigate the system without having to make selections in System Browser. It contains a set of icons, and a Breadcrumbs path that shows your current location as a series of links separated by arrows. The Back and Forward icons let you quickly return to recently-viewed selections. The History icon displays a list of your 20 most recently viewed selections, and the Favorite location icon jumps to a user-selectable view.

Breadcrumbs

The Breadcrumbs path in the Navigation bar functions like a condensed version of System Browser, without the search capabilities. The selections you make in the Breadcrumbs area are reflected in System Browser. The opposite is also true: the selections you make in System Browser are reflected in the Breadcrumbs area.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Back" /></td>
<td>Back</td>
<td>Go back to by one recently-viewed selection.</td>
</tr>
<tr>
<td><img src="image" alt="Forward" /></td>
<td>Forward</td>
<td>Go forward by one recently-viewed selection.</td>
</tr>
<tr>
<td><img src="image" alt="History" /></td>
<td>History</td>
<td>Shows a list of the 20 last recently-viewed selections. The current selection is highlighted with a checkmark and displays in the Primary pane. Click on another selection in the list to view it in the Primary pane.</td>
</tr>
<tr>
<td><img src="image" alt="Favorite location" /></td>
<td>Favorite location</td>
<td>Opens the location set as the current user’s favorite. This can be different for each user of the system. To set or change your Favorite location, navigate to the desired node in System Browser, then press and hold the Favorite location icon for approximately two seconds. The system will store your Favorite location and use it as the initial selection when you first open System Manager. When switching-over to a new user, that user's Favorite location will be used as the initial selection.</td>
</tr>
</tbody>
</table>

You can:

- Select a location [➙ 21] as your Favorite.

3.1.1 Navigating Through Recently Viewed Selections

Once you have visited a few locations, you can use the Navigation bar [➙ 20] to move backwards and forwards among the recently viewed selection.

The Navigation bar in System Manager is open.

1. If the Navigation bar is not open, in System Manager click the **Open Navigation Bar** icon ![Open Navigation Bar](image).

2. Click **Back** ![Back](image) or **Forward** ![Forward](image) to move back and forth among your recently viewed selections. Click **History** ![History](image) to view the list of the 20 most recently viewed selections, and select the desired item. Alternatively, you can use the
following keyboard shortcuts:

ALT + Left Arrow (Back)
ALT + Right Arrow (Forward)
CTRL + H (History).

► The selected view displays in the Primary pane.

### 3.1.2 Setting the Favorite Location

► The Navigation bar in System Manager is open.

1. If the Navigation bar is not open, in System Manager click the Open Navigation Bar icon.

2. In System Browser, select the node you want to use as your Favorite location.

3. In the Navigation bar, move the cursor over the Favorite location icon, and then press and hold the left mouse button for approximately two seconds.

► The status bar at the bottom of System Manager displays a message indicating that the favorite location has been set.

### 3.2 System Browser

#### 3.2.1 Overview of System Browser

System Browser displays objects in the building control system through various views, which you can select from a drop-down list. System Browser also supports searching and filtering of objects, displaying names and descriptions of objects, selecting single and multiple objects, and dragging and dropping of objects into Trends, Schedules, and Reports. The System Browser hierarchy updates dynamically to reflect changes at the system level.

**Searching and Filtering**

The Search area consists of an editable Search list box, a Search button, a drop-down list arrow, a Filter Search icon, and a Save Search icon.

Searching helps you quickly find objects in the currently selected view. You can perform searches on either names or descriptions but not on a combination of both names and descriptions. To start a search, you enter a search string in the Search list box, using wildcards if desired, and then either click Search or press ENTER. See the Wildcards section for more information about them.

After the search results display, you can save the search by clicking the Save As icon, entering a name in the Save Search field, and then clicking the Save button. The system saves the search to your own local user profile, and the search then becomes available only to you. You access saved searches by clicking the drop-down list arrow in the Search list box.

Filtering helps you limit the number of objects shown during a search, while also providing an efficient way to find objects without scrolling through the entire tree or without having to remember which node an object belongs to. You access the filtering fields by clicking Filter Search. You can then filter the objects by selecting individual or multiple building control types, subtypes, disciplines, and
subdisciplines. Clicking the **Search** button starts the search and displays the results of your filter selections.

Search results for both the searching and filtering features are sorted by path, using grouping, and by the name within each group. For example, a search for objects located in the east wing of the 92nd floor in your building could produce results similar to the following:

\[
\text{Willis Tower}\text{Floor 92(East Wing)}
\]

- EastWingTemp
- EastWingDailyTrend
- EastWingWeeklySchedule
- EastWingGraphic

**Wildcards**

Two wildcard characters are supported in System Browser—the asterisk (*) and the question mark (?). Each functions differently. The asterisk wildcard serves as a placeholder for zero or more characters. The question mark wildcard serves as a placeholder for exactly one character only. Therefore, each wildcard serves different purposes.

- ***(asterisk):** Allows you to add zero or more characters to your search criteria. For example, “a*” matches and displays, “a”, “ab”, “abc” and “abcd”.
- **? (question mark):** Allows you to add one character to your search. For example, “ab?” matches and displays “abc”, but does not match or display “a”, “ab” and “abcd”.

**Display Modes for Objects**

System Browser supports four modes for displaying objects. **Show Description** is the default display mode the first time you log on to the system with new credentials. After you log on, you can select your preferred mode, which the system saves for your next session. The mode you select affects the way the objects appear throughout the various panes in System Manager. The following table summarizes the four modes with display examples:

<table>
<thead>
<tr>
<th>Display Mode</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show Description</td>
<td>Air Handler Unit 1</td>
</tr>
<tr>
<td>Show Description [Name]</td>
<td>Air Handler Unit 1 [AHU1]</td>
</tr>
<tr>
<td>Show Name</td>
<td>AHU1</td>
</tr>
<tr>
<td>Show Name [Description]</td>
<td>AHU1 [Air Handler Unit 1]</td>
</tr>
</tbody>
</table>

**Views**

You can select from different views of the object types in the building control system, depending on how your system is set up. Selecting a view does not change the physical makeup of the system. The views merely represent convenient and different ways of looking at the system. Default views include **Application View** and **Management View**. The currently selected view is saved from session to session. In other words, the view that is selected when you close the software is the view that the system restores the next time you open the control software. Your last highlighted object selection in the System Browser tree, and the state of the expanded and collapsed folders, are not saved and restored from session to session.
Making Object Selections

System Browser offers you the following two methods for making objects the primary selection in System Manager:

- **Automatic Selection (default):** For selecting a single-object, you click the object, and it then automatically becomes the new primary selection in System Manager. For selecting multiple objects, you press and hold the **CTRL** key or the **SHIFT** key while highlighting the objects. Upon releasing either key, the objects become the new primary selection in System Manager.

- **Manual Selection:** First, check the **Manual Navigation** box, then highlight the object(s) in one of three ways: 1) Clicking the object(s), 2) Pressing and holding the **CTRL** key while clicking the object(s), or 3) pressing and holding the **SHIFT** key while clicking the beginning and ending range of objects. To make the highlighted object(s) the primary selection for System Manager, you can right-click and choose **Send to the Primary Pane**, or click the **Send** button. When selecting a single object, you can also double-click the object to make it the primary selection.

Dragging-and-Dropping

System Browser supports drag-and-drop of single or multiple objects from any of the views—including the **Search Result** view—to Trends, Schedules, and Reports. You can cancel a dragging operation by pressing the **ESC** key or by dragging the object(s) back to the original view (or other no-drop zone) and then dropping them.

### 3.2.2 System Browser Workspace

System Browser displays objects in the building control system through various views, and also supports searching and filtering.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| 1    | Views List Box  
   Allows you to select the view of the system by clicking the drop-down arrow. |
| 2    | Search List Box  
   Allows you to search for objects in the currently selected view. You can perform searches on either names or descriptions but not on a combination |
of both names and descriptions. The box consists of an editable field where you enter search strings, including wildcards. You can perform a search by name or description, depending on the setting of the Display mode. You start a search by entering text and then either pressing ENTER or clicking the Search icon. The matching results display in the list area. The drop-down arrow displays a list of your saved searches.

3 Display Mode List Box
Provides four options to display objects: Description, Description + Name, Name, and Name + Description. When you choose to display an object's Description + Name, the description appears first, followed by the name. When you choose to display an object's Name + Description, the name appears first, followed by the description. The option you select affects the way the object displays throughout the various panes in System Manager.

4 Manual Navigation Check Box
One of two methods for making objects the primary selection in System Manager. By default, automatic selection is enabled, which means that any object you select in System Browser automatically becomes the new primary selection for the system.

If you want to scroll through the System Browser tree and highlight an object without making it the primary selection, check the Manual Navigation box, and then single-click the object. If you then decide that you want to make the highlighted selection the new primary selection, you can do one of the following:

- Right-click and select either Send to the Primary Pane, or Send to the Secondary Pane.
- Click the Send button (sends to Primary pane only)
- Double-click (for single-object selection only, and sends to Primary pane only)

5 System Browser Tree
Displays system objects in a hierarchy.

6 Filtering Icon
Displays the Filtering Search area, where you can limit your search. In this area, you filter the objects by selecting individual or multiple building control types, subtypes, disciplines, subdisciplines, and aliases. Aliases are case sensitive. Clicking the Search button starts the search and displays the results of your filter selections. Clicking the X in the Alias field clears only the Alias field. Clicking the Clear button clears the Type, Sub Type, Discipline, Sub Discipline, and Alias fields.

7 Save Icon
Allows you to save a search entry for later use. You access saved searches by selecting the drop-down arrow in the Search list box.

8 Send Button
The Send button works in conjunction with the Manual Navigation check box. Once you select the check box and highlight an object, click the Send button and the object becomes the new primary selection for the system.

### 3.2.3 Working with System Browser

#### 3.2.3.1 Selecting Views

1. From the Views list box, click the drop-down arrow.
2. From the list of available views, select the view you want to display.
3.2.3.2 Searching for Objects
1. In the Search list box, enter the name of the object you want to search for. You can use wildcarding when performing a search.
2. Click the Search icon.

3.2.3.3 Filtering Searches
▷ You want to filter a search to limit the results that your search returns, and you have already entered text in the Search list box.
1. Click the Filter icon.
2. In the Type field, click the drop-down arrow and select the object type and subtypes you want to filter by.
3. In the Discipline field, click the drop-down arrow and select the discipline and subdisciplines you want to filter by.
4. In the Alias field, enter the case-sensitive alias you want to filter by.
5. Click Search to begin the search.
▷ The search results display in the tree area.

3.2.3.4 Saving Searches
1. Perform a search using the appropriate filtering criteria as needed.
2. Click the Save As icon.
3. In the Save Search field, type a name for your search.
4. Click Save.

3.2.3.5 Choosing a Display Mode
1. In System Browser, click the Display Mode drop-down list.
2. Select the mode you want for displaying objects.
▷ The object displays in the new mode throughout the various panes in System Manager.

3.2.3.6 Making a Manually Selected Object the New Primary Selection
▷ The Manual Navigation box is checked, with one or more objects selected.
● Do one of the following:
  – Right-click and select Send to the Primary Pane.
  – Click the Send button.
  – Double-click the object.
NOTE: Double-clicking works only when selecting a single object.
3.3 Textual Viewer

3.3.1 Overview of Textual Viewer

Textual Viewer displays the details for one or more objects in the building control system. For example, after you select one or more objects from System Browser, Textual Viewer displays their common properties in list form. Your selections can be either implicit or explicit. An implicit selection occurs when you click a parent object that has child objects associated with it. In this case, Textual Viewer displays the parent object in bold, followed by the child objects beneath it. An explicit selection occurs when you click a parent object that does not have child objects associated with it. You can sort the information in the various columns by selecting the column headings, and you can rearrange the order of the columns by dragging and dropping them to the desired location. Additionally, you can use the Customize Columns tool to hide or show columns.

Making a New Primary Selection

Making a new primary selection in Textual Viewer is an efficient alternative to manually scrolling through the System Browser tree to look for an item. It is also quicker than performing a formal search for an object using the Search feature.

Using the Double-Click Function

The double-click function gives you the ability to investigate building control system information in increasing detail. For example, if you select a building in System Browser, Textual Viewer displays it, along with each of the floors of the building. When you double-click one of the floors, Textual Viewer displays the floor, along with the sensors that are installed on that floor. If you then double-click one of the sensors, Textual Viewer displays the sensor. If a graphic is associated with the sensor, a graphic displays in the Primary pane. If not, text displays in the Primary pane.

3.3.2 Textual Viewer Workspace

Textual Viewer displays a hierarchical view of an object and, if applicable, its associated objects. Parent objects display as bolded text, while children objects display as regular text.

All columns except the Image column can be sorted. Clicking the column heading changes the sort order. A triangular icon displays in the column that the current sorting order is based upon. In implicit selection mode, with the parent object in bold and the children objects beneath them, sorting is based upon the parent object, so it will always remain at the top of the list, above the children associated with it. If you select multiple objects, with the parent object selected as one of the group, the parent object will not display as bolded.
Item | Description
--- | ---
1 | **Object**
   Displays a list of objects in the system. A bolded object indicates a parent object, with associated children objects.

2 | **Title Bar**
   Displays the name of the object with the primary selection. If you select multiple objects, the name of the first object you selected will display. If you select a parent object, you implicitly select the children objects belonging to the parent as well. In this case, the parent object displays in the title bar.

3 | **Path**
   Displays the location of the object in the building control system.

4 | **Name**
   Displays the name of the object.

5 | **Alias**
   Displays a unique name within the system for an object.

6 | **Type**
   Displays the type of object selected such as Smoke Detector, Room, Graphic etc.

7 | **Value**
   Displays the current value of the object.

8 | **Image**
   Displays an image associated with the status indicator.

9 | **Status**
   Displays the status of the object such as Normal, or the consolidated Status of the object such as Fire Alarm, Fault, or Technical Exclusion.
### 3.3.2.1 Customize Columns Dialog Box

![Customize Columns Dialog Box](image)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| 1    | **Available Columns**  
Displays a list of columns not currently shown in Textual Viewer. |
| 2    | **Movement Arrows**  
Allow you to move columns to control whether they are hidden or shown. |
| 3    | **Visible Columns**  
Displays a list of columns that will show in Textual Viewer. |
| 4    | **Selection Buttons**  
*Move up & Move down:* Allow you to rearrange the order in which columns display.  
*OK:* Allows you to accept the changes you have made.  
*Cancel:* Allows you to cancel changes you have made. |

### 3.3.3 Working with Textual Viewer

#### 3.3.3.1 Customizing Columns

- The system is in Operating mode and Textual Viewer displays in the Primary pane.

1. Right-click one of the following:
   - Column heading
   - Row
   - Scroll bar within the Primary pane
   - The Customize Columns dialog box displays.

2. To remove columns from the Visible list, select one or more headings, and then click the active arrow to move the headings.
3. To add columns to the Visible list, select one or more headings from the Available list, and then click the active arrow to move the headings.

4. Use the Move up and Move down buttons to arrange the order of the columns.

5. Click the OK button to accept the changes.

6. Click the Cancel button to cancel the changes.

3.3.3.2 Making a New Primary Selection

▷ Textual Viewer displays more than one object, and you would like to make one of those objects the new primary selection.

● Double-click the object you want to make the new primary selection.

❖ Textual Viewer sends the object to System Browser, and System Browser changes its focus to the object, just as if you had selected the object directly from System Browser. System Browser then refreshes the Textual Viewer, which displays the new primary selection.

3.3.3.3 Rearranging Columns

▷ Textual Viewer is open, and you would like to rearrange the order of the columns.

1. Click the column you want to move.

2. Drag and drop the column heading onto the desired location.

3.3.3.4 Sorting Objects

▷ You have more than one object displaying in Textual Viewer, and you would like to sort them.

● In the column you want to sort, click the drop-down arrow.

❖ The column sorts itself in either an ascending or descending alphabetical order, depending on the order prior to selecting the drop-down arrow.

3.4 Operation/Extended Operation

3.4.1 Overview of Operation/Extended Operation

The Operation and Extended Operation tabs allow you to display and change the current state of an object’s properties in your building control system. The Operation tab is designed for the most common daily tasks, and the Extended Operation tab is designed for more detailed tasks. Access to objects is based upon the object privileges and privilege profiles set for you by your system administrator.

3.4.1.1 Properties and Commanding

You change the current state of a property by commanding it. Once you command a property, the status of the command displays for the selected object. If the command fails, the reason for the failure displays so that you can take further action.

Examples of common commands:
● Acknowledge
● Change command priority
● Coldstart
● Enable/disable
● On/Off
● In service/Out of service
● Override/Release
● Reset value for equipment runtime
● Set a new point value
● Upload

Display of Properties
Properties display in one of two ways—automatically or manually. They display automatically when a property goes into an off-normal state, and they display manually when you select an object(s) in the system.

Why Command a Property?
You command a property to change its current state. For example, you might command to initiate an action, enable or disable a property, acknowledge or reset the status of a property, or override or release an override of a control program. Commanding a property is also useful under these conditions:
● User action is required to manage an emergency
● When an alarm indicates a malfunctioning device
● When performing preventive maintenance
● To save energy
● When managing runtime totalization

Example of Commanding
At your facility, you want to change the temperature from 68 to 73°F (20 to 22.78°C) in a conference room on your floor. Using your building control software, you send a command to change the Present Value of the Temperature Setpoint object of the room to override the normal system control.

3.4.1.2 Command Priorities and Priority Arrays
Some objects in your building control system use specialized command priorities to determine whether an operator or a particular control program is in control.

Command Priority
The Present Values of six object types in your building control system are based on a command priority and established in a hierarchy that ranks from highest (1 – Manual Life Safety) to lowest (16 - Available). The six object types are Analog Output, Analog Value, Binary Output, Binary Value, Multi-State Output, and Multi-State Value. The hierarchy helps determine which source has priority over another to change the value of an object. To command one of these object types, you—or an application—must have a command priority equal to or greater than the current command priority of the object.

Command Priority Array
The Command Priority Array displays commands that have been issued at various priority levels. Users and applications can set or relinquish (release) commands for a commandable object. If the Present Value of an object has a Command Priority Array, the appropriate priority level is commanded or relinquished when you execute a command. If the Present Value of an object does not have a Command
Priority Array, the system overwrites the present value with the newly commanded value. You can command or relinquish any priority level that you have access to, based on your user privileges.

The following table shows the Command Priority Array:

<table>
<thead>
<tr>
<th>Priority Level</th>
<th>Priority Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Manual Life Safety</td>
</tr>
<tr>
<td>2</td>
<td>Automatic Life Safety</td>
</tr>
<tr>
<td>3</td>
<td>Available</td>
</tr>
<tr>
<td>4</td>
<td>Available</td>
</tr>
<tr>
<td>5</td>
<td>Critical Equipment Control</td>
</tr>
<tr>
<td>6</td>
<td>Minimum On/Off</td>
</tr>
<tr>
<td>7</td>
<td>Available</td>
</tr>
<tr>
<td>8</td>
<td>Manual Operator</td>
</tr>
<tr>
<td>9</td>
<td>Available</td>
</tr>
<tr>
<td>10</td>
<td>Available</td>
</tr>
<tr>
<td>11</td>
<td>Available</td>
</tr>
<tr>
<td>12</td>
<td>Available</td>
</tr>
<tr>
<td>13</td>
<td>Available</td>
</tr>
<tr>
<td>14</td>
<td>Available</td>
</tr>
<tr>
<td>15</td>
<td>Available</td>
</tr>
<tr>
<td>16</td>
<td>Available</td>
</tr>
</tbody>
</table>

3.4.1.3 Summary Status

In order to simplify the system display and highlight the most important information, the system sometimes combines properties into a single Summary Status property. The Summary Status property displays the highest priority status that is currently active for an object. For example, if an object has an active Fire Alarm and Fire Fault, the Fire Alarm would be displayed in the Summary Status.

3.4.1.4 Multiple-Object Commanding

With multiple-object commanding, you are not really commanding objects at all. Instead, you are commanding one property type, Present Value for instance, for more than one object of the same type.

If you select multiple objects of the same type, for example, Analog Output, the icon next to the property name in the Operations or Extended Operations tab indicates this with a triangular symbol in the lower right-hand corner. Clicking this symbol expands the table row to show all of the selected objects of the same type that share this property. You can then change (command) all Present Value properties for the selected objects at the same time. The following graphics illustrate the multiple-object commanding concept.

In the following graphic, the system indicates that you have selected multiple objects by displaying a triangular symbol in the lower right-hand corner of the Present Value icon.
The following graphic shows that you have clicked the triangular icon. The system now displays two additional rows, which represent two selected objects of the same type.

3.4.1.5 Propagation

Propagation means relaying Common Status information up the building control system's hierarchical tree. Information that is relayed up the hierarchy as a result of a change in the Common Status of an object is called status propagation.

Propagation is based on the parent-child-grandchild model. Each object in the system can have one or more parent objects and one or more child objects. Each child in the system can simultaneously propagate multiple active Common Status properties to a parent—for example, fire alarm, fault, or technical excluded.

The following table shows propagation from two different viewpoints.

<table>
<thead>
<tr>
<th>Logical View of the System</th>
<th>Physical View of the System</th>
</tr>
</thead>
<tbody>
<tr>
<td>Building (parent)</td>
<td>A building node (parent)</td>
</tr>
<tr>
<td>Floor in the building (child)</td>
<td>Field panel (child)</td>
</tr>
<tr>
<td>Room on the floor (grandchild)</td>
<td>Point (grandchild)</td>
</tr>
<tr>
<td>Temperature sensor in the room (great-grandchild)</td>
<td>-</td>
</tr>
</tbody>
</table>

3.4.2 Operation/Extended Operation Workspace

The Operation and Extended Operation tabs display the name of the currently selected object(s), a list of properties associated with the object, the current value of the properties, and command buttons for initiating commands on commandable properties.
## Item Description

1. **Property Name**
   - Displays the name of one or more properties associated with the selected object(s).
   - If you select multiple objects of the same type in the system, the icon next to the property name indicates this with a triangular symbol in the lower right-hand corner. Clicking this symbol expands the table row to show all of the selected objects of the same type that share this property. You can then change all properties for the selected objects at the same time.

2. **Object Name**
   - The name of the selected object. If you selected more than one object to display, the default object name is Multi-Select.

3. **Current Value**
   - Displays the current value of each property.

4. **Command Button**
   - Displays the name of a command that you can initiate. Some commands are sent immediately after you initiate them by releasing the command button.
   - Others require you to enter arguments before they can be sent. When a command requires arguments (additional fields requiring information to continue with the command), the property row will expand after you click the command button. You then complete the additional fields and click the appropriate button (Send, Command, Change, Ack, and so on).
   - Some object properties support grouping of command buttons that occupy the space of one button, with a drop-down list of your choices. The button you choose from the drop-down list becomes the new commandable button in the group.

5. **Parameter**
   - When you initiate a command that requires additional parameters, the system prompts you to enter one or more parameters prior to sending the command. You must complete all required parameters before sending the command. A parameter field that displays a red border around it means that the value for that property is invalid. If that is the case, you will need to enter a valid value before commanding the property.

6. **Command Feedback Area**
   - Displays the progress and then the result of a command once you execute it.
3.4.3 Working with Operation/Extended Operation

3.4.3.1 Commanding Properties

▷ You have selected the object whose properties you want to command.
1. Click the Operation or Extended Operation tab.
   ◦ The tab displays properties of the object, their states, and all commands available to you for the properties.
2. Click the command button that displays the command you want to execute.
   ◦ If the command does not have arguments associated with it, the command is sent and the status displays.
   ◦ If the command button has arguments associated with it, go to the next step.
3. Complete the required fields.
4. Click Send.
   ◦ The system displays the status of the command.

3.4.3.2 Commanding Properties for Multiple Objects

▷ You have selected multiple objects of the same type whose properties you want to command.
1. Click the Operation or Extended Operation tab.
   ◦ The tab displays properties of the objects, their states, and all commands available to you for the properties. Properties affected by multiple selection of objects display an icon with a triangular symbol in the lower right-hand corner.
2. Click the triangular symbol on the icon next to the property you want to command.
   ◦ The table row of the property expands to show multiple instances of the property—one for each of the objects selected.
3. Click the command button that displays the command you want to execute.
   ◦ If the command does not have arguments associated with it, the command is sent and the status displays.
   ◦ If the command button has arguments associated with it, go to the next step.
4. Complete the required fields.
5. Click Send.
3.5 Related Items

3.5.1 Overview of Related Items

Related Items displays objects related to the currently selected object. Each related item is assigned a group name that represents the object's type—for example, graphics, trends, reports, or schedules.

Navigation

You can navigate to a view of each related item by clicking on the item. For instance, if you click a management station object, such as a graphic, Graphics Viewer displays the referenced graphic object. If you click an external item, such as a PDF file, Adobe Reader opens with the referenced file displayed. Other items that you can access include point types, Word documents, Excel documents, and URLs.

Display of Items

The Related Items tab displays the items used for most daily operations. Related Items contains two sets of buttons. You can toggle the first set of buttons, Links and Icons, which allows you to switch between text views or small images of the items in the list. The Links view is more compact than the Icons view, so more related items can be displayed with this view than with the Icons view. The display mode that is currently selected in System Browser determines how text displays in Related Items. For example, text might be displayed as description, name, description plus name, or name plus description.

The second set of buttons, Group and Ungroup, allows you to switch between categories or flat-list views of the items in the list. The Group view shows items arranged by object type (analog input, digital output, schedules, graphics, reports, PDFs, Word files, web links, etc.) and is expanded by default, but which you can collapse as well. When the Group view is collapsed, the Links and Icons views are disabled. The Ungroup view displays all related items without displaying their corresponding group names.

If you select one object from System Browser, Related Items displays all links associated with that object. If you select two or more objects from System Browser, Related Items displays only those links that all selected objects have in common.

For example, you select three objects in System Browser with the following links:

<table>
<thead>
<tr>
<th>Object</th>
<th>Links</th>
</tr>
</thead>
<tbody>
<tr>
<td>EastWingLabTemp</td>
<td>Monthly Energy Consumption Report</td>
</tr>
<tr>
<td></td>
<td>Third Floor Heating/Cooling Schedule</td>
</tr>
<tr>
<td></td>
<td>Third Floor Temperature Trend</td>
</tr>
<tr>
<td>WestWingOfficeTemp</td>
<td>Monthly Energy Consumption Report</td>
</tr>
<tr>
<td></td>
<td>Third Floor Heating/Cooling Schedule</td>
</tr>
<tr>
<td></td>
<td>Third Floor Temperature Trend</td>
</tr>
<tr>
<td>NorthWingOfficeTemp</td>
<td>Monthly Energy Consumption Report</td>
</tr>
<tr>
<td></td>
<td>Third Floor Heating/Cooling Schedule</td>
</tr>
</tbody>
</table>

The result of this selection is that Related Items displays only the Monthly Energy Consumption Report and the Third Floor Heating/Cooling Schedule links because they are common to all three objects. The Third Floor Temperature Trend link does not display because it is not common to all three selected objects. To view the Third Floor Temperature Trend link in this example, you would need to select either the EastWingLabTemp object or the WestWingLabTemp object.

While Related Items works to retrieve the links for the objects you select, it displays text to indicate the status of the selections.
Maintenance of User Preferences

Related Items stores the settings of the Group and Ungroup views and the Links and Icons views for each object that you interact with so that you do not need to continually adjust your settings as you navigate from one object to the next.

Related Items Restrictions

Be careful about deleting and then re-adding points in your system since this can break the links in Related Items.

For example, you select a point on a graphic, and the graphic itself displays as one of the links for that point in Related Items. If you delete the point from the field panel, and then re-add it (re-import it using the Auto Discovery feature), the graphic will display the point, but the related items for the point will be lost. If you select the re-added point in System Browser, the graphic will not display.

In the case of graphics, you can restore the broken links using the Graphics Consistency Checker diagnostic tool. See the Graphics Editor documentation for more information.

If you delete points relating to camera devices, External Documents, and Management Station Schedules, your links will be permanently lost.

3.5.2 Related Items Workspace

Related Items allows you to switch between small images or text views of the items in the list, or between categories or flat-list views of the items in the list.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td><strong>Links/Icons buttons</strong>&lt;br&gt;The Links button allows you to view items as text displays. The display mode that is currently selected in System Browser determines how text displays in Related Items. For example, text might be displayed as description, name, description plus name, or name plus description.&lt;br&gt;The Icons button allows you to view related items as small images.</td>
</tr>
<tr>
<td>2</td>
<td><strong>Group/Ungroup buttons</strong>&lt;br&gt;The Group button allows you to group items by object types such as analog inputs, analog outputs, schedules, reports, PDFs, Word files, and Web links. The Ungroup button allows you to view items in a flat list without their corresponding category names. Items display icons associated with the object type.</td>
</tr>
</tbody>
</table>
3.5.3 Working with Related Items

3.5.3.1 Viewing a Related Item

▷ You have selected an object with Related Items.
  • From Related Items, click the item you would like to view—for example, click a New Report, a Schedule, a PDF file, or a URL.
  ◇ The management station opens the representation for the selected item in the Secondary Pane (or in the Primary pane if the Primary pane splitting is locked).

3.5.3.2 Viewing Links

▷ You have selected an object with Related Items displayed as Icons.
  • From Related Items, click the Links button.
  ◇ The Related Items display as Links.

3.5.3.3 Viewing Icons

▷ You have selected an object with Related Items displayed as links.
  • From Related Items, click the Icons button.
  ◇ The Related Items display in the Icons view.

3.5.3.4 Grouping Items in the List

▷ You have selected an object with Related Items displayed in a flat list.
  • From Related Items, click the Group button.
  ◇ All Related Items are grouped according to type—for example, Report, Graphic, Schedule, etc.

3.5.3.5 Ungrouping Items in the List

▷ You have selected an object with Related Items displayed in Groups.
  • From Related Items, click the Ungroup button.
  ◇ All items are ungrouped.

3.5.3.6 Creating a New Object

▷ You have selected an object with links displaying in Related Items.
  • From Related Items, click the type of object you would like to create—for example, New Report.
  ◇ The management station opens a new object type in the Secondary Pane.
3.6 Recently Viewed

Recently Viewed is a navigation aid housed in the Selection pane that lets you quickly return to a recently-visited view in the Primary pane. To access Recently Viewed, click its stacked tab at the bottom of the Selection pane. You will see a history of the 20 most recent views in the Primary pane, displayed as either thumbnails (snapshots) or links. Click on a thumbnail or link to jump back to that view in the Primary pane.

See Recently Viewed Workspace \([\rightarrow 38]\) and Working With Recently Viewed \([\rightarrow 39]\) for details.

You can also navigate \([\rightarrow 20]\) through recently-visited views using the icons in the Navigation bar \([\rightarrow 20]\) of System Manager.

3.6.1 Recently Viewed Workspace

When you open the Recently Viewed panel in the Selection pane of System Manager, you can quickly scroll through the history of the recent views and select a snapshot/link to return to the corresponding recently visited \([\rightarrow 39]\) view in the Primary pane.

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Recent views</td>
<td>Lists the 20 most recently visited views, with the most newest one at the top. They may appear as snapshots (thumbnails) or links. The item corresponding to the current view in the Primary pane is highlighted.</td>
</tr>
<tr>
<td>2</td>
<td>Scroll icons (Newer/Older)</td>
<td>Move backward and forward among the recent views.</td>
</tr>
<tr>
<td>3</td>
<td>Links/Thumbnails toggle button</td>
<td>Switch from snapshots (thumbnails) to links and vice versa.</td>
</tr>
</tbody>
</table>

Notes

- A new recently-viewed item is stored whenever you change the view in the Primary pane (for example, by selecting an object in System Browser).
- Returning to one of the recent views creates a new recently viewed item.
- If there is a long operation in progress in the Primary pane, the snapshot/link being stored blinks until the in-progress operation completes.
3.6.2 Working With Recently Viewed

The Recently Viewed [38] feature lets you return to a previously visited view in the Primary pane.

1. In the Selection pane, click the Recently Viewed tab.
   - Recently Viewed displays showing a history list of the recently visited views in the Primary pane. Click the Links/Thumbnails button to switch between displaying the recent items as snapshots or text links.

2. Click the scroll icons (Newer) (Older) to move backward and forward among the recent views.
   - The selected view displays in the Primary pane, and a new recently visited view item is created and displays in Recently Viewed.

NOTE:
The access to recently visited view items depends on your user rights. If you don’t have appropriate access permissions you won’t be able to display some of the items.
4 Graphics

4.1 Overview of Graphics

The Graphics application allows you to view and command (Graphics Viewer), create (Graphics Editor), and store (Graphics Library Browser) large graphics representing equipment, floors, buildings, facilities, and entire campuses. These graphical representations can contain dynamic elements to represent devices or values you want to monitor or control. The Graphics application consists of three main components; the Graphics Viewer, the Graphics Editor, and the Graphics Library Browser.

The Graphics application is located by selecting System Browser > Application View. Project graphics are listed in the root of the Graphics Tree.

Graphics Viewer

The Graphics Viewer is the component of the Graphics application that allows you to view the graphics representing your facility or equipment. It is where you can change the current state of an object’s properties from a graphic, by using the floating Status and Commands windows. You can filter your view of a graphic by discipline, section, or you can zoom in and out for greater detail or for a birds-eye overview.

The Graphics Viewer is accessible from the Systems Browser’s Application View, and then clicking Graphics, or any one of the actual graphics in its root structure. The Graphics Viewer displays in the Default tab of either the Primary or Secondary pane. If you have the appropriate security access, you can access the Graphics Editor from the Graphics Viewer.

For more information on the Graphics Viewer, see Overview of Graphics Viewer [48].
Graphics Editor

The Graphics Editor is the Graphics component that, with the appropriate security rights, allows you to create and modify simple and dynamic graphical representations of your devices, facility, campus, or equipment. The Graphics Editor also allows you to test and simulate your dynamic graphics before going online with them. Graphics, Symbols, and Graphic Templates are all created in the Graphics Editor.

The Graphics Editor is accessible from the:

- Graphics Viewer, by switching from Operating to Engineering mode, or by clicking Edit from the Graphics Viewer toolbar.
- Graphics Library Browser, by right-clicking on a Symbol or Graphic Template thumbnail in the Primary pane, and selecting Edit, or by clicking Edit from the Graphics Library Browser.

For more information on the Graphics Editor, see Overview of Graphics Editor.

Graphics Library Browser

The Graphics Library Browser allows you to toggle between a view that displays all the available Symbols and graphic template objects in your project libraries. The Graphics Library Browser displays in the Primary pane when you click a libraries Symbol or Graphic Templates folder. It is also accessible from within the Graphics Editor as one of the views you can display in the dock panel.

For more information on the Graphics Library Browser, see Overview of Graphics Library Browser.

4.1.1 Graphic Libraries and Folders

Graphics Libraries and folders are located and created in the System Browser, in both the Management View and Application View.

In order to view graphics, you must first create your libraries and sub-libraries that will host the graphics. This is accomplished in the System Browser's Management View. The System Settings folder contains the configuration area for all your libraries.

Existing graphics associated with your plant are listed and viewed from the Application View tree, under the Graphics application.

4.1.2 Graphics Related Folders

Graphic Related Folders

Graphic related folders are displayed in both the System Browser’s Application View and the Management View. There are three types of graphic folders: Graphic, Symbols, and Graphic Template.

- Application View > Graphics – Displays all graphics (*.CCG) files.
- Management View > Project* > System Settings > Libraries > [Appropriate Sub-Library] > Symbols – Displays all the related Symbols (*.CCS) files associated with the selected library.

*If your System Browser display mode is set to Show Name, you will see ManagementView instead of Project.
4.1.3 Graphics Viewer: Operating and Engineering Mode

The following table describes the Graphics Viewer behavior according to the Graphics window mode.

<table>
<thead>
<tr>
<th>Graphics Viewer window mode</th>
<th>Graphics Viewer application behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating</td>
<td>● The Graphics Viewer displays:</td>
</tr>
<tr>
<td></td>
<td>− In the Default tab of the Primary pane.</td>
</tr>
<tr>
<td></td>
<td>− The Textual Viewer tab displays and is available in the Primary pane.</td>
</tr>
<tr>
<td></td>
<td>● Can create, open, and edit graphic files.</td>
</tr>
<tr>
<td>Engineering</td>
<td>● The Graphics Viewer displays:</td>
</tr>
<tr>
<td></td>
<td>− In the Graphics tab of the Primary pane.</td>
</tr>
<tr>
<td></td>
<td>− The Object Configurator tab displays and is available in the Primary pane.</td>
</tr>
<tr>
<td></td>
<td>● Can create, open, and edit graphic files.</td>
</tr>
</tbody>
</table>

4.1.4 Graphics Library Browser - Operating and Engineering Mode

The following table describes the Graphics Library Browser behavior according to the Graphics window mode.

<table>
<thead>
<tr>
<th>Graphics Viewer window mode</th>
<th>Graphics Viewer application behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating</td>
<td>● The Graphics Library Browser displays:</td>
</tr>
<tr>
<td></td>
<td>− In the Default tab of the Primary pane.</td>
</tr>
<tr>
<td></td>
<td>− The Textual Viewer tab displays and is available in the Primary pane.</td>
</tr>
<tr>
<td></td>
<td>● The Graphics Viewer toolbar displays.</td>
</tr>
<tr>
<td></td>
<td>● When you click the Edit icon, the Graphics Editor displays in Operating mode.</td>
</tr>
<tr>
<td>Engineering</td>
<td>● The Graphics Library Browser displays:</td>
</tr>
<tr>
<td></td>
<td>− In the Graphics tab of the Primary pane.</td>
</tr>
<tr>
<td></td>
<td>− The Library Object Configurator tab displays and is available in the Primary pane.</td>
</tr>
<tr>
<td></td>
<td>− The Object Configurator tab displays and is available in the Primary pane.</td>
</tr>
<tr>
<td></td>
<td>● The Graphics Viewer toolbar displays.</td>
</tr>
<tr>
<td></td>
<td>● When you click the Edit icon, the Graphics Editor displays in Engineering mode, and the Library Browser view opens and displays all the associated Symbols or graphic templates of that particular library.</td>
</tr>
<tr>
<td></td>
<td>● Can create, open, and edit graphic files.</td>
</tr>
</tbody>
</table>
4.1.5 Graphics Editor - Operating and Engineering Mode

The following table describes the Graphics behavior according to the Graphics window mode.

**NOTE:**
In addition to having a Graphics Editor license, you must also have Graphic Editor Application rights to create, edit, or delete a Symbol or Template Graphic. Graphic Editor level access is defined by the Security application.

<table>
<thead>
<tr>
<th>Graphics Editor window mode</th>
<th>Graphics Editor application behavior</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating</td>
<td>• The Graphics Editor displays</td>
</tr>
<tr>
<td></td>
<td>– In the <strong>Default</strong> tab of the Primary pane.</td>
</tr>
<tr>
<td></td>
<td>– The <strong>Textual Viewer</strong> tab is displayed and available in the Primary pane.</td>
</tr>
<tr>
<td></td>
<td>• Can create, open, and edit graphic files.</td>
</tr>
<tr>
<td>Engineering</td>
<td>• The Graphics Editor displays:</td>
</tr>
<tr>
<td></td>
<td>– In the <strong>Graphics</strong> tab of the Primary pane.</td>
</tr>
<tr>
<td></td>
<td>– The <strong>Object Configurator</strong> tab is displayed and available in the Primary pane.</td>
</tr>
<tr>
<td></td>
<td>• Can create, open, and edit graphic files.</td>
</tr>
</tbody>
</table>

4.1.6 Security and Graphics Overview

Access levels are the security rights users are granted to access applications and objects in the Desigo CC software. The access levels for the Graphics Viewer, Graphics Editor, and Graphics Library Browser are as follows:

**Graphics Viewer**

The access rights for the Graphics Viewer application define the user’s ability to display a graphic or a Symbol in the Graphics Viewer and in the Graphics Editor Runtime mode.

<table>
<thead>
<tr>
<th>Access</th>
<th>If Enabled</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show</td>
<td>You can display a graphic in the Graphics Viewer and in the Graphics Editor Runtime mode.</td>
</tr>
</tbody>
</table>

**Graphics Editor**

If you have access rights for the Graphics Editor application, you can create, modify, and delete graphics, Symbols, graphic templates, and graphic folders.

<table>
<thead>
<tr>
<th>Access</th>
<th>If Enabled</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show</td>
<td>You can access the Graphics Editor.</td>
</tr>
<tr>
<td>Create</td>
<td>You can create new and save existing graphics and graphic folders.</td>
</tr>
<tr>
<td>Delete</td>
<td>You can delete graphics and graphic folders.</td>
</tr>
<tr>
<td>Save</td>
<td>You can save any changes to a graphic. <strong>NOTE:</strong> If disabled, you can open a graphic, but, in Read-Only mode. No changes can be made.</td>
</tr>
</tbody>
</table>
Graphics Library Browser

If you have access rights for the Graphics Library Browser, you can navigate to and display Symbols and graphic templates in the Graphics Viewer, as well as the user’s ability to create and modify them in the Graphics Editor.

<table>
<thead>
<tr>
<th>Access</th>
<th>If Enabled</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show</td>
<td>You can view Symbols and Graphic Templates in the Graphics Viewer and the Graphics Editor.</td>
</tr>
<tr>
<td>Create</td>
<td>You can create new graphics, Symbols, and graphic templates, and save existing Symbols and graphic templates.</td>
</tr>
<tr>
<td>Delete</td>
<td>You can delete graphics and graphic folders.</td>
</tr>
<tr>
<td>Save</td>
<td>You can save an existing Symbol or graphics template in its original name or in one of the existing names in the library.</td>
</tr>
</tbody>
</table>

4.1.7 Scopes and Data Point Access

Assigning Scopes to Graphic Objects

Scope is a grouping of system objects, or nodes with specific scope definitions used for the purpose of assigning access rights. You can create scopes and assign access rights to any of the graphic nodes in the Graphics system tree. For more information, see Scopes.

You can apply scopes to the following graphic nodes:
- Graphics
- Symbols
- Templates
- Manual and Automatic Pages

Data Point Access Privileges

Data points are integrated into a graphic by associating them with elements. These data points and elements can be evaluated by creating expressions that result in a graphic that allows you to view dynamic values of a facility, building, or piece of equipment. Data points, therefore, always display using the elements they are associated with.

Depending on the your access rights, which are set in the System Manager, certain data points can be inaccessible. In this case, if one or more data points associated with an element is inaccessible, then the associated element will not display in the graphic while in Runtime mode or in the Graphics Viewer. However, the parent of an element, such as a Symbol instance or a group, and any other associated children (elements), are not affected and will display on the graphic. This is considered the Hide-Rule for data points in a graphic.

The Hide-Rule does not apply to Object References and Link Reference since there are no COV subscriptions involved in these scenarios.

When a data point with an existing address is subscribed for COV’s, the data point’s status and value are updated automatically in the Value Simulator view. If the Status for the data point displays General AccessDenied, this indicates that the data point is inaccessible and therefore not readable for COV subscriptions.
4.1.8 User Settings Overview

Graphics Viewer
The following user settings are automatically saved when you exit out of the Graphics Viewer.
- The Auto zoom selection is maintained.

Graphics Editor
The Graphics Editor allows you to retain your user settings applied to layout, views, and values. Therefore, when you exit and re-enter the application, your settings do not change. User settings are stored in the user’s Windows Temp Folder, `c:\Users\[username]\AppData\Local\Temp`.

If you want to restore your settings to the last saved layout, select the button from the Options tab > Layout group. The Graphics Editor will return to the last saved layout and settings.

The following user settings are automatically saved when you exit the Graphics Editor, and retained when you log on again.
- The location of the Quick Access toolbar and any shortcut items added to it.
- The size, position, and window state (maximized) of the Graphics Editor window.
- The Ribbon status; whether it is maximized or minimized.
- The Dock Panel layout, including size, position of each panel, and if it is docked and where, if it is floating, or set to auto-hide.
- The Library Browser filter and library selections, as well as the magnification setting.
- The Break Lock, Logical Units, and Disable Layer Visibility Range options located on the View tab.
- All selections from the View tab, whether they are visible or not. The only exception is the Aerial View; it is always visible in the dock panel upon opening the Graphics Editor.
- All Value Simulator view settings and selections, except for the Run Value Simulator. If enabled, it returns back to the disabled state when you exit the Graphics Editor.
- The most recent changes made to the Graphic and Graphic Workspace properties are stored, so that the next graphic you create, automatically takes the properties of the previously created graphic.

4.2 Navigation in Graphics

4.2.1 Accessing the Graphics Editor
You can switch between the Graphics Viewer and the Graphics Editor in Operating or Engineering mode.

To Access the Graphics Editor in Operating Mode
▷ You are in the Graphics Viewer, in Operating mode.

1. From the Graphics Viewer toolbar, click Edit.
   - The Graphics Editor opens in Operating mode in the Default tab of the Primary pane.
2. To switch to **Engineering** mode in the **Graphics Editor**, click the [Operating] button.
   - The Graphics Editor switches to **Engineering** and displays in the Graphics pane. The Object Configurator tab also displays.

3. To return to the Graphics Viewer from **Engineering** mode, click the **Edit**.
   - The Graphics Viewer displays in **Engineering** mode, in the Primary pane.

**To Access the Graphics Editor in Engineering Mode**

1. From the Graphics Viewer toolbar, click **Edit**.
   - The Graphics Editor displays in **Engineering** mode in the Graphics tab of the Primary pane. The Object Configurator tab is also displayed.

2. To return to the Graphics Viewer, do one of the following:
   - From the Graphics Editor toolbar, click **Edit**. The Graphics Viewer displays in the Primary pane in **Engineering** mode.
   - Click on the [Engineering] button. The Graphics Viewer displays in the Primary pane in **Operating** mode.

**To Switch Graphics Editor from Operating to Engineering Mode**

- You are in the Graphics Editor in **Operating** mode.

1. Click the [Operating] button.
   - The Graphics Editor switches to **Engineering** and displays in the Graphics pane. The Object Configurator tab also displays.

**To Switch from Graphics Editor Engineering Mode to the Graphics Viewer Engineering Mode**

- You are in the Graphics Editor in **Engineering** mode.

1. Click **Edit**.
   - The Graphics Viewer displays in **Engineering** mode in the Primary pane.

### 4.2.2 Drag-and-Drop Overview

The Graphics application supports the drag-and-drop of nodes and their properties from System Browser, the Graphics Viewer, and the Contextual pane to the canvas and various fields in the Graphics Editor views. After a drag-and-drop, the name and the address of the data point reference display in the target field.

**NOTE:** In order to drag-and-drop a node or object properties to the Graphics Editor, you must have the proper licensing or user access.

**Drag Source**

All object nodes from any of the System Browser applications, regardless of where they exist within the folder’s hierarchy, are **drag sources** that can be dropped on to a receiving field, a **drop target**. In the case of the Graphics Viewer, the properties of any object that has a valid reference to an object, such as a selection reference, expression, or evaluation associated with it, is a valid drag source. These
properties can be dragged over to the Graphics Editor or onto another application pane or view that accepts drag source.

**Drop Target**

All text or field boxes in the Graphics Editor are valid drop targets for the data point reference nodes. Generally, the data point references are dropped into the Expression field of the Evaluation Editor or used in the Animation Symbol for a substitution.

When you drop a node, the full path or hierarchy of the name display in the fieldname, separated with the separator from the hierarchy. For example, "User1:\Campus1\Building1\Floor1".

**Drag Data**

The drag data depends on the type of reference associated with the element or object when the drag was initiated.

- Evaluation – Data point I.D. of all unique referenced objects from all expressions.
- Selection Reference – Data point of the Selection Reference property.
- Symbol – Data point of the Object Reference, the associated object.

**Drag-and-Drop Symbol Instance \ Object Reference Replacement**

You can use drag-and-drop to replace an existing Symbol Instance on a graphic with a data point from System Browser. When you drag a data point from System Browser and hover over one of the Symbol Instance, after a few seconds, the Symbol Instance is automatically selected. Press **SHIFT** and release the mouse button, to replace the Symbol Instance. The Object Reference of the Symbol Instance is also changed. If you do not press **SHIFT**, then a separate and new Symbol Instance is created.

**Drag-and-Drop Multiple Objects from System Browser**

You can drag-and-drop multiple objects from System Browser to the Graphics Editor. When you drag-and-drop multiple objects over, the objects display in the alignment wrapped mode when dropped on the canvas. This means the objects display side-by-side in a row, and wrap to the next row as needed. When you initially drop the objects on the canvas and release the mouse button, the objects remain selected. You can also cascade the objects. Undo the wrap align step by pressing **CTRL+Z** or clicking  from the ribbon, and the objects display in a cascaded format on your canvas.

**Tips on Using Drag-and-Drop**

- When you drag-and-drop a node from the System Browser or the Graphics Viewer to the Graphics Editor, only the name of the data point reference is displays in the Graphics Editor, and not the description, which may be visible in System Browser, depending on the display view.
- While some nodes might belong to a hidden or another hierarchy, the structure should match the System Browser structure.
4.2.2.1 Drag-and-Drop Cursor Image

You can drag any item displayed in the Symbol Browser, Graphics Viewer, and Contextual pane—including a search result—to the Graphics Editor, if you have the application and licensing right to the Graphics Editor. Objects in the Graphics Viewer are always a drag source, and the Graphics Editor is a drag source and drag-target. Both support selecting both single and multiple items. The cursor image changes (see the following table) depending on whether or not the view accepts drops. You can cancel dragging by pressing the ESC key or by moving the cursor outside the boundary of the Graphics Editor window.

<table>
<thead>
<tr>
<th>Cursor Image</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accepts Drop</td>
</tr>
<tr>
<td>Does Not accept Drops</td>
</tr>
</tbody>
</table>

4.2.3 Table of Graphics Drop Targets

Many fields in the Graphics Editor views are valid drag-and-drop targets for normal text from other applications. For example, drag-and-drop text from a word processing application into the Text property field.

You can also drag-and-drop data point references from System Manager, the Graphics Viewer, and the Contextual pane into select fields in the Graphics Editor. The following fields are drop targets for valid data point references:

<table>
<thead>
<tr>
<th>Drop Target Field for Data Point References</th>
<th>View Name</th>
<th>List of Drop Target Fields for Data Point References</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ribbon</td>
<td>Move your cursor anywhere over the ribbon and any associated graphics open and display in the work area.</td>
<td></td>
</tr>
<tr>
<td>Graphic Canvas</td>
<td>Object displays on the canvas.</td>
<td></td>
</tr>
<tr>
<td>Evaluation Editor</td>
<td>Expression</td>
<td></td>
</tr>
<tr>
<td>Find and Replace</td>
<td>Find what, Replace with</td>
<td></td>
</tr>
<tr>
<td>Value Simulator</td>
<td>Object Reference</td>
<td></td>
</tr>
<tr>
<td>Properties</td>
<td>Text Property, Selection Reference, Object Reference (Symbols only), Expression field, Navigation Target</td>
<td></td>
</tr>
</tbody>
</table>

4.3 Overview of Graphics Viewer

The Graphics Viewer is the Graphics component that allows you to display and view graphics in your facility. While viewing your graphics, you can do the following in the Graphics Viewer:

- Increase or decrease them in size
- Pan them
- Scale them to
  - predefined viewports
Graphics

4

Overview of Graphics Viewer

– predefined zoom steps
– full size
– 1:1 resolution
● View them in part or as a whole using the viewport rectangle
● Navigate and filter the view in the primary or secondary work area by depth, layer, and discipline using the Graphic Navigation View
● View them from above using the Aerial View
● Mouse-over elements or objects on the graphic to view tooltip information
● View related properties in the contextual pane
● View changing property values of system objects on a graphic
● View the objects in a camera’s coverage area
● Navigate and display graphics in the Related Items tab related to the selected object in System Browser
● Acknowledge and command objects on a graphic using the Status and Commands window
● Access the Graphics Editor to edit them
● Access the Graphics Editor to create a new graphic

4.3.1 Point Centered Mode

Point Centered mode ensures that a selected data point or group of data points will always be centered in the Graphics Viewer.

For example, you might be required to put a data point in this mode if you are monitoring a fire system in a chemical manufacturing facility with key sensors that must always be viewed. Enabling Point Centered mode in such a scenario ensures that the data point does not blend in with and become lost among surrounding graphics. Or, you might be required to put the Graphics Viewer in this mode, if, for example, you are monitoring a fire system in a pharmaceutical manufacturing facility with key areas that must always be viewed. You can also enable the Group Center mode, to ensure that the parent and all children of the selected point are always selected; therefore, the group(s) of points do not blend in with and become lost among any surrounding graphics. In Group mode, siblings are all data points with the same parent as the selected data point. Those siblings are retrieved from the currently selected view when the selection in the System Browser changes.

This mean that selecting the same data point in different views, for example, Logical or Management View, could return different siblings.

To implement the feature, you select a data point object in System Browser. The System Manager application then opens the Graphics Viewer and loads the point’s default graphic view, depth, and graphic associated with it. You then select the...
Point Centered Mode button from the Graphics Viewer toolbar to center the point in the viewport. The feature is disabled by selecting the button again. While in Point Centered mode, you cannot pan the object. However, you can select any zoom factor without affecting centering in the viewport or you can select another Symbol to shift the focus to another object or Symbol.

4.3.2 Status and Commands Overview
The Status and Commands window displays on a graphic, and allows you to display and change the current state of an object’s properties in your building control system. Access to objects is based upon the object privileges and privilege profiles set for you by your system administrator.

Display of Properties on a Graphic
Properties display on a graphic in one of two ways—automatically or manually.
- They display automatically when a property goes into an off-normal state. The Status and Command window displays the icons associated with the properties in an off-normal state on the graphic. You expand the icon view to display the detailed property information and the command options.
- The Status and Command window(s) display manually when you right-click an object in a graphic that has data points associated with it. You can display multiple Status and Command windows in Graphics.

When a Status and Command window displays on the graphic, a connection line displays between the window and its associated objects on the canvas. The connection line between the Status and Command window and the object(s) remains intact, even when the window is moved around on the canvas.

Properties and commands also display in the Operation and Extended Operation tabs of the Contextual pane for the selected object.
For more information on commanding properties and priority arrays, see Command Priorities and Priority Arrays.

Summary Status
In order to simplify the system display and highlight the most important information, the system sometimes combines properties into a Summary Status property. The Summary Status displays the highest priority status that is currently active for an object. For example, if an object has an active Fire Alarm and Fire Fault, the Fire Alarm displays in the Summary Status.

4.3.3 Viewing Graphic Objects
The Graphics Viewer allows you to display dynamic graphics of your building control system. System Manager is the client application that hosts the Graphics Viewer. Within System Manager, you navigate the various views of System Browser to select the objects you want to display in the Graphics Viewer. System Browser displays only the objects in the system that you have access to, based on your user profile and privileges.

Primary and Secondary Selections
When you select a graphics object from System Browser, the Graphics Viewer displays the representative graphic. The selected object is considered the primary selection. The object properties also display in the Operations/Extended Operations view. The graphic that has the primary selection displays the name of the graphic and the object name according to your Display selection in the System Browser, in the upper, left-hand corner of the primary pane.
Additionally, the properties of the primary selection display in the Operation/Extended Operations, and the Detailed Log tabs. The Related Items tab displays objects related to the currently selected object. Each related item is
assigned a group name that represents the object's type, for example, graphics, trends, reports, or schedules.

If you left-click a Symbol on a graphic or, the referenced object of the Symbol becomes the secondary selection, while the primary selection remains the same in System Browser. The following figure illustrates the primary selection in System Browser, Analog Output 1.

In the Graphics Viewer, the Operations tab in the Contextual pane changes its display to correspond to the new, secondary selection. However, System Browser, still displays the original, primary selection, to show your starting point.
When you select an object from System Browser that is associated with a graphic, the Graphics Viewer displays the representative graphic and the object's associated Symbol on the graphic is selected. As a result, the Operations tab displays the object properties to correspond to the selection.

Double-clicking a Symbol on a graphic makes the referenced object associated with the Symbol the primary selection in System Browser, and all workflows update accordingly.

### 4.3.4 Viewing a Coverage Area

Desigo CC allows you to manually associate objects to one-another. For example, you can associate a fire detector (or any other object type) to a video camera or to a document. Then, whenever the fire detector is selected in the System Browser tree, the related video camera or document displays in the Related Items pane.

The coverage area feature provides a graphical way to achieve the same result. Desigo CC graphics can contain cameras or monitoring devices to which objects, such as fire sensors, ceiling sprinklers, temperature sensors, etc. are associated. For example, you have a graphic of an office space that includes a camera that is monitoring the fire sensors in that room. In this example, the fire sensors monitored by the camera, are in the coverage area of the device.

The coverage area contains the monitored objects. When you move your cursor over the coverage area, a tooltip displays the coverage area's object reference with the total number of monitored objects. If you move your cursor over an object in the coverage area, a tooltip displays the objects name or description. The background color of the coverage area varies depending on how the librarian has configured it to look for your project.

When you initially load a graphic, the Coverage Area of a camera is not visible in the Graphics Viewer. You must toggle the Coverage Area icon from the Graphics Viewer toolbar to view the coverage area of any monitoring device(s) on the graphic.

The **Operation** and **Extended Operation** tabs display the device properties when the coverage area is visible. The **Related Items** tab lists any coverage area's that are associated with the graphic under the heading that is named after the type of...
the monitoring object. For example, if the monitoring object is a camera, the heading displays "Camera" in the Related Items tab.

4.3.5 Zooming and Panning
The Graphics Viewer supports zooming and panning within the active graphic. Zooming allows you to magnify or reduce the graphic image, and panning allows you to move the graphic around on the canvas.

In zooming mode, you can left-click and drag a rubberband rectangle around any area of the graphic. The rectangle represents the area that will be zoomed to full view once you release the mouse button. Pressing the ESC key cancels the rubberband rectangle function.

4.3.6 Graphics Viewer Components
The components that make up the Graphics Viewer consist of a toolbar, two views for navigating the active graphic, keyboard and mouse shortcuts, and tooltips.

4.3.6.1 Graphics Viewer Toolbar
The Graphics Viewer toolbar allows you to navigate to and work with graphic pages displayed in the Graphics Viewer. Use your cursor to select a toolbar button.

<table>
<thead>
<tr>
<th>Graphics Viewer Toolbar Operating Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>Icon</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td><img src="icon.png" alt="Edit" /></td>
</tr>
<tr>
<td><img src="icon.png" alt="Next Related Item" /></td>
</tr>
<tr>
<td>Action</td>
</tr>
<tr>
<td>-----------------</td>
</tr>
<tr>
<td>←</td>
</tr>
<tr>
<td>📈</td>
</tr>
<tr>
<td>📈</td>
</tr>
<tr>
<td>100%</td>
</tr>
<tr>
<td>⏩</td>
</tr>
<tr>
<td>📊</td>
</tr>
<tr>
<td>🎯</td>
</tr>
<tr>
<td>🕰️</td>
</tr>
<tr>
<td>📡</td>
</tr>
<tr>
<td>🌟</td>
</tr>
<tr>
<td>⏤</td>
</tr>
<tr>
<td>⏤</td>
</tr>
</tbody>
</table>
4.3.6.2 Views

The Graphic Viewer provides you with two floating views, the Aerial view and the Graphic Navigation view, to help you navigate the active graphic in either the primary or secondary work area of System Manager. Both views can be resized and toggled to display or not, using the Graphics Viewer toolbar.

Aerial View

The Aerial view provides you with a bird’s-eye view of the active graphic at all times. The viewport rectangle, a rectangular shaped border within the Aerial view, provides a visual representation of the region that has the current focus. You can also draw a viewport rectangle in the area you would like to zoom in on, or click and drag the viewport to move to another location on the graphic.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Viewport Rectangle</td>
</tr>
<tr>
<td></td>
<td>Allows you to view graphics in part or as a whole.</td>
</tr>
</tbody>
</table>

Navigation View

The Graphic Navigation view allows you to customize and navigate through views of the active graphic by selecting a depth and then filtering, by discipline or by layer, which of the associated layers to display. If you choose to filter the layers by discipline, only the layers designated with that discipline display in the graphic view. Otherwise, if you filter on layers only, all the layers of the selected depth display in the Graphic Navigation view, and you can manually choose which layers will be visible in the current view of the graphic.
### Navigation View

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td><strong>Selected Depth</strong>&lt;br&gt;Displays the active depth. Use the drop-down menu to select from a list of available depths.</td>
</tr>
<tr>
<td>2</td>
<td><strong>Filtering</strong>&lt;br&gt;Allows you to select how to filter the layers associated with the selected depth. You can filter the layers by Discipline or by Layers.</td>
</tr>
<tr>
<td>3</td>
<td><strong>Discipline Selection</strong>&lt;br&gt;Displays the discipline used to filter the associated layers with. Use the drop-down menu to choose from a list of available disciplines. The active graphic will only display layers designated with the selected discipline. This section is only active if you have selected to filter the depth by Discipline.</td>
</tr>
<tr>
<td>4</td>
<td><strong>Layer Selection</strong>&lt;br&gt;Displays the list of available layers associated with the selected depth. If a layer is checked, the associated layer displays in the current graphic view. If unchecked, the layer does not display. This section is only active if you have selected to filter the selected depth of the graphic by Layer.</td>
</tr>
</tbody>
</table>

#### 4.3.6.3 About the Status and Commands Window

**Overview of the Window**

In Graphics, the Status and Command window is a floating view that displays an object's properties, current status, and command buttons in the following two scenarios.

- Automatically, in the Graphics Viewer when an object associated with the open graphic has a property in an off-normal state. The Status and Commands window displays in the collapsed, icon view over the associated object. To expand the view of the window, click the vertical expander on the side of the window.
● Manually, when you move the pointer over an object on a graphic and then right-click it and select **Show Status and Commands**.

**Connection Point and Lines**
The Status and Command window is a floating view that displays over an object on the canvas, and can be moved around in the Graphic Viewer. The Status and Command window displays a connection line to its associated object(s) on the canvas. The connection point of the connection line, anchors itself in the following manner:

- **Non-engineered elements** – The connection point aligns itself to the center of the element.
- **Symbols** – The connection point aligns itself to the center of the first element in the Symbol, according to the element tree.
- **Customized Connection Point** – You can create a connection point location by drawing an Ellipse where you want to anchor the connection point for the Symbol. In the Ellipse Descriptor field, you can enter text stating it is an **Anchor for the Connection Point**. To hide the Ellipse from view, either cover it up by another element (preferred method) or disable the **Visible** property for the element in the Property Tree. In both cases, make sure that the Ellipse is the first element in the Symbols element tree in the Element View.

For graphics and graphic templates only, you can specify the maximum number of connection lines to display. The default value of **65535** is used when the property **Graphics > Max Connection Lines** is left blank, in which case under normal circumstances all lines display with the Status and Commands window. If the actual number of connection lines associated with a Status and Command window exceeds the number of connection lines specified in this property, then none of the lines display.

**Drag-and-Drop**
The Status and Commands window is a drag source for data point properties. When the Status and Command window is expanded, you can drag a data point or one of its properties from the window to any of the drop targets in the Graphics Editor or other applications. You cannot drag-and-drop virtual data point properties, such as those properties that display **No Properties** or **Not Available**.

- **Evaluation Editor**: When you drop a data point property in the Expression field of the Graphic Editor’s Evaluation Editor, the current value of the property displays in the Result field for the element’s property.
- **Ribbon**: When you drop a data point property onto the ribbon, all the graphics associated with that data point display as tabbed graphics in the work area.
- **Graphic Canvas**: When you drop a data point property onto the canvas, the associated data point Symbol displays on the graphic.

For a list of the drop sources in the Graphics Editor, see the Table of Graphics Drop Targets [⇒ 48].
### 4.3.6.4 Status and Command Window

The Status and Commands window displays the following information about an object, its properties, and its status.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Icon</td>
</tr>
<tr>
<td></td>
<td>Displays the icon associated with the property type.</td>
</tr>
<tr>
<td>2</td>
<td>Object Path and Object Name</td>
</tr>
<tr>
<td></td>
<td>The path and the name of the object.</td>
</tr>
<tr>
<td>3</td>
<td>Property Name</td>
</tr>
<tr>
<td></td>
<td>Displays the name of one or more properties associated with the object the selected object(s).</td>
</tr>
<tr>
<td></td>
<td>If you select multiple objects of the same type in the system, the icon next to the property name indicates this with a triangular symbol in the lower right-hand corner. Clicking this symbol expands the table row to show all of the selected objects of the same type that share this property. You can then change all properties for the selected objects at the same time.</td>
</tr>
<tr>
<td>4</td>
<td>Current Value</td>
</tr>
<tr>
<td></td>
<td>Displays the current value of each property.</td>
</tr>
<tr>
<td>5</td>
<td>Argument Area and Progress / Result Area</td>
</tr>
<tr>
<td></td>
<td>When you initiate a command that requires additional arguments, the required argument fields display for you to enter one or more arguments prior to sending the command. You must complete all required arguments before sending the command.</td>
</tr>
<tr>
<td></td>
<td>An argument field that displays a red border around it means that the value for that property is invalid. You will need to enter a valid value before commanding the property.</td>
</tr>
<tr>
<td></td>
<td>● Once you execute a command, displays the progress and then the result of a command once you execute a command. During the command, the Progress / Result field displays Command In Progress, along with information about how many objects have been commanded and how many will be commanded all together. After a command execution is complete, successful commands display Success, Failed commands display the reason the command failed and, if you executed multiple commands, the number of failed commands.</td>
</tr>
<tr>
<td>6</td>
<td>Command Area</td>
</tr>
<tr>
<td></td>
<td>Displays the name of a command that you can initiate. If a command button has a triangle in the lower right-hand corner, the command has multiple buttons or options, and clicking on the triangle then displays the options. Some commands are sent immediately after you initiate them by clicking on the Command button. Others require you to enter arguments before they can be sent. When a command requires arguments (additional fields requiring information to continue with the command), the property row will expand after you click the command button. You then complete the additional fields and click the appropriate button (Send, Command, etc.). Some object properties support grouping of command buttons under a single command button with a drop-down list of your choices. The button you choose from the drop-down list becomes the new commandable button.</td>
</tr>
</tbody>
</table>
The Send button displays only for commands that require additional arguments. Clicking the Send button sends a command after you have entered all required arguments.

Command Types:

**Multiple Option Selection:**

Visual display of associated properties. Each slot represents a property option. If a property is selected, it is shaded, see example above. Moving your cursor over slot allows you to view the property option; clicking on the slot allows you to select the option.

**Expand/Collapse Button**

Allows you to expand, collapse, or close the window:
- Expands the Status and Commands window when icons display off-normal properties.
- Minimizes a Status and Command window so that only the icons of the off-normal properties display.
Closes a Status and Command window completely, if there are no properties in an off-normal state.

**Scrollbar**

Displays when the window has run out of space, and allows you to scroll through the active properties.

---

### 4.3.6.5 Status and Commands Connection Lines

Visibility of the connection line and its connection point are controlled as follows:
- A Connection line and its connection point are only visible if the element is visible.
- An element is only visible when the Layer is visible that contains the element.
- A Layer is only visible if a Depth is visible that contains that particular Layer.
- A Status and Command window is only displayed when there is at least one connection to an element.

### 4.3.6.6 About Tooltips

Tooltips are customizable properties that display as a yellow text box when you mouse-over an element or object on the active graphic. The text box for a tooltip contains descriptive text, the current value of the graphic object, and the name(s) of the associated objects based on the view selected in System Browser.
When you move your cursor over an object or element on the active graphic, an associated tooltip displays.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td><strong>Static Tooltip</strong>&lt;br&gt;Description: Descriptive text entered into the Tooltip property field that is associated with the General category in the Property Viewer.</td>
</tr>
<tr>
<td>2</td>
<td><strong>Dynamic Tooltip</strong>&lt;br&gt;Description: Current tooltip text based on a tooltip evaluation, if any, and the current field values. Evaluations are created in the Evaluation Editor.</td>
</tr>
<tr>
<td>3</td>
<td><strong>Static Link Reference and Link Description</strong>&lt;br&gt;Description: The name and description of the file linked to the element as entered in the Link Reference and Link Description fields from the Commands category in the Property Viewer.</td>
</tr>
<tr>
<td>4</td>
<td><strong>Dynamic Link Reference and Link Description</strong>&lt;br&gt;Description: The name and description of the associated link resulting from any evaluations on the Link Reference and Link Description fields. The text displayed depends on the current field values. Evaluations are created in the Evaluation Editor.</td>
</tr>
<tr>
<td>5</td>
<td><strong>Data point References</strong>&lt;br&gt;Description: The name(s) of the object and the System Browser view the name is based on. One line entry per object.</td>
</tr>
</tbody>
</table>

### 4.3.7 Working with the Graphics Viewer

#### 4.3.7.1 Displaying a Graphic

- You are in the System Browser, Application View, and are in **Operating** mode.

1. From System Browser, select **Application View**.
2. Expand the **Applications** folder. 
   - The list of available applications displays.
3. Expand the **Graphics** folder, and click the graphic you want to view in the **Primary pane**.
   - The selected graphic displays in the Primary pane of the Graphics Viewer.

#### 4.3.7.2 Displaying Properties

- You have an object in the System Browser and you want to display the associated properties.

- You have manually displayed the Status and Commands window for an object on a graphic in the **Primary Pane** or **Secondary Pane**.

- A graphic in the **Primary Pane** or **Secondary Pane** has an object in an off normal state and the associated Status and Commands window has automatically displayed.

- From **System Browser**, the **Primary Pane**, or the **Secondary Pane**, you have selected the object you want to command.

1. From the **Status and Commands** window, navigate the property you want to command. If there are more than four properties displayed in the window, you may have to scroll to locate the property.
The system displays a list of the object’s properties, their current state, value, status, and all commands available to you for this object, based on your system privileges and the configuration settings for the object.

2. Complete the required fields and click on the associated command button that displays the command you want to execute.

Depending on the command type, the command is sent, updated, or acknowledged and the status displays.

3. Observe the status of the command.

### 4.3.7.3 Displaying and Hiding Coverage Area

A graphic is displayed in the Graphics Viewer and you want to display the coverage area for the camera(s) or any monitoring device on the graphic. The coverage area shows the objects on your graphic that are within the viewing or monitoring range of a camera or device.

1. From the Graphics Viewer toolbar, click Coverage Area.

All configured coverage area’s on the graphic display.

2. To view the data points from all the objects in the coverage area that are monitored by the camera or device, move your cursor over the coverage area.

The tooltip displays a list of monitored objects.

3. To hide the coverage area, click Coverage Area.

The coverage area is toggled to hide the coverage area from displaying on the graphic.

### 4.3.7.4 Commanding Properties in Graphics Viewer

You have a graphic open in Graphics Viewer, and you want to command the properties of an object in the graphic.

1. Right-click the object, and select Status and Commands.

The system displays a list of the object’s properties, their current state, value, status, and all commands available to you for this object, based on your system privileges and the configuration settings for the object.

If you select multiple properties to command, the selected properties display an icon with a triangular symbol in the lower right-hand corner.

2. If you selected multiple properties in the step above, click the triangular symbol on the icon next to the property you want to command. Otherwise, proceed to Step 3.

The table row of the proper expands to show multiple instances of the property—one for each of the objects selected.

3. Click the command button that displays the command you want to execute.

If the command does not have arguments associated with it, the command is sent and the status displays.

If the command button has arguments associated with it, proceed to Step 4.

4. Complete the required fields if any are associated with the command.

5. Click Send.

The system displays the status of the command.
4.3.7.5 Commanding Off-Normal Properties

You have a graphic open in Graphics Viewer, and one or more objects have properties in an off-normal state. The system has displayed the objects and the icons of the properties that are in an off-normal state. You want to view or command these off-normal properties.

1. Navigate to the Status and Command window associated with the object you want to command.

2. Click **Expander** to display the list of property information for the object.
   - The system displays a list of the object’s properties, their current state, and all commands available to you for this object, based on your system privileges.

3. Click the command button that displays the command you want to execute.
   - If the command does not have arguments associated with it, the command is sent and the status displays.
   - If the command button has arguments associated with it, proceed to Step 4.

4. Complete the required fields.

5. Click **Send**.
   - The system displays the status of the command.

4.3.7.6 Navigating to a Linked Element

If configured, an element on a graphic can be used as direct navigation to an internal or external link.

You have an element on a graphic that if selected links you to an internal or external link.

1. **(Optional)** Move your cursor over the element to display the tooltip and view the linked path and descriptive text, if any, about the linked element.

2. Either single click or double click the element.
   - If the link is an internal Desigo CC link, the linked item becomes the primary selection and displays in either the primary or secondary pane.
   - If the link is external, the document, website, or application opens and displays.

4.3.7.7 Enabling Point Centered Mode

You have a graphic open and would like to place a point object in Point Centered Mode.

1. Select the point object.

2. Click **Point Centered Mode**.
   - The Point Centered mode context menu displays. The default mode is set to **None**.

3. Click one of the following options:
   - **Point** – Point Centered Mode is enabled for the point object to display in the center of the pane or canvas.
Group – Point Centered Mode is enabled for point objects to display in the center of the pane or canvas.

A checkmark displays next to the selected mode and the Point Centered mode is set on the canvas.

4.3.7.8 Disabling Point Centered Mode

- Point Centered Mode is enabled, and you want to disable it.
  1. From the Graphics Viewer toolbar, click Point Centered Mode.
  2. Select None.

Point Centered mode is disabled.

4.3.7.9 Working with the Aerial View

- You have a graphic open and would like to display the Aerial View on the canvas.
  1. From the Graphics Toolbar, click on the Aerial View icon.
     - The Aerial View displays in the primary pane.
  2. Within the Aerial View, do one of the following:
     - Click on a specific area – the graphic view is now adjusted so that the clicked area is the center.
     - Click and drag the mouse - to draw a rectangle around the specific area of the graphic you want to have the focus.

The graphic is resized and refocused around the area you clicked or drew.

4.3.7.10 Using the Depths Navigation View

- You have a graphic open in the Primary pane of the Graphics Viewer. You want to view a specific depth associated with the graphic, and, optionally, filter the view of the depth by its associated layers.
  1. From the Graphics Viewer toolbar, select DepthsNavigation View.
  2. From the depth selection drop-down menu, select the depth you want to view.
     - The graphic and the Navigation View display a list of <All> layers associated with the depth.
  3. Optional. Select the Discipline radial button, and from the drop-down menu select a discipline, or select <All> to view all layers.
     - The graphic updates and only displays the layers associated with the selected discipline.
     - The list of layers in the Navigation View is grayed-out, and only the layers associated with the selected depth are check-marked.
  4. Optional. Select the Layers radial button, and from the list of layers check-mark each layer you want to include in the graphic view, or uncheck a layer to remove it from view. As you make your selections the graphic view is automatically updated.
The graphic is updated to display the depth and layers as selected.

4.3.7.11 Zooming in the Graphics Viewer

A zoom factor of a graphic can be changed using one of the following methods from the Graphics Viewer toolbar:

- You have a graphic open.

- From the Graphics Viewer toolbar in the primary pane, you have the following zoom options available to you:
  - Click **Default View** to display the active graphic at 100% magnification.
  - Click **Scale to Fit** so that the entire graphic and all the objects on the graphic are visible.
  - Click **Zoom In (+20)** or **Zoom Out (-20)** to zoom in or out, accordingly, by a factor of 20% with each click of the icon.
  - Click **Zoom View**, and from the **Zoom View** pane, click and drag the **Zoom Slider** to either increase or decrease magnification of the active element(s).
  - Click **Zoom** to select from a list of pre-defined zoom factors.
  - Click **Zoom Real** to zoom in and out, using your mouse wheel.

4.3.7.12 Selecting Objects within Graphics Viewer

- You have a graphic open, and you would like to view the properties of an object on the graphic.

- Do one of the following:
  - Click and drag until the object is enclosed in the rubber band, and then release the mouse button. You can also select multiple objects by enclosing more than one object in the rubber band.
  - Click directly on the object. You can also select multiple objects by holding down the CTRL key while clicking on more than one object.

The object becomes the focus, and the object properties display in Property Viewer.

**NOTE:** When you select a graphics object from System Browser, the Graphics Viewer displays the representative graphic. The selected object is considered the primary selection. The object also displays in the Property Viewer.

If you click on another object in the graphic, that object becomes the secondary selection. As a result, Property Viewer changes its display to correspond to the new selection. System Browser, however, still displays the original, primary selection to show your starting point.
Double-clicking another object on the graphic makes that object the new primary selection in the Graphics Viewer and System Browser, while the object remains the secondary selection in the Property Viewer.

### 4.3.7.13 Dragging Object Properties from the Graphics Viewer

Referenced properties of an object or Symbol on a graphic in the Graphics Viewer can easily be dragged over to another graphic in the Graphics Editor, the Contextual Pane, or any other view or pane in that accepts a drag source.

**NOTE:** To select multiple objects, nodes, or properties, click **CTRL** and then click each item you want to drag over to the Graphics Editor.

- A graphic is displayed in the Graphics Viewer.
- If you are dragging an object or Symbol to the Graphics Editor, you must have another System Manager pane open. See, Launching a New System Manager [→ 78].

1. Hover over an element or Symbol in the Graphics Viewer. A red border displays around the highlighted object.
2. Click the **LEFT** mouse button and drag.
   - The cursor changes to 
3. Release the **LEFT** mouse button when the cursor changes to over the intended drop target.
   - The data from the object is copied to the area or field.

### 4.3.7.14 Selecting Objects from System Browser

1. From **System Browser**, navigate to the graphic object you want to view.
2. Click the graphic object.
   - Graphics Viewer displays the graphic object. Associated properties display in Property Viewer. Related links display in Related Items. To select objects within Graphics Viewer, see Selecting Objects within Graphics Viewer [→ 64].

### 4.3.7.15 Printing from the Graphics Viewer

- You are in the Graphics Viewer, in Operating mode, and have a graphic displayed in the primary or secondary pane that you want to print.

  - You can do a quick print using the current printer settings or you can configure the print settings prior to printing. Do one of the following:
    - To print using the current print settings - From the Graphics Viewer toolbar, click the **Print** icon. The Print dialog box displays. Select **Print**.
    - To configure the print settings before printing - From the Graphics Viewer toolbar, click on the **Page Setup** icon. The Page Setup window displays. Configure the settings as necessary. For more information, see Page Setup View. From Page Setup, click **Print**, when you are done.
  - The graphic is printed as configured.
### 4.3.7.16 Deleting a Graphic Item
You want to delete a graphic item, a graphic or a folder, from the Graphics folder. You can only delete an empty folder, you cannot delete a folder that contains any graphical objects.

- You are in Engineering mode and the Graphics Editor is displayed.

1. In System Browser, select **Application View**.
2. Expand the **Applications** folder.
   - The list of available applications display.
3. Expand the **Graphics** folder.
4. Navigate to and click the graphic or graphic folder you want to delete.
5. From the **Graphics Viewer** toolbar, click **Delete**.
   - The Delete icon is now active and the System Manager dialog box displays.
6. Click **Yes** to confirm you want to delete the listed graphic item.
   - The graphic item is deleted and removed from System Browser.

### 4.3.7.17 Navigating to the Graphics Library Browser from System Browser
You can view the Graphics Library Browser in the primary or secondary pane from System Browser in Operating Mode.

1. In System Browser, navigate to the **Management View > Project > System Settings > Libraries**.
2. Navigate to and click on any of your graphic Symbol folders.
   - The Graphics Library Browser displays in the Primary pane.

### 4.3.7.18 Creating a Graphic

- You are in **System Browser > Application View** and **Graphics** is selected, or one of the sub-graphic components, and the Graphics Viewer is displayed in the Primary or Secondary pane. **NOTE:** In order to create a graphic, you must have the appropriate access rights to the Graphics Editor application.

1. In **System Browser**, select **Application View**, and then **Graphics**.
2. In the Graphics Viewer, click the **Operating** button to switch to **Engineering** mode.
3. Do one of the following:
   - From the **Graphics** toolbar, click **CreateNew** and select **New Template Graphic**.
   - From the **Application** button menu, click **New Graphic**.
     A blank, tabbed graphic template displays in the Graphics Editor work area.
4. Create and design the graphic as necessary.
5. From the **Graphics** toolbar, click **Save As**.  
   - The **Save As** dialog box displays.

6. Do one of the following:
   - **Saving a Graphic** - Select the **Graphics** folder where you want to save the graphic. In the **Name** field, type a name for your graphic and click **Save**. The graphic is saved to **GMSProjects > [Name of Your Project] > Graphics** folder or sub-folder you may have selected. The graphic is saved in both a .CCG and a .PNG file format. The graphic is also listed in System Browser under **Graphics**.
   - **Saving a Graphic Template** - Navigate to the **Libraries** folder that contains the Graphics Template folder where you want to save the graphic template. In the **Name** field, type a name for your graphic template and click **Save**. The template is saved in a CCT and .PNG file format.

### 4.3.7.19 Creating a Graphics Sub-Folder

You want to create a Graphics sub-folder in System Browser and in your project's Graphics folder.

- You are in **Engineering** mode and the **Graphics Editor** is displayed in the **Graphics** tab of the work area.

1. To select the location of the new graphics folder, in **System Browser**, in the **Applications View**, click **Graphics** or a sub-folder, if one exists.

2. From the Graphics Editor toolbar, click **Create New**.  
   - The Create New context menu displays.

3. Click **New Folder**.  
   - The Create New Folder dialog box displays.

4. In the **Create New Folder** field, type a name for the new folder.

5. Click **OK**.  
   - The folder is created and displayed in the **Graphics** folder in System Browser.

### 4.3.7.20 Editing a Graphic

You want to edit an existing graphic. You have a graphic open in the primary pane.

1. From the Graphics toolbar, click **Edit**.  
   - The **Graphics Editor** opens and displays in the **Work Area**

2. Make modifications to the graphic as needed.

3. From the Graphics Toolbar, click **Save As**.  
   - The Save As dialog box displays.

4. Navigate to the appropriate folder where you want to save your graphic and type the new graphic **File Name** and from the **Save as Type** field, select the appropriate file type.

5. Click **Save**.  
   - The graphic is saved.
4.3.8 Graphics Viewer Appendix

You can use a set of keyboard and mouse button-wheel shortcuts to view the active graphic in the Graphics Viewer.

Before applying any of the shortcuts to a graphic, be sure the appropriate graphic is active by clicking on it.

4.3.8.1 Keyboard Shortcuts

Below is a list of available keyboard shortcuts you can apply to the active graphic or one of its children. A graphic is made active by clicking on the graphic in the primary or secondary pane.

<table>
<thead>
<tr>
<th>Press...</th>
<th>To ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+A</td>
<td>Select all elements</td>
</tr>
<tr>
<td>HOME</td>
<td>Scroll to the left</td>
</tr>
<tr>
<td>END</td>
<td>Scroll to the right</td>
</tr>
<tr>
<td>CTRL+HOME</td>
<td>Scroll to the top</td>
</tr>
<tr>
<td>CTRL+END</td>
<td>Scroll to the bottom</td>
</tr>
<tr>
<td>PAGE UP</td>
<td>Scroll up</td>
</tr>
<tr>
<td>PAGE DOWN</td>
<td>Scroll down</td>
</tr>
<tr>
<td>UP, LEFT, DOWN, RIGHT ARROWS</td>
<td>If not in panning mode: Move selected elements by 1 pixel. If in panning mode: Pan the view by 1 pixel. If modifying a line/polyline node: Move the node by 1 pixel.</td>
</tr>
<tr>
<td>CTRL+UP, CTRL+LEFT, CTRL+DOWN, CTRL+RIGHT ARROWS</td>
<td>If not in panning mode: Move selected elements by the grid pixels. If in panning mode: Pan the view by the grid pixels. If modifying a line/polyline node: Move the node by the grid pixels.</td>
</tr>
<tr>
<td>CTRL+0</td>
<td>Zoom = 100%</td>
</tr>
<tr>
<td>SPACEBAR</td>
<td>Activate quick panning mode. The previous tool mode is restored when the key is released.</td>
</tr>
<tr>
<td>MINUS SIGN</td>
<td>Zoom out (-20%)</td>
</tr>
<tr>
<td>PLUS SIGN</td>
<td>Zoom In (+20%)</td>
</tr>
<tr>
<td>Z-key</td>
<td>Activates quick zoom mode. Cursor changes to the magnifying glass and allows you to draw a viewport directly on the active graphic. The previous tool mode is restored when the key is released.</td>
</tr>
<tr>
<td>F5</td>
<td>Refresh. All views are refreshed. All open graphics are reloaded.</td>
</tr>
<tr>
<td>F12</td>
<td>Toggle the Aerial View On/Off</td>
</tr>
</tbody>
</table>
4.3.8.2 Mouse Functions

The following mouse functions are available in the active graphic once you have activated Zoom mode, either by clicking one of the zoom buttons on the toolbar or by pressing the Z-Key.

<table>
<thead>
<tr>
<th>Click...</th>
<th>To ...</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL +MOUSE WHEEL</td>
<td>Zoom in and out (+ or - 20%)</td>
</tr>
<tr>
<td>LEFT MOUSE BUTTON</td>
<td>Zoom in (+20%)</td>
</tr>
<tr>
<td>RIGHT MOUSE BUTTON</td>
<td>Zoom out (-20%)</td>
</tr>
</tbody>
</table>
5 Alarm Management

Alarm management (also called alarm handling) refers to the various actions and steps that you take to respond when an alarm (also called an event) occurs in the building control system. Such actions may include, for example, acknowledging the alarm, investigating its cause, resetting the alarm once the problem has been resolved, and filling out a report form.

The system displays all the detected alarms in the Event List window, with each alarm on a separate row (called the event descriptor), and this is your main starting point for dealing with alarms. In addition:

- The Summary bar along the top of the screen provides an overview of the alarms in the system grouped by category.
- In some configurations, the one or two most important alarms are also displayed in an Event Detail bar underneath the Summary bar.

To handle an alarm, you can:

- Click on an event descriptor to access Fast Treatment: this lets you directly view details of the alarm, and issue commands to handle the alarm, without leaving the window currently displayed on the screen.
- Click or double-click (depending on configuration) on an event button to access:
  - Investigative Treatment: Opens a new multi-pane window (similar to System Manager) with the alarm in question displayed along the top, and the object that caused the alarm already selected in the Selection pane. This helps you navigate to and investigate the source of the alarm. And you can still do Fast Treatment (directly send commands) from where the alarm is displayed at the top of the screen.
  - Assisted Treatment: Opens a dedicated window, with the alarm in question displayed along the top, that provides a fully guided step-by-step procedure for handling the alarm. You then follow this procedure, checking off each step as it is completed. You can also still do Fast Treatment (directly send commands) from where the alarm is displayed at the top of the screen.

(Assisted Treatment will only open if there is an operating procedure configured for that particular alarm. If there is no such procedure, Investigative Treatment will open instead.)

The system records a full history of each alarm that occurs, and its resolution. You can also generate event-related reports and view, save, or print them.

Alarm Handling and Client Profiles

The Client Profile is a configuration that can be applied to an individual user or station. The selected Client Profile determines the appearance and behavior of the Summary bar, Event List, and other system functions involved in handling alarms.

The following sections present details only about the basic Client Profiles. For details on Client Profiles extension, see Section Appendix A: Client Profiles Extensions.

NOTE:
For details about the configuration of Client Profiles, see the Engineering Manual (A6V10415473).
5.1 **Overview of Summary Bar**

The Summary bar is located along the top of the system screen, and is your main point of entry to all the functions of the management system.

On the left, it has a series of event lamps that provide an overview of the alarms in the system grouped by category. On the right, it has the operator menu, a system integrity indicator, and buttons for starting multiple System Manager windows, opening/closing Event List, filtering alarms, and controlling the audio alert.

The ability to expand/collapse the Summary bar, the specific set of event lamps that it displays, opening/closing Event List, and controlling the audio alert are dependent on configuration.

The Summary bar enables you to:
- View the overall events detected by the system (when available)
- Filter events
- Manage the audio alert
- Access general system functions (from the Summary bar and system menu)

5.1.1 **Summary Bar Workspace**

The Summary bar displays along the top of the screen. Depending on the Client Profile, the Summary bar:
- May or may not be expanded/collapsed
- Contains a specific set of event lamps that summarize the alarms in the system.

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>[Company] logo</td>
<td>Opens the About page which displays information about the Desigo CC software.</td>
</tr>
<tr>
<td>2</td>
<td>Event lamps</td>
<td>Summarize the alarms in the system, grouped by categories. You can click an event lamp, to open Event List filtered by that category. The number of lamps and their corresponding categories depends on the Client Profile.</td>
</tr>
<tr>
<td>3</td>
<td>Client name</td>
<td>Displays the name of the Installed Client. It also provides a tooltip with the same information. <strong>NOTE:</strong> If you are using a Web Client, the client name does not display.</td>
</tr>
<tr>
<td>4</td>
<td>Logged user</td>
<td>Displays the full name of the person logged onto the system. It also provides a tooltip with the user's most important information (for example, full name, account name, language, and so on). If the user's full name is not available, user name displays instead.</td>
</tr>
<tr>
<td>5</td>
<td>Date</td>
<td>Displays: System date</td>
</tr>
</tbody>
</table>
### License Mode

When Desigo CC client application is running normally, with a valid and sufficient license available on the server, you will not see any special indication on the user interface.

Otherwise, the Summary bar changes color and displays a message to indicate the following special situations, along with the time remaining (days, hours, minutes, or seconds) that you can continue running the Desigo CC client application.

- **Demo Mode (green):** There is no valid license available on the server. You can run the Desigo CC client application continuously for only 30 minutes.
- **Courtesy Mode (orange):** The license on the server is valid but insufficient. You can run the Desigo CC client application continuously for only 30 days.
- **Engineering Mode (blue):** The Desigo CC client is running, for a limited duration, with a special license used by authorized technicians to set up and configure the system.

For more information, see Licensing [→ 376].

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>6</strong></td>
<td><strong>Time</strong></td>
</tr>
<tr>
<td></td>
<td>Displays:</td>
</tr>
<tr>
<td></td>
<td>• System time</td>
</tr>
<tr>
<td></td>
<td>• Windows calendar when clicked.</td>
</tr>
<tr>
<td><strong>7</strong></td>
<td><strong>Menu [→ 75]</strong></td>
</tr>
<tr>
<td></td>
<td>Accesses other functions.</td>
</tr>
<tr>
<td><strong>8</strong></td>
<td><strong>System integrity indicator [→ 76]</strong></td>
</tr>
<tr>
<td></td>
<td>Displays the status of the network connection to the Desigo CC server.</td>
</tr>
<tr>
<td><strong>9</strong></td>
<td><strong>Expand/collapse Summary Bar</strong></td>
</tr>
<tr>
<td></td>
<td>Expands/collapses [→ 77] the Summary bar. Depending on the Client Profile [→ 76], this icon may not be available to you. In such a case, you cannot hide the event lamps in the Summary bar.</td>
</tr>
<tr>
<td><strong>10</strong></td>
<td><strong>Filter events [→ 92]</strong></td>
</tr>
<tr>
<td></td>
<td>Opens the filter menu [→ 92] to access the functions for filtering events before alarm handling.</td>
</tr>
<tr>
<td><strong>11</strong></td>
<td><strong>Open/close Event List</strong></td>
</tr>
<tr>
<td></td>
<td>Depending on the Client Profile [→ 76], it allows you to show/hide [→ 88] or expand/collapse [→ 89] Event List. This icon is disabled during Investigative/Assisted Treatment.</td>
</tr>
<tr>
<td><strong>12</strong></td>
<td><strong>Start a new System Manager window</strong></td>
</tr>
<tr>
<td></td>
<td>Allows you to open multiple System Manager windows.</td>
</tr>
<tr>
<td><strong>13</strong></td>
<td><strong>Audio Alert [→ 74]</strong></td>
</tr>
<tr>
<td></td>
<td>Allows you to mute/un-mute [→ 78] the sound emitted by the station to notify you of alarms. Depending on the Client Profile [→ 76], you can also disable/enable [→ 79] this sound.</td>
</tr>
<tr>
<td><strong>14</strong></td>
<td><strong>Show/hide Event Detail Bar</strong></td>
</tr>
<tr>
<td></td>
<td>Allows you to show/hide [→ 78] the Event Detail bar. Depending on the Client Profile [→ 76], this feature may not be available to you.</td>
</tr>
</tbody>
</table>
5.1.1.1 Event Lamp

The alarms that occur in the building-control system are grouped into categories [99], which are color-coded by severity. Each category typically corresponds to an event lamp that displays in the Summary bar.

Each event lamp shows the total number of alarms for that category, and how many of those are unprocessed (not yet acknowledged by the operator). An event lamp will also flash if there are any unprocessed alarms in its category.

NOTE:
The number of lamps and their corresponding categories depends on the Client Profile [76].

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Background color</td>
<td>Indicates the category color of the event.</td>
</tr>
<tr>
<td>2</td>
<td>Event counter</td>
<td>Shows the total number of alarms for that category present in Event List (second number), and how many of those are unprocessed (first number).</td>
</tr>
<tr>
<td>3</td>
<td>Event category</td>
<td>Descriptive name of the category (for example, Life Safety, Fault, and so on).</td>
</tr>
</tbody>
</table>

### Event Lamp Display

<table>
<thead>
<tr>
<th>Graphical Display</th>
<th>Background Color and Behavior</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Life Safety</td>
<td>Solid gray.</td>
<td>No events for that category.</td>
</tr>
<tr>
<td>3/7 Life Safety</td>
<td>Flashes from gray to the category color.</td>
<td>New events for that category have occurred in the system, and are still unprocessed.</td>
</tr>
<tr>
<td>3/7 Life Safety</td>
<td>Flashes from gray to the dark category color.</td>
<td>Filter by category activated. New events for that category have occurred in the system, and are still unprocessed.</td>
</tr>
<tr>
<td>0/7 Life Safety</td>
<td>Solid category color and not flashing.</td>
<td>There are no unprocessed events for that category.</td>
</tr>
</tbody>
</table>
**NOTE:** In Client Profiles where recurring events are grouped under an event container, the event lamp stops flashing when there are no unprocessed events in the event container.

<table>
<thead>
<tr>
<th>Category</th>
<th>Appearance</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Life Safety</td>
<td>Solid dark category color and not flashing.</td>
<td>Filter by category activated. There are no unprocessed events for that category.</td>
</tr>
</tbody>
</table>

When you move the cursor over an event lamp, a tooltip provides the following information:
- Total number of events for this category
- Number of unprocessed (unacknowledged) events for this category
- Number of events for this category that have been acknowledged

### 5.1.1.2 Audio Alert

The audio alert is the sound emitted by a client station to notify the operator of alarms in the building control system. (If a site has multiple client stations, each one will emit its own audio alert.)

When a new alarm occurs, the client station emits an audio alert that continues for as long as that alarm remains unprocessed (that is, unacknowledged by the operator). If there are multiple incoming alarms, the audio alert continues to sound for as long as any of them remain unprocessed.

The audio alert ceases when the incoming alarms have been acknowledged. It will resume after 24 hours if a previously-acknowledged alarm has still not been fully processed (closed) by then.

**Mute Audio Alert**

The operator can also temporarily mute the audio alert on a client station by left-clicking the icon in the Summary bar. This will cause the audio alert to cease even if there are still unprocessed alarms. (Muting applies only to the pre-existing alarms: the audio alert will still sound for any new alarms that come in).

The muted state lasts for at most 24 hours: after that time, the audio alert will start up again, unless all the alarms have been fully processed (closed).

The operator can manually unmute the audio alert at any time by left-clicking its icon again.

**Disable Audio Alert**

In some Client Profiles, the operator can also completely disable (permanently turn off) the audio alert by right-clicking its icon in the Summary bar. In this case, the audio alert will not sound, even for new alarms that come in. The operator can re-enable the audio alert at any time by right-clicking its icon again.

An icon on the Summary bar indicates the status of the audio alert. A tooltip displays when you move the cursor over the icon, and provides information on what you're allowed to do.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Appearance</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Active" /></td>
<td>Active</td>
<td>The system has detected a new alarm, or there are still alarms in the unprocessed state. You can mute or disable the audio alert.</td>
</tr>
</tbody>
</table>
### Muted
You temporarily muted the audio alert. After 24 hours the system will automatically re-activate the sound (audio alert reminder).

### Disabled
You disabled the audio alert. This means it is permanently silenced, and the system will not emit any sound when new alarms occur. Depending on the Client Profile [76], this function may not be available to you.

### Darkened
Hovering effect on icon.

### Audio Alert Sound
The specific audio alert sound can vary depending on the type of alarm and is configuration-dependent. In case of multiple alarms, the audio alert sound will be the one for the most important (severe) event, irrespective of any filters or sorting you may have applied to Event List.

### 5.1.1.3 Menu
The Menu located on the Summary bar, allows you to perform several operations.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help [383]</td>
<td>Launches inline Help.</td>
</tr>
<tr>
<td>User Documentation [384]</td>
<td>Open a sub-menu to select one of the available user documentation PDF files:</td>
</tr>
<tr>
<td></td>
<td>- Engineering Manual</td>
</tr>
<tr>
<td></td>
<td>- Getting Started</td>
</tr>
<tr>
<td></td>
<td>- Graphics Editor</td>
</tr>
<tr>
<td></td>
<td>- Installing the Web Client Application Certificate</td>
</tr>
<tr>
<td></td>
<td>- OPC Server Manual</td>
</tr>
<tr>
<td></td>
<td>- OPC Integration Guide</td>
</tr>
<tr>
<td></td>
<td>- User Guide</td>
</tr>
<tr>
<td>NOTE: The list of documents</td>
<td>will also include Operation and Engineering guides for any extension module.</td>
</tr>
<tr>
<td></td>
<td>installed.</td>
</tr>
<tr>
<td>Applications [78]</td>
<td>Opens a new System Manager.</td>
</tr>
<tr>
<td>Operator</td>
<td>Performs the following tasks:</td>
</tr>
<tr>
<td></td>
<td>- Switchover [79]: Change users</td>
</tr>
<tr>
<td></td>
<td>- Change User password [79]: Change your password</td>
</tr>
<tr>
<td>NOTE: This option is not</td>
<td>available if you are logged on as Windows user.</td>
</tr>
</tbody>
</table>
|                               | About Page [79]                                                             |"
5.1.1.4 **System Integrity Indicator**

The system integrity indicator, located on the Summary bar, indicates the network connection and system status. Its color and animation reflect the connection status, as follows:

<table>
<thead>
<tr>
<th>System Integrity Status</th>
<th>Appearance</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green and animated.</td>
<td>The icon is...</td>
<td>Network connection with the server is active and the system is healthy (that is, server running properly).</td>
</tr>
<tr>
<td>Red and animated.</td>
<td></td>
<td>Network connection with the server is active but at least one system component is not active on the server (that is, server not running properly). <strong>NOTE:</strong> If a client disconnects from the server, this issue is visually indicated on the Summary bar by pink background, and <em>Client Disconnected</em> text in red. An error message displays informing you that the connection to the server has been lost and will be restored when possible.</td>
</tr>
<tr>
<td>Red and not animated.</td>
<td></td>
<td>Network connection with the server is inactive.</td>
</tr>
</tbody>
</table>

A tooltip displays when you move your cursor over the indicator, and provides network connection and system status information.

5.1.2 **Summary Bar and Client Profiles**

The Client Profile in use determines the appearance and behavior of the Summary bar.

**Client Profile FS_EN**
- The Summary bar is always expanded. You cannot collapse it.
- The following event (category) lamps display:
  - Life Safety
  - Danger
  - Fault
  - Exclusion
  - Anomaly
  - Information
- You can:
  - Expand/collapse [→ 89] Event List.
  - Mute/un-mute [→ 78] the audio alert. When muted, after 24 hours, the system will automatically re-activate the sound.

**Client Profiles BA_EN and TBS_EN**
- The Summary bar is expanded. The Event Detail bar and Event List are hidden.
- The following event (category) lamps display:
● Life Safety
● High
● Medium
● Low
● Fault
● Information

● Life Safety
● Danger
● High
● Medium
● Low
● Fault
● Exclusion
● Anomaly
● Information

You can:
– Collapse/expand [➙ 77] the Summary bar (Client Profile TBS_EN only).
– Show/hide [➙ 78] the Event Detail bar.
– Mute/un-mute [➙ 78] the audio alert. When muted, after 24 hours, the system will automatically re-activate the sound.
– Disable/enable [➙ 79] (Client Profile BA_EN only) the audio alert.

5.1.3 Working with the Summary Bar
The following procedures describe common Summary bar operating tasks (some of these are available from the system menu).
See also:
● Working with Event Filters [➙ 94]

5.1.3.1 Collapsing and Expanding the Summary Bar
NOTICE! The following procedures apply only when working in Client Profile TBS_EN.
▷ The Summary bar displays expanded, and the command to collapse it is available.
  ● In the Summary bar, click arrow ▲.
  ▷ The Summary bar collapses.

▷ The Summary bar displays collapsed, and the command to expand it is available.
  ● In the Summary bar, click arrow ▼.
  ▷ The Summary bar expands.
5.1.3.2 Showing and Hiding the Event Detail Bar

NOTICE! The following procedures apply only when working in Client Profiles BA_EN and TBS_EN.

▷ The Event Detail bar is not visible, and the command to show it is available on the Summary bar.
  ● In the Summary bar, click arrow ▾.
  ◀ The Event Detail bar displays below the Summary bar.

▷ The Event Detail bar is visible, and the command to hide it is available on the Summary bar.
  ● In the Summary bar, click arrow ▲.
  ◀ The Event Detail bar is hidden.

5.1.3.3 Launching a New System Manager

▷ The primary System Manager displays on the screen, and you want to open another System Manager window.
  ● In the Summary bar, do one of the following:
    – Click System Manager.
    – Select Menu > Applications > Start new System Manager.
  ◀ Another System Manager window opens. Click Close to close it.

5.1.3.4 Muting and Un-muting the Audio Alert

▷ A new event occurs, and the system emits a sound.
  ▷ You want to mute the audio alert.
  ● In the Summary bar, left-click on Audio Alert.
  ◀ The icon changes to muted and the sound stops (After 24 hours the system will automatically re-activate the sound).

▷ The audio alert is off.
  ▷ You want to reactivate the sound.
  ● In the Summary bar, left-click on Audio Alert.
  ◀ The icon changes to active, and the sound starts again.
5.1.3.5 Disabling and Enabling the Audio Alert

**NOTICE!** The following procedures apply only when working in Client Profile BA_EN.

- One or more unprocessed events are present, and the system is emitting a sound.
- You want to disable the audio alert.
  - In the Summary bar, right-click on *Audio Alert*.
  - The icon changes to disabled and the sound stops. If a new event occurs the system does not emit any audible notification.
- The audio alert is disabled.
- You want to enable the sound.
  - In the Summary bar, right-click on *Audio Alert*.
  - The icon changes to active, and the system will emit a sound when a new event occurs or if there are unprocessed events.

5.1.3.6 Viewing the Help and User Documentation

- To display online Help, see Launching Online Help [→ 383]
- To view user documentation, see Displaying User Documentation [→ 384]

5.1.3.7 Performing a Switchover

See Changing Operators [→ 369].

5.1.3.8 Changing Password

See Changing Your Password [→ 369].

5.1.3.9 Displaying the About Page

See Displaying System Information [→ 375].

5.1.3.10 Printing Data

See System Printing [→ 372].

5.1.3.11 Switching Active Windows

- For example, you have two System Manager windows open. The first window (System Manager) is in the foreground, and the second window (System Manager (2)) in the background. You want the System Manager (2) window in the foreground.

  1. In the Summary bar, select *Menu > Active Tasks*. 
2. From the thumbnail preview of the active windows, select **System Manager (2)**.

   ✗ The System Manager (2) window is now in the foreground.

   **NOTE:** When Help is the active window it always stays in the foreground.

### 5.1.3.12 Ending Your Work Session

In the *Getting Started* document (A6V10415475), see the following:

- *Exiting the System* (if the menu on the Summary Bar contains *Exit*)
- *Logging Off in Closed Mode* (if the menu on the Summary Bar contains *Logoff*)

### 5.2 Overview of Event Detail Bar

**NOTICE!** The Event Detail bar is available only in Client Profiles BA_EN and TBS_EN.

The Event Detail bar is located in a dedicated area just below the Summary bar. It allows you to respond to the most critical event(s), meaning those that meet specific criteria that require immediate attention.

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Summary bar [➙ 71]</td>
<td>Provides an overview of the events in the system.</td>
</tr>
<tr>
<td>2</td>
<td>Event Detail bar</td>
<td>Present in some configurations [➙ 81] only. Highlights one or two events that require immediate attention. Its background color is the same color as that of Event List.</td>
</tr>
<tr>
<td>3</td>
<td>Work area</td>
<td>Large central portion of the screen below the Summary bar and Event Detail bar assigned to other Desigo CC windows (for example, System Manager) or to the operating system desktop (such as Windows desktop) or to external applications (for example, Microsoft Internet Explorer, Microsoft Office programs, and so on).</td>
</tr>
</tbody>
</table>
5.2.1 Event Detail Bar and Client Profiles

The Client Profile in use determines the appearance and behavior of the Event Detail bar.

Client Profile FS_EN
The Event Detail bar is not available.

Client Profiles BA_EN and TBS_EN
  • The Event Detail bar is hidden. You can show/hide it.
  • It contains only one event, that corresponds to the first (most important) event in Event List.

5.3 Overview of Event List

The Event List window is your main starting point for monitoring, viewing, and handling alarms. It displays a list of all the alarms (also called events) detected by the system, with each alarm on a separate row. This row, containing all the details about the alarm, is called the event descriptor.

The event descriptor shows information and details about an alarm, such as its discipline, category, cause, location and source, date and time, available command, and status. On the left of each descriptor, an icon (called the event button) graphically summarizes some information about that alarm.

You can open the Event List window by clicking the open/close Event List icon in the Summary bar. (Event List also opens when you click an event lamp in the Summary bar, an event button in the Event bar, or the expand/collapse Event List icon at the top of the Event bar.)

To handle an alarm, you can left click on its row to send alarm-handling commands directly from the event descriptor. (This facility is called Fast Treatment.) Alternatively, you can click (or, in some client profiles, double-click) on its event button to initiate (depending on configuration) either Investigative Treatment or Assisted Treatment of that alarm.

Alarms remain in Event List until they have been fully processed (all required alarm-handling commands sent, any mandatory procedure steps completed, and the alarm source is back to normal). When an alarm is fully processed, its status becomes closed and you can clear it from Event List.

In some Client Profiles, Event List can be completely hidden when it is not in use. In others, Event List can only be collapsed, leaving the event buttons visible along the left hand side of the screen. This collapsed view of the event list is called the Event bar.

From Event List you can view, handle, and print the alarms that occur in the building control site.

5.3.1 Event List Workspace

Event List displays up to 20 events (depending on monitor resolution), with each one on a separate row. Vertical and horizontal scrollbars become available when there is not enough space on the screen to view all the events (for example, if there are more than 20) or to completely display all the event details.
### Event List Workspace

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Summary bar [→ 71]</td>
<td>Provides an overview of the events in the system.</td>
</tr>
<tr>
<td>2</td>
<td>Event Detail bar [→ 80]</td>
<td>Highlights events that require immediate attention.</td>
</tr>
<tr>
<td>3</td>
<td>Title bar</td>
<td>Depending on what you select, the title bar shows:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Event List, if no event is selected in the list.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Event location, if a single event is selected in the list.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Number of events being processed, if multiple events are selected in the list.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Details of the applied filter, if a filter is applied to the events, and no event is being processed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>It also contains some icons to open/close [→ 117] the Contextual pane (6), lock the layout and, restore down the window (depending on Client Profile [→ 87]).</td>
</tr>
<tr>
<td>4</td>
<td>Event button [→ 83]</td>
<td>Graphic indicator of an event in the system.</td>
</tr>
<tr>
<td>5</td>
<td>Event descriptor [→ 84]</td>
<td>Contains the event button, event details and alarm-handling commands [→ 103] for the event currently being processed.</td>
</tr>
<tr>
<td>6</td>
<td>Contextual pane</td>
<td>Hidden by default. When open, it provides additional information, actions, and resources about the point in alarm. In particular:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Operation/Extended Operation tabs: Lets you inspect all the properties of the point in alarm, and view and execute any commands/actions available for that object. If you selected multiple events, the Contextual pane displays only the properties common to all the events, properties having different values are marked</td>
</tr>
</tbody>
</table>
5.3.1.1 Event Button

An event button is a graphic indicator that displays on the left side of an alarm's event descriptor [➙ 84]. It graphically summarizes some of the most important information about that alarm. The background color of the event button indicates the alarm's category [➙ 99], while the icon indicates its discipline [➙ 100]. The event button also shows the status of the alarm's source [➙ 103], and the suggested next action the operator should take (for example, what command to send next).

An event button flashes until you acknowledge its associated alarm.

In some Client Profiles [➙ 87], when the Event List window is closed the event buttons still remain visible (as an Event bar) on the left-hand side of the screen.

<table>
<thead>
<tr>
<th>Event Button Components</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item</td>
</tr>
<tr>
<td>------</td>
</tr>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Event Button and What It Tells You</th>
</tr>
</thead>
<tbody>
<tr>
<td>Button</td>
</tr>
<tr>
<td>--------</td>
</tr>
<tr>
<td>Unprocessed</td>
</tr>
</tbody>
</table>
### 5.3.1.2 Event Descriptor

The event descriptor is the individual row in Event List, that contains all the details about an alarm (for example, its cause, source, location, date and time, category, discipline, event status, source status, suggested action, available command, and so on). Each event descriptor also has an event button ➤83 on the left-hand side that graphically summarizes some of the most important information about that alarm.

The event descriptor is your starting point for handling an alarm. You can send alarm-handling commands from directly inside the event descriptor by clicking the available command/button.
The exact appearance of the event descriptor depends on the Client Profile [→ 87].

### Event Details

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>- Event button</td>
<td>Event button [→ 83] that graphically summarizes each alarm.</td>
</tr>
<tr>
<td>Cause</td>
<td>Description of the event followed by the condition (either numeric value or descriptive text) that caused the event. For example, <em>Temperature too high (39°C), Fault (INACTIVE)</em>, and so on. This description changes when the event source passes from the Active to the Quiet state.</td>
</tr>
<tr>
<td>Source</td>
<td>Provides information about the field object in alarm, referred to the current System Browser view. For BACnet Event Enrollment (EE) events, the source text includes the EE instance that generated the event followed by the original source in parentheses. Click the source text to check the event source in the current view [→ 115].</td>
</tr>
<tr>
<td>Description</td>
<td>Depending on the System Browser views that are configured, one or more of the following description columns may be available:</td>
</tr>
<tr>
<td>[View]</td>
<td>• Description [Management View]: description of the object in alarm in Management View</td>
</tr>
<tr>
<td></td>
<td>• Description [Application View]: description of the object in alarm in Application View</td>
</tr>
<tr>
<td></td>
<td>• Description [Logical View]: description of the object in alarm in Logical View</td>
</tr>
<tr>
<td></td>
<td>• Description [Physical View]: description of the object in alarm in Physical View</td>
</tr>
<tr>
<td></td>
<td>• Description [user view]: description of the object in alarm in a specific custom-user view</td>
</tr>
<tr>
<td></td>
<td>These description columns are also visible in the Event Detail bar and Investigative/Assisted Treatment windows. However, you can only configure them from Event List. Click the description text to check the event source in the Description view [→ 116].</td>
</tr>
<tr>
<td>Name</td>
<td>Indicates the name of the object. Click the name text to check the event source by its name [→ 116].</td>
</tr>
<tr>
<td>Alias</td>
<td>Indicates a customer-assigned name used to identify the technical equipment within the building/facility. Click the name text to check the event source by its alias [→ 116].</td>
</tr>
<tr>
<td>Commands</td>
<td>Available alarm handling commands [→ 103]. They appear as small icons.</td>
</tr>
<tr>
<td>Information</td>
<td>The following icons become visible only when the event descriptor is selected.</td>
</tr>
<tr>
<td></td>
<td>• : Allows you to display the History Database dialog box for that Event ID, where you can add a note for the event.</td>
</tr>
<tr>
<td><strong>Alarm Management</strong></td>
<td></td>
</tr>
<tr>
<td>----------------------</td>
<td></td>
</tr>
<tr>
<td><strong>Overview of Event List</strong></td>
<td></td>
</tr>
</tbody>
</table>

- **Suggested action [103]**: Describes the next action the operator should take for an event.
- **Date/Time**: Date and time when the event occurred.
- **Location**: Indicates the entire path of the object in alarm in the current System Browser view. For BACnet Event Enrollment (EE) events, it displays the [name of the field networks] + [name of the network] the EE event belongs to. The location text adjusts according to the column size and may appear on multiple lines.
- **Location [View]**: Depending on the System Browser views that are configured, one or more of the following location columns may also be available:
  - Location [Management View]: entire path of the object in alarm in Management View
  - Location [Application View]: entire path of the object in alarm in Application View
  - Location [Logical View]: entire path of the object in alarm in Logical View
  - Location [Physical View]: entire path of the object in alarm in Physical View
  - Location [user view]: entire path of the object in alarm in a specific custom-user view
  - The name of the view is indicated in the path. These location columns are also visible in the Event Detail bar and Investigative/Assisted Treatment windows. However, you can only configure them from Event List.
- **ID**: Unique number that identifies the event. This number has an upper limit. The numbering restarts when this limit is reached.
- **Counter**: Counter of recurring events [124]. This column does not appear in Investigative/Assisted Treatment.
- **Event Status [100]**: Describes the status of the event.
- **Source Status [103]**: Describes the status of the source.
- **Category**: Describes the event category.
- **Discipline**: Describes the discipline to which the event belongs.
- **In Process by**: Indicates which user is processing an event. Depending on the type of Desigo CC client you're working on the following may display:
  - Installed Client: [computer name]/[full name of the logged-on user]
    - If the computer/user data was not specified in the configuration, [localhost]+[user's short name] displays instead.
  - Web Client or Web App Client: Web Client/[Operator's full name].
    - For recurrences of the same event, this column displays the entire list of computer/users that are processing that event.
- **Tag**: Button that allows you to tag/untag [114] events. This button will be visible but inactive in the Event Detail bar, and the Tag column will not appear in Investigative/Assisted Treatment.
5.3.1.3 Customize Columns Dialog Box

The Customize columns dialog box allows you to customize what columns appear in Event List, and change their order. Such changes also apply to the Event Detail bar and the Investigative/Assisted Treatment windows.

![Customize Columns Dialog Box](image)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Available columns</td>
<td>Shows the list of all the available columns for Event List.</td>
</tr>
<tr>
<td>Visible columns</td>
<td>Shows the list of all the columns selected to be visible in Event List.</td>
</tr>
<tr>
<td>Arrow icons</td>
<td>Move items from/to the Available columns and Visible columns.</td>
</tr>
<tr>
<td>Move Up</td>
<td>Move a column up in the list of Visible columns.</td>
</tr>
<tr>
<td>Move Down</td>
<td>Move a column down in the list of Visible columns.</td>
</tr>
<tr>
<td>OK</td>
<td>Save the changes made.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Exit discarding the changes.</td>
</tr>
</tbody>
</table>

5.3.2 Event List and Client Profiles

The Client Profile in use determines the appearance and behavior of Event List.

**Client Profile FS_EN**

- Event List is collapsed to an Event bar on the left side of the screen. The Event bar is always visible and you cannot hide it. When Event List is collapsed, if you move your cursor over an event button, a tooltip appears and displays details of the event.
  - The background color of event descriptors [ług] follows the event category color. Alarm-handling commands are visible but dimmed (inactive) until you select an event. When you select an event:
    - The background color becomes darker
    - Alarm-handling commands become active
- Default event sorting is as follows and you cannot change it:
  - Unprocessed before unreset events
  - Unreset before acknowledged events
5.3.3 Working with Event List

The following procedures describe common Event List operating tasks.

- To learn how to handle events, see Handling Events [→ 111].

5.3.3.1 Showing and Hiding Event List

NOTICE! The following procedures apply only when working in Client Profiles BA_EN and TBS_EN.

- Event List is not visible and you want to display it.
  - In the Summary bar, click **Open/close Event List**.
  - Event List displays in the work area.

- Event List is visible and you want to hide it.
  - Do one of the following:
    - In the Summary bar, click **Open/close Event List**.
– In the Event List header, click **Collapse Event List**.

⇒ Event List is hidden.

### 5.3.3.2 Expanding and Collapsing Event List

**NOTICE**! The following procedures apply only when working in Client Profile FS_EN.

▷ Event List is collapsed to an Event a bar on the left side of the screen, and you want to expand it.

- Do one of the following:
  - In the Summary bar, click **Open/close Event List**.
  - In the Event List header, click **Expand Event List**.

⇒ Event List expands in the work area.

▷ Event List displays expanded, and you want to collapse it.

- Do one of the following:
  - In the Summary bar, click **Open/close Event List**.
  - In the Event List header, click **Collapse Event List**.

⇒ Event List collapses back to an Event bar.

### 5.3.3.3 Resizing the Columns

- In the column headers of Event List, drag the separator next to a column.

⇒ The column is resized.

**Operation Tips**

- You cannot resize the **Event button**, **Commands**, and **Information** columns.
- Any changes you make to the size of columns also apply to the Event Detail bar and the Investigative/Assisted Treatment windows. Such changes will automatically be saved when you exit the Desigo CC client application.

### 5.3.3.4 Changing the Position of the Columns

- In the column headers of Event List, drag-and-drop a column (for example, **Event Cause**) to the desired position.

⇒ The column displays in the new position.

**Operation Tips**

- You cannot move the **Event button** column.
- Any changes you make to the position of the columns also apply to the Event Detail bar and the Investigative/Assisted Treatment windows. Such changes will automatically be saved when you exit the Desigo CC client application.
5.3.3.5 **Customizing the Columns Display**

▷ You want to customize how the columns display in Event List. For example, add the *Location* column and remove the *Cause* column.

1. Right-click on the column headers of Event List, and select **Customize columns**.
   ➔ The *Customize columns* dialog box displays.

2. In the *Available columns* configuration box, select the name of the column you want to add.

3. Do one of the following:
   - Double-click the selected column name.
   - Click the **add arrow** button.
   ➔ The selected column name disappears from the *Available columns* configuration box, and appears in the *Visible columns* configuration box.

4. In the *Visible columns* configuration box, select the name of the column you want to remove.

5. Do one of the following:
   - Double-click the selected column name.
   - Click the **remove arrow** button.
   ➔ The selected column name disappears from the *Visible columns* configuration box, and appears in the *Available columns* configuration box.

6. *(Optional)* In the *Visible columns* configuration box, select a column name, and click **Move up** or **Move down** to change the order of the visible columns in Event List.

7. Click **OK**.
   ➔ Event List appears with the custom columns display.

**Operation Tips**

- You cannot remove the *Event button* and *Commands* columns.
- Any changes you make to the visible columns also apply to the Event Detail bar and the Investigative/Assisted Treatment windows. Such changes will automatically be saved when you exit the Desigo CC client application.

5.3.3.6 **Restoring Columns Settings**

▷ You previously changed the Event List layout (resized the columns [➞ 89], or customized the columns display [➞ 90], or changed the columns position [➞ 89]) and now you want to restore the default settings.

- Right-click on the column headers of Event List, and select **Restore column layout**.
   ➔ The default settings are restored for Event List, the Event Detail bar, and the Investigative/Assisted Treatment windows.
5.3.3.7 Changing Event Sorting

NOTICE! The following procedure applies only when working in Client Profiles BA_EN and TBS_EN.

- You want to change the default display of events in Event List. For example, you want to move Category to the top.
- In the column headers of Event List, click on the Category column header.
  - Default event sorting changes according to the applied criteria.

NOTE:
Event sorting also applies to the parent event of recurring events [→ 124] (designated by the Counter column). Any child recurring events are sorted by date and time in ascending order and you cannot change this sorted order.

5.3.3.8 Printing Event List Data

See Printing Data from a System Application [→ 374].

Tips for Printing Event List Data

- A printout of Event List will contain the following data: type of applied filter, events, date/time, and page number.
- A printout of recurring events will only contain the data of the parent event (such as, details of the parent event and number of recurrences).
- A printout of recurring events will only contain the data of the parent event (such as, details of the parent event and number of recurrences). In Client Profiles FS_UL/FS_ULC and TBS_UL/TBS_ULC, you will have the same printout as for non-recurring events. You can distinguish these types of events from the others because they have the same event category and event source.

5.4 Overview of Event Filters

Before you start alarm handling, you may want to apply a filter to decrease the number of events displayed in Event List. Filters are handy if you have many open events, and you want to view events of a certain type.

The following table describes the types of filters available.

<table>
<thead>
<tr>
<th>Event Filter</th>
<th>Description</th>
<th>Available using...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quick Filter [→ 94]</td>
<td>View open events of a single category. For example, Life Safety events.</td>
<td>Event lamp click in the Summary bar.</td>
</tr>
<tr>
<td>Simple Filter [→ 94]</td>
<td>Filter for something other than a specific category. For example, by discipline.</td>
<td>Filter menu [→ 92] (click the Filter icon [→ 92] in the Summary bar).</td>
</tr>
<tr>
<td>Filter by Tag [→ 97]</td>
<td>Hide or show tagged events [→ 114].</td>
<td></td>
</tr>
<tr>
<td>Advanced Filter [→ 94]</td>
<td>Filter open events using multiple criteria. For example, displaying only Life Safety events related to Fire that occurred within a certain period of time.</td>
<td>Advanced Filter [→ 93] window (click the Filter icon [→ 92] in the Summary bar to display the Filter menu [→ 92]).</td>
</tr>
</tbody>
</table>
### Operation Tips

- Before filtering events, be sure that alarm handling is suspended or not yet started.
- Generally, switching from one filter type to another causes the previous filter to be removed in order to apply the new one. The *Filter by Tag* is the only type of filter that you can use in conjunction with another filter.
- When filtering recurring events (designated by the Counter column), the filter applies only to the parent event, with the exception of the *Filter by Tag* that also applies to any child recurrences.
- To see the specified filter criteria in a tooltip, move your cursor over the Filter icon.

#### 5.4.1 Filter Icon

The Filter icon, located in the Summary bar, allows you to open a menu and apply event filters. Its color indicates the filter status as follows:

<table>
<thead>
<tr>
<th>Filter Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Filter off/inactive. If the filter functionality is unavailable to you, the filter icon appears dimmed." /></td>
<td>Filter off/inactive. If the filter functionality is unavailable to you, the filter icon appears dimmed.</td>
</tr>
<tr>
<td><img src="image" alt="Filter on/active." /></td>
<td>Filter on/active.</td>
</tr>
</tbody>
</table>

#### 5.4.2 Filter Menu

The Filter menu appears when you select the Filter icon in the Summary bar. The following table describes the menu options.

<table>
<thead>
<tr>
<th>Filter Menu Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remove Filter</td>
<td>Deactivate a filter.</td>
</tr>
<tr>
<td>Auto Remove on New Events</td>
<td>In Client Profile FS_EN, this menu option is visible but dimmed. This means that the system automatically removes any applied filter when a new event occurs and it does not satisfy the event filter criteria. In Client Profiles BA_EN and TBS_EN, you can activate/deactivate the possibility to remove any applied filter when a new event occurs and does not satisfy the event filter criteria. Generally, if you apply an event filter, you are not notified about any new event occurring in the system that does not satisfy this filter (Event List displays only the events that satisfy the filter applied). When you activate this option, any applied filter is automatically removed when new events occur and do not satisfy the applied event filter.</td>
</tr>
<tr>
<td>Filter By Category</td>
<td>Activate a Simple filter by category.</td>
</tr>
<tr>
<td>Filter By Discipline</td>
<td>Activate a Simple filter by discipline.</td>
</tr>
<tr>
<td>Filter By Date and Time</td>
<td>Activate a Simple filter by date and time (such as today, yesterday, last night, last hour, last half an hour, last quarter of an hour).</td>
</tr>
<tr>
<td>Filter by Maintenance State</td>
<td>Activate a Simple filter by maintenance (such as Maintenance or Genuine).</td>
</tr>
<tr>
<td>Filter By Event Status</td>
<td>Activate a Simple filter by event status (such as Unprocessed, Waiting for condition, Ready to be reset, Ready</td>
</tr>
</tbody>
</table>
5.4.3 Advanced Filter Window

The Advanced Filter allows you to create and apply a custom filter. You can:

- Activate a custom filter
- Create and save a custom filter to reuse it
- Modify an existing custom filter and reuse it
- Delete an existing custom filter
- Filter events by tags

The filter criteria are the same as the Simple filter applied from the filter menu with the following additional options:

- Location: Filter by geography
- Source: Filter by the point which has detected the event(s)
- Tag: Show both tagged and untagged events.
The system does not provide selected or predefined filter criteria. The filter options and Apply button become available only when you select one or more filter criteria. If you have already applied a custom filter to the Event List and then you reopen the Advanced Filter window, it contains the filter settings/criteria you applied. In this case, you can also save or modify the applied custom filter.

5.4.4 Working with Event Filters
The following procedures describe common event filter operating tasks (available from the Summary bar [71]).

See also:
- Overview of Event Filters [91]

5.4.4.1 Activating the Quick Filter

▷ You want to view events of a single category.
- In the Summary bar, click the event lamp that corresponds with the category of event for which you want to filter.

▷ The color of the selected event lamp becomes darker to indicate that a filter is applied, and the Filter icon changes color (filter on). Event List displays all open events in full detail for the category you selected, and the title bar displays the type of applied filter.

5.4.4.2 Activating the Simple Filter

▷ You want to view events with an attribute in common other than event category, such as by discipline, by date and time, by maintenance state, by event state.

1. In the Summary bar, click Filter.

2. From the Filter menu, select the attribute for which you want to filter, or the filter you want to apply.

▷ All open events that have the attribute you selected display in Event List, and the title bar displays the type of applied filter. As with all filters, the Filter icon changes color (filter on).

5.4.4.3 Creating and Activating a Custom Filter

▷ You want to filter a set of events by applying multiple criteria and/or attributes.

1. In the Summary bar, click Filter.

2. From the Filter menu, select Advanced Filter.

▷ The Advanced Filter dialog box displays.

3. Choose one or more filter criteria as follows:
   - Select the options that correspond to the criteria you want to use (Category, Discipline, Event status, Source status).
– In the list boxes, select the attributes you want to use for your filter (for example, \textit{Event status} = \textit{Unprocessed}, \textit{Source status} = \textit{Active}).

– In the \textbf{Location} and \textbf{Source} fields, enter an appropriate value. The location and source are limited to 100 alphanumeric characters.

– Select one of the available \textbf{Date and time} criteria.

– If available, select one of the \textbf{Tag} criteria.

– Select one of the available \textbf{Maintenance} criteria.

4. Click \textbf{Apply}.

\(\uparrow\) All open events with the attributes you selected appear in Event List, and its title bar displays the type of applied filter. As with all filters, the Filter icon changes color (filter on) \(\blacktriangleleft\).

5.4.4.4 \textbf{Saving a Custom Filter}

\(\uparrow\) You have opened the Advanced Filter window, and have already set up \([\rightarrow 94]\) a custom filter. Now you want to save it for future reuse.

\(\uparrow\) You must have selected at least a single criterion before saving, otherwise a message box asks you to define a filter.

1. In the \textbf{Filter name} field, enter a meaningful name. The name is limited to 50 alphanumeric characters. You cannot save a filter without giving it a name.

\(\uparrow\) The \textbf{Save} button is now available.

2. Click \textbf{Save}.

\(\uparrow\) The custom filter appears in \textbf{Saved filters} drop-down list.

\textbf{Tips for Working with Custom Filters}

– Custom filters are private and any that you create will be available only to you.

– If an internal error occurs when saving a filter, a message box informs you that the system cannot save your filter.

– When you save a custom filter, you can reuse \([\rightarrow 95]\), modify \([\rightarrow 96]\), or delete \([\rightarrow 96]\) it.

5.4.4.5 \textbf{Reusing a Custom Filter}

\(\uparrow\) The Advanced filter window is open.

\(\uparrow\) The \textbf{Saved filters} \([\rightarrow 95]\) drop-down list contains at least one of your custom filters.

1. In \textbf{Saved filters}, select a \textbf{custom filter}.

2. Click \textbf{Apply}.

\(\uparrow\) All open events with the attributes that correspond to the custom filter you selected appear in Event List. As with all filters, the Filter icon changes color (filter on) \(\blacktriangleleft\), followed by the filtering criteria.
Tips for Reusing a Custom Filter

- Reusing a saved custom filter is user profile-dependent.
- If an internal error occurs when applying a custom filter, a message box informs you that the system cannot apply the selected custom filter.

5.4.4.6 Modifying a Custom Filter

- The Advanced filter window is open.
- The Saved filters [→ 95] drop-down list contains at least one of your custom filters.

1. In Saved filters, select a custom filter.
   - The Update button becomes available.
2. Modify the filter criteria [→ 94].
3. Click Update.
   - The modified filter is saved in Saved filters and available for reuse.

5.4.4.7 Deleting a Custom Filter

- The Advanced Filter window is open.
- The Saved filters [→ 95] drop-down list contains at least one of your custom filters.

1. In Saved filters, select the custom filter you want to delete.
   - The Delete button becomes available.
2. Click Delete.
   - A confirmation message displays asking if you really want to delete the filter.
3. Click OK.
   - The custom filter is removed from Saved filters.

5.4.4.8 Deactivating a Filter

**NOTICE!** In FS_EN profile, the system automatically removes any applied filter when a new event occurs and it does not satisfy the event filter criteria.

- Event List displays a filtered list of events, and you want to view all open events.

1. In the Summary bar, click Filter \(\downarrow\).
2. From the Filter menu, select Remove Filter.
   - The Filter icon changes color (filter off) \(\downarrow\) and the filter criteria disappears. All open events reappear in the Event List.

**Tip for Deactivating a Quick Filter**

If you have applied a Quick filter and you want to remove it, instead of performing the previous steps, you can click the event lamp that corresponds with the category of event you filtered.
5.4.4.9 Filtering Tagged/Untagged Events

- You have already tagged/untagged some events.
- Event List displays all open events (both tagged and untagged), and you want to view only the tagged events or hide the tagged events displayed in Event List.

- In the Summary bar, click the Filter and do one of the following:
  - From the Filter menu, select Filter by Tag, and then one of the options either Show tagged events only (all open tag events display in Event List) or Hide tagged events (all open untagged events display in Event List).
  - Open the Advanced Filter window. From the Tag option, select Show tagged events only (or Hide tagged events), and click Apply.

- As with all filters, the title bar displays the type of applied filter, and the Filter icon changes color (filter on).

5.4.4.10 Deactivating the Filter by Tag

- Event List displays filtered by tag, and you want to display both tagged and untagged events.

- In the Summary bar, click Filter, and do one of the following:
  - From the Filter menu, select Filter by Tag, and deselect the option checked (either Show tagged events or Hide tagged events).
  - Open the Advanced Filter window. From the Tag option, select Show both tagged and untagged events, and click Apply.

- Tagged and untagged events reappear in Event List.

Tip for Deactivating the Filters Applied

- The events you see in Event List also depend on any other filter you have applied in combination with the Filter by Tag (the Filter icon is on to indicate the use of an additional filter). If you want to remove all the filters applied, select Remove Filter from the Filter menu.

5.4.4.11 Activating Auto Remove on New Events

NOTICE! The following procedure applies only when working in Client Profiles BA_EN and TBS_EN.

- Event List displays a filtered list of events, and you want to automatically remove this filter when any new events occur that do not satisfy the applied filter.

1. In the Summary bar, click Filter.

2. From the Filter menu, select Auto Remove on New Events.

- As soon as a new event occurs, the filter criteria disappears. All open events display in Event List.
5.4.4.12 Deactivating Auto Remove on New Events

NOTICE! The following procedure applies only when working in Client Profiles BA_EN and TBS_EN.

- You have activated the Auto Remove on New Events option and now you want to deactivate it so that any applied filter is not automatically removed when new events occur that do not satisfy the filter criteria.

1. In the Summary bar, click Filter ▾.
2. From the Filter menu, deselect Auto Remove on New Events.

5.5 Overview of Alarm Handling

This section describes the alarm handling (event treatment) process, and provides general guidelines for responding to events. The exact alarm handling steps appropriate for each event must be considered on a case-by-case basis.

Desigo CC provides both basic and advanced alarm-handling support, as well as access to all the relevant information, such as where an event occurred and the nature of the event.

Depending on the configuration and user privileges, you may have a choice between different ways of handling an event. The system has three possible alarm-handling modes called Fast Treatment ➔ 117, Investigative Treatment ➔ 118, and Assisted Treatment ➔ 119.

Fast Treatment is generally always available, while Investigative Treatment may in some cases not be available to you. For example, serious situations (Emergency or Life Safety) typically require you to follow the guided Assisted Treatment procedure. For less critical events you may instead be able to choose between Fast and Investigative Treatment.

- Fast Treatment allows you to quickly send alarm-handling commands ➔ 103 (such as, Acknowledge, Reset, and so on) from the Event Detail Bar ➔ 117 and Event List ➔ 111, without following any advanced guided procedure.
- Investigative Treatment allows you to send alarm-handling commands ➔ 103 while navigating System Browser and, for example, looking at a map of the area issuing the alarm.
- Assisted Treatment provides a guided procedure for you to follow, consisting of mandatory or optional steps that you have to complete and check off. Such a procedure might, for example, require you to contact the police station by email, and/or complete an event report, as well as sending alarm-handling commands ➔ 103.

You initiate event treatment by:
- Selecting a single event ➔ 117 in the Event Detail bar
- Selecting a single event ➔ 112 or multiple events ➔ 118 in Event List
- Starting Investigative Treatment ➔ 118 or Assisted Treatment ➔ 119 of an event

Automatic Alarm Handling

Desigo CC can be configured to automatically start the alarm handling of events when certain conditions occur on the site. The most common scenarios where this feature is available are the following:

- Unmanned clients (display stations, such as embedded monitors on the walls of hospitals or airports) where Desigo CC normally displays a graphic, so that in case of emergency it can automatically display the relevant alarm with its most important details (typically, a floor plan graphic and live video). Unmanned clients do not provide any alarm-handling function.
• Unskilled operators: In case of immediate threat to life or health (for example, a Fire Life Safety event), automatically displaying a floor plan graphic (or video feed) of the area where the alarm occurred enables even unskilled personnel to understand and react to an emergency situation on the site. In this scenario, too, Desigo CC automatically displays the relevant event with its most important details, without requiring those operators to send any alarm-handling commands.

**Activity Log and Event Log**

During event treatment, entries are recorded in the *History database* for the following:

• Operator’s activities relating to alarm handling (for example, initiating/suspending alarm handling, acknowledging/resetting an event, and so on). This log data is available when generating an *Activity Log* report.

• Evolution of the events in the system (for example, a new event occurs in the system, an event is acknowledged/reset and so on), and evolution of the operating procedure steps in Assisted Treatment (for example, an operating procedure is initiated or closed and so on). This log data is available when generating an *Event Log* report.

**Technical Notes**

• The available event treatment modes are configuration-dependent.

• The way events display depends on user’s privileges. This means that the Summary Bar, Event Detail Bar, Event List, Investigative Treatment, and Assisted Treatment display only the alarms coming from the points that you are allowed to see in System Browser. If an alarm is generated by a point not visible to you in System Browser, it does not display.

• The system allows Fast/Investigative treatment of an event by more than one user at the same time. If the connection is lost for any reason (for example, computer not reachable), the system quickly updates the list of users who are handling the same event, and removes the disconnected users. When the connection is restored, the system refreshes the event details and displays the current situation on the server (events, being processed by, and so on).

### 5.5.1 Event Categories

Each event is color-coded by its level of severity, and belongs to a specific category.

The following presents details only about the basic event categories. For details on any extension to event categories, see Section Appendix A: Client Profiles Extensions [➙ 396].

<table>
<thead>
<tr>
<th>Category Name</th>
<th>Color</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Emergency</td>
<td>Red</td>
<td>Events relating to an immediate threat to life, safety, or health created by Emergency call.</td>
</tr>
<tr>
<td>Life Safety</td>
<td>Red</td>
<td>Events relating to an immediate threat to life, safety, or health created by system.</td>
</tr>
<tr>
<td>Danger</td>
<td>Magenta</td>
<td>Events relating to an immediate threat to property or may become life-threatening.</td>
</tr>
<tr>
<td>High</td>
<td>Dark orange</td>
<td>Events relating as a major threat to property.</td>
</tr>
<tr>
<td>Medium</td>
<td>Orange</td>
<td>Events relating to improper operation, major occupant discomfort.</td>
</tr>
<tr>
<td>Low</td>
<td>Yellow</td>
<td>Events relating to general improper operation, minor occupant discomfort.</td>
</tr>
<tr>
<td>Fault</td>
<td>Yellow</td>
<td>Events relating to technical equipment failure.</td>
</tr>
</tbody>
</table>
### 5.5.2 Event Disciplines

Each event belongs to a discipline. They include:

<table>
<thead>
<tr>
<th>Icon (examples)</th>
<th>Discipline</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Building Automation" /></td>
<td>Building Automation</td>
</tr>
<tr>
<td><img src="image" alt="Building Infrastructure" /></td>
<td>Building Infrastructure</td>
</tr>
<tr>
<td><img src="image" alt="Energy Management" /></td>
<td>Energy Management</td>
</tr>
<tr>
<td><img src="image" alt="Fire" /></td>
<td>Fire</td>
</tr>
<tr>
<td><img src="image" alt="Management System" /></td>
<td>Management System</td>
</tr>
<tr>
<td><img src="image" alt="Notification" /></td>
<td>Notification</td>
</tr>
<tr>
<td><img src="image" alt="Security/Video" /></td>
<td>Security/Video</td>
</tr>
</tbody>
</table>

### 5.5.3 Event Status

The Event Status column in the event descriptor indicates the status of an event.

<table>
<thead>
<tr>
<th>The event status is...</th>
<th>When...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unprocessed</td>
<td>The event is new and still unprocessed. This means that you either did not yet select the event, or that you selected it but did not acknowledge it yet. You can also silence/unsilence the field panel.</td>
</tr>
<tr>
<td>Ready to be reset</td>
<td>In Assisted Treatment, you selected an event and the source status is back in normal condition. The Reset command is available.</td>
</tr>
<tr>
<td>Ready to be closed</td>
<td>In Fast/Investigative Treatment, you selected an event and the Reset command is available. You can also silence/unsilence the field panel. In Assisted Treatment, you reset an event, and all the mandatory steps of the assisted procedure were executed. The Close command is available.</td>
</tr>
<tr>
<td>Waiting for condition</td>
<td>You suspended the event. In Fast/Investigative Treatment, you acknowledged the event, but cannot reset it yet. You can also silence/unsilence the field panel.</td>
</tr>
</tbody>
</table>
In Assisted Treatment, you acknowledged the event, but cannot reset it yet because you must first complete all the mandatory steps of the assisted procedure.

Closed

In Fast/Investigative Treatment, you reset the event, and the source status is back in normal condition. You can clear the event.

In Assisted Treatment, you closed the event and now you can clear it.

NOTE:
For recurring events [124], the parent event will display the status relating to the most important recurrence.

Acknowledgment Models for Station-based Alarms
The following acknowledgment models are for station-based alarms:

- ACK and Reset required
- No Reset (ACK only required)
- No ACK, No Reset

### Fast/Investigative Treatment Workflow

<table>
<thead>
<tr>
<th>Acknowledgment Model</th>
<th>Scenario</th>
<th>Event Status</th>
</tr>
</thead>
</table>
| ACK and Reset required | ● Alarm handling started (and at least one alarm-handling command sent)  
                           ● Event source back to Quiet | Unprocessed  
                                                     Wait for condition  
                                                     Ready to be closed  
                                                     Closed           |
|                      | ● Alarm handling not started yet (no alarm-handling command sent yet)  
                           ● Event source back to Quiet | Unprocessed  
                                                     Ready to be closed  
                                                     Closed           |
| No Reset (ACK only required) | ● Alarm handling started (and at least one alarm-handling command sent) or not started yet (no treatment command sent yet)  
                                               ● Event source back to Quiet | Unprocessed  
                                                     Wait for condition  
                                                     Closed           |
| No ACK, No Reset     | ● Alarm handling started (and at least one alarm-handling command sent) or not started yet (no alarm-handling command sent yet)  
                           ● Event source back to Quiet | Wait for condition  
                                                     Closed           |

### Assisted Treatment (with Mandatory Steps) Workflow

<table>
<thead>
<tr>
<th>Acknowledgment Model</th>
<th>Scenario</th>
<th>Event Status</th>
</tr>
</thead>
</table>
| ACK and Reset required | ● Alarm handling started (and at least one alarm-handling command sent)  
                                  ● Event source back to Quiet | Unprocessed  
                                                    Wait for condition  
                                                    Ready to be reset  
                                                    Wait for condition (due to mandatory steps)  
                                                    Ready to be closed  
                                                    Closed           |
### Alarm Management

### Overview of Alarm Handling

- **Alarm handling not started yet (and no alarm-handling command sent yet)**
  - Event source back to Quiet
  - Unprocessed
  - Ready to be reset
  - Wait for condition (due to mandatory steps)
  - Ready to be closed
  - Closed

- **Event source back to Quiet**
  - Unprocessed
  - Wait for condition
  - Wait for condition (due to mandatory steps)
  - Ready to be closed
  - Closed

- **Event status back to Quiet**
  - Unprocessed
  - Wait for condition
  - Ready to be closed
  - Closed

- **No Reset (ACK only required)**
  - Alarm handling started (and at least one alarm-handling command sent)
  - Event source back to Quiet
  - Unprocessed
  - Wait for condition
  - Wait for condition (due to mandatory steps)
  - Ready to be closed
  - Closed

- **No ACK, No Reset**
  - Alarm handling started (and at least one alarm-handling command sent)
  - Event source back to Quiet
  - Unprocessed
  - Wait for condition
  - Wait for condition (due to mandatory steps)
  - Ready to be closed
  - Closed

---

### Assisted Treatment (Without Mandatory Steps) Workflow

<table>
<thead>
<tr>
<th>Acknowledgment Model</th>
<th>Scenario</th>
<th>Event Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACK and Reset required</td>
<td>Alarm handling started (and at least one alarm-handling command sent)</td>
<td>Unprocessed Wait for condition Ready to be reset Ready to be closed Closed</td>
</tr>
<tr>
<td></td>
<td>Event source back to Quiet</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Alarm handling not started yet (and no alarm-handling command sent yet)</td>
<td>Unprocessed Ready to be reset Ready to be closed Closed</td>
</tr>
<tr>
<td></td>
<td>Event source back to Quiet</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>No Reset (ACK only required)</td>
<td>Alarm handling started (and at least one alarm-handling command sent)</td>
<td>Unprocessed Wait for condition Ready to be closed Closed</td>
</tr>
<tr>
<td></td>
<td>Event source back to Quiet</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Alarm handling not started yet (and no alarm-handling command sent yet)</td>
<td>Unprocessed Ready to be closed Closed</td>
</tr>
<tr>
<td></td>
<td>Event source back to Quiet</td>
<td></td>
</tr>
<tr>
<td>No ACK, No Reset</td>
<td>Alarm handling started (and at least one alarm-handling command sent)</td>
<td>Wait for condition</td>
</tr>
<tr>
<td></td>
<td>Event source back to Quiet</td>
<td></td>
</tr>
</tbody>
</table>
5.5.4 Source Status

The Source Status column in the event descriptor indicates the status of the source.

<table>
<thead>
<tr>
<th>When the event status is...</th>
<th>And the source status color in the event button is...</th>
<th>Source status is...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unprocessed, Waiting for condition, Ready to be reset, or Ready to be closed, and the event is unselected</td>
<td>The same as the event category.</td>
<td>Active (event source is in an off normal condition).</td>
</tr>
<tr>
<td>Unprocessed, Ready to be reset, Ready to be closed</td>
<td>Gray</td>
<td>Quiet (event source is back to normal)</td>
</tr>
</tbody>
</table>

5.5.5 Suggested Action

The event descriptor [→ 84] suggests the following actions to take to treat an event.

<table>
<thead>
<tr>
<th>When the event status is...</th>
<th>The suggested action is...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unprocessed, Waiting for condition, Ready to be reset, or Ready to be closed, and the event is unselected</td>
<td>Select the event</td>
</tr>
<tr>
<td>Waiting for condition and the event is unselected in Assisted Treatment while the mandatory steps have not been completed yet.</td>
<td>Complete Operating Procedure</td>
</tr>
<tr>
<td>Unprocessed, Waiting for condition</td>
<td>Acknowledge event</td>
</tr>
<tr>
<td>Ready to be reset</td>
<td>Reset event</td>
</tr>
<tr>
<td>Ready to be closed</td>
<td>Close event</td>
</tr>
<tr>
<td>Closed</td>
<td>Suspend event</td>
</tr>
</tbody>
</table>

5.5.6 Alarm-handling Commands

The alarm-handling commands allow you to quickly perform Fast Treatment [→ 117] from: Event Detail bar, Event List, and Investigative/Assisted Treatment windows.

Technical Notes

- You cannot handle events generated by field points for which you don’t have proper user privileges (such alarms and the related commands will not be not visible).
While handling events, your ability to acknowledge, reset and/or silence/unsilence an individual field point/panel (sending an individual command) or all the panels belonging to the same network (sending block commands) depends on configuration.

If you try to send block commands while an event filter \( \rightarrow 91 \) is active, a message displays asking you to remove the filter. Deactivate the filter and send the (block) command.

### 5.5.6.1 Commands Display and Behavior

Commands display in the event descriptor \( \rightarrow 84 \). The Client Profile \( \rightarrow 87 \) in use determines the appearance and behavior of the alarm-handling commands.

<table>
<thead>
<tr>
<th>Commands</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Icon</strong></td>
</tr>
<tr>
<td>✔️</td>
</tr>
<tr>
<td>✔️</td>
</tr>
<tr>
<td>✔️</td>
</tr>
<tr>
<td>✔️</td>
</tr>
<tr>
<td>☮️</td>
</tr>
<tr>
<td>☮️</td>
</tr>
<tr>
<td>✗</td>
</tr>
</tbody>
</table>

The following three commands may simultaneously display: Acknowledge/Reset, Start Remote Notifications/Stop Remote Notifications, and Silence/Unsilence.

<table>
<thead>
<tr>
<th>Appearance</th>
<th>The command is...</th>
<th>Indicates...</th>
</tr>
</thead>
<tbody>
<tr>
<td>-</td>
<td>Not visible</td>
<td>Event unselected or selected, and command unavailable</td>
</tr>
<tr>
<td>✔️</td>
<td>Visible, but dimmed</td>
<td>Event unselected, and command inactive (FS_EN only)</td>
</tr>
<tr>
<td>✔️</td>
<td>Visible and available</td>
<td>Event unselected, and command active</td>
</tr>
<tr>
<td>✔️</td>
<td></td>
<td>Event selected and command active (FS_EN profile only)</td>
</tr>
<tr>
<td>✔️</td>
<td>Visible, available, and darkened</td>
<td>Hovering effect on command</td>
</tr>
</tbody>
</table>
Command Availability
- Acknowledge or Reset display depends on the current status of the event source.
- Start/Stop Remote Notifications commands display only if Remote Notification messages were configured for an event.
- Silence/Unsilence commands display only if they were configured for the field panels.

Command Execution Dependency
- To execute Acknowledge, Reset, or Silence/Unsilence, you must have proper user privileges, or the client station you’re working on must be the owner of the field panel.
- To execute Start/Stop Remote Notifications, you must have user privileges to start remote notifications.

5.5.7 Investigative Treatment
The Investigative Treatment window displays in the work area just below the Summary bar and Event Detail bar. It allows you to navigate to other system applications (for example, System Browser or Scheduler) while maintaining the context of the alarm handling.

Investigative Treatment Workspace

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Summary bar [71]</td>
<td>Provides an overview of the events in the system.</td>
</tr>
<tr>
<td>2</td>
<td>Event Detail bar [80]</td>
<td>Highlights events that require immediate attention.</td>
</tr>
<tr>
<td>3</td>
<td>Title bar</td>
<td>Shows the name of the Investigative Treatment window. It also contains some icons to open/close.</td>
</tr>
</tbody>
</table>
## Alarm Management

### Overview of Alarm Handling

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>Event descriptor pane</td>
</tr>
<tr>
<td>5</td>
<td>Selection pane</td>
</tr>
<tr>
<td>6</td>
<td>Primary pane</td>
</tr>
</tbody>
</table>
| 7 | Contextual pane | Displays by default and provides additional information, actions, and resources about the point in alarm. It is divided into two parts:  
- Operation/Extended Operation tabs (left side): Lets you inspect all the properties of the point in alarm, and view and execute any commands/actions available for that object. Detailed Log [328]: Lets you view a detailed log of the event currently being handled.  
- Related Items tab (right side): Provides links to additional resources (for example, reports or alarm-handling procedures) that are relevant to the point in alarm. If you click on a related item it opens by default in the Secondary pane. |

### Simultaneous Processing of Alarms from the Same Client Station

On the same client station:

- You can only process one event at a time in Investigative or Assisted Treatment.
- To highlight that an alarm is being processed by Investigative or Assisted Treatment:
  - In Event List the event button for that alarm is replaced by a placeholder.
  - In the Event Detail bar the color of the event button has a darker shade.

### Simultaneous Processing of Alarms from Different Client Stations

A Desigo CC installation can have one or more client stations from which operators monitor and respond to alarms.

- At any given time, you can see which operator(s) and station(s) are handling an alarm. This information is available in the event button tooltip and in the In Process by column of the event descriptor.
- When another operator is handling an alarm using Investigative Treatment, you can initiate Investigative Treatment for that alarm.

### 5.5.8 Assisted Treatment

Assisted Treatment is the name of a guided alarm-handling feature provided by Desigo CC. It gives the operator step-by-step instructions [119] for responding to certain alarms (also called events). During Assisted Treatment, the system may also automatically execute certain actions (such as sending notifications) without the operator's intervention.

Assisted Treatment is accessed by clicking (or, in some client profiles, double-clicking) an event button in Event List, or in the Event Detail bar: If the alarm in question has been configured to have an assisted procedure, then a dedicated Assisted Treatment window will open. (If Assisted Treatment is not available, then the Investigative Treatment window [105] opens instead).
The event descriptor of the alarm being handled displays at the top of the Assisted Treatment window, and you can also directly send alarm-handling commands (that is, do Fast Treatment [@117]) from there.

The Assisted Treatment window displays in the work area just below the Summary bar and Event Detail bar. It shows the sequence of steps (for example, viewing a document or graphic, sending a remote notification, or filling out a report) that you have to perform to properly handle that alarm. At each step, the system automatically opens and displays whatever resource or tool (for example, a floor plan graphic or a report template) you need to perform that step.

The procedure steps may be mandatory or optional. They can include:

- View interactive floor-plan graphic [@48]
- Display a document [@121]
- Generate a report [@123]
- Complete a form [@124]
- Event data printout [@123]
- Remote notifications [@121]
- Display live video of the point in alarm

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Summary bar [@71]</td>
<td>Provides an overview of the events in the system.</td>
</tr>
<tr>
<td>2</td>
<td>Event Detail bar [@80]</td>
<td>Highlights events that require immediate attention.</td>
</tr>
<tr>
<td>3</td>
<td>Title bar</td>
<td>Shows the name of the Assisted Treatment window. It also contains some icons to open/close [@117] the Contextual pane (7), change the default window layout, and icons for the standard window controls (minimize, restore, and so forth).</td>
</tr>
<tr>
<td>4</td>
<td>Event descriptor pane</td>
<td>Contains the event button [@83] and event details [@84] for the event that is currently being processed. The</td>
</tr>
</tbody>
</table>
background color reflects the event category color, but in a darker shade. Alarm-handling commands \[\rightarrow 103\] are also available. A specific icon in the event button indicates that the event is being processed by Assisted Treatment.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>Selection pane</td>
</tr>
<tr>
<td></td>
<td>Contains the list of operating procedure steps [\rightarrow 109] you must perform to process the event.</td>
</tr>
<tr>
<td>6</td>
<td>Primary pane</td>
</tr>
<tr>
<td></td>
<td>The Default tab contains the system application associated with the currently selected step in the procedure.</td>
</tr>
<tr>
<td>7</td>
<td>Contextual pane</td>
</tr>
<tr>
<td></td>
<td>Hidden by default. When open, it provides additional information, actions, and resources about the point in alarm. It is divided into two parts:</td>
</tr>
<tr>
<td></td>
<td>• Operation/Extended Operation tabs (left side): Lets you inspect all the properties of the point in alarm, and view and execute any commands/actions available for that object. Detailed Log [\rightarrow 328]: Lets you view a detailed log of the event currently being handled.</td>
</tr>
<tr>
<td></td>
<td>• Related Items tab (right side): Provides links to additional resources (for example, reports or alarm-handling procedures) that are relevant to the point in alarm. If you click on a related item it opens by default in the Secondary pane.</td>
</tr>
</tbody>
</table>

**Simultaneous Processing of Alarms from the Same Client Station**

On the same client station:

- You can only process one event at a time in Investigative or Assisted Treatment.
- To highlight that an alarm is being processed by Investigative or Assisted Treatment:
  - In Event List the event button for that alarm is replaced by a placeholder.
  - In the Event Detail bar the color of the event button has a darker shade.

**Simultaneous Processing of Alarms from Different Client Stations**

A Desigo CC installation can have one or more client stations from which operators monitor and respond to alarms.

- At any given time, you can see which operator(s) and station(s) are handling an alarm. This information is available in the event button tooltip and in the In Process by column of the event descriptor.
- When another operator is handling an alarm using Assisted Treatment, you cannot initiate Assisted Treatment for that alarm. Instead, Fast or Investigative Treatment is available to you.

**Availability of Assisted Treatment**

- Assisted Treatment is covered by a license. Check that the Assisted Treatment option license is installed in the system (in the Management View of System Browser, at the following path: Project > Management System > Servers > Main Server > Licenses); otherwise you won’t be able to initiate Assisted Treatment and execute any operating procedures that have been configured; you can use the other alarm-handling methods provided by the system (Fast Treatment and Investigative Treatment). If the license is installed but later expires or is lost for any reason, Assisted Treatment is available only for those events that were already undergoing Assisted Treatment, and that have an associated operating procedure. If a new event occurs, Fast Treatment and Investigative Treatment will remain available.
- In addition to the license, the availability of Assisted Treatment depends:
– On your user group rights. If you don’t have appropriate access permissions, you cannot initiate Assisted Treatment.
– On the system configuration (that is, on whether an assisted procedure has been configured for handling a particular type of alarm. If there is no such procedure configured, Investigative Treatment is available instead.

Closing an Event
In Desigo CC, when the event status of an alarm is *closed* it means it has been fully processed and so is ready to be cleared from Event List.
When you handle an alarm with Assisted Treatment, the following conditions must be met before that alarm can be closed:
- You must have completed the mandatory steps of the Assisted Treatment procedure.
- The event source (that is, the field point which generated the alarm) must be back to normal.
When these two conditions are met (event source back to normal, and mandatory procedure steps completed), then depending on configuration the system will either automatically close the event (autoclose) or you must manually close the event (clicking the Close command).
- The system allows you to carry out the assisted-procedure steps of a closed event. This means that you can re-execute the steps even after the assisted procedure is completed.

Output File Locations
- When you generate an alarm printout, a report, or an alarm-handling form using a virtual printer (for example, a PDF printer), the output files are saved in the following location: 
  C:\GMSProjects\[Customer project]\data\Reporting\Reports.
- When you complete an assisted procedure of an event, any attachment (such as, alarm printout, report or alarm-handling form) is saved in the following location: 
  C:\GMSProjects\[Customer project]\shared\attachments. The Activity Log report includes a link to these attachments.

5.5.8.1 Steps Workspace
When you open the Assisted Treatment window, the Selection pane on the left lists the steps of the guided procedure you must follow to handle the event. This list helps you select and carry out the steps in the correct sequence, which depends on how procedure was configured. Additionally, depending on configuration, a step can be:
- Automatic or manual
- Mandatory or optional
- Repeatable or not repeatable
Alarm Management
Overview of Alarm Handling

Steps Workspace

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Symbol that indicates a <em>mandatory</em> step.</td>
</tr>
<tr>
<td>2</td>
<td>Step identifier. This number may or may not correspond to the execution order.</td>
</tr>
<tr>
<td>3</td>
<td>Briefly describes the type step.</td>
</tr>
</tbody>
</table>
| 4    | Depending on the step’s configuration, you will see a white or gray check box:  
  - A tooltip tells you that you cannot check off the step because you haven’t done all the actions required to complete the step (for example, complete a remote notification procedure or fill out and save an event treatment report).  
  - A tooltip tells you that you can check off the step to mark it as completed.  
  Once you check off a step as executed, a checkmark icon displays in the place of the check box, to indicate that the step has been completed. |
| 5    | Graphically indicates the step’s execution status as follows:  
  - in progress  
  - successfully executed  
  - failed |
| 6    | Graphically indicates that the step is selected and the relevant application for performing that step is available in the Default tab of the Primary pane. |
Appearance and Behavior

- Each step has the same color as the event's category. When you select a step, it expands and changes to a darker color to indicate that it is being executed. Once you complete a step and a graphic icon indicates the execution outcome of that step (successful or failed).
- You must execute the first mandatory step before the ensuing mandatory steps can be selected and executed.
- Whether the steps must be executed sequentially, or may instead be free executed in any order, depends on how the assisted-procedure was configured.
- During the execution of an assisted procedure, when you move your cursor over a step:
  - If it turns into hand, this means that you can execute the step.
  - If it turns into arrow, this means that you cannot execute the step because it is locked. This may happen if a preceding mandatory step has not been executed yet, or during the execution of sequential steps.
- Once you have completed all the actions required by a step, the gray check box turns white and you can mark that step as completed.
- The system provides the following details of a step in a tooltip: name, execution type (mandatory or optional), type (automatic or manual), state (unknown, successful, or failed), and notes (error message, if any). Also, once a step is executed, the name of the operator who executed the step displays in the tooltip. If a step fails, an error message displays in the tooltip or in the window status bar.

5.5.8.2 Assisted Treatment Steps

Possible steps in Assisted Treatment include:
- Alarm printout [�数]: Print details of an event.
- Document Viewer [�数]: View instructions or other important information contained in a document file or web page.
- Graphics [�数]: Check a graphic of the area where the event occurred.
- Reno [ числе]: Send important event detail information via remote notification message.
- Alarm-handling form [ числе]: View and enter event handling information in a report for operating procedures.

5.5.9 Handling Events

Use the following to ensure that you completed alarm handling.
1. To handle an alarm start either:
   - Fast Treatment [ числе]
   - Investigative Treatment [ числе]
   - Assisted Treatment [ числе]
2. Follow the recommended alarm handling procedure (Fast [ числе], Investigative [ числе], or Assisted [ числе]).
3. Log [ числе] an event note in the history database, if desired.

The following sections describe alarm handling operating tasks in details.
**Alarm Handling Tips**

- Before proceeding with alarm handling, you may want to apply a filter [91] to decrease the number of events displayed in Event List, or view the intervention text [116] of a specific event, or check the event source [115].
- When dealing with multiple events in Event List, you may want to handle multiple events with one command [118].
- Any event you are currently handling is suspended if the system automatically starts handling another event.

### 5.5.9.1 Selecting and Unselecting an Event

- Event List [81] displays on the screen.
- The suggested action for an event is Select the event.
- Click an event button [83] or an event descriptor [84].
  - The event descriptor of the selected event appears highlighted to indicate the selection, and alarm handling is in progress.

- You want to unselect an event.
- Click the event button [83] that corresponds to the selected event.

### 5.5.9.2 Acknowledging an Event

- You have selected an event.
- The event status is Unprocessed.
- The suggested action is Acknowledge event.
- The Acknowledge command is available.

- Click Acknowledge [✓].
  - The event is acknowledged, and the event status changes to either Waiting for condition, Ready to be reset, or Ready to be closed.

### 5.5.9.3 Resetting an Event

- The physical conditions that caused an alarm are gone and you need to reset the control unit.
- The event status is Ready to be reset or Ready to be closed.
- The suggested action is Reset event or Close event.
- The Reset command is available.

- Click Reset [✓].
  - The event is reset, and the event status changes to Ready to be closed or Closed.
5.5.9.4 Suspending an Event

- You may want to suspend an event, for example, because you have already selected it and you want to suspend alarm handling as there are other events waiting to be handled.
- Click the event button [→ 83] that corresponds to the event being handled.
- The event is no longer handled.

NOTE:
If you select an event in Event List while another event is being handled, the alarm handling for this event is suspended, and the new selected event is handled.

5.5.9.5 Clearing an Event

Depending on how you are handling an event, you can clear an event from Event List in one of the following ways:
- You have completed Fast or Investigative Treatment.
- The event is selected and the event status is Closed.
- The suggested action is Suspend event.
- Click the event button [→ 83].
  - In Fast Treatment, the event is cleared from Event List.
  - In Investigative Treatment, the Investigative Treatment window closes and the event is cleared from Event List.

- You have completed Assisted Treatment (all the mandatory steps of an operating procedure have been executed).
- The event is selected and the event status is Ready to be closed.
- The Close command is available.
- The suggested action is Close event.
  1. Click Close
  - The event status becomes Closed. The suggested action is Suspend event.
  2. Click the event button [→ 83].
  - The Assisted Treatment window closes and the event is cleared from Event List.

5.5.9.6 Silencing/Unsilencing a Field Panel

- You have selected an event.
- The command to silence a field panel is available in the event descriptor [→ 84].
- Click Silence
  - The field panel is silenced.
You have selected an event.

The command to unsilence the field panel is available in the event descriptor [→ 84].

- Click Unsilence 🗣.
  - The field panel is unsilenced.

### 5.5.9.7 Starting/Stopping Remote Notifications

You have selected an event.

The command to manually start remote notifications is available in the event descriptor [→ 84].

- Click Start Remote Notifications ⬅️.
  - The remote notification is started.

You have selected an event.

The command to stop remote notifications is available in the event descriptor [→ 84].

- Click Stop Remote Notifications ⬇️.
  - The remote notification is stopped.

**Operation Notes**

- You can start/stop remote notifications regardless of whether or not the event has been reset.
- These operations are the same as when handling [→ 140] an alarm-based manual remote notification directly from RENO Messages.

### 5.5.9.8 Tagging/Untagging Events

You can hide some events in Event List until they change their state or until you want to see them again. You do this by tagging/untagging events in Event List thus applying a Filter by Tag [→ 97].

- The Tag column is available in Event List.
- By default, events in Event List are untagged, and the Tag column appears empty.

1. Move your cursor over the Tag column that corresponds to event you want to tag.
   - The Tag icon appears in the Tag column.
2. Click Tag ⚒️.
   - The event is now tagged.

You have tagged some events, and now you want to untag them.
- Click **Tag** for all the events you want to untag.
  - The Tag icon disappears for all the untagged events.

**Tagging/Untagging Recurring Events**
- Tagging/untagging a parent event also affects its child recurrences.
- You can tag/untag an individual child recurrence.
- When you tag recurring events, the *Hide tagged events* filter applies. If a new recurring event is generated, you see the parent event again and it will display only the new recurrence.
- The recurring events Counter shows the total number of recurring events, regardless of whether or not they are tagged.

**Operation Tips**
- When you select multiple events, and you tag/untag an individual event of the selection, all the events selected are tagged/untagged.
- When a tagged event changes its state, it is automatically untagged. If the current filter allows, this event is displayed again.
- The tag action is valid only during the current client session. If you restart the client application, all the events are visible in Event List and untagged.

**5.5.9.9 Logging an Event Note in the History Database**
- You have selected one or more events in Event List and you want to log a note in the History Database.

1. In the event descriptor [➔ 84], click **Log an event note in history**.
2. In the History Database dialog box, edit your note and then click **OK**.
  - The note is stored in the History Database. You can generate a report (Activity Log or Event Detail Log) to print any logged event note. If you selected multiple events, this note will be logged as applying to all those events.

**5.5.9.10 Checking the Event Source in the Current View**
- You are handling an alarm and want to check its event source.

1. Depending on how you are handling the alarm, locate its event descriptor [➔ 84] in Event List, or at the top of the Assisted Treatment or Investigative Treatment window. (You may also be able to access the event descriptor in the Event Detail bar).
2. In the event descriptor, click the **Source** text.
  - If you're handling the alarm from Event List, Event List collapses (or is hidden), System Manager displays in the foreground (if it was in the background) with the event source highlighted in the current view of System Browser. Textual Viewer displays details of the point in alarm and Operation/Extended Operation displays any properties and commands of the point in alarm. To go back to handling the alarm, open (or expand) Event List.
  - If the event in question is an Event Enrollment (EE) event, the original event source is highlighted in the current view of System Browser.
  - If you are handling the alarm from the Investigative Treatment window, the event source is highlighted in the current view of System Browser. Textual
Viewer displays details of the point in alarm and Operation/Extended Operation displays any properties and commands of the point in alarm.

If you are handling the alarm from the Assisted Treatment window, Operation/Extended Operation in the Contextual pane displays any properties and commands of the point in alarm.

5.5.9.11 Checking the Event Source by Alias, Name, or Description

You have customized the event descriptor to display the Alias, Name, or Description [View] columns.

1. Depending on how you are handling the alarm, locate its event descriptor [➡️ 84] in Event List, or at the top of the Assisted Treatment or Investigative Treatment window. (You may also be able to access the event descriptor in the Event Detail bar).

2. In the event descriptor, click one of the following texts:
   - Description [View]
   - Name
   - Alias

If you’re handling the alarm from Event List, Event List collapses (or is hidden), System Manager displays in the foreground (if it was in the background) with the event source highlighted in the specific view of System Browser. Textual Viewer displays details of the point in alarm and Operation/Extended Operation displays any properties and commands of the point in alarm. To go back to handling the alarm, open (or expand) Event List.

If you are handling the alarm from the Investigative Treatment window, the event source is highlighted in the specific view of System Browser. Textual Viewer displays details of the point in alarm and Operation/Extended Operation displays any properties and commands of the point in alarm.

If you are handling the alarm from the Assisted Treatment window, Operation/Extended Operation in the Contextual pane displays any properties and commands of the point in alarm.

5.5.9.12 Viewing the Intervention Text

Before proceeding with alarm handling, you may want to view the intervention text of a specific event.

You have selected an event, and the intervention text icon is available in the event descriptor [➡️ 84].

- Click Intervention Text.

The event descriptor displays the available technical information (if any). To hide this text, click the same icon again.
5.5.9.13 **Handling Events from the Event Detail Bar**

**NOTICE!** The following procedures apply only when working in Client Profiles BA_EN and TBS_EN.

You can perform Fast Treatment, and start Investigative or Assisted Treatment from the Event Detail bar.

**Performing Fast Treatment**
1. In the Event Detail bar [→ 80], click the event button [→ 83].
2. Proceed as described in Using Fast Treatment [→ 117].

**Performing Investigative or Assisted Treatment**
1. In the Event Detail bar [→ 80], double-click the event button [→ 83].
2. Depending on the availability, proceed as described in:
   - Using Investigative Treatment [→ 118]
   - Using Assisted Treatment [→ 119]

5.5.9.14 **Using the Contextual Pane in Alarm Handling**

During alarm handling, you may want to display the Contextual pane to:
- Inspect the properties of the point in alarm
- View and execute any commands/actions available for that object
- View a detailed log of the event currently being handled

1. In the window header, click one of the layout icons that includes the Contextual pane:
   - (Event List)
   - (Investigative Treatment and Assisted Treatment windows)
2. To hide the Contextual pane, click the splitter button( ) or select one of the available layouts that do not include that pane ( ).

5.5.10 **Using Fast Treatment**

Fast Treatment provides alarm-handling commands [→ 103] that you select to handle an event. A brief description of the next action to take (which command to select) is also included in the event descriptor.

When you handle an event, you can send the available commands to the source object that caused the event and completely handle an event or suspend alarm handling.

**Starting Fast Treatment**
- In Event List [→ 81], select [→ 112] the event.

**Fast Treatment Workflow**
1. Acknowledge [→ 112] the event.
2. If available by configuration:
– Silence/unsilence [→ 113] a field panel.
– Start/stop [→ 114] remote notifications.

3. Once the cause of the alarm is gone, reset [→ 112] the event.


5.5.10.1 Handling Multiple Events with One Command

You can handle multiple events simultaneously, regardless of the event category or discipline to which they belong.

Event List [→ 81] displays on the screen and you want to handle multiple events simultaneously.

1. Click an event descriptor [→ 84].

2. Do one of the following:
   – Use CTRL+A to select all the events.
   – Hold CTRL, and click to add events, one-by-one, to the selection.
   – Hold SHIFT and click to add a contiguous set of events to the selection.
   To unselect an event in a selection, press CTRL.
   ⇨ The selection includes multiple events. Alarm handling is in progress and the available commands are active. Each command is available if at least one of the selected events has this command.

3. According to commands availability, proceed as follows:
   – Acknowledge [→ 112] the events.
   – If available by configuration:
     - Silence/unsilence [→ 113] the field panel.
     - Start/stop [→ 114] remote notifications.
   – Once the cause of the alarm is gone, reset [→ 112] the events.
   – Close [→ 113] the events or suspend [→ 113] them.
   ⇨ Each command is sent to all the events in the selection.

5.5.11 Using Investigative Treatment

Investigative Treatment is available in a specific window [→ 105] and allows you to send alarm-handling commands [→ 103] while investigating the alarm occurred in the building control site.

Starting Investigative Treatment

● In Event List [→ 81], double-click an event button [→ 83].
   ⇨ The Investigative Treatment window [→ 105] displays in the work area. The details of the event and any available alarm-handling commands (Acknowledge, Reset, and so on) display in the event detail pane. In System Browser, the corresponding event source point is highlighted. Any other available applications display additional information/commands related to the same event source.

Investigative Treatment Workflow

1. Acknowledge [→ 112] the event.
2. Investigate the cause of the alarm.
3. If available by configuration:
– Silence/unsilence [113] the field panel.
– Start/stop [114] remote notifications.

4. Once the cause of the alarm is gone, reset [112] the event.

5. Close [113] the event or suspend [113] it.

**Operation Tips**

- Investigative Treatment for an event is suspended if you start Investigative Treatment of another event.
- The Investigative Treatment window automatically closes when alarm handling is complete or when you suspend Investigative Treatment.

5.5.12 **Using Assisted Treatment**

Assisted Treatment is available in a specific window [106] that provides a list of procedural steps not available in Fast Treatment and Investigative Treatment.

The assisted procedure may include:
- Checking a map of where an alarm is taking place
- Sending an email
- Printing event data

For more details, see Assisted Treatment Steps [111].

**Starting Assisted Treatment**

- In Event List [81], double-click an event button [83].

  The Assisted Treatment window [106] displays in the work area. The details of the event being handled and any available alarm-handling commands (Acknowledge, Reset, and so on) display in the event detail pane. The assisted procedure displays in the Selection pane. It contains the list of steps that you must (or optionally can) execute.

**Assisted Treatment Workflow**

1. Acknowledge [112] the event.
2. Follow [120] the assisted procedure.
3. If available by configuration:
   - Silence/unsilence [113] the field panel.
   - Start/stop [114] remote notifications.
4. Once the cause of the alarm is gone, reset [112] the event.
5. Close [113] the event or suspend [113] it.

**Operation Tips**

- The alarm-handling of the current event is suspended if you start Assisted Treatment of another event.
- Assisted Treatment provides a list of either optional or mandatory procedural steps [109] that you perform and then check off. An exclamation mark indicates those steps that are mandatory.
  In some cases, you may be required to perform the steps of the procedure in sequential order, while in other cases you may be able to do them in a different order.
- If you see a step *automatically* checked off in the assisted procedure, this means that this step was automatically executed (either when the event occurred, when you initiated alarm handling, or depending on configuration).
The Assisted Treatment window automatically closes when the event is fully handled, or when you suspend Assisted Treatment.

5.5.12.1 Following the Assisted Procedure

The Assisted Treatment window [→ 106] displays on the screen, with the steps of the procedure listed in the pane on the left. The available steps and the order in which they appear in the list may vary depending on configuration. They can include:
- Alarm Printout [→ 123]
- Document Viewer [→ 121]
- Graphics [→ 48]
- RENO Messages [→ 121]
- Report [→ 123]
- Alarm-handling Form [→ 124]

1. From the list on the left, select a step to start carrying it out.
   - The tools and information for performing that step display in the Primary pane.

2. Perform any task required for the selected step.

3. When you have carry out the task, check off the step by clicking the white check box.

   NOTE: If you complete the task and a gray check box displays instead of a white one, this means that you still need to carry out some other step in the procedure first before being able to check off the step.

   Once you check off a step a checkmark displays in place of the check box to indicate the step was completed, and an execution status icon underneath it indicates the outcome (success/failure/and so on) of the step.

Assisted Procedures Tips

- Steps displayed with an exclamation mark are mandatory, while the other steps are optional. Depending on the configuration, you may or may not have to follow the steps in the order they appear in the list.
- The steps may need to be followed in the order they appear in the list, but not always and this is configuration-dependent.
- You must complete all the mandatory steps before closing the event. If you haven’t completed those steps, the event status is Waiting for condition and the Close command is unavailable. In such a scenario, if you click the event button to suspend event handling the suggested action is Complete Operating Procedure.
- If you want to see all the events that still have mandatory steps that need to be completed, use Waiting for condition to filter by event status. As you cannot distinguish events that have mandatory steps, once you apply the Waiting for condition filter, start Assisted Treatment and check if any of the step in an assisted procedure has the exclamation mark which means that a step is mandatory.
- If you are in the middle of an assisted-treatment procedure for an event, and recurrences of the same event happen in the system, a message box may display informing you that the procedure has been reset. In this case you will have to perform again any steps previously marked as executed.
5.5.12.2 Viewing a Document

The Document step allows you view instructions or other important information contained in a file or a Web page.

The Assisted Treatment window [⇒ 106] displays on the screen.

1. From the Steps list, select the document step text.
   - The related application displays in the Default tab of the Primary pane.
2. Read the file (document or web page) carefully and follow any instruction.
3. Click Backward or Forward to navigate through and read other document-related items, if any.

NOTE:
If a PDF file displays, you can also click Zoom in or Zoom out to quickly zoom in and out the document, or click Print to print the document.

5.5.12.3 Handling a Remote Notification

The Reno step enables you to send important event detail information using an SMS (Short Message Service) or email directly from the system. If the remote notification does not start automatically, it may be a step in the treatment procedure where you manually tell the system to start it. When you initiate the step, the system keeps you informed of the message status.
The Assisted Treatment window [106] displays on the screen.

1. From the Steps list, select the remote notification step text.
   - The related application displays in the Default tab of the Primary pane.

2. Depending on the remote notification type (automatic or manual) and commands availability click:
   - **Start RENO procedure** to manually start the remote notification or to send the remote notification again (either manual or automatic).
   - **Stop RENO procedure** to abort an automatic, but time-delayed remote notification or stop monitoring the message status for a manual remote notification.
   - **Stop RENO procedure escalation** to stop the remote notification escalation for the selected recipient group.

3. *(Optional)* Select a recipient in the Message Status area to view the message sent in the Message area.

   - Depending on the result of the remote notification procedure, the steps status becomes one of the following:
     - **Successful**, the remote notification message status is *Completed*.
     - **Failed**, the remote notification message status is *Aborted, Partially failed or No Response* but you can mark the step as executed.
     - **Failed**, the remote notification message status is *Failed*, and you cannot mark the step as executed.
5.5.12.4 Printing Event Details

The Alarm Printout step allows you to print the details of an event. Depending on the execution mode, the event details are printed automatically or manually.

1. From the Steps checklist, select the **Alarm Printout** text.
   - The configured report displays with the event related information in the Default tab of the Primary pane. When you select this step for the first time, a new report is generated. On subsequent selection, the same report is reloaded.

2. Enter the information in the form controls (if present), save, and route the information to a file, email, or printer as configured.

5.5.12.5 Generating and Printing a Report

The Report step allows you to generate and print a report. Depending on the execution mode, the report is printed automatically or manually.

1. From the Steps checklist, select the **Report** text.
   - The configured report displays with the event related information in the Default tab of the Primary pane. A new report is generated each time you select this step.

2. Enter the information in the form controls (if present), save, and route the information to a file, email, or printer as configured.
5.5.12.6 Completing an Alarm-handling Form

The Treatment Form step allows you to enter event related information in a report for operating procedures [→ 220].

1. From the Steps checklist, select the **Treatment Form** text.
   - The configured report displays with the event related information in the **Default** tab of the Primary pane. When you select this step for the first time, a new report is generated. On subsequent selection, the same report is reloaded.

2. Enter the information in the form controls [→ 236], save [→ 223], and route [→ 223] the information to a file, email, or printer as configured.

5.5.13 Managing Recurring Events

Recurring events (subsequent events) are a set of events belonging to the same category, and generated by the same event point property that continuously switches from **active** to **quiet** status and vice versa.

These events appear grouped under a parent event (acting as container) designated by the Counter column in the event descriptor that indicates the total number of detected child recurrences. Any time a new recurrence is generated, the counter automatically increments.

The parent event always displays the newest recurrence (which also corresponds with the first recurrence of the set), and the following summary information:

- Event status of the most important recurrence (priority order is Unprocessed, Waiting for condition, or Ready to be closed)
- Event source status of the most recent recurrence
- Event ID identified by [...] indicating the range between the first and the last recurrence (for example, 3201…3245)

Even though the counter is visible in the Event Detail bar, Event List, and Investigative/Assisted Treatment, you can display recurring events only from Event List.

**Recurring Events and Event Handling**

- When you handle recurring events, you cannot filter Event List; however you can first filter Event List, and then display recurring events.
- Investigative Treatment workflow is the same as for non-recurring events.
- Assisted Treatment workflow is the same as for non-recurring events. Depending on the configuration, either an assisted procedure specific for each
5.5.13.1 Handling Recurring Events from Event List

In Event List, the Counter column for an event contains a number. This means that it is a recurring event that includes some recurrences.

1. In Event List, click the counter for the event.

   NOTE: During the selection, you may either individually select a single parent event (with all its child recurrences) or multiple parent events. For multiple selections, you must select either only parent events or only child recurrences of the same parent event (for example, you cannot select a parent event and any child recurrence belonging to another parent event).

   All the recurrences appear as smaller event buttons under the selected parent event button(s) (each acting as a container of recurrences) followed by the event descriptors. The first recurrence is the one having the highest priority. The Commands column of the parent event contains all the available alarm-handling commands.

2. According to command availability, do the following:

   - Acknowledge the event(s).
   - If available by configuration:
     - Silence/unsilence a field panel.
     - Start/stop remote notifications.
   - Reset the event(s).
   - Close the event(s) or suspend it.

When acknowledging recurring events...

- If you acknowledged the first recurrence (which always corresponds with the parent event), its event button stops flashing, as well as the parent event button.
- If you acknowledged a recurrence which is not the first in the set, only the corresponding button stops flashing.
- If you acknowledged the parent event, all the event buttons of the child recurrences stop flashing.

When handling an individual recurrence...

- The selected command is sent only to it.

When the first recurrence is fully handled...

- It disappears from the set and the event details for the parent event refresh to display data related to the next (by date and time) child recurrence.

NOTE: You cannot collapse (or hide) Event List while recurrences display. Click the counter again to hide the recurrences. Then, collapse (or hide) Event List.
5.5.13.2 Handling Recurring Events with All-in-One Action

All-in-one action means that you can handle all the child recurrences under a parent event by simply selecting the parent event and sending the available alarm-handling commands. You can perform this procedure from the Event Detail bar, Event List, Investigative Treatment, and Assisted Treatment windows.

The Counter column for an event contains a number which means that this is a recurring event [⇒ 124] that includes several recurrences.

1. Select the recurring event.
2. According to command availability, do the following:
   - Acknowledge [⇒ 112] the event.
   - If available by configuration:
     - Silence/unsilence [⇒ 113] a field panel.
     - Start/stop [⇒ 114] remote notifications.
   - Reset [⇒ 112] the event.
   - Close [⇒ 113] the event or suspend [⇒ 113] it.

Each alarm-handling command is sent to all the child recurrences. A message box informs you that all the recurrences relating to the same category and generated by the same event source received this command.
6 Remote Notifications

The system has the capability to manage remote notification (RENO) messages whether they are configured in the system and triggered by alarms, or you need to send a new remote notification (instant message) to configured contacts (recipients).

Alarm-based Remote Notifications

If a point is in alarm, you can view the related remote notification message provided by configuration.

These messages are delivered using email, SMS, or pagers to one or more groups of pre-defined recipients.

Each recipient of a group is a potential notification candidate for alarms, and is notified if pre-defined conditions arise. Once a notification is sent, one or more recipients can respond to the notification, and acknowledge the message.

When handling an alarm-based remote notification, you can:
- Manually send the preconfigured remote notification (in cases where it is not sent automatically by the system).
- Depending on the commands that are available:
  - Re-send the remote notification (whether manual or automatic)
  - Abort a time-delayed automatic remote notification, or stop monitoring the message status for a manual remote notification
- Stop escalation of the remote notification for a recipient group

NOTE:
Responding to an alarm-based remote notification indicates that the contact has received the message. It does not mean that the contact has acted on whatever caused the alarm or event.

New Remote Notification

The operator monitoring the system can also decide to compose and send a New remote notification, meaning one that is not preconfigured and triggered by an alarm.

This message is delivered using email, SMS, or pagers to one or more groups of recipients you define.

Each recipient of a group is a potential notification candidate of this message. Once the notification is sent, one or more recipients can respond to it, and acknowledge the message.

When handling a new remote notification, you can:
- Switch to Edit mode to compose (define message text, recipients, and escalation rules) and send the remote notification
- Re-send again the notification if necessary
- Stop monitoring the status of the notification
- Stop escalation of a remote notification for a recipient group
- Clear the sent notification message

Remote Notification Event Log

When working with remote notifications, entries are recorded in the History database tracking the progress of remote notifications (such as, remote notification devices status error, remote notification creation/deletion or start/stop, and so on).
6.1 Remote Notification Messages Workspace

The RENO Messages workspace is where you monitor and handle all types of remote notifications, whether they are alarm-based (preconfigured in the system) or new (operator-issued, including those sent from different stations). It is divided into a Message Status area on the left that lists the notifications and their outcomes, a Message area on the right that provides further details about the selected message, and a toolbar for performing certain actions. Depending on the specific workflow, RENO Messages may display in either the Primary or the Secondary pane, and it will list the remote notifications relevant to the current selection or task.

<table>
<thead>
<tr>
<th>Primary Pane Scenario</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Selection</strong></td>
</tr>
<tr>
<td>Application View &gt; Applications &gt; Remote Notifications</td>
</tr>
<tr>
<td>Application View &gt; Applications &gt; Remote Notifications &gt; [Remote Notification]</td>
</tr>
<tr>
<td>Management View &gt; Project &gt; System Settings &gt; Related Items Templates &gt; New Remote Notification</td>
</tr>
<tr>
<td>In Fast/Investigative Treatment, point in alarm</td>
</tr>
<tr>
<td>In Assisted Treatment, Reno step of an operating procedure</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Secondary Pane Scenario</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Selection</strong></td>
</tr>
<tr>
<td>New Remote Notification in Related Items pane</td>
</tr>
</tbody>
</table>
Example of Alarm-based Remote Notifications

Example of New Remote Notification Message from Secondary Pane
**Assisted Treatment – Example of Remote Notification Operating Procedure Step**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
<th>New notifications</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Back to configuration icon]</td>
<td>Back to configuration</td>
<td>-</td>
<td>Available only from the Secondary pane. It lets you switch to Edit mode to compose and send a new (operator-issued) notification.</td>
</tr>
<tr>
<td>![Start RENO procedure icon]</td>
<td>Start RENO procedure</td>
<td>Initiate a <em>manual</em> remote notification. This command becomes unavailable while the system is sending the message. It may then become available again to let you resend the notification message.</td>
<td>If available, it lets you send the notification message again.</td>
</tr>
<tr>
<td>![Stop RENO procedure icon]</td>
<td>Stop RENO procedure</td>
<td>Aborts a time-delayed automatic remote notification or stop monitoring the message status for a manual remote notification. This command is available only if this option was configured and the <em>automatic</em> remote notification is time-delayed, or the <em>manual</em> remote notification is in the <em>Running</em> state and the entire notification is not yet completed. Once you stop a notification, you cannot restart it (the notification status changes to <em>Aborted</em>).</td>
<td>Stop monitoring the message status.</td>
</tr>
<tr>
<td>![Stop RENO procedure escalation icon]</td>
<td>Stop RENO procedure escalation</td>
<td>Stops escalation of the remote notification message for the selected recipient group. An escalation is an increase in the number of recipients for a group. If not enough people in the original group respond, the notification can then be sent to an additional set of recipients.</td>
<td></td>
</tr>
</tbody>
</table>
Remote Notifications

Remote Notification Messages Workspace

This command is available when you select the original recipient group, and the escalation has not yet started.

| Clear manual procedure | Visible but dimmed. | Clears the selected message. This command is available once sending is completed or monitoring is stopped. |

Message Status Area – Unexpanded Remote Notifications

Alarm-based remote notifications are listed with the following details:
- Remote notification procedure name
- Alarm ID
- Type of sending (Automatic/Manual)
- Remote notification outcome

For example, test – Alarm ID 29 Automatic Completed.

New remote notification messages are listed with the following details:
- Type of sending (always Manual)
- Date and time
- Remote notification outcome

For example, Manual 1/24/2013 Failed

Remote Notification Outcome

The outcome listed alongside an alarm-based remote or new notification indicates the end result (for example, Completed or Failed) of the notification as a whole:
- Completed: depending on configuration, this may mean only that the remote notification was successfully sent, or it may mean that the remote notification was successfully sent and acknowledged by the recipients.
- Partially failed: the remote notification was successfully sent, but at least one of its recipient groups failed to acknowledge the message.
- No response: the remote notification was successfully sent, but all the recipient groups failed to acknowledge the message.
- Failed: the system was unable to send any of the messages.
- Aborted: the operator stopped the remote notification.

Message Status Area – Expanded Remote Notifications Details

When you expand a remote notification in the list, you can see additional details about the notification itself (these vary depending on whether it is alarm-based or new) and its recipients. This lets you monitor:
- Progress and outcome of the notification for each recipient group
- Escalation of the notification for any recipient group
- Progress and outcome of the notification for individual recipients

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Procedure Data</td>
<td>Expander at shows additional details about the remote notification as a whole.</td>
</tr>
<tr>
<td>Type</td>
<td>Type of message sending (Manual/Automatic).</td>
</tr>
<tr>
<td>Starting in</td>
<td>For automatic notifications, the time left before the remote notification message is sent (delay).</td>
</tr>
<tr>
<td>Trigger</td>
<td>Details about the condition that triggered the notification:</td>
</tr>
<tr>
<td></td>
<td>• Trigger: type of trigger (for example, Alarm)</td>
</tr>
<tr>
<td></td>
<td>• Category: event category (for example, Life Safety)</td>
</tr>
</tbody>
</table>
Remote Notifications
Remote Notification Messages Workspace

- Date: date the alarm occurred
- Time: time the alarm occurred
- Alarm ID: event identifier (for example, Alarm ID 44)
- Point state: point state that triggered the notification (Genuine, or All, or Maintenance)

<table>
<thead>
<tr>
<th>Source</th>
<th>Details about the source of the event that triggered the notification:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>- Source (for example, Analog Value 1)</td>
</tr>
<tr>
<td></td>
<td>- Location</td>
</tr>
<tr>
<td></td>
<td>- Discipline (for example, Building Automation)</td>
</tr>
<tr>
<td></td>
<td>- Sub-discipline</td>
</tr>
<tr>
<td></td>
<td>- Type (for example, Value)</td>
</tr>
<tr>
<td></td>
<td>- Sub-type (for example, Analog)</td>
</tr>
</tbody>
</table>

New Remote Notification Details

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date and time</td>
<td>Date: date you sent the message</td>
</tr>
<tr>
<td></td>
<td>Time: date you sent the message</td>
</tr>
</tbody>
</table>

Recipients

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recipients</td>
<td>A notification can be addressed to one or more first-level recipient group(s). Each group can also have a list of additional escalation recipients defined, to use in case the main group members can’t be reached. Each recipient of a notification has a primary and a fallback device. The remote notification is first sent using the current available device. If the primary device fails, the notification is automatically switched to the fallback device. If the fallback device fails, the system will retry the primary device. If the primary device fails again, the system stops trying to send the message and the recipient status becomes Not Reachable. Diagnostic messages display if the device is faulty/misconfigured/disabled. For each recipient group, the following information displays: Group name Status: outcome of the notification to the group as a whole Replies and Threshold: how many group members have replied and what is the minimum required number of replies Timeout for the group: time limit for receiving the required number of replies from this group. <strong>NOTE:</strong> When many clients and many remote notification messages are involved, the system ensures that all the timers are aligned. List of the individual members of the group, with the name, preferred (PR) and fallback (FB) devices, and notification status of each. Stop is the status that displays when you stop the escalation. If the group has escalation recipients, the following also displays: Status: outcome of the escalation as a whole. Replies and Threshold: how many escalation recipients have replied and what is the minimum required number of replies. List of the individual escalation recipients, with the name, preferred (PR) and fallback (FB) devices, notification status and timeout for each one. <strong>Pending</strong> is indicated in the interval of time before timeout expires. <strong>NOTE:</strong> When many clients and many remote notification messages are involved, the system ensures that all the timers are aligned.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Recipients</td>
<td></td>
</tr>
</tbody>
</table>
Status Indicates the progress or outcome of a remote notification whether sent to an individual recipient or to a group as a whole:
- Empty: the remote notification has not initiated yet.
- Running: the remote notification has been initiated.
- Pending: the message has been sent to the designated recipient(s) and the timeout for a response has not yet elapsed.
- Acknowledged: the designated recipient(s) replied within the timeout.
- Not Reachable: the system failed in sending the message to both the preferred and the fallback device.
- Timed out: the system received the recipients’ replies after the timeout expiration.
- Cancelled: the operator halted the remote notification during its execution.

Replies Group reply threshold. For example, Replies: 1/2 means that at least one of the two recipients belonging to the group must reply for this message to be considered acknowledged.

Timeout Current timeout within which the recipients belonging to a group must reply (Processing displays in the interval of time before timeout expires).

NOTE: When many clients and many remote notification messages are involved, the system ensures that all the timers are aligned.

When you select a recipient in the Message Status area on the left, the sent message displays in the Message area on the right.

The following table explains the meaning of what you see in the Message Status area during the course of a remote notification (from start to finish). Notice that the status (outcome) of the notification procedure as a whole, the notification status of recipient groups, and the notification status of individual contacts are all different.

<table>
<thead>
<tr>
<th>Status</th>
<th>When....</th>
</tr>
</thead>
<tbody>
<tr>
<td>RENO Outcome</td>
<td>Group(s)</td>
</tr>
<tr>
<td>Initialized</td>
<td>—</td>
</tr>
<tr>
<td>Aborted</td>
<td>Cancelled</td>
</tr>
<tr>
<td>Running</td>
<td>Pending</td>
</tr>
<tr>
<td>Running</td>
<td>Processing</td>
</tr>
<tr>
<td>Running</td>
<td>Acknowledged</td>
</tr>
</tbody>
</table>
| Running         | Timed out                   | Acknowledged Timed out Pending | ● Some recipients have replied, some are still pending, and others have timed out. ● The groups’ thresholds have not been reached. ● The groups’ timeouts are expired. ● Some second-level recipients did not reply and it is no longer
6.2 New Remote Notification Workspace

When you open RENO Message in the Secondary pane, you can switch to New Remote Notification workspace. Here you can compose a message, define the recipients, and send an operator-issued remote notification, meaning one that is not triggered by an alarm.
Remote Notifications

New Remote Notification Workspace

New Remote Notification – Edit Mode

New Remote Notification Toolbar.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Send this message</td>
<td>Once you have composed the remote notification (recipients and message text) this lets you switch back to RENO Messages [→ 128] to monitor the sending of your message.</td>
</tr>
<tr>
<td></td>
<td>Clear all message data</td>
<td>Clears all fields.</td>
</tr>
</tbody>
</table>

Recipient/Members

In the Recipients expander, the Recipient column lists the group or groups to which the message is addressed, while the Members column shows the number of individual recipients in each group. You can add and remove recipients from this section by linking them from the Address Book, but at least one group is required. You cannot add individual people as recipients here.

Escalation Rules

In the Recipients expander, the Escalation Rules section on the top right lets you specify, for each recipient group, when that group can be considered successfully notified, and what escalation actions to take if sending to that group fails. Specifically, you can set a response timeout for the group and a threshold defining how many (or what percentage) of the group’s members must have replied within that time. Then you can also specify a list of escalation recipients, to whom the
message should be sent if the group does not reach its response threshold within the timeout.

### Escalation Rules Fields

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| Threshold                           | Specifies how many (or what percentage) of the people in a recipient group need to reply for the system to consider that group successfully notified. Default is 0. The range of values available depends on the units you select:  
  - If you set the threshold as a percentage, the valid range is 0 to 100%.  
  - If you set the threshold as number of people, the valid range is 0 to the total number of members in the group. |
| Timeout                             | Specifies the amount of time (in seconds), the system waits for the members of a group to respond. Default is 30. Range is 0 through 3600 seconds: This value can be set in multiples of 30 seconds; if you enter a value that is not a multiple of 30, the number is automatically rounded up or down. |
| Escalation threshold                | Specifies how many (or what percentage) of the people in the escalation list need to reply for the escalation to be considered successful. Default is 0. The range of values available depends on the units you select:  
  - If you set the escalation threshold as a percentage, the valid range is 0 to 100%.  
  - If you set the escalation threshold as the number of people, the valid range is between 0 and the total number of contacts in the escalation list. |
| Escalation Recipient/Groups/Timeout | For each group, you can also specify a list of escalation recipients, to be used if the group doesn’t reach its response threshold within the timeout. You do this by linking escalation recipients from the Address Book to the escalation list area. The columns specify the recipient’s name, the group(s) to which that person belongs, and the timeout for receiving a reply from that person. This field is optional; you can add and remove individual escalation recipients. |

### Address Book

In the Recipients expander, the Address Book section on the bottom right displays the available contacts from which you can select the recipients of a remote notification. To select the first-level recipient groups of a remote notification, Link (drag-and-drop) groups from the Address Book to the Recipient/Members area on the left. (Note that first-level recipients can only be groups, and not individual contacts). To select the escalation recipients of a remote notification you instead link (drag-and-drop) individual contacts from the Address Book to the Escalation Recipient area on the top right.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter</td>
<td>Select whether you want to view the Groups or individual People available in the system’s Address Book [➙ 357] to link to the Recipient (only groups) or Escalation (individual contacts) lists.</td>
</tr>
<tr>
<td>Search by</td>
<td>Text search field to quickly find the contacts you want among the listed group(s)/recipients.</td>
</tr>
</tbody>
</table>
Recipient/Groups or Group/Members  | Depending on whether you set the Filter to People or Groups, shows either the list of individual contacts or the list of groups available in the Address Book. Groups are listed showing the name of the group (Group), and the contacts (Members) belonging to that group. Recipients are listed showing the person’s name (Recipient), the name of the group(s) to which that person belongs (Group), and their Preferred Device and Fallback Device.

Message Tailoring

Once you have defined the recipients of the remote notification, you can compose the message by completing the following fields:

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Language</td>
<td>Specify the recipient’s language to localize the fixed portion of the message. This field is required. Default is en_US.utf8 (English - United States).</td>
</tr>
<tr>
<td>Device</td>
<td>Specify the type of remote notification method to use.</td>
</tr>
<tr>
<td>Subject/Body</td>
<td>Specify any message tags from those listed on the right. You can also directly enter text, including in between the tags, and change the order of the tags (copy/cut/paste/drag-and-drop). The Subject field is only available if you select the email device.</td>
</tr>
<tr>
<td>Message Tags</td>
<td>Lists the available message you can use in the message:</td>
</tr>
<tr>
<td></td>
<td>- Date/Time Limited</td>
</tr>
<tr>
<td></td>
<td>- Date/Time Complete</td>
</tr>
<tr>
<td></td>
<td>- Sender Short name</td>
</tr>
<tr>
<td></td>
<td>- Sender Full name</td>
</tr>
<tr>
<td></td>
<td>- Workstation</td>
</tr>
</tbody>
</table>

6.3 Working with Remote Notifications

The following procedures describe how to perform various tasks involving alarm-based or new remote notifications.

For information about how to handle the remote notification step in Assisted Treatment, see Handling a Remote Notification [121].

6.3.1 Viewing the RENO Messages List

You can access the RENO Messages list from a variety of starting points, including by selecting:

- Remote Notifications in System Browser Application View
- A remote notification available under the Remote Notifications node
- New Remote Notification in System Browser Management View
- Point in alarm during event treatment

The ability to view remote notifications depends on your user privileges. If you have the requisite user privileges, you can access the RENO Messages list in one of the following ways:
Remote Notifications

Working with Remote Notifications

Selecting Remote Notifications
1. In System Browser, select Application View.
2. Select Applications > Remote Notifications.
   ✤ RENO Messages displays in the Primary pane, and lists all the remote notifications available in the system (that is, all the preconfigured alarm-based notifications as well as any new remote notifications composed and sent by the operator).

Selecting a Remote Notification
1. In System Browser, select Application View.
2. Select Applications > Remote Notifications, and then select the desired remote notification.
   ✤ RENO Messages displays in the Primary pane, and lists all the alarm-based remote notifications for the selected node.

Selecting New Remote Notification
1. In System Browser, select Management View.
   ✤ RENO Messages displays in the Primary pane, and lists all the new remote notification messages composed and sent by you.

Selecting a Point in Alarm
▷ A point is in alarm and RENO Message tab is available in the Primary pane.
   You want to view the associated remote notification.
1. In System Browser, select the point in alarm.
2. Select the RENO Messages tab, if not yet selected.
   ✤ RENO Messages displays in the Primary pane, and lists alarm-based remote notifications for the selected point.

6.3.2 Enabling a Remote Notification
If an alarm-based remote notification is not enabled by configuration, you need to enable it before any operators or stations can dispatch it. The enabled status applies to all users of the system, so that enabling a remote notification means that any authorized users will be able to dispatch it.
To enable a remote notification proceed as follows:
▷ The remote notification is currently inactive (its status in the Contextual pane is Disabled), and you want to enable it.
1. In System Browser, select Application View.
2. Select Applications > Remote Notifications.
3. Under Remote Notifications, select the remote notification you want to enable.
4. To enable the remote notification, in the Operation tab of the Contextual pane, click Enable.
   ✤ The status of the current remote notification changes to Enabled.
6.3.3 Disabling a Remote Notification

Disabling a remote notification prevents it from being dispatched by any operators or stations, while still retaining the remote notification within the system. For example, you might do this for remote notifications that are not yet complete or ready to be put into general use.

To disable a remote notification proceed as follows:

- The remote notification is currently active (its status in the Contextual pane is Enabled), and you want to disable it.

1. In System Browser, select Application View.
2. Select Applications > Remote Notifications.
3. Under Remote Notifications, select the remote notification you want to disable.
4. To disable the remote notification, in the Operation tab of the Contextual pane, click Disable.

The status of the current remote notification changes to Disabled.

NOTE:
When you disable a remote notification, the management system generates an event. This event is automatically cleared when you re-enable the remote notification.

6.3.4 Handling an Automatic Alarm-Based Remote Notification

The system can automatically send the remote notification message to a preconfigured set of recipients as soon as defined alarm conditions arise or after a pre-defined time delay. You can monitor the progress of this type of remote notification and optionally control it as follows.

- One of the following scenarios occurs:
  - You are processing an alarm and RENO Messages displays in the Primary pane.
  - You have selected a remote notification configured in the system and available when navigating the Application View (Applications > Remote Notifications).

- The message status tells you that the remote notification type is automatic. For example, Alarm ID 29 Automatic.

1. In the Message Status area, select a remote notification.
2. While monitoring the progress of a remote notification, depending on the commands available in the RENO Messages toolbar, you can optionally do one or more of the following:
   - To send the remote notification again, click Start RENO procedure.
     This operation is the same as starting [114] a remote notification using the command in the event descriptor during event treatment.
     During the send operation, the icon is dimmed.
   - To abort an automatic time-delayed remote notification, click Stop RENO procedure.
     This operation is the same as stopping [114] a remote notification using the command in the event descriptor during event treatment.
If the operation completes successfully, the remote notification status becomes **Aborted** and you cannot restart it; the status of pending recipients becomes **Cancelled**.

- To stop the escalation for a group of a remote notification before it starts, under **Recipients**, select the **group** for which you want to stop the escalation, then click **Stop RENO procedure escalation**.

  You can only stop one escalation at a time. If there is more than one recipient group with an escalation list, to stop all escalations you must select each group in turn and repeat this step to disable its escalation.

- The escalation for the selected group is now disabled. If the group does not reach its threshold of required responses, the escalation (if any) does not start. The status of the groups and recipients involved becomes **Stop**.

- To view the content of a message sent to a recipient, expand the remote notification, and under **Recipients**, select the appropriate **recipient**.

  The message displays in the Message area.

### 6.3.5 Handling a Manual Alarm-based Remote Notification

Depending on configuration, the system may allow you to manually send a remote notification message to preconfigured recipients when specified alarm conditions arise. You can monitor the progress of this type of remote notification and optionally control it as follows.

- One of the following scenarios occurs:
  - You are handling an event and RENO Messages displays in the Primary pane.
  - You have selected a remote notification configured in the system and available when navigating the Application View (Applications > Remote Notifications).

- The message status tells you that the remote notification type is **manual**. For example, **Alarm ID 40 Manual**.

1. In the Message Status area, select a **remote notification**.

2. To send the remote notification, click **Start RENO procedure**.

   This operation is the same as starting [→ 114] a remote notification using the command in the event descriptor during event treatment. During the send operation, the icon is dimmed.

3. While monitoring the progress of a remote notification, depending on the available commands in the **RENO Messages** toolbar, you can optionally do one or more of the following:

   - To send the remote notification again, click **Start RENO procedure**.

   - To stop monitoring the message status, click **Stop RENO procedure**.

     This operation is the same as stopping [→ 114] a remote notification using the command in the event descriptor during event treatment.

   - If the operation completes successfully, the remote notification status becomes **Aborted** and you cannot restart it; the status of pending recipients becomes **Cancelled**.

   - To stop the escalation for a group of a remote notification before it starts, under **Recipients**, select the **group** for which you want to stop the
You can only stop one escalation at a time. If there is more than one recipient group with an escalation list, to stop all escalations you must select each group in turn and repeat this step to disable its escalation.

The escalation for the selected group is now disabled. If the group does not reach its threshold of required responses, the escalation (if any) does not start. The status of the groups and recipients involved becomes Stop.

To view the content of a message sent to a recipient, expand the remote notification, and under Recipients, select the appropriate recipient.

The message displays in the Message area.

6.3.6 Editing, Sending, and Handling a New Remote Notification

You want to send a new remote notification message (meaning one sent on the initiative of the operator, rather than triggered by an alarm).

1. In Related Items, click New Remote Notification (icon or link).
   - The Secondary pane opens and displays New Remote Notification.

2. To choose the recipient group(s) of the message, do the following:
   - In the Address Book area, filter by Groups, and use the search field if needed to find the groups you want.
   - Drag and drop the group(s) you want to add from the Address Book to the Recipients/Members list on the left.

3. To define the escalation rules for a group, do the following:
   - Select a recipient group in the Recipients/Members area on the left.
   - In the Escalation Rules area on the right, enter a Timeout and a response Threshold for that group. This sets the number or percentage of group members that need to reply within the specified time for the group to be considered successfully notified.
   - To specify additional escalation recipients, to whom the message will be sent if the group doesn’t reach its threshold:
     - In the Address Book area, filter by People, and use the search field if needed to narrow down your choices.
     - Drag and drop the individual recipient(s) you want to add from the Address Book to the Escalation Recipient/Group/Timeout list.
     - Specify the Escalation Threshold, defining how many (or what percentage of) the contacts in the escalation list have to reply for the group’s escalation to be considered successful.

4. To compose the message to send, do the following:
   - Select the Language and Device.
   - Drag and drop the message tag(s) you want to add from Message Tags to Subject (E-Mail device only) and Body. Optionally, enter any additional text.

5. In the New Remote Notification toolbar, click Send this message.
   - The user interface in the Secondary pane switches to RENO Messages and the message is sent immediately.

6. While monitoring the progress of the remote notification, depending on the commands available in the RENO Messages toolbar, you can optionally do one or more of the following:
- To send the remote notification again, click Start RENO procedure.
- To stop monitoring the notification status, click Stop RENO procedure.
  ➤ If the operation completes successfully, the remote notification status becomes Aborted and you cannot restart it while the status of pending recipients becomes Cancelled.
- To stop the escalation for a group of a remote notification before it starts, under Recipients, select the group for which you want to stop the escalation, then click Stop RENO procedure escalation.
  You can only stop one escalation at a time. If there is more than one recipient group with an escalation list, to stop all escalations you must select each group in turn and repeat this step to disable its escalation.
  ➤ The escalation for the selected group is now disabled. If the group does not reach its threshold of required responses, the escalation (if any) does not start. The status of the groups and recipients involved becomes Stop.
- To view the content of a message sent to a recipient, expand the remote notification, and under Recipients, select the appropriate recipient.
  ➤ The message displays in the Message area.

7. To delete the remote notification, click Clear manual procedure.
  ➤ The remote notification is cleared.
  If you close the Secondary pane, all the remote notification that you sent are cleared.

8. To compose a new remote notification message, click Back to configuration, and repeat Steps 2 through 5. To clear any previous edited message, click Clear all message data.

6.3.7 Acknowledging Remote Notifications
When the recipients receive a remote notification message they can acknowledge the notification.

NOTES:
- Replying to a remote notification message stops the escalation, but it does not acknowledge an event.
- If recipients do not reply within the configured time frame, this will result in the message escalation to continue if configured to do so.

Recipients can acknowledge a notification in one of the following ways:
- Email: reply to the email message without adding any additional text
- SMS: reply to the SMS in one of the following ways:
  - Paste and send back the received text message, including the numeric code at the end of the received text message
  - Send a text message that contains the numeric code included at the end of the received text message
- Pager: notification acknowledge is not supported
7 Scheduler

7.1 Overview of Scheduler
You can set up schedules on management stations or on field panels at your facility. Calendars and time schedulers allow for creating and handling of switch programs for chronological control of specific plants and technical equipment.

Features
With Scheduler, you can do the following:
- Create calendars and associate them with schedules
- View daily and weekly schedules
- Create schedule entries from the weekly or daily view
- View schedule details
- Create exceptions to schedules
- Control BACnet command tables with schedules
- Copy current settings from one schedule to another

Scheduler Objects
Scheduler consists of the following object types:
- Management station calendars
- Management station schedules
- Management station time triggers
- BACnet calendars
- BACnet schedules
- BACnet command tables

7.2 Overview of Timeline Viewer
Timeline Viewer allows you to view the details of multiple management station and field panel schedules simultaneously, spanning a range of time. To do this, System Manager must be in Operating mode.

Adding Schedules
For automatic navigation, you select the schedules you want to view from System Browser, and the Timeline tab displays them by default. For manual navigation, you select the schedules you want to view from System Browser, and then click the Send button to have them display in the Timeline tab. While in manual navigation, you can also drag and drop schedules in the tab. Schedule names in the Timeline Viewer display in the same order as the schedules in System Browser.

Preset Time Periods
You can click the Zoom to Preset Time Period icon on the Timeline Viewer toolbar to select how much of the timeline is visible at once. The choices are 12 hours, 1 day, 3 days, 1 week, 2 weeks, or 1 month.

The Timeline Viewer accepts a maximum of 50 schedules. The less schedules you view, the more options you have with the preset time periods. The more schedules you view, the fewer options you have with the preset time periods.
Viewing Details in the Timeline Viewer
By moving your cursor over an entry in the Viewer, you can view schedule details, but you cannot edit them. Double-clicking a schedule’s details, however, sends the selection to the Default tab in the Primary pane. You can then click the Default tab and edit the schedule.

Color Indicators
A gray interval indicates that nothing has been scheduled for that period, and the schedule is in its default mode of operation. Other colors in the intervals indicate that something has been scheduled.

- If colors are assigned to the schedule from the text table, they will appear in the Timeline Viewer.
- If colors are not assigned to the schedule from the text table, they will default to blue.

Interval Types
Intervals are classified as one of four types:

- Default—not scheduled intervals (gray)
- Normal—scheduled intervals (solid colors)
- Exception—scheduled overrides to the normal schedule intervals (color-coded hatch marks)
- Inactive—not active interval (gray hatch marks)

Time Range Scrollbar
The Time Range scrollbar offers another way to control the displayed time span of schedules. The shorter the time span—one day, for instance—the more detail you can view. The longer the time span—one month, for instance—the less detail you can view.

The Time Range scrollbar contains a repeat function to make working with time ranges easier. Clicking to the left or right of the slider on the scrollbar moves it in the selected direction for the corresponding time range.

7.2.1 Timeline Viewer Workspace
### Overview of Timeline Viewer

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td><strong>Time Range Scrollbar</strong>&lt;br&gt;Allows you to control the date range of schedules.</td>
</tr>
<tr>
<td>2</td>
<td><strong>Schedule Name</strong>&lt;br&gt;Displays the name of the schedule with schedule details appearing on the row below it.</td>
</tr>
<tr>
<td>3</td>
<td><strong>Schedule Details</strong>&lt;br&gt;Hovering on an interval displays a tool tip with schedule details. Intervals also use color coding and hatch marks to provide basic information at a glance. Schedule details are view only.</td>
</tr>
<tr>
<td>4</td>
<td><strong>Timeline Toolbar</strong>&lt;br&gt;Includes the following time-adjustment controls:&lt;br&gt;* <strong>Show Today</strong>: Allows you to return to today's date and does not affect any preset time period you have chosen.&lt;br&gt;* <strong>Preset Time Periods</strong>: Allows you to choose one of six viewing options: 12 hours, 1 day, 3 days, 1 week, 2 weeks, or 1 month.&lt;br&gt;* <strong>Zoom In</strong>: Allows you to decrease the viewable span of the timeline (decrease the preset time periods).&lt;br&gt;* <strong>Zoom Out</strong>: Allows you to increase the viewable span of the timeline (increase the preset time periods).</td>
</tr>
<tr>
<td>5</td>
<td><strong>Date</strong>&lt;br&gt;Displays the date you are currently viewing. The date changes when you use either the <strong>Preset Time Spans</strong> or the <strong>Time Range</strong> scrollbar.</td>
</tr>
</tbody>
</table>

### 7.2.2 Working with Timeline Viewer

#### 7.2.2.1 Displaying the Timeline Viewer

- System Manager is in Operating mode

1. In System Browser, select Application View from the Views drop-down list.
2. Do one of the following:
   - Click Schedules > BACnet Schedules.
   - Click Schedules > Management Station Schedules.
3. Select the schedule(s) you want to display.
4. Click the Timeline tab.

   The Timeline Viewer displays the selected schedule(s).

#### 7.2.2.2 Adding a Schedule to the Timeline Viewer

- Timeline Viewer is open and displaying one or more schedules.

1. In System Browser, check the Manual navigation check box.
2. Navigate to the schedule you want to add to the Viewer.
3. Drag-and-drop the schedule in the Viewer.

   The system adds the schedule.
7.2.2.3 Bringing the Current Day into View

- Using the **Time Range** scrollbar, you have scrolled away from the current day and would like to return to it quickly.

- From the **Timeline** toolbar, select **Show Today**.

  **NOTE:** Selecting the **Show Today** icon does not affect any preset time period you have chosen.

7.2.2.4 Changing the Preset Time Span

1. From the **Timeline** toolbar, click **Preset time spans**.
2. Select the time span you want to display in the viewer.

   - The Timeline Viewer displays the new selection.

7.2.2.5 Zooming In

- You want to decrease the viewable span of the Timeline.

- From the **Timeline** toolbar, click **Zoom In**.

  **NOTE:** Each time you click the icon, the Timeline decreases to the next preset time period.

7.2.2.6 Zooming Out

- You want to increase the viewable span of the Timeline.

- From the **Timeline** toolbar, click **Zoom Out**.

  **NOTE:** Each time you click the icon, the Timeline increases to the next preset time period.

7.3 Management Station Scheduling

You can create daily or weekly schedules for your management stations, and a management station can run multiple calendars or schedules at the same time. Management station schedules and calendars run only if the management station is running.

You can also create exceptions to schedules. When a management station exception is ON, it overrides the weekly schedule. When the exception is OFF, control returns to the weekly schedule.

Additionally, management station schedules can process both BACnet and non-BACnet object types (BACnet schedules process only BACnet object types).

Management station schedules have only one binary output (value active or inactive). You can assign several objects to that output. For each assigned object, you can select the mode of action for the output value.
7.3.1 Management Station Calendars
Calendars allow you to override scheduled switch commands. In this sense, you can consider calendars as exception schedules, consisting of dates only. When you create a calendar, you can choose specific dates (January 15), a date range (August 1 – 31), or a week and a day you want the exception to run (third week of the month, on Wednesday). All calendars are associated with a schedule. For example, if you want to reduce energy costs in your building during company holidays, you can create a schedule with a calendar reference exception that commands equipment into holiday mode.

7.3.1.1 Management Station Calendar Workspace

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| 1    | New+ Button  
Opens a new calendar entry. |
| 2    | Applied Schedules  
Displays a list of schedules referencing the calendar. |
| 3    | Scheduler Toolbar  
Includes the following icons:  
**New+:** Opens a New BACnet Schedule, New Management Station Schedule, New BACnet Calendar, New Management Station Calendar, or New BACnet Command Table.  
**Save:** Saves the calendar to the system.  
**Save As:** Allows you to save another instance of the calendar with a different name and description.  
**Delete:** Deletes the calendar from the system. |
| 4    | Calendar Name  
Displays the name of the calendar. |
| 5    | Date Picker  
Displays a monthly calendar with entry dates highlighted. When first displayed or refreshed, the current day is selected by default. |
| 6    | Calendar Entries  
Displays a list of entries representing start and end dates and recurrence patterns. |
### 7.3.1.2 Adding a Management Station Calendar

1. In System Browser, select **Application View > Schedules > Management Station Calendars**.

2. From the **Scheduler** toolbar, click **Save**.

3. Complete the **Name** and **Description** fields.

4. Click **OK**.

### 7.3.1.3 Modifying a Management Station Calendar

1. In System Browser, select **Application View > Schedules > Management Station Calendars**.

2. Open the calendar you want to update.

3. To modify start dates, end dates, or recurrence settings, select a calendar entry from the **Calendar Entries** section, and then select the settings you want.

4. To delete a calendar entry, click **Delete**.

   **NOTE:** Do not click the **Delete** icon from the **Scheduler** toolbar, or you will delete the entire calendar.

5. Click **Save**.

### 7.3.1.4 Copying a Management Station Calendar

1. In System Browser, select **Application View > Schedules > Management Station Calendars**.

2. Open the calendar you want to copy.

3. Click **Save As**.

4. Complete the **Name** and **Description** fields.

5. Click **OK**.

### 7.3.1.5 Deleting a Management Station Calendar

1. In System Browser, select **Application View > Schedules > Management Station Calendars**.

2. Open the calendar you want to delete.

3. From the **Scheduler** toolbar, click **Delete**.

4. Click **OK**.
7.3.2 Management Station Schedules

Schedules consist of a name and description, a toolbar for working with the schedule, a date picker, several tabs (Schedule Entries, Outputs, Exceptions, and Setup), daily and weekly views, and schedule details.

More about Views

Even though you can schedule entries from the weekly view, the weekly view shows only the resulting schedule and not the details of the schedule. For more flexibility in visualizing and creating schedule entries, use the Schedule Entries tab instead.

Default Date

By default, every new schedule begins with the current date and never ends. Once a new schedule is opened, you can choose the start and end date for the schedule.

Default Schedule Behavior

When you select a management station schedule from System Browser, the Date Picker defaults to the current date, and the Schedule Entries tab becomes active.

7.3.2.1 Management Station Schedule Workspace

```
<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| 1    | **Schedule Name**  
   | Displays the name of the schedule. |
| 2    | **Scheduler Toolbar**  
   | Includes the following icons:  
   | *New*: Opens a New BACnet Schedule, New Management Station Schedule, New BACnet Calendar, New Management Station Calendar, or New BACnet Command Table.  
   | *Save*: Saves the schedule to the system.  
   | *Save As*: Allows you to save another instance of the schedule with a |
```
7.3.2.2 Adding a Management Station Schedule

1. In System Browser, select Application View > Schedules > Management Station Schedules.

2. From the Setup tab, complete the following:
   a) From the Start Date drop-down list, select the start date for the schedule. Selecting the Any date check box defaults to the current date.
   b) From the End Date drop-down list, select the end date for the schedule. Selecting the Any date check box defaults to an infinite date.

3. Click the Outputs tab, and then drag objects from System Browser you want associated with the schedule.

4. From the Scheduler toolbar, click Save.

5. Complete the Name and Description fields.

6. Click OK.
7.3.2.3 Copying a Management Station Schedule

1. In System Browser, select Application View > Schedules > Management Station Schedules.
2. Open the schedule you want to copy.
3. Click Save As.
4. Complete the Name and Description fields.
5. Click OK.

7.3.2.4 Deleting a Management Station Schedule

1. In System Browser, select Application View > Schedules > Management Station Schedules.
2. Open the schedule you want to delete.
3. From the Scheduler toolbar, click Delete.
4. Click OK.

7.3.2.5 Adding a Weekly Schedule Entry

1. In System Browser, select Application View > Schedules > Management Station Schedules.
2. Open the schedule to which you want to add a new weekly schedule entry.
3. Right-click in the schedule area.
4. Click Add New Weekly Schedule Entry.
5. From the Schedule Entries tab, complete the Time and Value fields.
6. Click Save to save the changes to the current schedule.

7.3.2.6 Modifying a Weekly Schedule Entry

1. In System Browser, select Application View > Schedules > Management Station Schedules.
2. Open the schedule you want to modify.
3. In the schedule area, click the weekly schedule you want to modify. Schedules are highlighted with a blue bar on the side of the entry.
4. In the Schedule Entries tab, modify the Time and Value fields as needed. NOTE: You can also drag the blocks up and down in the daily and weekly views to adjust the time. For more information, see Management Station Schedule Workspace [► 149].
5. Click Save.
7.3.2.7 Deleting a Weekly Schedule Entry

1. In System Browser, select Application View > Schedules > Management Station Schedules.
2. Open the schedule with the weekly schedule entry you want to delete.
3. In the schedule area, click the weekly schedule that contains the entry you want to delete. Details display in the Schedule Entries tab.
4. In the Schedule Entries tab, locate the entry you want to delete and click Delete.
   
   NOTE: You cannot delete default values.
5. Click Save.

7.3.2.8 Adding an Exception

1. In System Browser, select Application View > Schedules > Management Station Schedules.
2. Open the schedule to which you want to add an exception.
3. Right-click in the schedule area.
4. Click Add New Exception.
5. In the Exceptions tab, select the exception type, start and end dates, and the range you want.
   
   NOTE: Before the exception block can appear in the daily or weekly view, you must create at least one Time and Value pair, and one of the values must be ON.
6. Click the Save icon to save the changes to the current schedule.

7.3.2.9 Modifying an Exception

1. In System Browser, select Application View > Schedules > Management Station Schedules.
2. Open the schedule with the exception you want to modify.
3. In the schedule area, click the exception you want to modify.
   
   NOTE: Exceptions are highlighted in red.
4. In the Exceptions tab, modify the fields as needed.
5. Click Save.

7.3.2.10 Deleting an Exception

1. In System Browser, select Application View > Schedules > Management Station Schedules.
2. Open the schedule with the exception you want to delete.
3. In the schedule area, right-click the exception you want to delete.
   NOTE: Exceptions are highlighted with a red bar on the left side of the entry.
4. Click **Delete Exception**.
5. Click **Save**.

### 7.3.2.11 Adding an Exception Entry

1. In System Browser, select **Application View > Schedules > Management Station Schedules**.
2. Open the schedule to which you want to add an exception entry.
3. Click the **Exceptions** tab.
4. In the **Schedule entries** section, click **New**.
5. Complete the **Time** and **Value** fields.
6. Click **Save**.

### 7.3.2.12 Modifying an Exception Entry

1. In System Browser, select **Application View > Schedules > Management Station Schedules**.
2. Open the schedule you want to modify.
3. Click the **Exceptions** tab.
4. From the list of exceptions, select the exception you want to modify.
5. Make your changes in the **Exception Period** and **Exception Times** sections.
6. Click **Save**.

### 7.3.2.13 Deleting an Exception Entry

1. In System Browser, select **Application View > Schedules > Management Station Schedules**.
2. Open the schedule with the exception entry you want to delete.
3. Click the **Exceptions** tab.
4. From the list of exceptions, select the exception you want to delete, and then click **Delete**.
5. Click **Save**.

### 7.3.3 Management Station Time Triggers

Time triggers allow you to run offline trends, generate reports, or run macros at a specified time, and for the recurrence pattern you want.

Time triggers run independently of any schedules you have created. In other words, time triggers are not related to a particular schedule. Time triggers run only when the management station is running.
In Version 2 of the management station software, you cannot add, edit, or save time triggers. You can only view and delete existing time triggers.

### 7.3.3.1 Management Station Time Trigger Workspace

#### Activating Times

Allows you to set the time you would like to run the macro, report, or trend listed in the **Trigger Output** section.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| 1    | **Activation Times**  
|      | Allows you to set the time you would like to run the macro, report, or trend listed in the **Trigger Output** section. |
| 2    | **Scheduler Toolbar**  
|      | Includes the following icons:  
|      | **New**+ Opens a New BACnet Schedule, New Management Station Schedule, New BACnet Calendar, a New Management Station Calendar, or New BACnet Command Table.  
|      | **Delete** Deletes the time trigger from the system. |
| 3    | **Time Trigger Name**  
|      | Displays the name of the time trigger. |
| 4    | **Date Picker**  
|      | Displays a monthly calendar with effective periods of triggers highlighted. When first displayed or refreshed, the current day is selected by default. |
| 5    | **Effective Period**  
|      | Allows you to enter start and end dates, as well as set recurrence patterns. |
| 6    | **Trigger Output**  
|      | Allows you to run trends, generate reports, or run macros at a specified time, for a specified duration, and for the recurrence pattern you want. You drag objects from System Browser to this section. Clicking an object in this section sends data about the object to either the **Operation** or **Extended Operation** tabs. |

#### Deleting a Time Trigger

1. In System Browser, select **Application View**, click **Schedules > Management Station Time Triggers**.
2. Select the time trigger you want to delete.
3. From the **Scheduler** toolbar, click **Delete** 🗑.  
4. Click **OK**.
7.4 BACnet Scheduling

You use BACnet scheduling to automatically command points at prescribed time intervals. You can create daily or weekly schedules for BACnet field panels. Each BACnet panel stores its own calendar and schedule objects, and a BACnet panel can store and run multiple calendars or schedules at the same time. Because BACnet schedules reside in and are executed by field panels, they run even if the management station they are associated with is not running. BACnet schedules handle only BACnet objects (management station schedules can handle both BACnet and non-BACnet object types).

7.4.1 Example of BACnet Scheduling

The following procedures demonstrate how you can create a weekly occupancy schedule in a field panel that controls when the lights turn on and off for a school building. You will also see how to create a holiday calendar that is used as an exception to the schedule so that the lights will stay off during the holiday break, when the building will be vacant.

7.4.1.1 Creating a Weekly Schedule in a Field Panel

In System Manager, you have checked the Manual Navigation check box to keep from accidentally navigating away from the schedule you are creating.

1. From the Scheduler toolbar, click New.
2. Click New BACnet Schedule.
3. Click Save.
4. Complete the Name and Field device fields.
   NOTE: For this example, we will name the schedule OccupancySchedule.
5. Click OK.
The system adds the schedule to the BACnet Schedules node in the Application view.

7.4.1.2 Adding a Data Point to the Schedule

You are in System Browser.

1. From the Views drop-down list, select Management View.
2. Navigate to the field panel that contains the data point you want the schedule to control.
   NOTE: For this example, a binary output has been selected with two states (OCC, UNOCC) to represent lighting for a building when it is occupied and unoccupied.
3. Drag the object from System Browser and drop it in the Outputs tab.
4. In the Setup tab, select the default value, the text group (making sure that the group matches labels with the expected values), the start and end dates, and the priority.
   The system adds the point to the schedule.

7.4.1.3 Creating New Weekly Entries

1. Click anywhere on the default schedule.
   The Weekly Schedule Entries section displays.
2. Click the New+ button.
3. Enter 6:00:00 AM, and change the Default check box to ON.
   NOTE: Leaving an entry set to Default means the schedule will command all objects to the Schedule Default.
4. Click the New+ button.
5. Enter 6:00:00 PM, and change the Default check box to OFF.

6. Click Save.

   ➤ The system saves the settings.

7.4.1.4 Creating a Holiday Calendar

1. From the Scheduler toolbar, click New.

2. Click New BACnet Calendar.

3. Click Save.

4. Complete the Name and Field device fields.

   NOTE: For this example, the calendar is named HolidayBreak.

5. Click OK.

   ➤ The systems adds the calendar to the BACnet Calendars node in the Application view.
7.4.1.5 Adding a Calendar Entry

1. In the **Calendar Entries** section, click the **New+** button.
2. Click **Date range**.
3. Complete the **Start date** and **End date** fields.
4. Click **Save**.

**NOTE:** For this example, **December 24** to **December 31** is the holiday period when the lights will be turned off because the school building will be vacant.

The system saves the entries.

7.4.1.6 Creating an Exception

1. In System Browser, select **Application View > Schedules > BACnet Schedules > OccupancySchedule**.
2. Right-click the schedule and select **Create New Exception**.
3. In the **Exception Schedule** section, select **Calendar exception**.
4. From the **Calendar** drop-down list, select the **HolidayBreak** calendar.
5. In the **Schedule entries** section, delete one of the two entries.
6. In the remaining entry, enter **6:00:00 AM**.
7. Clear the Default check box.  
   **NOTE:** Creating an entry with the default check box checked returns control to the weekly schedule. For example, you might want to override the schedule for one hour at 1 P.M., so you create an entry at 1 P.M. with the override value. Then, you create an entry at 2 P.M. with Default checked. Control will then return to the weekly schedule at 2 P.M.

8. Select OFF from the drop-down list.

9. Click Save.

   The system saves the exception, and the OccupancySchedule for the week now looks like the following:

7.4.2 BACnet Calendars

Calendars allow you to override a scheduled event. In this sense, you can consider them as exception schedules, consisting of dates only. When you create a calendar, you can choose specific dates (January 15), a date range (August 1 – 31), or a week and a day you want the exception to run (third week of the month, on Wednesday). All calendars are associated with a schedule. If you want to reduce energy costs in your building during company holidays, for example, you could create a holiday calendar. On these days, your calendar might command the system to reduce the output of heating or cooling systems when the building is unoccupied.
### 7.4.2.1 BACnet Calendar Workspace

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| 1    | **New+ Button**  
Opens a new calendar entry. |
| 2    | **Applied Schedules**  
Displays a list of schedules referencing the calendar. Clicking a schedule in this section sends data about the object to either the **Operation** or **Extended Operation** tabs. |
| 3    | **Scheduler Toolbar**  
Includes the following icons:  
- **New+**: Opens a new BACnet Schedule, new Management Station Schedule, new BACnet Calendar, new Management Station Calendar or new BACnet Command Table.  
- **Save**: Saves the calendar to the system.  
- **Save As**: Saves another instance of the calendar with a different name and description.  
- **Delete**: Deletes the calendar from the system. |
| 4    | **Calendar Name**  
Displays the name of the calendar. |
| 5    | **Date Picker**  
Displays a monthly calendar with entry dates highlighted. When first displayed or refreshed, the current day is selected by default. |
| 6    | **Calendar Entries**  
Displays a list of entries representing a specific date, date range, or days of the week. The **Advanced** check box provides detailed settings for day, month, year, and the recurrence pattern. |

### 7.4.2.2 Adding a BACnet Calendar

1. In System Browser, select **Application View > Schedules > BACnetCalendars**.
2. From the **Scheduler** toolbar, click **Save**.
3. Complete the **Name** field.
4. From the **Field Device** drop-down list, select the panel you want this calendar associated with.
5. Click **OK**.
7.4.2.3 Modifying a BACnet Calendar

1. In System Browser, select Application View > Schedules > BACnetCalendars.
2. Open the calendar you want to update.
3. To modify start dates, end dates, or recurrence settings, select a calendar entry from the Calendar Entries section, and then select the settings you want.
   **NOTE:** If you use wildcards for date ranges (the Advanced check box), make sure to read your vendor's field panel documentation since the implementation of this feature is vendor-specific.
4. To delete a calendar entry, click the Delete icon associated with the entry.
   **NOTE:** Do not click the Delete icon from the Scheduler toolbar, or you will delete the entire calendar.
5. To add a calendar entry, click the New+ button, and then select the settings you want.
6. Click Save.

7.4.2.4 Copying a BACnet Calendar

1. In System Browser, select Application View > Schedules > BACnetCalendars.
2. Open the calendar you want to copy.
3. Click Save As.
4. Complete the Name field.
5. From the Field Device drop-down list, select the panel you want this calendar associated with.
6. Click OK.

7.4.2.5 Deleting a BACnet Calendar

1. In System Browser, select Application View > Schedules > BACnetCalendars.
2. Open the calendar you want to delete.
3. From the Scheduler toolbar, click Delete.
4. Click OK.

7.4.3 BACnet Schedules

Schedules consist of a name and description, a toolbar for working with the schedule, a date picker, several tabs (Schedule Entries, Outputs, Exceptions, and Setup), and schedule details.

**More about Views**

Even though you can schedule entries from the weekly view, the weekly view shows only the resulting schedule and not the details of the schedule. For more flexibility in visualizing and creating schedule entries, you can use the detail column of the daily view instead.
Default Date
By default, every new schedule begins with the current date and never ends. Once a new schedule is opened, you can choose the start and end date for the schedule.

Default State
By default, the system automatically creates weekly schedule entries for the default state, which you can modify. The Release (NULL) check box allows you to bypass the established priority and return an object to its default value. For example, to return control to lower priority commands, check the Release (NULL) check box for the schedule default, and then create a schedule entry with the Default check box checked. This will write BACnet null to the priority slot for the schedule, returning control to the system.

Default Schedule Behavior
When you select a BACnet schedule from System Browser, the Date Picker defaults to the current date, and the Schedule Entries tab becomes active.

About Priorities
The Present Value of some object types is based on a command priority and established in a hierarchy that ranks from highest (1 – Manual Life Safety) to lowest (16 - Available). The hierarchy determines which source has priority over another to change the value of an object. To command one of these object types, you—or an application—must have a command priority equal to or greater than the current command priority of the object. Typically, PPCL is set to priority 16, and schedules are set to priority 15.

7.4.3.1  BACnet Schedule Workspace

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td><strong>Schedule Name</strong>&lt;br&gt;Displays the name of the schedule.</td>
</tr>
<tr>
<td>2</td>
<td><strong>Scheduler Toolbar</strong>&lt;br&gt;Includes the following icons:&lt;br&gt;&lt;strong&gt;New+&lt;/strong&gt;: Opens a New BACnet Schedule, New Management Station Schedule, New BACnet Calendar, New Management Station Calendar, or New BACnet Command Table.</td>
</tr>
<tr>
<td>3</td>
<td>-tabs</td>
</tr>
<tr>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td><strong>Save:</strong></td>
<td>Saves the schedule to the system.</td>
</tr>
<tr>
<td><strong>Save As:</strong></td>
<td>Allows you to save another instance of the schedule with a different name and description.</td>
</tr>
<tr>
<td><strong>Delete:</strong></td>
<td>Deletes the schedule from the system.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>4</th>
<th>Date Picker</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allows you to select a day to view or create schedule entries. When first displayed or refreshed, the current day is selected by default.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>5</th>
<th>Schedule</th>
</tr>
</thead>
<tbody>
<tr>
<td>When first displayed or refreshed, the current day is selected by default.</td>
<td></td>
</tr>
<tr>
<td><strong>Day Tab:</strong></td>
<td>Displays a schedule for the day selected in the Data Picker.</td>
</tr>
<tr>
<td>Clicking the Detail check box reveals calendar entries, weekly schedule entries, and exception schedule entries. The Day tab also displays a horizontal time bar indicating the current time.</td>
<td></td>
</tr>
<tr>
<td><strong>Week Tab:</strong></td>
<td>Displays the weekly schedule. You can click any day of the week to view details. This tab also displays a horizontal time bar indicating the current time.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>6</th>
<th>Current Time Indicator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Displays a light-blue bar indicating the time of day.</td>
<td></td>
</tr>
</tbody>
</table>
7.4.3.2 Adding a BACnet Schedule

1. In System Browser, select Application View > Schedules > BACnetSchedules.
2. From the Setup tab, select the Default value and the Data type, and then complete the remaining fields.
3. Drag objects from the System Browser that you want associated with the schedule, and drop them into the Outputs tab.
4. Complete the resulting display of fields as needed.
5. From the Scheduler toolbar, click Save.
6. Complete the Name field.
7. From the Field Device drop-down list, select the panel you want this schedule associated with.
8. Click OK.

7.4.3.3 Copying a BACnet Schedule

1. In System Browser, select Application View > Schedules > BACnetSchedules.
2. Open the schedule you want to copy.
3. Click Save As.
4. Complete the Name field.
5. From the Field Device drop-down list, select the panel you want this schedule associated with.
6. Click OK.

7.4.3.4 Deleting a BACnet Schedule

1. In System Browser, select Application View > Schedules > BACnetSchedules.
2. Open the schedule you want to delete.
3. From the Scheduler toolbar, click Delete.
4. Click OK.

7.4.3.5 Adding a Weekly Schedule Entry

1. In System Browser, select Application View > Schedules > BACnetSchedules.
2. Open the schedule to which you want to add a new weekly schedule entry.
3. Right-click in the schedule area, and click Add New Weekly Schedule Entry.
4. Complete the fields in the Schedule Entries tab.
5. Click Save.
6. Click OK.
7.4.3.6 Modifying a Weekly Schedule Entry
1. In System Browser, select Application View > Schedules > BACnetSchedules.
2. Open the schedule you want to modify.
3. In the schedule area, click the weekly schedule you want to modify.
   NOTE: Weekly schedules are highlighted with a blue bar on the left side of the entry.
4. In the Schedule Entries tab, modify the Time and Value fields as needed.
5. Click Save.

7.4.3.7 Deleting a Weekly Schedule Entry
1. In System Browser, select Application View > Schedules > BACnetSchedules.
2. Open the schedule with the weekly schedule entry you want to delete.
3. Click in the schedule area.
4. In the Schedule Entries tab, locate the entry you want to delete and click Delete.
   NOTE: You cannot delete the entry for the beginning and end of day. You can delete default entries at other times, as long as there are still entries at beginning and end of day. You can also replace the entry at beginning or end of day with a non-default entry.
5. Click Save.

7.4.3.8 Adding an Exception
1. In System Browser, select Application View > Schedules > BACnetSchedules.
2. Open the schedule to which you want to add an exception.
3. Right-click in the schedule area, and click Add New Exception.
4. Complete the fields in the Exceptions tab.
5. Click Save.

7.4.3.9 Modifying an Exception
1. In System Browser, select Application View > Schedules > BACnetSchedules.
2. Open the schedule with the exception you want to modify.
3. In the schedule area, click the exception you want to modify.
   NOTE: Exceptions are highlighted with a red bar on the left side of the entry.
4. In the Exceptions tab, modify the fields as needed.
   NOTE: If you use wildcards for date ranges (the Advanced check box), make sure to read your vendor’s field panel documentation since the implementation of this feature is vendor-specific.
5. Click **Save**.

### 7.4.3.10 Deleting an Exception

1. In System Browser, select **Application View > Schedules > BACnetSchedules**.
2. Open the schedule with the exception you want to delete.
3. In the schedule area, right-click the exception you want to delete.  
   NOTE: Exceptions are highlighted with a red bar on the left side of the entry.
4. Click **Delete Exception**.
5. Click **Save**.

### 7.4.3.11 Adding an Exception Entry

1. In System Browser, select **Application View > Schedules > BACnetSchedules**.
2. Open the schedule you want to add an exception entry to.
3. Right-click the exception to which you want to add an entry
4. Click **Add New Exception Entry**.
5. Complete the fields in the **Schedule entries** section.
6. Click **Save**.

### 7.4.3.12 Modifying an Exception Entry

1. In System Browser, select **Application View > Schedules > BACnetSchedules**.
2. Open the schedule you want to modify.
3. In the schedule area, select the exception entry you want to modify.  
   NOTE: Exception entries are highlighted with a red bar on the left side of the entry.
4. In the *Exceptions* tab, modify the fields as needed.  
   NOTE: If you use wildcards for date ranges, make sure to read your vendor’s field panel documentation since the implementation of this feature is vendor-specific.
5. Click **Save**.

### 7.4.3.13 Deleting an Exception Entry

1. In System Browser, select **Application View > Schedules > BACnetSchedules**.
2. Open the schedule with the exception entry you want to delete.
3. Right-click the exception entry you want to delete.  
   NOTE: Exception entries are highlighted with a red bar on the left side of the entry.
4. Click **Delete Exception**.
5. Click **Save**.
7.4.4 BACnet Commands
Commands allow you to control BACnet objects related to your schedules. For example, you want to create a command that turns lights on and maintains room temperature at 72°F (22.22°C) when the room is occupied. When the room is unoccupied, the command would turn lights off and maintain the room temperature at 65°F (18.33°C). In this scenario, you could create a command with an entry for Occupied/Unoccupied, save it, and then drag it from System Browser to a schedule of your choice. The schedule will determine what time the command executes, the start and end dates, and the frequency of repetition.

7.4.4.1 BACnet Command Workspace

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>New+ Button&lt;br&gt;Opens a new command table.</td>
</tr>
<tr>
<td>2</td>
<td>Scheduler Toolbar&lt;br&gt;Includes the following icons:&lt;br&gt;New+: Opens a New BACnet Schedule, New Management Station Schedule, New BACnet Calendar, New Management Station Calendar, New BACnet Command Table, or New Management Station trigger.&lt;br&gt;Save: Saves the command object to the system.&lt;br&gt;Save As: Allows you to save another instance of the command object with a different name and description.&lt;br&gt;Delete: Deletes the command object from the system.</td>
</tr>
<tr>
<td>3</td>
<td>Command Name&lt;br&gt;Displays the name of the command.</td>
</tr>
<tr>
<td>4</td>
<td>Command Attributes&lt;br&gt;Displays the command object attribute, the panel it is associated with, the text group associated with the object, and the schedules controlling the command.</td>
</tr>
<tr>
<td>5</td>
<td>Command Table Action List&lt;br&gt;Displays command tables with additional detail when you select an entry row. The Move Up and Move Down arrows allow you to re-order entries within a command table. Further detail can be displayed by clicking the Advanced button.</td>
</tr>
</tbody>
</table>
7.4.4.2 Adding a Command

1. In System Browser, select **Application View > Schedules > BACnetCommands**.
2. From the **Text Group** drop-down list, select the text group you want associated with this command.
3. In the **Command Table Action List**, click the **New+** button.
4. Highlight the text in the new action list, and rename it to suit your needs.
5. From **System Browser**, drag the object you want to the action list.
6. Complete the resulting fields.
7. Click **Save**.
8. Complete the **Name** field.
9. From the **Field Device** drop-down list, select the panel you want this command associated with.
10. Click **OK**.

7.4.4.3 Modifying a Command

1. In System Browser, select **Application View > Schedules > BACnetCommands**.
2. Open the command you want to modify.
3. Make changes to the **Text Group** and the **Applied Schedules** sections, and to the states in the **Command Table Action List** as needed.
4. Click **Save** to save and activate the changes.

7.4.4.4 Copying a Command

1. In System Browser, select **Application View > Schedules > BACnetCommands**.
2. Open the command you want to copy.
3. From the **Scheduler** toolbar, click **Save As**.
4. Complete the **Name** field.
5. From the **Field Device** drop-down list, select the panel you want this command associated with.
6. Click **OK**.

7.4.4.5 Deleting a Command

1. In System Browser, select **Application View > Schedules > BACnetCommands**.
2. Select the command you want to delete.
3. From the **Scheduler** toolbar, click **Delete**.
4. Click **OK**.
8 Trends

A key functionality in a building automation and control system includes acquiring measured values from workflows and processes. This chapter includes all information required to operate and analyze trends (historical data acquisition).

What is Trend?

All available process data of a system can be recorded and applied to operational optimization. This allows you to record information on plant states, temperature curves, switching states, and counter values in a form that is suitable for your purposes. The measured value data can be displayed and evaluated graphically.

Trends can be conducted short-term as online trends, or over an extended timeframe using offline trend functions.

Trend Examples

- Control monitoring for optimization purposes.
- Room temperature measurements relating to the entered setpoint temperature.
- Temperature and humidity trends in Pharma.

Trend Functions

- Create, delete, and edit Trend View.
- Record, analyze, compare, save, print, export any trend data.
- Display trend curves.
  - Display data quality using the appropriate quality symbols.
  - Trend curve display in 2D.
  - Time range displayed in absolute/relative time or selectable using a scrollbar.
  - Freely zoom in/out.
  - Manually scale or automatically define individual trend axes.
  - Freely define the display type for each trend curve (color, font, and so on).
● Measured value trends based on intervals, or each time a value changes (change-of-value).
● Data types analog, digital, and multistate are supported.
● Create trendlog objects in the automation station.

Restrictions
● Maximum 10 GB database memory for SQL Server Express or 250 GB of database memory for SQL Server.
● Display 10 curves (max. recommended) within a Trend View.

Restrictions: Version 2.1
● No archive data can be generated.

8.1 Overview of Trend Application

The Trends application allows you to create online trends and display offline trends from the automation station.

The Trend application contains a workspace with specific properties (for example, name, gridlines, scaling, and so on) as well as data point references (properties, and so on). Trendlog objects contain measured values. The collected values are displayed in a common time range and saved to the trend database.

Regardless of the trend data, Trend Views can be saved, queried, deleted, and edited as well as saved under a new name.

You can use Trend Views in two ways in the management station:
● During operation, trend data recorded in real-time and saved to the trend database (management station is online).
● Trend data are recorded in the automation station (management station is offline) and periodically loaded to the management station trend database.

You can display the trend data in the Trend Viewer any time, even if the management station is not connected to the site (no real-time data available).

Methods to Record Data

Two methods to configure online and offline Trendlog objects to record data:
● Change-of-Value (COV)
  This method allows you to record new data when the data point value within the defined data point range is changed. No value is recorded or transmitted if the value does not change over an extended period of time. Database acquisition of several data points in a Trend View is asynchronous.
● Interval-based (offline trend only)
  This method allows you to record current data as soon as the time stamp is reached. The data values are recorded without impact of a defined COV property.

- Triggered
  Refers to the BACnet reference names of the selected trigger from reaction, scheduler or the BACnet reference.
8.2 What is Online/Offline Trend?

Online Trend

Online trend records real-time values from your plant and displays them graphically in a Trend View. The data values are sent to the trend application upon each change of value. The measured values are temporary and can be stored for later queries continuously in the Trend database (online Trendlog object). Online trends can be used for real-time visualization of one or more process variables, usually for the purposes of analysis or diagnosis.

<table>
<thead>
<tr>
<th>Record Online Trend Data</th>
<th>Trend data are uploaded continuously to the management station and are not saved in the automation station.</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Diagram" /></td>
<td></td>
</tr>
</tbody>
</table>

**NOTE:**
An uninterrupted site connection with the management station is required. Measured values may be irretrievably lost when the site is interrupted during data recording. Therefore, online trend is not well suited for long-term secure data recording.

Offline Trend

Offline trend data is used for the longer-term storage and retrieval of historical data for the analysis of entire plants or single processes. With offline trend, data is recorded directly in the automation station. Users can retrieve data as needed or automation stations can automatically upload the data. The data recording can be prepared in advance using the engineering tool or you can create a Trendlog object from the management station in the automation station (must be supported by the subsystem).

<table>
<thead>
<tr>
<th>Phase 1: Record Offline Trend Data</th>
<th>Trend data is saved locally to the Trendlog object in the automation station.</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image2.png" alt="Diagram" /></td>
<td></td>
</tr>
</tbody>
</table>

| Phase 2: Upload Offline Trend Data | Trend data is uploaded if:  
|-----------------------------------|-----------------------------|
| ![Diagram](image3.png)            |   - The maximum buffer size is reached.  
|                                   |   - The number of defined entries is reached.  
|                                   |   - Manually triggered by the management station. |
8.3 Trend Data Storage

Recorded trend data can be stored in three different locations:

- **Offline Trendlog Objects**: Offline trend data is saved in the automation station.
- **Online Trendlog Objects**: Contains the online trend data recorded and saved in the management station.
- **Archived Trend Database (not in version 2.0)**: Contains all recorded Trend data moved previously to the archive database.

**Offline Trendlog Objects**
Offline trend data can be recorded and saved by Trendlog objects within the automation and control system even when the management station is not connected. The recorded data can then be saved in the trend database. Offline trend data can be retrieved and displayed in the trends.

**Online Trendlog Objects**
Data recorded by online trending and saved to the trend database (for example, using save continuously) can be retrieved and displayed in the trends. Online Trendlog objects record data also when the Trend View is closed.

**Database Storage Capacity**
In the database, 10 GB is saved for SQL Server Express and 250 GB of historical data for SQL-Server. Once 90% of the database size is reached, the 10% oldest data entries are deleted. The 10% of data for deletion always refers to the entire time axis for the collected data. Thus, it cannot be exactly determined how many entries or the database size that is actually deleted. Additional incoming entries are rejected if the 10% of data entries cannot be deleted before reaching 98% of the database size.

![Graph showing database storage capacity](image)

The data amount is comprised of the following:

- System activities
- Alarm messages
- Trend data

**NOTE:**
Additional information on data backup is available in the document *System Management Console.*
Change to Daylight Savings Time
- Date/time data is saved in UTC format. Entries are in double for one hour when setting back to normal time. In this case, the curve is displayed using both values. When switching to daylight savings times, no value is displayed in this hour and the displayed line is straight between the two measured values.
- A system message Anomaly is generated when changing times that must be acknowledged.

Application Examples for Online or Offline Trend
Online Trend: You can create the online trend if the room temperature is too low and record data for specified period and analyze measured values in a trend curve directly on the management station.
Offline Trend: Assign the outside temperature to the Trendlog object in the automation station if you want to calculate energy consumption and need the outside air temperature series for measured values. You can then manually or automatically (periodically) upload the recorded temperature data to store in the management station.
8.4 Working with Trends

Trends are divided into the following main elements:

- Trend View
- Comparative Trend View
- Trend View properties
- Configuration bar
- Key
- System Browser

### Name | Description
--- | ---
1 | System Browser Displays available Trendlog objects as well as created Trend Views.
2 | Configuration Toolbar Displays buttons for the most common commands (new, save, print, zoom).
3 | Compare view Allows you to compare measured values from the same Trend View.
4 | Trend View The range which can be displayed and processed for online and offline trend data in chart form. These Trend Views are saved independently of the trend data.
5 | Key Displays information on data points that are displayed graphically in the Trend View.

8.4.1 Trend View Properties

You can enter the following settings in Trend View properties to define the display for the graphical curve:

- Chart
- Axis
- Legend
- Series
8.4.1.1 Chart

You can define the following Chart properties:
- Grid
- Background color
- Trend View title
- Display quality attributes
- Number of maximum series values in Trend View

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Grid</td>
<td>Hides/shows the grid for the Trend View or displays it with horizontal or vertical lines.</td>
</tr>
<tr>
<td>Background</td>
<td>Hides/shows the background color as well as pattern for Trend View. Allows you to define or select the background from a predefined set of colors.</td>
</tr>
<tr>
<td>Titles</td>
<td>A descriptive name required for each Trend View. You can also add your own title to the left and right axis of the Trend View.</td>
</tr>
<tr>
<td>Maximum displayed samples per series</td>
<td>Specifies how many values are displayed in a Trend series during the defined Trend View period. This setting directly determines if Trend View displays the values in a reduced view (see also Data Point Key [→ 186], Reduced values).</td>
</tr>
<tr>
<td>Advanced display if chart stopped</td>
<td>Displays quality attributes, markers, and values, even for cleared check boxes, if the open Trend View is updates continuously. This means that updating the values takes longer.</td>
</tr>
</tbody>
</table>

8.4.1.2 Axis

You can enter the following settings in the Axis properties:
- Left axis
- X-axis
- Right axis

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title Y Left</td>
<td>Displays the title on the left side of the Trend View. Auto Scale: A minimum and maximum range must be defined if auto scale</td>
</tr>
</tbody>
</table>
### General
Each chart can display a left and right Y-axis independent of each other. Series can be selectively assigned and scaled to either axis, by default or manually.
Scaling is set to automatic by default. This means that the range is defined by the highest amplitude of all displayed series, with analog data types attached to the left axis and digital data types to the right axis.
When a single Trend View contains several digital data types, these are shown one above the other with an offset.
The X-axis is always the time-related axis and the chart display is calculated according to the selected time range.

#### 8.4.1.3 Legends

<table>
<thead>
<tr>
<th>Chart Properties</th>
<th>Auto Properties</th>
<th>Legends Properties</th>
<th>Series Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Legend/Bottom</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Configure</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Menu** | **Description**
--- | ---
Legend | The position can be left, right, above, or below the Trend View. Under a comparison view, the legend always displays on the right.

#### 8.4.1.4 Series
Series properties, you define the individual series for the corresponding properties in Trend View.
- Line properties
  - Data series type
  - Data series form
  - Data series color
- Displaying Markers
  - Marker type
  - Marker size
- Y-axis position
- Display values
- Displaying Quality Attributes
## Working with Trends

### Menu

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line Properties</td>
<td>Defines the appropriate property type, form and color, as well as the property for the series (see the Table Line Properties below).</td>
</tr>
<tr>
<td>Visible</td>
<td>Displays the trend curve if this check box is selected.</td>
</tr>
<tr>
<td>Show Markers</td>
<td>Defines the corresponding property type, and size, as well as the corresponding property for the series.</td>
</tr>
<tr>
<td>Show Values</td>
<td>Displays numerically each measured value for the read value if this check box is selected.</td>
</tr>
<tr>
<td>Show Quality Icons</td>
<td>The Trend View can display a number of state attributes, referred to as quality attributes, along with the trend data.</td>
</tr>
</tbody>
</table>

### Line Properties

<table>
<thead>
<tr>
<th>Line type</th>
<th>Line style</th>
<th>Stroke color</th>
<th>Stroke thickness</th>
<th>Marker style</th>
<th>Marker thickness</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>1-6</td>
<td></td>
<td></td>
<td>1-10</td>
</tr>
</tbody>
</table>

### Colors

8.4.1.5 **Colors**

You can assign a color to the Trend View (background color) or to each individual series (line). You can choose between:

- Predefined set of colors.
- Custom colors.
8.4.2 Compare View

You can link the same or another Trend View for data analysis that applies the same X-axis for the time range to both Trend Views. The current lower Trend View serves as the basis for the upper comparative Trend View. Any changes to the time range in the current Trend View are reflected in the comparative Trend View. Predefined buttons allow you to offset the comparative Trend View to the current Trend View by the selected value.
### Item Description

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Current Trend View.</td>
</tr>
<tr>
<td>2</td>
<td>Compare View.</td>
</tr>
<tr>
<td>3</td>
<td>Time bar with time displayed in the comparative view.</td>
</tr>
<tr>
<td>4</td>
<td>No offset.</td>
</tr>
<tr>
<td>5</td>
<td>Predefined offset buttons.</td>
</tr>
<tr>
<td>6</td>
<td>Freely definable offset range (range, unit).</td>
</tr>
<tr>
<td>7</td>
<td>1x forward or 1x back for the selected offset range.</td>
</tr>
<tr>
<td>8</td>
<td>Freely definable offset range in hours, days, weeks, years.</td>
</tr>
<tr>
<td>9</td>
<td>Data Point Key</td>
</tr>
</tbody>
</table>

#### Same Trend View

This type of comparison is especially useful when analyzing the data for individual components, such as a room temperature for a room. The time offset allows you to easily check how the corresponding measured value behaves at the same time of day.

**NOTE:**
The legend displays the last left measured value in the time bar.
In the legend, the displayed value is not displayed based on the intersection of the time bar and trend curve. Instead, the time/date display is based on the time bar position.

#### 8.4.3 Trend View

The Trend View consists of a chart area where series are viewed and manipulated. All the main elements such as the axes, scaling, titles and colors can be configured in Trend View properties (by taking over defaults or changing the current Trend View).
### Item | Description
--- | ---
1 | Displays title of current Trend View.
2, 11 | Displays and highlights the selected trend curve in Trend View. **NOTE:** To display a change of value on a binary value, an additional dotted zero line displays at State 1 or One.
3, 12 | Displays unselected trend curves as collapsed curves.
4 | Displays the time bar. The time bar can be dragged anywhere on the time axis. The data legend at the bottom of the Trend View displays the value or state valid at the point where the bar intersects with the series. When the time bar is hidden, the legend displays the last correct value for the Trend View.
5 | Displays the present measured value for the series at the cursor. The current measured value in a graphic curve is displayed by moving the mouse pointer to the desired position. The precise measured points can be better displayed by enabling the marker for the series.
6 | Displays the Y-axis with the appropriate scaling. Each chart can display a left and right Y-axis independent of each other. Data series can be selectively assigned and scaled to either axis (by default or manually).
7 | Legend header.
8 | **Online:** Current value from the automation station.  **Offline Trend:** The values are displayed as a function of the time bar [3].
9 | Displays time or date range display across the entire selected display range.
10 | Displays time range scrollbar (see Time Range Scrollbar [→ 180]).
13 | Displays time and/or date display for the grid.
14 | Displays time range display between grid sections.

### 8.4.3.1 Time Range Scrollbar

In every Trend View, there are two time ranges of interest for analysis:
- Data displayed in the time range of the current chart (which is displayed directly on the screen).
- Data in the time range of all available data.
Use the time range scrollbar to set the appropriate data range for your analysis.

**Description**

1, 6 **Repeat** button left/right. The displayed timeline moves to the left or right if you click the button at a ratio of 1:10 of the entered timeline. The corresponding repeat value displays with a tooltip.

2 Value range for all stored data.

3, 5 Context menu: First/last time range for current Trend View.

4 Context menu: Time range for current Trend View.

7, 8 Tooltip: Repeat value.

9 Direct time selection for a freely definable time and date range. See section Direct Time Selection [→ 181].

10 Tooltip: Time and date of the oldest displayed data.

11, 13 Timeline slide left/right. Click the end of the time range slider (dark grey area) and pull the slider to the desired time/date position, which the tooltip continuously displays. The range of the time window is changed at the same time you slide the end points.

12 Time range slider time window for the displayed window. Using the mouse, click the end of the time range slider (dark grey area) and pull the slider to the desired time/date position, which the tooltip continuously displays. The entered time window range is constant for the function.

14 Tooltip: Time range of the displayed data.

15 Tooltip: Time and date of the oldest displayed data.

### 8.4.3.2 Direct Time Selection

Right-click the Time Range scrollbar to select the time directly. The exact time range can be entered as:

- Absolute Time Range
- Relative Time Range
- Enter time range for trend.
Absolute Time Range

The absolute time range is suitable for displaying the data for a known time range. To display the Trend View, you can directly define the start and stop times using a calendar entry as well as the corresponding time entry.

Relative Time Range

The relative time range is determined by a selectable time range (for example, 2 weeks) and depends on the current time. You can set the interval (in [x] seconds, minutes, hours, days, weeks, months, and years) to display the data within the optimum time range.
Recorded Time Range
Select Full View to display the recorded data. Only the Trend View to the date of the last save is displayed when the current date does not match the date of the last save.

8.4.3.3 Context Menu
### Context Menu 1

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide this column.</td>
<td>Hides the selected column.</td>
</tr>
<tr>
<td>Visible columns</td>
<td>Shows/hides columns.</td>
</tr>
<tr>
<td>Hide this column.</td>
<td></td>
</tr>
<tr>
<td>Trended Object Name</td>
<td></td>
</tr>
<tr>
<td>Trended Property Name</td>
<td></td>
</tr>
<tr>
<td>Trended Log Object Name</td>
<td></td>
</tr>
<tr>
<td>Alias</td>
<td></td>
</tr>
<tr>
<td>Unit</td>
<td></td>
</tr>
<tr>
<td>Value</td>
<td></td>
</tr>
<tr>
<td>Time</td>
<td></td>
</tr>
<tr>
<td>Date</td>
<td></td>
</tr>
<tr>
<td>Y-Axis Attachment</td>
<td></td>
</tr>
<tr>
<td>Remove</td>
<td></td>
</tr>
<tr>
<td>Visibility</td>
<td></td>
</tr>
</tbody>
</table>

### Context Menu 2

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Trended Object in Contextual Pane</td>
<td>Displays object properties in Operation pane.</td>
</tr>
<tr>
<td>Display Trendlog Object in Contextual Pane</td>
<td>Displays object properties in Operation pane.</td>
</tr>
<tr>
<td>Create Trendlog Object in BACnet Device</td>
<td>Creates a Trendlog object on the device.</td>
</tr>
<tr>
<td>Create Trendlog Multiple Object in BACnet Device</td>
<td>Creates a Trendlog multiple object on the device.</td>
</tr>
<tr>
<td>Delete the trendlog object on the BACnet device</td>
<td>Deletes a Trendlog object on the device.</td>
</tr>
<tr>
<td>Remove</td>
<td>Removes a series from the Trend View.</td>
</tr>
</tbody>
</table>

### Context Menu 3

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Range…</td>
<td>User-defined range (see Direct Time Selection [181]):</td>
</tr>
<tr>
<td>Selection type</td>
<td></td>
</tr>
<tr>
<td>Date</td>
<td></td>
</tr>
<tr>
<td>Time</td>
<td></td>
</tr>
</tbody>
</table>

### Context Menu 4

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>First 1</td>
<td>minute, hour, day, week, month, or year.</td>
</tr>
<tr>
<td>Full View</td>
<td>Entire date range.</td>
</tr>
<tr>
<td>Select Range…</td>
<td>User-defined range.</td>
</tr>
</tbody>
</table>
### Context Menu 5

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>One</td>
<td>minute, hour, day, week, month, or year.</td>
</tr>
<tr>
<td>Full View</td>
<td>Entire date range.</td>
</tr>
<tr>
<td>Select Range…</td>
<td>User-defined range.</td>
</tr>
</tbody>
</table>

### Context Menu 6

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>First</td>
<td>minute, hour, day, week, month, or year.</td>
</tr>
<tr>
<td>Full View</td>
<td>Entire date range.</td>
</tr>
<tr>
<td>Select Range…</td>
<td>User-defined range.</td>
</tr>
</tbody>
</table>
8.4.4 Data Point Key

The legend for the series contains information on the given data point in the Trend View.

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trended Object</td>
<td>Displays the object names for the Trendlog object.</td>
</tr>
<tr>
<td>Trended Property</td>
<td>Displays the trended property name for the object.</td>
</tr>
<tr>
<td>Alias</td>
<td>Displays the alias name for the object.</td>
</tr>
<tr>
<td>Unit</td>
<td>Physical unit for the data point.</td>
</tr>
<tr>
<td>Value</td>
<td>Displays the last displayed current value (unless the time bar is in use. In this case, the value is displayed at the intersection).</td>
</tr>
<tr>
<td>Time</td>
<td>Displays the time for the most recent value (unless the time bar is used; in this case, the value is displayed at the intersection).</td>
</tr>
<tr>
<td>Date</td>
<td>Displays the date for the most recent value (unless the time bar is used; in this case, the value is displayed at the intersection).</td>
</tr>
<tr>
<td>Reduced</td>
<td>When this symbol [] displays, not all values for this series are displayed in the Trend View (dependent on the displayed time period) (see Reduced Display).</td>
</tr>
<tr>
<td>Y-axis</td>
<td>Indicates the Y-axis where the point is scaled.</td>
</tr>
<tr>
<td>Remove</td>
<td>Removes the selected trend value from the Trend View.</td>
</tr>
<tr>
<td>Show/hide</td>
<td>Temporarily shows/hides the trend curve in the Trend View.</td>
</tr>
</tbody>
</table>
Reduced Display

Displays a maximum of two values per interval. The interval is calculated based on the set sample rate for the Trend View (Trend Chart Properties).

- 1 interval = Max. displayed samples per series/2.
  - Example 1: 100/2 = 50 intervals
  - Example 2: 400/2 = 200 intervals

A reduced display can also occur with just a few values. For example, when the values are recorded within a short interval. With the reduced display, minimum and maximum values always display.

Quality attributes:

With the reduced display, not all quality attributes can be displayed. In order to display all quality attributes, limit the time period.
8.4.5 Toolbar

You can perform some commands directly in Trend View using the Configuration bar. This allows you to optimally process the data in Trend View.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete</td>
<td></td>
<td>Deletes the current Trend View.</td>
</tr>
<tr>
<td>Save</td>
<td></td>
<td>Saves the current Trend View.</td>
</tr>
<tr>
<td>Save As</td>
<td></td>
<td>Saves the Trend View under a new name.</td>
</tr>
<tr>
<td>Save as user default</td>
<td></td>
<td>Saves the Trend View definition as a new user default.</td>
</tr>
<tr>
<td>Properties</td>
<td></td>
<td>Opens the properties dialog box for chart, axes, legends, and series.</td>
</tr>
<tr>
<td>Stop</td>
<td></td>
<td>Stops trend logging.</td>
</tr>
<tr>
<td>Run</td>
<td></td>
<td>Starts trend logging.</td>
</tr>
<tr>
<td>Refresh</td>
<td></td>
<td>Refreshes the Trend View.</td>
</tr>
<tr>
<td>Compare view</td>
<td></td>
<td>Opens the same Trend View a second time.</td>
</tr>
<tr>
<td>Zoom</td>
<td></td>
<td>Allows you select a time range in the currently selected Trend View by effectively zooming in on the X-axis and Y-axis.</td>
</tr>
<tr>
<td>Timebar</td>
<td></td>
<td>Shows/hides the time bar.</td>
</tr>
<tr>
<td>Table view</td>
<td></td>
<td>Switches from graphical Trend View to a table view.</td>
</tr>
<tr>
<td>Print</td>
<td></td>
<td>Prints Trend View.</td>
</tr>
</tbody>
</table>

Time Bar Scrollbar

The time bar consists of a vertical bar and a time/date field. The time bar can be dragged anywhere on the time axis. The data legend below the Trend View shows the value and state for a point. The last recorded value is displayed to the left of the time bar.
8.4.6 System Browser

All Trendlog objects or Trend View definitions display hierarchically in the System Browser in a tree structure. Click or drag-and-drop to temporarily view Trendlog objects in a Trend View or configure a specific object and save it in a Trend View.

Offline Trend

Lists all available offline Trendlog objects available in the automation station for a project.

Online Trend

Lists all available online Trendlog objects. An online Trendlog object is created when you define a series and save it in a Trend View definition. However, this Trendlog object is available only on the management station. No Trendlog object is created in the automation station.

Trend View Definition

The Trend View definition includes all properties required for graphical displaying of the Trend View and the series:

- Background colors
- Series column order
- Series reference

NOTE:
The Trend View definition does not contain process values, but only one reference to the corresponding series (Trendlog objects).
### 8.4.7 Quality Attributes

The Trend View can display a number of state attributes, referred to as *quality attributes*, along with the trend data. These enable you to identify problems with the data point being recorded, and assist with the diagnosis of plant conditions. The following table describes these quality attributes:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>BACnet</th>
<th>Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DRIVER FAILED (Bit=1)</td>
<td>No connection</td>
<td>Indicates that no connection exists to the logged data point.</td>
<td></td>
</tr>
<tr>
<td>DRIVER FAILED (Bit=0)</td>
<td>Connected</td>
<td>Indicates that the connection exists to the data point.</td>
<td></td>
</tr>
<tr>
<td>ERROR_IN_LOG</td>
<td>Error</td>
<td>Indicates an error in the Trendlog object.</td>
<td></td>
</tr>
<tr>
<td>T_LOG_ENABLE (Bit=0)</td>
<td>Trend disabled</td>
<td>Indicates that the Trendlog object is disabled. Text display for the last known value.</td>
<td></td>
</tr>
<tr>
<td>T_LOG_ENABLE (Bit=1)</td>
<td>Trend enabled</td>
<td>Indicates that the Trendlog object is enabled.</td>
<td></td>
</tr>
<tr>
<td>T_PURGED</td>
<td>Buffer deleted</td>
<td>Indicates that the buffer in the Trendlog object is deleted.</td>
<td></td>
</tr>
<tr>
<td>T_ROLLOVER</td>
<td>Buffer full</td>
<td>Indicates that the Trendlog buffer is full.</td>
<td></td>
</tr>
<tr>
<td>T_TIME_SHIFT</td>
<td>Time change</td>
<td>Indicates that the time in the automation station was changed (displayed in table only).</td>
<td></td>
</tr>
<tr>
<td>LOG_INTERRUPTED</td>
<td>Power fail</td>
<td>Indicates that the automation station has been set to state Log_interrupted in the trend buffer (for example: in the event of a power outage, application program stop, change of data point log type). This may cause trend data from not being logged.</td>
<td></td>
</tr>
<tr>
<td>OUT_OF_SERVICE (Bit=1)</td>
<td>Out of Service switched on</td>
<td>Indicates that the Out of Service property is switched on.</td>
<td></td>
</tr>
<tr>
<td>OUT_OF_SERVICE (Bit=0)</td>
<td>Out of Service is normal</td>
<td>Indicates that the Out of Service property is switched off.</td>
<td></td>
</tr>
<tr>
<td>FAULT (Bit=1)</td>
<td>Trendlog object error</td>
<td>Indicates that a data point error exists in the Trendlog object (values may not be usable for follow-on evaluation).</td>
<td></td>
</tr>
<tr>
<td>FAULT (Bit=0)</td>
<td>Return from Trendlog error</td>
<td>Indicates that the data point error returns to the normal state.</td>
<td></td>
</tr>
<tr>
<td>ALARM (Bit=1)</td>
<td>In alarm state</td>
<td>Indicates that the data point is in the alarm state.</td>
<td></td>
</tr>
<tr>
<td>ALARM (Bit=0)</td>
<td>Return from the alarm state</td>
<td>Indicates that the data point has returned from the alarm state.</td>
<td></td>
</tr>
<tr>
<td>OVERRIDDEN (Bit=1)</td>
<td>Into override (module)</td>
<td>Indicates that the data point on a module is overridden.</td>
<td></td>
</tr>
<tr>
<td>OVERRIDDEN (Bit=0)</td>
<td>Return from overridden (module)</td>
<td>Indicates that the data point's override on the module is removed.</td>
<td></td>
</tr>
</tbody>
</table>
Only the highest priority displays in the Trend View if several states are active. The priority sequence in the previous quality attributes table is read in descending order (highest to lowest priority). With the reduced display, not all quality attributes display. In order to display all quality attributes, limit the time period.

**NOTE:**
Quality attributes can only be evaluated if this function supports the corresponding subsystem. An alarm setup on the management station does not possess quality attributes: therefore an alarm cannot display an alarm bell in the Trend View.

### 8.4.8 Table View

The table view offers a view that differs from the standard view where curves are displayed as series.

The table view displays each series as a column in the data grid. The first column (right) shows the time stamp. The column displays by merging all time stamps for all values in each series. It is displayed at an accuracy of 1 second.

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
<tr>
<td>5</td>
</tr>
<tr>
<td>6</td>
</tr>
<tr>
<td>7</td>
</tr>
</tbody>
</table>

There are two display types in table view:
- **Normal view:** The corresponding cell has a value or is empty.
- **Interpolated view:** The corresponding cell is empty and shows a linear interpolated value based on previous current and subsequent current selection.

**NOTE:**
The table view only shows values as per the graphical time range. These values are exported during data export.
8.5 Defining Trend Views

You need a Trend View definition to graphically record data. The Trend View definition includes all properties required for graphical display of the Trend View and the series. Measured value data belonging to the given series such as time/date, value or period are saved in the Trendlog object and can only be displayed in the Trend View definition.

Steps

The following illustration shows a general workflow to creating a Trendlog. For more information, see the detailed workflows in the following chapters.
1. In System Browser, select Application View.

2. Select Applications > Trends > Trend View Definitions.


4. In System Browser, select Management View.

5. Select Project > Field Networks > [Network Type] > Hardware > [Device].

6. Select the corresponding data point (do not click the data point) and drag-and-drop the selected data point to the Trend application.

7. Click Save.

   **NOTE:** The values display in the Trend View as soon as the data point value changes.

8. Select the Trend View Definitions folder.

9. Type a name for the Trend View and click OK.

### 8.5.1 Creating Trend View definition

A Trend View definition normally is customized only once in a project. This ensures that all Trend Views that are created look the same (see User Default table).

† You are in the System Browser, Trend is still closed.

1. In System Browser, select Application View.

2. Select Applications > Trends.


   † The Trend application opens.

4. Click Properties.

5. Select the Chart Properties and edit the Trend View properties (see Trend View Properties [174]).

   **NOTE:** Only the grid and background properties are part of the user default.

6. Click Save as user default.

   † These settings now apply to all new Trend Views. You can, however, adapt the Trend View definition as needed.

<table>
<thead>
<tr>
<th>Property</th>
<th>Yes</th>
<th>No</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trend View name.</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Background color of the Trend View.</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Legend position in the Trend View.</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Show/hide columns.</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Adjust column width.</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Move columns.</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Series properties.</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Axes properties.</td>
<td>X</td>
<td></td>
</tr>
</tbody>
</table>
8.5.2 Creating New Trend Folder

1. In System Browser, select Application View.
2. Select Trends > Trend View Definitions.
3. Click New > New Folder.
4. Type the appropriate information in the Name and Description fields.
5. Click OK.

A new folder is created under Trends > Trend View Definitions.

NOTE:
You can create additional sub-folders as needed. However, it is recommended to save Trend Views in a structured manner by building topology or electrical and mechanical installations.

8.5.3 Creating New Trend View from System Browser

You are in System Browser, and the Trend application is closed.

1. In System Browser, select Application View.
2. Select Trends > Trend View Definitions.
   ➤ The Trend application opens.
4. In System Browser, select Management View.
5. Select Project > Field Networks > [Network Type] > Hardware > [Device].
6. In System Browser, select the corresponding data point (do not click the data point).
7. Drag-and-drop to the selected data point to the Trend application.

NOTES:
Data trending continues as long as the VL attribute for the data point is enabled (see Object Configurator).
To display a change of value on a binary value, an additional dotted zero line is displayed at State 1 or One.

8. Change the Trend View properties.
9. Change the series properties.
10. Click Save As.
    ➤ The text dialog pane opens.
11. Select the desired folder to save the Trend View.
12. Type a name and description for the new Trend View.
13. Click OK.
    ➤ An online Trendlog object is created for each data point in Application View > Trends > Online Log Objects.
NOTE:
Select the Manual navigation check box and the corresponding data points if you want to assign several data points to the Trend View at the same time. You can now assign them to the Trend View by dragging and dropping them.

8.5.4 Creating and Saving New Trend View
1. In System Browser, select Application View.
2. Select Applications > Trends.
3. Click New and then New Trend.
4. Select one of the following:
   – Offline Trend-Log Object in the folder Offline Log Objects
   – Online Trend-Log Object in the folder Online Log Objects.
5. Click or drag-and-drop to add the Trendlog object to the new Trend View.
6. Repeat Steps 1 through 5 for additional Trendlog objects that you want to display in this Trend View.
7. Change the Trend View properties.
8. Change the properties for each series.
9. Click Save and select the folder Trend View Definitions or a subfolder.
   The Trend View definition is saved in the Trend View Definitions folder or as a new Trend View.

NOTE:
Please read the appropriate workflows to edit the properties for the Trend View or a series.

8.5.5 Creating New Trend View from Related Items
▷ You are in an open application.
1. Select the symbol New Trend under Related Items.
   Trend View opens a secondary view.
2. Change the Trend View properties.
3. Change the properties for each series.
4. Click Save As.
   The text dialog pane opens.
5. Select the folder to save the Trend View.
6. Type a new name and description for the new Trend View.
7. Click OK.
   The Trend View is saved.
8.5.6 Defining Chart Properties

▷ A Trend View is open.

1. Click Properties 🌐.
2. Click the Chart Properties tab (see Chart [➙ 175]).
3. In the Configure group box, do the following:
   – From the Grid drop-down list, select the corresponding background grid for the Trend View.
   – From the Background drop-down list, select the corresponding background color for the trend view or click More color to define a customized color.
4. In the Titles group box, do the following:
   – Type a descriptive Trend View name.
   – Type a title for the left Trend View border.
   – Type a title for the right Trend View border.
5. Click Save 📜.
    The edited properties are saved to the Trend database.

8.5.7 Defining Axis Properties

▷ A Trend View is open.

1. Click Properties 🌐.
2. Click the Axis Properties tab (see Axis [➙ 175]).
3. Type a title for the:
   – Left axis property.
   – Right axis property.
   – X-axis property.
4. Click Save 📜.
    The edited properties display in the Trend View.

8.5.8 Positioning Legend

▷ A Trend View is open.

1. Click Properties 🌐.
2. Click the Legend Properties tab (see Legends [➙ 176]).
3. Select the appropriate position (top, bottom, left, right) from the Legend drop-down list.
4. Click Save 📜.
    The legend is positioned as selected in the current Trend View.
8.5.9 Defining Line Properties

▷ A Trend View is open.
1. Select the series for editing from the legend for the Trend View.
2. Click Properties.
3. Click the Series Properties tab (see Series \[\rightarrow 176\]).
4. Select Visible and enable it.
5. Select the appropriate type from the Series line type drop-down list.
6. Select the appropriate style from the Series line style drop-down list.
7. Select the appropriate color from the Series stroke color drop-down list.
8. Select the appropriate line thickness from the Series stroke thickness drop-down list.
9. Click Save.

▷ The edited properties are saved for the particular Trend View to the Trend database.

<table>
<thead>
<tr>
<th>Line Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line type</td>
</tr>
<tr>
<td>![Line type icon]</td>
</tr>
</tbody>
</table>

NOTE:
Do not select too thick a line if you want to display the Trend curve with marker. The marker will disappear behind a thick line.

8.5.10 Displaying Markers

You want to further emphasize the measurement time using a symbol

▷ A Trend View is open.
▷ The Show quality icons property must be selected (see Displaying Quality Attributes \[\rightarrow 198\]).
1. Select the series for editing from the legend for the Trend View.
2. Click Properties.
3. Click the Series Properties tab (see Series \[\rightarrow 176\]).
4. Select the **Show markers** check box.
   - Select the corresponding type from the **Marker style** □ ■ △ drop-down list.
   - Select the appropriate style from the **Marker size** drop-down list.

5. Click **Save**.
   - The edited properties are saved to the Trend database.

**NOTE:**
Be careful not to select too thick a line if you want to display markers. The marker disappears behind a thick line.

### 8.5.11 Displaying Measured Values in Trend View

You want to also display the measured value for the data point at the time of the measured value.

- A Trend View is open.
- The **Show quality icons** property must be selected (see Displaying Quality Attributes [➔ 198]).

1. Select the **series** for editing from the **legend** for the Trend View.

2. Click **Properties**.

3. Click the **Series Properties** tab (see Series [➔ 176]).

4. Select the **Show values** check box. **NOTE:** Values displayed on series when Trend View is stopped.

5. Click **Save**.
   - The current measured values are updated in the chart each time a data point's measured value changes.

**NOTE:**
Measured values display on top of one another when the changes to the measured values occur in quick succession or the selected time range is too large.

Since the measured values are no longer readable, select a smaller time range or switch off the labels.

### 8.5.12 Displaying Quality Attributes

You want to also display the quality attribute for the data point at the time of the measured value.

- A Trend View is open.
1. Select the **series** for editing from the legend for the Trend View.

2. Click **Properties**.

3. Click the **Series Properties** tab (see Series [→ 176]).

4. Select the **Show quality icons** check box.

5. Click **Save**.

6. Click **Stop**.

   - Interventions or states that are not Normal display with the corresponding quality attribute.

   For example, ![Alert](see also Quality Attributes [→ 190])

**NOTE 1:**
The quality attributes are hidden when you re-click **Run** and the trend series is updated.

**NOTE 2:**
You must select **Advanced display if chart stopped** in the **Chart Properties** tab (acts on all series) if you want to display quality attributes during update. If there are too many symbols, the update to the Trend View can take some time.

**NOTE 3:**
With the reduced display 🟢, not all quality attributes can display. In order to display all quality attributes, limit the time period.

---

### 8.5.13 Positioning the Y-Axis

- A Trend View is open.

  1. Select the **series** for editing from the **legend** for the Trend View.

  2. Click **Properties**.

  3. Click the **Series Properties** tab (see Series [→ 176]).

  4. In the drop-down list, select **Y-axis position**.

  5. Click **Save**.

   - The Y-axis displays either on the left or right side of the chart.

**NOTE:**
The position is set and cannot be changed for digital and multistate data types.

---

### 8.5.14 Editing Background or Line Colors

- A Trend View is open.

  1. Click **Properties**.

  2. Do one of the following:
8. Trends
Defining Trend Views

- Click the **Chart Properties** tab (see Chart [➜ 175]) to change the background color.
- Click the **Series Properties** tab (see Series [➜ 176]) to change the line color for a series.

3. Then select the appropriate series from the legend.
4. Select the drop-down list for colors.
5. Select one or the predefined colors or click More colors.
6. Select the color:
   - Click the predefined color pattern (small squares) or drag the slider (right-click) until you reach the desired color. Click the large square for color selection.
   - Click the **Color Picker** and drag the cursor to the desired location on the screen.

7. Click Save .
   - The edited color properties are assumed.

8.5.15 Showing, Hiding and Arranging Columns
Define the custom table view for series information and position the column correctly.

- The Trend View is open.
1. Point to and right-click the legend header.
2. Enable the required column.
   - The selected column is added to the legend view.
3. Click and hold down the left mouse button on the column header.
4. Move the column to the desired location and release the mouse button.
5. Point to the separator line and adapt the column width.
6. Click Save .

**NOTE:**
Changes to this legend view are not saved to the Trend View definition.
### 8.5.16 Deleting Trend View

- A Trend View is open or a Trend View is selected via the System Browser.

1. Click **Delete**.
2. Click **Yes** to delete the Trend View.

   The Trend View is permanently deleted from the **Trend View Definitions** folder. The Trendlog objects in the Trend View are not deleted. No recorded data is lost.

### 8.6 Offline Trendlog Objects

Offline trend data can be recorded and saved by Trendlog objects within the automation and control system even when the management station is not connected. The recorded data can then be saved in the trend database. Offline trend data can be retrieved and displayed in the Trend View.

**Creating or Deleting BACNet Trendlog Objects Online**

Creating and deleting BACnet objects online provides greater flexibility for adapting projects during operation. In other words, you can create and delete BACnet objects without engineering tools from the applicable manufacturer. The corresponding BACnet function must be supported by the automation station from the given manufacturer.

**NOTE:**

The Trendlog or Trendlog multiple objects are created permanently with the engineering tool cannot be deleted from the management station.

**NOTICE**

**Validated Projects**

Specific critical environments (for example, pharmaceutical installations and processed) require a high degree of safety and traceability of all operational workflows and user activities. A validated plant can loose its validity or must be revalidated by adding or losing BACnet objects! In such a case, do not use this function, or do not enable it in the application rights.
8.6.1 Creating Offline Trendlog Object

- The device supports the creating offline Trendlog objects without an engineering tool.
- You are in System Browser, and Trend is closed.

1. In System Browser, select the corresponding data point.
2. Select Related Items tab and click New Trend.
   - The Secondary pane opens.
3. On the data point, right-click and select Create Trendlog Object in BACnet Device.
4. In the Create BACnet Trendlog Object dialog box:
   - Type an unique name to the offline Trendlog object.
   - Select the device where you store the offline Trendlog object.
   - Type the buffer size from 0–500.
   - Select the logging type:
     Polled: The data entry is polled periodically as per the settings in Logging interval, Align intervals, and Interval offset.
     COV: The data entry is carried out when the trended property is changed.
     Trigger: Triggered when Trigger = On, a data entry is made for the data series.
     Empty: Default initiated by device.
   - NOTE: If a particular device does not support a certain initial Logging Type value, then the default value is used.
   - When logging type polled, enter the log interval cycle time (seconds) used to log values of an external data source in the trend log buffer.
5. Click OK.
   - The offline Trendlog object is created.
6. Click OK.
   - The offline Trendlog object is saved and visible in the System Browser after 10 – 60 seconds (folder Trends > Offline Log Objects > [own path structure]).

8.6.2 Creating Offline Trendlog Multiple Object

- The device supports creating offline Trendlog multiple objects without an engineering tool.
- You are in System Browser, and Trend is closed.

1. In System Browser, select the first corresponding data point.
2. Select Related Items tab and click New Trend.
   - The secondary pane opens.
3. In System Browser, select further data points and add those with drag-and-drop to the Trend View.
4. Select all these data points, right-click and select Create Trendlog Multiple Object in BACnet Device.
5. In the Create BACnet Trendlog Object dialog box:
   - Type an unique name to the offline Trendlog multiple object.
— Select the **device** where you store the offline Trendlog multiple object.
— Type the **buffer size** from 0–500. The buffer space used per value is the same for all data formats.
— Select the **logging type**:
  * **Polled**: The data entry is polled periodically as per the settings in Logging interval, Align intervals, and Interval offset.
  * **Trigger**: Triggered when Trigger = On, a data entry is made for the data series.
  * **Empty**: Default initiated by device.
**NOTE**: If a particular device does not support a certain initial **Logging Type** value, then the default value is used.
When logging type **polled**, enter the **log interval** cycle time (seconds) used to log values of an external data source in the trend log buffer.

6. Click **OK**.
   - The offline Trendlog multiple object is created.
7. Click **OK**.
   - The offline Trendlog multiple object is saved and visible in the System Browser after 10 – 60 seconds (folder Trends > Offline Log Objects > [own path structure]).

### 8.6.3 Upload Offline Trendlog Data Manually

Offline trendlog data is regulated and uploaded to the management station from the device. You must manually upload the data stored on the device to conduct analysis using the most current data.

**Trend View prior to Uploading the Data:**

- Red curve: Offline trend data is not yet updated.
- Blue curve: Online Trend data

A Trend View is open with an offline Trendlog object.

1. In the data point legend, select the **Trended Object**.
2. Do one of the following:
   - Right-click **Trended Object** and select Display Trendlog Object in **Contextual** pane.
In System Browser, select **Trends > Offline Log Objects** and then select the corresponding Trendlog object.

3. Click the **Extended Operation** tab.
4. Select **Logging enabled** property and click **Collect**.

   - Offline Trendlog data is uploaded to the management station.

**Trend View after Uploading the Data:**

- Red curve: Updated Offline Trend data
- Blue curve: Online Trend data

### 8.6.4 Automating Execution for Upload Trendlog Data

You can create an automated Trendlog data upload using the **Macro** and **Reaction Editor** functions.

**Creating Macro**

1. In System Browser, select **Application View**.
2. Select **Applications > Logics > Macros** and select the **Macro** tab.
3. Click **Create** and select **New Macro**.
4. In the **Create New Object** dialog box enter a **Name** and **Description**.
5. Click **OK**.
   - The new macro appears in the **Macro** tab.
6. Select the **Manual navigation** check box.
7. Select **Applications > Trends > Offline Log Objects > [Network name] > Hardware > [Automation station]**
8. Drag-and-drop the **Trendlog objects** in the macro configuration area.
9. In the **Command column**, select the option **Collect**.
10. Repeat Steps 8 and 9 for each Trendlog object or select multiple Trendlog objects in System Browser tree.
11. Define the initial delay in the Initial Delay column (in seconds) for a cascade Trendlog data upload.  
   **NOTE:** This cascade procedure avoids an overload of network traffic.

12. Click **Save**.

13. Creating a scheduler [➙ 204] as a next Step.  
   - The macro is defined and the Trendlog objects are assigned.

---

**Creating Scheduler**

1. In System Browser, select **Application View**.

2. Select **Applications > Logics > Reactions**.  
   - The Reaction Editor opens.

3. Select **Triggers > Time & Organization Mode** expander and click **Add**.

4. Click anywhere on the row.  
   - The fields to set the execution time opens.

5. Set the **dates**, **days** and **time** to execute the macro.

6. In System Browser, select **Applications > Logics > Macros > [MyMacro Trendlog upload]** and drag-and-drop the object to the **Output** expander section.

7. Click **Save As**.

8. Type name and description in the **Name** and **Description** fields.

9. Click **OK**.  
   - The reaction for Trendlog upload is defined.

---

**Reaction Defined for Executing Macro**
### 8.6.5 Assigning or Replacing a New Trendlog Reference

A new object reference can be added to available offline trendlog objects as needed. In this case, the collected data must first be backed up (uploaded); only then can the new object reference be assigned. Data that is not uploaded in advance can no longer be restored after being assigned anew. This applies to trendlog and trendlog multiple objects.

To assign or replace a new trendlog reference:

1. In System Browser, select **Application View**.
2. Select **Applications > Trends > Offline Log Objects > [Network name] > Hardware > [Automation station] > [Offline Trendlog object]**.
3. Click the **Extended Operation** tab.
4. Select the **Logging enabled** property and click **Collect**.
   
   **NOTE:** The current offline Trendlog data is uploaded to the management station before you reset the collected data.
5. Select **Logging enabled** property and click **Disable**.
6. Select the **Record count** property and click **Reset**.
7. Click the **BACnet Editor** tab and open the **Trended Properties** expander.
8. In System Browser, select the **Manual navigation** check box.
9. In System Browser, select **Logical View**.
10. In System Browser select the **desired data point** and drag-and-drop the selected data point in the **Trended Properties** expander.
11. Select the **property** you want to record and click **Send**.
12. Select **Applications > Trends > Offline Log Objects > [Network name] > Hardware > [Automation station] > [Offline Trendlog object]**.
13. Click the **Extended Operation** tab.
14. Select the **Logging enabled** property and click **Enable**.

   ✤ The Trendlog object is new configured and is ready to collect data.

---

### 8.6.6 Delete Offline Trendlog Object

1. In System Browser, select **Application View**.
2. Select **Trends > Offline Log Objects > [Trendlog Object]**.
3. Select the offline Trendlog object in the data point legend.
4. Right-click and select **Delete Trendlog Object in BACnet Device**.
5. Click **Yes** only if you are sure you want to delete the offline Trendlog object.

   ✤ The Trendlog object is deleted and removed from the System Browser.
8.7 Analyzing Trend Data

The collected measured values serve as an indicator for an analysis of your plant. It is important to be able to easily find the appropriate data as needed. Desigo CC provides you a number of tools including time range scrollbars, context menus with predefined times, absolute/related time entries or zoom functions.

1. In System Browser, select **Application View**.
2. Select **Applications > Trends > Trend View Definitions > [Name of folder structure] > [Name of Trend View]**.

   ⊳ The Trend View opens.

8.7.1 Switching between Automatic and Stop Mode

Automatic mode normally is used to analyze trend data (continuous scrolling of the graphic curves). The latest data are always loaded automatically from the system. You can change to manual mode for a detailed analysis (scrolling mode off). In this case, the management station data no longer is updated automatically from the system.

   ⊳ The Trend View is open.

1. Click **Stop**.

   ⊳ This stops automatic data updates and suppresses the symbol to update Trend View.
2. Define the desired date range using the slider or time bar.
3. Click **Refresh** when the symbol is available and you want to upload the latest data from the history database.
4. Click **Run** to update data on a continuous basis.

8.7.2 Selecting the Time Range using the Time Range Scrollbar

Setting Time Range and Time Window

You intend to define the visible time range as well as the corresponding time window for the Trend View.

   ⊳ You are in an active Trend View.

1. In the Trend View, point the mouse to the left or right slider (dark grey area) for the time range slider (see Time Range Scrollbar [180]).

   ⊳ The mouse pointer changes shape and the tooltip displays.
2. Press the left button and move the time range slider to the left or right until you have reached the desired time range.

   ⊳ The time range change continuously displays.

   ⊳ The Trend View displays the selected time range.
3. Move the mouse cursor to the time range slider (light grey area).
4. Press the left button and slide it to the desired time/data range.

   ⊳ The time range is displayed with the corresponding data period in the Trend View.
### Repeat Functions

- Click the time range scrollbar to the left or right of the time range slider. The time range slider moves in the corresponding direction per the time range defined in the time range slider.
- Click the left or right arrow on the time range scrollbar. The time range slider moves in the corresponding direction at a 1:10 ratio for the selected time range.

**NOTE:**

Data is compressed for display purposes only if you select a large time range or very large number of measured values. All data is displayed for smaller time ranges.

### 8.7.3 Selecting Absolute Time Range

You want to define the time window with a precise start and stop date.

1. Right-click the **time range** bar.
2. Click **Select range**.
   - The **Select Date/Time** window displays.
3. From the **Selection type** drop-down list, select the **Absolute**.
4. Click the displayed **Start time**.
   - The **Calendar** dialog box opens.
5. Enter the desired **start date** in the calendar dialog field.
   - Select **Month/Year** with the symbols.
   - Click the appropriate **Date**.
6. Click the displayed time at **Start time** and enter the desired **start time**.
7. Click the displayed **End time**.
   - The **Calendar** dialog box opens.
8. Click the displayed time at **End time** and enter the desired **end data** in the calendar dialog box.
   - Select **Month/Year** with the symbols.
   - Click the appropriate **Date**.
9. Click the displayed time at **End time** and enter the desired **Stop time**.
10. Click **OK**.
The Select Date/Time dialog box closes and the Trend View displays the defined time range.

8.7.4 Selecting Relative Time Range from a Start Date
You want to define a time window from a certain start date with a set time range.

1. Right-click the time range bar
2. Click Select range.
3. Select the Relative option in the Selection type drop-down list.
4. In the Interval text field, enter a time range from 1 to X and select the corresponding time unit in the drop-down list.
5. From the Start/end time drop-down list, select the Starting.
6. Click the displayed date and enter the desired start date in the Calendar dialog.
   - Select Month/Year with the symbols.
   - Click the appropriate Date.
7. Click the displayed time and enter the desired start time.
8. Click OK.
   The Select Date/Time dialog box closes and the Trend View displays the defined time range.

8.7.5 Selecting Relative Time Range from a Stop Date
You want to define a time window from a certain end date with a set time range.

1. Right-click the time range bar
2. Click Select range.
8. Trends
Analyzing Trend Data

3. The Select Date/Time window displays.

4. From the Selection type drop-down list, select Relative.

5. In the Interval text field, enter a time range from 1 to X and select the corresponding time unit in the drop-down list.

6. From the Start/end time drop-down list, select Ending.

7. Click the displayed date and enter the desired stop date in the Calendar dialog box.
   - Select Month/Year with the symbols.
   - Click the appropriate Date.

8. Click OK.

9. The Select Date/Time dialog box closes and the Trend View displays the defined time range.

8.7.6 Selecting Relative Time Range from a Current Date
You want to define a time window from the current date with a set time range.

1. You are in an active Trend View.

2. Right-click the time range bar

3. The Select Date/Time window displays.

4. From the Selection type drop-down list, select Relative.

5. In the Interval text field, enter a time range from 1 to X and select the corresponding time unit in the drop-down list.

6. Select the Ending now option in the Start/end time drop-down list.

7. Click Now.

8. Click OK.

9. The Select Date/Time dialog box closes and the Trend View displays the defined time range.
8.7.7 Selecting Time Range from Predefined Time Ranges
Select the visible time range based on predefined time ranges.

**Time range**
1. You are in an active Trend View.
2. Move the mouse cursor to the **time range** slider (light grey area).
3. Right-click the **time range** slider.
   - Predefined time ranges display.
4. Select the desired **time range**.
   - The time range displays with the corresponding data period in the Trend View.

**NOTE:**
The display calculation is always based on current visible date range. Depending on the position of the current Trend View, the starting point may not be at the start of the day.

**Start/Stop Range**
1. You are in an active Trend View.
2. In the Trend View, point the mouse to the left or right end point (dark grey area) for the time range slider.
   - The mouse pointer changes shape and the tooltip displays.
3. Right-click the **time range** slider.
   - Predefined time ranges display.
4. Select the desired **time range**.
   - The time range displays with the corresponding data period in the Trend View. The display calculation is always based on current visible date range as displayed in the tooltip.

8.7.8 Using Comparative View
The comparative view is ideal for extended data analysis with time offset.

1. Click **Stop**.
2. Click **Compare View** to open a comparative view.
   - The same Trend View displays a second time.
3. Define the appropriate time/date range with the scrollbar.
4. Select time offset **Forward** or **Backward**.
5. Do one of the following:
- Click one of the predefined offset buttons \(1\text{hr}\) (for example, 1 hour).
- Select your own range by selecting the dark button \(3m\; 1y\; 1d\) (for example, 3 hours) and select the time offset \(3\text{hours}\)

\(\Rightarrow\) Comparison view displays with the corresponding time offset and measured values.

### 8.7.9 Using Mouse Zoom

The zoom function allows you to select a time range in the currently selected Trend View (applies as well for the comparison view) by zooming in on the X-axis and Y-axis.

- You are in an active Trend View and in **Stop** mode (atement symbol) displays.

1. Click **Zoom**.
2. Using your cursor, move the point to the left zoom starting range.
   - The point changes shape and the tooltip displays the current position.
3. Hold down the left mouse button, and drag the pointer to the right zoom end range.
4. Release the mouse button at the desired position.
   - The selected zoom range displays in the Trend View.
5. Click **Zoom** again.
   - The original time range, prior to the zoom in, displays, even if you zoom multiple times.

### 8.7.10 Selecting Table View

Switching between graphic and table allows for efficiently analyzing data.

1. Click **Stop**.
   - The automatic data update is stopped.
2. Click **Table View** (see Table View [264]).
   - The table opens in default view. Click the time stamp header to sort the rows by ascending or descending order.
3. Click **to show or hide interpolated values.**
   - Interpolated values are displayed in light-grey.
4. Click **Table View** again.
   - The graphical Trend View re-displays.
5. Click **Run** to start the automatic data update.
NOTE 1:
When you use Export in the table view, the exported data range depends on the time setting in the graphical view.

NOTE 2:
Interpolated values are not exported to an export file.

NOTE 3:
The priority displays in the table if a subsystem supports information on BACnet write priority (1-16).

8.7.11 Temporarily Highlighting Data Series
During analysis, it is helpful to temporarily bring a certain series in the Trend View to improve the readability of the trend curve.

1. Drag the pointer to the trend curve you want to bring forth.
   - All non-selected trend curves are reduced in their display intensity.
   - The measured value as well as time and date are displayed in tooltip at the pointer position.
   - The quality attribute is brought forth when only one trend curve is visible.

2. Drag the pointer to once again view all trend curves.

8.7.12 Temporarily Hiding Data Series
You can temporarily or permanently hide multiple series to increase the readability of the Trend View.

1. Click Properties.
   - The menu bar displays above the Trend View.

2. Select the series you want to hide in Legend.

3. Click Series Properties.

4. Clear the Visible check box.
   - The menu bar is hidden.
   - The series is hidden in the Trend View.
   - The Trend data is still recorded for this series, but is no longer displayed.

5. Click Save.

Repeat Steps 2 through 4 for each additional series you want to hide.

NOTE:
As an alternative, you can click either or in the legend. This allows you to show or hide each individual trend curve.
8.7.13 Removing Data Series from Trend View

- You are in Trend View and multiple trend curves are displayed.
  1. Select the series you want to hide in Legend.
  2. Clear the check box in the Remove column.
     - The Remove Trend Series dialog box displays.
  3. Select on the Stop trending this object on the Management System check box:
     - Cleared: The selected series is deleted from Trend View. The Trendlog object is still available in the Online Log Objects folder. All data continues to be recorded (Subscribe=On).
     - Selected: The series and the associated Trendlog object are deleted. The Trendlog object is removed from the Online Log Objects folder. All recorded data remains available, but no new data is recorded (Subscribe = Off). The previously logged data is still available if you reuse the same data point in the Trend View. However, there is a gap in the data between delete and re-generation.
  4. Click OK.
     - The trend series is removed from the current Trend View.
  5. Click Save.

**NOTE:**
When an object is deleted, no warning displays if a Trendlog object is used in several Trend Views! All associated data is lost in the associated Trend Views.

8.8 Exporting Trend Data

Process data recorded and saved for a Trend View definition can be exported to a CSV export format. Third-parties can analyze the data as needed. The workflow illustrates how to export trend data from Desigo CC.

8.8.1 CSV Format

The Trend definition contents can be exported to CSV file format. The CSV files only contain the values for the selected time range (selected using the slider or time selector) and not all values of a Trendlog object.

- The Trend View is open.
- The current Trend View has stopped recording.
  1. Point to the time slider (light-grey area).
  2. Right-click the time slider, and select the desired time range.
     - The selected time range displays in the Trend View.
3. (Optional) Click **Table View**.

4. Click **Export**.

   **NOTE:** The export file can contain reduced data (highlighted in pink). Use reporting to export all data.

5. Type the **target folder** and a unique **file name**.

6. Click **Save**.

   - The export file is generated at the defined location.

### CSV File Format Description

The **Comma-Separated Values** file format is a type of file where data is saved in tabular format. CSV export data is divided into two areas in Desigo CC. The first contains three lines with information on the Trend View definition and the data point. From Line 4 to Line \( x \), the data point value is saved dependent on time stamp or data stamp.

<table>
<thead>
<tr>
<th>Description</th>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trend View definition name.</td>
<td>Trend View definition name.</td>
<td>Data point name with the attribute name.</td>
<td>First data line of the data point.</td>
<td>Second data point information.</td>
</tr>
</tbody>
</table>
- When there is more than one data point information state, the states are separated by comma and space.
- In Excel, the cell is comma separated, regardless of the regional settings by the current user.
- In Excel, the end of the line is = CR, LF.

**NOTE 1:**
The data points unit is not exported in this version.
**NOTE 2:**
Individual lines are not synchronized That is the time stamps in each line normally differ between the various Trendlog objects.

The following table lists supported data point states:

<table>
<thead>
<tr>
<th>Trend View Symbol</th>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Value_OK</td>
<td>Value in <em>Normal</em> state.</td>
</tr>
<tr>
<td></td>
<td>Value_InAlarm</td>
<td>Value in <em>Alarm</em> state.</td>
</tr>
<tr>
<td></td>
<td>Value_OutOfService</td>
<td>Value in <em>Out of Service</em> state.</td>
</tr>
<tr>
<td></td>
<td>Value_Fault</td>
<td>Value in <em>Fault</em> state.</td>
</tr>
<tr>
<td></td>
<td>Value_Overriden</td>
<td>Value in <em>Overridden</em> state.</td>
</tr>
<tr>
<td></td>
<td>LogDisabled</td>
<td>Trendlog object is disabled.</td>
</tr>
<tr>
<td></td>
<td>LogEnabled</td>
<td>Trendlog object is enabled.</td>
</tr>
<tr>
<td></td>
<td>BufferPurged</td>
<td>Buffer in the Trendlog object is deleted.</td>
</tr>
<tr>
<td></td>
<td>DataLost</td>
<td>No connection to data point.</td>
</tr>
<tr>
<td></td>
<td>Overflow</td>
<td>Trendlog buffer is full.</td>
</tr>
</tbody>
</table>

### 8.9 Printing

There are two methods for printing a Trend View:
- Using the Reporting function (see Inserting a Plot)
- Print function in the Trend View
8.9.1 Print Preview and Properties

Description

1 Toolbar.
2 Preview of print view.
3 Select printer.
4 Set margins in pixels.
5 Select paper size.
6 Select paper format (portrait or landscape).
7 Select Fit to page to display the selected area on a page.
   You can modify print options on the toolbar if Fit to page is cleared.
8 Closes the Print dialog box without printing.
Prints the document and closes the Print dialog box.

8.9.2 Printing Trend View

▷ A Trend View is open.
▷ You must define the Print in color setting in advance if you want to print in color.

1. Select the time range to print using the time range scrollbar. The time range displayed on the screen is printed.

2. Click Print 📹.

3. Select or clear the Fit to page check box. Select the corresponding option in the toolbar if Fit to page is not selected.

4. Define print properties for:
   – Margins (top, bottom, left and right).
   – Printer.
   – Orientation (portrait or landscape).
   – Paper size.

5. Click Print and Close to print, or click Close to cancel the print process.
9 Reports

The main function of Reports is to collect data from the runtime system, and allow you to present this data in a customized manner.
This chapter provides a description of the Desigo CC Reports configuration and the corresponding configuration procedures.

9.1 Overview of Reports

A report is a formatted and organized presentation of data. The Reports application lets you configure and produce a variety of reports on the functioning of the building control system.

To compose a report, you configure a Report Definition that specifies:
- The elements that you want to include in the report (such as tables, plots, logos, form controls, text and so on), and their layout.
- Appropriate filter(s): Name, Condition, Time, and/or Row to populate the elements of the report with information. For example, if you want a report on a room's activity data over the past month, you could define a Name Filter as well as Time Filter in an Activities table.
- The formatting you want to apply to the report elements, and the page layout.

You can also configure a Report Output Definition to specify the type of output (PDF or XLS), and the output destination (file, email, or printer).

Once you configure a Report Definition, you can save it for later use, run it, or schedule the report to be run at a specified time.

You can use reports as a reference or as a troubleshooting mechanism. Reports are helpful during system operation. For example, you can:
- View a mixed report containing:
  - A table displaying details of all active events for a floor of a building
  - A table displaying a history report of events
  - A trends plot displaying the temperature variations gathered from temperature sensors
- Export trend data for statistical analysis to:
  - An XLS file
  - A CSV file (according to the EMC requirement)
- Schedule production of a report using macros and reactions
- Send a report to someone using email, to a printer as a .pdf, or to a folder as a file

You can also export and import Report Definitions and logos.

Pre-configured Report Definitions and associated logo files are available at: ...

You can also create and configure reports for operating procedures \(\rightarrow\) 220. These reports are used during Assisted Treatment \(\rightarrow\) 106 to enter information about how the alarm or event is being handled.

NOTE:
You cannot use trend plots and trend tables in reports for operating procedures, because these elements do not display any data when the report is executed from Assisted Treatment.
Report Types
Reports allow you to create different types of reports, including (but not limited to):
- BACnet Event Information
- BACnet Alarm Summary
- BACnet Enrollment Summary
- Objects
- Active Events
- Activities
- Events
- Event Details
- Trends plot
- Trends table
- Graphics
- All Logs

9.1.1 Reports for Operating Procedures
Reports configured in operating procedure steps allow you to view and enter Event Treatment related information when executed for a selected event from Assisted Treatment [两手106]. In addition to the existing reporting elements, you can add Form Controls [两手236] to these reports. You create and configure a report for operating procedure steps in the same way as you would create [两手262] and configure [两手263] any report. When executed in the context of the selected event, the report displays the event treatment related information and allows you to enter information in the form controls.

NOTE:
You cannot use trend plots and trend tables in reports for operating procedures as these elements do not display any data when the report is executed from Assisted Treatment.

You can enter information in the following scenarios:
- The event is treated for the first time; the operating procedure step is configured as repeatable and is in progress.
- You re-select the same event, for a repeatable step that is not yet complete.

If you re-select the same event with a non-repeatable step that is complete, you cannot perform activities such as editing information, sorting entries in tables, or resizing columns. You can only view and route the information to a file, email, or printer as configured in the report definition.

Information entered in the form controls can be viewed by users on different client machines for the same step in the same event. However it can be edited only if the step is configured to be repeatable.
9.2 Reports Workspace

This section gives an overview of the Reports workspace.

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>System Browser</td>
<td>Displays all the saved Report Definitions in Application View &gt; Applications &gt; Reports.</td>
</tr>
<tr>
<td>2</td>
<td>Reports Toolbar [➡️ 222]</td>
<td>Contains icons for performing various actions in Reports. Reports Toolbar For Operating Procedures [➡️ 223] - Displays only when the report is executed for a selected event from Assisted Treatment. Contains icons for saving user input and routing information.</td>
</tr>
<tr>
<td>3</td>
<td>Reports Ribbon</td>
<td>Contains several tabs and group boxes to help you define a Report Definition. The tabs available on the ribbon are: Home [➡️ 224], Filter [➡️ 237], Layout [➡️ 245], Data [➡️ 248], and Settings [➡️ 249]. <strong>NOTE:</strong> The Reports ribbon is only visible when you create a new Report Definition or select an existing one.</td>
</tr>
<tr>
<td>4</td>
<td>Report Definition</td>
<td>Displays the following: <strong>Edit mode:</strong> Workspace where you configure a Report Definition. <strong>Run mode:</strong> Workspace where you view an executed report.</td>
</tr>
<tr>
<td>5</td>
<td>Report Management Section [➡️ 255]</td>
<td>Displays a report snapshot and documents for the executed reports. <strong>NOTE:</strong> This section does not display when the report is executed for a selected event from Assisted Treatment.</td>
</tr>
<tr>
<td>6</td>
<td>Extended Operation Tab</td>
<td>Displays the properties of the selected Report Definition. The <strong>Execute</strong> button allows you to run a Report Definition. <strong>NOTE:</strong> You must configure a Report Output Definition [➡️ 249] for the selected Report Definition.</td>
</tr>
<tr>
<td>7</td>
<td>Related Items Tab [➡️ 256]</td>
<td>Displays the following: <strong>New Report:</strong> Opens a new Report Definition for configuration. <strong>Related Report:</strong> Displays the name(s) of the report(s) related to the selected System Browser object. <strong>Show-in-Related Items Report:</strong> Displays the name of the report (s) that has the <strong>Show in Related Items</strong> check box selected.</td>
</tr>
</tbody>
</table>
### 9.2.1 Reports Toolbar

The Reports toolbar contains icons that help you perform reporting operations quickly. This toolbar is present in both Edit mode and Run mode.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="New Icon" /></td>
<td>New</td>
<td>Opens a sub-menu where you can select: New Report [→ 262] and New Folder [→ 263].</td>
</tr>
<tr>
<td><img src="image" alt="Delete Icon" /></td>
<td>Delete</td>
<td>Removes the current Report Definition [→ 296] or Report folder and deletes its entire configuration from the System Browser tree.</td>
</tr>
<tr>
<td><img src="image" alt="Save Icon" /></td>
<td>Save [→ 279]</td>
<td>Saves the configuration of the currently selected Report Definition or saves a newly created and configured Report Definition. <strong>NOTE:</strong> This command is dimmed until you modify the current Report Definition.</td>
</tr>
<tr>
<td><img src="image" alt="Save As Icon" /></td>
<td>Save As [→ 279]</td>
<td>Saves the configuration of the currently selected Report Definition as a new Report Definition, or saves a newly created and configured Report Definition.</td>
</tr>
<tr>
<td><img src="image" alt="Save as Default Icon" /></td>
<td>Save as Default [→ 279]</td>
<td>Saves the selected Report Definition as the default report template.</td>
</tr>
<tr>
<td><img src="image" alt="Properties Icon" /></td>
<td>Properties</td>
<td>Shows or hides the Reports ribbon in Edit mode [→ 258].</td>
</tr>
<tr>
<td><img src="image" alt="Run Icon" /></td>
<td>Run</td>
<td>Auto-closes Edit mode and executes the current Report Definition in Run mode [→ 258]. <strong>NOTE:</strong> You can run up to five reports simultaneously; an error message displays for any subsequent clicks of the Run or Run As icon.</td>
</tr>
<tr>
<td><img src="image" alt="Run As Icon" /></td>
<td>Run As</td>
<td>Opens a sub-menu where you can select a language from a list of languages supported in Desigo CC. Languages currently supported for report execution are: en-US, fr-CA.</td>
</tr>
<tr>
<td><img src="image" alt="Stop Icon" /></td>
<td>Stop</td>
<td>Stops report execution of the selected Report. This command is available only while the report is running. <strong>NOTE:</strong> You can also stop the report execution using the STOP button that becomes available in the Report Management section while the report is running.</td>
</tr>
<tr>
<td><img src="image" alt="Edit Icon" /></td>
<td>Edit</td>
<td>Opens the Report Definition in Edit mode. In this mode you can design the layout of a report. This command is available only in Run mode.</td>
</tr>
<tr>
<td><img src="image" alt="Create and view PDF Icon" /></td>
<td>Create and view PDF [→ 287]</td>
<td>Starts creating PDF document for the current Report snapshot. The maximum number of pages in one PDF document is 500. When the number of pages exceeds 500, the PDF document splits into two. This process goes on until all the data in that specific report snapshot is moved to the document. The PDF creation progress for all the split PDF documents displays under the same Report snapshot in the Report Management section. When successfully created, the PDF displays in Adobe Reader in Reports. This command is available only in Run mode.</td>
</tr>
<tr>
<td><img src="image" alt="Create and view Excel Icon" /></td>
<td>Create and view Excel [→ 288]</td>
<td>Starts creating Excel document for the current Report snapshot. The maximum number of rows...</td>
</tr>
</tbody>
</table>
in an Excel document is $1,048,575$ (Excel limit). When the number of rows exceeds this limit, the Excel document splits into two. The process of the Excel creation for all the split Excel documents displays under the same Report snapshot in the Report Management Section. When successfully created, the Excel document displays in MS Excel in Reports. This command is available only in Run mode.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Report Management Icon" /></td>
<td>Report Management</td>
<td>Shows or hides the Report Management section.</td>
</tr>
<tr>
<td><img src="image" alt="Export Icon" /></td>
<td>Export</td>
<td>Exports the Report Definition(s) as an .xml file to a selected location.</td>
</tr>
<tr>
<td><img src="image" alt="Import Icon" /></td>
<td>Import</td>
<td>Imports the Report Definition(s) and logo(s). The Import icon is enabled only when the report folder is selected in System Browser.</td>
</tr>
<tr>
<td><img src="image" alt="Save PDF as Icon" /></td>
<td>Save PDF as</td>
<td>Saves the PDF report output. <strong>NOTE:</strong> Displays when clicking Create and view PDF in the generated report.</td>
</tr>
<tr>
<td><img src="image" alt="ZoomIn Icon" /></td>
<td>ZoomIn (+10%)</td>
<td>Allows you to zoom in the view of the PDF document by +10% with each mouse click. <strong>NOTE:</strong> Displays when clicking Create and view PDF in the generated report.</td>
</tr>
<tr>
<td><img src="image" alt="ZoomOut Icon" /></td>
<td>ZoomOut (-10%)</td>
<td>Allows you to zoom out the view of the PDF document by -10% with each mouse click. <strong>NOTE:</strong> Displays when clicking Create and view PDF in the generated report.</td>
</tr>
<tr>
<td><img src="image" alt="Print Icon" /></td>
<td>Print</td>
<td>Prints the PDF document. <strong>NOTE:</strong> Displays when clicking Create and view PDF in the generated report.</td>
</tr>
</tbody>
</table>

### 9.2.1.1 Reports Toolbar For Operating Procedures

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Save User Input Icon" /></td>
<td>Save User Input</td>
<td>Saves the Event Treatment related information you entered in the report for operating procedures [220], when it is executed for a selected event from Assisted Treatment [106]. You can view the saved information if you re-select the same step in the same event. Additionally, users on other client machines can also view this information for the same step in the same event. If you move to another step or event or exit the current step without saving the information, a save confirmation message displays. <strong>NOTE:</strong> This command is available only if the report contains form controls.</td>
</tr>
<tr>
<td><img src="image" alt="Send to Output Icon" /></td>
<td>Send to Output</td>
<td>Routes the report for operating procedures to a file, email, or printer according to the Report Output configuration settings [292].</td>
</tr>
</tbody>
</table>
NOTE: If you have not specified the report output configuration settings, the information is routed to the path specified in the location supervised folder in the System Browser: Management View > Management System > Servers > Main Server > Report Manager > Report Default Folder.

9.2.2 Reports Ribbon — Home Tab
The Home tab is the main tab of the Reports ribbon.

![Home Tab]

The available group boxes in the Home tab are:

**Insert Group Box**
The Insert group box allows you to insert different reporting elements such as tables, plots, text, keywords, and logos in the Report Definition.

- **Table Group Box** (➙ 225): Displays different tables that you can add to a Report Definition.
- **Plot Group Box** (➙ 233): Displays different plots (such as graphics and trends) that you can add to a Report Definition.
- **Text Group Box**: Displays a label that you can add to a Report Definition. You can insert labels (Blank, Page, and Report) in the header/footer section or anywhere in the Report Definition. Using labels, you can type text to be displayed in the Report Definition or insert keywords. By default the labels display all the languages configured in the system.
- **Keyword Group Box** (➙ 233): Displays all the keywords that you can add to a Report Definition.
- **Logo Group Box** (➙ 235): Displays all the logos that you have added to the Manage Logo dialog box. You can drag-and-drop these logos onto the Report Definition.
- **Form Controls Group Box** (➙ 236): Displays the controls that you can use to create forms. You can drag-and-drop these controls in the Report Definition.

**View Group Box**
Use the View group box to choose how much of a Report Definition to view on the screen.

- **Page Width**
  Adjusts the width of a report page to use all the available width of the Reports workspace.
- **Full Page**
  Displays a full page to maximize the space available in the Reports workspace.
- **Original Size**
  Displays the width of a report page in normal size.
Options Group Box
The Options group box provides additional options available in the Home tab:

- Show in Related Items check box
  While creating a Report Definition, enable this check box to create a standard report. When you select an object from System Browser, this standard report displays as a link in the Related Items.

- Date/time in UTC format check box
  Selecting this check box, the date and time you type is represented in UTC format. The following elements in Reports display date/time values:
  - Keywords (Date, Time, Report Start, Report Stop, Content Start, Content Stop)
  - Columns of the tables
    - Source Time column (Activities)
    - Alert time and Transition time (Events)
    - Creation date time (Active Events)
    - Date
    - Alert time and Alert went (for parent record of Event Details)
    - Time (for child record of Event Details)
    - Event Stamp Fault, Event Stamp Off-Normal and Event Stamp Normal (BACnet Event Information)
  - Time Filter dialog box
  - Condition Filter dialog box (Data in the reports can be filtered based on data time values)

- Fixed Locale check box
  Selecting this check box and a locale from the corresponding list, displays the date/time and decimal separator according to the format set for the locale on the server. For example, if you select English (United States) as the locale, the date/time and decimal separator set for English (United States) on the server displays in the report.

9.2.2.1 Table Group Box
A table is a collection of records that display in tabular format. Tables in a Report Definition can contain a huge number of records which cannot be viewed at the same time.

It is recommended that you have a maximum of ten tables in a single report. If you need more than ten tables, you must create multiple reports.

Reporting incorporates a paging mechanism that optimizes the number of records that display in a table. The configured height of a table in the Layout tab determines the number of records that display.

The Table group box contains the following different tables.

<table>
<thead>
<tr>
<th>Table Type</th>
<th>Default Columns</th>
<th>Additional Columns</th>
<th>Support/Limitations</th>
</tr>
</thead>
</table>
| Objects Table and its extensions: Schedule and Related Items | - Default columns displayed are: Object Description - Object Designation - Function - Discipline - Subdiscipline - Type - Subtype | - Supports the following additional columns: - Alias - Default Property - Object Designation [Application View] - Object Designation [Current View] - Object Designation [Management View] - Object Identifier [Internal] - Object Location | - Does not support the Time Filter
- For more information on the Objects table and its configurations, see Objects Report [→ 301].
- The values of filters applied on the Alias column are case sensitive. |
### Active Events
- Category
- Cause
- State
- Object Designation
- Object Description
- Discipline
- Subdiscipline
- Creation Date Time
- Object Property
- Source Status

- Supports the following additional columns
  - Alias
  - Available Commands
  - Customer Text
  - Event ID
  - In process by
  - Intervention Text
  - Is Maintenance
  - Location
  - Name
  - Object Designation [Application View]
  - Object Designation [Current View]
  - Object Designation [Management View]
  - Object Identifier [Internal]
  - Object Location
  - Object Location [Application View]
  - Object Location [Current View]
  - Object Location [Management View]
  - Object Name
  - Observer Source ID
  - Source ID
  - Suggested Action

- Does not support the Time Filter
- The values of filters applied on the **Alias** column are case sensitive.

### Activities
- Source Time
- Object Description
- Object Designation
- Action
- Log Type
- Previous Value
- Value
- Status
- User Name
- Management Station
- Message Text

- Supports the following additional columns
  - Alias [Associated Object]
  - Alias [Object]
  - Associated Object Description
  - Associated Object Designation
  - Associated Object Location
  - Associated Object Name
  - Associated Object Name [Internal]
  - Discipline
  - DPEName 1

- Supports: Name, Condition, Time, and Row Filter. When the activities table is inserted, by default the Name Filter is set to **.*.**
- For more information on the Activities table, its constraints, and configurations, see Activities Report [→ 304].
- The values of filters applied on the **Alias [Object]** column are
### Events

| Event | Default | Supports the following additional columns | Supports: Name, Condition, Time, and Row Filter. When an events table is inserted, by default, the Name Filter is set to **.**
|---|---|---|---
| Event Time | | Event Message Text | **For more information on the Events table and its constraints, see Events Report [➡️313].**
| Event State | | Event Mode | **The values of filters applied on the Alias [Object] column are case sensitive.**
| Event Category | | Event Source |
| Event Cause | | Event Value |
| Event ID | | Event Went |
| Object Description | | Object Designation [Application View] |
| Object Designation | | Object Designation [Current View] |
| User Name | | Object Designation [Management View] |

---

Supports the following additional columns:
- Alias [Object]
- Alias [Observer]
- Discipline
- DPEObserver
- Event Message Text
- Event Mode
- Event Source
- Event Value
- Event Went
- Object Designation [Application View]
- Object Designation [Current View]
- Object Designation [Management View]
- Object Identifier [Internal]
- Object Location
- Object Location [Application View]
- Object Location [Current View]
- Object Location [Management View]
- Object Name
- Object Property
- Observer Description
- Observer Designation
- Observer Location
- Observer Name
- Observer Identifier [Internal]
- Subdiscipline
- Subtype
- Transition Time
- Type
- Unit
- Went Text

---

- **Attachment**
- DPEName 2
- Error
- Object Designation [Application View]
- Object Designation [Current View]
- Object Designation [Management View]
- Object Identifier [Internal]
- Object Location
- Object Location [Application View]
- Object Location [Current View]
- Object Location [Management View]
- Object Name
- Object Property
- Previous Quality
- Quality
- Subdiscipline
- Subtype
- Type
- Unit

case sensitive.
### Details

| columns displayed in the Parent table are: | additional columns |
| - Event Time | - Alias [Object] |
| - Event Category | - Alias [Observer] |
| - Event Cause | - Discipline |
| - Object ID | - DPEObserver |
| - Object Description | - Event Message Text |
| - Object Designation - | - Event Mode |
| | - Event Source |
| | - Event Value |
| | - Event Went |
| | - Object Designation [Application View] |
| | - Object Designation [Current View] |
| | - Object Designation [Management View] |
| | - Event ID |
| | - Object Identifier [Internal] |
| | - Object Location |
| | - Object Location [Application View] |
| | - Object Location [Current View] |
| | - Object Location [Management View] |
| | - Object Name |
| | - Object Property |
| | - Observer Description |
| | - Observer Designation |
| | - Observer Location |
| | - Observer Name |
| | - Observer Identifier [Internal] |
| | - Subdiscipline |
| | - Subtype |
| | - Type |

- Supports child records. Child Rows show data of the system related to the event. These are:
  - State transitions of the corresponding event.
  - Activity log data related to the point which caused the event.

- The following are the columns of a child (nested) table:
  - Time
  - Value
  - Previous Value
  - User Name
  - Management Station
  - Action
  - Attachment
  - Object Property

**NOTE:** These columns are added to the table in Run mode. In Edit mode, they are not visible, but can be selected or removed by clicking the Child tab in the Select Column dialog box.

- The values of filters applied on the Alias [Object] column are case sensitive.

- For more information on the Event Details table, its constraints, and configurations, see Event Details Report [→ 307].

### BACnet Event Information

- Event Stamp Fault
- Event Enable
- Aced Transitions
- Device Description
- Event Stamp Off-Normal
- Event Stamp Normal
- Event Priority Off-Normal
- Notify Type
- Alarm State

- Supports the following additional columns
  - Alias [Device]
  - Device Designation [Application View]
  - Device Designation [Current View]
  - Device Designation [Management View]
  - Device Identifier [Internal]
  - Device Location
  - Device Location [Application View]
  - Device Location [Current View]

- Supports only the Name and Row Filter.
<table>
<thead>
<tr>
<th>BACnet Alarm Summary</th>
<th>Supports the following additional columns:</th>
</tr>
</thead>
<tbody>
<tr>
<td>- Object Id</td>
<td>- Alias [Device]</td>
</tr>
<tr>
<td>- Event Priority</td>
<td>- Device Designation</td>
</tr>
<tr>
<td>- Fault</td>
<td>- Device Designation [Application View]</td>
</tr>
<tr>
<td>- Acked Transitions</td>
<td>- Device Designation [Current View]</td>
</tr>
<tr>
<td>- Alarm State</td>
<td>- Device Designation [Management View]</td>
</tr>
<tr>
<td>- Object ID</td>
<td>- Device Identifier [Internal]</td>
</tr>
<tr>
<td></td>
<td>- Device Location</td>
</tr>
<tr>
<td></td>
<td>- Device Location [Application View]</td>
</tr>
<tr>
<td></td>
<td>- Device Location [Current View]</td>
</tr>
<tr>
<td></td>
<td>- Device Location [Management View]</td>
</tr>
<tr>
<td></td>
<td>- Device Name</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>BACnet Enrollment Summary</th>
<th>Supports only the Name (on devices only) and Row Filter.</th>
</tr>
</thead>
<tbody>
<tr>
<td>- Notification Class</td>
<td></td>
</tr>
<tr>
<td>- Object Id</td>
<td></td>
</tr>
<tr>
<td>- Device Description</td>
<td></td>
</tr>
<tr>
<td>- Notification Class Present</td>
<td></td>
</tr>
<tr>
<td>- Event Type</td>
<td></td>
</tr>
<tr>
<td>- Alarm State</td>
<td></td>
</tr>
<tr>
<td>- Priority</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Trends</th>
<th>Supports the Name Filter, Condition, Time Filter, and Row Filter.</th>
</tr>
</thead>
<tbody>
<tr>
<td>- DateTime</td>
<td>Does not support multiple Name Filters.</td>
</tr>
<tr>
<td>- Value</td>
<td>Does not support the Data Selection dialog box.</td>
</tr>
<tr>
<td>- Unit</td>
<td>Sorting is possible only on the DateTime column.</td>
</tr>
<tr>
<td>- Quality</td>
<td>The information on the alias of an object (if present) displays above the column headings (Present Value, Unit, and Quality) and appears next to the object hierarchy.</td>
</tr>
</tbody>
</table>

- There are no additional columns in the Trends table.
### All Logs

- Event Category
- Log Type
- Event ID
- Event Time
- Previous Value
- Event Message Text
- Quality
- Date/Time
- Record Type
- Event Cause
- Event State
- Previous Quality
- Source Description
- Action
- Source Property
- Value
- Unit

- Supports the following additional columns
  - Action Details
  - Action Result
  - Alert ID
  - Alias [Observer]
  - Alias [Source]
  - Attachment
  - Discipline
  - Event Mode
  - Management Station
  - Observer Description
  - Observer Designation
  - Observer Location
  - Observer Name
  - Observer Identifier [Internal]
  - Observer Property
  - Source Designation [Application View]
  - Source Designation [Current View]
  - Source Designation [Management View]
  - Source Identifier [Internal]
  - Source Location [Application View]
  - Source Location [Current View]
  - Source Location [Management View]
  - Source Name
  - Subdiscipline
  - Subtype
  - Type
  - User

- Supports the Name Filter, Condition, Time Filter, and Row Filter.
- For more information on the All Logs table and its constraints, see Log View Report [→ 316].
- The values of filters applied on the **Alias [Source]** column are case sensitive.

### Select Columns

You can add, remove, or reorder columns in a table using the Select Columns [→ 231] dialog box.

### Sorting

Sorting allows you to arrange data in ascending or descending order. Sorting priority depends on the order in which the column headers are clicked.

Sorting more than one column can be done by holding the **CTRL** key and then selecting multiple columns. The columns are prioritized in the order they have been clicked. A number (starting with 1) on the column header indicates the sorting priority. For example, Source time (1), Date (2), Discipline (3), and so on.

You can sort the table columns in Edit mode as well as in Run mode.

If you sort the table columns in Edit mode, then the sorted data displays in Run mode according to the sort criteria specified in Edit mode. When sorting is applied on an executed report, data in the current snapshot is sorted.

### NOTE:

Sorting is unavailable during report execution. Sorting is re-enabled once report execution is complete or you stop a report execution.
9.2.2.2 Select Columns

You can add, remove, or reorder columns in a table using the Select Columns dialog box.

Select Columns Dialog Box (Generic) - For All Tables

Select Columns Dialog Box Components

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parent tab</td>
<td>Allows you to add, remove, or reorder Parent columns in the table.</td>
</tr>
<tr>
<td>Object Type</td>
<td>Displays only for a Point table. When an object is selected in the Object Type drop-down list, all the associated properties are listed in the Available Columns list.</td>
</tr>
<tr>
<td>Available Columns</td>
<td>Displays all the columns associated with the table. View specific columns such as Source Location and Source Designation are dynamically added to the Available Columns list when you create a new view.</td>
</tr>
<tr>
<td>Selected Columns</td>
<td>Displays the mandatory columns of a selected table. You can add columns to the selected columns list by selecting the check box associated with each column in the Available Columns list.</td>
</tr>
<tr>
<td>Select Default</td>
<td>Selects the default columns in the Available Columns list.</td>
</tr>
<tr>
<td>Clear All</td>
<td>Unchecks all columns except mandatory columns. The Selected Columns list displays only mandatory columns.</td>
</tr>
<tr>
<td>Move Up</td>
<td>Moves the selected column one step up in the Selected Columns list. The Move Up button is unavailable if you select the column on the top.</td>
</tr>
<tr>
<td>Move Down</td>
<td>Moves the selected column one step down in the Selected Columns list. The Move Down button is unavailable if you select the column at bottom.</td>
</tr>
<tr>
<td>Remove</td>
<td>Removes the selected column from the Selected Columns list.</td>
</tr>
</tbody>
</table>
NOTE:
You can add, reorder, and delete child records using the Child tab. The tab becomes available when you insert the Event Details table.

Select Columns Dialog Box - For Objects Table

The following table provides information for Type Filter, Type and Available Columns particularly for the Objects table. The other components in the Select Columns dialog box are the same for all tables.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type Filter</td>
<td>Allows you to enter the object type description on which you want to filter the object types to be displayed in the Type drop-down list. For example, if you want the Type drop-down list to display all BACnet object types, enter BACnet as the type filter.</td>
</tr>
<tr>
<td>Type</td>
<td>Displays the list of object types available in the system.</td>
</tr>
<tr>
<td>Available Columns</td>
<td>Displays the following information:</td>
</tr>
<tr>
<td></td>
<td>• Common columns applicable to any type of object. These are listed at the top of the list. For example, Discipline, Object Name, Object Description, and so on.</td>
</tr>
<tr>
<td></td>
<td>• Columns referring to properties supported by the selected object type. These are listed after the common columns and have a tree structure. When you click any such column, the tree expands and displays the attributes of the property. For example, if you click the expander of the Current_Priority property, its attributes such as Archive, Activity Log, Min, Max, Default, and so on display.</td>
</tr>
<tr>
<td></td>
<td>NOTE: View specific columns such as Source Location and Source Designation are dynamically added to the Available Columns list when you create a new view.</td>
</tr>
</tbody>
</table>
Column names with and without square brackets [ ].
You may observe that some column names in the Available Columns list are enclosed within square brackets[], whereas some are not. This occurs for the following reasons:

- In the Object Model, each property name has a property descriptor attribute. If the same property is used in more than one Object Models, and the property descriptor is same in all instances, then for such property, the property descriptor displays as the column name in the Objects table. For example, the Out_Of_Service property is common to BACnet Analog Output and Desigo TRA Analog Output object models. The property descriptor associated with the Out_Of_Service property for both these models is Out-of-Service. Therefore the name displayed in the Objects table is Out-of-Service.

- If the same property is used in more than one Object Models, however the property descriptor is not same in all instances, then for such property, property name displays as column name in the Objects table and is enclosed within square brackets. For example, the Event_State property is common to the BACnet Analog Output and Desigo TRA Analog Output object models. However, the property descriptor associated with this property in the BACnet Analog Output model is EventState and in the Desigo TRA Analog Output is Eventstate. Therefore the name displayed in the Objects table is [Event_State].

### 9.2.2.3 Plot Group Box

A plot displays data in a graphical view. The Plot group box contains different graphic elements from different data sources such as Trends and Graphics.

**Graphics Plot**

You can drag-and-drop any graphics definition or manual view port from the System Browser tree onto a Report Definition to insert a graphics plot. This inserts a placeholder graphics plot and sets the Name Filter to the dragged and dropped object.

When you execute a report containing a graphics plot, it displays the graphic image associated with the dragged and dropped object. If the object is not present in any of the graphics definitions, then an error message displays in the report management section.

Applicable filters: Name Filter [⇒ 238]

**Trends Plot**

You can drag-and-drop a trend view definition from the System Browser tree onto a Report Definition to insert a trends plot. The system behaves the same way as when inserting a graphics plot. For more information on the Trends Plot and its configuration, see Trends Plot [⇒ 314].

Applicable filters: Name [⇒ 238] and Time [⇒ 243]

See also Inserting a Plot [⇒ 266]

### 9.2.2.4 Keyword Group Box

Keywords are pre-defined templates that can be added anywhere in a Report Definition. They are replaced with actual data in Run mode and when the report document (PDF, XLS) is created.

There are two types of keywords:

- Content-specific, which can be inserted only above tables/plots
- Generic, which can be inserted anywhere including the header and footer of the Report Definition

For example, you can add the **Date** keyword in the Report Definition header to display the date on which the report is executed.
The following Keywords are supported by Reports:

<table>
<thead>
<tr>
<th>Content-specific Keyword</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Content Type</td>
<td>Displays the name of the content provider – Alarm, Log, Reference, Objects, and Graphics.</td>
</tr>
<tr>
<td>Name Filter</td>
<td>Displays the Name filter(s) set for the content provider.</td>
</tr>
<tr>
<td>Condition Filter</td>
<td>Displays the condition filter expression set for a table. In case of Plot content, this keyword remains empty.</td>
</tr>
<tr>
<td>Time Range</td>
<td>Displays the Time filter set for the content provider.</td>
</tr>
<tr>
<td>Content Start</td>
<td>Displays the Date and Time when execution started for the content provider.</td>
</tr>
<tr>
<td>Content Stop</td>
<td>Displays the Date and Time when execution completed or stopped for the content provider.</td>
</tr>
<tr>
<td>Content Duration</td>
<td>Displays the time difference between Content Start and Content Stop.</td>
</tr>
<tr>
<td>Content State</td>
<td><strong>Succeeded</strong> – Displays if content provider’s execution succeeds. <strong>Cancelled</strong> – Displays if content provider’s execution stops or fails.</td>
</tr>
<tr>
<td>Content ErrorState</td>
<td>Provides additional information about Content execution. It is independent of the Content state. The following states are possible: <strong>OK</strong> - Succeeded <strong>Errors</strong> - Errors occurred <strong>Failures</strong> - Severe errors occurred</td>
</tr>
<tr>
<td>Content ErrorState Message</td>
<td>Displays the error description of Content ErrorState.</td>
</tr>
<tr>
<td>Content Activity</td>
<td>Displays the detailed information about the Content creation activity.</td>
</tr>
<tr>
<td>Content Progress</td>
<td>Displays the Content execution progress from 0% to 100%.</td>
</tr>
<tr>
<td>Record Count</td>
<td>Displays the number of records in the table.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Generic Keywords</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date</td>
<td>Displays the Date (format is location-dependent)</td>
</tr>
<tr>
<td>Time</td>
<td>Displays the Time (format is location-dependent)</td>
</tr>
<tr>
<td>Page</td>
<td>Displays the page number when the report document (PDF) is created.</td>
</tr>
<tr>
<td>Pages</td>
<td>Displays the total number of pages when the report document (PDF) is created. <strong>NOTE:</strong> Keywords <strong>Page</strong> and <strong>Pages</strong> are replaced by page numbers and total number of pages respectively only when inserted in Header or Footer of the Report Definition.</td>
</tr>
<tr>
<td>User</td>
<td>Displays the name of the logged-in user.</td>
</tr>
<tr>
<td>Desigo CC Name</td>
<td>Displays the name of the management station that created the report.</td>
</tr>
<tr>
<td>Report Name</td>
<td>Displays the name of the Report Definition.</td>
</tr>
<tr>
<td>Report Description</td>
<td>Displays the description typed for the Report Definition.</td>
</tr>
<tr>
<td>Report Start</td>
<td>Displays the Date and Time when report execution started.</td>
</tr>
<tr>
<td>Report Stop</td>
<td>Displays the Date and time when report execution completed or stopped.</td>
</tr>
<tr>
<td>Report Duration</td>
<td>Displays the time difference between Report Start and Report Stop.</td>
</tr>
<tr>
<td>-----------------</td>
<td>---------------------------------------------------------------</td>
</tr>
<tr>
<td>Report State</td>
<td><strong>Succeeded</strong> - Displays if the report execution succeeds. <strong>Cancelled</strong> - Displays if the report execution stops or fails.</td>
</tr>
<tr>
<td>Report ErrorState</td>
<td>Provides additional information about report execution. It is independent of the report state.</td>
</tr>
<tr>
<td>Report ErrorState Message</td>
<td>Displays the error description of report ErrorState.</td>
</tr>
<tr>
<td>Report Activity</td>
<td>Displays detailed information about report creation activity.</td>
</tr>
</tbody>
</table>
| Report Progress | Displays the report execution progress:  
  If **continuous progress** is possible, a number between 0 and 100 displays  
  If **no continuous progress** is possible, **In progress** displays. |
| Report Summary | Displays the summary. |

### 9.2.2.5 Logo Group Box

You can insert logos into a Report Definition using the Logo group box. For example, you can add your company’s logo to a report. You can define, and change the size, position, and indentation of a logo. To insert a logo to a Report Definition, you must upload it using the Manage Logo dialog box.

#### Manage Logo Dialog Box

![Manage Logo Dialog Box](image)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select logo to upload</td>
<td>Displays selected image file path.</td>
</tr>
<tr>
<td>Browse</td>
<td>Opens the Windows Open dialog box.</td>
</tr>
<tr>
<td>Close</td>
<td></td>
</tr>
</tbody>
</table>
9.2.2.6 Form Controls Group Box

Form controls are controls that you can edit in the Run mode. There are four form controls - Editable Field, Custom Text Selection, Text Group Selection, and Comments Table. These controls are accessed from the Form Controls group box within the Insert group box in the Home tab of Reports.

The Editable Field control displays a watermark text that enables you to perform the required action. You can change this text if you want the control to display a different text when the report is executed. These controls can also be used to provide event treatment related information in reports for operating procedures [220].

Following is an overview of the form controls:

**Editable Field**

Use the Editable Field control, to enter text in the Run mode. This field does not support keywords.

**Custom Text Selection**

The Custom Text Selection control provides a drop-down list that enables you to add [270], modify [270], and delete [271] text entries in the Edit mode and select entries in the Run mode. You can add text in any of the languages configured in the system. In Run mode, this control displays text using the logged-in language of the user.

**Components of the Custom Text Selection Control**

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>✓</td>
<td>Add</td>
<td>Adds the text entered to the control. <strong>NOTE:</strong> Available only when some text is entered.</td>
</tr>
<tr>
<td>✏️</td>
<td>Update</td>
<td>Modifies an existing entry. <strong>NOTE:</strong> Available only when you change an existing entry.</td>
</tr>
<tr>
<td>🇺🇸</td>
<td>Flag</td>
<td>Allows you to enter text for all languages configured in the system.</td>
</tr>
</tbody>
</table>

**Text Group Selection**

The Text Group Selection control provides a drop-down list with entries from a text group in the Run mode. You can drag-and-drop a text group to this control in the Edit mode and the values display in the Run mode. However, you can add only one text group to the control. If more than one text group is added, the existing group is overwritten with the new group. If you add new entries, modify or delete existing entries from the associated text group, the control displays the updated
values every time you run the report. If the text group is deleted, a message indicating that the group is no longer available displays.

![Text Group Selection Control - Edit Mode](image1)

### Comments Table

The **Comments** table allows you to add, modify, and delete comments in the Run mode. You can modify and delete your own comments by clicking **Edit** and **Delete** that are available in the Run mode.

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creation date</td>
<td>Displays the date and time stamp when comment is added</td>
</tr>
<tr>
<td>User</td>
<td>Displays the Id of user who entered the comment</td>
</tr>
<tr>
<td>Management Station</td>
<td>Displays the workstation from where comment is added</td>
</tr>
<tr>
<td>Comment</td>
<td>Allows you to enter comments</td>
</tr>
</tbody>
</table>

Creation date, User, and Management Station are read only. These are populated with information after you enter the comments and press **ENTER**. To add a new line to the comments, press **ALT+ENTER**.

Unlike other tables, the columns in this table are fixed and you cannot perform column operations like adding, deleting, reordering, and sorting. Also, this table does not support filtering.

![Comments Table](image2)

**9.2.3 Reports Ribbon — Filter Tab**

The **Filter** tab allows you to define and apply different filters for data retrieval.

**Filter Tab**

The various filters are:

- Name Filter
- Condition Filter
- Time Filter
- Row Filter: Allows you to set the maximum number of rows of a table to be displayed at runtime.
- Languages Filter: Allows you to set the language for a Report Definition. You can configure filters (Condition and Name) in the selected language.
9.2.3.1 Name Filter

The Name Filter allows you to filter data based on the Name or Description of System Browser objects.
You can apply a Name Filter to a table or plot.

Name Filter Dialog Box

Use the Name Filter dialog box to add [➙ 272], edit [➙ 272] and delete [➙ 273] Name Filter condition(s). The added Name Filter is also added to the Name Filter group box when the dialog box is closed.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Creates a Name Filter according to the object name displayed in System Browser.</td>
</tr>
<tr>
<td>Description</td>
<td>Creates a Name Filter according to the object description displayed in the System Browser. A message displays below the Name Filter list if the filter is invalid (in red color).</td>
</tr>
</tbody>
</table>
| Name Filter List | Lists all the Name Filters and displays whether the applied filter is valid or not. The Name Filter list contains four columns.  

**Total no. of filters:** Displays the total number of filters in the column header and displays the sequential number before each Name Filter.  

**Valid:** Shows if the applied filter is valid or not (OK or question mark symbol (?) respectively).  

**Children:** Disabling this check box excludes the child nodes of the System Browser object from the Report Definition.  

**Name Filter:** Displays the hierarchical path of the System Browser object.  

<table>
<thead>
<tr>
<th>Name Filter</th>
<th>Displays the filter that is currently selected in the Name Filter list. You can type a name into this field. For example, Application View. Site.Building.Floor1.*</th>
</tr>
</thead>
<tbody>
<tr>
<td>NOTE: For a plot, you can set only one Name Filter at a time.</td>
<td></td>
</tr>
<tr>
<td>Validate</td>
<td>Checks whether the applied filter is valid or not.</td>
</tr>
<tr>
<td>NOTE: Displays only for Trends Table, Trends Plot, and Graphics Plot.</td>
<td></td>
</tr>
<tr>
<td>Accept</td>
<td>Accepts the change made to a Name Filter. This button is unavailable until a change is made to an existing Name Filter.</td>
</tr>
<tr>
<td>New</td>
<td>Adds a new Name Filter to the Name Filter list. This button is unavailable until a Name Filter is typed in the Name field or if any existing Name Filters are selected in a Name Filter list.</td>
</tr>
<tr>
<td>NOTE: When you add the Name Filter for the very first time, the default Name Filter <em>:</em> is replaced.</td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes an existing Name Filter. This button is unavailable until one or more Name Filters is selected in the Name Filter list.</td>
</tr>
<tr>
<td>NOTE: When all the Name Filters are deleted the default Name Filter <em>:</em> is restored.</td>
<td></td>
</tr>
</tbody>
</table>

**NOTE 1:**
When an Activities, Events, Active Events, BACnet Alarm Summary, BACnet Enrollment Summary, BACnet Event Information, and/or Objects table is inserted in the Report Definition, a valid Name Filter "*:*" is added by default.

**NOTE 2:**
For Trends table, Trends plot, and Graphics plot no default Name Filter is added. You can apply only single Name Filter.

**NOTE 3:**
For Trends table, you can drag-and-drop Offline, Online Trend Logs, and Trend View Definitions.

**Wildcard Characters in Name Filters:**
You can use wildcard characters (* and ?) in a name filter. The following examples will help you in using these characters:

- To display the details of only Analog Output objects of a device, Dev 1 in a report, specify the name filter as "System1.ManagementView:ManagementView.FieldNetworks.BAC1.Hardware.Dev1.Local_IO.AO*". When you run the report, the details of all the Analog Output objects belonging to the Dev 1 device will display.

- To display the details of only Analog Output objects of all system devices in a report, specify the name filter as "System1.ManagementView:ManagementView.FieldNetworks.BAC1.Hardware.Dev*.Local_IO.AO*". When you run the report, the details of all Analog Output objects belonging to all devices in the system with names starting with Dev will display.

- To display the details of Analog Output objects with names starting from Analog Output 11 through Analog Output 19 of device Dev 1 in a report, specify the name filter as "System1.ManagementView:ManagementView.FieldNetworks.BAC1.Hardware.Dev1.Local_IO.AO_1?". When you run the report, the details of Analog Output objects with names starting from AO_11 through AO_19 belonging to device Dev 1 will display. The assumption here is that there is a device Dev1 in your system that has Analog Output objects with names starting from AO_11 through AO_19.

- If you want to display the details of Analog Output objects with names starting from Analog Output 11 through Analog Output 19 of all devices with names in the range of 21 through 29 in a report, specify the name filter as...
"System1.ManagementView:ManagementView.FieldNetworks.BAC1.Hardware.Dev2?.Local_IO.AO_1?". When you run the report, the details of all analog output devices with names starting from AO_11 through AO_19 that are present in devices Dev21 through Dev29 will display. The assumption here is that there are devices in your system having names Dev 21 through Dev 29 and there are Analog Output objects having names AO_11 through AO_19 in those devices.

However, when you apply wild cards to a name filter, the report execution may be slower. Therefore, if you are processing an operating procedure form, report steps, or log viewer on a system, it is necessary that any reports executed on this system have more specific name filters instead of having name filters with wildcards to achieve optimum performance.

9.2.3.2 Condition Filter

A Condition Filter defines a filter expression that is composed of one or more Filter expression(s).

Condition Filter Condition

A Condition Filter condition is composed of:

- Column name (Condition Name)
- Operators
- Condition value

Examples of Condition Filter Expressions

The following list contains some valid Condition Filter expressions:

- Status = "Alarm"
- Status = { "Alarm"; "Alarm Acked"; "Alarm Unacked" }
- Alarm Value = { 12; "Text" }
- Time of last Change = "Current day"

**NOTE:**

You cannot apply the Condition Filter to Plots.

The Condition Filter also allows you to create complex filters and conditions using mathematical and logical operators, and wildcard characters. The following operators are supported:

- **Mathematical Operators:** Equal to (=), Not Equal to (<>), Greater than (>), Less than (<), Greater than Equal to (>=), Less than Equal to (<=), and (-) In operator
- **Logical Operators:** AND, OR, NOT
- **Wildcard Character:** Asterisk (*)

**NOTE:** The In operator (→) is used to filter data in a column that supports display of multiple values in a single cell. Following is an example of columns having the possibility to display multiple values in a single cell.
Table Name | Columns with possibility to display multiple values in a single cell
--- | ---
Objects | Related Items Type
 | Related Items
Activities | Value
 | Previous Value
 | Quality
 | Previous Quality
Active Events | Available Commands

For more information, see In Operator [➔ 317].

**Condition Filter Syntax**

When you are creating a condition filter, you must know the data type of the property for which you want to apply the filter. Following are some examples which will help you create condition filters without syntax errors.

1. If property displays text data, for example string or enumeration, then the value must be enclosed within double quotes.
   - `[Current_Priority]` = “Priority - 16”
   - `Object Description` = “Analog Output 1”
   - `[Event_State]` = “Normal”
   - `[Present_Value]` = “INACTIVE”
   
   **NOTE:** The values of some properties such as `[Current_Priority]` are referenced in text groups. Therefore, whenever you are assigning values for such properties, you must refer to the respective text groups. In order to refer to the text groups in the Management View, you must have an Engineering license. In the absence of an Engineering license, you will have to run the report to find out the appropriate values for such properties.

2. If property displays values in the date time format, then the value must be in date time format configured in Windows on the server machine. Date in the short date format. Time in the long time format (24 hours).
   - `Main Value` = 3/13/2014 16:04:25 (assuming that the date format on the server is M/d/yyyy)

3. If property displays Boolean data, for example. TRUE, FALSE, then the value must be enclosed in double quotes.
   - `[Stop_When_Full]` = “True”
   - `[Log_Enable]` = “False”

4. If property displays numeric data, for example., 54.11, 25, -20, then the values must be specified as follows:
   - `[Present_Value]` = 54.11
   - `[Present_Value]` ≥ 25
   
   **NOTE:** The decimal separator will be according to your Windows Regional and Language settings.

5. If property displays bit string, then the value must be enclosed by double quotes.
   - `Status_Flags` <- “Fault”
   - `Event_Enable` <- “To Fault”
   - `Limit_Enable` <- “Low Limit Enable”

The Condition Filter is applicable only to Objects, Active Events, Activities, Events, Event Details, and Trends tables.

When you select any of these tables, you can display the Condition Filter dialog box.

For the Objects table, you can add a conditional filter that specifies the acceptable age of the data on which the filter is applied. For example, if you specify 0 as the
acceptable age, the filter is always applied on the latest data from the field system. If you specify 2 weeks, the age of the data with the cache is checked. If the data is older than 2 weeks it is obtained from the field system, else the data from the cache is used for filtering. This setting helps in the faster report generation.

**Condition Filter Dialog Box**

This dialog box allows you to specify the condition to filter the report data. You can apply the condition filter on all columns except columns of type date/time.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type Filter</td>
<td>Displays only when an <em>Objects table</em> is selected in the Report Definition. Allows you to enter the object type description on which you want to filter the object types to be displayed in the <em>Type</em> drop-down list. For example, if you want the <em>Type</em> drop-down list to display all BACnet object types, enter BACnet as the type filter.</td>
</tr>
<tr>
<td>Type</td>
<td>Displays only when an <em>Objects table</em> is selected in the Report Definition. It lists all the object types available in the system. When you select an object, associated columns are populated in the Available Columns list.</td>
</tr>
</tbody>
</table>
| Available Columns | Lists all the available columns of a selected table. For an Objects table, the columns corresponding to the object type selected in *Type* are listed. In case of the Objects table, displays the following information:  
  - Common columns applicable to any type of object. These are listed at the top of the list. For example, Discipline, Object Name, Object Description, and so on.  
  - Columns referring to properties supported by the selected object |
<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operators List</td>
<td>Lists all the operators associated with a specific column selected in the Available Columns list.</td>
</tr>
<tr>
<td>Values List</td>
<td>Lists all the values associated with a specific column selected in the Available Columns list. Moreover, you can select multiple values by pressing CTRL or SHIFT and selecting different values.</td>
</tr>
<tr>
<td>Filter expression field</td>
<td>Displays the filter expression. You can edit a filter expression in this field.</td>
</tr>
<tr>
<td>Read all data from field system</td>
<td>Displays only when an <em>Objects table</em> is selected in the Report Definition. If this option is selected the objects data for filtering is always read from the field system.</td>
</tr>
<tr>
<td>Read all data from process image</td>
<td>Displays only when an <em>Objects table</em> is selected in the Report Definition. If you select this option, the objects data is always read from the cache.</td>
</tr>
<tr>
<td>Read data from field system older than</td>
<td>Displays only when an <em>Objects table</em> is selected in the Report Definition. It allows you to specify the acceptable age of the data on which the filter is applied. If you select this option, the value entered is compared with the age of the data in the cache. If the data in the cache is older than the value entered, it is obtained from the field system; else data from the cache is used for filtering.</td>
</tr>
<tr>
<td>Add/Update</td>
<td>Allows you to add or update a filter expression. <em>Update</em> is enabled only when a valid filter expression is added or modified in the filter expression field.</td>
</tr>
<tr>
<td>AND/OR</td>
<td>These are logical operators that allow you to combine filter expressions and create complex filters. This button is unavailable until a filter expression is added to the filter expression field.</td>
</tr>
<tr>
<td>&quot;( ) &quot;</td>
<td>Allows you to group filter conditions, which define the order of their evaluation. These brackets are unavailable until a filter expression is added to the filter expression field.</td>
</tr>
</tbody>
</table>

**9.2.3.3 Time Filter**

The Time Filter group box and the dialog box launcher icon is enabled only when you select a table or plot in a Report Definition for which the Time Filter is applicable.

The Time filter allows you to specify time as a filter for retrieving records.

---

1) The selected item displays below the list.
Reports
Reports Workspace

Time Filter Dialog Box

Time Filter Dialog Box Components

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date time specification</td>
<td>Shows LOCAL, when the Date/Time in UTC format check box on the Home tab is not selected.</td>
</tr>
<tr>
<td>Select Column</td>
<td>Displays only when an Events or All Logs table is selected in the Report Definition. The entries in the drop-down list depend on table selected. For an Events table, Event Time, Event Went, and Transition Time display allowing you to filter information on the basis of the time when the event occurred, time when the event state changed, or time when the event was closed. For an All Logs table the entries in the drop-down list include Date/Time and Event Time.</td>
</tr>
<tr>
<td>Exact</td>
<td>Allows you to filter data based on the exact date specified.</td>
</tr>
<tr>
<td>Custom</td>
<td>The Custom option allows you to set the date and time as per your requirement. Selecting the Custom option enables the From/To field. The To date should always be greater than From date. If the To date is less than the From date, then the To field is highlighted in red color and an error message displays on mouse-over. The From and To date should be same as the date already set in Short date on your management station. To view the Short date: (Start &gt; Control Panel &gt; Regional and Language Options &gt; Regional Options)</td>
</tr>
<tr>
<td>Relative</td>
<td>Relative has two options: Last and Current Period. The Last option allows you to filter data for the last 'x' period that you specify. For example, last 'x' hours, last 'x' months, last 'x' years, last 'x' weeks, last 'x' days, or last 'x' minutes. The Current Period option allows you to filter data for the current 'x' period.</td>
</tr>
</tbody>
</table>
period that you specify. For example, current 'x' hours, current 'x' months, current 'x' years, current 'x' weeks, current 'x' days, or current 'x' minutes.

For example, if the current date and time on your machine is 10/07/2014 10.35 AM and you specify any of the following:

1 Hour in the Last option - The data for the 9:00 to 10:00 AM period is retrieved.

1 Hour in the Current Period option - The data for the 10:00 to 11:00 AM period is retrieved.

1 Month in the Last option - The data for the period June 01, 2014 to July 01, 2014 is retrieved.

1 Month in the Current Period option - The data for the period July 01, 2014 to August 01, 2014 is retrieved.

1 Year in the Last option - The data for the period January 01, 2013 to January 01, 2014 is retrieved.

1 Year in the Current Period option - The data for the period January 01, 2014 to January 01, 2015 is retrieved.

NOTE: The Last and the Current Period field accepts only integer values up to 3 digits.

<table>
<thead>
<tr>
<th>Unlimited</th>
<th>Default selection. Allows you to retrieve all records.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Defined By Source</td>
<td>This option only displays for Trend objects. It sets the date and time to what you have defined for the selected Trend View Definition.</td>
</tr>
<tr>
<td>Null</td>
<td>Allows you to retrieve records with Null value.</td>
</tr>
</tbody>
</table>

Preview of Resulting Time range

Displays the resulting time range for the options selected in the Time Filter dialog box. For example, if the present time is 02/06/2012 4:37 PM, then for the selection current 24 hrs the Preview of Resulting Time Range displays absolute time range for this selection as follows:

From: Sunday, February 05, 2012 5:00:00 PM
To: Monday, February 06, 2012 5:00:00 PM.

9.2.4 Reports Ribbon — Layout Tab

The Layout tab allows you define the format of layout elements of a Report Definition.

The Layout tab contains the following group boxes:

- Page Setup group box [→ 246]
- Placement group box [→ 246]
- Position group box [→ 246]
- Font group box [→ 247]
- Auto-scaling group box [→ 247]
9.2.4.1 Page Setup Group Box

The Page Setup group box allows you to set the orientation, page size, and margin of the Report Definition.

- Orientation
  - The Orientation menu contains two submenus:
    - Portrait: long vertical edge
    - Landscape: long horizontal edge (default)

- Page Size
  - The Page Size menu contains several pre-configured sizes including: A3, A4, A5, Letter, and so on. The default page size is A4.

- Margins
  - A margin is the space between the edge of the page and the area where report elements are placed.
  - The Margins menu has four preconfigured margins with values displayed for quick selection:
    - Normal (default)
    - Narrow
    - Moderate
    - Wide

9.2.4.2 Placement Group Box

The Placement group box provides icons so you can rearrange the position of the report elements in a Report Definition by selecting an element and using the icons:

- Move up ▲, Move down ▼, Move to top ☐, and Move to bottom ☐.

When there is only one element present or if there are multiple elements but none is selected, then all four icons are unavailable.

9.2.4.3 Position Group Box

The Position group box allows you to adjust the position of the layout elements of a Report Definition.
- **Alignment** refers to the placement of objects or layout elements on the report page. The different alignments are: Left, Center, and Right.
- **Indentation** allows you to set the distance between the report page margin and the actual placement of the element.
- **Spacing** allows you to set the space before and after the layout elements.
- **Width** allows you to adjust the width of a layout element (logo and plot only).
- **Height** allows you to adjust the height of a table/plot (logo and plot only).

### 9.2.4.4 Font Group Box

The **Font** group box allows you to apply a font type, size, style and/or color to the layout elements such as a label or a table. The Font group box becomes enabled only when you have inserted a label or a table in a Report Definition template while configuring a Report Definition.

![Font Group Box](image)

### 9.2.4.5 Auto-scaling Group Box

Selecting the **Auto-scaling** check box adjusts the column width automatically in PDF documents that are generated when you execute a report.

If the Auto-scaling check box is not selected, then the PDF may not display all table columns.

![Auto-scaling Group Box](image)
9.2.5 Reports Ribbon — Data Tab

The **Data** tab allows you to specify the location from which the data is to be retrieved when you run the report. It also provides the option to define the Graphics filter.

![Data Tab](image)

The group boxes available in the **Data** tab are:

**Table Group Box**

The controls in the **Table** group box are enabled only when you select an **Objects** table in the Reports Workspace. The **Table** group box has the following options:

- **Read all data from field system:**
  If you select this option, the objects data is always read from the field system. This ensures that you always get the latest data.

- **Read all data from process image:**
  If you select this option, the objects data is always read from the cache. This setting helps in the faster report generation.

- **Read data from field system older than:**
  If you select this option, you must specify the acceptable age of the data to display in the report. The value you enter is compared with the age of the data in the cache. If the data in the cache is older than the value entered, it is obtained from the field system; else the data from the cache displays. For example, if you specify 0 as the acceptable age, the latest data from the field system is retrieved and displayed. If you specify 2 weeks, the age of the data with the cache is checked. If the data is older than 2 weeks it is obtained from the field system, else the data from the cache displays. This setting helps in the faster report generation.

  If you have selected any of the following options, **Read all data from field system**, **Read all data from process image**, or **Read data from field system older than** in the **Data** tab, the same option is also selected in the **Condition Filter** dialog box. Any change in selection reflects in the **Condition Filter** dialog box as well. However, if you change your selection in the **Condition Filter** dialog box, it does not reflect in the **Table** group box options of the **Data** tab.

  For example, by default the **Read all data from field system** option is selected in the **Data** tab and the same option is also selected in the **Condition Filter** dialog box. So, when you run the Objects report the data from the field system is retrieved. As the same option is also selected in the **Condition Filter** dialog box, the condition filter is applied on the latest data retrieved from the field system. However, if you change the option to **Read all data from process image** in the **Condition Filter** dialog box, it will not reflect in the **Table** group box options of the **Data** tab and the condition filter is applied on the data retrieved from the Cache.

**Graphics Group Box**

The Graphics group box has the following option:

- **All Related Graphics:**
  When you select this box, the related graphics and view ports of an object display in the **Run mode**. To view the graphics and view ports, you must assign the object as a name filter to the graphics plot.
9.2.6 Reports Ribbon — Settings Tab

The Settings tab allows you to configure the output format and destination for a Report Definition.

Report Output Group Box

The Report Output group box displays the configured entries for a Report Definition.

The Report Output Definition [➙ 249] dialog box allows you to configure the settings. The configured Report Output Definitions are executed when the Report Definition runs automatically [➙ 282].

For more information on configuring a Report Definition to be routed in different formats and to different destinations, see Routing Reports [➙ 290].

NOTE: If there is a change in the configured email address of a recipient in the Address Book, it is automatically reflected in the Report Output Group Box. However, if the configured email address is deleted or the recipient is deleted in the Address Book, the entries for a Report Definition display in red text. For more information, see the Automatic Update of Configured E-mail Addresses section in Email [➙ 252].

9.2.6.1 Report Output Definition Dialog Box

The Report Output Definition dialog box allows you to configure the Report Definition’s output format and destination for routing reports [➙ 290]. You can create, modify, or delete a Report Definition output entry.
### Report Output Definition Dialog Box Components

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report format</td>
<td>Lists the different supported file formats. <strong>NOTE 1:</strong> According to the EMC requirement, the CSV report format is supported to export a Trends report in the CSV format. The EMC proxies have plug-ins that support converting data from CVS formats for import into EMC. To have Desigo CC trend data compatible with the EMC trend data import plug-in, the CSV columns (for trends table only) are modified: Date; Data Source; Value (separated by semicolon). <strong>NOTE 2:</strong> The CSV does not support logos or plots; also Report header/footer is not present. <strong>NOTE 3:</strong> The CSV format applies only to exporting the Trends table.</td>
</tr>
</tbody>
</table>
| Destination types | Lists all the various destination types: File [➙ 251], Email [➙ 252] and Printer [➙ 254]. For an XLS and a CSV report format, the Printer destination type is unavailable. **NOTE:** When you select the Destination Type as *File or Email*, you can specify the name of the file that will be generated upon automatic report execution using either of the following options:  
  - Use report name as file name  
  - Enter custom file name |
| Destination | Depending on the Destination types settings, you can configure the destination in one of the following ways:  
  - **File:** Configured folder name displays in the File drop-down list.  
  - **Email:** Email text field is populated with the pre-configured e-mail contacts.  
  - **Printer:** Available printers display in the Printer drop-down list. |
| Use report name as file name | Default option. Becomes available only when you select the destination type as *File or Email*. In this case, the **File Name** field is populated with the selected report name and is unavailable. |
| Enter custom file name | When selected, allows you to type in the desired file name in the File Name text box. |
| File name | If the file name contains special characters such as, / : * ? < > | " , then it is highlighted with a red border and a tool-tip displays the error message. |
| Append date/time to file name | Becomes available only when you select the destination type as *File or Email*. When checked, adds the date and time to the file name. |
| Create new/overwrite existing file | Default option. Allows you to configure a new file to the configured destination when routing reports. If the file doesn’t exist, a new file is created or is overwritten if the file already exists. **NOTE 1:** This option only applies to PDFs. **NOTE 2:** In case of an existing split PDF document, if the Append data check box is selected, the number of available pages in the previous split document is ignored and, a new split document is created in the same folder with an incremental number. |
| Append data | When selected, adds the currently executing report data to the existing file having same file name and same file type present at the destination. If a file having the same name and same file type is not already present at the destination, then a new file will be created. **NOTE 1:** This option only applies to PDFs. **NOTE 2:** In case of an existing split PDF document, if the Append data check box is selected, the number of available pages in the previous split document is ignored and, a new split document is created in the same folder with an incremental number. |
| Change | Allows you to modify an existing Report Output Definition entry. |
| Add | Adds a Report Output definition entry to the Output Definition list. **NOTE:** This button is unavailable if the Destinations drop-down list is empty. |
| Output Definition List | Displays the existing Report Output Definition entries. |
| Delete | Deletes the selected Report Output Definition. |
9.2.6.2 File

You can save a Report Output Definition in supported formats to a file. You can configure [➙ 291], modify [➙ 291] and delete [➙ 292] reports using the Report Output Definition dialog box.

Report Output Folders Configuration Dialog Box

Before you save a file at a specific location in your local management station, you must configure the output folder paths in the Report Output Folders Configuration dialog box. You can launch this dialog box from the Report Output Definition dialog box.

After configuration, you can view and select these output folder paths in the Report Output Definition dialog box.

Report Output Folders Configuration Components

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Folder Alias</td>
<td>Displays the name of the destination folder. When you select File as the Destination Type, this name will be displayed in the File dropdown list of the Destination list of the Report Output Definition dialog box.</td>
</tr>
<tr>
<td>Folder Path</td>
<td>Displays the folder path that you have selected using the Browse button. You can configure a maximum of 100 folder paths. An error message displays if the number of folder path exceeds 100.</td>
</tr>
<tr>
<td>Browse</td>
<td>Helps you to locate the destination folder. You can also create a new folder at a desired location. <strong>NOTE:</strong> If you don’t have the required permission on the selected folder, an error message displays.</td>
</tr>
<tr>
<td>Folder Description</td>
<td><em>(Optional)</em> Describes the contents of a folder.</td>
</tr>
<tr>
<td>Add</td>
<td>Adds the Folder Alias, Folder Path, and Folder Description in the List of folders for Report Output. This button is unavailable until all the mandatory fields are filled.</td>
</tr>
</tbody>
</table>
### 9.2.6.3 Email

The **Report Output Definition** dialog box allows you to send a report to someone using email. You can send all documents in one mail or configure the number of documents to be sent per email to the selected email contact(s). The default is one document per email.

![Report Output Definition Dialog Box for Email](image)

The **E-Mail Contacts** dialog box allows you to choose and filter from the list of all recipients having email addresses configured in the Contacts selection list.

**NOTE 1:**
Before sending an email you must configure the mail server.

**NOTE 2:** The **E-Mail Contacts** dialog box displays when you select the destination type as Email and then click the **Select Contacts** button.
E-mail Contacts Dialog Box Components

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contacts selection</td>
<td>Shows the names of the configured contacts in the Address Book followed by their email address in brackets. This list is sorted alphabetically. <strong>NOTE:</strong> A recipient may have up to three different email addresses configured.</td>
</tr>
<tr>
<td>Filter List Entries</td>
<td>Allows you to type in a filter. For example, if you type the letter “A”, the recipient list displays all the contacts starting with letter A.</td>
</tr>
</tbody>
</table>

Automatic Update of Configured E-mail Addresses

The Output Definition List in the **Report Output Definition** dialog box and Contacts selection list in the **E-mail Contacts** dialog box updates automatically, if you change or delete the email address of a particular recipient in Address Book.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>A recipient email address is changed in the Address Book</td>
<td>The new email address reflects in the Output Definition List in the <strong>Report Output Definition</strong> dialog box and Contacts selection list in the <strong>E-mail Contacts</strong> dialog box.</td>
</tr>
<tr>
<td>A listed email address of the configured contact is deleted in the Address Book</td>
<td>The list of email addresses in the Output Definition List in the <strong>Report Output Definition</strong> dialog box displays in red. On moving your mouse pointer over the text, the following tooltip message displays &quot;One or more email addresses are invalid. Select the correct email address. Report will not be sent to the invalid email addresses &quot;. On selecting the report output definition, the email addresses configured in the definition display in the Destination field. The deleted email address displays as &quot;Unknown object&quot;. In order to remove the &quot;Unknown object&quot; from the list, you must select a valid email address from the <strong>Select</strong> drop-down list.</td>
</tr>
</tbody>
</table>
The report is run by clicking the **Execute** button in the **Extended Operation** tab. Report is routed to the valid email addresses configured in the report output definition.

A recipient is deleted from the **Address Book**. The list of email addresses in the Output Definition List in the **Report Output Definition** dialog box displays in red. On moving your mouse pointer over the text, the following tooltip message displays "One or more email addresses are invalid. Select the correct email address. Report will not be sent to the invalid email addresses." On selecting the report output definition, the email addresses configured in the definition display in the Destination field as **Unknown objects**.

### 9.2.6.4 Printer

The **Report Output Definition** dialog box allows you to send a Report Output Definition to a printer.

You can print **all** or the **first 100** (default) pages. You can edit the default and enter the number of pages to be printed.
NOTE 1:
Currently only PDF report format is supported for printing. To print a PDF report format on a printer, you must configure a server printer.

NOTE 2:
The document to be printed depends on the sorting you applied to the columns of a table.

9.2.7 Report Management Section

The Report Management section displays the Report execution status, PDF/XLS document creation status, and so on during Report execution. The Report execution/generation mode is called Run mode [258]. It also provides quick and easy navigation to different Report snapshots. That is, when you select a snapshot in the Report Management section, it displays in Reports.

For example, if you have an executed report and both a PDF and Excel document is generated for that report, then you can quickly switch between the two using the Report Management section.

The Reports toolbar has a toggle icon called Report Management, which shows or hides the Report Management section. This section is visible at the bottom of the Reports window.

The Report snapshot of an executed Report Definition in the Report Management section is available until the user logs out.

The Report snapshots in the Report Management section are displayed in a hierarchical manner. For example, if you execute a Report and then view it as a PDF or Excel (XLS) document, then in the Report Management section, the first entry is of Report execution and the second entry is the PDF/XLS creation as displayed in the following image.

You can also monitor the PDF/XLS document creation progress; stop it using the Stop button. All the consecutive split document creation will be stopped.
You can also delete the split document using the Delete button or all the documents by deleting the Report snapshot entry.

The entry of each split document in a Report Management section is a child of the entry for the Report snapshot. Selecting any document entry, displays the document linked to that entry in the Reports.

**NOTE:** This section does not display when the report is executed for a selected event from Assisted Treatment.

### Report Management Section Components

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Header</td>
<td>Displays the name of the reporting object currently executing. For example, the Report Definition name when executing a report.</td>
</tr>
<tr>
<td>State</td>
<td>Displays the execution state of a Report, PDF, XLS. For example, Pending, Succeeded, Failed, and so on.</td>
</tr>
<tr>
<td>Activity</td>
<td>Displays the description of the task being performed.</td>
</tr>
<tr>
<td>Execution Start</td>
<td>Displays the execution start date and time.</td>
</tr>
<tr>
<td>Action</td>
<td>Displays the Stop button when the execution of a reporting object starts. When the execution is finished, the Stop button changes to the Delete button.</td>
</tr>
<tr>
<td>Progress</td>
<td>Displays the Progress information in a progress bar to indicate the execution progress.</td>
</tr>
<tr>
<td>Summary</td>
<td>Displays the execution summary. For example, if a BACnet device is unavailable or available but offline, then the summary will be Report snapshot created successfully. At least one error reported: BACnet error: Device has operational problem.</td>
</tr>
</tbody>
</table>

### 9.2.8 Related Items Tab

The Related Items tab displays New Report, Related Report, and Show-in Related Items Report as a link or icon upon selection of a System Browser object.

**New Report**

This report is always available for quick access to a new Report Definition (as a link or icon) in the Related Items tab upon selection of a System Browser object.

When clicking the New Report link/icon, a new Report Definition opens in the Secondary pane (if the Primary pane is unlocked – pushpin horizontal). This Report Definition, by default, contains the Objects table with the Name Filter set to the selected object in the System Browser tree.
NOTE 1:
If you select a Trend View Definition/Graphic Definition in System Browser and click the New Report link/icon, then the Report Definition contains a trend plot/graphics plot with the Name Filter set to the selected Trend View Definition/Graphic Definition.

NOTE 2:
If multiple objects are selected in System Browser (Graphics Definitions, Trend Definitions, BACnet devices/points, and so on) and you click the New Report link/icon in the Related Items tab, then all the selected objects are set as Name Filters for the Objects table (no graphics plot, trends plot).

You can then configure and run this report as usual.

Related Report

If the selected System Browser object is defined as a Name Filter in a report, then this report becomes a Related report for that object and displays as a link/icon in the Related Items tab.

When clicking this link/icon, the Related report runs in the Primary pane if locked, or in the Secondary pane if the Primary pane is unlocked. During the Related report execution, the data is retrieved according to the Name Filter set for the report element in the Report Definition. The Name Filter set in the report element is not replaced by the selected System Browser object.

For example, if an Event Details report is present in the Related Items tab, it can be run for the selected event in the Event List.

NOTE:
Ensure that in a Report Definition, you have set the complete path of the system object as the Name Filter (without any wild cards). If a wild card (? or *) is used in the Name Filter, then this Report Definition is not set as a Related report and does not display in the Related Items tab.

Show in Related Items Report

When you select a System Browser object, the reports having Show-In-Related-Items check box selected are displayed (as a link/icon) in the Related Items tab.

When clicking this link/icon, the report runs in the Primary pane if locked, or in the Secondary pane if the Primary pane is unlocked.

During the report execution, the Name Filter is set to the path of the selected object in the System Browser tree. If a Name Filter was configured in the report, it is replaced with the path of the selected object.

9.3 Reports Modes

Reports operates in two modes:

- Edit mode [➜ 258]: This is the default mode, which allows you to design the layout of a Report Definition.
- Run mode [➜ 258]: This mode allows you to view the actual data retrieved from the Reports service.
9.3.1 Edit Mode
When you create a new Report Definition, it opens in *Edit mode* (default mode).

Edit Mode allows you to design the layout of a report, delete a report, and so on. You can also show/hide the Reports Ribbon using the Properties icon.

![Edit Mode](image)

**NOTE:**
You can switch to *Run mode* by clicking the **Run** icon or **Run As** icon present in the Reports toolbar.

9.3.2 Run Mode
The Run mode executes a Report Definition and displays the data retrieved from Reports and other services. In Run mode, the ribbon disappears.

In Run mode, the following occurs:
- Keywords are replaced by actual data.
- No element can be added or deleted in this mode.
- You can perform the following activities:
  - Sorting (ascending or descending) or changing column width.
  - Selecting rows in tables.
  - Entering text in the **Editable Field** control.
  - Selecting text entries from the **Custom Text Selection** control or values of a text group from the **Text Group Selection** control.
  - Adding, Modifying, and Deleting comments from the **Comments** table.

- The **STOP** icon or the **Stop** button in the report management section stops the execution of a Report Definition.

In Run mode, the layout elements are populated with data as displayed in the following image.
NOTE 1:
You can toggle to Edit mode by clicking Edit on the Reports toolbar. If you perform sorting in Run mode and then switch to Edit mode, the Select Edit Option dialog box displays asking whether you want to save or discard the changes you made in Run, or to create a new Report Definition based on the changes.

NOTE 2:
In Run mode, when you move the cursor over a table/plot, a tooltip displays the applicable filter and the number of records (only for tables). The number of records tooltip is helpful in deciding the destination type, for example Printer.

NOTE 3:
When you view a report in the configured language (en-US or fr-CA), the data is displayed as per the settings done in Control Panel > Region and Language > Additional Settings for the following fields
- numeric (including decimal symbol, no. of digits after decimal)
- short date and
- short time

The report workspace specifications for example, page size/margin, table width/height and so on are as per the measurement system. specified in the Control Panel > Region and Language > Additional Settings.
9.4 Reports Workflow

This section describes how to work with reports in the Primary, Secondary, and Contextual panes.

NOTE:
For Reports, you can perform the same activities in Operating and Engineering mode.

9.4.1 Primary Pane

In the Primary pane, you can view and work with all types of reports and perform activities including but not limited to the following:

- Create and configure a Report Definition by:
  - Adding various report elements
  - Configuring filters
  - Applying formatting
- Locate and Modify a Report Definition
- Run a selected Report Definition
- View report execution status, document creation status, and so on during report execution
- Display generated report in Run mode
- View a report as a PDF or XLS
- Export/Import a Report Definition
- Route a report to:
  - Folders as files (PDF/XLS)
  - Email recipients as a file attachment (PDF/XLS)
  - Local printers (PDF only)
### 9.4.2 Secondary Pane

If the Primary pane is unlocked (horizontal pushpin icon), then you can work with the following three additional report types in the Secondary pane:

- **New Report**: Opens a new Report Definition for configuration.
- **Related Report**: Opens the report related to the selected System Browser object.
- **Show in Related Items Report**: Opens a report having the Show in Related Items check box selected.

#### Reports - Secondary Pane Workflow

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Point Selection</td>
<td>Location of Point in the Application View/Management View of System Browser.</td>
</tr>
<tr>
<td>2</td>
<td>Report Definition Selection</td>
<td>Report Definition selected in the Related Items tab.</td>
</tr>
<tr>
<td>3</td>
<td>Executed Report Display</td>
<td>Location of selected Report Definition—before and after execution—with command toolbar to execute the Report Definition located on the left side of the Secondary pane. <strong>NOTE</strong>: Executed Report Definitions display in Run Mode.</td>
</tr>
<tr>
<td>4</td>
<td>Report Management</td>
<td>Status details of the executed or currently running Report.</td>
</tr>
</tbody>
</table>
9.4.3 Contextual Pane — Extended Operation Tab

You can generate a selected report automatically by clicking the Execute command button in the Extended Operation tab of the Contextual pane.

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Report Definition Selection</td>
<td>Location of Report Definitions/Report folders in the Application View of System Browser.</td>
</tr>
<tr>
<td>2</td>
<td>Automatic report execution</td>
<td>Execute Command button to run a Report Definition in the background.</td>
</tr>
<tr>
<td>3</td>
<td>Report Definition Properties</td>
<td>Properties (Last Run, Summary Status, and Show in Related Items) displayed in the Extended Operation tab.</td>
</tr>
</tbody>
</table>

9.5 Creating a New Report Definition

You are in System Browser.

1. In System Browser, select Application View > Applications > Reports.
   ➤ Reports displays in the Primary pane.


3. Proceed to Configuring a Report Definition.

   NOTE: If a default Report Definition template is available, then clicking New Report creates a new Report Definition based on the default template.

   NOTE: You can also create a new Report Definition by clicking the New Report link or icon in the Related Items tab.
9.6 Managing Reports Folders

Creating Reports folders in the System Browser help you to keep Report Definitions organized.

You want to create a new Reports folder and are in System Browser.

1. Select Application View > Applications.
2. Select the main Reports node or a reports folder in the System Browser tree.
   ➔ Reports displays in the Primary pane.
3. In the Reports toolbar, click New.
4. From the context menu that displays, click New Folder.
   ➔ The Create New Object dialog box displays with the Child Type configured as Report Folder.
5. Enter the folder Name and Description. Provide a unique folder name, otherwise a message box displays asking you to provide this. The description is mandatory.
   a) Click Flag to display and modify the text for all languages configured in the system.
   b) Click OK to confirm (or Cancel to abort).
   ➔ If confirmed, the new Report folder is saved and displays under the Reports node in the System Browser tree.

NOTE 1:
To delete a Reports folder, expand the main Reports node. Select the folder you want to delete, and then in the Reports toolbar, click Delete.

NOTE 2:
Deleting a folder deletes the contents as well.

9.7 Configuring a Report Definition

You can configure a Report Definition by:

- Inserting a table [➙ 263], plot [➙ 266], text [➙ 266], keywords [➙ 267], logos [➙ 268], editable field [➙ 269], custom text selection control [➙ 269], text group selection control [➙ 271], or comments table [➙ 271]
- Applying filters: Name [➙ 272], Condition [➙ 273], Time [➙ 274], Row [➙ 275]
- Setting page layouts [➙ 275]
- Formatting page elements [➙ 277]

9.7.1 Inserting a Table

You have selected an existing Report Definition in System Browser > Reports or you have created a Report Definition and now want to configure it.

1. From the Reports ribbon, click the Home tab.
2. Do one of the following:
   - From the Insert group box on the Home tab, click the Table group box, select a table (such as Objects, Active Events, Activities, and so on), and
drag-and-drop it in the Report Definition.
The cursor shape changes and indicates the selected table name.

- Right-click the **Report Definition** and select the table type from the **Insert Table** option.
- Drag-and-drop the desired **system object** from the System Browser tree on the Report Definition. The Name Filter of the inserted table is set to the dropped system object.

**NOTE 1:**
The table is added to the Report Definition. By default, the table is left-aligned.

- Right-click the **Report Definition** and select the table type from the **Insert Table** option.

**NOTE 2:**
- Drag-and-drop the desired **system object** from the System Browser tree on the Report Definition. The Name Filter of the inserted table is set to the dropped system object.

**NOTE 3:**
Whenever you insert a Trends table, there is an ascending sort on the Date column.

### 9.7.1.1 Adding a Column

- You have added a table in a Report Definition.

1. Select a **table** in the Report Definition.
2. Right-click the table and select **Select Columns**.

**NOTE:** The layout and content of the **Select Columns** dialog box varies according to the type of table selected.

- The **Select Columns** dialog box displays.
3. Select the **check box** preceding each column to add it to the table. In case of a property, you must first expand it, and then check the columns.

**NOTE:** For an Objects table: Select the object related to the Objects table from the **Type** drop-down list. The columns related to the object type selected are filtered and displayed in the **Available Columns** list.
If you select a **column** that belongs to a property, then the column is added in the **property.column** format. For example, High Limit.ActivityLog.

- The checked columns are added to the **Selected Columns** list.
4. Click **OK**.

- The columns are added to the table in order of their presence in the **Selected Columns** list.

### 9.7.1.2 Reordering a Column

- You have added a table with multiple columns in the selected Report Definition.

1. Select a **table** in the Report Definition.
2. Right-click the **table** and select **Select Columns**.

- The **Select Columns** dialog box displays with the available columns in the table.
3. Select the required column in the **Selected Columns** list.
4. Click **Move Up** or **Move Down** to reorder the column.

5. Click **OK**.

   - The column in the table is arranged accordingly.

### 9.7.1.3 Removing a Column

- You have added a table in a Report Definition.
- The table must contain at least one column.

1. Select a table in the Report Definition.

2. Right-click the table and select **Select Columns**.

   - The **Select Columns** dialog box displays with the available columns of table.

3. Select the required column in the **Selected Columns** list, and click **Remove**.

4. Click **OK**.

   - The column is removed from the table.

**NOTE 1:** You can also remove the default column(s) of a table.

### 9.7.1.4 Sorting a Column

- You have added a table with multiple columns to a Report Definition.

- Do one of the following:

  - To sort a column data in **ascending order**, click the **column header** of a table.
  
  - To change the sort order to **descending**, click the **same column header** again.
  
  - To sort the data on **multiple columns**, press the **CTRL** key and click the **column headers**.

**NOTE:** Remove the priority of the prioritized columns for multiple sorted columns by single clicking any column header.

- The data is sorted, and a priority is assigned to the columns if sorting is done on more than one column.

**NOTE 1:**

In Activities, Events and Event Details tables, you cannot sort columns such as type, sub-type, discipline, object name, object description, object location, and so on.

**NOTE 2:**

In Trends tables, you can only sort the **Date** column. By default, whenever you insert a Trends table there is an ascending sort on the **Date** column.

### 9.7.1.5 Deleting a Table

- At least one table is added in the selected Report Definition.

1. In the Report Definition, select the **table** you want to delete.

   - The border color changes to indicate table selection.
2. Either right-click the table and select **Delete**, or press the **DEL** key.
   - A confirmation message displays.
3. Click **Yes** to confirm.
   - The table is deleted from the Report Definition.

### 9.7.2 Inserting a Plot

- You have selected an existing Report Definition in **System Browser > Reports** or you have created a Report Definition and now want to configure it.

1. From the **Reports** ribbon, click the **Home** tab.
2. Do one of the following:
   - From the **Insert** group box on the **Home** tab, click the **Plot** group box, and select any plot (Trends, Graphics), and drag-and-drop it onto the selected Report Definition.
     - **NOTE:** The cursor changes and indicates the selected plot name.
   - Right-click the Report Definition and select the required type of plot from the **Insert Plot** option.
   - Drag-and-drop the desired **Trend View Definition/Graphics View Port** from the System Browser tree on the Report Definition. The Name Filter of the inserted plot is set to the dropped Trend View Definition or Graphics View Port.
   - The plot placeholder is added to the Report Definition. By default, the plot is left-aligned.
     - **NOTE:** In Run mode, this plot image is replaced by the actual data retrieved from the Report service.

**NOTE 1:**

You cannot insert a plot in the header/footer section.

**NOTE 2:**

You cannot apply font types, size, and color on a plot.

**NOTE 3:**

If you select a plot in the Report Definition and right-click, you can move, set position, apply filters, and delete the plot.

### 9.7.2.1 Deleting a Plot

- At least one plot is inserted in a Report Definition that you have selected.

1. From the Report Definition, select the plot you want to delete.
   - The border color changes to indicate the plot selection.
2. Either right-click the plot and select **Delete**, or press the **DEL** key.
   - A message displays.
3. Click **Yes** to confirm.
   - The plot is deleted from the Report Definition.

### 9.7.3 Inserting Text (Label)

1. Do one of the following:
9.7.3.1 Deleting Text

➤ You have inserted a label.

1. Select the label you want to delete.
   ➤ The border color changes to indicate that the label is selected.

2. Either right-click the label and select Delete, or press the DEL key.
   ➤ A confirmation message displays.

3. Click Yes to confirm.
   ➤ The selected label is deleted.

9.7.4 Inserting a Keyword

1. From the Reports ribbon, click the Home tab.

2. Do one of the following:
   - From the Insert group box, select a keyword from the Keyword group box and drag-and-drop in the header/footer section or anywhere in the Report Definition.
   - In the Report Definition, place the cursor where you want to insert the keyword, right-click and select the required keyword from the Insert Keyword option.
   - From the Insert group box, insert a blank text and then do one of the following:
     - Select a keyword from the Keyword group box and drag-and-drop it onto the blank text.
     - Right-click the blank text and select the required keyword from the Insert Keyword option.
   ➤ The keyword is inserted.

NOTE 1:
If no text or keyword is added to a label in Edit Mode, then a blank label displays in Run Mode.

NOTE 2:
To delete a keyword, you must delete the label [268] containing that keyword.

NOTE 3:
Content-specific keywords such as Content Type, Name Filter, Record Count, and so on cannot be inserted in the header/footer section of a Report Definition.
9.7.4.1 Deleting a Keyword

- You have inserted at least one label in the selected Report Definition.
1. Select the label that contains the keyword you want to delete.
   
   NOTE: To delete a keyword you must delete the label.
   - The border color changes to indicate that the label is selected.
2. Either right-click the label and select Delete, or press the DEL key.
   - A confirmation message displays.
3. Click Yes to confirm.
   - The selected label and keyword are deleted.

9.7.5 Inserting a Logo

- You have added [268] at least one logo to the Logo group box.
1. From the Reports ribbon, click the Home tab.
2. Do one of the following:
   - From the Insert group box, click the Logo group box and select a logo, and then drag-and-drop it on the Report Definition where you want to insert the selected logo.
   - In the Report Definition, place the cursor where you want to insert the logo, right-click and select the required logo from the Insert Logo option.
   - The logo is inserted in the Report Definition.

Tips

- To insert a logo in the header/footer section of a Report Definition, delete any existing label.
- You can change the position of the logo in the Report Definition by using the Move buttons (up, down, top, bottom) present in the Placement group box of the Layout tab, or by right-clicking a logo in the Report Definition, and selecting Move.

9.7.5.1 Adding a Logo

1. From the Reports ribbon, click the Home tab.
2. From the Insert group box, click the Logo group box and select Manage Logo.
   - The Manage Logo dialog box displays.
3. Click Browse.
4. Select an image file, preferably in the format: .bmp, .jpeg, .png, or .gif.
5. Click Open.
   - The Select logo to upload field displays the file path. You cannot edit this field. The image file name is saved as the logo name.
6. Click Upload.
   - The image is added to the Available Logos list.
   
   NOTE: The Logo file is saved in the directory:
[drive]\GMSProjects\[project]\data\Reporting\Logos, where [Project] is the project you created using System Management Console on the Server.

9.7.5.2 Deleting Logos

You have inserted a logo [268] in a Report Definition.

1. Select the logo you want to delete.
2. Either right-click the logo and select Delete, or press the DEL key.
   - A confirmation message displays.
3. Click Yes to confirm.
   - The logo is deleted from the Report Definition.

**NOTE:**
You delete a logo from the source directory using the Manage Logo command in the Logo group box. When a logo is deleted from the source directory, the no parking symbol displays in the Report Definition (in place of the logo) with a tooltip that displays Logo is deleted or renamed from the source directory. Any subsequent execution of the Report Definition does not display anything in the PDF or XLS.

9.7.6 Configuring Form Controls
You can configure form controls in reports.

9.7.6.1 Inserting an Editable Field

1. From the Reports ribbon, click the Home tab.
2. Do one of the following:
   - From the Insert group box on the Home tab, click the Form Controls group box, select the Editable Field control and drag-and-drop it in the Report Definition or in the header/footer section.
   - Right-click the Report Definition or the header/footer section, where you want to insert the Editable Field, and then select the Insert Editable Field option.
   - The Editable Field is added.

**Tips**
- To insert the editable field in the header/footer section of a Report Definition, delete any existing label.

9.7.6.2 Inserting a Custom Text Selection Control

1. From the Reports ribbon, click the Home tab.
2. Do one of the following:
From the Insert group box on the Home tab, click the Form Controls group box, select the Custom Text Selection control and drag-and-drop it in the Report Definition or in the header/footer section.

Right-click the Report Definition or the header/footer section, where you want to insert the Custom Text Selection control, and then select Insert Custom Text Selection.

The Custom Text Selection control is added.

9.7.6.3 Adding Entries to the Custom Text Selection Control

The Custom Text Selection control is added to the Report Definition or in the header/footer section.

1. Do one of the following:
   - Click the control and enter text.
   - Click the Flag icon and enter text in any of the languages configured in the system.

2. Click Add.

The text entry is added to the control.

9.7.6.4 Modifying Entries in the Custom Text Selection Control

The Custom Text Selection control has one or more text entries.

1. Select the text entry you want to modify from the list.

2. Do one of the following:
   - Click the control and modify the text.
   - Click the Flag icon to modify the text in any of the language fields.

3. Click Update.

The text entry is modified.
9.7.6.5 Deleting Entries from the Custom Text Selection Control

- The Custom Text Selection control has one or more entries in it.
  - From the list of entries, click **Delete** corresponding to the text entry you want to delete.
  - The deleted entry no longer displays in the list.

9.7.6.6 Inserting the Text Group Selection Control

1. From the Reports ribbon, click the Home tab.
2. Do one of the following:
   - From the Insert group box on the Home tab, click the Form Controls group box, select the Text Group Selection control, and drag-and-drop it in the Report Definition or in the header/footer section.
   - Right-click the Report Definition or the header/footer section, where you want to insert the Text Group Selection control, and then select **Insert Text Group Selection**.
  - The Text Group Selection control is added.

9.7.6.7 Adding a Text Group to the Text Group Selection Control

- The Text Group Selection control is added to the Report Definition or in the header/footer section.
  - Navigate to the Libraries node in the System Browser and drag-and-drop a text group node from the Libraries tree to the Text Group Selection control.
  - The text group is added to the Text Group Selection control. The name of the text group displays on the control. If you want to view the complete hierarchy of the text group, move your cursor over it. The hierarchy displays in a tool tip.

9.7.6.8 Inserting the Comments table

- You have selected an existing Report Definition in System Browser > Reports or you have created a Report Definition and now want to configure it.
  1. From the Reports ribbon, click the Home tab.
  2. Do one of the following:
     - From the Insert group box on the Home tab, click the Form Controls group box, select the Comments table and drag-and-drop it onto the Report Definition.
     - Right-click the Report Definition and select **Insert Comments Table**.
  - The Comments table with a single row is added to the Report Definition.
9.7.7 Applying a Name Filter

▷ You have created a Report Definition and inserted a table or plot.

1. Select a **table or plot** in the Report Definition.
2. Do one of the following:
   - Click **Dialog Launcher** in the **Name Filter** group box.
   - Right-click the selected **table/plot** and select **Name Filter** from **Filters**.
   - Double-click inside the **Name Filter** group box.
   ⇒ The **Name Filter** dialog box displays.
3. Select the **Name** or **Description**. The default selection is **Name**. The **Name** or **Description** in the **Name Filter** is the same as the **Name** or **Description** in the **Display Mode List Box** in the System Browser.
4. To set the **Name Filter**, do one of the following:
   - In the **Name Filter** text box, type the complete path of the object for which you want to apply the **Name Filter** according to the System Browser Name. For example:
     **NOTE:** Adding a “.*” at the end of the name or selecting the **Children** check box enables the **Children** option. For a plot, you can apply only one **Name Filter** and the **Children** check box is unavailable.
   - Drag-and-drop a System Browser **object** onto the selected table or plot and the **Name Filter** is set to the hierarchy of the dropped object. You can view and modify it using the **Name Filter** dialog box.
     **NOTE:** When you drag-and-drop an object for the first time onto a table, the default filter “:*” is replaced by the hierarchy of the dragged and dropped object.
5. Click **New**.
   ⇒ The **Name Filter** is added to the **Name Filter** list.
6. Click **OK**.
   ⇒ The **Name Filter** is added to the **Name Filter** group box.

**NOTE:**
You can apply multiple **Name Filters** on all tables except for a Trends table. For BACnet tables, applying multiple **Name Filters** is possible, but the **Children** check box is unavailable.

9.7.7.1 Editing a Name Filter

▷ You have already applied [272] a **Name Filter** for a table or plot in a Report Definition.
1. Open the **Name Filter** dialog box.
2. In the **Name Filter** list, select the **Name Filter** you want to edit.
   ⇒ The selected **Name Filter** displays in the **Name Filter** text box.
3. In the **Name Filter** text box, type in your modifications.
4. Click **Accept**.
   ✥ The updated Name Filter displays in the **Name Filter** list.

5. Click **OK**.
   ✥ The updated Name Filter displays in the **Name Filter** group box.

### 9.7.7.2 Deleting a Name Filter

▷ You have already applied [↩ 272] a Name Filter to a table or plot.

1. In the **Name Filter** list, select the **Name Filter(s)** to be deleted. You can select multiple Name Filters by pressing the **CTRL** key.

2. Click **Delete** or press the **DEL** key.
   ✥ The deleted Name Filter(s) is removed from the **Name Filter** list.

3. Click **OK**.
   ✥ The Name Filter is deleted from the **Name Filter** group box.

### 9.7.8 Applying a Condition Filter

▷ You have inserted a table in a Report Definition.

1. Select a **table**.

2. Do one of the following:
   - Click **Dialog Launcher** in the Condition Filter group box.
   - Right-click the selected table and select **Condition Filter** from Filters.
   - Double-click inside the **Condition Filter** group box.
     ✥ The **Condition Filter** dialog box displays.

3. Select a column from the **Available Columns** list.
   **NOTE:** For Objects Table: A **Type** drop-down list displays. Select an object to populate the Available Columns list.
   ✥ The operators and values associated with the selected column display in the **Operator and Values** list.

4. Select required **operator** and **value** from the respective lists. If values are not displayed for the selected column, type in the value. To apply brackets, select a **filter expression** and click { ( ). The brackets are applied at the start and end of the filter expression.
   **NOTE:** You have to specify time related values in a 24-hour clock format. For example, to specify the Source Time as 2.00 PM, type 14.00.
   ✥ Use AND, OR, () to form the Filter expression.

5. **[Optional] For Objects table only:** Specify the acceptable age of the data on which the filter is applied by selecting the **Read data from field system older than** option.
   ✥ The value entered is compared with the age of the data in the cache. If the data in the cache is older than the value entered, it is retrieved from the field system; otherwise data from the cache is used for filtering.

6. Click **Add**.
   ✥ The filter expression formed displays in the **Filter expression** field.

7. Click **OK**.
9.7.8.1 Modifying a Condition Filter

One or more Condition Filter expressions are added to the Condition Filter group box.

1. Open the **Condition Filter** dialog box.
   - The Condition Filter expression displays in the **Filter expression** field. Clicking the filter expression displays the column, operator, and value in their respective lists.

2. Modify the **Condition Filter** expression as required.
3. Click **Update**.
   - The updated filter expression is added to the **Condition Filter** group box.

**NOTE:**
If you enter an invalid filter expression, an error message displays below the Filter expression field in red and the invalid part of the Filter expression is highlighted in red. To correct the error, place the cursor over the error message below the Filter expression field. A tooltip displays the possible solution.

9.7.8.2 Deleting a Condition Filter

You have applied a Condition Filter to a table.

1. Open the **Condition Filter** dialog box.
2. Delete the condition filter expression from the **Filter Expression** field.
3. Click OK.
   - The Condition Filter is deleted from the table.

9.7.9 Applying a Time Filter

You have inserted a table in a Report Definition.

1. Select a table.
2. Do one of the following:
   - Click **Dialog Launcher** in the Time Filter group box.
   - Right-click the selected table and select **Time Filter** from Filters.
   - Double-click inside the **Time Filter** group box.
   - The **Time Filter** dialog box displays.

3. **For Events and Event Details table only:** Select the column on which you want to apply the time filter from the **Select Column** drop-down list.
4. Select the appropriate values for Date/Time type: Exact, Custom, or Relative.
5. Click OK.
   - **NOTE:** By default, the Unlimited option is selected. The Defined by Source option becomes available only for a Trends table and plot.
   - The Time Filter is added in the **Time Filter** group box.
9.7.10 Applying a Row Filter

- You have selected a table in a Report Definition for which you want to apply a row filter.
  - Select the Row filter check box and enter the desired number of rows to be displayed in the report output.
  - The configured number of rows are displayed for the table in Run mode.

9.7.11 Applying the Graphics Filter

- You have added a graphics plot to the Report Definition.
  1. Assign the name filter of the object whose graphics and view ports you want to display in the report output.
  2. Select the All Related Graphics check box from the Graphics group box in the Filter tab.
    - All the graphics and view ports related to the object display in the Run mode.

9.7.12 Setting Page Layout

The following sections tell you how to set the orientation [275], page size [275] and margin [276] of a Report Definition.

9.7.12.1 Setting Orientation

1. From the Reports ribbon, click the Layout tab.
   - The Page Setup group box displays.
2. In the Page Setup group box, click the Orientation menu.
   - The Portrait and Landscape submenu displays.
3. Select Landscape or Portrait. By default, Landscape is selected.
   - The report’s orientation changes based on your selection.

9.7.12.2 Setting Page Size

1. From the Reports ribbon, click the Layout tab.
   - The Page Setup group box displays.
2. In the Page Setup group box, click the Page Size menu.
   - NOTE: Selecting the More Sizes option displays the Width and Height (in cm or inch – location dependent) of the selected page size. These fields are read-only.
3. Select the page size of your choice.
   - The page size of the Report Definition changes accordingly.
9.7.12.3 Setting Page Margins

1. From the Reports ribbon, click the Layout tab.
   - The Page Setup group box displays.

2. In the Page Setup group box, click the Margin menu.
   - A list of preconfigured margins display such as Normal, Narrow, Moderate, Wide, and More Margins. You can specify the top, bottom, left and right margins of a page as well as the header and footer margins by selecting the More Margins option.

3. Select the margin of your choice.
   - The margin of the report changes accordingly.

Tips
- In the Page Setup dialog box, all fields in the Margins section accept only integer and floating point values.
- A negative value entered highlights the text field in red. Placing the cursor over the field displays a tooltip informing you that one or more margins are set outside the printable area of the page.
- If the difference between the top margin and header margin is zero or a negative value, then the header height is set to a default value of 5 units (mm or inch – location dependent).

9.7.12.4 Setting a Header/Footer

The header and footer are positioned at the top and bottom of the page and provide information about the page, such as page number, page title, date/time, and so on.

1. Click the Layout tab.
   - The Page Setup group box displays.

2. Click Dialog Launcher .
   - The Page Setup dialog box opens.

3. Do one of the following:
   - To view the header/footer along with the page, check the Show header and Show footer options.
   - To hide a header/footer on a page, uncheck the Show header and Show footer options.

   NOTE: You can also define the top header and bottom footer margins by changing the Top margin and Bottom margin values respectively.

NOTE:
By default, the Show header and Show footer check boxes are selected and the margin from top and bottom are set to 1 unit (cm or inch – location dependent).
9.7.12.5 Enabling/Disabling Auto-scaling

1. From the Reports ribbon, click the Layout tab.

   The Auto-scaling group box displays.

2. Select the Auto-scaling check box. By default, the Auto-scaling mechanism is enabled.

9.7.13 Formatting Report Elements

You can format the report elements by:

- Adjusting the position [277]
- Customizing a font [278]
- Applying color [278]

9.7.13.1 Adjusting a Report Element Position

1. Select a Report element in a Report Definition.

   The menus in the Position group box become available.

2. You can adjust the position of the report element by doing one of the following:

   - Use the Position group box.
   - Click Dialog Launcher or right-click and select Position to open the Position dialog box.

3. To set the alignment, click the required alignment type.

4. To set the Indentation, type the values in the Left or Right field (for Left and Right Indentation respectively). If the Center alignment is selected, then both these fields are unavailable.

5. To set the spacing, type values in the Before and After fields.

6. To set the width, first select the Width check box and then type in the value in the Width field.

7. To set the height, first select the Height check box and then type in the value in the Height field. The height option is unavailable for labels.

8. Click OK.

Tips

- All fields in the Position group box and Position dialog box accept only integer and floating point values.
- A negative value entered highlights the text field in red. Placing the cursor over this field informs you that the value must be greater than or equal to 0 unit (cm or inch – location dependent).
- For logos and plots, the width-height aspect ratio is maintained, so that if you change one the other gets adjusted automatically as per the aspect ratio. While inserting logos the original aspect ratio of the image is maintained.
9.7.13.2 Customizing a Font

1. Select a label or a table in a Report Definition.
2. From the Reports ribbon, click the Layout tab.
   - The Font group box displays.
3. Do one of the following to apply a font, font style, or font size.
   - Click the drop-down arrow in the Font group box.
   - Right-click the report element, and select Font.
   - The Font dialog box displays.
4. Select the font type, font size, and font style as desired.
5. (Optional) Select the Underline check box to apply it to the label. The Underline option is unavailable when you select a table in the Report Definition.
6. Click OK.

9.7.13.3 Applying Color

1. Select a label or a table in a Report Definition.
2. Click Color.
3. Do one of the following:
   - Select a predefined color (in square boxes).
   - Click the More Color option and choose a custom color in the More Color dialog box.
4. Click OK.

9.8 Saving a Report Definition

You have configured a Report Definition and want to save it.

1. In the Reports toolbar, click Save.
   - The Save Object As dialog box displays.
2. In the view structure that displays, select the destination folder in which to save the Report Definition. The destination folder can be the main Reports folder.
3. Type the Name for the Report Definition. There should be no space between the words.
4. Enter a description in the Description field. By default, when you click the Description field, the same text contained in the Name field displays. You can optionally modify this text.
   - NOTE: Click Flag to display a field for each language available in the system; modify the text for each language.
5. Click OK to confirm (or Cancel to abort).
   - If confirmed, the Report Definition is saved.
9.9 Creating a New Report Definition from an Existing One

- You have made modifications to an existing report definition and want to save it as a new Report Definition.
- The modified Report Definition displays in the Primary pane.

1. In the Reports toolbar, click Save As.
   - The Save Object As dialog box displays.

2. Follow Steps 2 through 5 in Saving a Report Definition ➜ 278.

9.10 Modifying a Report Definition

- You are in System Browser.

1. Select Application View ➔ Applications ➔ Reports.
   - Reports displays in the Primary pane.

2. Select a Report Definition and make the necessary configuration ➜ 263 changes.

3. In the Reports toolbar, do one of the following:
   - Click Save to replace the Report Definition with the changes.
   - Click Save As to create a new Report Definition.
     - The Save Object As dialog box displays.

4. Follow Steps 2 through 5 in Saving a Report Definition ➜ 278.

9.11 Saving a Report Definition as the Default Template

1. From the Reports toolbar, click New then New Report, or you can open an existing Report Definition.
   - The Report Definition opens in the Primary pane.

2. (Optional) Configure or modify the Report Definition.

3. In the Reports toolbar, click Save as default. When you save an existing Report Definition as a default template, a message displays informing you all elements are removed from the Report Definition; Text (Labels), Keywords, and Logos remain in the header/footer section.
The Report Definition is saved as a default template.

Tips
- There can only be one default template. You can create a new one or use the one provided by the system. When you create a new template, the existing default template is overwritten. The new Report Definition is always based on the default template.
- The template may contain generic and content-specific keywords. Creating a new Report Definition displays generic keywords, but not the content-specific keywords. The applicable content-specific keywords are automatically inserted above an inserted table and/or plot; however certain keywords are not applicable for certain types of tables/plots. For example, if the default template contains the content-specific keyword *Time Range* and you insert the Active Events table in the Report Definition, the Time Range keyword will not be inserted above the Active Events table in the Report Definition as the Time Filter is not applicable for the Active Events table.
- While creating a template, you can configure it in multiple languages by clicking the **Settings** tab and selecting the **Language for Labels** group box. When you create a new report based on this template, the language of the logged-in user is selected automatically and the Report Definition contents are added to this definition.

9.12 Generating a Report from a Report Definition

You can generate a report from a configured Report Definition either manually or automatically.

You can generate a report manually to display in the Reports workspace according to your login language (Run) or according to the selected language (Run As). Additionally, you can also generate a report manually by selecting a System Browser object, and clicking the link/icon in the Related Items tab for a Report Definition associated to that object.

To generate a report automatically, the Report Definition must have an associated Report Output Definition that specifies the report file format and output destination, such as a printer. You can generate a report automatically by using *macros and reactions*, or by clicking the **Execute** button.

You can optionally view and save manually or automatically generated reports as PDF and/or XLS files.

**NOTE:** If you generate any of the History reports such as Activity Log, Event Log, or Event Details Log and the system is over loaded, the data is logged in the History database with some delay. This leads to a delay in displaying data in such reports.

See also
- Configuring a Report Output Definition
- Routing Reports

9.12.1 Generating a Report Manually using Run or Run as

- At least one Report Definition is available under **System Browser > Reports**.

1. In **System Browser**, select **Application View**.
2. Expand the **Reports** node.
3. Locate and select the **Report Definition** you want to execute.
   - The **Report Definition** displays in Edit mode.
4. In the **Reports** toolbar, click one of the following:
9.12.2 Generating a Report Manually from Related Items Tab

1. Select an object from the System Browser tree. For example, Field Networks. This object is set as the name filter for the report definition you want to execute.

2. In the Related Items tab, select an icon/link for the Report Definition. For example, Object Status. You must import the report that you want to execute.

   **NOTE:** Do not select an icon/link for New Report as this opens a new Report Definition.

   ✔ The selected report displays in the Secondary pane in Run mode (if the Primary pane is unlocked – pushpin horizontal). The selected System Browser object is set as the Name filter for the table(s) and plot(s) present in the report. The report execution status displays in the Report Management section. On successful report execution, the generated report displays information related to the selected object.

**NOTE 1:**

If the selected report in the Related Items tab is a Related report for the selected System Browser object, then data is retrieved according to the Name Filter(s) set for a report element(s). However, if the selected report in the Related Items tab is a Show in Related Items report, then the Name Filter configured for all the reporting elements in the generated report is replaced by the path of the selected object in the System Browser.

**NOTE 2:**

After running a Report Definition, should you decide to change some Definition parameters, click Edit to toggle from Run mode to Edit mode in order to make your configuration [⇒ 263] changes.
9.12.3 Generating a Report Automatically

At least one Report Definition for which a Report Output Definition is configured and available under System Browser > Reports.

1. In System Browser, select Application View.
2. Expand the Reports node.
3. Select the Report Definition you want to execute.
   ➔ The Report Definition displays in Edit mode.
4. Do one of the following:
   - From the Contextual pane, click the Extended Operation tab, and then click Execute.
   - Create a macro [→ 352] for a report definition and Execute.

The report executes in the background when triggered (you have no visual indication that the report is being generated), and on successful execution, the report is routed to the destination configured in the Report Output Definition such as email, printer, or folder.

NOTE: If you have not configured the destination in the Report Output Definition, the report is routed to the path specified in the location supervised folder in System Browser - Management View under Management System > Servers > Main Server > Report Manager > Report Default Folder.

9.13 Printing Reports
You can print automatically as well as manually generated reports.

9.13.1 Automatically Generated Reports

You have selected an existing Report Definition in System Browser > Reports or created [→ 262], configured [→ 263], and saved [→ 278] a Report Definition.

- Configure the report output definition [→ 292] by selecting PDF as the report format and Printer [→ 294] as the destination.

  ➔ The report is printed in the PDF format on automatic execution [→ 282].

9.13.2 Manually Generated Reports

For reports generated in either of the following ways:
- Using Run or Run as: You have selected an existing Report Definition in System Browser > Reports or created [→ 262], configured [→ 263], and saved [→ 278] a Report Definition. The report is generated using Run or Run as [→ 280] and it displays in the Run mode.
- From the Related Items tab: You have selected the report to be generated from the Related Items tab [→ 281] and it displays in the Run mode.

1. Generate a PDF output by clicking Create and View PDF on the Reports toolbar.
   ➔ The PDF output displays inside the Reports workspace.
2. Click Print on the Reports toolbar.
   ➔ The Print dialog box displays.
3. Select the configured printer and click Print.
9.14 Working with Reports in Run Mode

9.14.1 Adding comments to the Comments Table
▷ The Report displays in the Run mode and has a Comments table.
- Enter the comments in the Comments column and press ENTER. Press ALT + ENTER to add a new line.
  ◄ The Creation date, User, and Management Station columns are automatically filled in with their respective read-only values. The icons Edit and Delete display on the row.

9.14.2 Modifying comments in the Comments table
▷ You can edit only your own comments.
1. Click Edit corresponding to the row with your comments.
  ◄ The comments cell in that row becomes editable.
2. Make the required updates and press ENTER.
  ◄ The comments are updated.

9.14.3 Deleting comments from the Comments table
▷ You can delete only your own comments.
- Click Delete corresponding to the row with your comments.
  ◄ The comments are deleted.

9.14.4 Selecting Rows in Tables
You can select single or multiple rows in a reports table in the Run Mode. The information of the object or objects in the selected row or rows displays in the Contextual pane. Additionally, any related items of the objects also display in the Related Items pane. To select multiple rows, hold down the CTRL key and select the rows.
In Trends tables, you can select only a single cell and the information of the object in the selected cell displays in the Contextual pane.
9.15 Creating and Viewing a Report as a PDF or Excel

After executing a Report Definition manually or automatically, you can view and save the report as a PDF or Excel (XLSX) document. This way you can share the PDF/Excel document with someone, or perform some calculations on the Excel document by applying Excel formulas. You can either view the PDF, Excel/CSV documents and consecutive split documents (if any) in the Report Management section under the Report snapshot when you generate the report manually or you can locate them in the folder configured in the Report Output Definition dialog box when you generate the report automatically.

PDF

You can view and save the report output in a PDF document. A PDF document contains all the report elements of the Report Definition with output data and sorting applied. It also displays the special formatting applied to Report Definition elements (such as tables, plots, keywords, and so on). The PDF document can have a maximum of 500 pages, if the number of pages exceeds 500 the document splits into two.
### NOTE 1:
To view a PDF document, you must have a PDF Reader installed on your computer (which is installed with the system).

### NOTE 2:
Reports do not support TrueType collections for PDF generation.
To generate a PDF document for Asian languages, you must select TrueType fonts which support Asian characters in the Report Definition, for example, Arial Unicode MS.

### NOTE 3:
You can print the PDF file by clicking Print on the Reports toolbar. This button is available when you click Create and view PDF on the generated report.

---

### Excel (XLSX)
You can view and save the report output as an Excel (XLSX) document. An Excel document contains all of the reporting elements of the Report Definition with output data and user defined configuration (if applied). Form Controls (if present) in the report definition are not present in the Excel document. Any special formatting applied to the Report Definition elements are not retained in the Excel document.

If you have multiple tables or plots in a report definition, then the generated Excel document displays the details of each table or plot in a separate worksheet. Each worksheet also displays information on other reporting elements such as keywords and logos (if present) in the report definition. Each column in the worksheet has a combo box that corresponds to a table column that enables you to perform analysis on the table data. In case of an Event Details table the generated Excel document does not have any combo boxes as the data displays parent and child records. However, if you remove the child columns from the Select Columns dialog box, run the report, and then generate the Excel document, only the parent records display and the columns display a combo box that enables you to perform data analysis.
In order to perform analysis on a specific set of columns in a table, you can add a PivotTable or chart to the generated Excel document and set this document as a template to the report definition having this table. When you run the report and generate the Excel document, information related to the columns you added to the PivotTable or chart displays in a separate worksheet.

The PivotTable or chart in the template must have columns of only those tables that are present in the report definition. For example, if you have a report definition with an All Logs table, the PivotTable or chart in the Excel document that is set as a template to this definition must have columns specific to the All Logs table only.

In case of an Event Details table, you must remove all the child columns for the PivotTable to be displayed.
An Excel document can have a maximum of 1000 worksheets (0 through 999). Each sheet can have a maximum number of 10,48,575 rows. If all the 1000 worksheets are filled with data, then a new Excel file is created for the next set of records.

**NOTE:**
To view and save an Excel document, you must have Microsoft Office Excel 2007 or later installed. Microsoft Excel is not installed with the management system.

### 9.15.1 Generating a PDF

- You have run a Report Definition and it displays in Run mode.
- A PDF Reader is installed on your system.

- In the **Reports** toolbar, click **Create and view PDF**.
- The PDF file opens in the PDF viewer inside the Reports workspace.
NOTE 1:
When a PDF document exceeds the page limit of 500 pages, it splits into two documents. The PDF creation progress for all the split PDF documents displays under the same Report snapshot in the Report Management section.

NOTE 2:
From the Report Management section, you can:
- Click Stop to stop creating the PDF document and a consecutive PDF split document (if any).
- Click Delete to delete each entry.

NOTE 3:
After clicking Create and view PDF on the generated report, you can save, print, zoom in, and zoom out of the PDF file by clicking either Save PDF as, Print, Zoom In, or Zoom Out on the reports toolbar.

9.15.2 Generating an Excel (XLSX)
You can generate an Excel document using any of the following procedures:
- Generating an Excel document without a template [288]
- Generating an Excel document with a template [289]

9.15.2.1 Generating an Excel Document without a Template

▷ You have run a Report Definition and it displays in Run mode.
▷ Microsoft Excel 2007 or later is installed on your system.

- In the Reports toolbar, click Create and view Excel.

▷ An Excel file is created and stored at the following temporary location on your machine \[Drive\]:\Users\[UserID]\AppData\Local\Temp\temp\GMS. A dialog box displays asking you to save a copy of this file on your machine, open the file from the temporary location, or cancel the procedure to open or save the file.

NOTE 1:
The Excel creation progress for all the split Excel documents displays under the same Report Snapshot in the Report Management section.

NOTE 2:
From the Report Management section, you can do one of the following:
- Click Stop to stop creating a Excel document and a consecutive Excel split document (if any).
- Click Delete to delete each entry.

NOTE 3:
If you have Internet Explorer 10.0 or higher on your machine the Excel file opens outside the Reports Workspace. However, in systems having lower versions of Internet Explorer, the Excel file opens in the Reports Workspace.
9.15.2.2 Generating an Excel Document with a Template

- You have created a report definition, run it, and it displays in the Run mode.
- Microsoft Excel 2007 or later is installed on your system.

1. In the Reports toolbar, click Create and view Excel.
   - An Excel file is created and stored at the following temporary location on your machine [Drive]:\Users\[UserID]\AppData\Local\Temp\temp\GMS. A dialog box displays asking you to save a copy of this file on your machine, open the file from the temporary location, or cancel the procedure to open or save the file.

2. Open the Excel file by clicking Open in the dialog box. If you have Internet Explorer 10.0 or higher on your machine the Excel file opens outside the Reports Workspace. However, in systems having lower versions of Internet Explorer, the Excel file opens in the Reports Workspace. In such cases, you must open the Excel file by navigating to the temporary location of your machine. You can also open the saved copy of the Excel file from your machine.
   **NOTE:**
   If you are opening the file from the temporary location, you must first ensure that you save a copy of this file at a different location on your machine and proceed with the further steps on the saved copy.

3. Open the worksheet with the table information in the saved copy of the Excel file and select a row with data.

4. From the Insert menu, select the PivotTable option.
   - The Create PivotTable dialog box displays.

5. Select the Select a table or range option and specify the table details.

6. Select the New Worksheet option in the Choose where you want the PivotTable report to be placed and click OK.
   - A new worksheet is added to the Excel document with the PivotTable options.

7. From the PivotTable Field List, select the columns to be added to the PivotTable.
   - The selected columns are added to the worksheet.

8. (Optional) Re-organize the columns as per your requirement in the Drag fields between areas below section in the PivotTable Field List.
   - Any changes you make in this section, reflect in the worksheet.

9. Select any row from the PivotTable, right click, and then select PivotTable Options.
   - The PivotTable Options dialog box displays.

10. Select the Data tab.

11. In the PivotTable Data section, clear the Save source data with file check box and select the Refresh data when opening the file check box.

12. Click OK.

13. Delete all the sheets in the Excel document, except the sheet having the PivotTable configuration.

The saved Excel document is a template that contains the PivotTable.

15. Select the Report Definition you created.

16. From the Extended Operation tab, specify the path of the template in the Excel Output Template field and click Set. By default, the Excel Output Template field does not display in the Extended Operation tab. In order to display this field, you must select the DL3 display level check box for the Template Path property in the Report Definition Object Model.

**NOTE:** The template path is the path of the Server machine. A Process Monitor User must have access to the folder in which the template file is present for the PivotTable to display.

17. Run the report.
   - The generated report displays in the Run mode.

18. In the Reports toolbar, click Create and view Excel.

19. Click Open to open the Excel document.
   - The Excel document displays. The first worksheet displays information on the PivotTable and the details of other table(s) in the Report display in the other sheets.

### 9.16 Routing Reports

You can route reports to folders, email recipients as an attachment, and to local printers.

Routed reports can be in the format:
- PDF
- XLS
- CSV

In order to route reports, you must:
1. Configure report destination types [➡ 290], such as email recipients.
2. Configure a Report Output Definition [➡ 292] in which you specify the report output file format and destination.
3. Run a Report Definition [➡ 282] using one of the following:
   - The Execute command button from the Extended Operation tab of the Contextual pane.
   - Create a macro [➡ 352] for a report definition and execute.

### 9.16.1 Configuring Report Destination Types

You must configure the following destination types to route report outputs:
- Report output folder(s) [➡ 291]) to save a file in a specific location
- Contact list [➡ 357] of recipients to send an email
- Server printer to send a PDF to print out

**NOTE:** Contact list(s) and server printer(s) are configured outside of the Reports workspace. If no contacts or printers are configured in Desigo CC, the corresponding drop-down lists in Reports is empty.
9.16.1.1 Configuring a Report Output Folder

1. From the Reports ribbon, click the Settings tab.

2. Click Dialog Launcher for the Report Output group box.
   ➔ The Report Output Definition dialog box displays.

3. Select File as the Destination Type and click Configure Folders that becomes available.
   ➔ The Report Output Folders Configuration dialog box displays.

4. Type the Folder Alias (name).

5. Click Browse to select a destination folder. To route report documents to a network folder, see the NOTE following this procedure.

6. (Optional) In the Folder Description field, type the folder description.

7. Click Add.
   ➔ The output folder is added to the List of Folders for the Report Output.

8. Click Close to close the Report Output Folders Configuration dialog box.
   ➔ The configured output folders display in the File drop-down list of the Report Output Definition dialog box.

NOTE:
To route report documents to a network folder, you must do the following:
a) Share and map the network folder on the client machine.
b) Provide full permissions to Process Monitor User on shared and mapped folder.

9.16.1.2 Modifying a Report Output Folder

▷ At least one output folder [➔ 291] is present in the List of Folders for Report Output of the Report Output Folders Configuration dialog box.

1. In the Report Output Folders Configuration dialog box, select an output folder from the List of Folders for Report Output.
   ➔ The Folder Alias, Folder Path, and Folder Description fields are populated with pre-configured data.

2. Modify the fields as necessary. Modifying the Folder Alias field adds a new entry in the List of Folders for Report Output.
   ➔ The Change button becomes available.

3. Click Change.
   ➔ The output folder is modified.

4. Click Close to close the Report Output Folder Configuration dialog box.
   ➔ The modified output folders displays in the File drop-down list of the Report Output Definition dialog box.
9.16.1.3 Deleting a Report Output Folder

- At least one report output folder [➙ 291] is present in the List of Folders for Report Output in the Report Output Folders Configuration dialog box.

1. In the Report Output Folders Configuration dialog box, select an output folder from the List of Folders for Report Output.

2. Click Delete.

- A message will prompt you to confirm your action, and the output folder entry is deleted from the List of Folders for Report Output.

9.16.2 Configuring a Report Output Definition

A Report Output Definition specifies the file format in which the report output can be generated: either PDF, XLS, or CSV. It also specifies the destination type(s) for the report output. You can choose File [➙ 292], Email [➙ 293], or Printer [➙ 294]. After configuring, you can modify [➙ 294] or delete [➙ 294] an existing Report Output Definition.

9.16.2.1 File

- You have configured report output folders [➙ 291].

1. From the Reports ribbon, click the Settings tab.

2. From the Report Output group box, click Dialog Launcher [➙ ].

- The Report Output Definition dialog box displays.

3. Select the required report format (PDF, XLS, or CSV) in the Report format list.

4. Select File in the Destination types list.

5. From the File drop-down list, select the destination folder where you want to save the file.

- The File drop-down list displays all the report output folders that you have configured.

6. Select Enter custom file name to add the file name. The default option is Use report name as file name.

7. Do one of the following:

- Select the Append date/time to file name check box to add the date and time to the file name when saved.

  NOTE: The Create new/overwrite existing file and Append data options become unavailable when you select the Append date/time to file name check box.

- Select the Append data option button to append data (previously gathered) in the same folder but creating new document with incremental number.

- Select the Create new/overwrite existing file option button to create a new file or overwrite the existing file with the same file name.

8. Click Add.

- The selected format, destination, and file name are added to the Output Definition list.
9. Click OK.

> Configured Report Output Definitions display in the Report Output group box.

**NOTE 1:** When executed (using the Execute command button or macros and reactions), the file is created and saved at the configured destination with the name entered in the **File Name** field.

**NOTE 2:** In a CSV file, numeric values display in an exponential format.

### 9.16.2.2 Email

▷ You have configured the mail server or have verified it has been configured.

1. From the **Reports** ribbon, click the **Settings** tab.

2. From the **Report Output** group box, click **Dialog Launcher**.

> The **Report Output Definition** dialog box displays.

3. Select the required format (PDF, XLS, or CSV) in the Report format list.

4. Select **Email** in the **Destination types** list.

> The **Select Contacts** button becomes available.

5. Click **Select Contacts**.

> The **E-Mail Contacts** dialog box displays all the configured contacts.

6. Select the required contact(s) by selecting the check box preceding each contact.

7. Click **OK**.

> The selected contacts are displayed in the **Destination** field in the **Report Output Definition** dialog box. A semicolon (;) separates multiple contacts.

8. In the **Report Output Definition** dialog box, do one of the following:

   - Select **All documents in one email**.
   - Select **Document(s) per mail** and configure the number of documents to be sent.

     The default option is one document per email.

     If you configure too many documents per email, the email delivery may take long time!

9. Select the **Enter custom file name** option to add the file name. The default is **Use report name as file name**.

10. Select the **Append date/time to file name** check box to add the date and time to the file name when saved.

11. Click **Add**.

> The selected format, destination, and file name are added to the **Output Definition** list.

12. Click **OK**.

> The configured Report Output Definitions display in the **Report Output** group box. When executed (using the Execute command button or macros and reactions), the file is emailed as an attachment to the configured email contact(s).
9.16.2.3 Printer

▷ One or more local printers are configured in the System.
1. From the Reports ribbon, click the Settings tab.
2. From the Report Output group box, click Dialog Launcher. 
   ➤ The Report Output Definition dialog box displays.
3. Select PDF in the Report format list. 
   NOTE: The destination type Printer is not available for XLS or CSV printing.
4. Select Printer in the Destination types list.
5. Select the required printer from Printer drop-down list.
6. Select the option to print either All or the First number of pages. 
   NOTE 1: By default, the first 100 pages are printed. You can edit the default and add the number of pages to be printed. 
   NOTE 2: Content that is printed depends on the sorting you applied on the table.
7. Click Add. 
   ➤ The selected format and destination are added to the Output Definition list.
8. Click OK. 
   When executed (using the Execute command button or macros and reactions), the file is sent to the configured printer for printing.

9.16.2.4 Modifying a Report Output Definition

1. Select an existing Report Output Definition from the Output Definition list of the Report Output Definition dialog box.
2. Modify the Report format, Destination type, and/or Destination. 
   ➤ The Change button becomes available.
3. Click Change. 
   ➤ The Report Output Definition is modified.

9.16.2.5 Deleting a Report Output Definition

1. Select a Report Output Definition from the Output Definition list of the Report Output Definition dialog box.
2. Click Delete. 
   ➤ The selected Report Output Definition is deleted.
9.17 Exporting a Report Definition

**NOTE:**
You can export multiple Report Definitions or multiple folders; however, you cannot export a Report Definition and a folder at the same time.

1. You are in System Browser.
   1. Select **Reports > Report Definition(s)** or **folder(s) containing Report Definition(s)**. To select multiple Report Definitions or folders, hold the **CTRL** key.
   2. In the **Reports** toolbar, click **Export**.
      - The **Browse for Folder** dialog box displays.
   3. Browse for the **desired location** and click **OK**.
      - On successful export, a confirmation message displays and the Report Definition(s) or folder(s) are exported to the selected location. The export file is created in an XML format.
      **NOTE:** The export fails, if you don’t have write permission for the selected location.

**NOTE 1:**
If the Report Definition(s) selected for export contains logo(s), then image files (.jpg, .bmp, and so on) associated with these logo(s) are also exported to the selected location.

**NOTE 2:**
If a Report Definition file name contains special characters (such as \, <, >, |), they are replaced with an underscore (_) when the export file is created.

9.18 Importing a Report Definition

1. You have exported **[295]** Report Definition(s) or a folder containing Report Definition(s) to a specified location.
   - You have selected a report folder for importing into the System Browser.
   1. In the **Reports** toolbar, click **Import**.
      - The **Open** dialog box displays.
   2. Browse for the folder where the exported .xml files, logo files, and so on were created and saved after exporting a Report Definition.
      - If you import a Report Definition with the same name that already exists under the folder selected for import, the existing Report Definitions with the same name(s) are overwritten.
   3. Select single or multiple .xml and any associated logo files (.jpeg, .gif, .png, and so on).
      - Use the **CTRL** key to select multiple files.
      - If you import logo files, these are stored at the default logo storage location: [drive]:\GMSProjects\[project]\data\Reporting\Logos, where [project] is the project you created using System Management Console.
9 Reports
Deleting a Report Definition

4. Click Open.
   ➔ On successful import, the selected Report Definition(s) are imported in the selected folder in the System Browser.

NOTE 1: If you open a Report Definition that has invalid column(s), invalid condition filter(s), or is missing content templates for a table or a plot, the Report Validation [➙ 297] dialog box displays the errors. For example, if the imported Report Definition contains an Active Events table that is not supported, then opening such a Report Definition displays the Report Validation dialog box informing you of this.

NOTE 2: You can import pre-configured Report Definitions and associated logo files. They are available at: \GMSMainProject\Data\Reporting.

NOTE 3: You can also import a log view definition in Reports by selecting the respective xml file. When you import an existing log view definition, the configurations applied to the definition such as selected columns, filters applied, resizing and reordering of columns are retained. Data sorting on some columns is retained. However, since reports do not support sorting on some columns, if any such columns are present in the imported log view definition, then the sorting on such columns is not retained.

9.19 Deleting a Report Definition

▷ At least one Report Definition is available under System Browser > Reports.

1. In System Browser, select Application View.

2. Expand the main Reports folder.

3. Select the Report Definition that you want to delete.

4. In the Reports toolbar, click Delete ❌ .
   ➔ A confirmation message displays.

5. Click OK to confirm.
   ➔ If confirmed, the selected Report Definition is deleted from the System Browser tree.

TIPS:

• If a Report Definition is deleted but a report snapshot(s) related to this definition exists in the Report Management section, you can do the following:

  - Display the report data by selecting this report snapshot

  - Generate PDF/Excel documents using this snapshot

  - Run this report and generate additional snapshots. You can switch back to the Edit mode, make changes in the Report Definition, and save and create a new Report Definition at the specified location in System Browser.

  - Delete the snapshot(s) using the Delete button available in the Report Management section.
9.20 Aborting a Running Report Definition

▷ You are executing a Report Definition.

● Do one of the following:
  – In the Reports toolbar, click Stop.
  – In the Report Management section, click Stop that becomes available in the Action column for a currently running Report Definition.

▷ A report is populated with the data which is gathered before you stopped the report execution.

NOTE:
You can stop creating a PDF or XLS document in the same way.

9.21 Reports References

The following sections provide additional information regarding reports.

9.21.1 Validating a Report Definition

The Report Definition is validated when you open or save it for:

● Columns of the table(s) present in the Report Definition
● Condition filter(s)
● Availability of the content template

![Report Validation Dialog Box](image_url)
Columns in Table(s) Present in the Definition

When you open or save a Report Definition, it is checked for the validity of the selected columns present in the table(s). If any of the columns in the Report Definition is invalid, an error message informing you the position of the erroneous table element or column name displays.

You can run a report containing invalid columns; however, in the executed report, the invalid column will not contain any data. The same is true for any PDF/XSL that you generate from the executed report.

Condition Filters

If you open a Report Definition where a Condition filter exists on an invalid column, an error message displays the name and position of the table, and any invalid condition filter(s).

While you can run such a report; the tables containing invalid condition filters are empty in the executed report. The same is true for any PDF/XSL that you generate from the executed report.

To resolve the validation error on invalid column(s) or condition filter(s), do any of the following depending on the table type:

- [Objects table] The table columns correspond to object properties. If any of the properties are no longer available, the error message displays on opening or saving a report having this property as a column. You must either import the related libraries or remove the invalid column(s) to resolve this error.
- [Other tables] Remove the invalid column(s).

Availability of the Content Template

If a table/plot is present in a Report Definition, but the associated content template is missing, when you open such a definition, a message displays that this table type/plot is not supported.

While you can open the definition, any unsupported tables/plots do not display.

9.21.2 Report Events Logged in the History Database

An entry is logged in the History Database when the following events occur:

- Reports Manager startup
- When you execute a report (manually/automatically). In case of automatic report execution, only one event is logged for all Report Output Definitions configured in that specific Report Definition.

**NOTE:**
An event is not logged for a manually executed report until you save it.

9.21.3 Reports – Scope Rights

The Reports data that displays is determined by that user's scope, permissions for object attributes, and the access level that user has for the different Desigo CC objects.

- Data related to objects which are excluded from the scope of a user is not displayed to that user.
- If objects are in scope for a user, but that user does not have permissions for the attributes (Discipline, Sub Discipline, Type, Sub Type) of these objects, then data related to these objects does not display to that user. For example, if Discipline is set to Fire in a user's Scope Rights, then data related to all other disciplines is not displayed to that user.
- If objects are in scope for a user, but that user does not have read or read/write access to those object properties, then data related to these objects is not displayed to that user.

- (In context of Operating Procedure Steps) If the configured report definition is out of scope, then the report does not execute, and the message "Access Denied. Please contact System Administrator" displays in the status bar. The Save User Input and Send to Output buttons are not available.

## 9.21.4 Working with Reports for Operating Procedures

The following table may help you to resolve possible errors when working with reports for operating procedures.

<table>
<thead>
<tr>
<th>Problem</th>
<th>Cause</th>
<th>Resolution</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reporting snapin does not display</td>
<td>- You do not have the Show privilege for Reporting.</td>
<td>- Contact the system administrator to obtain the Show privilege.</td>
<td>- See the Operating Procedures help in the Engineering Manual (A6V10415473) for the configuration steps.</td>
</tr>
<tr>
<td>Report for operating procedures is not executed</td>
<td>- Configured Report Definition is out of scope.</td>
<td>- Contact the system administrator.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Configured Report Definition is either deleted or corrupted.</td>
<td>- Configure a new report definition.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Report Definition is not configured in operating procedures.</td>
<td>- Ensure that the report definition is configured in the Operating Procedure step.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Ensure that the report definition is configured in the Operating Procedure step.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Configure the report with form controls.</td>
<td></td>
</tr>
<tr>
<td>Save User Input and Send to Output buttons are not available</td>
<td>- You do not have the Show privilege for Reporting.</td>
<td>- Contact the system administrator and get the Show privilege.</td>
<td>- See the Operating Procedures help in the Engineering Manual (A6V10415473) for the configuration steps.</td>
</tr>
<tr>
<td></td>
<td>- Configured Report Definition is out of scope.</td>
<td>- Contact the system administrator.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Configured Report Definition is either deleted or corrupted.</td>
<td>- Configure a new report definition.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Report Definition is not configured in operating procedures.</td>
<td>- Ensure that the report definition is configured in the Operating Procedure step.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Configured report does not contain form controls [In this case only the Save User Input button is not available]</td>
<td>- Configure the report with form controls.</td>
<td></td>
</tr>
<tr>
<td>Report for operating procedure does not display</td>
<td>- The configured table's content provider is not available in the</td>
<td>- Contact the system administrator and get the content provider added to the project.</td>
<td>To create a graphics, see Creating a Graphic [66] in the Graphics help.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### 9.22 Examples

This section provides examples on creating and configuring reports. Procedures on how to create and configure the reports, along with information on their constraints are also covered.

The examples cover certain aspects that you must know before creating or configuring a report such as the syntax to be followed when applying a condition filter, significance of column names with and without square brackets [], and so on. By referring to these examples, you will be able to create and configure any type of report.

Objects Report [➙ 301]
Activities Report [➙ 304]
Event Details Report [➙ 307]

| configured table in the Run mode | project.  
• One of the element such as graphics has not received data from the service/graphic s engine. | Create a graphics containing the object in event. |
|---|---|---|
| PDF document generated for operating procedure does not display any data  
• Data is not available as per the filters applied to the configured table.  
• Graphics is not available for the object in event. | Check and correct the applied filters.  
Create a graphics containing the object in event. | To create a graphics, see Creating a Graphic [➙ 66] in the Graphics help. |
| The report for the operating procedure cannot get routed to the specified printer  
• Printer is faulty.  
• Printer does not have paper.  
• Printer is jammed.  
• Printer is not reachable  
• Printer is offline  
• Printer door is open | Rectify the printer related issues | |
| The report for the operating procedure cannot get routed to the specified folder  
• You do not have permissions for the specified folder  
• Either contact the system administrator to receive the required permissions on the configured folder or configure a new folder. | Ensure that the condition filter is applied properly. | For steps to apply the condition filter to a table, see Applying a Condition Filter [➙ 273]. |
| Table in the report does not display any data  
• The Report Definition has an invalid condition filter | Ensure that the condition filter is applied properly. | |


9.22.1 Objects Report

This section provides information on configuring the Objects report.

Overview

An Objects report contains an Objects table that displays the run time property values of system objects. To know the property values of any object such as present value, high limit, low limit and so on, you must configure an Objects report.

Each object has a corresponding object model associated with it. An object model specifies the properties applicable to the object type, configuration attributes of properties, and additional settings like data type of the property, text group configured for the property, commands defined for the property and so on. Each property value has configuration attributes like property name, property descriptor, unit, resolution, minimum and maximum value, and so on. For example, the Present Value property has attributes such as Unit, Resolution, Type, Descriptor and so on. The Objects report also provides information on these attributes.

The properties applicable to an object type can be selected to display as columns in the Objects table by setting the appropriate display levels in the Properties expander in Models and Functions. For more information on setting display levels, see System Help. In the following screenshot, the AlarmFault and Alarm.OffNormal properties cannot display as table columns since their display levels are not set.

If a property has array attributes assigned to it, then the text entries in the text group associated with the array attributes of the property can be set as the attribute columns in the Objects table. For example, the Event_Time_Stamps property of the BACnet Analog Input object type has the TxG_BACnetEventTransitionBits Text group associated with its array attributes. You can set the text entries of the text group (To Off Normal, To Fault, To Normal) to display as columns in the Objects table.
Steps for Configuring an Objects Report for a Particular Object Type

1. Create a new report definition [➔ 262] with the objects table inserted.
   ⇒ The Objects table is inserted with the following default set of columns — Object Description, Object Designation, Function, Discipline, Type, Subtype, Main Value.

2. Right-click the table and select Select Columns. The Select Columns dialog box displays.

   ![Select Columns Dialog Box](image)

3. Enter the object type description in the Type Filter field. The Type drop-down list displays the object types corresponding to the description you entered. For example, if you want the Type drop-down list to display all BACnet object types, enter BACnet as the type filter.

4. Select the object type from the Type drop-down list, for example, BACnet Analog Output.
   ⇒ The columns applicable to the selected object type are listed in the Available Columns list.

   NOTE: For more information regarding the Type Filter, Type, and Available Columns for the Objects table, see Select Columns Dialog Box - For Objects Table section in [➔ 231].

5. Select the property and/or attribute to display as column(s) in the table. If you want to see the run time value of a property then select the column associated with that property, for example, to see the present value of Analog Output, select the Present Value column. If you want to see the configuration information for a property then select the attribute associated with that property. For example, to see the unit and/or resolution for the present value of Analog Output, select the Present Value.Unit and/or Present Value.Resolution column.
   ⇒ The list of selected column(s) displays in the Selected Columns list.

   NOTE: To remove columns that you do not want displayed in the table, click .

6. Click OK in the Select Columns dialog box.
   ⇒ The Objects table displays with the selected columns.
7. Configure a name filter \[\rightarrow 272\] for your report by dragging-and-dropping the required objects from the System Browser to the Objects table in the report definition. In order to get the desired results, you must assign the objects of type for which columns are configured in your report. For example, if you have selected columns for the BACnet Analog Output object, then you must assign Analog Output objects as name filter.

**NOTE:** Your report is now ready with the basic configuration. You can run the report to display all the data or apply condition filters to view specific information. If you want to continue without applying any condition filters, proceed to Step 10.

8. Configure a condition filter for your report. For example, assume that you want to view the details of all BACnet Analog Output objects with the Current Priority as 16.

9. Right-click the Objects table, point to Filters and select **Condition Filter**. The **Condition Filter** dialog box displays.

10. Perform the following steps to apply the condition filter:
   a. Enter BACnet in the **Type Filter** field to display all BACnet related objects in the **Type** drop-down list.
   b. Select the BACnet Analog Output Object from the **Type** drop-down list. All the common columns and columns specific to the selected object display in the **Available Columns** list.
   c. Select the column on which you want to add the condition filter. In this case, select [Current_Priority].
   d. Select = in the **Operator** list.
   e. In the **Values** text field, enter "Priority - 16".
f. Click Add.
g. Click OK.

► The Condition Filter is added to the table.

NOTE: When you are creating a condition filter, the syntax of the property values depends on the data type of the property. For more information, see Condition Filter Syntax in Condition Filter [► 240].

11. Run the report [► 280] to view the data.

► If you have applied the condition filter, the details of all analog output objects with Current Priority set to 16 display. If no condition filter is specified, then the details of all the analog output objects display.

12. Save the report definition [► 278] if the configuration of columns and name filter is sufficient.

NOTE: You can enhance the report configuration at any time in the future by adding/removing columns or by setting additional objects as name filter or by removing existing objects from the name filter.

9.22.2 Activities Report

This section provides information on configuring the Activities report and its constraints.

Overview

The Activities report provides information on system activities over a period of time. For example, you can generate an Activities report to get the treatment related information logged in the database for activities.

Constraints

- You cannot sort or apply condition filters for the following columns:

<table>
<thead>
<tr>
<th>No Sorting</th>
<th>No Condition Filter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Discipline</td>
<td>Error</td>
</tr>
<tr>
<td>Subdiscipline</td>
<td>DPE Name 1</td>
</tr>
<tr>
<td>Type</td>
<td>DPE Name 2</td>
</tr>
<tr>
<td>Subtype</td>
<td>Associated Object Description</td>
</tr>
<tr>
<td>Object Description</td>
<td>Associated Object Name</td>
</tr>
<tr>
<td>Object Name</td>
<td>Associated Object Designation</td>
</tr>
<tr>
<td>Object Property</td>
<td>Associated Object Location</td>
</tr>
<tr>
<td>Quality</td>
<td>Associated Object Name (Internal)</td>
</tr>
<tr>
<td>Previous Quality</td>
<td></td>
</tr>
<tr>
<td>Object Designation[Application View]</td>
<td></td>
</tr>
<tr>
<td>Object Designation[Current View]</td>
<td></td>
</tr>
<tr>
<td>Object Designation[Management View]</td>
<td></td>
</tr>
<tr>
<td>Object Identifier [Internal]</td>
<td></td>
</tr>
<tr>
<td>Object Location</td>
<td></td>
</tr>
<tr>
<td>Object Location[Application View]</td>
<td></td>
</tr>
<tr>
<td>Object Location[Current View]</td>
<td></td>
</tr>
<tr>
<td>Object Location[Management View]</td>
<td></td>
</tr>
<tr>
<td>Error</td>
<td></td>
</tr>
</tbody>
</table>
When you are adding a condition filter to the Activities table, you cannot apply the
**OR** operator between two filter expressions that are located on two different
columns. For example, the expression 'Log Type' = "Reports" OR 'Action' = "Report Execution" is invalid.

You can apply the **OR** operator between two filter expressions set on the same
column. For example, 'Log Type'="Reports";"Scheduling") is valid. To apply
the OR operator on the same column, select the column and the operator,
press **SHIFT** or **CTRL**, depending on whether you want to select values listed
next to each other or away from each other, and then click **Add**.

You cannot apply the **NOT** operator in the Condition Filter for an Activities
table. For example, NOT 'Action' = "Add Camera" is invalid.

**Example**
Let us assume that you want to determine the number of times the present value
property of an Analog Input object has exceeded 100 in the last 24 hours. In this
case, you must configure an Activities report. In order to monitor the change of
value of any property in the activities report, you must ensure that the AL attribute
for the property is selected for the respective Analog Input object. For this you must
navigate to the **Properties** expander in **Object Configurator**.

**Steps for Configuring an Activities Report**

1. Create a new report definition [→ 262] with the Activities table inserted.
   - The Activities table contains the following default set of columns — Source
     Time, Object Description, Object Designation, Action, Log Type, Previous
     Value, Value, Status, User Name, Management Station, Message Text,
     and Attachment.

2. **(Optional)** Add any extra columns to the table from the Select Columns [→ 231]
dialog box. To display this dialog box, right-click the table and select **Select
Columns**.
3. From the System Browser, drag-and-drop the analog input object whose value you want monitored, to the Activities table. This object acts as the name filter [→ 238].

4. Right-click the Activities table, point to Filters and select Condition Filter. The Condition Filter dialog box displays.

5. Perform the following steps to apply the condition filter:
   a. Select Value from the Available Columns list.
   b. Select > from the Operators list.
   c. Enter 100 in the Values text field.
   d. Click Add. The expression displays in the Filter Expression field.
   e. Click OK.

   The Condition Filter is added to the table.

   NOTE: When you are creating a condition filter, the syntax of the property values depends on the data type of the property. For more information, see Condition Filter Syntax in Condition Filter [→ 240].

6. Specify the time period by adding the Time Filter to the report definition.
   Perform the following steps to add the Time filter:
   a. Right-click the Activities table, point to Filters and select Time Filter. The Time Filter dialog box displays.
   b. Select the Relative option.
   c. Select the Last or Current Period option, depending on the data requirement for the last 24-hour period or current 24-hour period. For more information regarding setting the time period, see Time Filter [→ 243]. In this example, since data is required for the last 24-hours, you must select Last and specify 24-hours.
7. Run the report \( \rightarrow 280 \) to view the data.

   - The report displays the data for analog input object where value is greater than 100 in the last 24-hours.

8. Save the report definition \( \rightarrow 278 \) if the data matches your requirements.

   **NOTE:** You can enhance the report configuration at any time in the future by adding/removing columns or by setting additional objects as name filter, removing existing objects from the name filter, or by modifying the condition filter, time filter criteria.

### 9.22.3 Event Details Report

This section provides information on configuring the Event Details report and its constraints.

**Overview**

The Event Details report provides information related to events and their treatment. When you run the report, the preliminary details of the event such as Event Time, Event Category, Event Cause, Event ID, Object Description, and Object Designation display as parent records. Additional information related to the treatment of the event such as Time, Action taken, Message text, User Name, Management Station, Attachment, Value, and Previous Value display as child records. The child records display only in the Run mode. The total number of available children can be read from the **Row No** column.

The number of records that display in the child table depend on the following:

- If a name filter with wild card characters is applied to the report or a default name filter is applied, then the latest 1000 records display.
If a single name filter without any wild card characters is applied, then all records display. In this case, the **Row Number** column is empty.

If multiple name filters are applied, then the child table is restricted to the latest 1000 records.

You can configure an Event Details report for the following:

- Viewing event details of a particular event using Investigative Treatment [➙ 309].
- Viewing event details of a particular event using Assisted Treatment [➙ 310].
- Viewing event details for specific events using Reports [➙ 311]. For example, you can configure an event details report to display all events of type Fault or Life Safety on an Analog Output object for a 24-hour period.

**Constraints**

- You cannot sort or apply condition filters for the following columns:

<table>
<thead>
<tr>
<th>No Sorting</th>
<th>No Condition Filter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Discipline</td>
<td>DPE Observer</td>
</tr>
<tr>
<td>Subdiscipline</td>
<td>Event Source</td>
</tr>
<tr>
<td>Type</td>
<td>Observer Description</td>
</tr>
<tr>
<td>Subtype</td>
<td>Observer Name</td>
</tr>
<tr>
<td>Object Description</td>
<td>Observer Designation</td>
</tr>
<tr>
<td>Object Name</td>
<td>Observer Location</td>
</tr>
<tr>
<td>Object Property</td>
<td>Observer Identifier (Internal)</td>
</tr>
<tr>
<td>Object Designation</td>
<td>Event Went</td>
</tr>
<tr>
<td>Object Designation[Application View]</td>
<td></td>
</tr>
<tr>
<td>Object Designation[Current View]</td>
<td></td>
</tr>
<tr>
<td>Object Designation[Management View]</td>
<td></td>
</tr>
<tr>
<td>Object Identifier [Internal]</td>
<td></td>
</tr>
<tr>
<td>Object Location</td>
<td></td>
</tr>
<tr>
<td>Object Location[Application View]</td>
<td></td>
</tr>
<tr>
<td>Object Location[Current View]</td>
<td></td>
</tr>
<tr>
<td>Object Location[Management View]</td>
<td></td>
</tr>
<tr>
<td>Observer Description</td>
<td></td>
</tr>
<tr>
<td>Observer Name</td>
<td></td>
</tr>
<tr>
<td>Observer Designation</td>
<td></td>
</tr>
<tr>
<td>Observer Location</td>
<td></td>
</tr>
<tr>
<td>Observer Identifier (Internal)</td>
<td></td>
</tr>
<tr>
<td>Alias [Object]</td>
<td></td>
</tr>
<tr>
<td>Alias [Observer]</td>
<td></td>
</tr>
</tbody>
</table>

- When you are adding a condition filter to the Event Details table, you cannot apply the OR operator between two filter expressions located on two different columns. For example, the expression 'Discipline' = "Building Automation" OR 'Event Category' = "Alarm" is invalid.

- You can apply the OR operator between two filter expressions set on the same column. For example, 'Discipline' =("Building Automation","Fire") is valid. To apply the OR operator on the same column, select the column and the
operator, press **SHIFT** or **CTRL**, depending on whether you want to select values listed next to each other or away from each other, and then click **Add**.

- You cannot apply the **NOT** operator in the Condition Filter for an Event Details table. For example, NOT 'Discipline' = "Building Automation" is invalid.

### 9.22.3.1 Viewing Event Details using Investigative Treatment

- Ensure that operating procedure templates (if configured) are disabled. See the Operating Procedures help in the Engineering Manual A6V10415473 for additional information.

- Ensure that a report containing the Event Details table is available and the **Show in Related Items** checkbox is selected for this report or the **HQ_EventDetailsLog** report is imported.

1. Double-click the event in the Event bar.

   - The event details display in the **Contextual** pane.

2. Perform the required steps to treat the event.

3. Select the report containing the Event Details table from Related Items.

   - The report executes in the **Secondary** pane and the information related to the event time, category, cause, ID, object description, and designation displays in the report.

4. Click **+** before the event entry.

   - Information related to the event treatment such as Time, Action, User Name, Management Station, Attachment, Value, and Previous Value display as child records.
9.22.3.2 Viewing Event Details using Assisted Treatment

- You have created an Operating Procedure template in Operating Procedures in System Browser and have completed the required configuration steps. See the Operating Procedures help in the Engineering Manual A6V10415473 for creating and configuring an Operating Procedure template.

- Ensure that the Operational Status property for the Operating Procedure template is set to Enabled. See the Operating Procedures help in the Engineering Manual A6V10415473 for additional information.

- An Alarm step is added to the Operating Procedure template and an Event Details report is associated with the step. The step is configured as per the required settings. See the Operating Procedures help in the Engineering Manual A6V10415473 for creating and configuring the alarm step.

1. Double-click the event in the Event bar.

   - The Event Details report displays in Assisted Treatment. Information related to the event time, category, cause, ID, object description and designation displays in the report.

2. Click before the event entry.

   - Additional information related to the event such as Time, Action, User Name, Management Station, Attachment, Value, and Previous Value display as child records.

3. Perform the required steps to treat the event from the Contextual pane.

4. Click Send to Output on the toolbar.

   - The report is routed to a file, email, or printer according to the Report Output configuration settings [292].

   **NOTE:** If you have not specified the report output configuration settings, the
information is routed to the path specified in the location supervised folder in
the System Browser: Management View > Management System > Servers >
Main Server > Report Manager > Report Default Folder.

9.22.3.3 Viewing Event Details for specific events using Reports

1. Create a new report definition [➙ 262] with the Event Details table inserted.
   ­ The Event Details table is inserted with the following default set of columns
   — Event Time, Event Category, Event Cause, Event ID, Object
   Description, and Object Designation.

2. **(Optional)** Add any extra columns to the parent table from the **Parent** tab in the
   Select Columns [➙ 231] dialog box. You can add the extra columns to the child
   table from the **Child** tab. To display this dialog box, you must right-click the
   table and select **Select Columns**.

3. From the System Browser, drag-and-drop the analog output object (For
   example, Analog Output 1) whose event details are to be monitored to the
   Event Details table. This object acts as the name filter [➙ 238].

4. Right-click the **Event Details** table, point to **Filters** and select **Condition Filter**.
   The Condition Filter dialog box displays.

5. Perform the following steps to apply the condition filter:
   a. Select **Event Category** from the **Available Columns** list.
   b. Select **=** from the **Operators** list.
   c. From the **Values** list, select **Fault**, press **CTRL**, and then select **Life Safety**.
   d. Click **Add**. The expression displays in the **Filter Expression** field.
   e. Click **OK**.

   ­ The Condition Filter is added to the table.

   **NOTE:** When you are creating a condition filter, the syntax of the property
   values depends on the data type of the property. For more information, see
   Condition Filter Syntax in Condition Filter [➙ 240].
6. Specify the time period by adding the Time Filter to the report definition. Perform the following steps to add the Time filter.
   a. Right-click the Event Details table, point to Filters and select Time Filter. The Time Filter dialog box displays.
   b. Select Relative.
   c. Select either the Last or Current Period option, depending on the data requirement for the last 24 hour period or current 24 hour period. For more information regarding setting the time period, see Time Filter [243]. In this case, as we want the data for the current 24-hour period, select Current Period and specify 24 hours.
   d. Click OK

7. Run the report [280] to view the data.
   - The report displays the details of any Fault or Life Safety events that occurred on the Analog Output 1 object in the current 24-hour period.

8. Save the report definition [278] if the data matches your requirements.
   **NOTE:** You can enhance the report configuration at any time in the future by adding/removing columns or by setting additional objects as name filter, removing existing objects from the name filter, or by modifying the condition filter, time filter criteria.
9.22.4 Events Report

The following section provides information on the Events table and its constraints.

Overview

The Events table provides information related to events. It provides information such as Event Time, Event State, Event Category, Event Cause, Event ID, Object Description, and Object Designation.

Constraints

- You cannot sort or apply condition filters on the following columns:

<table>
<thead>
<tr>
<th>No Sorting</th>
<th>No Condition Filter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Discipline</td>
<td>DPE Observer</td>
</tr>
<tr>
<td>DPE Observer</td>
<td>Event Source</td>
</tr>
<tr>
<td>Event Source</td>
<td>Observer Description</td>
</tr>
<tr>
<td>Subdiscipline</td>
<td>Observer Name</td>
</tr>
<tr>
<td>Type</td>
<td>Observer Designation</td>
</tr>
<tr>
<td>Subtype</td>
<td>Observer Location</td>
</tr>
<tr>
<td>Object Description</td>
<td>Observer Identifier (Internal)</td>
</tr>
<tr>
<td>Object Name</td>
<td></td>
</tr>
<tr>
<td>Object Designation</td>
<td></td>
</tr>
<tr>
<td>Object Designation [App.]</td>
<td></td>
</tr>
<tr>
<td>Object Designation [Cur.]</td>
<td></td>
</tr>
<tr>
<td>Object Designation [Mgmt]</td>
<td></td>
</tr>
<tr>
<td>Object Location</td>
<td></td>
</tr>
<tr>
<td>Object Location [App.]</td>
<td></td>
</tr>
<tr>
<td>Object Location [Cur.]</td>
<td></td>
</tr>
<tr>
<td>Object Location [Mgmt]</td>
<td></td>
</tr>
<tr>
<td>Object Identifier [Internal]</td>
<td></td>
</tr>
<tr>
<td>Object Property</td>
<td></td>
</tr>
<tr>
<td>Observer Description</td>
<td></td>
</tr>
<tr>
<td>Observer Name</td>
<td></td>
</tr>
<tr>
<td>Observer Designation</td>
<td></td>
</tr>
<tr>
<td>Observer Location</td>
<td></td>
</tr>
<tr>
<td>Observer Identifier (Internal)</td>
<td></td>
</tr>
<tr>
<td>Alias [Object]</td>
<td></td>
</tr>
<tr>
<td>Alias [Observer]</td>
<td></td>
</tr>
<tr>
<td>Unit</td>
<td></td>
</tr>
</tbody>
</table>

- When you are adding a condition filter to the Event Details table, you cannot apply the OR operator between two filter expressions set on two different columns. For example, the expression 'Discipline' = "Building Automation" OR 'Event Category' = "Alarm" is invalid.

- You can apply the OR operator between two filter expressions set on the same column. For example, 'Discipline'=("Building Automation";"Fire") is valid. To apply the OR operator on the same column, select the column and the
operator, press **SHIFT** or **CTRL**, depending on whether you want to select values listed next to each other or away from each other and then click **Add**.

- You cannot apply the **NOT** operator in the Condition Filter for an Events table. For example, **NOT 'Discipline' = "Building Automation"** is invalid.

### 9.22.5 Trends Plot

The following section provides information on a Trends Plot and its configuration.

**Overview**

The Trends Plot provides a graphical representation of the change of value of an object over a period of time. In order to view the change of value graphically, you must assign a Trend View Definition as a name filter to the Plot. You cannot add a Condition Filter to the Trends Plot.

**Example**

Let us assume that you want to track the change of value of an Analog Input object graphically over a period of 10 hours. For this you must create a Trends Plot.

**Steps for Configuring a Trends Plot**

- You have created a Trend View Definition with the Analog Input object.


   - A Trends Plot is inserted in the report definition.

2. From the System Browser, drag-and-drop the Trend View Definition to the Trends Plot. This acts as a name filter to the plot.

3. Specify the time period by adding a Time Filter to the plot. Perform the following steps to add the Time filter:
   
   a. Right-click the **Trends Plot**, point to **Filters** and select **Time Filter**. The **Time Filter** dialog box displays.
   
   b. Select the **Relative** option.
   
   c. Select the **Last** or **Current Period** option, depending on the data requirement for the last 10 hours or current 10 hours. For more information regarding setting the time period, see **Time Filter** [► 243]. In this case, we will obtain the data for the current 10 hours by selecting **Current Period** and specifying 10 hours.
   
   d. Click **OK**.
4. Run the report \[\rightarrow 280\] to view the data.

   The report displays the graphical representation of the data for the current 10 hour period.

5. Save the report definition \[\rightarrow 278\].

   **NOTE:** You can enhance the report configuration at any time, in the future, by changing the name and time filters.
9.22.6 All Logs Report

The following section provides information on the All Logs table and its constraints.

Overview
The All Logs table provides information on system activities and events.

Constraints
- You cannot apply sorting on the following columns:

<table>
<thead>
<tr>
<th>No Sorting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Discipline</td>
</tr>
<tr>
<td>Subdiscipline</td>
</tr>
<tr>
<td>Type</td>
</tr>
<tr>
<td>Subtype</td>
</tr>
<tr>
<td>Source Description</td>
</tr>
<tr>
<td>Source Name</td>
</tr>
<tr>
<td>Source Designation</td>
</tr>
<tr>
<td>Source Location</td>
</tr>
<tr>
<td>Source Designation [Application View]</td>
</tr>
<tr>
<td>Source Designation [Current View]</td>
</tr>
<tr>
<td>Source Designation [Management View]</td>
</tr>
<tr>
<td>Source Location [Application View]</td>
</tr>
<tr>
<td>Source Location [Current View]</td>
</tr>
<tr>
<td>Source Location [Management View]</td>
</tr>
<tr>
<td>Source Identifier [Internal]</td>
</tr>
<tr>
<td>Property</td>
</tr>
<tr>
<td>Quality</td>
</tr>
<tr>
<td>Previous Quality</td>
</tr>
<tr>
<td>Alias [Observer]</td>
</tr>
<tr>
<td>Alias [Source]</td>
</tr>
</tbody>
</table>

- When you are adding a condition filter to the All Logs table, you cannot apply the OR operator between two filter expressions set on two different columns. For example, the expression 'Action' = "Automatic Login" OR 'Discipline' = "Building Automation" is invalid.

- You can apply the OR operator between two filter expressions set on the same column. For example, 'Action'='("Add Camera";"Add Group") is valid. To apply the OR operator on the same column, select the column and the operator, press SHIFT or CTRL, depending on whether you want to select values listed next to each other or away from each other, and then click Add.

- You cannot apply the NOT operator in the Condition Filter for a Log View table. For example, NOT 'Action' = "Add Camera" is invalid.

- You can only apply the Equal to (=) operator to the following columns in the Condition Filter dialog box.
  - Discipline
  - Subdiscipline
  - Type
9.22.7 In Operator

The following section provides an example of the In operator. This operator is used to filter data in a column that supports display of multiple values in a single cell.

Assume you have an Objects report that displays data for some objects. Now you want to view the data for only those objects that are linked to a graphic.

A generated Objects report displays in the Primary pane.

1. From the Select Columns dialog box select the Related Items Type column.

The Objects report displays with the Related Items Type column added to it.

2. Perform the following steps to add a condition filter with the In operator:
   a) From the Condition Filter dialog box, select Related Items Type in the Available Columns list.
   b) Select In (←) from the Operators list.
   c) In the Values text field, type "Graphics".
   d) Click Add.

The Condition Filter is added to the table and displays in the Filter Expression field below the Add button.
3. Click OK.

4. Run the report.

The generated report displays the data for only those objects that have a graphic linked to them. In case of the above scenario, the report displays the data for Analog Output 1 and Analog Output 2 as these are the only objects that have a graphic linked with them.
10 Log Viewer

The main function of Log Viewer is to present you the historical data from activities and events for performing analysis. This chapter provides information on the Log Viewer workspace, workflow, creating and configuring a log view definition, and other activities.

10.1 Overview of Log Viewer

The Log Viewer application allows you to view the historical data related to system activities and events directly without the need to create and configure a report from the Reports application.

The information related to all the system activities and events displays in a columnar pattern in a grid. You can create a subset of this information by applying the necessary configurations such as filters, identifying the columns to display, specifying the number of records to display, and other settings such as resizing the column width, re-ordering the columns and so on.

Once configured, this information can be saved as a log view definition that can be used later. When you access the log view definition at a later date, the latest data, according to the configurations that you have applied to the definition displays.

The following table lists the default columns that display in the Log Viewer. In addition to these columns, you can add other columns from the Select Columns dialog box [➡ 322].

<table>
<thead>
<tr>
<th>Default Columns in the Log View</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date/Time</td>
</tr>
<tr>
<td>Source Description</td>
</tr>
<tr>
<td>Record Type</td>
</tr>
<tr>
<td>Source Property</td>
</tr>
<tr>
<td>Event Message Text</td>
</tr>
<tr>
<td>Event Category</td>
</tr>
<tr>
<td>Event Time</td>
</tr>
<tr>
<td>Event State</td>
</tr>
<tr>
<td>Event Cause</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Additional Columns</th>
</tr>
</thead>
<tbody>
<tr>
<td>Action Details</td>
</tr>
<tr>
<td>Action Result</td>
</tr>
<tr>
<td>Alert ID</td>
</tr>
<tr>
<td>Alias [Observer]</td>
</tr>
<tr>
<td><strong>NOTE</strong>: The values of filters applied on the Alias column are case sensitive.</td>
</tr>
<tr>
<td>Alias [Source]</td>
</tr>
<tr>
<td><strong>NOTE</strong>: The values of filters applied on the Alias column are case sensitive.</td>
</tr>
<tr>
<td>Attachment</td>
</tr>
<tr>
<td>Discipline</td>
</tr>
<tr>
<td>Event Mode</td>
</tr>
<tr>
<td>Source Designation</td>
</tr>
<tr>
<td>Source Designation [Application View]</td>
</tr>
<tr>
<td>Source Designation [Current View]</td>
</tr>
<tr>
<td>Source Designation [Management View]</td>
</tr>
</tbody>
</table>
Log Viewer is covered by a license. In order to access the Log Viewer application, you must ensure that the Log Viewer license is available in your system.

## 10.2 Log Viewer Workspace

This section gives an overview of the Log Viewer workspace:

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>System Browser</td>
<td>Displays all the saved Log View Definitions in Application View &gt; Applications &gt; Log Viewer.</td>
</tr>
<tr>
<td>2</td>
<td>Log Viewer Toolbar</td>
<td>Contains buttons for performing various actions in Log Viewer.</td>
</tr>
<tr>
<td>3</td>
<td>Log View</td>
<td>Displays the combined data from the activity log and event log.</td>
</tr>
</tbody>
</table>
| 4    | Dropdown Arrow | When clicked, displays a menu with the following options:  
  - **Hide Column** - Hides the column.  
  - **Select Column** - Displays the Select Columns dialog box.  
  - **Remove Filters** - Removes any online filters (if applied) on the column.  
  - **Custom Filter** - Displays the Custom Filter dialog box.  
  - **Selection Filter** - Applies only if the column displays ENUM data. Displays a list of data entries for the column.  
  - **Date Filters** - Applies only if the column displays date/time data. Allows you to filter data on the basis of date and time. |
10 Detailed Log Tab
[→ 328] Displays information related to system activities and events.

10.2.1 Log Viewer Toolbar

The Log Viewer toolbar allows you to perform the following operations:

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🗂️</td>
<td>New Folder [→ 345]</td>
<td>Creates a new folder below the Log Viewer root node.</td>
</tr>
<tr>
<td>![Save]</td>
<td>Save [→ 343]</td>
<td>Saves a newly created and configured log view definition or changes in the configuration of the currently selected log view definition.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>NOTE:</strong> This command is available only after you perform some operation on the displayed log view data.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This command is not available if a result filter is applied to the log view. In order to enable this button, you must move the result filter to a search filter [→ 340].</td>
</tr>
<tr>
<td>![Save]</td>
<td>Save as [→ 344]</td>
<td>Saves the configuration of the currently selected log view definition as a new log view definition.</td>
</tr>
<tr>
<td>![Save]</td>
<td>Save as Default [→ 347]</td>
<td>Saves the log view as a default template.</td>
</tr>
<tr>
<td>![Save]</td>
<td>Save as Report Definition [→ 344]</td>
<td>Saves the configuration of a log view definition such as search filters, column selection, sorting as a report definition.</td>
</tr>
<tr>
<td>![Delete]</td>
<td>Delete [→ 344]</td>
<td>Deletes the currently selected log view definition or a folder below the Log Viewer root node. Deleting the folder also removes its contents.</td>
</tr>
<tr>
<td>✓</td>
<td>Refresh [→ 345]</td>
<td>Refreshes the data displayed in a log view definition, Log Viewer root node, or a log view folder.</td>
</tr>
<tr>
<td>![Export]</td>
<td>Export [→ 345]</td>
<td>Exports the log view definition and saves it in an xml file format.</td>
</tr>
<tr>
<td>![Import]</td>
<td>Import [→ 345]</td>
<td>Imports a log view definition.</td>
</tr>
<tr>
<td>![Select]</td>
<td>Select Columns [→ 334]</td>
<td>Displays the Select Columns dialog box that allows you to select the columns to display in the log view.</td>
</tr>
<tr>
<td>✐</td>
<td>Search Filter [→ 341]</td>
<td>Displays the Search Filter dialog box that allows you to view a search filter condition and specify a filter condition on the columns that are not present in the log view.</td>
</tr>
<tr>
<td>✒️</td>
<td>Remove all Result Filters</td>
<td>Removes all the result filters applied on the log data.</td>
</tr>
<tr>
<td>✒️</td>
<td>Revert to Saved Search Filters [→ 341]</td>
<td>Returns to the previously applied search filter.</td>
</tr>
<tr>
<td>✽️</td>
<td>Stop Execution</td>
<td>Stops the execution of a log view.</td>
</tr>
<tr>
<td>✒️</td>
<td>Configuration</td>
<td>Displays the Configuration dialog box that allows you to specify the filter language for modifying a search filter. This is essential when you are accessing a log view definition that is configured in a different language.</td>
</tr>
</tbody>
</table>
10.2.2 Select Columns Dialog Box

The Select Columns dialog box allows you to add, remove, or reorder columns in a log view. You can access this dialog box using any of the following methods:

- Clicking the Select Column icon on the Log Viewer toolbar.
- Clicking the Select Column icon from the toolbar in the Detailed Log tab.
- Clicking the dropdown arrow on a column header and selecting the Select Column menu option.
- Right-clicking a column entry and selecting Select Column menu option.

Select Columns Dialog Box

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parent tab</td>
<td>Allows you to add, remove, or reorder Parent columns in the log view.</td>
</tr>
<tr>
<td>Available Columns</td>
<td>Displays all the columns associated with the log view.</td>
</tr>
<tr>
<td></td>
<td>NOTE: View specific columns such as Source Location and Source Designation are dynamically added to the Available Columns list when you create a new view.</td>
</tr>
<tr>
<td>Selected Columns</td>
<td>Displays the default columns of a log view. You can add columns to the selected columns list by selecting the check box associated with each column in the Available Columns list.</td>
</tr>
<tr>
<td>Select Default</td>
<td>Selects the default columns in the Available Columns list.</td>
</tr>
<tr>
<td>Select All</td>
<td>Selects all the columns in the Available Columns list.</td>
</tr>
<tr>
<td>Clear All</td>
<td>Clears all the columns in the Available Columns list.</td>
</tr>
<tr>
<td>Move Up</td>
<td>Moves the selected column one step up in the Selected Columns list. The Move Up button is unavailable if you select the column on the top.</td>
</tr>
<tr>
<td>Move Down</td>
<td>Moves the selected column one step down in the Selected Columns list. The Move Down button is unavailable if you select the column at bottom.</td>
</tr>
<tr>
<td>Remove</td>
<td>Removes the selected column from the Selected Columns list.</td>
</tr>
</tbody>
</table>
10.2.3 **Custom Filter**

A Custom Filter allows you to define a filter expression from which you can filter data according to your specific requirements.

**Custom Filter Condition**

A Custom filter condition is composed of:
- Column name (Condition Name)
- Operators
- Condition value

**Examples of Custom Filter Expressions**

The following list contains some valid Custom filter expressions:

- Event Category = "Life Safety"
- Event Category = {"Status"; "Life Safety"; "Supervisory"}

The Custom filter also allows you to create complex filters and conditions using mathematical and logical operators, and wildcard characters. The following operators are supported:

<table>
<thead>
<tr>
<th>Table 1: Mathematical Operators</th>
</tr>
</thead>
</table>
| **Enum Columns**                | Equal to (=), Not Equal to (<>)
| **NOTE:** For columns such as Discipline, Sub discipline, Type, and Subtype only the (=) operator is supported. |
| **Numeric Columns**             | Equal to (=), Not Equal to (<>), Less than (<), Greater than (>) |
| **Text Columns**                | Equal to (=), Not Equal to (<>), IN (←) |
| **Variant Columns**             | Equal to (=), Not Equal to (<>), Less than (<), Greater than (>) |
| **CNS Columns**                 | Equal to (=) |
| **View Specific Columns**       | Equal to (=) |
| **Object Name,**                | |
| **Object Description,**         | |
| **Object Location**             | |
| **Object Location (All Views),**| |
| **Object Designation**          | |
| **Object Designation (All Views)**| |

<table>
<thead>
<tr>
<th>Table 2: Logical Operators</th>
</tr>
</thead>
</table>
| **AND**                     | Applying the custom filter expression on multiple columns. For example, 'Discipline' = "Building Automation" AND 'Subdiscipline' = "Access Control"
| **OR**                      | Applying the custom filter expression on the same column. For example, 'Discipline' = {"Building Automation";"Energy Management"}

- **Wildcard Character:** Asterisk (*)

**List of ENUM columns**
- Subtype
- Type
- Subdiscipline
- Discipline
Custom Filter Syntax

When you are creating a custom filter, you must know the data type of the column for which you want to apply the filter. The following examples should help you create custom filters without syntax errors.

1. If column displays text data, for example string or enumeration, then the value must be enclosed within double quotes.
   - ‘Source Description’ = "Analog Output 1"
   - ‘Event Mode’ = “Normal”
   - 'Value' = "True"
   - ‘Previous Quality’ = "#COM"

2. If column displays date time value, then the value must be in date time format configured in Windows on the server machine. Date in the short date format. Time in the long time format (24 hours).
   - ‘Date/Time’ = 3/13/2014 16:04:25 (assuming that the date format on the server is M/d/yyyy)
   - ‘Value’ = 07/24/2014 11:52:00

3. If column displays Boolean data, for example. TRUE, FALSE, and so on, then the value must be enclosed in double quotes.
   - ‘Previous Value’ = "True"
   - ‘Value’ = “False”

4. If column displays numeric data, for example, 54.11, 25, -20, and so on, then the values must be specified as follows:
   - ’Value’ = 54.11
   NOTE: The decimal separator must be according to your Windows Regional and Language settings.

5. If column displays bit string, then the value must be enclosed in double quotes.
   - ‘Quality’ = “Out of service”

6. Specify time values in a 24-hour clock format. For example, to specify the Source Time as 2.00 PM, type 14.00.

Types of Custom Filters

The custom filter applied on the log data is of two types:

Result filter: The Result filter enables you to filter data from the displayed data set in the log view. You can use this filtered data for the purpose of analysis. You cannot save a result filter condition. In order to save the filter condition, you must move the result filter to a search filter and then save the configuration as a log view definition. You can apply a result filter from the Custom Filter dialog box, Quick Filter, Selection Filter, and using the drag-and-drop option. For more information, see Applying Result Filters on Columns other than Date/Time and Applying Result Filters on Date/Time Columns.

Search filter: The Search filter enables you to obtain the data matching the filter expression from the database. Any modification or addition to the search filter, refreshes the log view automatically. When you do a refresh, all the data matching the search filter is obtained from the database. To preserve the search filters, you
must save the settings as a log view definition. Using the search filter, you can filter the data for the columns that are present in the log view. For more information see, Applying Search Filters on columns other than Date/Time [335] and Applying Search Filters on Date/Time Columns [336].

You can also apply a search filter if you need to filter the data for a column that is not present in the log view [341]. The combined search filter is always available in the Search Filter dialog box.

For example, you can apply a result filter on the log data to retrieve all records with Source Description as "Analog Input 1". However, in order to save the filter condition, you must move the result filter to a search filter.

Custom Filter Dialog Box - For columns other than date/time

The Custom Filter dialog box allows you to define Result and Search filter expressions on a particular column. You can access this dialog box using any of the following methods:

- Clicking the dropdown arrow on a column heading displaying non date/time values and selecting Custom Filter.
- Right-clicking a log view entry displaying non date/time data and selecting Custom Filter.

Custom Filter Dialog Box Components

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Result Filter</td>
<td>Allows you to specify a result filter.</td>
</tr>
<tr>
<td>Search Filter</td>
<td>Allows you to specify a search filter.</td>
</tr>
<tr>
<td>Operator</td>
<td>Lists the mathematical operators. The list of operators displayed in this box depends on the column type.</td>
</tr>
<tr>
<td>Value</td>
<td>Allows you to specify values. Depending on the column type, you</td>
</tr>
<tr>
<td>Add Filter</td>
<td>Adds a new filter expression row with the <strong>Operator</strong> and <strong>Value</strong> fields to the <strong>Custom Filter</strong> dialog box.</td>
</tr>
<tr>
<td>-----------</td>
<td>----------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Remove Filter</td>
<td>Removes the filter set on the particular column.&lt;br&gt;&lt;br&gt;&lt;span class=&quot;note&quot;&gt;NOTE: In order to enable the <strong>Remove Filter</strong> button, you must select the check box preceding the <strong>Operator</strong> and <strong>Value</strong> fields corresponding to the result filter expression to be deleted.&lt;/span&gt;</td>
</tr>
<tr>
<td>AND</td>
<td>This is a logical operator that allows you to combine filter expressions and create complex filters. This button is available only when you add a new filter expression row and select the check boxes preceding the <strong>Operator</strong> drop down list in the filter expression rows.</td>
</tr>
<tr>
<td>OR</td>
<td>This is a logical operator that allows you to combine filter expressions and create complex filters. This button is available only when you add a new filter expression row and select the check boxes preceding the <strong>Operator</strong> drop-down list in the filter expression rows.</td>
</tr>
<tr>
<td>Move to Search Filter</td>
<td>Displays only when the <strong>Result Filter</strong> tab is selected. Allows you to move the result filter to a search filter.</td>
</tr>
<tr>
<td>Filter expression field</td>
<td>Displays the filter expression. In case of multiple filter expressions, the <strong>OR</strong> operator is applied by default.</td>
</tr>
</tbody>
</table>

**Time Filter Dialog Box**

This dialog box allows you to define Result and Search filter expressions on a particular date/time column. You can access this dialog box using any of the following methods:

- Clicking the dropdown arrow on a column heading displaying date/time values, positioning your cursor over **Date Filters** and then selecting **Custom Filter**.
- Right-clicking a log view entry displaying date/time data and selecting **Custom Filter**.
### Time Filter Dialog Box Components

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Result Filter</td>
<td>Allows you to specify a result filter.</td>
</tr>
<tr>
<td>Search Filter</td>
<td>Allows you to specify a search filter. <strong>NOTE:</strong> The Search Filter tab does not display when the Time Filter dialog box is accessed from the <strong>Detailed Log</strong> tab in the Contextual Pane.</td>
</tr>
<tr>
<td>Exact</td>
<td>Allows you to filter data based on the exact date specified.</td>
</tr>
<tr>
<td>Custom</td>
<td>This option allows you to set the date and time as per your requirement. Selecting the <strong>Custom</strong> option enables the From and To fields. The To date should always be greater than From date. If the To date is less than the From date, then the To field is highlighted in red color and an error message displays when you move your cursor over the field.</td>
</tr>
<tr>
<td>Relative</td>
<td>Relative has two options: Last and Current Period. The <strong>Last</strong> option allows you to filter data for the last <code>x</code> (where <code>x</code> stands for a number) period that you specified. Valid periods are hours, months, years, weeks, days, or minutes. The <strong>Current Period</strong> option allows you to filter data for the current <code>x</code> period. Valid periods are current <code>x</code> hours, months, years, weeks, days, or minutes.</td>
</tr>
</tbody>
</table>
For example, if the current date and time on your machine is 10/07/2014 10:35 AM and you specify any of the following:

- **1 Hour in the Last option** - The data for the 9:00 to 10:00 AM period is retrieved.
- **1 Hour in the Current Period option** - The data for the 10:00 to 11:00 AM period is retrieved.
- **1 Month in the Last option** - The data for the period June 01, 2014 to July 01, 2014 is retrieved.
- **1 Month in the Current Period option** - The data for the period July 01, 2014 to August 01, 2014 is retrieved.
- **1 Year in the Last option** - The data for the period January 01, 2013 to January 01, 2014 is retrieved.
- **1 Year in the Current Period option** - The data for the period January 01, 2014 to January 01, 2015 is retrieved.

**NOTE**: The Last and the Current Period fields accept only integer values up to three digits.

### Unlimited
- Default selection. Allows you to retrieve all records.

### Null
- Allows you to retrieve records with Null value.

### Move to Search Filter
- Displays only when the Result Filter tab is selected. Allows you to move the result filter to a search filter.

### Preview of Resulting Time range
- Displays the resulting time range for the options selected in the Time Filter dialog box. For example, if the present time is 08/07/2014 10:35 AM, then for the Current 1 hour selection, the Preview of Resulting Time Range displays the following:
  - From: Tuesday, July 08, 2014 10:00:00 AM
  - To: Tuesday, July 08, 2014 11:00:00 AM

## 10.2.4 Contextual Pane - Detailed Log Tab

You can view information related to system activities and events through the Detailed Log tab in the Contextual pane.

**NOTE**: The Detailed Log tab in the Contextual pane is covered by a license. In order to view the information in the Detailed Log tab, you must ensure that the Log Viewer license is available in your system.

The information displayed in the Detailed Log tab is related to the following:

- **An object selected from the System Browser** - When you select an object from the System Browser, the Detailed Log tab displays the latest 100 activities for that object. For example, if you select an Analog Input object in the System Browser, the Detailed Log tab displays the latest 100 activities for the Analog Input object.

- **An object is selected in the Primary pane from any application such as Graphics, Trends, Textual Viewer, or Reports** - If you select an object in the Primary pane from any application, the Detailed Log tab displays the latest 100 activities and event log records for the object.

- **An activity or event type record is selected from the log view** - When you select an activity type record from a log view, the latest 100 activities and event logs for the selected object display in the Detailed Log tab. However, if a record of type event is selected, the details of the selected event including the different state changes of the event and the user activities performed in context of the event are displayed in the Detailed Log tab of Event List [➙ 81], Investigative Treatment [➙ 105], and Assisted Treatment [➙ 106] windows.

- **Event handling** - When you select an event from the Event List, the details of the selected event including the different state changes of the event and the user activities performed in context of the event are available in the Detailed Log tab of Event List [➙ 81], Investigative Treatment [➙ 105], and Assisted Treatment [➙ 106] windows.

You can customize the information displayed in the Detailed Log tab by,
- Applying Result Filters on Columns other than Date/Time [→ 337]
- Applying Result Filters on Date/Time Columns [→ 339]
- Selecting columns to be displayed [→ 334]
- Hiding columns [→ 335]
- Sorting Log Entries [→ 343]
- Reordering [→ 335] and Resizing [→ 335] Columns

By default, the following information displays for activity and event type data in the **Detailed Log** tab.

<table>
<thead>
<tr>
<th>Information Type - Activity</th>
<th>Information Type - Event</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date/Time</td>
<td>Date/Time</td>
</tr>
<tr>
<td>Property</td>
<td>RecordType</td>
</tr>
<tr>
<td>LogType</td>
<td>Property</td>
</tr>
<tr>
<td>Action Details</td>
<td>Event Message</td>
</tr>
<tr>
<td>Action</td>
<td>Event Category</td>
</tr>
<tr>
<td>Value</td>
<td>Event Time</td>
</tr>
<tr>
<td>Previous Value</td>
<td>Event Cause</td>
</tr>
<tr>
<td>Quality</td>
<td>Event ID</td>
</tr>
<tr>
<td>Previous Quality</td>
<td>LogType</td>
</tr>
<tr>
<td>Unit</td>
<td>Action</td>
</tr>
<tr>
<td>Action Result</td>
<td>Value</td>
</tr>
<tr>
<td>User</td>
<td>Previous Value</td>
</tr>
<tr>
<td></td>
<td>Quality</td>
</tr>
<tr>
<td></td>
<td>Previous Quality</td>
</tr>
<tr>
<td></td>
<td>Unit</td>
</tr>
<tr>
<td></td>
<td>Action Result</td>
</tr>
<tr>
<td></td>
<td>User</td>
</tr>
</tbody>
</table>

You can also save the settings in the **Detailed Log** tab as default template [→ 347]. You can create individual customized templates for displaying activity and event information by specifying the respective columns, their order and size, and by applying sorting on the data displayed. Filters applied (if any) are not retained in the default template.
### Detailed Log Tab

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Checkmark]</td>
<td>SaveAsDefault</td>
<td>Saves the selected columns in the <strong>Detailed Log</strong> tab as a default template.</td>
</tr>
<tr>
<td>![Clock]</td>
<td>Refresh</td>
<td>Refreshes the data displayed in the <strong>Detailed Log</strong> tab.</td>
</tr>
<tr>
<td>![Stop]</td>
<td>Stop Execution</td>
<td>Stops the execution of the log view in the <strong>Detailed Log</strong> tab.</td>
</tr>
<tr>
<td>![List]</td>
<td>Select Columns</td>
<td>Displays the <strong>Select Columns</strong> dialog box that allows you to select the columns to display in the <strong>Detailed Log</strong> tab.</td>
</tr>
<tr>
<td>![TrashCan]</td>
<td>Remove all Result Filters</td>
<td>Removes all the Result filters applied to the log data in the <strong>Detailed Log</strong> tab.</td>
</tr>
</tbody>
</table>

### 10.2.5 Search Filter Dialog Box

The **Search Filter** dialog box allows you to view a search filter condition and specify a filter condition on the columns that are not present in the log view. It also allows you to view, modify, and delete a combined search filter expression. You can apply the search filter on all columns except columns of type date/time.
### Search Filter Dialog Box Components

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Available Columns</td>
<td>Lists all the available columns from the Activities and Events log.</td>
</tr>
<tr>
<td>Operators</td>
<td>Lists all the operators associated with a specific column selected in Available Columns.</td>
</tr>
<tr>
<td>Values</td>
<td>Lists all the values associated with a specific column selected in the Available Columns list. You can also select multiple values by pressing <strong>CTRL</strong> or <strong>SHIFT</strong> and selecting multiple values. <strong>NOTE:</strong> Multiple values can be typed within curly brackets {} and are separated by a semicolon (;).</td>
</tr>
<tr>
<td>Filter expression field</td>
<td>Displays the filter expression. You can edit a filter expression in this field. <strong>NOTE:</strong> An invalid filter expression displays in red.</td>
</tr>
<tr>
<td>Add/Update</td>
<td>Allows you to add or update a filter expression. <strong>Update</strong> is enabled only when a valid filter expression is added or modified in the <strong>Filter expression</strong> field.</td>
</tr>
<tr>
<td>And</td>
<td>This is a logical operator that allows you to combine filter expressions and create complex filters. This button is unavailable until a filter expression is added to the <strong>Filter expression</strong> field.</td>
</tr>
<tr>
<td>&quot;( ) &quot;</td>
<td>Allows you to group filter conditions, which define the order of their evaluation. These brackets are unavailable until a filter expression is added to the <strong>Filter expression</strong> field.</td>
</tr>
</tbody>
</table>

1) The selected item displays below the list.
10.3 Log Viewer Workflow

This section describes the procedures for performing the following activities:

- Accessing Log Viewer
- Viewing Log Data

10.3.1 Accessing Log Viewer from System Browser

1. In System Browser, select Application View.
2. Select Applications > Log Viewer.

Log Viewer displays in the Primary pane with the combined data from the activity log and event log.

10.3.2 Viewing Log Data

You can view log data using any of the following procedures:

- Selecting the Log Viewer root node or a folder below it from System Browser - This displays the combined data from the activity and event logs.
- Selecting a saved log view definition from System Browser - This displays the data, applying all the configurations you set up in the selected log view definition.
- Selecting an object from System Browser - This displays the activity and event log records pertaining to the selected object in the Detailed Log tab in the Contextual pane.
- Selecting an object in the Primary pane from any application such as Graphics, Trends, Textual Viewer, or Reports - This displays the latest 100 activity and event log records pertaining to that object in the Detailed Log tab.
- Selecting an activity type or event type record in the log view - When you select an activity type record from a log view, the latest 100 activities and event logs for the selected object display in the Detailed Log tab. However, if a record of type event is selected, the details of the selected event including the different state changes of the event and the user activities performed in context of the event are displayed in the Detailed Log tab.
- Selecting an event from Event List - Displays information about the object involved in the event in the Detailed Log tab.

TIPS:

When you select the Log Viewer root node, a log view folder, or a saved log view definition from System Browser, you may see the following message above the log view table "Configured View Size reached! Refine search via Search Filter". This means that there are more records in the database than can be displayed in the defined view size. In order to view such records you must either specify filters or modify existing filters (if present).
10.4 Working with Log Viewer

This section describes the activities you can perform using the Log Viewer.

10.4.1 Creating a Log View Definition

1. In System Browser, select Application View.
2. Select Applications > Log Viewer.
   - Log Viewer displays in the Primary pane with the combined data from the activity log and event log.
3. Perform the required configuration (§ 333) such as selecting columns, applying filters, sorting data, resizing column width and so on.
4. Save (§ 343) the log view definition.
   - The log view definition is saved and displays in the System Browser.
   NOTE: If you try to exit the configuration without saving the changes, the unsaved data message box displays.

10.4.2 Configuring a Log View Definition

You can configure a log view definition by:
- Defining the log view size (§ 334)
- Selecting Columns to be displayed (§ 334)
- Hiding Columns (§ 335)
- Re-ordering Columns (§ 335)
- Resizing Columns (§ 335)
- Removing Columns (§ 335)
- Applying Search Filters on columns other than Date/Time (§ 335)
- Applying Search Filters on Date/Time Columns (§ 336)
- Modifying Search/Result Filters on Columns other than Date/Time (§ 336)
- Modifying Search/Result Filters on Date/Time Columns (§ 337)
- Deleting Search Filters on Columns other than Date/Time (§ 337)
- Deleting Search Filters on Date/Time Columns (§ 337)
- Applying Result Filters on Columns other than Date/Time (§ 337)
- Applying Result Filters on Date/Time Columns (§ 339)
- Deleting Result Filters (§ 340)
- Moving Result Filters to Search Filters (§ 340)
- Reverting to Saved Search Filters (§ 341)
- Applying Search Filters on Columns Not Present in the Log View (§ 341)
- Modifying Search Filters on Columns Not Present in the Log View (§ 342)
- Deleting Search Filters on Columns Not Present in the Log View (§ 342)
- Sorting Log Entries (§ 343)
10.4.2.1 Defining the Log View Size

You can define a size for the log view to display a specific number of records.

1. In System Browser, select Application View.
2. Select Applications and click the Log Viewer root node.
   ➔ Log Viewer displays the data in the Primary pane.
3. Navigate to the Contextual pane and click the Extended Operation tab.
   ➔ The number of records in the log view displays in View Size. By default, this value is set to 1000.
4. Specify a size for the log view by entering the value in the Value field. The value must be less than or equal to 250,000 which is the maximum number of records that can be displayed in the Log Viewer.
5. Click the Set button next to the Value field.
6. Click Refresh on the Log Viewer toolbar.
   ➔ The log view refreshes to display the latest number of records as per the specified value.
   NOTE: A larger view size is not recommended as it slows down the process of retrieving the records. In order to view and print a large amount of data, you must export the log view definition [➔ 345] to Reports.

10.4.2.2 Selecting Columns

1. Click Select Columns [➔ 322] from the Log Viewer toolbar (if you are selecting columns for log data displayed in the Primary pane) or from the toolbar in the Detailed Log tab (if you are selecting columns for log data displayed in the Detailed Log tab).
   ➔ The Select Columns [➔ 322] dialog box displays. In the Available Columns list, the default columns are selected. These columns also display in the Selected Columns list of the dialog box. These columns represent the columns of the log view definition.
2. In the Available Columns list, select the check box preceding the column names you want displayed in the log view definition. If you do not want to display a column name in the log view definition, clear the checkbox preceding the column name.
   ➔ The Selected Columns list box is updated to reflect these changes.
3. Click OK.
   ➔ The log view definition is updated with the changes.
   NOTE: For each view present in the system, you can add the view specific columns (Object Location and Object Designation) to a log view from the Select Columns dialog box. If you are running the log view definition from the Secondary pane and activities such as renaming a view are done in the Primary pane, the effect of these changes reflect in the log view definition only after you click Refresh in the Log Viewer toolbar.
10.4.2.3 **Hiding Columns**

Perform any of the following steps to hide columns:

- Right-click the column that you want to hide, and select **Hide Column**.
- Click the dropdown arrow on a column header of the column that you want to hide and select **Hide Column**.

10.4.2.4 **Reordering Columns**

1. Click **Select Columns** from the Log Viewer toolbar (if you are reordering columns in the Primary pane) or from the toolbar in the Detailed Log tab (if you are reordering the columns in the Detailed Log tab).
   - The **Select Columns** dialog box displays.
2. In the **Selected Columns** list, select the column whose position should be changed and click **Move Up** or **Move Down**.
3. Click **OK**.
   - The columns displayed in the log view are re-ordered.

**NOTE:** You can manually reorder a column displayed in the grid by selecting the column and dragging and dropping it to a new location in the grid.

10.4.2.5 **Removing Columns**

- You have selected the Log Viewer root folder, or a log view folder, or a log view definition and the log data displays in the Primary pane.

1. In the Log Viewer toolbar, click **Select Columns**.
   - The **Select Columns** dialog box displays.
2. In the **Selected Columns** list, select the column to be removed and click **Remove**.
3. Click **OK**.
   - The log view refreshes automatically and the column is removed.

10.4.2.6 **Resizing Columns**

- In the log viewer grid, drag the column separator next to the column to be resized.

   - The column is resized.
   - You cannot reduce the width of a column below its minimum width.

10.4.2.7 **Applying Search Filters on Columns other than Date/Time**

- You have selected the Log Viewer root folder, or a log view folder, or a log view definition and the log data displays in the Primary pane.

1. Right-click the data value for which you want to apply the filter.
2. From the menu options, select **Custom Filter**.
   - The **Custom Filter Dialog Box** displays.
3. Click the **Search Filter** tab.
4. Click the **Add Filter** button.
   - An empty row with the **Operator** and **Value** fields displays.
5. Specify the operator by selecting a value from the **Operator** drop down list. In order to specify the value, you must either select a value from the Value drop down list or type a value in the field. This depends on the type of column on which you want to apply the filter.
   - The filter expression displays in the **Filter Expression** field.
6. Click **OK**.
   - The data matching your filter condition is retrieved from the server.

### 10.4.2.8 Applying Search Filters on Date/Time Columns

- You have selected the Log Viewer root folder, or a log view folder, or a log view definition and the log data displays in the **Primary** pane.

1. Position your cursor over a column with date-time data, such as Date/Time.
2. Right-click and then select **Custom Filter**.
   - The **Time Filter** dialog box displays.
3. Click the **Search Filter** tab.
4. Specify the appropriate date/time values in the **Exact**, **Custom**, or **Relative** options.
   - **NOTE**: By default, the **Unlimited** option is selected in the **Time Filter** dialog box.
   - If you want to view records having NULL as the value, select the **Null** option.
   - A preview of the date/time values you specified displays in the **Preview of Resulting Time Range** section.
5. Click **OK**.
6. The log view refreshes automatically and the data corresponding to the specified date time values displays.

### 10.4.2.9 Modifying Search/Result Filters on Columns other than Date/Time

- You have applied a search/result filter to the log data.

1. Right-click the data value in the column pertaining to the filter to be modified and select **Custom Filter**.
   - The **Custom Filter** dialog box displays.
2. Click the **Search Filter** or **Result Filter** tab depending on the filter that you want to modify.
3. Modify the filter condition.
4. Click **OK**.
   - The view refreshes and the data matching the modified filter displays.
10.4.2.10 Modifying Search/Result Filters on Date/Time Columns

You have applied a search/result filter to a column displaying date time data.

1. Right-click the data value in the column pertaining to the filter to be modified and select **Custom Filter**.
   - The **Time Filter** dialog box displays.
2. Click the **Search** or **Result Filter** tab depending on the filter that you want to modify.
3. Modify the filter condition.
4. Click **OK**.
   - The view refreshes and the data matching the modified filter displays.

10.4.2.11 Deleting Search Filters on Columns other than Date/Time

You have applied a search filter to the log data.

1. Right-click the data value in the column pertaining to the search filter to be deleted.
2. From the menu options, select **Custom Filter**.
   - The **Custom Filter** dialog box displays.
3. Click the **Search Filter** tab.
4. Select the check box preceding the **Operator** and **Value** fields corresponding to the search filter expression to be deleted.
5. Click **Remove Filter**.
6. Click **OK**.
   - The log view refreshes and displays all the data from the database.

10.4.2.12 Deleting Search Filters on Date/Time Columns

You have applied a search filter to a column displaying date time data.

1. Right-click the data value in the column pertaining to the filter to be modified.
2. From the menu options, select **Custom Filter**.
   - The **Time Filter** dialog box displays.
3. Click the **Search Filter** tab.
4. Select the **Unlimited** option.
5. Click **OK**.
   - The view refreshes and displays all the data from the database.

10.4.2.13 Applying Result Filters on Columns other than Date/Time

You can apply a result filter on the data set displayed in a log view using any of the following techniques:

- Custom Filter
- Quick Filter
Selection Filter

When you apply a Result Filter on a column, a filter icon displays in the column header indicating that a filter is applied on the column.

Custom Filter

1. Right-click the data value for which you want to apply the filter.
2. From the menu options, select Custom Filter.
   - The Custom Filter Dialog Box displays.
3. Click the Result Filter tab.
4. Click the Add Filter button.
   - An empty row with the Operator and Value fields displays.
5. Specify the operator by selecting a value from the Operator drop down list. In order to specify the value, you must either select a value from the Value drop down list or type a value in the field. This depends on the type of column on which you want to apply the filter.
   - The filter expression displays in the Filter Expression field.
6. Click OK.
   - The result filter is applied to the data set.

Quick Filter

To apply a quick filter, do the following:

- Right-click the data value for which you want to apply the filter and select the Filter By option. For example, if you want to view the data with Log Type as UserActivity, right-click on the UserActivity entry and then select Filter By UserActivity.
  - NOTE: The last three filters applied on a column are listed as menu options that display when you right-click on a data value. You can also apply a quick filter by selecting any of these options.

Selection Filter

The Selection filter is applicable for filtering ENUM type of data. See List of ENUM columns section in Custom Filter [323] for a list of columns of type ENUM.
Perform the following steps to apply the Selection filter:
1. Click the inverted arrow on any column displaying ENUM data, for example, Action Result. The list of data entries for the column display as menu items.
2. Select the checkbox pertaining to the entry on which you want to apply the filter, for example, Succeeded.
   - NOTE: For faster retrieval of the data entries, you can type the value of the entry to be retrieved in the text box above the Selection filter. This is helpful if the list of data entries is long.
3. Click OK. The view displays the data filtered on the basis of the selected entry.
   - NOTE: If you select more than one data entry (for example, Succeeded and Failed), the system displays the data matching either of the selected entries.

Drag-and-Drop

You can also apply the result filter on the data displayed in the Primary pane by using the drag-and-drop function. However, this function is not applicable when you are applying the result filter on the data displayed in the Detailed Log tab in the Contextual pane.
- From the System Browser, drag-and-drop an object that you want to set as a condition filter to a log view. You can also drag-and-drop multiple objects from...
the System Browser. For this, ensure that the Manual navigation option in the System Browser is checked. The log view displays the entries corresponding to the object. In case of multiple selection, the data matching either of the selected objects displays.

Tips:
If you apply a result filter on a column with an existing result filter, the new filter condition replaces the older condition.

10.4.2.14 Applying Result Filters on Date/Time Columns

You can apply a result filter on the columns displaying date/time data using any of the following techniques:

- Custom Filter
- Date Filters
- Quick Filter

Custom Filter
1. Position your cursor over a column with date-time data, such as Date/Time.
2. Right-click and then select Custom Filter.
   - The Time Filter dialog box displays.
3. Click the Result Filter tab.
4. Specify the appropriate date/time values in the Exact, Custom, or Relative options.
   - NOTE: By default, the Unlimited option is selected in the Time Filter dialog box. If you want to view records having NULL as the value, select the Null option.
   - A preview of the date/time values you specified displays in the Preview of Resulting Time Range section.
5. Click OK.
   - The log view refreshes automatically and the data corresponding to the specified date/time values displays.
   - NOTE: If you specify a date in the Exact option, the data corresponding only to the specified date displays.

Date Filters
Using the Date Filters option, you can retrieve data for the current day, previous day, current week, previous week, current month, previous month, current year, or previous year. Perform the following steps to retrieve the data for the required time period.

1) Click the dropdown arrow on any column displaying date/time data, for example, Date/Time. A list of menu options display.
2) Position your mouse pointer over the Date Filters menu option. A list of options to filter the data on the basis of the current day (Today), previous day (Yesterday), current week (This Week), previous week (Last Week), current month (This Month), previous month (Last Month), current year (This Year), or previous year (Last Year) displays.
3) Select the required option. The view refreshes and displays the data according to the selected time option.
Quick Filter
Perform the following step to apply a quick filter:
- Right-click the data entry corresponding to the date time value for which you want to apply the filter and select the **Filter By**. The log view refreshes and displays the entries corresponding to the selected date.

**NOTE:** The last three filters applied on a column are listed as menu options that display when you right-click on a data value. You can also apply a quick filter by selecting any of these options.

10.4.2.15 Deleting Result Filters
You can delete a result filter for a column displaying date/time or non date/time values using any of the following options:
- Clicking the **Remove All Result Filters** button on the **Log Viewer** toolbar.
- Clicking the drop-down arrow on the column header with a result filter applied and clicking **Remove Result Filter**.
- Right-clicking the column entry on which the filter is applied, and selecting **Remove Result Filter** from the menu options.
- Removing the selection on the checkbox pertaining to the entry on which the filter is applied and clicking **OK**.
- **For columns displaying values other than date/time** - Clicking the **Remove Filter** button from the **Custom Filter** dialog box.

**NOTE:** In order to enable the **Remove Filter** button, you must select the check box preceding the **Operator** and **Value** fields corresponding to the result filter expression you want to delete.

10.4.2.16 Moving Result Filters to Search Filters
A search filter obtains the data matching your filter expression from the database, whereas a result filter filters the data matching the filter expression from the data displayed in the log view.

For example, assume you apply a result filter on the data displayed in the log view to retrieve all records with Action as “Primary Authentication”. The records with Action as Primary Authentication display. However, there are more records with Action as Primary Authentication in the database than what displays in the log view. This is indicated by the following message **Configured View Size reached! Refine search via Search Filter.** In this case, you must move your result filter to a search filter to obtain all the matching data from the database.

**Moving Result Filters to Search Filters**
- You have applied a result filter on the data displayed in the log view.
- Perform any of the following steps to move the result filter to a search filter.
  a) Click **Refresh** on the **Log Viewer** toolbar.
  b) Click the **Move to Search Filter** button in the **Custom Filter** dialog box for the column on which the result filter is applied and click **OK**.

**NOTE:** When you move a result filter on a column to a search filter, any existing search filter present on the same column is replaced.
10.4.2.17 Reverting to Saved Search Filters

The Revert to Saved Search Filter function enables you to obtain the data provided by a previously defined search filter that is now being overwritten by a newly applied filter. For example, assume you apply a result filter on the log view to display all records of type Activity. The filter is moved to a Search filter in order to save it. You have now applied a new result filter to obtain data having Source Description as Users and have moved this to a search filter. So, the existing search filter is now replaced with the following new filter (‘Record Type’ = "Activity" AND ‘Source Description’ = "USERS") However, you want to retrieve the previously saved search filter (‘Record Type’ = "Activity").

The log data displays in the Primary pane.

1. Apply a result filter on any column. For example, Record Type = Activity.
   - The applied filter displays in the Filters area below the log view and the log view refreshes to display all records with Record Type as Activity.

2. Move the result filter to a search filter [340] in order to save the filter condition.
   - The result filter is moved to a search filter and displays in the Filters area.
   - Save is enabled in the Log Viewer toolbar.

3. Save the information as a log view definition [343].
   - The saved log view definition is reloaded and the data matching the filter expression displays in the Primary pane.

4. Apply a new result filter on any column. For example, Source Description is = Users.
   - The applied filter displays in the Filters area below the log view and the log view refreshes to display all records with Source Description as Users.

5. Move the result filter to a search filter.
   - The search filter is now modified and displays as follows in the Filters area.
     ('Record Type' = "Activity" AND 'Source Description' = "USERS"). Revert to Saved Search Filters is now activated.

6. Click Revert to Saved Search Filters on the Log Viewer toolbar.
   - The view refreshes and displays the data according to the previously defined search filter (‘Record Type’ = "Activity"). The filter condition is also updated in the Filters area.

10.4.2.18 Applying Search Filters on Columns Not Present in the Log View

You have selected the Log Viewer root folder, or a log view folder, or a log view definition and the log data displays in the Primary pane.

1. In the Log Viewer toolbar, click Search Filter.
   - The Search Filter dialog box displays.

2. Select a column from the Available Columns list.
   - The operators and values associated with the selected column display in the Operators and Values list.
3. Select the required operator and value from the respective lists. If values are not displayed for the selected column, type in the value. To apply parentheses, select a filter expression and click ( ). The parentheses are applied at the start and end of the filter expression.

4. Click **Add**.
   - The filter expression displays in the **Filter Expression** field.

5. Click **OK**.
   - The log view refreshes and the data that matches the search filter expression displays.

### 10.4.2.19 Modifying Search Filters on Columns Not Present in the Log View

- You have applied a search filter to a log view definition.

1. In the Log Viewer toolbar, click **Search Filter**.
   - The **Search Filter** dialog box displays with the filter expression in the **Filter Expression** field.

2. Click the filter expression.
   - The column, operator, and value of the condition filter expression display in their respective lists.

3. Modify the search filter expression as required.

4. Click **Update**.
   - The updated filter expression displays in the **Filter Expression** field.

5. Click **OK**.
   - The log view refreshes displaying the updated data according to the modified filter expression.

   **NOTE**: If you want to modify the search filter in a log view definition that is configured in a different language from your logged in language, then you must change the filter language in the **Configuration** dialog box. This dialog box is accessed by clicking the **Configuration** icon in the Log Viewer toolbar. For example, if you have logged in as a German user and you want to modify the search filter in a log view definition that is configured in English, you must change the filter language to German.

### 10.4.2.20 Deleting Search Filters on Columns Not Present in the Log View

- You have applied a condition filter to a log view definition.

1. In the Log Viewer toolbar, click **Search Filter**.
   - The **Search Filter** dialog box displays.

2. Delete the search filter expression from the **Filter Expression** field.

3. Click **OK**.
   - The log view refreshes displaying the latest data.
10.4.2.21 Sorting Log Entries

- Perform any of the following steps to sort the data. By default, the displayed data is sorted on the basis of the latest date and time.
  - To sort a column data in the ascending order, click the column header.
  - To change the sort order to descending, click the column header twice.
  - To sort the column data for multiple columns, click the column header of the first column, press CTRL and then click the column headers of subsequent columns.

The data displays in the sorted order and a priority is assigned in case the sorting is applied to more than one columns.

TIPS:
- When you save the data as a log view definition, the sort criteria is also saved. The next time when you load the log view definition, the data with the saved sort criteria displays.
- You can change the sorting order of a column by pressing CTRL and clicking the column header.
- To remove the sorting order and priority of a column, select a column on which sorting is not applied.
- If you hide a column having a sort priority, then the priority of other sorted columns changes. Additionally, the data in the log view is re-ordered based on the new priority. Re-selecting the hidden column from the Select Columns dialog box does not retain its sort order and priority.

10.4.3 Saving a Log View Definition

You have created and configured a log view definition.

1. In the Log Viewer toolbar, click Save.

   NOTE: You cannot save a result filter condition. In order to save the filter condition, you must move the result filter to a search filter and then save the configuration as a log view definition.

   The SaveObjectAs dialog box displays.

2. In the view structure that displays, select the destination folder in which you want to save the log view definition. The destination folder can be the main Log Viewer folder or it can be a sub-folder below the main Log Viewer folder.

3. Type a name for the Log View Definition in the Name field.

4. Enter a description in the Description field. By default, when you click the Description field, the same text in the Name field displays. You can optionally modify this text.

   NOTE: Click Flag to display a field for each language available in the system; modify the text for each language.

5. Click OK to confirm (or Cancel to abort).

   If confirmed the Log View definition is saved and displays in the System Browser tree in the selected destination folder.

   NOTE: If you have applied any filters to the log view definition the filter is also saved.
10.4.4 Creating a New Log View Definition from an Existing One

You have made modifications to an existing log view definition and want to save it as a new one.

1. In the Log Viewer toolbar click **SaveAs**.
   - The **SaveObjectAs** dialog box displays.

2. Follow Steps 2 through 5 in Saving a Log View Definition [→ 343].
   
   **NOTE:** You cannot save a result filter condition. In order to save the filter condition, you must move the result filter to a search filter [→ 340] and then save the configuration as a log view definition.

10.4.5 Saving Log View Definition as a Report Definition

You have selected the log viewer node or a log view definition and the log data displays in the Primary pane.

1. *(Optional)* Perform any required configurations such as applying search filters, selecting columns, and applying sorting.

2. In the Log Viewer toolbar, click **Save as Report Definition**.
   - The **SaveObjectAs** dialog box displays with the expanded tree view of Reports.

3. Select the Reports folder where you want to save the definition and enter a name and description.

4. Click OK.
   - A report definition is created and displays in the Primary pane. This report definition contains the All Logs table. All configurations applied on the log view definition such as selected columns, order of columns, sorting on columns (if applied), search filters (if applied) are present in the All Logs table in the report definition.

5. Run the report.
   - On successful execution, the report displays the log data.

10.4.6 Deleting a Log View Definition

At least one log view definition is available in System Browser > Log Viewer.

1. In System Browser, select Application View.

2. Select Applications and expand the root Log Viewer node.

3. Select the log view definition from the Log Viewer root node or from a log view folder below it.

4. In the Log Viewer toolbar, click **Delete**.
   - A confirmation message displays.

5. Click OK to confirm.
   - If confirmed the selected log view definition is deleted from the System Browser.
10.4.7 Exporting a Log View Definition

1. In System Browser, select Application View.
2. Select Applications and expand the Log Viewer root node.
3. Select the log view definitions to be exported from the Log Viewer root node or select the folder with the log view definitions.
4. In the Log Viewer toolbar, click Export. The Browse for Folder dialog box displays.
5. Browse for the desired location and click OK.

On successful export a confirmation message displays. The log view definition(s) is exported and saved in an xml format. Sorting (if applied) on any of the column(s) in the log view definition is also retained.

NOTE: The export will fail if you do not have the write permissions for the selected location.

10.4.8 Importing a Log View Definition

1. From the System Browser, select the location where you want to import the log view definition. This could be the Log Viewer root node or a folder below it (if present).
2. In the Log Viewer toolbar, click Import. The File Open dialog box displays.
3. Browse to the folder where the exported log view definitions are available. Select the xml file to be imported and click Open.

A success message displays on import of the xml file and the log view definition is successfully added to the selected location.

10.4.9 Refreshing a Log View

You can refresh the data in a log view to reflect the most current data.

- Perform any one of the following steps to manually refresh the data:
  - In the Log Viewer toolbar, click Refresh. Any result filter (if applied) on the log view is moved to the search filter.
  - Press F5 on the keyboard.

The system displays the updated data as per the configurations applied to the log view definition. The maximum number of records that are displayed after refresh in the Log Viewer depends on the configured view size [334].

NOTE: Any addition or update in the view or text group is reflected in the log viewer on the next refresh.

10.4.10 Managing Log View Folders

Creating Log View folders enable you to properly organize log view definitions.

1. Select Application View > Applications.
2. Select the Log Viewer root node or a log viewer folder below the Log Viewer root node (if present) in the System Browser.

Log Viewer displays in the Primary pane.
3. In the Log Viewer toolbar, click **New Folder**.  
   ➤ The **Create New Object** dialog box displays with the child type set as Log View Folder.

4. Enter the folder **Name** and **Description**. Provide a unique folder name, otherwise a message box displays asking you to provide a unique name. A description is mandatory.  
   a) Click **Flag** to display and modify the text for all languages configured in the system  
   b) Click **OK** to confirm or **Cancel** to abort.  
   ➤ If confirmed a new Log Viewer folder is created and saved and displays in the System Browser.

**NOTE 1:**  
To delete a Log Viewer folder, expand the Log Viewer root node. Select the folder you want to delete, and then click **Delete** in the Log Viewer toolbar.

Deleting a folder also deletes its contents.

---

10.4.11 Viewing Object Properties and Hierarchy

You can view the properties as well as the hierarchy of an object associated with a log view entry using the following steps:

1. In **System Browser**, select **Application View**.

2. Select **Applications** and expand the **Log Viewer** root node.

3. Select either the **Log Viewer** root node, **log view** folder below it, or a **log view definition** (if present).  
   ➤ Log Viewer displays the data in the **Primary** pane according to your selection.

4. Select a log view entry to view the properties of the object associated with it or double-click the entry to view its object hierarchy. You can also view the properties of multiple objects of the same type, For example, Analog Output 1 and Analog Output 2 by pressing **CTRL** or **SHIFT** and selecting the objects.  
   ➤ When you select the log view entry, the properties of the object associated with the selected entry displays in the **Operation** and **Extended Operation** tabs in the **Contextual** pane. In case you select multiple objects, the property values of the selected objects display when you select the property name in the **Operation** and **Extended Operation** tabs. When double-clicking the log view entry, the complete hierarchy of the object associated with the entry displays in the System Browser.
10.4.12 Creating a Default Log View Template

A default log view template enables you to create a customized template with a specific set of columns, their position, and size. The template also contains sorting applied to the column data. Any new log view definition is always based on the default template.

1. Configure the log view by selecting [334], reordering [335], or resizing the columns. You can also apply sorting [343] on the displayed data.

2. Click Save as Default from the Log Viewer toolbar (if you are working with the columns displayed in the Primary pane) or from the toolbar in the Detailed Log tab (if you are working with the columns displayed in the Detailed Log tab).
   - A message box displays informing you that the existing log view template is replaced and filters are not retained in the template.

3. Click Yes to confirm.
   - The log view is saved as a default template.

TIPS:
- There can only be one default template. You can create a new template or use the one provided by the system. When you create a new template, the existing default template is overwritten.
- View specific columns (if present) in the log view template display in red color, if the view is deleted. You can get the details of the invalid columns by double-clicking the header text. The information displays in the Log View Validation message box.
- If a saved log view definition contains view specific columns from a deleted view, the Log View Validation message box displays with details of the invalid columns when selecting the log view definition.
11 Macros

Macros are predefined lists of instructions that enable you to send out a sequence of commands to specified devices with a single action. Some macros can be started manually by the operator, while others may be run automatically by the system as part of preconfigured schedules (for time-based functions) or automatic reactions.

Macros are also used to issue multiple command actions. The system includes some predefined macros that are automatically created at configuration time and appear in a list visible to high security level users. The exact number of these macros is configuration-dependent. System macros are stored in dedicated subfolders and used to perform certain control actions, such as sending block commands to fire control panels, or activate system backup functions.

This section describes how work with Desigo CC Macros.

11.1 Macros Workspace

The macros that you can run manually are available in the Application View of System Browser under the Macros folder. The individual macro nodes may be organize into sub-folders to help you quickly select and execute the desired one.

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Macro selection</td>
<td>Location of macros/macro folders under the Logics folder in the Application View of System Browser.</td>
</tr>
<tr>
<td>2</td>
<td>Textual Viewer information</td>
<td>When a macro is selected in System Browser, information about it displays in the Textual Viewer in the Primary pane on the right-hand side of the screen.</td>
</tr>
<tr>
<td>3</td>
<td>Macro properties and control commands</td>
<td>Macro command buttons, properties, and states display in the Operation tab of the Contextual pane.</td>
</tr>
</tbody>
</table>
11.1.1 Macro Properties and Control Commands

The Operation tab in the Contextual pane provides status information and commands about the macro selected in System Browser. Macro control commands are available as buttons on the right-hand side of the Operation tab.

Macro Control Commands in the Contextual Pane

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operational Status</td>
<td>Indicates whether the macro is enabled (meaning it is available to be run by the user) or not:</td>
</tr>
<tr>
<td></td>
<td>- Enabled: the macro is currently active, and the Disable button is available.</td>
</tr>
<tr>
<td></td>
<td>- Disabled: the macro is currently inactive, and the Enable button is available.</td>
</tr>
<tr>
<td>Activity Status</td>
<td>Indicates whether the macro is currently running, aborting, or not running:</td>
</tr>
<tr>
<td></td>
<td>- Executing (the macro is running)</td>
</tr>
<tr>
<td></td>
<td>- Idle (the macro is not running)</td>
</tr>
<tr>
<td></td>
<td>- Aborting (the macro is in the process of stopping)</td>
</tr>
<tr>
<td>Last Execution Status</td>
<td>Indicates the outcome the last time the macro was run:</td>
</tr>
<tr>
<td></td>
<td>- Never Executed (the macro has not previously been run)</td>
</tr>
<tr>
<td></td>
<td>- Succeeded (the previous execution of the macro ended successfully)</td>
</tr>
<tr>
<td></td>
<td>- Aborted by user</td>
</tr>
<tr>
<td></td>
<td>- Failed</td>
</tr>
<tr>
<td></td>
<td>- Partially failed</td>
</tr>
<tr>
<td>Last Execution User</td>
<td>Name of the user who last executed the macro.</td>
</tr>
<tr>
<td>Last Execution Time</td>
<td>Date and time when the macro was last executed.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disable</td>
<td>Makes the macro no longer available for execution.</td>
</tr>
<tr>
<td>Enable</td>
<td>Makes the macro available for execution.</td>
</tr>
<tr>
<td>Abort</td>
<td>Stops the macro (if it is running and executing a time-delayed instruction within the macro).</td>
</tr>
<tr>
<td>Execute</td>
<td>Runs the macro.</td>
</tr>
</tbody>
</table>
11.2 Working with Macros

To manually control a macro, search for the macro you want to work on (see Macros Workspace [➙ 348]), and then use one of the following workflows:

- Enable [➙ 351] or disable [➙ 351] the macro.
- Execute [➙ 352] the macro or abort [➙ 352] one that is already running.

System Macros

The system has some predefined special-purpose macros, which are located in dedicated subfolders. The exact number of system macros is configuration-dependent. System macros include:

- **Backups folder** (always present): These are macros that create backup copies of the system data. You can use them in conjunction with scheduled tasks to make backups of both history and online databases at pre-planned intervals.

- **Block Commands Macros folder**: These are macros for broadcasting fire alarm handling commands (such as acknowledge, reset, and silence/unsilence) to multiple devices at the same time. Each block command macro is associated with a specific fire network (meaning the command(s) in the macro will be sent to all the devices on that network), and the system creates it when you enable block commands for the network. In case of multiple networks, the same list may also include global multi-network macros that broadcast the same command to all the devices on more than one network.

**CAUTION**

Do not disable any of the system macros, as this will prevent the system from properly executing the associated functions.
### 11.2.1 Enabling a Macro

If a macro is not enabled by configuration, you need to enable it first before you can run it. The enabled status applies to all users of the system, so that enabling a macro means that all authorized users will be able to execute it.

To enable a macro proceed as follows:

- You are authorized to issue standard commands on the relevant project scope.
- The macro is currently inactive (its status in the Contextual pane is *Disabled*), and you want to enable it.

1. In System Browser, select **Application View**.
2. Select **Applications > Logics > Macros**.
3. In the main **Macros** folder, or in a subfolder under it, select the macro you want to enable.
4. To enable the macro, in the **Operation** tab [349] of the Contextual pane, click **Enable**.
   - The status of the current macro changes to **Enabled**.

### 11.2.2 Disabling a Macro

Disabling a macro prevents it from being executed by any operators or stations, while still retaining the macro within the system. For example, you might do this for macros that are not yet complete or ready to be put into general use.

**NOTE:**

When you disable a macro, the management system generates an event. This event is automatically cleared when you re-enable the macro.

To disable a macro, proceed as follows:

- You are authorized to issue standard commands on the relevant project scope.
- The macro is currently active (its status in the Contextual pane is *Enabled*), and you want to disable it.

1. In System Browser, select **Application View**.
2. Select **Applications > Logics > Macros**.
3. In the main **Macros** folder, or in a subfolder under it, select the macro you want to disable.
4. To disable the macro, in the **Operation** tab [349] of the Contextual pane, click **Disable**.
   - The status of the current macro changes to **Disabled**.
11.2.3 Executing a Macro

- You are authorized to issue standard commands on the relevant project scope.
- The macro you intend to run is currently enabled.

1. In System Browser, select Application View.
2. Select Applications > Logics > Macros.
3. Expand the Macros node. Locate and select the macro you want to execute.
   - The macro control commands [➙ 349] display in the Contextual pane.
4. In the Operation tab, click Execute.
   - The macro starts executing.

11.2.4 Aborting a Macro

- You are authorized to issue standard commands on the relevant project scope.
- A macro is running and performing a time-delay instruction (waiting phase).

1. In System Browser, select Application View.
2. Select Applications > Logics > Macros.
3. Expand the Macros node. Locate and select the macro you want to abort.
   - The macro control commands [➙ 349] display in the Contextual pane.
4. In the Operation tab, click Abort.
   - The macro stops executing.

NOTE:
Macros can be aborted before their normal termination only during the waiting phases corresponding to time-delay instructions.
Reactions
Reactions are automations programmed into the system, so that when a specific situation occurs on site, a command or series of commands --called a *macro*-- are automatically executed.

This section describes how to work with reactions.

12.1 Reactions Workspace
The reactions configured in the system are available in the Application View of System Browser, under the Reactions folder. The reaction nodes may be further organized into subfolders to help you find them. You can select a reaction to view its status information and enable/disable it.

![Reaction Selection and Information](image)

**Reaction Selection and Information**

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Reaction selection</td>
<td>Location of reactions/reaction folders under the Logics folder in the Application View of System Browser.</td>
</tr>
<tr>
<td>2</td>
<td>Textual Viewer information</td>
<td>When you select a reaction in System Browser, information about it displays in Textual Viewer in the Primary pane.</td>
</tr>
<tr>
<td>3</td>
<td>Reaction properties and control commands</td>
<td>The properties and status of the selected reaction, and buttons to enable or disable it, display in the Operation tab in the Contextual pane.</td>
</tr>
</tbody>
</table>
12.1.1 Reaction Properties and Control Commands

The Operation tab in the Contextual pane provides status information about the reaction selected in System Browser, and commands for enabling or disabling it.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operational Status</td>
<td>Indicates whether the reaction is enabled or disabled, and the reason why if it is disabled:</td>
</tr>
<tr>
<td></td>
<td>- Enabled: The reaction is currently active, and the Disable button is available in all Activity Status conditions, except Executing.</td>
</tr>
<tr>
<td></td>
<td>- Disabled: The reaction is currently inactive, and the Enable button is available.</td>
</tr>
<tr>
<td></td>
<td>- Disabled for invalid configuration: The reaction is currently inactive owing to its invalid configuration. The Disable and Enable buttons are unavailable.</td>
</tr>
<tr>
<td></td>
<td>- Disabled for missing license: The reaction is currently inactive because some or all required license options are missing. If the reaction was enabled and the license is lost, Disable and Enable buttons are unavailable. If the reaction was disabled, when the license is lost, the Enable button will appear available, but you still cannot enable the reaction.</td>
</tr>
<tr>
<td>Activity Status</td>
<td>Indicates whether the reaction is currently running or not running:</td>
</tr>
<tr>
<td></td>
<td>- Executing (the reaction is running)</td>
</tr>
<tr>
<td></td>
<td>- Idle (the reaction is not running)</td>
</tr>
<tr>
<td>Last Execution Status</td>
<td>Indicates the outcome the last time the reaction was executed:</td>
</tr>
<tr>
<td></td>
<td>- Never Executed</td>
</tr>
<tr>
<td></td>
<td>- Succeeded</td>
</tr>
<tr>
<td></td>
<td>- Aborted by user</td>
</tr>
<tr>
<td></td>
<td>- Failed</td>
</tr>
<tr>
<td></td>
<td>- Exception</td>
</tr>
<tr>
<td>Last Execution Time</td>
<td>Date and time when the reaction was last executed.</td>
</tr>
</tbody>
</table>

**Reaction Control Commands.**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disable</td>
<td>Inactivate the reaction, so that it will not execute.</td>
</tr>
<tr>
<td>Enable</td>
<td>Activate the reaction so that it will execute.</td>
</tr>
</tbody>
</table>
12.2 Working with Reactions

To manually control a reaction, search for the reaction you want to work on (see Reactions Workspace [353]), and then use the following workflow:

- Enable [355] or disable [355] the reaction.

12.2.1 Enabling a Reaction

If a reaction is not enabled by configuration, you need to enable it first before the management system can execute it. Enabling a reaction means that it will be executed when its trigger conditions occur.

To enable a reaction proceed as follows:

- You are authorized to issue standard commands on the relevant project scope.
- The reaction is currently inactive (its status in the Contextual pane is Disabled), and you want to enable it.

1. In System Browser, select Application View.
2. Select Applications > Logics > Reactions.
3. In the main Reactions folder, or in a subfolder under it, select the reaction you want to enable.
4. To enable the reaction, in the Operation tab [354] of the Contextual pane, click Enable.
   - The status of the current reaction changes to Enabled.

12.2.2 Disabling a Reaction

Disabling a reaction prevents it from being triggered, while still retaining the reaction within the system. For example, you might do this for reactions that are not yet complete or ready to be put into general use.

NOTE:
When you disable a reaction, the management system generates an event. This event is automatically cleared when you re-enable the reaction.

To disable a reaction, proceed as follows:

- You are authorized to issue standard commands on the relevant project scope.
- The reaction is currently active (its status in the Contextual pane is Enabled), and you want to disable it.

1. In System Browser, select Application View.
2. Select Applications > Logics > Reactions.
3. In the main Reaction folder, or in a subfolder under it, select the reaction you want to disable.
4. To disable the reaction, in the Operation tab [354] of the Contextual pane, click Disable.
   - The status of the current reaction changes to Disabled.
### 13 Address Book

The Desigo CC address book [↩ 357] contains a list of contacts (called **recipients**) which the system can use for sending out remote notifications [↩ 127], or for emailing reports [↩ 219].

You can view or interact with the address book by selecting the **Address Book** node, in the Application View of System Browser.

For each contact, the address book stores:

- The person's full name, initials, and language
- The **group(s)** to which that person belongs (for example, Operator, Supervisor, Administrator).
  
  **Note:** Groups are used in remote notifications, which are addressed to recipient groups and not to individuals. When a remote notification is sent out, it goes to all the people who are members of its recipient group.

- One or more **devices** that can be used for contacting that person (up to three email addresses, up to two mobile phone numbers for SMS messages, and/or a pager number).
  
  **Note:** Each email address, mobile phone number, and so forth counts as a separate device.

- The preferred and fallback devices that should be used to contact that person.

The **Address Book** workspace lets you import Microsoft Outlook contacts into the Desigo CC address book from a CSV file. You can also manually add and edit address book entries:

- Import [↩ 359] contacts from a .csv file
- Filter [↩ 361] the address book, and add [↩ 360]/modify [↩ 361]/delete [↩ 362] contacts

#### Importing Microsoft Outlook Contacts From a CSV File

Desigo CC supports exported contacts files from Microsoft Outlook 2003 and 2007, and only in English language.

The export of Outlook contacts to a CSV file results in a multi-line text file where each line contains values separated by commas.

The first row contains the description of the values, while the succeeding rows contain data, one contact per row.

When importing a contact list, the following rules apply:

- Any CSV file in a language different from English is not imported. For more information on how to handle this case, see the note in Importing Contacts to the Address Book [↩ 359].

- Each contact is identified by a preferred device. By default, this device corresponds to the first valid e-mail address. If there is no e-mail address, a phone number (for either a mobile phone or pager) is taken as a preferred device.

- If a preferred device is missing or invalid, the corresponding contact is skipped.

- A phone number is considered valid even if it contains:
  
  - A preceding plus sign (+); during import this character is replaced by two zeros (00).
  
  - An empty space, a hyphen (-), or a comma (,) between the numbers; during import these characters are removed.

- When re-importing an address book:
  
  - Any duplicated contact is skipped
  
  - If the preferred device data is changed (for example, a different e-mail address), a new entry for the same contact is created.

  - If any other data is changed (for example, name or other phone number) the same contact is updated.
The following rules apply to populating the Address Book with the contacts data:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full Name</td>
<td>First Name, Middle Name, and Last Name with a space as separator.</td>
</tr>
<tr>
<td></td>
<td>Full Name is limited to 50 alphanumeric characters.</td>
</tr>
<tr>
<td>Preferred Device</td>
<td>E-mail/SMS/pager.</td>
</tr>
<tr>
<td>E-mail1, E-mail2, E-mail3</td>
<td>E-mail Address.</td>
</tr>
<tr>
<td></td>
<td>E-mail is limited to 50 alphanumeric characters; if you exceed the limit, the field is left empty.</td>
</tr>
<tr>
<td>SMS1, SMS2</td>
<td>Mobile phone number.</td>
</tr>
<tr>
<td>Pager</td>
<td>Pager number.</td>
</tr>
</tbody>
</table>

The rest of the fields in the Address Book are left empty or set to default values.

13.1 **Address Book Workspace**

The Desigo CC **Address Book** workspace is divided into three parts: a toolbar, the list of the contacts, and the details of the selected contact.
### Address Book Toolbar

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Save recipient</td>
<td>Save any changes.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Add recipient</td>
<td>Add [→ 360] a new contact row in the address book.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Remove recipient</td>
<td>Delete [→ 362] a contact.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Remove all recipients</td>
<td>Delete [→ 362] all the contacts from the address book.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Import address book</td>
<td>Browse to select a CSV file containing the contacts to import [→ 359] (previously exported from Microsoft Outlook 2003 or 2007).</td>
</tr>
</tbody>
</table>

### Address Book Fields

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search</td>
<td>Filter [→ 361] the address book.</td>
</tr>
<tr>
<td>Address Book</td>
<td>View contact data:</td>
</tr>
<tr>
<td></td>
<td>- Full Name</td>
</tr>
<tr>
<td></td>
<td>- Groups</td>
</tr>
<tr>
<td></td>
<td>- Preferred Device</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Details Fields.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full name</td>
<td>Enter the contact full name. This value must be unique.</td>
</tr>
<tr>
<td>Short name</td>
<td>Enter the contact short name.</td>
</tr>
<tr>
<td>Language</td>
<td>Select the contact language. Default is en-US (English - United States).</td>
</tr>
<tr>
<td>Groups</td>
<td>Assign the contact to one or more groups of recipients. You can also add/update/remove groups.</td>
</tr>
<tr>
<td>Devices</td>
<td>Specify at least one remote notification device among the following:</td>
</tr>
<tr>
<td></td>
<td>- Email (E-Mail 1, E-Mail 2, E-Mail 3)</td>
</tr>
<tr>
<td></td>
<td>- SMS (SMS 1, SMS 2)</td>
</tr>
<tr>
<td></td>
<td>- Pager (number is required). Comma is not allowed.</td>
</tr>
<tr>
<td>Preferred device</td>
<td>Select the primary device. Default is E-mail 1.</td>
</tr>
<tr>
<td>Fallback device</td>
<td>Select an alternative device. Default is None.</td>
</tr>
<tr>
<td>Contact data</td>
<td>Enter any additional information (for example, phone number).</td>
</tr>
</tbody>
</table>

### 13.2 Working with the Address Book

The following procedures describe Address Book tasks.

#### Technical Notes

For the following procedures, a message box displays to warn you if:

- You try to save an address book contact, but you did not enter a required field, or the contact name you entered already exists.
- You try to update (change) a group name, but the new name you entered already exists.
- You navigate away without saving the changes made.

### 13.2.1 Importing Contacts to the Address Book

- You want to import contacts into the Desigo CC address book from a CSV file containing contacts exported from Microsoft Outlook (2003 or 2007).

1. In System Browser, select Application View.
2. Select Applications > Address Book.
   - The address book user interface [357] displays in the Primary pane.
3. In the Address Book toolbar, click Import address book.
4. In the Open dialog box, do the following:
   - a. Browse the file system and select the CSV file you want to import (for example, MyContacts.csv).
   - b. Click Open.
   - When the import procedure is complete, a message box informs you about the number of new contacts created, the number of existing contacts updated and the number of contacts skipped (because of importing rules).
5. Click **OK** to close the message box.
   - The imported contacts appear in the Address Book.

<table>
<thead>
<tr>
<th>WARNING</th>
</tr>
</thead>
</table>

**NOTE:**
Only CSV files in English language are supported. If your language is not English, change this setting to *English* before proceeding with the file import. For more information about this procedure, see the following:


### 13.2.2 Adding a Contact

1. In System Browser, select **Application View**.
2. Select **Applications > Address Book**.
   - The address book user interface [357] displays in the Primary pane.
3. In the **Address Book** toolbar, click **Add recipient**.
   - A new row appears in the **Address Book**.
4. Select the new row.
   - The contact details fields are available for editing.
5. Enter the **Full name** and **Short name**.
6. *(Optional)* Select a **Language** different from the default (English (United States)).
7. To assign the contact to a group of recipients, select the group from the list and click **Add**. *(Repeat this step for all the groups to which the contact belongs).*
   **NOTE:** To create a new group and assign the contact to it, enter the new group name and then click **Add**. To change the name of an existing group, select it, enter the new name and click **Update**.
8. Enter the appropriate information for at least one of the following devices:
   - E-Mail 1/E-Mail 2/E-Mail 3
   - SMS 1/SMS 2
   - Number (pager).
9. Select the **Preferred device** and **Fallback device**.
10. *(Optional)* Enter the **Contact data**.
11. In the **Address Book** toolbar, click **Save**.
   - The contact details appear in the Address Book.
13.2.3 Filtering the Address Book

- The address book user interface [→ 357] displays in the Primary pane.
- Sample scenario: you want to quickly find a contact to modify the corresponding data.
  - Use the Search function by doing one of the following:
    - Enter the first letters of the contact name and click Search (or press ENTER).
    - From the Search drop-down list, and under Saved Searches select a group of recipients.
  - The Address Book refreshes and displays data according to the active filter.

Deactivating the Filter

- To deactivate the filter, click Remove.

13.2.4 Modifying a Contact

1. In System Browser, select Application View.
2. Select Applications > Address Book.
   - The address book user interface [→ 357] displays in the Primary pane.
3. Select the contact you want to modify.
   - Details fields are now available for editing.
4. If necessary, do one or more of the following:
   - Modify the Full name, Short name, and/or Language.
   - Modify the group(s) of recipients to which the contact belongs.
   - If you want to remove the contact from a group, select the group in the list and click Remove.
     - If the group has other members aside from this contact, only the association between the group and this contact is removed. If this contact was the group’s only member, the group itself is also removed.
   - Modify the devices.
   - Modify the Preferred device and Fallback device.
   - Modify the Contact data.
5. In the Address Book toolbar, click Save.
   - The contact details update in the Address Book.
13.2.5 Deleting Contacts

When deleting contacts you may either remove an individual contact or clear the entire address book.

▷ The Address Book contains contact entries.

1. In System Browser, select Application View.

2. Select Applications > Address Book.
   ▷ The address book user interface [→ 357] displays in the Primary pane.

3. Do one of the following:
   - To remove an individual contact, select the contact you want to delete. Then in the Address Book toolbar, click Remove recipient.
   - To clear the entire address book, click Remove all recipients.
   ▷ A confirmation message box asks if you want to delete the selected item (or all the contacts).

4. Click Yes.
   ▷ Depending on the operation you carried out, the selected individual contact is removed from the Address Book or the entire Address Book is cleared.
14 Documents

The management system lets the operator consult a set of reference documents configured in the system.

These documents can be files (PDF, RTF, TXT. Note that Microsoft DOC and DOCX formats are not supported) or web links (URLs of HTML pages). They will typically contain instructions, procedures, or other information relevant to the operation of the building-control site.

In the Application View of System Browser, under Applications > Documents you can create documents (document objects) and associate them with copied files on the Desigo CC server, or with web links. The documents created in this way can then be viewed (in read-only mode) by:

- Selecting a document node in System Browser (the document displays in the Primary pane).
- Selecting a document link in Related Items (the document displays in the Secondary pane).
- Executing a document step in Assisted Treatment.

Make a Document Appear in Related Items

A document will appear as a Related Item of a system object if it is linked (associated) to that object. To create such links manually, select a document and drag-and-drop system objects into its Manually Linked field.

(In the graphics application, you can also place a document symbol in a graphic and then use the coverage area feature to create Related Items links automatically. These links display in the Automatically Assigned field in the documents application. For more information about the coverage area, see the Graphics Editor manual A6V10415487).

Manage Document Objects

You can manipulate document objects as follows:

- Change the file or web link that is associated with a document object. **NOTE:** You can only choose from the files stored under the project documents folder.
- Link a document object to a system object so that the document becomes a related item of that system object. Or remove a link between a document and a system object. **NOTE:** You cannot remove automatically created links.
- Create a copy of a document object (by saving an existing document object with a different name).
- Delete document objects.

The specific tasks you can perform will depend on the application rights configured for your user group.

**NOTE:**

When you are working in Operating mode and select a Document object in the Application View of System Browser, the Documents workspace [➙ 364] opens in the Primary pane, automatically set to Operate mode . Switch to Edit mode to manipulate document objects as described above.
14.1 Documents Operating Workflows

The following describes how to access and work with documents from the Primary and from the Secondary pane.

Primary Pane

In System Manager, from the Application View of System Browser, under Applications > Documents select one of the available document objects, which displays in the Primary pane. To manage the current document, switch to Edit mode.

You can do the following:

- Create [→ 365] a copy of the document and save it with a different name (Save as)
- Modify [→ 366] the document (replacing the document with a different file or web link or adding/removing System Browser objects that are linked to the document) and save it (Save the changes)
- Create related items [→ 366] or modify related items [→ 367] by associating the current document to one or more objects in System Browser
- Delete [→ 368] the document

Once you complete your changes, switch back to Operate mode.

In the Assisted Treatment window, select the Document step of an operating procedure to view a document [→ 121].

Secondary Pane

From the Related Items tab, select a document link (for example, text file, hyperlink, and so forth). The Secondary pane opens and previews the selected document.

Use Backward or Forward to navigate through any other documents in Related Items.

To manage the current document, switch to Edit mode. You can do the following:

- Modify [→ 366] the document (replacing the document with a different file or web link or adding/removing System Browser objects that are linked to the document)
- Create related items [→ 366] or modify related items [→ 367] by associating the current document to one or more objects in System Browser

Once you complete your changes, switch back to Operate mode.

14.2 Documents Workspace

The Documents workspace lets you view the documents (files or web links) made available to you by the system.
When you select a document, you can click the Edit mode icon \(\text{Edit}\) in the toolbar to manipulate \([\rightarrow 364]\) document objects.

### 14.3 Working with Documents

The following procedures describe Documents operating tasks.

#### Technical Notes

These notes apply to one or more of the following procedures.

- An error message displays in the following situations:
  - The document you selected is not available.
  - If you select the file radio button, but do not select a file form the drop-down list, you’re not allowed to save.
- If you try to exit Edit mode (go back to Operate mode) without saving the changes, a message box prompts you to save, discard the changes, or cancel (remain in Edit mode).

#### 14.3.1 Creating a New Document from an Existing One

A document object (either a file or web link) is available in System Browser, and you want to create a new document from the existing one.

1. In System Browser, select **Application View**.
2. Select **Applications > Documents** (or any document folder).
3. Select the appropriate document object (either a file or a web link).
   \(\Rightarrow\) The document displays in the Primary pane.
4. If in Operate mode, switch to **Edit mode** \(\text{Edit}\) .
5. If necessary, modify the document settings \([\rightarrow 366]\) and the document related items \([\rightarrow 366]\).
6. To save the settings into a new document object, in the **Documents** toolbar, click **Save as** \(\text{Save as}\) .
   
   Then, in the **Save Object As** dialog box, do the following:
   - a. Select the location in the tree (under **Applications > Documents**).
   - b. Type the **Name** and **Description** of the document.
By default, when you click in the **Description** field, the same text contained in the **Name** field displays. Click the **Flag** icon to display a field for each language available in the system; modify the text for each language and click **OK**.

c. Click **OK**.
   ⇒ The new document object appears in System Browser.

7. To go back to normal operation, click **Operate**.

### 14.3.2 Modifying a Document

> A document object (either a file or a web link) is available in System Browser, and you want to replace it with a different file or web link.

1. In System Browser, select **Application View**.
2. Select **Applications > Documents** (or any document folder).
3. Select the document object (either a file or a web link) that you want to replace.
   ⇒ The document displays in the Primary pane.
4. If in Operate mode, switch to **Edit** mode.
5. In the **Document settings** configuration box, enter the new web link or select the new file that will replace the current document. Do one of the following:
   - Choose the **Web URL** option, and enter an **HTML page URL**. The selected document will be replaced with this web link.
   - Choose the **Select a file** option, and select one of the available document files from the list. The selected document will be replaced with this file.
6. Click **Preview**.
   ⇒ The modified document displays in the preview area.
7. To save the changes, in the **Documents** toolbar, click **Save**.
   ⇒ The System Manager status bar indicates that the data was successfully saved.
8. To go back normal operation, click **Operate**.

### 14.3.3 Creating a Document Related Item

> You want to associate a document with one or more system objects, so that the document appears as a related item for those objects.

1. In System Browser, select **Application View**.
2. Select **Applications > Documents** (or any subfolder).
3. Select the document (either a file or a web link) you want to use as a related item.
   ⇒ The document displays in the Primary pane.
4. If in Operate mode, switch to **Edit** mode.
5. Drag-and-drop the object(s) you want to associate from any of the System Browser views to the **Manually assigned** field.

**NOTE:** If you need to select an object from a view that is different from **Application View**, remember to first select the **Manual Navigation** check box in System Browser to freeze the Primary pane.
6. Repeat the previous step for all the objects you want to link with the document. 
**NOTE:** To remove the association between the current document and an object, select the object and click **Remove**.

7. To save the changes, in the **Documents** toolbar, click **Save**.
   - The System Manager status bar indicates that the data was successfully saved.

8. To go back normal operation, click **Operate**.

To view the document related items, do the following:

1. In System Browser, select an object that includes at least one document among its related items.

2. In **Related Items**, select one of the document related items (for example, **PDF**).
   - The Secondary pane opens next to the Primary pane, and displays the document.

3. Click **Backward** or **Forward** to navigate through the other document related items for the same object. Alternatively, you can use the following keyboard shortcuts:
   - ALT + P (previous related item)
   - ALT + N (next related item)

### 14.3.4 Modifying a Document Related Item

- A System Browser object has at least one document related item.
- You want to replace this document related item with a different file or web link. Or you want to add/remove System Browser objects that are linked to this document.

1. In System Browser, select the object whose document related item(s) you want to modify.
   - Related Items displays (at least) one document related item.

2. In **Related Items**, select the document (for example, **PDF**).
   - The Secondary pane opens next to the Primary pane. It displays the document.

3. In the **Documents** toolbar, click **Edit**.
   - The document switches to Edit mode.

4. Modify the document settings [366] and/or linked objects [366] and save the changes.

5. To go back normal operation, click **Operate**.
14.3.5 Zooming In/out and Printing a PDF Document

You can zoom in/out and print a PDF document.

- A PDF document is available in the Documents folder in System Browser.

1. In System Browser, select Application View.
2. Select Applications > Documents (or any document folder).
3. Select the PDF document.
   - The PDF page displays in the Primary pane. The icons to zoom in/out, and print a PDF document become available in the toolbar.
4. Click one of the following:
   - ☝️ Zoom in, to enlarge the view of the PDF document. Click repeatedly to continue zooming in.
   - ☝️ Zoom out, to reduce the view of the PDF document. Click repeatedly to continue zooming out.
   - 🖨️ Print, to send the PDF document to the printer.

14.3.6 Deleting a Document

- A document (either a file or web link) is available in System Browser.

1. In System Browser, select Application View.
2. Select Applications > Documents (or any document folder).
3. Select the document (either a file or web link) you want to remove.
   - The document displays in the Primary pane.
4. If in Operate mode, switch to Edit mode 🆕.
5. In the Documents toolbar, click Delete ✗.
   - A confirmation message displays asking if you want to remove the selected object.
6. Click Yes.
   - The selected document is removed from System Browser.
7. To go back to normal operation, click Operate 📝.
15 System-related Functions

This section discusses miscellaneous system functions that deal with operator authentication, for example, changing a password or executing a switchover across two operator shifts, licensing, to display the available licenses, printing, to control the printing options, and so on.

15.1 User Password Change

If you are logged on as Desigo CC user, you can change your password at any time from the system menu.

15.1.1 Changing Your Password

You are logged on as Desigo CC user, and the option to change the user’s password is available in the system menu.

1. In the Summary bar, select Menu > Operator > Change User Password.
   - The password change window appears. The password fields are empty and the Change Password button is inactive.

2. Enter the following:
   - Old password
   - New password
   - Confirm password
   - The Change Password button is now active.

3. Click Change Password. If you enter an invalid password, a message tells you to verify the inserted data.
   - A message informs you that the changes have been successfully saved.

15.2 Operator Switchover

When you start your shift and some else is logged on to the system, you should perform a switchover [→ 369]. Perform a switchover again when you are ending your shift and someone else is ready to log on to the system.

You perform a switchover from the menu [→ 75] on the Summary Bar.

**NOTE:**

If you need to leave the system and no one else is taking over, log out of the system.

15.2.1 Changing Operators

You want to perform an operator switchover.

1. In the Summary bar, select Menu > Operator > Switchover.
   - The switchover window displays. The fields are empty and the Logon button is inactive.

2. Enter the following:
   - Current User password
   - Your username, password, and domain
   - The Logon button becomes active.
3. Click Logon.
   ◮ The current user is logged off from the system. The system splash screen informs you of the system initialization progress. When the system is initialized, it restarts with your user credentials.

**Technical Notes**

● If you provide invalid credentials, a message displays informing you to verify the credentials.
● If you provide the same credentials for the current and the new user, the Logon button stays inactive and you cannot logon.

**WARNING**
The current version of Desigo CC supports only one domain. This means that you can only log on to the configured default domain. If you belong to a domain different from the default, you can log on only as a Desigo CC user or local user ([station name] user name). The default domain name is configuration-dependent. If default domain name is not configured, the default station name and Desigo CC (not Windows user) are available as domain instead.

### 15.3 Auto Logoff

The auto logoff is a system-configuration feature. If configured, and you are not using the keyboard and the mouse because you are not at the computer where Desigo CC client application is running, a message informs you that you will be logged off automatically.

You have 30 minutes to decide whether to be logged off or continue your work session.

When this message box displays, Windows screensaver is disabled.

#### 15.3.1 Interrupting the Auto Log Off

▷ You are not using the computer where Desigo CC client application is running.
▷ The log off message box displays the time remaining before the automatic log off.
▷ You want to stop the log off.

● Move the cursor or press any key on the keyboard.
▷ The auto log off is interrupted.

### 15.4 Logging On and Off in Closed Mode

Desigo CC can be installed on a client computer configured to run in Closed mode. Consequently:

● If the computer is powered on, Default User is logged on and the operator can log off [→ 371] the Default User and log on with user credentials. To hand over to another operator it is necessary to log off [→ 371] the first operator (Default User is automatically logged on); then the other operator can log off [→ 371] the Default User and log on with user credentials.

● If the computer is powered off (for example, manually by the operator, hard reset, or because of power failure), once the operator powers on again the computer, Desigo CC starts in Closed mode with Default User automatically logged on.
15.4.1 Logging Off Default User and Logging On Operator

In Closed mode, Desigo CC runs with the Default User logged on. To log on, you have to log off the Default User and then log on with your credentials:

1. In the Summary bar, select Menu > Logoff.
   - A message box informs you that Desigo CC will be closed and you will be logged on.
2. Click OK.
   - Default User is logged off. The initialization splash screen displays for a few seconds. Then the logon dialog box displays.
3. Enter your username and password.
4. Select the domain.
5. Click Logon.
   - Desigo CC restarts in Closed mode with your credentials.

15.4.2 Logging Off Operator and Logging On Default User

In Closed mode, you cannot shut down Desigo CC. You can only end your session leaving the computer running for the Default User:

1. In the Summary bar, select Menu > Logoff.
   - A message box informs you that Desigo CC will be closed and the Default User will be logged on.
2. Click OK.
   - You are logged off. Desigo CC starts in Closed mode and the Default User is automatically logged on.

15.5 Multiple Monitor Management

When Desigo CC runs as an Installed Client or Windows App Client and an additional monitor is available, you can move any system window (such as, System Manager, Event List in some Client Profiles only, Investigative/Assisted Treatment, or Help) from the default monitor to a second monitor. The only exception is the Summary Bar which cannot be moved.

If you minimize the window displaying on a second monitor, the corresponding icon displays in the Windows taskbar of the default monitor. If you maximize the window again, it displays on the monitor where you previously minimized it.

Typical application example: You’re running two System Manager windows, and want to display them on separate monitors.
15.5.1 Moving a System Window to a Second Monitor

- Desigo CC is running as an Installed Client or Windows App Client on a computer connected to two monitors.

- You want to move a window from the default monitor to the second monitor. For example, you want to move the System Manager window.

1. Click **Restore Down** in the window.
   - The window restores down, you can move it to another monitor, and the icon changes to **Maximize**.

2. Drag the **window** from the default monitor to the second monitor, and click **Maximize**.
   - The window displays on the second monitor.

15.6 Print Feature

Desigo CC allows you to:

- Print from the Menu [➙ 374] on the Summary Bar
- Printing Data from a System Application [➙ 374]

15.6.1 Printouts Selection Dialog Box

The **Printouts selection** dialog box displays only when you select the **Print** option from the Menu on the Summary bar, and you can select the printouts of one or more system applications.

By default all of the system applications that have data to print are selected. You can de-select the printouts you don’t want, and change the printout order.
15.6.2 Print Preview Dialog Box

The Print Preview dialog box displays when you click Print in the Printouts selection dialog box, or when you print from an application.

You can choose margins, orientation, scaling and color option, printer, paper, and print.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Zoom in</td>
<td>Provides a close-up view of the printout. Keep clicking it to continue zooming in.</td>
</tr>
<tr>
<td></td>
<td>Zoom out</td>
<td>Reduces the view of the printout. Keep clicking it to continue zooming out.</td>
</tr>
<tr>
<td></td>
<td>Actual size</td>
<td>Fits the printout into the whole preview page.</td>
</tr>
<tr>
<td></td>
<td>Fit width</td>
<td>Fits the printout into the preview page’s width.</td>
</tr>
<tr>
<td></td>
<td>One page</td>
<td>Displays the printout one page per sheet.</td>
</tr>
<tr>
<td></td>
<td>Two pages</td>
<td>Displays the printout two pages per sheet.</td>
</tr>
</tbody>
</table>

1) These commands affect only the print preview, and not the printout.
15.6.3 Printing from the Menu

1. In the Summary bar, select Menu > Print.
   ↳ The Printouts selection dialog box displays.
   If you want to terminate the printout selection operation and exit this dialog box, click Abort. In this case, skip the next steps.

2. In the Printouts selection dialog box, do the following:
   - Clear the check boxes that correspond to the system application(s) printouts you don’t want to generate.
   - Click Move up or Move down to change the printout order.

3. Click Preview.

4. (Optional) In the Print Preview dialog box, do the following:
   - Use the icons in the toolbar [→ 373] to check the output to make sure it is the way you want it.
   - Adjust Margins (default is 50 pixels).
   - Select the desired Orientation (default is Landscape).
   - Adjust Scaling (default is fit to page selected).
   - Select the Printer and Paper size.
   - Select the Color option (default is black and white).
     NOTE: The color option depends on the selected printer. If it appears dimmed and unselected, this means that the selected printer cannot print color. If it appears dimmed and selected, this means that the selected printer can print only color. Even when you can select to print color (or black and white), the printout may not correspond to the color option selected because of the printer drivers.

5. Click Print and Close.
   ↳ The printout is sent to the selected printer. A message box informs you if the print operation fails.

15.6.4 Printing Data from a System Application

The access to the print option varies according to the application selected and your user privileges. For example, it may be available when you right-click on the Event List window, but some other system applications may have the Print icon 📢.

▷ The print option is available to you.
▷ Select the Print option as provided by the application.
   For example, right-click on the column headers of Event List, and select Print Event List.

1. (Optional) In the Print Preview dialog box, do the following:
   - Use the icons in the toolbar [→ 373] to check the output to make sure it is the way you want it.
   - Adjust Margins (default is 50 pixels).
   - Select the desired Orientation (default is Landscape).
   - Adjust Scaling (default is fit to page selected).
   - Select the Printer and Paper size.
Displaying System Information

You want to view system information such as Desigo CC version.

1. In the Summary bar, do one of the following:
   - Select Menu > About Page.
   - Click the [Company] logo (when moving your cursor on the logo, a tooltip displays:\Click to open the About Page).

   The About dialog box displays, and shows general information about the software.

   If you want to close this dialog box, click OK or Close. In this case, skip the last step.

2. (Optional) If you are working on a Client computer, click System Info.

   The System Information window displays detailed information about the Client computer.

Windows Shortcut Keys Behavior

Regardless of the operating mode you are working in, the following Windows shortcut keys are disabled:

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ALT+F4</td>
<td>Closes the active item or quits the active program.</td>
</tr>
<tr>
<td>ALT+SPACEBAR</td>
<td>Opens the shortcut menu for the active window that contains, among other commands, Minimize and Close.</td>
</tr>
<tr>
<td>Windows key+M</td>
<td>Minimizes all the windows.</td>
</tr>
</tbody>
</table>

If you are working in Closed mode, the following Windows shortcut keys are also disabled:

- CTRL+SHIFT+ESC
- Windows key+Pause/Break
- Windows key+R
- Windows key+L
- Windows key+F
- Windows key+CTRL+F
- Windows key+D
- Windows key+U
- Windows key+F1

NOTE: The color option depends on the selected printer. If it appears dimmed and unselected, this means that the selected printer cannot print color. If it appears dimmed and selected, this means that the selected printer can print only color. Even when you can select to print color (or black and white), the printout may not correspond to the color option selected because of the printer drivers.
15.9 Client Application Supervision

Desigo CC is reliable and responsive thanks to a constant supervision of the client application.

In case of any technical problem, Desigo CC client application automatically stops and restarts to perform a quick and safe memory optimization.

十堰 If a screen message displays informing you that Desigo CC needs a restart within 1 minute:

1. Save your work and optionally restart Desigo CC before the countdown expires.

十堰 When Desigo CC starts up again, a message informs you that the client application has been restarted due to an unhandled error or insufficient memory problem. Anyway, no changes will occur in the field conditions or will be reported by the management station.

2. Log on again to Desigo CC.

15.10 Licensing

The Desigo CC software requires a valid license to run. Typically, the license is stored on the Desigo CC server and consists of a set of license features that cover the requirements of a specific installation (project). Generally, a valid customer license includes:

十堰 A set of license features covering the basic functionality of the software (for example, System Manager, Event List, and so forth). This is called the basic required license set.

十堰 A set of option license features to enable additional or extended functionality (for example, Assisted Treatment, Reactions, and so on)

十堰 A set of license features to cover the hardware configuration of the system and the site (for example, number of client stations, field points, and so on)

Depending on whether a valid license (basic required license set) with sufficient license features to cover the field hardware) is found on the server, the Desigo CC clients may run in the following modes:

十堰 If a valid and sufficient license is found, the Desigo CC client will run normally (Normal mode).

十堰 If no valid license is found, the Desigo CC client will run in Demo mode.

十堰 If there is a valid license but it is not sufficient (for example, it does not cover all the field points in the building control system) then the Desigo CC client will run in Courtesy mode.

For more details about modes see License Modes [378].
View the License

The license data is available in the Management View of System Browser at the following path:

**Project > Management System > Servers > Main Server > Licenses.**

You can also quickly automatically point to the Licenses node by clicking the license text (for example, Demo Mode, or Courtesy Mode) in the Summary bar.

License Data

The license workspace shows you the current license mode (for example, Normal Mode) and a list of the installed license features.

For each license feature:

- **Required** indicates how many copies of that license feature must be installed for the system to operate normally (that is, for Desigo CC to run in Normal Mode). Note that the **Required** column will show 0 for option license features (such as Assisted Treatment) because the system will still function in Normal Mode even without those features installed.

- **Assigned** indicates how many copies of that license feature are being used by the system. The **assigned copies** of each license feature must match (or exceed, in the case of option license features) the **required copies** for the system to run in Normal mode.

- **Remaining** indicates how many copies of that license feature are still available (that is, how many of the installed copies are still unused).

Notes:

- For license features covering software functionality, one assigned copy is sufficient to enable that functionality for all Desigo CC clients. For example, Assigned=1 for sbt_gms_ext_sm enables the System Manager application for all Clients.

- For license features covering field data points, the **Required** column indicates how many are physically connected to the Desigo CC server: the **Assigned** column must match this value (for the system to run in Normal mode); and the **Remaining** column shows how many further points you can connect.

- Some license features have the effect of providing unlimited copies of another license feature. For example, one assigned copy of **Unlimited Web or Installed Clients** (sbt_gms_add_max_cl ) sets the assigned copies of **Concurrent Web or Installed Client Sessions** (sbt_gms_add_client) to Unlimited.
License Check
On system startup, and at 5-minute intervals afterwards, the Desigo CC server carries out an automatic check on the installed license features and counts the:

- Installed Clients, Web Clients, and Windows App Clients. If a Client disconnects from the server (because it is manually shut down, or owing to a malfunction), the count decreases.
- Physical objects in scan, such as Desigo CC data points, and third-party objects (for example, SCADA data points). These objects are grouped by disciplines (physical/logical objects). Every physical/logical object is represented by the corresponding data point in the database. Out of scan objects are not counted.

This check determines whether Desigo CC can run normally (Normal Mode) or under special restricted license modes [→ 378] (Demo or Courtesy).

15.10.1 License Modes
The Desigo CC server checks at regular intervals whether there is a valid license [→ 376] (with sufficient license features) installed.

As a result of this check, the Desigo CC clients will run in one of the following modes: Normal Mode, Demo Mode, Courtesy Mode, or Engineering Mode.

Normal Mode
Desigo CC is functioning normally with a valid and sufficient license (basic required license set with sufficient license features to cover the field hardware). In this case you will not see any special messages on the Summary bar.

Demo Mode
On initial startup, or during normal operation, if a valid license (basic required license set) is not found (for example, because it expired, or was lost for any reason) the Desigo CC server switches to Demo Mode, and the system operates for 30 minutes. When the 30-minute Demo Mode time limit expires, the Desigo CC server stops the project and the operators are forced to log off. If the project is subsequently restarted, the system will run in Demo Mode for another 30 minutes.
Demo Mode Characteristics

- When Demo Mode is active, this is visually indicated on the Summary bar in green, with a timer that shows how much time is left.
- If you view the license data, the basic required license set will be highlighted in red. **Assigned** and **Remaining** will indicate 0.
- If the basic required license set is detected before the 30-minute Demo Mode time expires, Desigo CC switches back to Normal Mode.

Courtesy Mode

The Desigo CC server switches to Courtesy Mode when the basic required license set is installed, but one of the following situations occurs:

- An **insufficient** set of license features for field points is detected. That is, the site project was configured with a certain number of physical objects, but only a subset of these are licensed. For example, if the site project was configured with 2000 fire data points but only 1000 are licensed,Courtesy Mode activates.
- The system detects 3 or more sabotage attempts within a 30-minute period. Sabotage means any unauthorized attempt to modify the system's license data directly in the database (for example, inappropriate changes to the time remaining in a specific license mode). Only the system itself is allowed to write to the license data.

In the event of sabotage by unauthorized software:

- If the system detects fewer than 3 sabotage attempts within 30 minutes, at the end of the 30 minutes the sabotage attempt counter is reset.
- If the system detects 3 sabotage attempts within 30 minutes, Desigo CC switches toCourtesy Mode but the license features are still considered valid. An alarm is also generated to inform the operator.
- If the system detects more than 3 sabotage attempts within 30 minutes, Desigo CC switches to Courtesy Mode and the license features are invalidated (even if the license features are installed the system treats them as no longer valid).

WhenCourtesy Mode activates, the Desigo CC management system can continue to operate for a total of 30 days accumulated.
- When Courtesy Mode is active, this is visually indicated on the Summary bar in red, with a countdown timer that shows how much time is left.
- If you check the licenses, any license features that are insufficient will be highlighted in red. The **Required**, **Assigned** and **Remaining** columns will indicate the discrepancy: **Remaining** shows how many of the installed copies of that license feature are still unused while **Assigned** shows how many copies of that license feature are being used by the system.
- During Courtesy Mode, if a sufficient set of license features is detected during a license check (that is, the site project was reconfigured so that all the field objects are licensed), the Desigo CC server switches back to Normal mode.
- If the Desigo CC server switches back to Courtesy Mode, the countdown timer does not restart from 30 days, but from the previous time remaining in Courtesy Mode.
- After the Desigo CC server has run in Normal Mode for 180 days without switching to Courtesy Mode, the next time it switches to Courtesy Mode, the countdown timer starts at 30 days.
- If the time allowed for operation in Courtesy Mode expires, Desigo CC shuts down and it is necessary to install again all the license features required to run the system.

**Engineering Mode**

Engineering is a feature of Desigo CC that enables an authorized technician to configure the management-system software for a particular building-control site (that is, to configure a site project).

For more information, see the *Engineering Manual* (A6V10415473).

**License Mode in Collapsed Summary Bar**

The license mode (color and text) is also visible when the Summary bar is collapsed.

### License Properties in the Operation Tab

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>License mode</td>
<td>Desigo CC current mode.</td>
</tr>
<tr>
<td>Sabotage attempts</td>
<td>Number of sabotage attempts.</td>
</tr>
<tr>
<td>Time remaining in this session</td>
<td>Residual time in the current Demo Mode or Engineering-license session.</td>
</tr>
<tr>
<td></td>
<td>- When the 30-minute Demo time expires the project will be stopped and the operator will be forced to log off.</td>
</tr>
<tr>
<td></td>
<td>- When the 48-hour Engineering license time expires, the system will switch back to its previous license mode.</td>
</tr>
<tr>
<td>Time remaining in Courtesy Mode</td>
<td>Residual time in Courtesy Mode, during which it is possible to temporarily work with the project until a valid and sufficient license is installed again.</td>
</tr>
<tr>
<td>Total operating time</td>
<td>Duration counter that indicates how long Desigo CC has been operating.</td>
</tr>
</tbody>
</table>
with valid license | continuously working with a valid and sufficient license (that is, in Normal mode).
---|---
Engineering license will expire in | How many days until the Engineering License expires.

### System Shutdown in Demo Mode or Courtesy Mode

When the **Demo Mode** or **Courtesy Mode** countdown timer is about to expire, you are informed by a dialog box that the Desigo CC management system will shut down in 60 seconds: you cannot dismiss this dialog box, but you can continue your work (for example, saving data) until the system shuts down. Alternatively, to end your session immediately:

- In the dialog box, click **Shutdown Now**.
- The Desigo CC management system shuts down.

**Note:** If the missing license features are detected again before the 60 seconds expire, the dialog box disappears and the system reverts to Normal mode.

#### 15.11 Help System

The following help features are available to you at any time during your work session:

<table>
<thead>
<tr>
<th>Type</th>
<th>Provides...</th>
<th>Available using....</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help [➙ 383]</td>
<td>Online help. The functionalities similar to the standard HTML Help Viewer including:</td>
<td>Help item in the Menu on the Summary Bar or From the Windows Start menu: <code>Start &gt; All programs &gt; [Company] &gt; Desigo CC &gt; User Documentation &gt; [language specific] (such as, en-US)</code></td>
</tr>
<tr>
<td>Contextual help [➙ 384]</td>
<td>A way to view the Help contents relating to any system application component contained in a window or pane on focus.</td>
<td>F1</td>
</tr>
<tr>
<td>User documentation [➙ 384]</td>
<td>A list of the product documents available that describe how to perform system tasks. They are available if you prefer to work with a hard copy.</td>
<td>User documentation item in the Menu on the Summary Bar</td>
</tr>
</tbody>
</table>

#### 15.11.1 Help Workspace

You can display the online Help page using the Windows Start menu, the system menu, or the contextual help within the Help page by pressing F1.
### Help Workspace

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selection area</td>
<td>Find the information you need by searching in one of the following ways:</td>
</tr>
<tr>
<td></td>
<td>• By category in the Contents [➙ 382] tab.</td>
</tr>
<tr>
<td></td>
<td>• By subject in the Index [➙ 382] tab.</td>
</tr>
<tr>
<td></td>
<td>• By topic using a keyword in the Search [➙ 382] tab.</td>
</tr>
<tr>
<td>Contents area</td>
<td>View the information available when a topic is selected.</td>
</tr>
<tr>
<td>Icons</td>
<td>Lock/minimize/maximize/close Help.</td>
</tr>
</tbody>
</table>

#### 15.11.1 Contents

In the selection area on the left, the Contents tab displays a list of Help categories [➙ 383] that you can select to display sub-categories and narrow your search.

#### 15.11.2 Index

In the selection area on the left, the Index tab includes a list of Help subjects [➙ 383] that you can select or search by keyword.

#### 15.11.3 Search

In the selection area on the left, the Search tab displays a list of help topics containing a specific keyword.

You can select the following options:

- Get partial matches [➙ 383] – find all the topics available containing a specific keyword.
- Search titles only [➙ 384] – find all the topics available containing a specific keyword in the title.
15.11.2 Working with Help
The following procedures describe how to perform Help operating tasks.

Tips for Working with Help
- Online help is also available even without starting Desigo CC from the Windows Start menu (Start > All programs > [Company] > Desigo CC > User Documentation > [language specific]).
- When you open the Help page for the first time during your work session, an empty Help page displays on the screen, while the status bar indicates that help is under construction. When the operation is complete, the help contents appear.
- If the help contents in the Help page display in the default language (English (United States)) and it is different from your user language settings, then help is not available in your language.

15.11.2.1 Launching Online Help
- In the Summary bar, select Menu > Help.
  ➤ The Help page displays on the screen showing Desigo CC online help.

15.11.2.2 Searching by Category
- The Help page displays on the screen.
  1. Click the Contents tab.
  2. Select a category or sub-category.
  ➤ The topic you selected displays in the contents area of the Help page.

15.11.2.3 Searching by Subject
- The Help page displays on the screen.
  1. Click the Index tab.
     ➤ The Index tab contents display in the selection area in alphabetical order.
  2. Do one of the following:
     - Type the keyword to search in the field at the top of the tab area.
     - Select a title.
     ➤ The topic searched appears highlighted in the selection area.
  3. Press ENTER.
  ➤ The information related to the subject displays in the contents area of the Help page.

15.11.2.4 Searching by Keyword – Get Partial Matches
- The Help page displays on the screen.
  1. Click the Search tab.
     ➤ The Search tab contents display in the selection area.
  2. Type the keyword to search for in the field at the top of the tab area.
3. Select the **Get Partial Matches** option.

4. Click **List Topics**.
   - The list of all the subjects containing that keyword displays in the selection area.

5. Select a **topic**.
   - The topic appears highlighted in the selection area.

6. Press **ENTER**.
   - The information related to the subject displays in the contents area of the Help page.

### 15.11.2.5 Searching by Keyword – Search Titles Only

> The Help page displays on the screen.

1. Click the **Search** tab.
   - The Search tab contents display in the selection area.

2. Type the keyword to search for in the field at the top of the tab area.

3. Select the **Search titles only** option.

4. Click **List Topics**.
   - The list of all the titles containing that keyword displays in the selection area.

5. Select a **topic**.
   - The topic selected appears highlighted in the selection area.

6. Press **ENTER**.
   - The information related to the subject displays in the contents area of the Help page.

### 15.11.2.6 Displaying Contextual Help

1. Click a system component (for example, a pane or any part/object in a system window).
   - The related pane or window is now on focus.

2. Press **F1**.
   - The **Help** page displays on the screen showing the related online help topic. Help information about a specific component (for example, a field) is available in the help contents of the application that includes this object. If help contents for a system application are unavailable, the online help overview page displays.

### 15.11.2.7 Displaying User Documentation

1. In the Summary bar, select **Menu > User Documentation**.

2. Select one of the available **user documents**, for example **User Guide**.
   - The selected document displays in a separate PDF Reader window. You can minimize, maximize, or close this window.
16 Backup

Overview of Backup
Backing up Desigo CC requires storage of independent parts and those can be saved on different servers or PC’s. Of course it’s recommended to save the backups of your project data to a different machine from where they originally reside.

Basically there are two main parts to backup. Backups can be done either manually or by applying a macro in combination with a management station scheduler:
- Backup of the entire customer project data including all libraries, configurations, object data (project backup).
- Backup of the historic data collected in the history databases (HDB backup).

**NOTICE**
Prevent loss of project data in case of a HW disc failure.
Do not save your project data or any history database backups on the same hard disc drive where you have installed your Desigo CC management station software, respective the Microsoft SQL History Databases!

When you select a backup path different from the default location, make sure the target location directories exist on your back up machine.

**NOTE:**
Restoring the project folders or a history database requires working with the System Management Console. Refer to the Desigo CC System Management Console help (A6V10415491).

16.1 Project Backup
The project backup creates a recursive copy of all data contained in the C:\GMS\Projects\[Project]\ folder (such as libraries, graphics, and so on) with the following exceptions:
- The SQL database folder is skipped
- The log folder is copied but left empty

Your project is saved in the Backup folder on the Desigo CC server (in the path defined during the installation).

For each successful backup, this Backup folder is overwritten.

The backup contains all the folders, subfolders, and files of your project.

**NOTE:**
In case the backup fails or if you abort the backup process, the directory created for the backup — and all its contents — is removed.

Starting the Project Backup
Project backup starts in one of the following ways:
- Automatic (if configured using macros and reactions functions, see Automating Data Backup [390])
  Automatic backup saves both the DB data and the customer project data added after the most recent backup.
- Manual (using the backup commands available in the **Operation/Extended Operation** tabs of the Contextual pane, see Backing Up Your Project [➙ 387]).

**Limitations**
- When the backup process starts, and until it completes, the DB is locked. You cannot create and/or delete objects, modify the existing configuration, or carry out any import operations.
- The system does not support more than one project on the same server.

**Useful Tips**
- During the backup, the available disk space is not monitored. Make sure beforehand that there is sufficient disk space. Do not create a backup on the same disk on which the actual database resides.
- If you plan to make many modifications to your project, it is recommended that you perform a backup before modifying it and then again after you have completed the changes.
- Keep the three most recent backup copies.

### 16.1.1 Manual Project Backup

When you select the **Main Server** object in System Browser, the **Operation** and **Extended Operation** tabs in the Contextual pane display the various properties and commands of the **Main Server** object, which also include those relating to the project backup.

**Project Backup Properties and Commands**

**Backup Destination**
Indicates the directory where the Backup folder is created. The default directory is C:/GmsBackups/.
You can modify the default backup directory, and click **Apply** to save the changes.

**Backup Status**
Indicates the status of the backup which can be: one of the following:
- Last Backup Successful
- In Progress
- Cancelling
- Last Backup Failed
- Last Backup Cancelled
- Last Backup Failed for Timeout Expiration
- Backup Destination Path Not Found
You can manually start the backup operation (click **Start**) or abort a backup in progress (click **Cancel**).

**Backup Timeout**
Indicates the maximum time allowed for a backup. Timeout range is 0-120 minutes, where 0 means no timeout.
You can modify the timeout value, and click **Apply** to save the changes.

**Maximum number of stored backups**
Indicates the maximum number of stored backup allowed. Default is **100**.
You can modify the default value, and click **Apply** to save the changes.

**Backup Activity**
Indicates the progress of the backup operation (backup starting, internal backup, name of the component being backed up, and so on).

**Last Successful Backup Date**
Indicates date and time of last successful backup.

**Overwrite Backup Folder**
Indicates whether or not the backup folder must be overwritten. Default is **False**.
You can modify this default value, and click **Apply** to save the changes. In particular, if you set:
- **False**, a backup folder for each backup will be created with the following naming convention [YYYYMMDD-HHMM] (for example, 20140707-1342).
- **True**, the backup folder will be overwritten. The name of the folder will be **Backup**.

### 16.1.1.1 Backing Up Your Project

1. In **System Browser**, select **Management View**.
2. Select **Project > Management System > Servers > Main Server**.
   - The **Operation** (and **Extended Operation**) tab displays the Main Server properties.
3. *(Optional)* Modify one or more of the following:
   - **Backup Destination**: Enter a valid destination path in this field and click **Apply**.
     **NOTE**: If you enter an invalid path, the backup will fail (**Backup Status** will display **Last Backup Failed**).
   - **Backup Timeout**: Enter a value in this field (or use the slider on the left) and click **Apply**.
   - **Maximum number of stored backups**: Enter a value different from 1 (default stored backup) and click **Apply**.
   - **Overwrite Backup Folder**: Select **True** or **False** and click **Apply**.
4. Click **Start**.
   - The backup status changes to **In Progress**; **Component** displays the component currently backed up; **Progress** displays the backup completion percentage. When the backup completes and it is successful, the backup status changes to **Last Backup Succeeded**, and indicates the backup date. The project is available on the **Server** at the given destination path.
Once the backup starts, click **Cancel** if you want to abort the operation. The backup status changes to **Cancelling**. When the abort operation completes, the backup status changes to **Last Backup Cancelled**. The directory created is removed from the Main Server.

**Technical Notes**
- If the backup timeout is exceeded, the backup is aborted and its status displays the error **Last Backup Failed for Timeout Expiration**.
- During the backup operation (status is **In Progress** or **Cancelling**), if the system crashes, the backup status displays **Last Backup Failed**, but the directory containing the interrupted backup is not removed. You should remove any failed backup files. See your System Administrator for details.

### 16.2 History Database

The history database (HDB) is used to log all user and system activities as well as online and offline trend data. The history database guarantees storage of the following data:
- User activities in the system
- Alarms and their treatment
- What faults have occurred and handled as batch messaging
- Type of values logged in trend

**Backing up**

To prevent losing saved data, a manual data backup [→ 388] or an automatic data backup [→ 390] can be executed. For server failures or exchange, you can restore the last backup to the project. For more information see **System Management Console (A6V10415491)**.

**Deleting Data**

To prevent history database overflow, the oldest data must be deleted periodically. This can be done either on time in Desigo CC or manually using the System Management Console. For more information see **System Management Console (A6V10415491)**.

---

**NOTE:**

Back up the data prior to manually or automatically deleting the history data.

---

### 16.2.1 Backing up Data

If no automatic data backup is set up, data can be backed up manually from time to time.
Backup History Database

NOTICE

Not enough disk space available
Insufficient storage capacity results in faulty data backup. Prior to starting a backup, check that at least 150 GB of available storage is available. Check whether sufficient storage capacity is available on the backup media.

- Verify there are sufficient user rights to back up history data.
1. In System Browser, select Management View.
2. Select Project > Management System > Servers > Main Server > History Database > Backup.
3. Click the Extended Operation tab.
   - The backup function properties display.
4. You can change the backup folder and file name as needed at Default Backup File and click Apply. Type the folder path as follows:
   - \[drive]\MyProject\Backups\HDB.bak
   - \MyComputer\Backups\HDB.bak
5. Click Start.
   - The process state goes to Planned during backup. After successful completion of the backup, the display changes to Successful Completed and also displays the backup date. The Last Backup information displays the backup folder and file name HDB.bak.

NOTE:
After successfully backing up the historical data, copy the file HDB.bak to an external storage media (server, DVD, and so on). The data can be restored in the event of an error. Siemens Industry, Inc. recommend always retaining the last three backups.
16.2.2 Automating Data Backup

You can create an automated backup of historical data using the Macro and Reaction Editor functions.

- The backup folder is available (see Backing up Data [➙ 388]).

1. In System Browser, select Application View.
2. Select Applications > Logics > Reactions.
3. Click the Reactions Editor tab.
4. Select Triggers > Time & Organization Mode expander and click Add.
5. Click anywhere on the row.
   - The dialog box to set the execution time displays.
6. Set the dates, days and time to execute the macro.
7. Select the Manual navigation check box to change the focus to Backup History.
8. In System Browser, select Applications > Logics > Macros > Backups > Backup History and drag the object to the Output expander.
9. Click Save As.
10. Type the name and description in their respective fields.
11. Click OK.

**NOTE 1:**
The Operational Status from Macro Backup History must be enabled to run automatic backups.

**NOTE 2:**
Since the older version is overwritten when creating the backup file, you must rename the backup file after creating it in order to retain multiple backup versions.

**NOTE 3:**
Siemens Industry, Inc. recommends saving history data on a daily basis.

**NOTE 4:**
Data backup and history data deletion must be coordinated. Thus, if a deletion interval of one day is defined, data must be backed up each day prior to deletion of history data (see Automatically Deleting Data Entries [➙ 391]).

**NOTICE**

Avoid Data Loss
Test the history backup functions including restoring the history database to the project.
- Having a backup is good.
- Having a restoration scenario is better.
- Having a complete backup, archiving, and restoration concept is perfect.
- Having tested the entire concept is excellent!
16.2.3 Automatically Deleting Data Entries

By enabling the **Delete Log Entries** function, old historical information can be automatically deleted from the history database (for details, see System Management Console A6V10415491). History data deletion can be specified for each individual data group.

![Diagram of data deletion process]

**NOTICE**

Deleting Historical data permanently deletes it; the historical data cannot be restored. Define automatic data backup (see Automating Data Backup [390]) to be carried out prior to deletion.

- You want to permanently delete unneeded data entries from the history database.

1. In System Browser, select **Management View**.
2. Select **Project > Management System > Servers > Main Server > History Database > Archive Groups > [Data group]**.
3. Click the **Operation** tab.
   - **Minimal retention span** defines the minimum length of the time period and **Max retention span unit** defines the associated unit.
   - **Minimal retention count** defines how many entries still exist in the History Database after each deletion (see document System Management Console A6V10415491). Type 0 if you do not want to limit the entries.
4. Click the **Extended Operation** tab.
   - The properties for the corresponding data group display.
5. Type the following data and confirm with **Set**:
   - **Delete schedule start** defines the first time to delete data.
- **Delete schedule period** defines the length of the time interval and **Delete schedule period units** defines the associated unit.  
  **NOTE:** The greater the interval, the more data is saved during the maximum time span.

- **Maximal retention span** defines the maximum length of the time period and **Max retention span unit** defines the associated unit.

- **Maximal retention count** defines how many entries still exist in the History Database after each deletion (see document *System Management Console A6V10415491*). The default value of 999,999,999 applies if you do not want to limit the entries.

6. Click **Enable** to enable the process.

  - Deletion is defined for the applicable data group and starts as per the defined date and time setting.

<table>
<thead>
<tr>
<th>Setting Examples for Storage by Days</th>
</tr>
</thead>
<tbody>
<tr>
<td>Max retention time of data in the HDB</td>
</tr>
<tr>
<td>-------------------------------------</td>
</tr>
<tr>
<td>30 days</td>
</tr>
<tr>
<td>90 days</td>
</tr>
<tr>
<td>180 days</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Setting Examples for Storage by Number of Entries</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database</td>
</tr>
<tr>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>SQL Server Express</td>
</tr>
<tr>
<td>SQL Server</td>
</tr>
</tbody>
</table>

For more information on calculating the database size and time span, see Values and Data Capacity Settings [394].

**NOTE:**
No additional historical data is deleted if deletion is disabled with **Disable**.
2a. The start date is in the past: When re-enabling with **Enable**, the historical data outside the defined time period is immediately deleted.
2b. The start date is once again set to the future: When reenabled with **Enable**, deletion starts as per the defined data and time setting.

### 16.2.4 Checking the Database Size

1. In System Browser, select **Management View**.

2. Select **Project > Management System > Servers > Main Server > History Database > Tables**.

3. Click the **Extended Operation** tab.

  - The data size properties display.

<table>
<thead>
<tr>
<th>Database size</th>
<th>Displays the amount of storage used for the entire database in MB.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Log size</td>
<td>Displays the storage used for the applicable data.</td>
</tr>
</tbody>
</table>
### 16.2.5 Creating an Alarm Message

Set up optional monitoring for the History Database.

1. Click **Operating**.
2. In System Browser, select **Management View**.
3. Select **Project > Management System > Servers > Main Server > History Database**.
4. Click the **Object Configurator** tab.
5. In the Properties expander, select **DB_Size**.
6. In the **Alarm Configuration** expander, select **Management Station**.
7. Select **Continuous** from the **Alarm kind** drop-down list.
8. In the **Alarm** column, define the **alarm limit** in dependence of the database size used. For example, **> 8000 (MB)** and enter an event text **History Database Size Reached**.
9. Select the **Alarm config. activated** check box.
10. Click **Save**.

History Database monitoring is created and enabled. The check box in the **MS** column is selected.

**NOTE:**
When the History Database is 95% full, an alarm message displays. Normally, **Emergency Delete 1** is already executed when the database is this full and nothing else needs to be done. A visual check of the database size (per data group) can be carried out using the **System Management Console**.
16.2.6 **Troubleshooting**

The following error messages from the history database may occur and are displayed in Desigo CC:

- History Database is not operating.
- You have sufficient rights to start the System Management Console.

1. Exit the Desigo CC program.
2. Start **System Management Console**.
3. Click **Stop**.
   - The database stops.
4. Check whether the corresponding History Database is linked to the project.
5. Click **Start**.
   - The database starts.
6. Restart the Desigo CC program.
7. Check the program to ensure proper operation.

**NOTE:**
Contact your database administrator or local partner support if problems continue to occur with the history database.

16.2.7 **Values and Data Capacity Settings**

The following tables provide general guidelines for the various data volumes that are possible in a History Database while operating prior to executing an emergency delete. An average value of 0.4 KB per data entry is assumed to calculate the database storage used. The effective number of saved data entries may be higher than indicated in the tables.

The applied settings depend strongly on the maximum entries per day, data group, legal regulations, and SQL Server used (maximum of 10 GB for SQL Server Express or 250 GB for SQL Server).

**NOTE:**
SQL Server Express is not suitable if you anticipate a large amount of data as well as using **Minimal retention span**.
Settings with Maximum Timeframe Only

<table>
<thead>
<tr>
<th>DB-Size</th>
<th>HD-Size Reserved</th>
<th>Minimal Retention Span</th>
<th>Max. Ret. Count</th>
<th>Maximal Retention Span</th>
<th>Delete Period</th>
<th>Rows per Day</th>
<th>Size per Day</th>
<th>DB-Size Used Dependant on Maximal Retention Span</th>
</tr>
</thead>
<tbody>
<tr>
<td>10 GB</td>
<td>30 GB</td>
<td>10 days</td>
<td>0</td>
<td>1 month</td>
<td>999,999,999</td>
<td>1 day</td>
<td>1'000</td>
<td>0.4 MB</td>
</tr>
<tr>
<td>10 GB</td>
<td>30 GB</td>
<td>10 days</td>
<td>0</td>
<td>1 month</td>
<td>999,999,999</td>
<td>1 day</td>
<td>10'000</td>
<td>4 MB</td>
</tr>
<tr>
<td>10 GB</td>
<td>30 GB</td>
<td>10 days</td>
<td>0</td>
<td>1 month</td>
<td>999,999,999</td>
<td>1 day</td>
<td>100'000</td>
<td>40 MB</td>
</tr>
<tr>
<td>10 GB</td>
<td>30 GB</td>
<td>10 days</td>
<td>0</td>
<td>1 month</td>
<td>999,999,999</td>
<td>1 day</td>
<td>1'000'000</td>
<td>400 MB</td>
</tr>
<tr>
<td>10 GB</td>
<td>30 GB</td>
<td>10 days</td>
<td>0</td>
<td>3 months</td>
<td>999,999,999</td>
<td>1 day</td>
<td>1'000</td>
<td>0.4 MB</td>
</tr>
<tr>
<td>10 GB</td>
<td>30 GB</td>
<td>10 days</td>
<td>0</td>
<td>3 months</td>
<td>999,999,999</td>
<td>1 day</td>
<td>100'000</td>
<td>40 MB</td>
</tr>
<tr>
<td>10 GB</td>
<td>30 GB</td>
<td>10 days</td>
<td>0</td>
<td>3 months</td>
<td>999,999,999</td>
<td>1 day</td>
<td>100'000</td>
<td>400 MB</td>
</tr>
<tr>
<td>10 GB</td>
<td>30 GB</td>
<td>10 days</td>
<td>0</td>
<td>3 months</td>
<td>999,999,999</td>
<td>1 day</td>
<td>1'000'000</td>
<td>400 MB</td>
</tr>
<tr>
<td>100 GB</td>
<td>300 GB</td>
<td>1 month</td>
<td>6 months</td>
<td>999,999,999</td>
<td>1 day</td>
<td>1'000</td>
<td>0.4 MB</td>
<td>180 x 0.4 = 72.0 MB</td>
</tr>
<tr>
<td>100 GB</td>
<td>300 GB</td>
<td>1 month</td>
<td>6 months</td>
<td>999,999,999</td>
<td>1 day</td>
<td>10'000</td>
<td>4 MB</td>
<td>180 x 4 = 720 MB</td>
</tr>
<tr>
<td>100 GB</td>
<td>300 GB</td>
<td>1 month</td>
<td>6 months</td>
<td>999,999,999</td>
<td>1 day</td>
<td>100'000</td>
<td>40 MB</td>
<td>180 x 40 = 7200 MB</td>
</tr>
<tr>
<td>100 GB</td>
<td>300 GB</td>
<td>1 month</td>
<td>6 months</td>
<td>999,999,999</td>
<td>1 day</td>
<td>100'000</td>
<td>400 MB</td>
<td>180 x 400 = 72000 MB</td>
</tr>
<tr>
<td>150 GB</td>
<td>450 GB</td>
<td>6 month</td>
<td>0</td>
<td>1 year</td>
<td>999,999,999</td>
<td>1 day</td>
<td>1'000'000</td>
<td>400 MB</td>
</tr>
<tr>
<td>150 GB</td>
<td>450 GB</td>
<td>6 month</td>
<td>0</td>
<td>1 year</td>
<td>999,999,999</td>
<td>1 day</td>
<td>1'000'000</td>
<td>400 MB</td>
</tr>
</tbody>
</table>

Settings by Number of Entries Only

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1 GB</td>
<td>3 GB</td>
<td>1 sec</td>
<td>0</td>
<td>100'000</td>
<td>99 years</td>
<td>2'300'000</td>
<td>1 day</td>
<td>0.5 GB</td>
</tr>
<tr>
<td>10 GB</td>
<td>30 GB</td>
<td>1 sec</td>
<td>1'000'000</td>
<td>99 years</td>
<td>23'000'000</td>
<td>1 day</td>
<td>9.0 GB</td>
<td></td>
</tr>
<tr>
<td>150 GB</td>
<td>450 GB</td>
<td>1 sec</td>
<td>10'000'000</td>
<td>99 years</td>
<td>350'000'000</td>
<td>1 week</td>
<td>135 GB</td>
<td></td>
</tr>
</tbody>
</table>

NOTE:
When applying settings, remember that an emergency delete occurs at 90% of database capacity.

Use the following table if the data volumes must be more precisely calculated.

<table>
<thead>
<tr>
<th>Data group</th>
<th>KB per data entry</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time Series</td>
<td>0.057</td>
</tr>
<tr>
<td>Activity log</td>
<td>0.37</td>
</tr>
<tr>
<td>Alarm Log</td>
<td>0.38</td>
</tr>
<tr>
<td>Incidents</td>
<td>0.21</td>
</tr>
</tbody>
</table>
Appendix A: Client Profiles Extensions

The Client Profile is a configuration that can be applied to an individual user or station. The selected Client Profile determines the appearance and behavior of the Summary bar, Event List, and other system functions involved in handling alarms. A basic set of Client Profiles is included with the Desigo CC platform software. For more information about these, see the relevant sections in Alarm Management \[70\]. Additional Client Profiles, designed to meet specific needs, can be installed as an extension module.

DMS_AT Extension

The DMS_AT extension includes the following Client Profiles for Austria:

- F_AT (Fire)
- S_AT (Security)
- FS_AT (Fire and Security)

<table>
<thead>
<tr>
<th>DMS_AT Client Profiles</th>
<th>F_AT</th>
<th>S_AT</th>
<th>FS_AT</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Summary bar</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Start expanded. The operator cannot collapse it.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Summary bar lamps (event indicators)</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>● Fire Alarm</td>
<td>● Alarm</td>
<td>● Fire Alarm</td>
<td></td>
</tr>
<tr>
<td>● Fire Fault</td>
<td>● Fault</td>
<td>● Fire Fault</td>
<td></td>
</tr>
<tr>
<td>● Fire Control</td>
<td>● Information</td>
<td>● Fire Control</td>
<td></td>
</tr>
<tr>
<td>● Fire Information</td>
<td>● Isolation</td>
<td>● Fire Information</td>
<td></td>
</tr>
<tr>
<td>● Fire Isolation</td>
<td></td>
<td>● Fire Isolation</td>
<td></td>
</tr>
<tr>
<td><strong>Audio alert</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>The operator can temporarily mute the audio alert. The sound is automatically re-activated after 24 hours.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Event Detail bar</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Not available.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Event List availability, background, and behavior</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Starts collapsed to an Event bar on the left side of the screen, and is always visible. The operator can expand/collapse Event List.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>The operator can:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>● Expand/collapse Event List.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>● Resize the columns, change the position of the columns, customize how the columns display, and restore default columns layout.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>● Tag/untag events.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>The background color matches the event category color. When the operator selects an event, the background color becomes of a darker shade, and alarm-handling commands display (if available).</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>The following columns may also be available: Name, Alias, Description [View], and Location [View].</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Size of alarm-handling commands</strong></td>
<td>Small</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Default event sorting</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>● Unprocessed before unreset events</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>● Unreset before acknowledged events</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Appendix A: Client Profiles Extensions

#### DMS_AT Extension

- Oldest event on top
  - The operator cannot change default event sorting.

#### Event grouping

- Events belonging to the same source and category display grouped under a parent event (recurring events).
- The operator can display any recurrences for those events by clicking the Counter column in Event List.

#### Out of filter

- The system automatically removes any applied filter when a new event occurs that does not match the event filter criteria.

#### Start Fast Treatment

- Click on an event button or event descriptor.

#### Start Investigative/Assisted Treatment

- Double-click on an event button.

---

### DMS_AT Categories

<table>
<thead>
<tr>
<th>Category Name</th>
<th>Color</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>English Text</strong></td>
<td><strong>German Text</strong></td>
<td><strong>Notes</strong></td>
</tr>
<tr>
<td>Fire Alarm</td>
<td>Brandalarme</td>
<td>Red</td>
</tr>
<tr>
<td>Fire Fault</td>
<td>Brandstörungen</td>
<td>Yellow</td>
</tr>
<tr>
<td>Fire Control</td>
<td>Brandsteuerungen</td>
<td>Green</td>
</tr>
<tr>
<td>Fire Information</td>
<td>Brandmeldungen</td>
<td>Blue</td>
</tr>
<tr>
<td>Fire Isolation</td>
<td>Brandabschaltungen</td>
<td>Orange</td>
</tr>
<tr>
<td>Alarm</td>
<td>Alarme</td>
<td>Red</td>
</tr>
<tr>
<td>Fault</td>
<td>Störungen</td>
<td>Yellow</td>
</tr>
<tr>
<td>Information</td>
<td>Meldungen</td>
<td>Blue</td>
</tr>
<tr>
<td>Isolation</td>
<td>Abschaltungen</td>
<td>Orange</td>
</tr>
</tbody>
</table>