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About this document

About this document
Purpose
This manual is intended as a guide to the installation and configuration procedures for
the integration of DLCS Access Control system in the MM8000 Management Station
and MK8000 OPC server. It presents the MM8000 add-on module for this type of
subsystems.
This guide is part of the general DMS8000 engineering documentation set which
includes the Composer Technical Manual, the other DMS8000 Connectivity Guides
(the complete list includes: Network, Fire, Intrusion, Access Control, Video, and OPC),
and the Installation, Configuration, and Commissioning manual (ICC) for each specific
product.

Scope
This document applies to the MM8000 Management Station MP4.15 and higher.

Target audience
This documentation is intended for the following users:


Project Managers



Project Engineers



Commissioning Personnel

It is assumed that individuals performing the operations described in this manual have
prior expertise and training in the field of safety and security, at least a moderate level
of familiarity with the Siemens Building Technologies product line, and experience with
the installation, configuration, and commissioning of security management systems.

Documentation resource information
The DMS8000 Documentation Resource Information and Glossary Guide assembles
important information regarding documentation resources. This document contains the
following:


Comprehensive definitions of the target audiences for Siemens FS DMS
documents



Training program information including the Siemens intranet link



A complete list of all available DMS8000 documents



Instructions for how to obtain a document via the Siemens intranet using the
Siemens Asset Portal



A map of relevant documents for each target audience group



Customer Support links & resources



A glossary containing definitions of all terms and acronyms used in DMS8000
documentation

To access the DMS8000 Documentation Resource Information and Glossary Guide
(document no. A6V10089056), go to the link and follow the document search
instructions below:
http://assetportal.bt.siemens.com/portal/index.html
1. In the Search column on the left, set:
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-

Segment: 04 Fire -3F

-

Document Type: All

-

Image Type: All

-

Advanced search criterias: Select Brochure No. and enter the document
number to search for (A6V10089056). Alternatively, select Title and enter the
product name (DMS8000).

2. Click Search to start.
3. In the resulting area on the right, click on Contents link to show the list of search
results.
For more information such as Siemens news and announcements, visit the STEP Web
portal at:
https://workspace.sbt.siemens.com/content/00001123/default.aspx

Operational and safety regulations
Before groups of persons begin work on the system, they must have read and
understood the Safety Regulations [➙ 7] section in this manual.

Liability disclaimer for damage or injuries
Before products are delivered, they are tested to ensure they function correctly when
used properly. Siemens disclaims all liability for damage or injuries caused by the
incorrect application of the instructions, or the disregard of danger advisories. This
disclaimer applies in particular to personal injuries or damage caused by:


Improper and/or incorrect use.



Disregard of safety instructions in the documentation or on the product.



Poor maintenance or a lack of maintenance.

We have checked the contents of this manual for agreement with the hardware and
software described. Since deviations cannot be precluded entirely, we cannot
guarantee full agreement. However, the data in this manual are reviewed regularly and
any necessary corrections are included in subsequent editions. Suggestions for
improvement are welcome.

Copyrights and registered trademarks
Brand or product names mentioned in this document may be names protected by
copyright law or registered trademarks of other companies. These are mentioned only
for identification purposes and have no recommendatory character in regard to the
product or manufacturer, unless otherwise stated.

Documentation Conventions
The following table lists conventions to help you use this document in a quick and
efficient manner.
Convention

Examples

Numbered Lists (1, 2, 3…) indicate a
procedure with sequential steps.

1. Turn OFF power to the field panel.
2. Disconnect the power cord.
3. Open the cabinet.
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One-step procedures are indicated by a bullet
point.



Expand the Event List.

Conditions that you must complete or must be
met before beginning a procedure are
designated with a ⊳.
Results, after completing a step or at the end
of the entire procedure, are designated with a
⇨.

⊳ The report you want to print is open.

Bold font in a procedure indicates something
you should select or type.

Type F for Field panels.
Click OK to save changes and close the dialog
box.

Menu paths are indicated in bold.

Select File > Text, Copy > Group, which
means from the File menu, then select Text,
Copy and finally Group.

Error and system messages are displayed in
Courier New font.

The message Definition successfully
renamed displays in the status bar.

Italics are used to emphasize a term.

The Open Processor continuously executes a
user-defined set of instructions called the
control program.

1. Click the Print icon

.

⇨ The Print dialog box appears.
2. Select the printer and click Print.
⇨ The print confirmation appears.

This symbol signifies a Note. Notes provide
additional information or helpful hints.
Caution

This is a Caution message and indicates that
minor or moderate injury or property damage
may occur if a procedure is not followed.

Warning

This is a Warning message and indicates that
a serious injury or a severe equipment and
property damage may occur if a procedure is
not followed.

Cross references to other information in
printed material are indicated with an arrow
and the page number, enclosed in brackets:
[→92]

For more information on creating flowcharts,
see Flowcharts [→92].

Modification index
Note: For versions more than four years old, please visit the Siemens Asset Portal.
Version

Date

Notes

A6V10067792_a_en

06.2009

DMS8000 4.20.
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1 Safety regulations
This section describes the danger levels and the relevant safety regulations applicable
to the use of the products described in this manual. Please read the following work
instructions as well as the preceding section About this document thoroughly before
beginning any work.

1.1

Country-specific standards
Siemens products are developed and produced in compliance with the relevant
international and European safety standards. Should additional country-specific, and/or
local safety standards or regulations concerning project planning, installation, and/or
operation of the product(s) apply, then these standards and/or regulations must also be
taken into account, in addition to the safety regulations mentioned in the product
documentation.

1.2

1.3

Commissioning and testing


Activate security-, fire- and third party systems or devices only in the presence of
the person responsible.



Abide by the safety regulations of the connected sub-systems when working on
management stations. This especially applies when switching-off system
components.



Inform people before the testing of alarm devices; take the possibility of panic
reactions into account.



Inform the alarm and fault receiving stations connected to the system before
carrying out any tests.

Modifications to system design and products
Modifications to a system or to individual products may cause faults or
malfunctioning.
Please request written approval from Siemens Building Technologies, FS-DMS, and
the relevant authorities concerning intended system modifications and system
extensions.
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2 Introduction
DLCS Access Control
The DLCS (Door Light Control System) can monitor and control the state of doors and
detect the related alarm states. Also, a control command may be optionally available
for unlocking doors. The MM8000 can receive the door states/alarms and issue control
commands (unlock door) by means of a networked OPC server (Siemens WinCC V6.0
SP2).
The MM8000 can communicate with DLCS by means of a networked OPC server
(Siemens WinCC V6.0 SP2), which provides as many as 3 OPC items to represent the
conditions of each door. The item list includes:


Door status (open/closed)



Door alarm (normal/alarmed)



Door control command (unlock, optional)

The OPC items can be imported in Composer using a WinCC export file. Then, the
items should be manually linked to the door objects in order to build up the Composer
tree that can map the actual door state.


More than one OPC link can be supported, each one requiring the configuration of
a DLCS node in Composer.
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3 Installation
The add-on package is provided in the MM8000 product DVD as add-on. It can be
installed using the standard Add-on Manager.

3.1
3.1.1

Software installation
Software License
MM8000 license must include specific items for the add-on and for the OPC Driver.
Therefore, the required license includes:


WW8000 Composer (project configuration and download): Composer License or
Service key



MM8000 core, no. of subsystems and points
This license should include the number of OPC subsystems and points



OPC Driver license

Other licenses, covering more MM8000 options, may or may not be used and they are
not related to the add-on module support.

3.1.2

Installing the Add-on module
The following are the installation procedures for the add-on module.
1. Start the Add-on Manager.
-

From the Windows Start menu, select the following:
Start > DMS8000 > Tools > Add-on Manager
 The Add-on Manager window appears.
2. In the list of MM8000 Add-Ons/Name, select the name of the module you wish to
install
-- OR – (if the name of the add-on is not in the list on the screen):
click Browse, locate the installation files of the add-on module, and select the text
file (Extension Product Name.txt) in the root folder.
3. If your installation includes a customized MM8000 internal account, then deselect
the check box Use default MM8000 User account and specify the customized
username and password.
Note: For information about the MM8000 Internal Account, refer to MM8000
internal user account section of the MM8000 ICC, doc.no. A6V10062413_a_en.
4. Click Install (or Update if a previous version was detected).

3.1.2.1

Multiple add-on’s installation
In general, it is possible to install multiple add-on packages and benefit of their
combined functionalities. However, specific incompatibilities might exist. Please check
about possible problems in the documentation of all add-on modules that must be
installed.
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3.1.3

Removing the Add-on module
Add-on module cannot be uninstalled.
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4 Configuration
4.1

Configuration checklist
Verify that you have satisfied the items needed in the first checklist before proceeding
to the configuration checklist that follows.

Items needed for configuration


The general system architecture and the number of WinCC connections that will
require configuration for each DLCS unit.



For each DLCS, the list of doors and the associated OPC items in WinCC



The WinCC export file including all the DLCS items



Plug-ins needed:
–

#252301 (ND Dlcs/ST ND OPC)

–

#353901 (DLCS/STDLCS2)

Note: Plug-ins are installed during the software setup procedure. You can check that
the Plug-ins are actually available using the Composer Plug-in Installer in the
DMS8000 start menu.

Configuration overview
1. Add the DLCS driver.
2. Add the folder for the DLCS system.
3. Add the DLCS node.
4. Link the DLCS node to the OPC driver.
5. Set the server computer name or IP address.
6. Import the WinCC OPC items.
7. Set the PC items property.
8. Add the door nodes.
9. Link the OPC items to the door nodes.
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4.2

Configuration procedure
The following are the configuration procedures for a DLCS unit.

Adding the OPC driver
1. Open the Composer project.
2. If not already done, add the OPC driver:
In the MM8000 physical configuration, select the main station name and then the
Channel Collection.
Supervisor System Settings > MM8000 System > Physical configuration > <Station
name> > Channels Collection
3. Click the ND Dlcs icon

to add the OPC driver required for DLCS/WinCC.

Adding the OPC driver

 A new node is added. No further configuration is required for the OPC driver.

Adding the folder for the DLCS system


Optionally, create a folder for the DLCS unit.

Adding the DLCS node
1. Select the new folder.
2. Click the Access Control menu folder icon
3. Select the DLCS icon

.

to add a new DLCS node.
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Adding the DLCS node

 A new DLCS node is added to the Composer tree.
Note: You can customise the default name of the new node typing in a new name in
the Description field of the Node tab.

Linking the DLCS node to the OPC driver
1. Select and expand the Channels collection of the main station.
2. Select DLCS node.
3. Drag-and-drop the DLCS node to the OPC Driver node.

Linking DLCS node to the OPC Driver
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Setting the server computer name or IP address
1. Select and expand the Channels collection of the main station.
2. Select and expand the OPC Driver node.
3. In the Node tab, set the Remote server name or IP address.
By default, the field is set with the local IP address.
Note that the next field (WinCC server name) contains by default the standard WinCC
settings. Do not modify the default value.

Setting server computer name or IP address

In case of network-distributed solutions, be aware that DCOM security must be
configured in order to enable the correct communication over the network.
In general, the MM8000 internal user (→ see MM8000 Installation, Configuration, and
Commissioning manual) must be recognised by the server (i.e. defined locally on the
server computer or at domain level) and granted the DCOM permissions for the
WinCC process (DCOMCNFG settings).
Also, the computer running MM8000 should be configured in order to grant access
the user of the WinCC server.
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Importing the WinCC OPC items
1. Select and expand the DLCS node.
2. Select the Namespace node.
3. Select Tools > Import in the Composer menu.

 After a confirmation request, the software presents a browsing window to
search for the file to import (a file with extension CSV is expected).
4. Locate the CSV file and click Open.
 In a few moments, the OPC items are imported in the Composer tree.
Selecting the Import tab results in a page report being displayed. This page contains
the detailed logs of the latest import procedure, including all the added or removed
objects.

CSV files can be re-imported after a configuration change. Note the behaviour of the
import procedure:
- New objects in CSV (not configured in Composer) are added to the configuration.
- Old objects in CSV (already configured in Composer) are updated.
- Removed objects in CSV (configured in Composer) are removed.

Setting the OPC items property
The OPC items should be configured to set the type of item in relation to the DLCS
application. The type can be:


Unused



Door Status



Door Alarm



Door Open Command

In order to set the item type, proceed as follows:
1. Select and expand the Namespace node.
2. Select the first OPC item used by DLCS, and click the Node tab.
3. In the Item Type drop-down list, set the Item Type.
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4. Repeat steps 2 and 3 for the remaining items used by DLCS.

Setting the item type on the Node tab

Note: If you are familiar with the Composer tool, select the Children tab of the
Namespace node. At this point, you can quickly set the item types in the spreadsheet
page.

Setting the item types on the Namespace Children tab

Adding the door nodes
1. Select and expand the DLCS node.
2. Select the Doors Folder.
3. Click the Door icon

to add a new door.

 A new Door node is added to the Composer tree.
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Adding a new door

Note: You can customise the default name of the new node typing in a new name in
the Description field of the Node tab.

Linking the OPC items to the door nodes
1. Select and expand the DLCS node.
2. Select and expand the Namespace node.
3. Select and expand the Doors folder.
4. Drag and drop the OPC items to the corresponding door.

Linking OPC items in the Composer tree

Note: If you are familiar with the Composer tool, click the Children tab of the
Namespace node. At this point, you can select the three associated items (keep the
CTRL key pressed and click them all) and then drag and drop them together to the
corresponding door node.
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Linking OPC items from the Namespace Children tab

WARNING
Each door requires a link to at least two items (Door Status and Door Alarm),
whereas the third item (Open Command) may or may not be present depending on
whether the door can be remotely unlocked or not.
Door nodes that are nor properly linked to two or three OPC items will not be
downloaded (an error message will display during the download procedure).
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