Desigo™ Insight
Operating the management station, V6.0 SP3
User’s guide, Volume 1
## Contents

1. **About this document** ................................................................. 6
    1.1 Before you start ................................................................. 6
    1.1.1 Trademarks ................................................................. 6
    1.1.2 Copyright ................................................................. 6
    1.1.3 Quality assurance ....................................................... 6
    1.1.4 Document use/request to the reader ................................. 7
    1.1.5 Other important documents ........................................... 7
    1.2 Document validity ............................................................. 7
    1.3 Target readers .................................................................. 7
    1.4 Document conventions ..................................................... 8
        1.4.1 Symbols used .......................................................... 8
        1.4.2 Typographical conventions ....................................... 8
    1.5 Document structure ........................................................... 10
2. **Security** ............................................................................. 12
    2.1 Cyber Security Disclaimer .................................................. 12
3. **System overview** ................................................................. 13
    3.1 Features of the system philosophy ....................................... 13
    3.2 General system topology .................................................... 13
    3.3 Software architecture ....................................................... 14
    3.4 SQL database (password guidelines) ...................................... 14
    3.5 List of Desigo Insight programs .......................................... 14
    3.6 User access philosophy ..................................................... 16
4. **General operation** ................................................................. 18
    4.1 Conventions and style ....................................................... 18
    4.2 Desigo Insight installation modification ............................... 19
    4.3 User privileges ............................................................ 21
    4.4 Using Help and ToolTips ................................................... 21
    4.5 Working with the Desigo Insight program window ................. 22
    4.6 Automatic third-party program start based on time ............... 23
    4.7 Navigate between programs ............................................... 23
    4.8 Close application ............................................................ 24
    4.9 Operate the Desigo Insight programs ................................... 25
        4.9.1 Personalize the workspace ...................................... 25
        4.9.2 Common program elements ...................................... 25
        4.9.3 Working with the System Browser ......................... 26
        4.9.4 View data ........................................................... 27
        4.9.5 Set up the workspace for Alarm Viewer and Log Viewer 32
        4.9.6 Locate log entries in the System Browser tree ............. 33
        4.9.7 Print from programs .............................................. 39
5. **Start Desigo Insight** ........................................................... 41
    5.1 Start Desigo Insight .......................................................... 41
    5.2 Login ............................................................................ 42
    5.3 Configure taskbar ........................................................... 43
    5.4 Display system and version information ............................. 44
5.5 Manually connect/disconnect a site ...................................................... 46
5.6 System time ......................................................................................... 49
5.7 Start programs manually ................................................................. 51
5.8 Create and delete user ...................................................................... 52
5.9 Lock .................................................................................................... 54
5.10 Logoff .................................................................................................. 55
5.11 Shut down Desigo Insight ............................................................... 56
5.12 Restart Desigo Insight...................................................................... 57
5.13 Desigo Insight terminal server .......................................................... 57
5.13.1 Connect to the terminal server ..................................................... 58
5.13.2 Start Desigo Insight (Remote Desktop) .......................................... 59
5.13.3 Desigo Insight service .................................................................... 59
5.13.4 Disconnect connection to terminal server ........................................ 61
6 Working with the Object Viewer ........................................................ 62
6.1 Display detailed data point information from the Object Viewer ......... 67
6.1.1 Change object values and properties from Object Viewer ............. 71
6.1.2 Override outputs ............................................................................. 71
6.1.3 Enable outputs ............................................................................... 73
6.1.4 Override inputs ............................................................................... 74
6.1.5 Edit Notification Class .................................................................... 74
6.1.6 Change comment required ............................................................. 74
6.1.7 Change user designation text.......................................................... 75
6.2 Instruction texts to create alarms....................................................... 76
7 Operate graphics ............................................................................... 79
7.1 Layout of the Plant Viewer screen .................................................... 79
7.2 Help in Plant Viewer .......................................................................... 79
7.3 The navigation bar and the context menus ........................................ 80
7.4 Display/hide the navigation bar ......................................................... 83
7.5 Open graphics pages .......................................................................... 84
7.6 Components of the graphics pages .................................................. 85
7.7 Graphics operation principles ........................................................... 87
7.8 Add comments to pages .................................................................... 88
7.9 Status indication in Plant Viewer ....................................................... 88
7.10 Handle alarms in the Plant Viewer ................................................... 90
7.11 Modify object and property values in Plant Viewer ......................... 91
7.12 Display properties of symbols, genies, and graphics pages .............. 94
7.13 List object properties for a graphics page ....................................... 95
7.14 Print from the Plant Viewer ............................................................. 95
7.15 Navigate to other Desigo Insight programs via object or property name (Send To...) .......................................................... 97
7.16 Exit the Plant Viewer ........................................................................ 100
8 Alarm handling ................................................................................ 101
8.1 Principles of alarm handling ........................................................... 101
8.2 Alarm handling-related Desigo Insight applications ......................... 105
8.3 What happens when an alarm occurs .............................................. 108
8.3.1 Alarm suppression ......................................................................... 111
8.4 Alarm Viewer: General operation ................................................... 112
8.5 Adjust the alarm handling system ....................................................... 115
8.6 Route alarm messages to output devices ........................................... 115
8.7 Alarm configuration with System Configurator .................................. 117
8.8 Routing alarms using the Alarm Router .......................................... 137
8.8.1 Alarm Router functions ............................................................. 137
8.8.2 Edit routing groups ................................................................. 138
1 About this document

1.1 Before you start

1.1.1 Trademarks

The trademarks used in this document are listed together with their legal owners in the table. The use of these trademarks is subject to international and national statutory provisions.

<table>
<thead>
<tr>
<th>Trademarks</th>
<th>Legal owner</th>
</tr>
</thead>
<tbody>
<tr>
<td>CitectSCADA™</td>
<td>Schneider Electric (Australia) Pty Limited see citect.com</td>
</tr>
<tr>
<td>Microsoft …</td>
<td>Microsoft Corporation see <a href="http://www.microsoft.com/TRADEMARKS/t-mark/nopermit.htm">http://www.microsoft.com/TRADEMARKS/t-mark/nopermit.htm</a></td>
</tr>
<tr>
<td>Windows 7</td>
<td></td>
</tr>
<tr>
<td>Windows 10</td>
<td></td>
</tr>
<tr>
<td>Windows Server 2012</td>
<td></td>
</tr>
<tr>
<td>Windows Server 2016</td>
<td></td>
</tr>
<tr>
<td>SQL Server 2014</td>
<td></td>
</tr>
</tbody>
</table>

All the product names listed in the table are trademarks (™) or registered trademarks (®) of their respective owners, as listed in the table. Further to the notes in this section, and to facilitate the reading of the text, these trademarks will not be indicated elsewhere in the text (e.g. by use of symbols such as ® or ™).

1.1.2 Copyright

This document may be duplicated and distributed only with the express permission of Siemens, and may be passed only to authorized persons or companies with the required technical knowledge.

1.1.3 Quality assurance

These documents were prepared with great care.
- The contents of all documents are checked at regular intervals.
- All necessary corrections are included in subsequent versions.
- Documents are automatically amended as a consequence of modifications and corrections to the products described.

Please make sure that you are aware of the latest document revision date.

If you find any lack of clarity while using this document, or if you have any criticisms or suggestions, please contact your local POC at the nearest branch office. Addresses for Siemens RCs are available at www.siemens.com/sbt.
1.1.4  Document use/request to the reader

Before using our products, it is important that you read the documents supplied with or ordered at the same time as the products (equipment, applications, tools etc.) carefully and in full.

We assume that persons using our products and documents are authorized and properly trained and have the requisite technical knowledge to use our products as intended.

Additional information on products and applications is available:
- On the intranet (for Siemens employees only) at https://workspace.sbt.siemens.com/content/00001123/default.aspx
- At your next Siemens branch office www.siemens.com/sbt or at your system suppliers.
- From the support team in the headquarters fieldsupport-zug.ch.sbt@siemens.com if no local POC is available.

Siemens assumes no liability to the extent allowed under the law for any losses resulting from a failure to comply with the aforementioned points or for the improper compliance of the same.

1.1.5  Other important documents

Engineering manuals: For Siemens Building Automation experts or for authorized personnel only.

1.2  Document validity

This document is valid for the Desigo Insight management station software, Version 6.0.

Local differences in operation or processes may be caused by:
- Windows user rights.
- Windows terminal server user rights
- Network configurations.
- Operator security restrictions.
- Scope of purchased software.
- Engineering defaults for the plant.

1.3  Target readers

This document contains all information relevant to the user when operating the system.
1.4 Document conventions

1.4.1 Symbols used

**Caution**
Users with access can change or delete data. When you see the symbol to the left, data may be lost *irretrievably*.

**Tip**
The symbol to the left denotes information that helps you properly operate and use the programs. This information is based on experience; we strongly suggest that you observe all hints.

Important note:
Important information is printed on a gray background.

1.4.2 Typographical conventions

**Introduction**
The following conventions apply to this document for names of buttons, keys, and fields.

**Display of keyboard keys**
Keyboard keys are always printed in angle brackets < >.

Example: `<Shift>`, `<Shift + N>`

**Table of the keys used in this document:**

<table>
<thead>
<tr>
<th>Press key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift key</td>
<td><code>&lt;Shift&gt;</code></td>
</tr>
<tr>
<td>Enter</td>
<td><code>&lt;Enter&gt;</code></td>
</tr>
<tr>
<td>Control key (Ctrl)</td>
<td><code>&lt;Ctrl&gt;</code></td>
</tr>
<tr>
<td>Delete key</td>
<td><code>&lt;Del&gt;</code></td>
</tr>
<tr>
<td>Insertion key</td>
<td><code>&lt;Ins&gt;</code></td>
</tr>
<tr>
<td>Space key</td>
<td><code>&lt;Space&gt;</code></td>
</tr>
<tr>
<td>Backspace key</td>
<td><code>&lt;Backspace&gt;</code></td>
</tr>
<tr>
<td>Alt key</td>
<td><code>&lt;Alt&gt;</code></td>
</tr>
<tr>
<td>Arrow keys</td>
<td><code>&lt;Up&gt;</code>, <code>&lt;Down&gt;</code>, <code>&lt;Left&gt;</code>, <code>&lt;Right&gt;</code></td>
</tr>
<tr>
<td>Alt key plus key &quot;A&quot;</td>
<td><code>&lt;Alt + A&gt;</code></td>
</tr>
</tbody>
</table>

**Elements in the application window**
Application window elements are presented as follows:

**Element**
Dialog boxes, entry fields and tabs

**Description**
Names of dialog boxes, tabs, and fields in Windows are displayed in **bold**.

Example: In the **Numbers** dialog box...

**Input in fields**

Keyboard entries are always set in quotation marks "...

Example: Enter the **address** "http://www.msn.com" in the field.
The individual steps of instructions that must be performed in a specific order are separated by a >.

Example: **System** > **Meters** > right-click > **New Meter**.

This tells you to right-click the **Meter** command in the **System** menu and then select **New Meter** in the menu that opens.
Mouse click  
In command sequences, right-click and double-click are mentioned specifically. For all other cases, left-click the selections.

Context menus  
Right-clicking normally opens a context menu.

Date and time format  
Display of date and time depends on the settings of your Windows installation.
1. Select Start>Settings>Control Panel>Regional Settings.  
2. Select the Time tab in the Regional Settings dialog box to define the format.

1.5 Document structure

This document has the following structure:

1 Documentation  
Describes the documents conventions.

2 System overview  
This section gives the user an overview of the system philosophy and functions of Desigo Insight.

3 General operation  
This section takes the user through the general operation of the management station.

4 Start Desigo Insight  
This chapter describes how to start Desigo Insight and how to connect to the site.

5 Operating with Object Viewer  
This chapter describes the operation of project-specific data point lists.

6 Operating graphics  
This chapter describes the operation of project-specific graphical user interfaces.

7 Alarm handling  
Describes the options available to the user for processing and monitoring alarms.

8 Plant trend data  
This section describes the functions available for displaying, archiving and further processing of trend data from the system.

9 Time scheduling  
This section describes the possibilities for creating and modifying time programs.

10 Trend data
Describes the functions available for the logging of events and their retrieval by the user.

11 Report Viewer
This section describes the functions used to collate plant data to produce a report.

12 Event program (Reaction Processor)
This section describes the functions which influence events transmitted to or received from the system.

13 Scope
This section describes functions defining user-specific object access.

14 Eco Viewer
This section describes the functions used to assess a plant's efficiency.

15 Project backup
This chapter describes how to back up project data.

16 Frequently asked questions
Common questions relating to the Desigo Insight management station.

Conventions

"Operator"
The term "operator" (from the user's point of view) refers in this regard to a company that operates or maintains one or more buildings.

"User"
The term "user" refers to any person who uses the management station for day-to-day operation. By implication, a user is able to use Desigo Insight applications and a restricted set of system settings.

"Administrator"
The "administrator" is responsible for running the entire Desigo Insight installation on site. This responsibility includes assigning specific levels of password-protected access to the various users, and analyzing event data from the system.
2 Security

2.1 Cyber Security Disclaimer

Cyber security disclaimer

Siemens products and solutions provide security functions to ensure the secure operation of building comfort, fire safety, security management and physical security systems. The security functions on these products and solutions are important components of a comprehensive security concept.

It is, however, necessary to implement and maintain a comprehensive, state-of-the-art security concept that is customized to individual security needs. Such a security concept may result in additional site-specific preventive action to ensure that the building comfort, fire safety, security management or physical security system for your site are operated in a secure manner. These measures may include, but are not limited to, separating networks, physically protecting system components, user awareness programs, defense in depth, etc.

For additional information on building technology security and our offerings, contact your Siemens sales or project department. We strongly recommend customers to follow our security advisories, which provide information on the latest security threats, patches and other mitigation measures.

3 System overview

This chapter provides an overview of general, user-relevant aspects of Desigo Insight.

3.1 Features of the system philosophy

The Desigo Insight management station software is object-oriented and has a modular structure. It is based on a wide range of standard technologies including:

- SQL or SQL Server Express databases
- Custom reports created with Crystal Reports Professional
- Citect SCADA software for Plant Graphics and third-party integration
- Standard interfaces for integration of third-party software
- Viewer over Internet
- UTF-8 / ANSI X3.4 Protocol

3.2 General system topology

Desigo Insight offers a wide range of system topologies, so that it can be adapted to an unlimited number of individual requirements. For this reason, we can only provide a description of a general system topology.
3.3 Software architecture

The following images provide an overview of the internal structure of the Desigo Insight management station software.

3.4 SQL database (password guidelines)

Desigo Insight uses an SQL database to store data. Siemens requires you to change the default password to prevent Desigo Insight from becoming a target of hacker attacks (refer CM110591 Installation and configuration chapter 6.7.17 SQL System Administrator Password Management).

WARNING

The customer’s IT department is responsible for changing and securing the edited SQL data.
You cannot restore a lost password.

3.5 List of Desigo Insight programs

The management station software comprises all the modules required for efficient building automation and control.

Taskbar

Provides a quick system overview and can be used to launch any Desigo Insight application.

Plant Viewer

Plant Viewer provides a graphical representation of the areas of a building or buildings, and the associated mechanical and electrical building services. You can use the dynamic color graphics in Plant Viewer to monitor and operate the system.

Alarm Viewer

Detailed display of alarm messages for fast location and elimination of faults. The list of alarms is automatically updated whenever an alarm event occurs, so that it always contains the current alarm state of the system.
Alarm Router

Alarm Router dispatches the alarm messages to the selected receivers (e.g. printers, e-mail, fax, pagers or mobile phones).

Time Scheduler

Time Scheduler allows central programming of all time-controlled building services functions, including individual room control.

Trend Viewer

Historical and real-time processing of data, for convenient analysis of off-line and on-line trend data. Used to optimize plant operation.

Log Viewer

All user activities, alarms and faults are logged and can be displayed with Log Viewer for further analysis as required.

Audit Viewer

The database Audit Viewer allows you to check the log database's integrity. The functionality is described in CM110796, Audit trail for critical environments.

Object Viewer

Object Viewer provides an efficient means of navigating through the building automation and control system. Data objects are presented in different views and can be operated from Object Viewer.

Report Viewer

Report Viewer lets you document alarm states, log entries and data point states.

Reaction Processor

The Reaction Processor (event program) allows you to create automated reports or to modify the response of the plant (e.g. modify setpoints).

DB Import Utility

Used to import, update or delete engineering data from the automation and control system to the Desigo Insight system database. Import applied.

System Configurator

Tool for the general set-up of Desigo Insight management station. Create and change user rights as well as user scope.

RS Access

Displays online data from INTEGRAL automation station, in particular to change the time scheduler.

System Information

Displays plant state (devices, modems) as well as the management stations.

ECO Viewer

The information only indicates how efficiently your plant works. The plant must be engineered to display and enable the function.

Help

Desigo Insight online help.
3.6  User access philosophy

**Philosophy**

The management station software offers a highly flexible means of defining an environment ideally suited to each user. It is possible to specify which user(s) should be allowed access to which sites and buildings, and which Desigo Insight applications each operator may use.

Users in a building can be grouped logically according to their tasks (e.g. caretaker, building manager, maintenance engineer), each of these “user groups” having a dedicated set of privileges.

**Standby user**

After logoff, all background Desigo Insight activities continue, the connection is automatically maintained through a standby user. In the log database, the most recently logged in user is entered, not the standby user.

**Access privileges**

Desigo Insight has the following access rights:

**Access to applications**

A user group’s access to a Desigo Insight application can be defined by privileges individually assigned to all major functions of an application. Locked functions are displayed (inaccessible), but cannot be selected. Buttons associated with the locked functions are, however, not displayed in the taskbar. The application privileges for each user group also include the authorization to start and shut down an Desigo Insight application.

**Page access**

A user group’s access to the pages in Plant Viewer can be defined individually. Areas can be defined, to which pages can be assigned. Access to a defined area can then be enabled or disabled for a given user group. This makes it possible to split the plant responsibility between several operators.

**Site access**

A user group’s access to a site can be defined individually by assigning access privileges. The table below contains the privileges in ascending order (the smaller the value, the greater the privilege):

<table>
<thead>
<tr>
<th>Access level</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0: No access</td>
<td></td>
</tr>
<tr>
<td>1: Internal</td>
<td></td>
</tr>
<tr>
<td>2: Service</td>
<td>Administration</td>
</tr>
<tr>
<td>3: Standard service</td>
<td>SBT service staff and qualified plant technicians are part of this user group.</td>
</tr>
<tr>
<td>4: Administration</td>
<td>Administration</td>
</tr>
<tr>
<td>5: Expert</td>
<td>Service staff and persons responsible for plant operations are part of this user group. Service technicians must monitor and operate all control functions.</td>
</tr>
<tr>
<td>6: Standard mode</td>
<td>Plant operators and trained staff are part of this user group. These users are responsible for the plants.</td>
</tr>
<tr>
<td>7: Customer</td>
<td>Building operators and security staff are part of this user group. They operate and sometimes monitor the plants.</td>
</tr>
</tbody>
</table>

Each privilege includes all privileges from lower levels.
<table>
<thead>
<tr>
<th>Scopes</th>
<th>Freely definable scopes (e.g. range scope, discipline scope) allow for customizing project data views (e.g. lighting control visible only to electricians, not heating engineers).</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automation system access</td>
<td>The system can be set up to allow a variety of media (Ethernet, LON, PTP) access to the automation system.</td>
</tr>
</tbody>
</table>
4 General operation

4.1 Conventions and style

General

Desigo Insight is operated with the mouse. As a consequence, we do not make special reference to key commands. Unless otherwise stated, mouse and keyboard operation is based on the Windows 7 conventions.

Note

A mouse or other pointing device is always required. Desigo Insight cannot be operated from the keyboard only.

Mouse operation

The left mouse button is normally used to select or select an option.

Example:

If you are asked to select or select an entry in the list, this is an instruction to:

- Point to (i.e. place the cursor over) an entry and click the left mouse button.
  “Double-click an entry in the list” is an instruction to:
  - Point to (i.e. place the cursor over) an item in a list and click the left mouse button twice in quick succession.

Note

The instruction “Click” without further details always refers to a single click of the left mouse button (see below).

Example:

left-click

“Click OK” or “Click the OK button” is an instruction to:

1. Point to (i.e. place the cursor on) the OK button and click the left mouse button.

The instruction “Select File > Print…” or “Select Print … from file menu” means:

1. Point at File on the menu bar and left-click.
   The menu opens.
2. Point at Print on the menu bar and left-click.
   The command or function is executed.
The right mouse button is normally used to display context menus, (i.e. short-cut menus related to a specific item or area on the screen).

The instruction "Right-click Alarm Acknowledge in the Event column and select Filter by Alarm acknowledge" means:

1. Place the cursor over a selected Alarm Acknowledge entry (see below) and right-click to display the associated context menu, then
2. Left-click Filter by “Urgent” in the context menu.

Example:

Reference

For more detail on mouse operation in Plant Viewer graphics, refer to the section "Plant Viewer operation" in this manual.

Standard keyboard operation

When keyboard keys are referred to by name, the names are shown with an initial capital (e.g. "the Delete key"). Otherwise the keys are shown between angular brackets <…>.

A plus sign is used between keys to be pressed simultaneously.

Example:

<Alt>+<Ctrl>+<1> is an instruction to press all three keys simultaneously.

4.2 Desigo Insight installation modification

Step 1
Automatic windows login

Various modifications during installation are required for Desigo Insight to automatically restarts after a power outage.

Contact your IT Support for the required settings.

If you only want an automatic user logon, continue directly to step 2.

Step 2
Automatically Start Desigo Insight

First create a shortcut to Desigo Insight as follows:

1. Select the Desigo Insight symbol on the desktop.
2. Right-click and click Copy.
4. Click folder C:\Users\[Username]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\ Autostart.
5. Right-click and select Insert.

Note

The Insight.exe application in the folder Programs\Siemens\Desigo\Insight [version]\Bin is stored on your local hard drive.
1. Start Desigo Insight.
2. Logon as Administrator.
3. Click “System Configurator” on the Desigo Insight taskbar.
4. Create the user as a Windows login.
5. Click the No Password checkbox.
6. Click OK > OK.

1. Select Desigo Insight building automation and control system in the System Configurator Browser.
2. Right-click to open the properties dialog box.
3. Select Windows from the Authentication Mode list box.

1. In the System Configurator Browser, select the appropriate user group, e.g. BASIS GRUPPE.
2. Right-click Properties.
3. Select the Site Access tab.
4. Click checkboxes May establish connection and connect at user login.
5. Select the Programs tab.
6. Select the Plant Viewer and click the checkbox Program operates automatically after user login.
7. Click OK.
8. Close the System Configurator and exit Desigo Insight.

Note
After a power outage and automatic startup, the system is available for any user corresponding to the user profile. Enable the automatic management lock in the System Configurator and define a short lock-up period (ca. 5-15 minutes). The setting is located at: Desigo Insight Building Automation System > Desigo Insight Management Stations > Log On tab.
4.3 User privileges

**Scope**
Only authorized users have access to the Desigo Insight system. When you enter your user name and password, the system checks your user privileges to determine, for example, the programs to which you have access and the sites to which you can connect.

**No access**
If a user has not been assigned the necessary privileges to perform a given operation, this is indicated in one of the following ways:
- The associated menu option may be "grayed out" (dimmed).
- The associated menu option or button may be invisible to the user.
- The user may receive a message indicating that the operation cannot be performed.

4.4 Using Help and ToolTips

**Help system**
The help system in Desigo Insight is modeled on the standard help used in Windows 7.
Desigo Insight help covers the following:
- Online help.
- Project-specific help (depending on the project).
- Tool tip.

**Invoking on-line help**
Access Desigo Insight online help as follows:
1. Click the help button on the Desigo Insight taskbar. Opens the online help (AcrobatReader must be available).

![Image of help system](image-url)

2. Select the appropriate Section of the user's guide or enter a search term.

**Tool tip**
ToolTips are simple text labels which provide brief information about various items in a program.
They normally appear automatically when the cursor is pointed at a specific item on the screen. It describes buttons, symbols, etc.
Displaying ToolTips
Example:
Place the mouse pointer over one of the buttons on the Desigo Insight taskbar.

Reference
For more detail on special application of tool tips in Plant Viewer, refer to Chapter "Plant viewer operation" in this manual.

4.5 Working with the Desigo Insight program window

Basic principles
The Desigo Insight program windows are modeled on Microsoft Windows, and can be manipulated in the same way.

Menu bar
Toolbar
Close
Maximize
Minimize
Status bar

Minimize
1. Click Minimize in the upper right corner of the window.
The minimized program remains open, but appears in the form of a button on the Windows taskbar at the bottom of the screen.
OR
Right-click anywhere in the title bar of the program and select Minimize.

Restore
1. Click the program button on the Windows taskbar at the bottom of the screen.
The minimized program is restored to full size on the screen.

Resize
1. Place the cursor on the frame of the window. The cursor changes from a pointer to a double-headed arrow.
2. Holding down the left mouse button, drag the frame in either direction indicated by the arrow.
3. Release the mouse button to end the “resize” operation.
4.6 Automatic third-party program start based on time

It is possible to have your system configured so that one or more third-party programs start at a specified time. This could be useful for spreadsheet and analysis programs. You might, for example, want to run a spreadsheet program every Monday morning to check the hours-run readings from fans and pumps.

Tip

Ask your Desigo Insight expert to configure a program so that it starts automatically at a specified time.

4.7 Navigate between programs

There are three basic methods of switching between the various Desigo Insight programs:

<table>
<thead>
<tr>
<th>From</th>
<th>User action</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Desigo Insight taskbar</td>
<td>1. Click the desired program button.</td>
<td>Starts the selected Desigo Insight program.</td>
</tr>
<tr>
<td>Desigo Insight menu</td>
<td>1. Select Desigo Insight &gt; Desigo Insight Programs &gt; Plant Viewer</td>
<td>Starts the selected Desigo Insight program.</td>
</tr>
<tr>
<td>Windows taskbar</td>
<td>1. Click the application button (possible when application is already operating).</td>
<td>Displays the selected Desigo Insight application in foreground.</td>
</tr>
<tr>
<td>Context menu</td>
<td>1. Right-click to display context menu. 2. Select Send To … 3. Select the desire application from the list.</td>
<td>Switches to application (starts Log Viewer if it is not already running.). Different applications process the &quot;transferred&quot; object differently.</td>
</tr>
</tbody>
</table>

Tip

First check on the Windows taskbar to see whether the program you need is already open. If it is, simply click the program button.

Send to

This function is available in all Desigo Insight foreground programs. You can use it in the System Browser view of Object Viewer for example, to go directly to the Alarm Viewer program from an object signaling an alarm. Once in Alarm Viewer, you can obtain more information about the alarm and acknowledge or reset it.
1. Click the **Object Viewer** on the Desigo Insight taskbar.

2. Expand the view in System Browser until you can see all the relevant data points in the System View. Active alarms are indicated by a red alarm symbol on the relevant site, device and object icons.

3. Right-click the object symbol to display a context menu.

4. Point to **Send To >**.

5. Click the required program (in this case **Alarm Viewer**).

This operation launches the program if it is not already open. The alarm view is filtered by object (in other words, only alarms associated with the object is displayed).

Reference

For additional information on using the System Browser: Refer to chapter "Working with System Browser" in this manual.

**Example 2:**

**Alarm Viewer to Plant Viewer**

You can also use Send To, for example, to jump directly from an item selected in Alarm Viewer to its location in the plant graphics.

1. Open Alarm Viewer on the Desigo Insight taskbar.

2. If there is no tree structure displayed to the left of the alarm view, click the **System Browser** button.

3. Expand the tree view to locate the relevant sites. Active alarms are indicated by a red alarm symbol on the relevant site, device and object icons.

4. Right-click the object symbol to display a context menu.

5. Point to **Send To >**.

6. Click the required program (in this case **Plant Viewer**).

This operation launches the program if it is not already open. The Plant Viewer page containing the selected object is displayed.

### 4.8 Close application

**Prior to closing**

Before closing a program it is good practice to:

- Check that there are no pending alarms requiring attention.
- Save any data required for future reference
- Print any alarms, reports etc. which you may need for future reference.

**Close a program**

1. From the **File** menu, select **Exit**.

   OR

   Click in the **Close** box in the upper right corner of the program window.
4.9 Operate the Desigo Insight programs

4.9.1 Personalize the workspace

The programs in the Desigo Insight system allow you to personalize the workspace to suit your own preferences and specific needs. For example, you can:

- Move, resize or hide the program toolbars;
- Position the Desigo Insight taskbar at the top or bottom of the screen;
- Adjust the position and size of program windows;
- Choose to display or hide the program toolbar and status bar.

In Alarm Viewer, Log Viewer and Reaction Processor you can also:

- Define and save personal filter criteria;
- Define and save personal sort criteria;
- Select the columns to be displayed;
- Define the order and width of columns;
- Display/hide horizontal and vertical borders.

4.9.2 Common program elements

Common elements

The various Desigo Insight programs are designed to make operation easier by providing the same “look and feel” wherever possible. This section describes common elements of the following programs:

- Log Viewer
- Alarm Viewer
- Object Viewer
- Trend Viewer

Reference

For more information on Plant Viewer graphical user interface, refer to Chapter "Plant viewer operation" in this manual. Alarm Router is a part of the alarm handling system. Refer to the chapter “Alarm Handling” in this manual.

View

A Desigo Insight application window has the following elements:
4.9.3 Working with the System Browser

System Browser is an ideal tool for navigating through the various levels of your system. It provides comprehensive information about the automation and control system hierarchy in all the available sites. The information is displayed in a tree structure similar to that used in the Windows Explorer.

The System Browser simplifies a series of processes and makes it possible, for example to:

- Drag and drop data point objects to a view in Trend Viewer.
- Filter information by site, device or object in an alarm view or log view (see the "Alarm handling" and "Logging" sections of this manual).
- View and modify the values and properties of objects.
- Jump to a weekly time schedule or an exception schedule in the Time Scheduler.

For specific information on the use of System Browser in the various Desigo Insight programs, refer to the sections on the specific programs in this manual.

1. Click the buttons for:
   - Log Viewer
   - Alarm Viewer
   - Object Viewer
   - Trend Viewer
   - Time Scheduler

2. Click "Show/hide system browser" to display tree view.
4.9.4 View data

As is the case with System Browser in all other Desigo Insight applications, the user can decide whether to view the data using the Technical View, User View or System View.

Select view

System Browser provides two identical tree structures, in a format similar to that used in the Windows Explorer.

1. Select menu View > View.

Technical View

Selecting the Technical View gives you a generic view of the automation and control system.

e.g. Site: A’Ahu’FanEh’Cmd.FbVal.

User Designation View.

Choose the User View to display a hierarchical view of the project. The User View has a project-specific naming convention based on geographical location and type of equipment and plant. This hierarchical structure is engineered specifically for a project, and may not be available in all projects:

e.g.: Zurich, Oerlikon, CA1, CM3, VR01, C, CHA.

<table>
<thead>
<tr>
<th>Site</th>
<th>Hierarchy</th>
<th>User designation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Site independent</td>
<td>Region</td>
<td>Region Zürich</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Location</td>
<td>OrtOerlikon</td>
<td></td>
</tr>
<tr>
<td>Site dependent</td>
<td>Plant</td>
<td>CA1</td>
<td>Kitchen</td>
</tr>
<tr>
<td></td>
<td>Function</td>
<td>CM3</td>
<td>Air conditioning plant</td>
</tr>
<tr>
<td></td>
<td>Device</td>
<td>VR01</td>
<td>Extract air fan 1</td>
</tr>
<tr>
<td></td>
<td>Message</td>
<td>C</td>
<td>Switch-on command</td>
</tr>
<tr>
<td></td>
<td>Group</td>
<td>CHA</td>
<td>HVAC</td>
</tr>
</tbody>
</table>
The user view is individually created for each building automation system. It is otherwise empty if not engineered for your plant.

Desigo Insight supports variable or set user designations that can be defined individually for each site. Only one type can be defined for the site-independent part. The project determines which type is used in the project.

**Set**

<table>
<thead>
<tr>
<th>Object</th>
<th>Length</th>
<th>Length</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Min/Max</td>
<td>Min/Max</td>
<td>Min/Max</td>
</tr>
<tr>
<td>UD1</td>
<td>XXX</td>
<td>YYYY</td>
<td>ZZZ1</td>
</tr>
<tr>
<td>UD2</td>
<td>XXX</td>
<td>YYYY</td>
<td>ZZZ2</td>
</tr>
<tr>
<td>UD3</td>
<td>XXX</td>
<td>YYYY</td>
<td>ZZZ3</td>
</tr>
</tbody>
</table>

**Variable**

<table>
<thead>
<tr>
<th>Object</th>
<th>Length</th>
<th>Length</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Min/Max</td>
<td>Min/Max</td>
<td>Min/Max</td>
</tr>
<tr>
<td>UD1</td>
<td>XXX</td>
<td>YYYY</td>
<td>Z1</td>
</tr>
<tr>
<td>UD2</td>
<td>XXX</td>
<td>YYYY</td>
<td>ZZ2</td>
</tr>
<tr>
<td>UD3</td>
<td>X</td>
<td>YY</td>
<td>ZZZ3</td>
</tr>
</tbody>
</table>

**System View**

The System View displays all objects of a project in a flat hierarchy (Site->Device->Object). Individual objects are listed alphabetically within an automation station.

**View created automatically**

The Technical Designation (technical address) determines the object view. Individual hierarchies are separated with separators.

**Engineered view**

The object names define the view of engineered objects.
Symbols

The following symbols denote BACnet objects.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>BACnet objects</th>
</tr>
</thead>
<tbody>
<tr>
<td>![input]</td>
<td>Digital</td>
</tr>
<tr>
<td>![input]</td>
<td>Analog</td>
</tr>
<tr>
<td>![input]</td>
<td>Counter</td>
</tr>
<tr>
<td>![output]</td>
<td>Digital</td>
</tr>
<tr>
<td>![output]</td>
<td>Analog</td>
</tr>
<tr>
<td>![output]</td>
<td>Multistate</td>
</tr>
<tr>
<td>![setpoint]</td>
<td>Digital</td>
</tr>
<tr>
<td>![setpoint]</td>
<td>Analog</td>
</tr>
<tr>
<td>![setpoint]</td>
<td>Multistate</td>
</tr>
<tr>
<td>![schedule]</td>
<td>Digital</td>
</tr>
<tr>
<td>![schedule]</td>
<td>Analog</td>
</tr>
<tr>
<td>![schedule]</td>
<td>Multistate</td>
</tr>
<tr>
<td>![calendar]</td>
<td></td>
</tr>
<tr>
<td>![trend]</td>
<td></td>
</tr>
<tr>
<td>![common_alarm]</td>
<td></td>
</tr>
<tr>
<td>![measured_value]</td>
<td>count</td>
</tr>
<tr>
<td>![automation_station]</td>
<td></td>
</tr>
<tr>
<td>![automation_alarm]</td>
<td></td>
</tr>
<tr>
<td>![automation_status]</td>
<td></td>
</tr>
<tr>
<td>![notification_class]</td>
<td></td>
</tr>
<tr>
<td>![user_profile]</td>
<td></td>
</tr>
<tr>
<td>![compound_element]</td>
<td></td>
</tr>
<tr>
<td>![control_component]</td>
<td></td>
</tr>
<tr>
<td>![alarm_display]</td>
<td></td>
</tr>
<tr>
<td>![referenced_object]</td>
<td></td>
</tr>
</tbody>
</table>
Object properties

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Desigo PX data type</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Real" /></td>
<td>Real</td>
</tr>
<tr>
<td><img src="image" alt="Integer" /></td>
<td>Integer</td>
</tr>
<tr>
<td><img src="image" alt="Multistate" /></td>
<td>Multistate</td>
</tr>
<tr>
<td><img src="image" alt="Digital" /></td>
<td>Digital</td>
</tr>
<tr>
<td><img src="image" alt="Time" /></td>
<td>Time</td>
</tr>
<tr>
<td><img src="image" alt="Date" /></td>
<td>Date</td>
</tr>
<tr>
<td><img src="image" alt="Time and date" /></td>
<td>Time and date</td>
</tr>
<tr>
<td><img src="image" alt="Bit set" /></td>
<td>Bit set</td>
</tr>
<tr>
<td><img src="image" alt="String" /></td>
<td>String</td>
</tr>
<tr>
<td><img src="image" alt="Array, list" /></td>
<td>Array, list</td>
</tr>
<tr>
<td><img src="image" alt="Unknown" /></td>
<td>Unknown</td>
</tr>
<tr>
<td><img src="image" alt="I/O address" /></td>
<td>I/O address</td>
</tr>
</tbody>
</table>

Find objects

If you have problems finding certain folders, sites, devices or objects in either the System View or the User View of the System Browser tree, you can use the **Find** function described here to locate them.

Frequently used objects can be added to the Favorites folder as described further on in this section.

1. Click "Find" on the toolbar.
2. Select the browse view in the **Path** field.

<table>
<thead>
<tr>
<th>List box</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ditech</td>
<td>Technical view</td>
</tr>
<tr>
<td>diuser</td>
<td>User view</td>
</tr>
<tr>
<td>disys</td>
<td>System view</td>
</tr>
</tbody>
</table>

3. Click **Browse**.
   The **Object selection** dialog box opens.

4. Select the start for browsing.
5. Click the site object or a device object.
6. Click OK.
7. Enter the short name in the Name field (e.g.: FanSu).
8. Enter a description (e.g. supply air fan) in the Description field.
9. In the Find Hierarchy field, enter the number of hierarchies to be found.
10. Click OK in the Search field to start the search. The Dialog box Find in <path> opens.

All data points matching the search criteria are listed (name and path).

11. Right-click the desired object and select the corresponding function.

Note
Note that when text search criteria are applied to the System View, the ID and designation of an element are treated as a single text item. In other words, it's not possible to search for an object designation (displayed in []) independent of the object ID. As a consequence, the wildcard * at the start of the search string "* supply air sensor" is required to find, for example, "AHU10 [supply air sensor]".

Tip
You can use the search results to navigate in the following ways:
• Drag and drop into System Browser to find the location of the object
• Drag and drop into Trend Viewer to start trend logging directly
• Right-click and select Send To... to navigate to another Desigo Insight program

Wildcards
The following wildcard characters are allowed in the search function:

<table>
<thead>
<tr>
<th>Wildcards</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>*</td>
<td>Represents any character or group of characters</td>
</tr>
<tr>
<td>?</td>
<td>Represents a single character</td>
</tr>
</tbody>
</table>

Example:

<table>
<thead>
<tr>
<th>String</th>
<th>Possible result</th>
</tr>
</thead>
<tbody>
<tr>
<td>A?A*</td>
<td>ALA; ANA; ALA100; ANA1;</td>
</tr>
<tr>
<td>M?*</td>
<td>MA, M500, M, M_ALARM</td>
</tr>
</tbody>
</table>
4.9.5 Set up the workspace for Alarm Viewer and Log Viewer

Setup workspace
The user can customize the workspace as follows:

- Show/hide the toolbar
- Show/hide the status bar
- Show/hide System Browser
- Show/hide columns
- Modify column width and order
- Modify grid line display

Note
The workspace settings listed above are stored on a user-specific basis and is applied automatically when next started by that user.

Toolbar
1. From the View menu, select to show or hide the Log Viewer toolbar.

Status bar
1. From the View menu, select show or hide status bar.

System Browser
1. From the View menu, select System Browser to show/hide the System Browser
   OR
   Click “Show/hide system browser” on the toolbar.

Define columns
1. Right-click the column title and confirm the dialog box Change Column Order.
2. Select or clear the tick-boxes to display or hide columns:
   
   ![Change Column Order dialog box]

3. To change the column order, select one of the displayed (enabled) columns and use the arrow buttons to move it up or down in the list.
4. Click OK to apply the new settings.

Note
The Event Group column cannot be hidden. It appears grayed-out (dimmed) in the list above.

Change column width
The sizing of the column width works in the same way as in the Windows Explorer:
1. Point mouse to column divider.
   The cursor changes from a pointer to a double-headed arrow.
2. Holding down the left mouse button, drag the frame in either direction indicated by the arrow.
3. Release the mouse button to end the “resize” operation.
You can also double-click column divider to modify the column width.

Note
The column size cannot be set to zero. Refer to "Define columns" to show/hide columns.

Change grid settings
Grids can be shown or hidden.
1. From the View menu, Show Grid.
2. Enable/disable the display of grid lines separately for horizontal and vertical lines.
3. Click OK to apply the new settings.

Reset workspace settings
1. Select Tools > Setup workspace to rest default workspace settings.

4.9.6 Locate log entries in the System Browser tree

Locate entries
With this function, sites, devices, objects and object properties associated with a given log entry can be located in the optional System Browser tree by means of the Locate function.
The relevant item is selected in System Browser.

Find entries
1. Right-click an event entry (right pane) and select Localize Entry.
2. The element is selected in the Browser window.
   (The System Browser opens automatically.)

Scope of the Find function
As an alternative to the Locate option, entries can also be located in the System Browser tree by means of the Find function. This is a text search tool.
1. To invoke the Find dialog box, press <F3>.
   OR
   From the Edit menu, select Find.
   OR
   Click "Find" on the toolbar.
For details of how to use the Find function and the associated search criteria: Refer to chapter “General Operation” in this manual.

### 4.9.6.1 Filter events lists

**Filter view**
Filtering the view produces a subset of the complete database. If required, the view can be filtered by more than one criterion simultaneously.

**Filter types**
There are three basic filter options:

<table>
<thead>
<tr>
<th>Filter function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter by “…”</td>
<td>Selecting an item in the event list as a filter criterion allows you to display only those events which match the selected criterion (e.g. only events logged on the selected date, or only “Alarm High” events, or only events related to “Room 217” etc.)</td>
</tr>
<tr>
<td>Select from...</td>
<td>Lists the available filter criteria based on the contents of the selected column. The resulting filter is a logic OR combination of the items selected from the list. Note that the Date/Time column has pre-defined time range filters such as “Current Day/Week/Month”, “Last Day/Week/Month” etc.</td>
</tr>
<tr>
<td>Custom filter...</td>
<td>You can customize a column filter using a range of specific filter dialog boxes which vary according to the type of column selected.</td>
</tr>
</tbody>
</table>

**Note**
You can also use System Browser to filter a view. See further down this section for a description of this procedure.

**Filter by “…”**
1. Place the cursor on the field to be used as a filter criterion.
2. Right-click to display the context menu.
3. Select the **Filter by “…”** command to filter the view by this item.

**Tip**
You can repeat this procedure for each column until the desired information meets your needs. Also works with select filter and customer-specific filter.

**Filter with “Select from”**
1. Place the cursor on a field in the column by which you want to filter the view.
2. Right-click to display the context menu.
3. Choose **Select from ...** to display the following dialog box:
1. Left-click the item(s) you want to use as filter criteria. You can select a combination of options by holding down the <Ctrl> or <Shift> key while making your selection. The filtered view is included only events which match one of the selected criteria.

2. Click **Filter** to filter the view.

**Custom filter**

This function **cannot** be used in the Event Group and Comment columns.

1. Place the cursor on a field in the column by which you want to filter the view.
2. Right-click to display the context menu.
3. Select the **Custom Filters** to display a dialog box specific to the type of entry.
4. Enter or select the desired combination of filter criteria.

**Example 1:**
Custom Filter dialog box for the **Date/Time** column.

**Example 2:**
Custom Filter dialog box for the **text** column.

**Tip**

Add an * both before and after the word. This is the only way to ensure that all entries that meet these criteria are displayed.

**Example 3:**
Custom Filter dialog box for size and unit columns.
Example 4:
Custom Filter dialog box for the priority column (priorities selected here correspond to the priorities on the management station).

5. Click OK to start the filter process.

Tip

The three most recently used filter attributes for each column can be found and recalled from the context menu (right-click). See also “Operating Log Viewer” above for the structure of the context menu.

Time/Date filter

When you select the Time/Date field, you can select the following options from Filter by Custom Filter as well as the following:

- Current
  - Day 07.05.2004
  - Week 03.05.2004 – 09.05.2004
  - Month May 2004
- Last
  - Day 06.05.2004
  - Week 26.04.2004 – 02.05.2004
  - Month April 2004

Indication of filter status

A funnel icon on the column header indicates that the event list is filtered.

Filter display

The currently applicable filter criteria are also detailed on the status bar:

A window appears with the entire search string when you double-click the status bar:
Remove Filters
Remove all filters from a view.
1. Right-click the view. Select View > Remove filter.
   OR
   Click "Remove Filter" on the toolbar.
   OR
   Select menu View > Remove Filter.

Remove one specific filter criterion.
1. Right-click the relevant column. Select Remove.

4.9.6.2 Saving and applying filter queries

What is a filter query? Currently applied filters can be saved as a set of criteria referred to as a “filter query”.
These filter queries can then be recalled and applied to a view of the same category.
In principle, filters are saved on a user-specific basis, but if required, each user can also apply any existing query saved by any other user.

Save filter queries
1. Filter the view as required.
2. Select Filter > Save.
   OR
   Click Filter on the toolbar to display a list of your personal queries.
3. Enter a query name (max. 20 characters).
4. Click Save.

Recall filter queries
Recall filter queries from the Filter menu.
(This displays all queries in the system).
1. Go to the view to be filtered.
2. From the Filter menu select Predefined to display a list of existing personal queries associated with this view.
   If the required query is not in the list, click More to display a list of all defined queries in the system.
3. Double-click a query in the list or select a query and click Filter.

Recall a filter query from the query list on the toolbar.
(This displays only your personal queries).
1. Display the drop-down list from the toolbar and select the query to be applied:

![Application drop-down list]

Note Whenever a filter query is applied to a view, any other active filters are removed (i.e. filter queries cannot be combined by running them in sequence).

Copy in personal query Global filter queries can be copied to the list of personal queries.
1. Go to the view for which the required query is valid.
2. Select Filter > Predefined to display a list of existing personal queries.
3. Click **More** to display a list of all queries in the system.
4. Select queries you want to copy to the list of personal queries.
5. Click **Copy**.

**Rename filter queries**
1. Select **Filter > Predefined** to display the list of existing filters.
2. Select the query to be renamed and click it a second time (slower than a double click) or right-click and select **Rename**.
3. You are now in the edit mode. Edit the filter name.
4. Press enter or click into the background of the dialog to complete editing and accept the new name
5. Click **Close**.

**Delete filter queries**
1. Go to view to which the query to be deleted applies.
2. Select **Filter > Predefined** to display a list of existing personal queries.
3. Right-click the filter query to be deleted and click **Delete**.
4. When you have finished deleting the filter query or queries, click **Close** to close the dialog.

### 4.9.6.3 Sort entries

**Sorting principles**
As a general rule, each column can be sorted independently in ascending or descending order.

By default, if no specific sorting criteria apply, each column is sorted in descending order, with the Date/Time column having the highest priority. This default state is never indicated.

Sorting is initiated by clicking the heading of the column to be sorted.

The first column to which sorting is applied has the highest priority in the sort hierarchy. The last column to be sorted has the lowest priority in the sort hierarchy.

**Sort entries**
1. Click the heading of the relevant column.
   - Clicking the column heading for the first time sorts the appropriate column in ascending order.
   - Click a second time to change the sort criterion to descending order.
   - Click a third time to remove the sort criterion for this column.

**Indication of sort status**
When one or more columns in view are sorted arrowhead symbols are displayed in the appropriate column headings, to indicate which of the columns are sorted, and in which order (ascending or descending).

Further, a number beside each symbol indicates the sort priority for this column.

<table>
<thead>
<tr>
<th>Event Group</th>
<th>DateTime</th>
<th>/</th>
<th>Priority</th>
<th>/</th>
<th>Event</th>
<th>/</th>
<th>Message</th>
</tr>
</thead>
<tbody>
<tr>
<td>User</td>
<td>25.07.2012 09:38:19</td>
<td>High</td>
<td>Alarm acknowledgement</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>User</td>
<td>25.07.2012 09:57:06</td>
<td>High</td>
<td>Alarm acknowledgement</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

If at least one of the columns in the view is sorted, the following icon appears on the status bar:

A double-click on the “Sort” icon on the status bar opens a field containing full details of the sort criteria:
Remove sorting

1. Click the relevant column heading until sorting is removed.
   - The column is sorted in ascending order at the first click.
   - The second click results in a sort in descending order.
   - A third click removes the sort in this column.

Remove sorting from all columns

1. Select View > Remove Sorting.
   OR
   Click " Remove sort "
   OR
   Right-click to open context menu and select Remove Sort.

4.9.7 Print from programs

General

- Printing is generally possible for all applications in Desigo Insight.
- Each program can be assigned to a different printer, and you can have several printers connected to your management station.
- This allows you, for example, to send graphics to a color printer and reports to a laser printer, without having to change the print settings.
- Print-outs from the various programs have a common appearance (layout, header, footer etc.).

Print Preview

The Print Preview button on the toolbar of the individual programs in Desigo Insight displays each page as it looks when printed.

Working with Print Preview

When you have decided what you want to print (e.g. a filtered and sorted selection of alarms, or a trend view, perhaps),

1. Click Print Preview on the toolbar. In the Print Preview screen you have the following options:

<table>
<thead>
<tr>
<th>Text on toolbar button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print...</td>
<td>Sends the previewed document to the printer. The standard Windows Print dialog box appears, allowing you to select a printer, define the print range, specify the number of copies you require, etc.</td>
</tr>
<tr>
<td>Next Page</td>
<td>Lets you view the next page in a multiple page document.</td>
</tr>
<tr>
<td>Prev Page</td>
<td>Returns to the previous page in a multiple page document.</td>
</tr>
<tr>
<td>One Page</td>
<td>Displays one page at a time (option only available in Two Page display mode).</td>
</tr>
<tr>
<td>Two Page</td>
<td>Displays two pages at a time in a multiple page document (option is only available if current display mode is &quot;One Page&quot;).</td>
</tr>
<tr>
<td>Zoom In</td>
<td>Magnifies the view in two stages. This button then becomes inaccessible, and Zoom out becomes active instead.</td>
</tr>
</tbody>
</table>
| Zoom Out                | Reduces the size of view in two stages. This button then be-
comes inaccessible, and Zoom in becomes active.

| Close | Closes the Print Preview and returns to the standard document view. |

### Printing a document

1. Click **Print** in the menu or print on the application toolbar. The **Print** dialog box appears.
2. Check that the printer shown in the **Printer** dialog box is the one you want to use.
   - If not, scroll through the list to find the correct printer.
3. Specify the page range where appropriate.
4. Specify the number of copies you require.
5. Click **OK**.

### Print a ‘snapshot’ of the screen

1. Press `<Alt>++<PrtScn>`, to copy the selected window screen.
   - OR
   - Press `<PrintScrn>` to copy the entire screen to the clipboard.
2. Switch to a word processing program.
3. Select **Edit > Paste** to insert the clipboard contents into a document.
5 Start Desigo Insight

Chapter overview
This chapter describes how to start Desigo Insight, shut down and how to add or delete a user with the proper authorization.

5.1 Start Desigo Insight

Automatic start
Your Desigo Insight is normally configured to automatic startup when the computer is turned on. Installation modifications for automated start or after a power outage are described in the section "Installation modification".

Manual start
1. Double-click the Desigo Insight icon on the Windows Desktop.
   OR
   Click Start on the Windows taskbar
2. Point to Programs and then point to Desigo Insight V6.0 to display a further menu.
3. Click Desigo Insight in this menu.
   The Desigo Insight “splash” appears, indicating that the program is starting:

Note
If any of the programs within Desigo Insight have been configured to run automatically on start-up, there may be a brief delay while these are launched.

Taskbar
The startup process is complete when the standard Windows taskbar and the Desigo Insight taskbar appear on the screen:

The Desigo Insight taskbar

What can be operated after start-up
Until you have logged in, you have no access to any of the functions of Desigo Insight. Selecting any of the buttons on the taskbar at this stage invokes the login dialog box.
5.2 Login

Manual

1. Click any of the buttons on the Desigo Insight taskbar to display the Log On - Shell dialog box.

   ![Log On - Shell](image1)

   **Standard**

   **Special**

2. Enter your user name and password. Note that the password is case-sensitive.
3. Click OK.

   If your system has been configured to connect to a site or start a Desigo Insight program automatically, the connection is established or the program is started when you log in.

Note for Windows users

When you log in as a Windows user, this login window does not appear. The Desigo Insight taskbar opens immediately following startup.

Note

After a certain period of inactivity by the user, as shown in the Time to auto-cancel progress indicator, the dialog box closes.

Change password

1. Click the Desigo Insight button on the Desigo Insight taskbar.
2. Select Properties to display the Desigo Insight Settings dialog box.
3. Click Change Password….
4. In the Change Password dialog box, enter your old password in the Old password field:

   ![Change Password](image2)

5. Enter the new password in the New password field (min. 4 and max. 16 characters).
6. Enter the new password again in the Confirm new password field.
7. Click OK.

Note

Passwords in Desigo Insight are case-sensitive. Take care with the use of upper and lower case and check that the <Caps Lock> key is not accidentally on.
Password policy

If required, a more stringent password policy can be applied. This must be defined under General in System Configurator and activated for the user concerned.

With an active password policy, the following rules apply:

- The password must have at least n characters.
- The password must not have been used previously in the last n passwords.
- The password must not have been used in the last n days.
- The password must include characters from three of the following four categories:
  - Upper case letters A…Z
  - Lower case letters a…z
  - Digits 0…9
  - Special characters such as !, $, #, %

Operation

When you log in, Desigo Insight checks the privileges associated with your password. After login, all the programs and menu options to which you have authorized access is available to you.

Note

If your system is configured to start the graphics component of Desigo Insight automatically, then the Plant Viewer navigation bar appears directly beneath the Desigo Insight taskbar.

For details, refer to the “Operation of Plant Viewer” section of this manual.

5.3 Configure taskbar

Position

You position the taskbar at the top or bottom of the screen.
1. Click the **Desigo Insight** button.
2. Select **Properties…** to display the Desigo Insight properties dialog box.
3. In the **Taskbar position** dropdown list, select operation **Top** or **Bottom**.
4. Click **OK**.

Classic or modern

1. Click the **Desigo Insight** button.
2. Select **Properties…** to display the Desigo Insight properties dialog box.
3. In the **Motive** dropdown list, select **Classic** or **Modern**.
4. Click **OK**.

Note

The taskbar is reduced in size if the screen resolution is too low. Click **to display the other applications.**
5.4 Display system and version information

Display

This is a special indicator, showing if there is a problem with the local management station. The symbol is always visible in the Desigo Insight taskbar, even when no user is logged on.

The image displays the content of the Supervisor Information tab.

1. Click the Desigo Insight button on the Desigo Insight taskbar
2. Select Show > System information.
   OR
   Click system information on the taskbar.

The resulting dialog box gives details of the present state of your system.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Supervisor information</td>
<td>Shows present state of databases, storage space, time synchronization and Desigo Insight applications.</td>
</tr>
<tr>
<td>Device status</td>
<td>Shows an overview of connected automation stations and their state.</td>
</tr>
<tr>
<td>Modem status</td>
<td>Shows an overview of connected modems and their state.</td>
</tr>
<tr>
<td>Desigo Insight Information</td>
<td>Displays the exact version numbers for all Desigo Insight applications.</td>
</tr>
<tr>
<td>Project information</td>
<td>Base information on storage location of the various databases for your Desigo Insight management station.</td>
</tr>
</tbody>
</table>

1. Open system information  2. Select tab
3. Set filter Object status display Additional information in case of abnormal state

Note

Depending on the state of your system, the system information button may show the number of critical or warning states, and might look like this, for example:
Desigo Insight shows warnings 🔴 that must be reset, e.g. if a folder changes during operations (storage on server). In this case, you must first adjust the folder and then acknowledge the warning in the Alarm Router.

![Image](image_url)

1. Click 🔄 in the Desigo Insight taskbar.
2. Select View > Statistics....
   The Task Statistics dialog box shows the message information.
3. Click Reset.
   The warning messages are reset.
   - Yellow: A driver cannot route a task.
   - Red: Task not executed due to error.

**Display version information**

1. On the Desigo Insight taskbar, click Desigo Insight > About Desigo Insight.
   The dialog window displayed gives details of the current version of Desigo Insight.
2. Click Close.

**Update project data**

The symbol 🔄 displays if the project data no longer matches the Desigo Insight system database.

1. Click "System information" 🔄 on the taskbar.

2. Select the site.
3. Click Device Wizard.... The device wizard opens and display the state of the individual automation stations.
4. Click Next >. All automation stations with state 🔄 up prepared for upload.
5. Click Run. This runs the upload process for the data and displays ✔️ under system information when finished.
6. Click Close.
5.5 Manually connect/disconnect a site

**Definition of a site**
A site is an independent (from the user’s point of view) and self-contained logical entity within the building automation and control system. A site is a means of structuring, and in general, consists of an area which is self contained in terms of location, function and organization (e.g. a building or a group of buildings).

**Manual connection**
1. Click **Desigo Insight** on the Desigo Insight taskbar and select **Connect/Disconnect**.
   OR
   Click “Site Connect and Disconnect”.
2. In the pane of the **Desigo Insight Site Connect and Disconnect** dialog box, click the required site:
3. Select the desired site and click **Connect** (refer to State of site connection below).
4. Click **Advanced** and an additional description of the connection as well as the communication protocol.
5. Click **More** to display connection reference dialog for the application and the reason for the connection.
6. Click **Close** when the site is connected.

**Note**
Should you receive a message indicating that a connection is not possible, contact your Desigo Insight expert or your local Siemens Building Technologies office.

**Site connection status**
1. Click on the Desigo Insight taskbar.
   The list of active connections for your user scope is displayed.
<table>
<thead>
<tr>
<th>Symbol</th>
<th>Symbol description</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="no-arrow.png" alt="No arrow available." /></td>
<td>No arrow available.</td>
<td>There is no connection to and from the corresponding site.</td>
</tr>
<tr>
<td><img src="green-arrow.png" alt="Green arrow pointing from management station to automation and control system" /></td>
<td>Green arrow pointing from management station to automation and control system</td>
<td>Connection established by the management station, e.g. a manual connection by a user, or an automatic life-check connection.</td>
</tr>
<tr>
<td><img src="red-arrow.png" alt="Red arrow pointing from automation and control system to management station." /></td>
<td>Red arrow pointing from automation and control system to management station.</td>
<td>The site was called and the connection cannot be established.</td>
</tr>
<tr>
<td><img src="red-arrow.png" alt="Red arrow pointing from management station to automation and control system." /></td>
<td>Red arrow pointing from management station to automation and control system.</td>
<td>The site is connected for a single application.</td>
</tr>
<tr>
<td><img src="blue-arrow.png" alt="Blue arrow displays from the management station to the automation station" /></td>
<td>Blue arrow displays from the management station to the automation station</td>
<td>Site is connected for a life check only</td>
</tr>
<tr>
<td><img src="green-arrow-clock.png" alt="Green arrow with clock." /></td>
<td>Green arrow with clock.</td>
<td>The time for this site is outside permissible range.</td>
</tr>
<tr>
<td><img src="green-arrow.png" alt="Green arrow displays from management station to the automation station" /></td>
<td>Green arrow displays from management station to the automation station</td>
<td>The “always connected” site is not connected.</td>
</tr>
</tbody>
</table>
Green arrow displays from management station to automation station | The connected site has devices that are not online.

The same symbols are used to display the site connection state in the Connect/Disconnect site dialog box. Click Connect and Disconnect Sites on the Desigo Insight taskbar.

**Life check**

Life check allows you to check whether or not the appropriate site is still communicating with your management station.

1. Click **Desigo Insight** on the Desigo Insight taskbar and select Connect/Disconnect.
   OR
   Click "connect and disconnect sites".
2. Click Life Check in the Desigo Insight connect and disconnect sites dialog box.
   The new Life Check time is displayed in the dialog box.
3. Click OK to close the dialog box.

**Disconnect site**

You can force an interruption to a site when the connection to the site is maintained by an application.

1. Click **Desigo Insight** on the Desigo Insight taskbar and select Connect/Disconnect.
   OR
   Click "connect and disconnect sites".
2. Select the corresponding site.
3. Click Advanced in the Desigo Insight connect and disconnect sites dialog box.
4. Select the connection.
5. Click Disconnect Site.
6. Click Yes if you really want to disconnect the connection.
7. Click Close when the desired site no longer displays a connection.

**What can be operated after connection to a site?**

When you have established a connection to a site, you are able to:
- Operate the system via Plant Viewer graphics
- Handle alarms (Reset, acknowledge etc.)
- Operate objects in Object Viewer
- Create and view an online trend in Trend Viewer
Taskbar information after connection to a site

After a site connection is established, your user name appears on the taskbar to confirm your login.

Further, the following changes are visible on the Desigo Insight taskbar:

<table>
<thead>
<tr>
<th>Buttons</th>
<th>Details</th>
<th>Measures</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>A red clock in the time display indicates that the site time and the management station time are not synchronized, and that the time difference is greater than the predefined maximum.</td>
<td>This is not necessarily a serious problem, but you should contact your system administrator or your local Siemens office for advice.</td>
</tr>
<tr>
<td>White</td>
<td>Number of site for the present user scope.</td>
<td>Can display a list of visible sites and their properties.</td>
</tr>
<tr>
<td>Yellow</td>
<td>Device offline</td>
<td></td>
</tr>
<tr>
<td>Red</td>
<td>Unexpected error occurred</td>
<td></td>
</tr>
<tr>
<td></td>
<td>The System Event Indicator shows the system status.</td>
<td>Click the System Event Indicator to open the Desigo Insight System Information window.</td>
</tr>
<tr>
<td></td>
<td>Project data in the automation station are newer than in the Desigo Insight database.</td>
<td>Click the system event and use the Device Wizard to update using the automation station data.</td>
</tr>
<tr>
<td></td>
<td>An alarm indicator on the right in the taskbar indicates the number of high-level alarms, if any. Only alarms in the user scope are displayed. (Alarms are displayed only if the alarm has the indicated priority.)</td>
<td>Open Alarm Viewer (see &quot;Starting programs manually&quot; below) or click the alarm indicator to start Alarm Viewer with a predefined filter. This removes all high-level alarm pop-up windows. For more information: refer to the &quot;Alarm handling&quot; section.</td>
</tr>
<tr>
<td></td>
<td>Displays the plant’s economic efficiency.</td>
<td>Check your plant if the leaf is not green. Start the Eco Viewer based on the display and filter.</td>
</tr>
<tr>
<td></td>
<td>Displayed only if an alarm sound is assigned to the alarm and when several alarms occur at the same time.</td>
<td>None, suppresses only long sounding of alarm sounds.</td>
</tr>
<tr>
<td></td>
<td>A tree shows that the user scope has changed since login.</td>
<td>Click the symbol to update the data.</td>
</tr>
<tr>
<td></td>
<td>Display and go to fire alarms</td>
<td>Open Alarm Viewer (see Section &quot;Manually start programs&quot;).</td>
</tr>
<tr>
<td></td>
<td>Fire alarm</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Prealarm</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Fault</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Shut down</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Anomaly</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Test</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Renovation</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Manned operation</td>
<td></td>
</tr>
</tbody>
</table>
5.6 System time

Overview

"System time" refers to the time clock in your building automation and control system. This includes the time at the PX automation stations and the time on the management station. Your system has several so-called "Real Time Clocks". As a rule, there is one per management station and one per PX automation station. The following options are available for the time master for synchronization:

Option 1: PX automation station time is synchronized with the time in a specific management station.
Option 2: Management station time is synchronized with the time in the PX automation stations.
Option 3: No synchronization.

The first option is the most common. Option 3 may be used if the management station and the automation stations are in different time zones. In such cases we differentiate by referring to the management station time and the PX automation station time.

We usually refer to the time used by the PX automation stations as the "site time". In options 1 and 3, the PX automation stations are synchronized with a single PX "master" automation station. If the PX master fails, then a back-up automation station is used until the master is back in service.

Define time master

Define the time master in the System Configurator.

1. Click "System Configurator".
2. Right-click Desigo Insight building automation and control system.
3. Select the Time Master tab and define the corresponding settings.

Synchronization

Synchronization with the management station, where configured, takes place upon site connection. If the difference between the management station time and the site time is outside a given narrow band (e.g. 1 minute), then the red "out of range" indicator is displayed and the time is synchronized. If the difference is outside of a wider band, e.g. 1 hour, then the same red warning icon is displayed, but the time is not synchronized (this option prevents inadvertent synchronization across time zones).
Check / Change

If the system time is incorrect, and the site time is synchronized automatically to the management station time, then check the management station time. This is displayed in the lower right hand corner in the Windows taskbar. Double-click this time display to adjust it using the normal Windows interface. It is then usually sufficient to connect to site.

In cases where the site time is not synchronized to the management station, you can adjust the site time as follows:

1. Click **Connected Site** or **on the Desigo Insight taskbar.**
2. Select the site and click **Properties.**

3. Select the **Time** tab and set date and time. The ... **Properties** dialog box opens.

4. Select the desired type for **Specify new site time.**
5. Click **OK.**

**Note**

Your system has probably been engineered to synchronize the management station time automatically with the site time.

If you follow the procedure below and it is not successful, i.e. the site time reverts to the previous value, this indicates that the site time is being synchronized by the management station. To alter it, you must alter the management station time via Windows.

**Daylight savings time.**

The switch from standard to daylight savings time is automatic. This function is handled automatically both by the management station via the Windows operating systems, and, if required, autonomously by the PX automation stations.

Where there is more than one Desigo Insight management station, then just one of these may be configured as the time master as in option 2 (see above).

**Note**

After changing the time, check the execution times for the Reaction Processor, e.g. if you are using short intervals (< 1 hour) or if execution time was defined as per daylight savings/standard time.
UTC

UTC (Universal Time Coordinated) is a worldwide reference time, equivalent to GMT (Greenwich Mean Time). UTC may be used in the Desigo PX automation stations, one advantage being that daylight saving time changes are no longer necessary and hence the trend data and historical data does not suffer from gaps or compressions in clock time. The disadvantage is that human operators of the system prefer to work in “local time”. Check with your local Siemens representative whether this option has been used in your Desigo system.

5.7 Start programs manually

Manual start

The Desigo Insight programs can be started manually as follows:

1. Click the Desigo Insight button on the Desigo Insight taskbar
2. Point to Desigo Insight Programs
3. Select the desired Desigo Insight program.

OR

Click the relevant program button on the taskbar.

<table>
<thead>
<tr>
<th>Taskbar</th>
<th>Symbols</th>
<th>Program name</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><img src="image" alt="Plant Viewer" /></td>
<td>Plant Viewer</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Alarm Viewer" /></td>
<td>Alarm Viewer</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Trend Viewer" /></td>
<td>Trend Viewer</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Log Viewer" /></td>
<td>Log Viewer</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Database Audit Viewer" /></td>
<td>Database Audit Viewer</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Object Viewer" /></td>
<td>Object Viewer</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Time Scheduler" /></td>
<td>Time Scheduler</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Report Viewer" /></td>
<td>Report Viewer</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Reaction Processor" /></td>
<td>Reaction Processor</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Alarm Router" /></td>
<td>Alarm Router</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="System Configurator" /></td>
<td>System Configurator</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Database Import Utility" /></td>
<td>Database Import Utility</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Eco Viewer" /></td>
<td>Eco Viewer</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Database import (only for older subsystems)" /></td>
<td>Database import (only for older subsystems)</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="RS Access" /></td>
<td>RS Access</td>
</tr>
</tbody>
</table>
Note: You only see buttons for Desigo Insight applications to which you have authorized access.

Tip: You can use ToolTips to check which icon is associated with which program (point the cursor at a button to display its function).

5.8 Create and delete user

Why create a user? A user login must be created for each Desigo Insight user to ensure clear identification of the interaction in Desigo Insight, e.g. acknowledging an alarm. The user is assigned to a user group based on his or her activities (all have the same access rights within the group).

Important: Create an additional user in the Administrator group only if this group does support two users. Create a "Supervisor" group with rights identical to administrator rights to assign administrator rights to the users.

Note:
- You can only add or delete a user from the same or lower user group.
- A user may only be a member of one user group. For this reason, each user must be assigned a clear name.
- The graphic is re-compiled when creating a user. This occurs right after saving the newly created user and may take several minutes depending on project size.
- You must wait while each user is compiled when setting multiple users one after the other.
  OR
- Click Cancel compile (Note: Dialog box is in the system configurator background); the graphic must be manually compiled using the Citect Compiler after all new users are created.

Create user: Create a new user in the System Configurator.
1. Click “System Configurator”.
2. Right-click the user groups folder where this user is assigned.
3. Select Add user.
The User Properties dialog box opens.
4. Enter the **User name**.
   The selected user name determines user authentication when starting Desigo Insight.
   - **Desigo Insight user**: Select any user name.
   - **Desigo Insight Windows user**: User name is identical to the Windows user name.
     - **User name**: 
     - **Windows user**: The user name is identical to the windows user and must be defined as follows.
     1. Click **User is a Windows user**.
     2. Click **Select Windows user**.
     3. Select a Windows user.

4. Click **OK**. The user name is defined.

5. Define other user properties.

<table>
<thead>
<tr>
<th>User Name</th>
<th>The user name is displayed on the management stations to identify the user.</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Group</td>
<td>The user assumes the properties of this user group.</td>
</tr>
<tr>
<td>Full Name</td>
<td>The full name is displayed in User Properties and information on the state is displayed in the toolbar.</td>
</tr>
<tr>
<td>Visa</td>
<td>The signature serves the logon in automation systems.</td>
</tr>
<tr>
<td>Password</td>
<td>Input password configuration (validity 0 days = Password is always valid).</td>
</tr>
<tr>
<td>Account Expires</td>
<td>Ability to create a temporary user account.</td>
</tr>
<tr>
<td>Apply password policy</td>
<td>The password policy can be enabled. (Configuration in Desigo Insight Building Automation and Control System &gt;&gt; Properties &gt;&gt; Account policies).</td>
</tr>
<tr>
<td>Apply lockout policy</td>
<td>The lockup guideline can be switched on. (Configuration in Desigo Insight Building Automation and Control System &gt;&gt; Properties &gt;&gt; Account policies).</td>
</tr>
</tbody>
</table>

6. Click the **Scopes** tab.
7. Specify the user view. See Section Scopes.
8. Click **OK**. A new user is created.

**Note**

See documentation "Installation and configuration" for more information on user groups and users:
8.1.1 Configure general project properties and others.
12.2.3 Logon.

**Copy user**

You can copy a user in the System Configurator.
1. Click "System Configurator".
2. Right-click the user folder to be copied.
3. Select Copy user.
4. Enter the name of the new user and configure user properties as described below.

**Delete user**

To delete a user in the System Configurator.

Click "System Configurator"  
1. Right-click the user folder to be deleted. You can select several folders by holding the control key and left-clicking the desired folder.
2. Select **Remove**.
3. Click the key to delete one or more users.

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yes</td>
<td>Deletes the currently displayed user.</td>
</tr>
<tr>
<td>Yes to All</td>
<td>Deletes all pre-selected users without confirmation.</td>
</tr>
<tr>
<td>No</td>
<td>Skips the currently displayed user and displays the next one.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Exits the dialog box without deleting any further users.</td>
</tr>
</tbody>
</table>

4. Click **Cancel** to close the dialog box.

**Tip**

Before deleting a user, start by deleting only the account privilege.

### 5.9 Lock

**Disabling a session**

A Desigo Insight session can be locked, in order to prevent any further actions by the user. In this state, the background activities continue to operate as normal.

1. Click the **Desigo Insight** button and select **Shutdown**.
   OR
   Click the **Lock/Logoff/Shutdown** button on the Desigo Insight taskbar.
2. Select the Lock option in the Desigo Insight Lock, Log Off and Shut Down window:

3. Click **OK**.
   The taskbar indicates that the session is in the locked state.

**Automatic locking**
After a predefined period of inactivity on the part of the user (definable in System Configurator, default 15 minutes), Desigo Insight locks automatically to prevent unauthorized system access.

Note for Windows users
Desigo Insight is not automatically locked for Windows users. In this case, the desktop can be locked via Windows. To do this, select Display Properties > Screen Saver. Desigo Insight continues to run under the logged in user when the Desktop is locked under Windows.

Release the lock
Log on in the normal way to release the lock.
1. Click any button on the Desigo Insight taskbar. The Unlock - Shell dialog box opens.

2. Enter the Password.
3. Click OK.

5.10 Logoff
What to do before logging off
Decide whether you want to shut down Desigo Insight.
- Close any open programs, and
- Disconnect from all the currently connected sites.

Logoff
1. Click the Desigo Insight button and select Shutdown.
   OR
   Click the Lock/Logoff/Shutdown button on the Desigo Insight taskbar.
2. Select Log Off in the Desigo Insight Lock, Log Off and Shut Down window.

3. Click OK. In the log database, the most recently logged in user is entered upon logout.
After logoff, all background Desigo Insight (e.g. online trend) activities continue, the connection is automatically maintained through a standby user. User actions are only possible after the user logs in. If a user from a different user group logs in, this may cause activities such as online trend, which depend on user privileges, to be terminated.

A Windows user cannot log off Desigo Insight. This is the only way to ensure user authentication.

### 5.11 Shut down Desigo Insight

1. Click the **Desigo Insight** button and select **Shutdown**.
   OR
   Click the **Lock/Logoff/Shutdown** button on the Desigo Insight taskbar.
2. Select **Shut Down** in the Desigo Insight Lock, Log Off and Shut Down window.

![Desigo Insight Lock, Log Off and Shut Down](image)

3. Click **OK**.

The user rights of the logged on user (e.g. Administrator) are retained when the system configurator is still opened during downloading or logging off the Desigo Insight shell. The previously logged on user rights (e.g. example "Administrator") in the system configurator is still active if you log on again to Desigo Insight at a lower user right. Log off and download of the system configurator always depends on the Desigo Insight shell since the system configurator is a standalone application, i.e. it can be started without previously starting the Desigo Insight shell.

Selecting **Shut Down** closes Desigo Insight on the management station and disconnect all site connections. Activities such as online trend is terminated (the data is normally lost). To ensure uninterrupted monitoring of a site, at least one Desigo Insight station or the Desigo Insight server must be operating.

A logged in Windows user can shut down Desigo Insight directly via the Windows taskbar **Start -> Shut Down** and turn off the PC.
5.12 Restart Desigo Insight

1. Click Desigo Insight and select Restart.
   The dialog box Desigo Insight Lock, Log OFF and Shut Down opens.

2. Select Restart.
3. Click OK. Desigo Insight is shut down and restarted.
4. Log in under your user name.

Note
When you select Restart, Desigo Insight is ended on the management station. All site connections are disconnected. Activities such as online trend are ended (data normally are lost).
Select Restart after you have made changes requiring a restart in the System Configurator.

5.13 Desigo Insight terminal server

General
Operation of the Desigo Insight terminal server barely differs from direct operation of the management station. Applications can be used as per the user's Desigo Insight user rights.

Note
The terminal server requires the corresponding licenses from Microsoft and for the Desigo Insight terminal server. If the licenses are already used by other users, an error message is displayed.
5.13.1 Connect to the terminal server

In a network, any (configured) computer can access the Desigo Insight terminal server.

1. Select Start > All Programs > Accessories > Communications > Remote Desktop Connection.
2. The Remote Desktop Connection dialog box opens.

![Remote Desktop Connection dialog box]

3. Enter the terminal server computer name (e.g., chstaw0290).
4. Click Connect.
5. The Log On to Windows dialog box opens.

![Log On to Windows dialog box]

6. Enter all information.
   - User name: Personal user name on the terminal server computer.
   - Password: Personal password.
   - Log on to: Computer name on the network.
7. Click OK. The connection to the terminal server is opened and a session is started.

Successful connection: If connection is successful, the terminal server toolbar is displayed at the top of the screen.

<table>
<thead>
<tr>
<th>Keep terminal server toolbar on top</th>
<th>Connection to the computer</th>
</tr>
</thead>
<tbody>
<tr>
<td>...</td>
<td></td>
</tr>
</tbody>
</table>
Connection error: If connection to the terminal server cannot be established, the following error message appears.

![Remote Desktop Connection error message](image)

5.13.2 Start Desigo Insight (Remote Desktop)

**Start Desigo Insight**

1. Select **Start > All Programs > Desigo Insight Vx.x > Desigo Insight**. Desigo Insight starts (startup screen followed by Insight taskbar).
2. Select a button on the Desigo Insight taskbar. The **Log on to - Shell** dialog box opens.
3. Enter your user name and password. Note that the password is case-sensitive.
4. Click **OK**.

**Connect site**

1. Click “Connect/Disconnect Sites”.
2. Select the site you want to (additionally) connect.

**Stay connected, concurrent users**

If another terminal server user is already connected to the site, you can secure that connection by selecting **Keep connection**. This is to ensure that your user login remains intact and the line is not disconnected when the other user tries to disconnect.

1. Click **Connect** and then **Close**.

5.13.3 Desigo Insight service

**General**

Desigo Insight service runs in the background after starting the Desigo Insight server. This service is responsible for tasks such as alarm routing even if no user actively uses Desigo Insight.

**Changes with System Configurator**

If the system becomes unstable after changes have been made, try stopping and restarting the Desigo Insight service. Click the service icon and restart the service.

**Caution**

Use the service function only if you are familiar with the function's impact or if the Siemens service technician tells you to do so.

**Status message service**

The following table shows the status messages for the Desigo Insight service in the Windows task bar.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Status</th>
<th>Measure</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Service active" /></td>
<td>Service active</td>
<td>None</td>
</tr>
<tr>
<td><img src="image" alt="Service active" /></td>
<td>Service active</td>
<td>Check the system information in Desigo Insight</td>
</tr>
</tbody>
</table>

Siemens Building Technologies

Desigo Insight, Operating the management station, V6.0 SP3

Start Desigo Insight

CM110588en01_11

2018-09-05
<table>
<thead>
<tr>
<th>Service Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Service active</td>
<td>Check the system information in Desigo Insight und contact Siemens Service.</td>
</tr>
<tr>
<td>Desigo Insight Information</td>
<td></td>
</tr>
<tr>
<td>Service stopped</td>
<td>Data cannot be edited or forwarded. Contact Siemens Service.</td>
</tr>
<tr>
<td>Service started or is stopped</td>
<td>If the status does not change after 60 s, contact Siemens Service.</td>
</tr>
</tbody>
</table>
5.13.4 Disconnect connection to terminal server

Disconnect the connection to the terminal server as follows.

**Shut down Desigo Insight**

1. Click "Log off and shut down" in the Desigo Insight taskbar.
2. Select Shut down.
3. Click OK.

**Disconnect connection to terminal server**

2. Select Log Off. This disconnects the connection to the terminal server, closes the session and releases the license.

**Note**

When you click Close (RDT) in the terminal server toolbar, the connection is disconnected, but the session remains open and the license continues to be occupied.
6 Working with the Object Viewer

Chapter overview
This section provides all the information required by the user to operate the Object Viewer (plant data points are displayed in a browser) and the associated plant.

What is the Object Viewer?
The Object Viewer allows you to display detailed information about your building automation and control system, including information about individual objects by data point name, showing values, units and maximum and minimum limits. Depending on user rights, object view and operation is unlimited.

You can use the Object Viewer to:
- Navigate simply and quickly through the system
- Locate data points (objects) and alarms anywhere in the system
- Display detailed data point information
- Display on-line data from the process
- Manually change analog, digital or multi-state data points;
- Modify object properties
- Navigate from a selected object or property of an object directly to the relevant location in another program (e.g. Plant Viewer).

Object Viewer application description

<table>
<thead>
<tr>
<th>Designation</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Online View</td>
<td>The list box shows the selected view for the objects</td>
</tr>
<tr>
<td>Technical View</td>
<td>Opens a dropdown list box to select a view in the System Browser. Only available when the System Browser is open.</td>
</tr>
<tr>
<td>User View</td>
<td></td>
</tr>
<tr>
<td>System View</td>
<td></td>
</tr>
<tr>
<td>Online View</td>
<td></td>
</tr>
<tr>
<td>Back</td>
<td>Selects the previously selected object in the System Browser (reverse sequence). Shows a list of 20 previously selected objects (reverse sequence).</td>
</tr>
<tr>
<td>Forward</td>
<td>Selects previously selected object in the System Browser (forward sequence). Shows a list of 20 previously selected objects (forward sequence).</td>
</tr>
<tr>
<td>Next Higher Level</td>
<td>Selects the superposed object in the System Browser with regard to the currently selected object.</td>
</tr>
<tr>
<td>Open Favorites</td>
<td>Shows the list of favorite</td>
</tr>
<tr>
<td>Add to Favorites</td>
<td>Opens a dialog box to add the selected object to the list of favorite objects.</td>
</tr>
<tr>
<td>Properties</td>
<td>Opens a dialog box with the properties of the selected object.</td>
</tr>
<tr>
<td>System Browser</td>
<td>Hides the System Browser. Shows the System Browser.</td>
</tr>
<tr>
<td>Show/hide</td>
<td></td>
</tr>
<tr>
<td>Find</td>
<td>Opens a dialog box to enter search criteria to search for objects in the System Browser.</td>
</tr>
</tbody>
</table>
| Refresh View | Updates all objects. Manual refresh is required for the following cases:  
    - An object property was changed manually.  
    - A new site was connected. |
| Disable value updates | No object values are updated. Manual updating is unavailable (i.e. Menu View > View Update). |
| Update visible values | Only displayed object values are updated. |
| Update all values | All object values are updated. |
| Supress Property not Supported | Hide or show rows for not supported properties. |
| Always on Top | Shows the Object Viewer application window on top. |
| Print | Prints the object table. |
| Print Preview | Displays full pages. |

**Menu bar**

### File

| Properties | Opens a dialog box with the properties of the selected object. |
| Page Setup | Opens a dialog box for print settings. |
| Print Preview | Displays a print preview. |
| Print | Prints the object table. |
| Export... | Opens a dialog box to determine the export file (*.csv) for the object table. The data can be opened, for example, with Excel (values separated by a comma). |
| Exit | Closes the Insight program Object Viewer. |

### Edit

| Copy | Copies the System Browser reference for the selected object to the clipboard. |
| Paste selection | Inserts the contents of the clipboard (e.g. as an object in the System Browser). |
| Copy Citect tag. | Copies the Citect tag for the selected object to the clipboard. |
| Copy Name Reference | Copies the reference name for the selected object to the clipboard. |
| Find | Opens a dialog box to enter search criteria to search for objects in the System Browser. |

### View

| System Browser | Displays / hides the System Browser pane. |
| Toolbar | Shows or hides the toolbar. |
| Status bar | Shows or hides the status bar. |
| Technical View | Shows objects in the technical designations structure (TD). |
| User View. | Shows (data) objects in the user signations structure. |
| System View | Shows objects in the system designations structure. |
| Online View | Reads all BACnet objects available on a network. Data can be imported to the database using the device wizard (see CM110591 Section 10 Import BACnet project data). |
| Always on Top | Shows the Object Viewer application window. |
View Update
- Updates all objects.
- Manual refresh is required for the following cases:
  - An object property was changed manually.
  - A new site was connected.
Options
- Opens a dialog box to set display options (application window, toolbar, status bar).
Update mode
- Determines which object values to regularly update (i.e. in the object table or under Properties). Displayed in the status bar.
  - Update: Disabled.
    - No object values are updated. Manual updating is unavailable (i.e. Menu View > View Update).
  - Update: Visible values.
    - Only displayed object values are updated.
  - Update: All values.
    - All object values are updated.
  - Update visible values: If an object has more than 300 properties, this option updates all the visible values and ‘Update All Values’ is grayed out.
Go To
- Up One Level
  - Selects the superposed object in the System Browser with regard to the currently selected object.
- Back
  - Selects the previously selected object in the System Browser (reverse sequence).
- Forward
  - Selects previously selected object in the System Browser (forward sequence).
Favorites
- Add to Favorites...
  - Opens a dialog box to add the selected object to the list of favorite objects.
- Organize Favorites...
  - Opens a dialog box to rename or delete entries in the list of favorite objects.
- Favorites
  - Shows the list of favorite objects (maximum 20 entries).
Context menus
- Right-click the empty table header or outside the table (e.g. below last row)

<table>
<thead>
<tr>
<th>Context menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Up One Level</td>
<td>Selects the superposed object in the System Browser with regard to the currently selected object.</td>
</tr>
<tr>
<td>Update</td>
<td>Updates all objects.</td>
</tr>
<tr>
<td>Optimize Column Width</td>
<td>Limits column width to display the entire column in the window pane.</td>
</tr>
<tr>
<td>Show Grid</td>
<td>Opens a dialog box to show or hide grid lines in the object table.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Context menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open</td>
<td>Opens the next lower hierarchy.</td>
</tr>
<tr>
<td>Value</td>
<td>Opens the dialog box with the properties of the selected object.</td>
</tr>
</tbody>
</table>
Start Object Viewer

1. Click the Object Viewer on the Desigo Insight taskbar.

2. Select the view on the objects:
   - Technical View
   - System View
   - User View
   - Online View

Tip

The view in the content window can be optimized to your requirements (refer to Resizing application windows).

Online View

When selecting the Online View, the entire network is scanned for BACnet objects and management stations.

Note

The display and processing of object in Online View can only occur if the options Use online view and Change value in online view are enabled under User Groups > [User group] > Tab Object Access. Changed values in the online view are not logged in the Log-database.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🌐 Online mode selected.</td>
<td></td>
</tr>
<tr>
<td>🌐 IP Displays the IP network with the assigned network names.</td>
<td></td>
</tr>
<tr>
<td>🌐 Sites are imported. At least one automation station is imported. Additional automation stations cannot, however, be imported at this time. Icon displayed on super visor:</td>
<td>The automation station is not up-to-date and a data import can be run as needed. If you use Scopes: After a data import, you must update Scopes so that the imported data is displayed in the other</td>
</tr>
</tbody>
</table>
views. The automation station is up-to-date and does not require a data import.

The corresponding hierarchy stage is scanned online for underlying objects.

Site is not imported. No automation station is imported.

Displays the management stations found with the defined management station designation. The management stations are imported during the scan to the first site found (does not necessarily need to be the first on the alphabetic list).

- Operating and monitoring of online objects is similar to importing data using the Device Wizard.
  Note: Objects that do not receive text reference via the meta data, displays only one ID number.
- Online data import is described in document "CM110591 Section 11.3.4 Import Online Data".

**Refresh values**

Changes of object states and values are normally refreshed automatically in the Object Viewer.

However, a manual refresh is required in the following cases:

- After manual editing of object properties such as the user designation text
- After connecting a site

1. In the Object Viewer, select **View > Refresh**.
   OR
   Click "Refresh" on the object view toolbar.
   OR
   In the Object Viewer, press <F5>.

**On top**

You may wish to keep the Object Viewer open and on top of other programs, enabling you to drag and drop several objects into Trend Viewer, for example. To do so:

1. Select **View > Always on Top**.
   OR
   Click **Always on top** on the object view toolbar.
   This switches between enable and disable.
6.1 Display detailed data point information from the Object Viewer

Select a data point

1. Display System Browser if necessary by clicking the Show/hide System Browser button on the Object Viewer toolbar.
2. Expand the System Browser view down the tree to display the required object. If you have problems locating the required object, use the Find function as described above.
3. Click the object in the System Browser view to display detailed information in the contents pane of Object Viewer.

Displaying the object states

The attributes of an object also indicate the current status by means of an abbreviation (e.g. ZY). Double-click the attribute line to open the properties dialog box. In this dialog box, the state is described in plain text with the associated abbreviation.

<table>
<thead>
<tr>
<th>State</th>
<th>Name</th>
<th>Explanation</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Alarm</td>
<td>Limit value exceeded.</td>
<td>Limit value exceeded</td>
</tr>
<tr>
<td>D</td>
<td>Delay period still active.</td>
<td>Pump overrun active.</td>
<td>Pump overrun active</td>
</tr>
<tr>
<td>F</td>
<td>Communications failure to I/O module.</td>
<td>Wrong I/O module in use.</td>
<td>Wrong I/O module in use, no sensor</td>
</tr>
<tr>
<td>Column A</td>
<td>Column B</td>
<td>Column C</td>
<td></td>
</tr>
<tr>
<td>----------</td>
<td>----------</td>
<td>----------</td>
<td></td>
</tr>
<tr>
<td>O</td>
<td>Manually overwrite object.</td>
<td>PXM10 / PXM20 or Desigo Insight has set value.</td>
<td></td>
</tr>
<tr>
<td>Q</td>
<td>Default value is active</td>
<td>Input not connected. No values have been set</td>
<td></td>
</tr>
<tr>
<td>R</td>
<td>Alarm not yet reset.</td>
<td>Press</td>
<td></td>
</tr>
<tr>
<td>S</td>
<td>Output module on manual.</td>
<td>The switch is set on the output module (no software function can overwrite the value). The physical input/output is decoupled from the processing</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Input module on manual.</td>
<td>Default of a certain value to the application program.</td>
<td></td>
</tr>
<tr>
<td>U</td>
<td>Alarm not yet acknowledged.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>V</td>
<td>Value object overwritten</td>
<td>The object is interconnected at the input. Alarming is switched off via EnEvt</td>
<td></td>
</tr>
<tr>
<td>W</td>
<td>Object overridden by external switch.</td>
<td>switch panel is switched off. Fire alarm active</td>
<td></td>
</tr>
<tr>
<td>X</td>
<td>Alarm switched off</td>
<td>Object is switched off via EnEvt. The fan can be switched on only after the damper is open</td>
<td></td>
</tr>
<tr>
<td>Y</td>
<td>Object overridden by safety function.</td>
<td>Fire alarm active.</td>
<td></td>
</tr>
<tr>
<td>Z</td>
<td>Manually overwrite object by system.</td>
<td>The fan can be switched on only after the damper is open.</td>
<td></td>
</tr>
</tbody>
</table>

**Function history**

Object Viewer keeps a history of the last 20 objects selected. There are two ways of navigating to previously selected objects using the **History** option in Object Viewer.

**Scrolling back and forth through the history:**

1. Click **Back** and **Forward** buttons on the toolbar to scroll through the 20 entries in the history.
   OR
   Select **Back** or **Forward** in the **Go** menu, or
2. Press `<Alt + Left arrow>` or `<Alt + Right arrow>` to scroll up and down through the history.
3. Select a certain entry from the history:
   You can display the list of history entries before and after your present position:
4. Click the drop-down button next to the **Back** or **Forward** on the toolbar. You can then select an entry from the displayed list.

Drop-down arrow used to display the history of entries before your current location in the process.
Working with the Favorites folder

To simplify navigation to frequently used objects, you can add them to the Favorites folder.

You can then jump from Object Viewer to one of these objects as follows:

1. Select the Favorites menu in Object Viewer to save your “Favorites”.
   OR
   Click Favorites on the toolbar.

2. From the list select the shortcut to the required object.

Add to Favorites

You can add an object to the Favorites folder as follows:

1. Navigate to the required object in the Object Viewer tree and select it.
2. Select Favorites from the menu and Add to Favorites.
   OR
   Click Add to Favorites on the toolbar.

3. Enter the name of the link.

4. Click OK.

Rename or delete favorites

The shortcuts in the Favorites folder can be renamed or deleted as follows:

1. Click Favorites on the object view toolbar.
   OR
   Select Favorites > Organize Favorites.
2. In the Organize Favorites dialog box, select the shortcut to be deleted or renamed:
3. Click **Rename** to change the shortcut name.
   OR
   Click **Delete** to remove this data point.

4. Click **Close** to close the **Organize Favorites** dialog box.
6.1.1 Change object values and properties from Object Viewer

Before you begin this procedure, make sure you are connected to the site. (You can check this from the connection indicator on the Desigo Insight toolbar, or by choosing Connect/Disconnect in the Desigo Insight menu.)

1. Show System Browser.
   (See “Show/hide System Browser” earlier in this section.)
2. Select the desired object. Expand the System Browser view as required.
   The object is displayed in the content window.

Note
When you right-click Name in the dialog box for the Value tab, you can show the associated logical value for binary and multistate data points.

<table>
<thead>
<tr>
<th>Display without value</th>
<th>Display with value</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Image" /></td>
<td><img src="image2.png" alt="Image" /></td>
</tr>
</tbody>
</table>

Note
Not all users have the right to override or edit object values or properties. The linked options are hidden in this case.

Note
Objects may only be edited, but never deleted in the Object Viewer, since the displayed objects are engineered on the process device. This applies to:
- Data points
- Calendars
- Notification Classes
- User groups

6.1.2 Override outputs

1. Double-click attribute PrVal in the pane.
   The Properties dialog box opens

![Image](image3.png)
2. Select the Place data point in manual (i.e. overridden) state checkbox.

**Analog values:**
Change the value or state with:
- Spin buttons
- Slide

3. Select the priority you want to use to write the output object. Standard priority for Desigo Insight is 8 (see write priority).

**Digital or multistate values:**
Change the value by selecting the state.

4. Click **Apply** or **OK**. This sends the new value to the field device.

**Caution**
The lower write priority, the more safety precautions in Desigo PX can be bypassed. This may result in injury or damages due to unintended use!

**Note**
Manually overwriting a value means that the value remains valid until the following occurs:
- The value is overridden by a higher-priority value.
- The value is overwritten by a same-priority value.
- The value is reset to NULL (see "Enable outputs").
6.1.3 Enable outputs

After a fault is resolved, the set value must again be enabled.

1. Double-click attribute **PrVal** in the pane.
2. Select the priority you used to write the output object.
3. Select the **Set NULL** checkbox.
4. Click **Apply** or **OK**.

Tip

You can check the current BACnet priority by clicking the properties of **PrioArr**.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yes, Off</td>
<td>Value active, Value = Off</td>
</tr>
<tr>
<td>Yes, On</td>
<td>Value active, Value = On</td>
</tr>
<tr>
<td>No, &lt;NULL&gt;</td>
<td>This priority is not considered.</td>
</tr>
</tbody>
</table>

**BACnet write priority**

Individual priorities have predefined meaning.

In [PrioArr], two neighboring priorities are reserved for protection of persons, plant protection, manual operation, and plant operation.

- The higher priority (lower number) of these priority pairs is reserved for local plant control and monitoring (priorities 1, 4, 7, 15).
- The lower priority (higher number) of the priority pairs is reserved for superposed control and monitoring (priorities 2, 5, 8, 16).
- Priority 6 is reserved to guarantee switch-on and switch-off delays as well as to ensure adherence to minimum switch-on and switch-off times.

This ensures that local commands receive greater priority (e.g. Emergency Off of the plant) than safety functions from a higher partial plant.
For more information on BACnet write priorities, see Documentation on basics CM110664, Section 24.

### 6.1.4 Override inputs

1. Double-click attribute **OoServ** (Out of Service) in the pane. The **Properties** dialog box is displayed.
2. Select **On**.
3. Click **OK**.
4. Double-click attribute **PrVal** (Out of Service) in the pane.
5. Select a value.
   - Select **On** for digital inputs.
   - Select the corresponding value for analog inputs.
6. Click **Apply** or **OK**.
   - The new value is sent to the field device.

**Override parameter**

1. Double-click the desired attribute in the pane. The **Properties** dialog box is displayed.
2. Select the state.
   - OR
   - Enter a corresponding parameter value.
3. Click **Apply** or **OK**.
   - The new value is sent to the field device.

**Change comment required**

Enter a text in the comment field for projects requiring a mandatory change comment upon change of value. The change of value is activated only after you click **Save Comment**.

**Note**

Not all users are authorized to override or change object values or properties. In these cases, associated options are hidden.

**Note**

Object Viewer only allows for changing, not deleting objects, as the objects displayed are engineered in the process unit. This applies to:
- Data points
- Calendar
- Notification classes
- User groups

### 6.1.5 Edit Notification Class

**General**

The Notification Class is determined using alarm class and alarm processing categories \((\text{AlmCl} + \text{AlmFnct} = \text{NotifCl})\). You can edit the properties using the Object Viewer if you want to edit a Notification Class. Requirement: You must have the property write rights for the corresponding properties.

See CM110592 Section 3.2.2 Alarms and the automation system Desigo PX.

### 6.1.6 Change comment required

Appropriate text must be entered in the comment field on project requiring a change comment for a change of value. The change of value is only actively switched after confirm and saving the comment. This function used only for Desigo PX Automation stations.
6.1.7 Change user designation text

During the engineering of a Desigo Insight subsystem, information such as the engineering unit, the precision of the value to be displayed and the minimum/maximum limit of every object in the automation system is imported into the Desigo Insight system database. These properties define the format of information displayed in Object Viewer and Plant Viewer.

Depending on your project, you may find that user designations of the objects have also been retrieved from the subsystem and imported into the system database. The user designation can be modified in Object Viewer. Considerable caution is required however (see below).

⚠️ Caution

When values or text are modified in Object Viewer, the associated changes are made in the management station database, but not in the automation systems. As a result, the information in the management station is no longer consistent with the information in the automation and control system. It is essential to carry out a database import, to fix the inconsistencies. It is also possible that information modified manually in Object Viewer might be overwritten and therefore lost during a future database import.

Only perform these steps if you are fully aware of all the consequences and have discussed the procedure with your Siemens Building Technologies engineering specialist (see the previous warning note).

1. Show System Browser.
   (See “Show/hide System Browser” earlier in this section.)
2. Right-click the desired object and select Properties.
3. Select the User Designation tab.
4. Select Define user designation for this object.
5. Enter the user designation for this object in the field containing the pre-defined user designation structure.
   To do so you can either type in all the information, or you can select existing text from a list by clicking the button associated with each block.
6. Click OK to save the new user designation in the system database.
6.2 Instruction texts to create alarms

Why instructions? Instructions provide the user additional information an event (alarm) or an object in the user's plant. Informative instructions can help the user eliminate faults faster, at lower costs and with less stress or to introduce the appropriate measure to eliminate the fault.

Since the texts are very project-specific, definitions are more logically created by the plant user (operator).

Create concept Before starting the actual creation of instructions, it is important to consider what instructions may pop-up numerous times in the plant. Considerable time and effort are saved if instructions can be assigned to multiple objects.

Select object Instructions can only be created for objects visible in the Object Viewer, e.g. temperature sensor.

1. Right click the desired object in the System Browser. Select Properties.
2. Click the To Do text tab.
3. Click Configure.... Custom texts are displayed.
Create text

These texts apply across site to avoid the need to newly define texts for each site in a project.

1. Click **New** to start the user text editor.

![User Text Editor](image)

2. Define a unique name in the **Name** field, e.g. Fire alarm (max. 20 characters) and describe the appropriate measure in the large text field.

3. Click **OK > OK** to save the data.

OR

Click **OK > New** to define the next entry.

Note

Only users with the appropriate access can create or change instructions.

Create hyperlink

You can create a hyperlink to the supplier data to avoid installing all the data on a local computer.

Note

Hyperlinks to the supplier may change. Adapting the hyperlinks is an absolute must (refer to text editing).

The following methods are available to create a hyperlink in an instruction:

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><a href="Mailto:xx.xx@siemens.com">Mailto:xx.xx@siemens.com</a></td>
<td>Opens the mail dialog.</td>
</tr>
<tr>
<td><a href="http://www.siemens.com">http://www.siemens.com</a></td>
<td>Opens the website.</td>
</tr>
<tr>
<td>&lt;File://c:\mye file.txt&gt;</td>
<td>Opens the file</td>
</tr>
<tr>
<td>&lt;Ftp://C:\mye fdp file.txt&gt;</td>
<td>Loads the file from the fdp.</td>
</tr>
</tbody>
</table>

Note

Hyperlinks to folders with a space in the path must be defined with `<…>` e.g. `<file://c:\My folder\Info.txt>`

Text editing

1. Click **Edit** to open the user text editor.

2. Change the text in the **Name** field or in the large text field for the instruction.

3. Click **OK > OK** to save the data.

4. OR

5. Click **OK > Edit** to change the next entry.
**Text assignment**

The corresponding instruction can be assigned to every data point visible in the object structure.

1. Select the text you want to assign to the object.
2. Click **OK**. The text is applied in the text dialog.
3. Click **OK** or **Apply** to save the data.

OR

Click **Cancel** to reject the input.

**General text**

The corresponding, additional text can be assigned to every data point visible in the object structure. The input and assignment is the same as for the instructions. This general text is, however, only visible in Object Viewer and should, therefore, only be used with the instruction is not directly related to an alarm, e.g. a reference to a data sheet.
7 Operate graphics

Chapter overview
This section provides all the information required by the user to operate graphics (Plant Viewer) and the associated plant.

Start Plant Viewer
1. Click the Plant Viewer  on the Desigo Insight taskbar.

Note
Your system may be configured so that Plant Viewer is launched automatically when you start Desigo Insight.

7.1 Layout of the Plant Viewer screen

The Plant Viewer screen consists of the following basic areas:
- Navigation bar.
- The graphics page(s)

The Windows taskbar is visible and accessible

7.2 Help in Plant Viewer

Tool tip
If tool tips have been engineered for your system, they appear automatically when the cursor is pointed at a specific item on the graphics page.

They provide a brief text label describing the function of an icon or button, for example. In Plant Viewer you can specify the type of text label you want to see when you point at a graphic object.

In addition to displaying the engineered tool tip text, you can toggle between three additional options:
- No additional text
- Supplemental technical designation.
- Additional system designation.
- Supplemental user designation.

Display tool tip
1. Right-click the Plant Viewer navigation bar. Select Tool tips.
2. From the options displayed, choose “Technical Designation”, “System Designation”, “User Designation” or “None”.

<table>
<thead>
<tr>
<th>Select</th>
<th>For…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Technical designation</td>
<td>… a text label based on the hierarchy of the BACnet objects.  E.g. Site:A'Aoa'FanEh'Cmd.FbVal</td>
</tr>
<tr>
<td>System designation</td>
<td>… a text label based on the system address.  E.g. Site:AS10'Vnt10'Fan'Cmd.</td>
</tr>
<tr>
<td>User designation</td>
<td>… a text description can display, for example: building, floor, plant type, plant number, data point type and number, etc.  e.g. Siemens'AS01'BZW5'Ahu1'Fan.</td>
</tr>
</tbody>
</table>

3. Move the cursor over an item on the graphics page to display tool tip information. (Do not click the mouse button.)

### 7.3 The navigation bar and the context menus

#### Navigation bar
The following buttons are available on the navigation bar:

#### Functions
Page functions:

<table>
<thead>
<tr>
<th>Buttons</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Last Page</td>
<td>Opens the previously opened graphic page (reverse sequence).</td>
</tr>
<tr>
<td>Forward</td>
<td>Opens the previously opened graphic page (forward sequence)</td>
</tr>
<tr>
<td>Page History</td>
<td>Displays a list of the six most recently selected graphics pages.</td>
</tr>
<tr>
<td>Page Down</td>
<td>Opens the previous (underlying) graphics page in the hierarchy defined in your system.</td>
</tr>
<tr>
<td>Page Up</td>
<td>Opens the previous (parent) graphics page in the hierarchy defined in your system. If the page appears in the root of the page browser, i.e. there is no parent page, this icon is grayed out.</td>
</tr>
<tr>
<td>Next Page</td>
<td>Opens the next graphics page in the sequence defined for your system; (must be engineered: not every graphics page has a “next page” defined).</td>
</tr>
</tbody>
</table>
**Select page**  
Opens a list box, from which you can select a graphics page to open. If engineered accordingly, the graphics pages may be displayed in a hierarchical structure. You may also be able to choose whether to open the selected graphics page in addition to, or instead of the currently open graphics page, depending on your user privileges.

**Top Page**  
Opens the “Top” graphics page, i.e. the opening screen for your system. (This may be a photo of the building or a map of a building complex, for example).

**System overview page**  
Opens the “System Overview” (topology) graphics page, if available.

**Present overview page**  
Opens the “current overview page” of the defined graphics page. It is context related, i.e. open various graphic pages depending on the queried location.

**Favorite pages**  
Keeps a list of maximum 20 “Favorite” graphics pages.

### Special functions:

<table>
<thead>
<tr>
<th>Buttons</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Setup</td>
<td>Defines the layout of the graphics page to be printed and the printer used.</td>
</tr>
<tr>
<td>Print Preview</td>
<td>Shows a print preview of the graphics page in the active window.</td>
</tr>
<tr>
<td>Print</td>
<td>Prints the graphics page in the active window.</td>
</tr>
<tr>
<td>Page data snapshot</td>
<td>Displays a text summary of all the objects of the graphics page in the active window.</td>
</tr>
<tr>
<td>Page description</td>
<td>Lets you create a text file with your own description of the graphics page in the active window.</td>
</tr>
<tr>
<td>Page properties</td>
<td>Displays the properties of the graphics page in the active window.</td>
</tr>
</tbody>
</table>

**Reference**  
For information about printing from the Desigo Insight, refer to:  
- “Printing” in the “General operation” section of this manual  
- “Printing from Plant Viewer” in this section
Handling multiple windows with the buttons on the Plant Viewer navigation bar:

<table>
<thead>
<tr>
<th>Buttons</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tile Horizontally</td>
<td>Arranges all the open graphics pages on the screen.</td>
</tr>
<tr>
<td>Tile Vertically</td>
<td>The graphics pages can be “tiled” (arranged horizontally or vertically)</td>
</tr>
<tr>
<td>Cascade</td>
<td>or “cascaded” (overlapping).</td>
</tr>
<tr>
<td>Select Window</td>
<td>Selects an option from the list of open windows, and bring it to the foreground.</td>
</tr>
<tr>
<td>Close Window</td>
<td>Closes the active window</td>
</tr>
<tr>
<td>Close All Windows</td>
<td>Closes all currently open windows.</td>
</tr>
<tr>
<td>Project help</td>
<td>Project-specific help (not available in all projects).</td>
</tr>
</tbody>
</table>

Tip

All the navigation functions on the navigation bar are also available in the Page context menu. To display the Page context menu, right-click in the background of a graphics page.

System context menus

To display the System context menu right-click anywhere on the navigation bar (but not on a button).

The System context menu appears, as shown below:

- Saves custom workspace setting upon exit from Plant Viewer.
- Defines additional information referenced in ToolTip for graphic symbols.

Page context menus

To display the Page context menu, right-click anywhere on the background of a graphics page.
The navigation commands in the Page context menu have the same functions as the corresponding buttons on the Plant Viewer navigation bar (see above for a description).

7.4 Display/hide the navigation bar

**Show / Hide**

The navigation bar is displayed automatically when Plant Viewer is started, but it can be hidden and redisplayed as follows:

1. Right-click anywhere on the background of a graphics page (but not over a symbol).
2. Select Show Navigation Bar.

**Tip**

Key combination: Press <Ctrl+N> to show or hide the navigation bar.

**Project-specific help**

The project-specific help allows for defining customized processes, e.g. behavior in the case of alarm messages.

1. Click on the Plant Viewer taskbar.
2. Go to the desired information
This project-specific help is not a part of standard delivery by Siemens; it must be ordered separately as needed.

### 7.5 Open graphics pages

#### Navigation methods
You can navigate between graphics pages in three main ways:
- Buttons on the navigation bar
- Options in the Page context menu
- Engineered buttons and symbols on the graphics pages. This last method is described under “Operating the graphics” later in this section.

#### Note
Typically, the total number of windows which can be open simultaneously in Plant Viewer is limited to ten. Double-click the page name, or select it and click OK to open the graphics page and close the Select Page dialog box.

#### Open a graphics page
To open a graphics page in a window:

1. Click Select Page on the navigation bar, to open the Select Page window.
2. Click + to expand the tree structure. Double-click the page names.
   OR
   Select page names and click OK (dialog box closes).
   OR
   Click Apply to open the graphics page without closing the dialog box.

When enabled, you can keep a previously opened window on-screen or open and display the selected page in a new window.

#### Tip
Key combination: Press <Alt+P> on the keyboard to display the Select Page list.

#### Navigate between graphics pages
Use the buttons on the navigation bar as described above under “The navigation bar”.

#### Add to Favorites
It is possible to add frequently-used graphics pages to a list of “Favorite” pages. This list is easily accessible from the navigation bar. To add a graphics page to the list:
1. Open a “Favorite” graphics page (i.e. one to which you know you want to return to frequently).
2. Click **Favorites** on the navigation bar.
3. Click **Add to Favorites** to add your selected open graphics page to the list.
   The graphics page name now appears in a drop-down list whenever you click the **Favorites** button.

**Note**
The Favorites list can hold a maximum of 20 graphics pages.

**Open Favorites**
1. Click “Favorites” on the navigation bar to display a drop-down menu.
2. Press <Alt+5> to open Favorite page No. 5.

**Tip**
You can directly access the first 10 graphics pages with the key combination <Alt+"Favorites number">.
Example:
For example, press <Alt+5> to open favorites page number 5.
To access favorites 10 – 19, click the favorites button on the Plant Viewer navigation bar.

**Remove from favorites**
To remove a graphics pages from the Favorites folder, follow steps 1 to 2 above but click **Remove from Favorites** as step 3.

### 7.6 Components of the graphics pages

**Definition**
The graphics pages appear in the main area of the Plant Viewer screen, and in essence, comprise the following:

<table>
<thead>
<tr>
<th>Graphics component</th>
<th>Linked with object</th>
<th>Definition</th>
<th>Possible user action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background</td>
<td>No</td>
<td>Background of a graphics page, consisting of a simple background Color or, perhaps, a photo of a building, or a bitmap of a floor-plan. The background is static and not linked to any object.</td>
<td>Right-click in the background of a graphics page invokes the Page context menu</td>
</tr>
<tr>
<td>Symbols</td>
<td>No</td>
<td>Symbols not linked to any object. These behave in the same way as the static background of a graphics page.</td>
<td>Right-click invokes the Page context menu</td>
</tr>
<tr>
<td>Genie</td>
<td>Yes</td>
<td>Symbols linked to one or more objects.</td>
<td>Right-click invokes the Object context menu</td>
</tr>
<tr>
<td>Program Genie</td>
<td>Yes</td>
<td><strong>This is a subset of the genie.</strong> They can be identified by the white frame which appears when the cursor is passed over them.</td>
<td>Right-click invokes the Object context menu</td>
</tr>
<tr>
<td>Genie</td>
<td>Yes</td>
<td><strong>This is a subset of the genie.</strong> They can be identified by the white frame which appears when the cursor is passed over them.</td>
<td>Right-click invokes the Object context menu</td>
</tr>
<tr>
<td>Buttons</td>
<td>Sometimes</td>
<td>Visible or invisible buttons (or areas) which respond when clicked on, e.g. by opening a graphics page, operating an object, opening another program or executing a given function. They can be identified by the white frame which appears when the cursor is passed over them.</td>
<td>Left-click performs the action defined</td>
</tr>
</tbody>
</table>
Move the mouse cursor over a symbol and right-click.
If the Object context menu opens, this indicates that there is an object linked to that symbol. Symbols of this type are referred to as **Genies**.

Releases from manual state.

Display object property sheet. Navigate to other Desigo Insight programs via object name or property name

Example of an Object context menu invoked by a right-click a Genie.

**Super-Genie**

Move the mouse cursor across the graphics page. As the cursor passes across an operable symbols with attached super genie pages and all buttons are shown outlined with a rectangle. (The default Color of the rectangle is white.)

Frame indicates that this is either a Genie with referenced super genie, or a button.

Left-clicking inside the white frame results in the following:

On a button:
- Left-click operates the button

On a Genie with referenced Super-Genie:
- Left-click opens the super genie (a small pop-up window).
7.7 Graphics operation principles

Mouse use

Because of the significance of the context menus in Plant Viewer, it is important to note the following conventions for operating the mouse within a graphics page:

<table>
<thead>
<tr>
<th>Action</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Right-clicking an operable symbol displays the Object context menu</td>
<td>Executes an action, for example, opens a Super-Genie, operating a button.</td>
</tr>
<tr>
<td>Right-click</td>
<td>Displays a context menu. The context is defined by the position of the mouse before the right-click. Right-clicking the navigation bar displays the System context menu. Right-click the static background and on a symbol: displays the page context menu. Right-click a Genie: displays the Object context menu. Right-click a Genie: displays the Object context menu.</td>
</tr>
</tbody>
</table>

Navigating in graphics pages larger than the screen

Use either the scroll bars or the engineered buttons to navigate within large graphics pages.

Example of engineered buttons for navigation of the four fourths of the graphics page that are larger than the screen.

Save workstation on Exit

You can save the workspace (the open windows and their position) when you close Plant Viewer. As follows:

1. Right-click in the navigation bar before closing Plant Viewer to display the System context menu.
2. In the System context menu, make sure that the option “Save Windows on Exit” is ticked.
### Keyboard shortcuts

The following default shortcuts are defined in Plant Viewer:

<table>
<thead>
<tr>
<th>Keys</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Start project-specific help (if available in your project)</td>
</tr>
<tr>
<td>Alt+F4</td>
<td>Close Plant Viewer</td>
</tr>
<tr>
<td>Alt+P</td>
<td>Open the Page selection menu</td>
</tr>
<tr>
<td>Home</td>
<td>Open the Top page</td>
</tr>
<tr>
<td>Alt+0..9</td>
<td>Open Favorite graphics page 0..9</td>
</tr>
<tr>
<td>Ctrl+N</td>
<td>Show/hide Plant Viewer navigation bar</td>
</tr>
<tr>
<td>Ctrl+P</td>
<td>Print page in active window</td>
</tr>
<tr>
<td>Ctrl+F</td>
<td>Find Tag</td>
</tr>
<tr>
<td>F5</td>
<td>Back</td>
</tr>
<tr>
<td>F6</td>
<td>Forward</td>
</tr>
<tr>
<td>F7</td>
<td>Next Page</td>
</tr>
</tbody>
</table>

### 7.8 Add comments to pages

**Scope**

It is possible to add individual comments to every graphics page. This feature can be used for example to describe plant and equipment in detail, to add instructions or information about localization, or to attach information such as supplier addresses. The text is saved in an individual file for each graphics page.

**Display or add comments**

To add or display a comment as described above under “Scope”, follow these steps:

1. Select the desired graphics page.
2. Click the “Page description” in the Plant Viewer navigation bar. The text editor program starts.
3. Click Yes to create a new file.
4. You can now enter or change comments for graphics pages.
5. Click File > Save or Save under and enter the corresponding file name.
6. Click Save.
7. Exit the text editor.

### 7.9 Status indication in Plant Viewer

**Genie with alarm symbols**

The following is just one example of an alarm indicated in Plant Viewer, in this case a maintenance alarm:

- Alarm bell
- Clock with pliers indicates a maintenance event.
The following alarm states can be displayed:

<table>
<thead>
<tr>
<th>Alarm state</th>
<th>Display</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>Into Alarm (Extended alarm)</td>
<td>Indicated by a swinging red alarm bell</td>
<td></td>
</tr>
<tr>
<td>Into Alarm</td>
<td>Indicated by a red alarm bell</td>
<td></td>
</tr>
<tr>
<td>Acknowledged alarm</td>
<td>Indicated by a red alarm bell marked with a tick</td>
<td></td>
</tr>
<tr>
<td>Unreset alarm</td>
<td>Indicated by a gray alarm bell marked with a tick</td>
<td></td>
</tr>
<tr>
<td>Normal not reset (Extended alarm)</td>
<td>Indicated by a gray bell marked with a cross</td>
<td></td>
</tr>
</tbody>
</table>

For run-time and maintenance events a clock with a spanner symbol is shown:

Maintenance symbol: 🕒🔧

The manual state of an object is indicated with a yellow “hand” symbol:

Example of a valve set manually to 80%

Communications failures or failures in the automation system that prevent Plant Viewer from displaying the correct value of an object are indicated by special symbols in place of the normally displayed value:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
<th>Indicated state</th>
<th>User action</th>
</tr>
</thead>
<tbody>
<tr>
<td>#COM</td>
<td>Hash COM</td>
<td>Communication failure between management</td>
<td>Check connection with automation system.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>station and automation system</td>
<td></td>
</tr>
<tr>
<td>?</td>
<td>Red question mark</td>
<td>Error, automation system.</td>
<td>Check automation system and automation system communication</td>
</tr>
<tr>
<td>#ASS</td>
<td>Hash ASS in Super Genie</td>
<td>Communication failure between management</td>
<td>Check connection with automation system.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>station and automation system</td>
<td>Check Cicode Function.</td>
</tr>
</tbody>
</table>

The following process plant or object states are displayed in the Super Genie:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Process state</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>⚠️</td>
<td>Safety</td>
<td>Personal safety so that the object cannot be</td>
</tr>
<tr>
<td></td>
<td></td>
<td>switched.</td>
</tr>
<tr>
<td>🛠️</td>
<td>Lock</td>
<td>Lock a dependent object, e.g. a damper must be</td>
</tr>
<tr>
<td></td>
<td></td>
<td>opened before the fan is switched on.</td>
</tr>
<tr>
<td>🔄</td>
<td>Delay</td>
<td>Delay is active, e.g. dampers must be opened</td>
</tr>
<tr>
<td></td>
<td></td>
<td>first.</td>
</tr>
<tr>
<td>🎯</td>
<td>Manual switch</td>
<td>Panel switch is set manual.</td>
</tr>
<tr>
<td>🎯</td>
<td>Manual interven-</td>
<td>User intervention with PXM20 or Desigo Insight.</td>
</tr>
</tbody>
</table>
### 7.10 Handle alarms in the Plant Viewer

Alarms can be acknowledged or reset with the Super Genie.

**Simple object**

Simply objects with only a physical data point, e.g. valve, damper, can be directly acknowledged.

1. Move the mouse cursor over the alarm bell.

2. Left-click inside the frame to open the super genie.

3. Acknowledge or reset the alarm using the buttons.

4. Exit the super genie.

**Hierarchical object**

Hierarchical objects than are assigned more than one physical data point, e.g. fan, pumps are acknowledged via an expanded alarm super genie.
1. Move the mouse cursor over the alarm bell. Left-click inside the frame to open the super genie.

2. Click to display data point information.
3. Acknowledge or reset the alarm using the buttons.
4. Exit the super genie.

7.11 Modify object and property values in Plant Viewer

Types of operation

Plant Viewer is designed to allow you to modify values via the graphical interface. The various operations can be categorized as follows:

- Modification of values and states via the super genie.
- Modification of values and states directly in the graphics pages using the standard buttons for operation.

The standard buttons used to operate the different object types are basically the same in both the super genie and the graphics pages. They are described below. It is possible that your project may include additional buttons or other elements for operation.

Access rights

Depending on access rights, you can view values or change them. Desigo Insight is designed to gray out buttons with lower access rights or a super genie displays less information.

Change comment required

Enter a text in the comment field for projects requiring a mandatory change comment upon change of value. The change of value is activated only after you click OK.
### Example setpoint

**With write access**

<table>
<thead>
<tr>
<th>Value</th>
<th>40.0</th>
</tr>
</thead>
</table>

**Without write access**

<table>
<thead>
<tr>
<th>Value</th>
<th>40.0</th>
</tr>
</thead>
</table>

### Example buttons

**With write access**

- ON/OFF button
- AUTO/Manual button
- Option button
- Checkbox

**Without write access**

- ON/OFF button
- AUTO/Manual button
- Option button
- Checkbox

### Access rights

<table>
<thead>
<tr>
<th>Counters</th>
<th>Analog value</th>
<th>Digital or multi-state value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Low</td>
<td>Low</td>
<td>Low</td>
</tr>
<tr>
<td>Medium</td>
<td>Medium</td>
<td>Medium</td>
</tr>
<tr>
<td>High</td>
<td>High</td>
<td>High</td>
</tr>
</tbody>
</table>

### Operation elements

<table>
<thead>
<tr>
<th>Object type</th>
<th>Standard buttons for operation</th>
<th>Description</th>
<th>Process</th>
</tr>
</thead>
<tbody>
<tr>
<td>Digital value</td>
<td>ON button (green)</td>
<td>Click to switch equipment on</td>
<td></td>
</tr>
<tr>
<td></td>
<td>OFF button (grey)</td>
<td>Click to switch equipment off</td>
<td></td>
</tr>
<tr>
<td></td>
<td>AUTO button</td>
<td>Click to set state to automatic</td>
<td></td>
</tr>
<tr>
<td></td>
<td>MANUAL button</td>
<td>Click to set state to manual</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Option button</td>
<td>Click to toggle state</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Checkbox</td>
<td>Click to toggle state</td>
<td></td>
</tr>
<tr>
<td>Multi-state value</td>
<td>Multi-state buttons</td>
<td>Click to set corresponding step</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Multi-state buttons</td>
<td>Click to set room controller to corresponding operating mode</td>
<td></td>
</tr>
<tr>
<td></td>
<td>MANUAL button with list box</td>
<td>Click to set desired operating mode</td>
<td></td>
</tr>
<tr>
<td>Analog value</td>
<td>Spin buttons</td>
<td>Use the arrows to set the new value or, if possible, edit directly the value field</td>
<td></td>
</tr>
</tbody>
</table>
Change values with super genie

1. Click a genie to open the super genie.
2. Use one of the standard buttons described above, to change the value.
   For analog values, the entered value must be confirmed by pressing the enter key.
3. Check that the new value has been written to and reported from the field, and that the point status has changed to manual.
4. Click the button to reset point status to automatic.
5. Close the super genie.

Operate plants

Plant control is the easiest way to influence a plant. With plant control you can:
   - Turn the plant on/off.
   - Adjust setpoint.
   - Navigate to schedule.
   - Navigate control sequences.
   - Acknowledge / reset alarms.

The examples below how plant control can be presented for the user.

Air handling plant

Heating group

Operate valve

Window title with object names

Present operating state.

Present object state.

- Button for switching object to automatic.
- Spin button to manually change the value.
- Button to exit the super genie page.

Example: Super genie for a valve.
7.12 Display properties of symbols, genies, and graphics pages

Symbol properties

Available symbol, genie properties:

- Object name
- Object type
- Object description
- Object system designation
- Object user designation
- User designation structure

The following properties (depending on object type) are available only if the linked object can be written to:

- Object value (can be modified if the user has the necessary privileges)
- Range, engineering unit and precision (can be modified if the user has the necessary privileges)

⚠️ Caution

Note that editing the range (min./max. value) of an object can cause problems in already engineered Plant Viewer graphics pages!

Reference

For general guidelines and details of how to modify object properties from property sheets:

refer to “Modifying object values and properties from Object Viewer” in the “General operation” section of this manual.

Display properties

1. Right-click genie. Linked objects are displayed.
2. Select the desired object or property names.

If there is more than one object name or property name associated with a symbol, a list is displayed.


Properties of a graphics page

1. Right-click the graphic page background. The context menu opens.
2. Select Page properties.

The available properties of a graphics page are:

- General tab:
  - Page name.
  - Page title.
  - Description.
  - Previous page.
  - Area.
  - Sampling time.
  - Scan time.
  - Events tab:
7.13 List object properties for a graphics page

You can display a list of objects and their properties on a graphics page.

1. Open the corresponding graphics page.

2. Click **Page Data Snapshot** on the navigation bar.
   OR
   Right-click the graphic page background. The context menu opens.
   Select **Page Data Snapshot**.

3. The resulting report is displayed in a text editor program.

4. Select **File > Save as** to save the text file.

Note

A focus must be on the super genie for super genies. A summary of the data from a super genie and a graphics page cannot be displayed in the same snapshot.

7.14 Print from the Plant Viewer

You can print a graphics page with the current information.

Configure print settings

You can configure the print settings specially for printing in the Plant Viewer:
- Printer selection and printer properties configuration
- Paper size and orientation

1. Click **Page Setup** on the navigation bar.
   OR
   Right-click the graphic page background. The context menu opens.
   Select **Page Setup**.

2. Configure the print settings.

3. Click **OK**.

Display and operate the print preview

Print preview provides an on-screen preview.

1. Click “Page Preview” on the navigation bar.
   OR
   Right-click the graphic page background. The context menu opens.
   Select **Page Preview**.
2. Check the displayed preview, if necessary using the scroll bars or by zooming in and out.

3. Click Exit on the window title bar to close the page preview window.

Note
If you are ready to print directly, you can start printing straight from the preview, by clicking the Print button on the Print Preview toolbar.

Print graphics page
Print present graphics page
1. (Optional): Check the settings by displaying a print preview (see above).
2. Click Print on the navigation bar.
   OR
   Right-click the graphic page background. The context menu opens.
   Select Print.
3. The graphics page, with a print header, is printed as defined in the Page Setup... menu.

Tip
To print an immediate “snapshot” of the screen, press <Alt+PrintScrn> for a snapshot of the currently active window or <PrintScrn> for a snapshot of the entire screen. These commands copy the selected snapshot to the clipboard.
When you select the print preview page, a bitmap image is automatically generated and saved to the clipboard. This enables you to insert it into another program without difficulty. (Limitation: the image must not exceed the standard dimensions.)
7.15 Navigate to other Desigo Insight programs via object or property name (Send To...)

**Navigation**

You can navigate to other Desigo Insight programs from Plant Viewer via the object name or property name of the selected symbol.

This feature can be used for example:

1. To open Alarm Viewer from a graphics page in Plant Viewer in which an alarm is indicated, automatically filtering the list of alarms by the corresponding object name or property name.
   OR
   To open Trend Viewer and automatically start a trend (online or offline) with the corresponding object.

Navigation is as follows:

1. In Plant Viewer right-click a genie and select the required object (by object name or property name)
2. Point to Send To > and select the target program from the list.

**Send To Trend Viewer**

Right-Click the object and click Send To > Trend Viewer. Trend Viewer displays.

A pop-up dialog displays with following options.

Note: This dialog is not displayed for Trend Log Multiple objects or the objects which do not support trending.
Send To Actions

- **View trended series (select from below list)**
  This action allows you to view the trends using the selected trend log in **List of trendlog objects**. This option is disabled when there are no existing recorded trend series.

- **Start online trend**
  This action allows you to set up an online trend for the object sent.
  
  **Always start online trend**: This option is enabled when you select the Start online trend radio button. Skip this dialog in future and directly start the online trend. The box can be unchecked in the Tools menu (see 9.2 Trend Viewer). By default this checkbox is unchecked.

- **Setup offline trend**
  This action navigates to **Create trend log** dialog box which allows you to create the trend log object. This option is enabled when the site of the sent object contains at least one PX device which supports dynamic trend log object crea-
You must have "Create object" privileges to view this dialog.

- **Modify offline trend**
  This action allows you to view **Modify trend log** dialog box. You can modify some of the properties of trend log object and delete trend log object. For delete operation, you must have delete object privileges while for modify, you must have either create or delete object privileges in System Configurator. Refer the property table in 9.4.9.3 Chapter **Settings in the Trend Log Multiple object** for some of the properties.
7.16 Exit the Plant Viewer

Exit Plant Viewer

Exit the Desigo Insight Plant Viewer as follows:
1. Right-click anywhere in the Plant Viewer navigation bar (no on a button). Select **Exit Plant Viewer**.
   OR
   Click the **Exit** button on the right corner of the Plant Viewer navigation bar.
   OR
   Left-click in the Plant View navigation bar in the foreground and press <Alt+F4>.

Save workspace configuration

The position of the open graphics pages can be automatically saved when exiting Plant Viewer. They are then displayed in the same manner when the Plant Viewed is reopened.
1. Right-click anywhere in the Plant Viewer navigation bar (no on a button).
2. Select Save Window during Exit.
8 Alarm handling

Chapter overview
This section describes how the Desigo Insight alarm system works, and how you may use it.

8.1 Principles of alarm handling

What the alarm system does
Your Desigo system controls your building automation and control system plants. Sometimes events occur (e.g. a fault) that is important for the operator to know and requiring user intervention. The alarm system processes and issues the appropriate reports (e.g. to a printer or pager) for such events.

Your Desigo system reacts automatically to a fault (e.g. the ventilation plant is automatically locked during a fire alarm).

An alarm is issued for a control deviation (i.e. a dirty filter triggers only a simply alarm).

In both cases the system changes to an alarm state and a corresponding alarm is issued. The system returns to normal after the cause of the alarm is eliminated and reset by the user.

Hardware elements of the Desigo system
The diagram shows a typical Desigo system reacting to an alarm event. Note the functions performed by the management station, the PXM10 / PXM20 hand-held terminal and the receiver.

1 Physical event.
2 The alarm object in the automation stations changes state and sends out an alarm message.
3 The management stations receives the alarm and forwards it to the receiver. The new state is displayed in the Alarm Viewer.
4 The printer (alarm receiver) prints the alarm.

Alarm messages and alarm states
You must differentiate between these two: An alarm message is what is sent to a receiver, such as a printer.

An alarm state is the condition an alarm object takes when a measured variable is outside normal range.
Alarms are actually a specific type of Desigo Insight event. There are four event types:

1. Alarm events.
2. System events.
3. User events.
4. Status events.

Events are all things that happen within your Desigo system. They are subdivided into the categories above on the basis of their character. All events are capable of being transmitted to one or more “receivers”. They are all assigned a “priority”, i.e. a level of importance. All events are logged and are viewable in Log Viewer.

- **Alarm events**
  
  Alarm events generally constitute a warning, rather than just information. They also differ from other events in so far as they have a dedicated Alarm Viewer, for you to check the current status of the source alarm object. By "alarm object" we simply mean the source of the alarm, which is usually a software element of the PX automation station. Furthermore, the user interactions “Acknowledge” and “Reset” may only be applied to alarm objects.

- **System events**
  
  System events concern activities of the Desigo Insight software running on the management station: this does not include the PX automation station hardware. Typical system events are “Application start” (start Desigo Insight application), “Communication error” and “Router job dispatch”.

- **User events**
  
  User events are things that you (or your colleagues) have done to the Desigo system, via the management station. Typical user events are “Alarm acknowledge”, “Pop-up suppression” and “Time set”.

- **Status events**
  
  Status events concern changes in the operation of the PX automation stations, such as a change from “Stop” to “Run”, and messages from third-party systems.

**Interacting with alarms**

The PX automation stations were programmed to monitor system conditions on alarm states. A software element to check contact state is available for each monitored element (e.g. for each fire protection contact). We refer to this software element as an “alarm object”. When the contact indicates an alarm, then the alarm object changes to the alarm state.

These alarm objects always appear on the Plant Viewer graphics when abnormal, as well as in the Alarm Viewer list. They are not displayed in Alarm Viewer when they are normal. From either point you can see the immediate state of the abnormal alarm object, and, according to the programming of the alarm object, interact with it.

By interact we mean:

- To acknowledge the alarm (state)
- To reset the alarm (so that it returns to the normal state)

All alarm interactions are logged in the log database and can be displayed in the Log Viewer.
**Simple alarm**
Simple alarms (or alarm objects) do not require you to acknowledge or reset, they simply return to the normal state when the monitored condition (e.g. a dirty filter) returns to normal.

**Basic alarm**
More important alarms (e.g. lack of water) must be acknowledged. After the alarm state is eliminated, the plant is once again released after acknowledgement.

**Extended alarm**
For an extended alarm (e.g. velocity monitor), the reset returns the plant to normal. Provided the monitored state returns to the normal range. The idea is that important alarms are not overlooked when the alarm condition clears. The plant must be reset to re-start operation.

For the purpose of monitoring operations, the Log Viewer can be reviewed to see who reacted to a Basic or Extended alarm and when.

⚠️ **Caution**
A reset and acknowledge with the PXM10 / PXM20 / Desigo WEB of a Basic or Extended alarm is not logged in the Desigo Insight Log database. So that checks of the user is not possible at a later date. Do not use these devices in audited projects.

**Alarm priorities**
There are 10 alarm priorities (degrees of importance) numbered from 0 to 9, of which 0 is the highest priority. We typically do not use all levels in Desigo Insight. Each priority is allocated a text description, so that the alarm message which appears at the Desigo Insight management station is easy to understand.

**Event classifications**
These are not used for PX objects in this release of Desigo Insight. There are, however, used for linked SCADA systems (linked system not from Siemens).
Like alarms, the other 3 event types also have a priority: the same priority text description (e.g. “High”, “Low” etc.) is used for all four. Also like alarms, “Category” is not used with the other events.

A number of applications are employed on the Desigo Insight management station for alarm handling:

- **Taskbar (Desigo Insight Shell)**
  - Shows a summary of all site alarms
- **Alarm Viewer**
  - Shows the state of all alarm objects not in a normal state.
- **Log Viewer**
  - Displays a list of all alarm messages.
- **Alarm Router**
  - Used to configure which Alarm receiver receives an alarm message.
- **Alarm Pop-up**
  - Any events can trigger a pop-up window.
- **Plant Viewer**
  - Display the present alarms in a pop-up window.

The other 3 events (User, System, Status) use a limited range of the applications above, being logged and visible via Log Viewer and routable via Alarm Router.

- **System information**
  - An information system dedicated to the status of the management station software. The information here is only visible via the Information application itself.

Alarms may be suppressed for commissioning and servicing work so that no alarm messages are sent. Suppression is normally set using a switch on the panel for the corresponding plant. A change in state of the switch is maintained in the log database. You can document suppressed alarms using the Report Viewer.
You can jump between various Desigo Insight applications using principally **Send to...** as follows:

Note that a filter is applied if you use the taskbar to jump to Alarm Viewer. When using the **Send to...** function, select the object of concern before right clicking to display the option list.

### 8.2 Alarm handling-related Desigo Insight applications

**Plant Viewer**

Plant Viewer gives you a graphical view of the alarm location, showing the status of nearby plant, and also allows you to interact with it. The alarm itself is selected by an icon, for example:

You can click the alarm bell icon to display a standard alarm interaction window:

Using this window you are thus able to acknowledge and reset the alarm. The corresponding buttons are only enabled when appropriate. Acknowledging and resetting is the same as any other Insight application and PXM10 / PXM20 operator units.
The meanings of the various icons is as follows:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
<th>Alarm cause</th>
<th>User intervention</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Alarm</td>
<td>Alarm cause exists.</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Acknowledged alarm</td>
<td>Alarm cause exists.</td>
<td>Acknowledged alarm</td>
</tr>
<tr>
<td></td>
<td>Acknowledged alarm, not reset.</td>
<td>Alarm cause no longer exists.</td>
<td>Acknowledged alarm</td>
</tr>
<tr>
<td></td>
<td>Unacknowledged alarm, not reset.</td>
<td>Alarm cause no longer exists.</td>
<td>None</td>
</tr>
</tbody>
</table>

No more display | Alarm cause no longer exists. | Alarm reset.

You can acknowledge or reset alarms according to the way they have been engineered by us; for example for unimportant alarms a reset is usually deemed unnecessary. Furthermore, you may only reset alarms if the field condition has been returned to normal. These structures are automatically taken care of: only the correct interaction buttons are displayed:

- Acknowledge
- Reset

**Note**

All alarm interactions in Desigo Insight applications are logged, and may be displayed in Log Viewer.

**Extended alarm user interface**

In some cases there is more than one alarm signal pertaining to a single plant item, such as a fan. In such cases clicking the alarm bell icon described above displays an enhanced interface. Note that the actual display depends upon the privileges of the user; a lower level user sees somewhat less of the interface than as shown.

The operation of the lower part of this interface is exactly as the standard alarm window described above.
Manual switch.

The Reliability icon means that the signal source has become unreliable, perhaps being open circuit. Operating mode warns if an override has been applied.

These are displayed at the top right hand side of the Desigo Insight taskbar. As described in the section on navigation, you can click one of the three symbols at any time to display the Alarm Viewer. The display for the selected symbol is filtered by alarm priority.

The alarm priority groupings “High-medium-low”, used in the Taskbar, are nominally set during engineering. The alarm priorities (see introduction) are typically divided:

<table>
<thead>
<tr>
<th>Priority</th>
<th>Taskbar group</th>
<th>Alarm bell stats</th>
</tr>
</thead>
<tbody>
<tr>
<td>0...2</td>
<td>High</td>
<td>State not acknowledged</td>
</tr>
<tr>
<td>3...6</td>
<td>Medium</td>
<td>State acknowledged</td>
</tr>
<tr>
<td>7...9</td>
<td>Low</td>
<td>State normal, not reset or normally not acknowledged</td>
</tr>
</tbody>
</table>

The number in the taskbar icon indicates the total number of alarm objects that are abnormal within the taskbar group. The alarm bell symbol itself indicates the “worst case” state of those objects in the taskbar group, where Unacknowledged is worse than Acknowledged, which is worse than Normal unrest/unacknowledged. The last state is rather unusual as it groups together the states Normal - unacknowledged and Normal - unreset. Where there are no abnormal states within a taskbar group, the icon is not displayed.

Alarm Viewer displays all alarm objects in your Desigo system that are not normal. You may acknowledge and reset alarms from here either singly or in groups (see the section “Using Alarm Viewer to acknowledge and reset alarms”).

Alarm Viewer is concerned with alarm states, not alarm messages: for the latter see below.

Log Viewer - Alarm Section

This displays all alarm messages received by the management station, but not alarm states: the latter is displayed by Alarm Viewer. You cannot acknowledge or reset alarms from here.

Pop-up window

The pop-up window displays the alarm object. When an alarm occurs, you can acknowledge it or switch directly to the Plant Viewer.
When using scopes, the popup window only shows alarms assigned to you.

**Alarm Router**

The Desigo Insight Alarm Router forwards all event messages including alarm messages to receiver devices, so-called receivers. The following receivers may be configured for Desigo Insight:

- Printers.
- Fax machine.
- E-mail receiver.
- Pager receiver.
- File.
- Management station pop-up.

The routing of event messages can be finely tuned, according to:

- Alarm priority.
- The time of day
- The availability of Alarm receivers

Groups of events (routing groups) must be created: it is these that are linked to receivers using Alarm Router.

**8.3 What happens when an alarm occurs**

When an alarm occurs you are informed via a receiver, such as the management pop-up (see diagram in “Hardware Elements of the Desigo Insight alarm system”). Automatic control (e.g. turning off the plant) may only take place at the PX automation station level.

**What you should do next**

We recommend the following measures:

1. Acknowledge the alarm.
2. Consult the instruction to introduce the proper measure as necessary.
3. Check the immediately affected plant on-site.
4. Check if any other alarms have been triggered, and check their affected plant.
5. Eliminate the cause of the alarm.
6. Execute the required interaction (reset the alarm objects).

The diagram shows one example of this philosophy and how to navigate between the various Desigo Insight applications related to the alarm. Of course, if you are already comfortable operating Desigo Insight, feel free to develop your own strategies for navigating between the programs.

**Check the impacted plant with**

Plant Viewer is the easiest method to check alarms, since the alarm bell is displayed for the object in question.
1. Click Plant Viewer in the pop-up window to go directly to the Plant Viewer.

2. Right-click alarm entry in the Alarm Viewer and Send to > Plant Viewer in the context menu.

3. Right-click alarm entry in the Log Viewer and Send to > Plant Viewer in the context menu.

This is most conveniently done via Alarm Viewer. Start Alarm Viewer and order the “time of alarm” column, so that the most recent alarms are visible. You can jump directly to Plant Viewer by right-clicking the alarm and using Send to... Alternatively you may display Log Viewer, Alarm tab. The latest entries in the list are on top by default. You can also jump to the Plant Viewer with Send to.

This of course depends up the alarm itself. You must decide on the required measure (create instructions for your personnel). Until the source of the alarm is removed, you are unable to clear the alarm (by resetting it) from the Alarm Viewer.

You can acknowledge and reset alarms using either:
- Plant Viewer
- Alarm Viewer
- in pop-up (Acknowledge only)

The advantage of using Plant Viewer to interact with alarms, is that it shows diagrammatically the source of the alarm and the effect on the immediate plant. The disadvantage is that you do not have an overview of all plant alarms and interaction with alarms is on a one-by-one basis. The opposite is true of Alarm Viewer, which of course has no graphical element but allows multiple interactions.

Use the standard or enhanced interface window as described in the section above. You can interact with alarms either singly or in multiples:
If you make a multiple selection then the interaction symbols are displayed according to states that are common to that selection. If both buttons are grayed out, then there is no common interaction available to your selection. Select alarms that all have the same state to enable a multiple acknowledge or reset.

The alarm states are displayed with symbols and text. The symbols are described in the section on Plant Viewer.

**Acknowledge alarms via the alarm pop-up window**

You can acknowledge the alarm directly in the pop-up window via the **Acknowledge** button. Reset is not possible with the pop-up.
8.3.1 Alarm suppression

Alarms can temporarily suppressed for commissioning and service work. Such suppressed alarms do not sent alarm messages to the recipients. No messages or only after the fact, for pending alarm, may be sent depending on the suppressed alarms.

Case 1

Event triggered, for popup, SMS, email
Alarm Viewer, SODIAPI
Alarm bell and state in Object Viewer and Plant Viewer
Online Trend Alarm display
BACnet Status_flags = Suppressed

System log entry "Event suppressed"
System log entry "Event once again active"

Alarm Viewer, SODIAPI
Alarm bell and state in Object Viewer and Plant Viewer
Online Trend Alarm display
BACnet Status_flags = In Alarm

Event is triggered, for popup, SMS, email
Alarm Viewer, SODIAPI
Alarm bell and state in Object Viewer and Plant Viewer
Online Trend Alarm display
BACnet Status_flags = Suppressed

System log entry "Event suppressed"
System log entry "Message alarm normal suppressed"

Alarm Viewer, SODIAPI
Alarm bell and state in Object Viewer and Plant Viewer
Online Trend Alarm display
BACnet Status_flags = In Alarm

System log entry "Event once again active"
Alarm occurred "Message Alarm"

System log entry "Event once again active"
Alarm log entry "Alarm returned to normal"

Case 2

Case 3

Case 4

Note

You can create a report in Report Viewer on objects with status "Alarm suppressed".
8.4 Alarm Viewer: General operation

Alarm Viewer displays a list of the states of all alarm objects that are in an abnormal state. You can acknowledge and reset alarms from here. The layout of Alarm Viewer is as follows:

The display table can be influenced in the Alarm Viewer. These operations include:
- Ordering of columns
- Filtering the display
- Select which columns are shown in the table

These operations are described in detail in the general handling section of this User guide.

<table>
<thead>
<tr>
<th>Toolbar</th>
<th>Description</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print</td>
<td>Print</td>
<td>Prints the active document.</td>
</tr>
<tr>
<td>Print Preview</td>
<td>Displays full pages.</td>
<td></td>
</tr>
<tr>
<td>Show / Hide System Browser</td>
<td>Hides the System Browser. Shows the System Browser.</td>
<td></td>
</tr>
<tr>
<td>Find</td>
<td>Finds objects matching the specified attributes.</td>
<td></td>
</tr>
<tr>
<td>Acknowledge alarm</td>
<td>Acknowledges the selected alarm(s).</td>
<td></td>
</tr>
<tr>
<td>Reset alarm</td>
<td>Resets selected alarm(s).</td>
<td></td>
</tr>
<tr>
<td>Refresh Alarms From All Sites</td>
<td>Reads pending alarms from all connected sites. Filter settings and sorting remain.</td>
<td></td>
</tr>
<tr>
<td>To-Do Text</td>
<td>Displays help text related to the selected alarm.</td>
<td></td>
</tr>
<tr>
<td>Remove Sorting</td>
<td>Redisplays the alarm table with standard settings (column &quot;State&quot; sorted in ascending order; no sort icon).</td>
<td></td>
</tr>
<tr>
<td>Remove Filters</td>
<td>Displays the alarm table without user-defined filters. BUT: Filters for the connected sites remain in place.</td>
<td></td>
</tr>
<tr>
<td>Filter Connected Sites</td>
<td>Shows all alarms, Filter to connected sites only.</td>
<td></td>
</tr>
<tr>
<td>Save Filter as Query</td>
<td>Saves the filter as query.</td>
<td></td>
</tr>
<tr>
<td>Select Filter</td>
<td>Selects the predefined filter (if available). Opens a dialog box of predefined filters as query. Filters the alarm table with the selected filter.</td>
<td></td>
</tr>
</tbody>
</table>
### Menu bar

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print</td>
<td>Prints the active document.</td>
</tr>
<tr>
<td>Print Preview</td>
<td>Displays full pages.</td>
</tr>
<tr>
<td>Page Setup</td>
<td>Opens a dialog box for print settings.</td>
</tr>
<tr>
<td>Exit</td>
<td>Quits the Insight program Alarm Viewer.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Edit</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find</td>
<td>Finds objects matching the specified attributes.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>View</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>System Browser</td>
<td>Displays / hides the System Browser pane.</td>
</tr>
<tr>
<td>Toolbar</td>
<td>Shows or hides the toolbar.</td>
</tr>
<tr>
<td>Status bar</td>
<td>Shows or hides the status bar.</td>
</tr>
<tr>
<td>Technical View</td>
<td>Shows objects in the technical designations structure (TD).</td>
</tr>
<tr>
<td>User View</td>
<td>Shows (data) objects in the user designation structure.</td>
</tr>
<tr>
<td>System View</td>
<td>Shows objects in the system designations structure.</td>
</tr>
<tr>
<td>Remove Filters</td>
<td>Displays the alarm table without user-defined filters. BUT: Filters for the connected sites remain in place.</td>
</tr>
<tr>
<td>Remove Sorting</td>
<td>Redisplays the alarm table with standard settings (column “State” sorted in ascending order; no sort icon).</td>
</tr>
<tr>
<td>Show Gridlines…</td>
<td>Displays the current gridline view.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Alarm</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acknowledge</td>
<td>Acknowledges the selected alarm(s).</td>
</tr>
<tr>
<td>Reset</td>
<td>Resets selected alarm(s).</td>
</tr>
<tr>
<td>Refresh</td>
<td>Reads pending alarms from all connected sites.</td>
</tr>
<tr>
<td>Alarms</td>
<td>Filter settings and sorting remain.</td>
</tr>
<tr>
<td>To Do...</td>
<td>Displays help text related to the selected alarm.</td>
</tr>
<tr>
<td>Properties</td>
<td>Shows properties of the selected alarm.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Filter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected Sites</td>
<td>Filter to connected sites only.</td>
</tr>
<tr>
<td>Save…</td>
<td>Saves the filter as query.</td>
</tr>
<tr>
<td>Predefined…</td>
<td>Shows predefined filters as query. Filters the alarm table with the selected filter.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Tools</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customized Work-space…</td>
<td>Opens a dialog box to change the display and sequence of the table columns.</td>
</tr>
</tbody>
</table>
You can filter the Alarm Viewer table by the same general methods described in the general handling section.

Save present filters
Filter Connected Sites
Turn off filter
List of available filters

Display, whether filter is active
Actively save filters (if available)

The filter effect is also applied if you jump from the Desigo Insight taskbar alarm summary icons.

Examples of filters you may find useful are:

- All alarms of a specific priority
- All alarms after this morning at 0800
- All alarms pertaining to e.g. the boiler plant.

Alarm “To Do” text

This is an optional text note that can be appended to an alarm object, to assist you in someway with the situation. An example is provided below:

This can only be done using Object Viewer. Only users with higher access rights can create or change instructions as described in the section “Object Viewer”.

In a large Desigo system, there may be many hundreds of alarm objects. For this reason, Alarm Viewer does not routinely poll all points just in case they may be in alarm, rather it reacts to events as they happen. We refer to this as a COV (Change of Value) mechanism. You can check if Alarm Viewer is up to date via the Refresh icon:

- No new data available.
- New data. Click here to update.

A similar mechanism applies to Log Viewer.
8.5 Adjust the alarm handling system

General
You can individually configure alarm response based on your operational requirements with Desigo Insight. For example, you can determine which alarms are sent where, e.g., SMS to the janitor from Friday, 5:00 pm through Monday, 8:00 am.

The properties can be edited:
- The routing of event (including alarm) messages
- The appearance and sounds of pop-up windows
- The limits which are used for analogue alarms
- The text used for each alarm priority
- The groups used for the alarm summary icons on the Desigo Insight taskbar.
- Which management stations log events and which events are logged.
- The priority of System and User events.

Note
Changes in the alarm objects in the PX automation stations for example require a special engineering tool.

8.6 Route alarm messages to output devices

Overview
Alarm routing determines the destination of the alarm message. The target device is referred to the alarm receiver. It is quite separate from alarm state display. All Desigo Insight management stations in your system display alarm states in Alarm Viewer, irrespective of where alarm messages are routed to.

Although we refer here to “alarms” the principles apply equally to all event types: Alarm, system, user and status events.

Routing example
Two examples are shown here:

Here we see the simplest case of routing. An alarm message arrives at the management station. The main attributes of the message are checked against all of the available routing groups. If there are any matches, these groups become active within the Alarm Routing Table. In our example one group is activated. The table is then checked, and the linked receivers then receive the alarm message.

In the following example a time schedule has been added to the Routing Table. The initial “Check groups” stage is the same. The active group is then checked in the Time Schedule and routed to the target device at the appropriate times.
Alarm Routing is engineered using **System Configurator** and **Alarm Router**.

System Configurator is used in this instance for:
- Creating, modifying and deleting Alarm Routing groups
- Adding, modifying and deleting Alarm receivers
- Configuring which management stations log event messages and which event types

Alarm Router is used for:
- Enabling and disabling alarm routing to an Alarm receiver
- Applying time control to the routing of alarms.
- Configuring the alarm pop-up.

Alarm messages are always received by the PXM10 / PXM20. This function is not configurable.

All event messages, including Alarm messages are routed on the basis of routing groups.

Example:
You may create a group “Panic Stations” which comprises all alarm messages of Priority 0. This group may then be routed to alarm receiver(s) as necessary. You cannot route an event that is not a member of such a group.

The following instructions actually apply to events of all types, not just alarms. In general to route an event:

1. Create a routing group (System Configurator).
2. Create a receiver (System Configuration).
3. Link the group to a receiver (Alarm Router). Steps 1 and/or 2 can be omitted if the elements already exist.
8.7 Alarm configuration with System Configurator

Create an event routing group

Event message groups (including alarm routing groups) are created via System Configurator. You create the group according to:

- The event type (Alarm, System, User or Status)
- Event priority
- Site

Start System Configurator, and proceed as shown.

1. Right-click "Router Groups" folder.
2. Select Add.
   OR
   Right-click an existing group and select Copy.

General

1. Select the General tab.
2. In the General Settings group box, enter the designation in the Name field. The Added Text is an optional text string that may be displayed or printed together with the alarm message.
3. Select the options to be routed in the Event Groups group box.
4. You may select the Designation group box as an option. Click the check box Route after Designation if you want to create additional sub-headings for the router groups.
Route by designation groups or classifies alarms by using a portion of the designation chain as a routing criteria.

**Set up routing after designation**

After enabling *Route after Designation*, two decisions must be made.

- **Designation type**: Select the view (technical view, user view, system view) to complete the designation chain for alarm routing.
- **User syntax**: *(wildcards or regular expression)*. These options determine how the chain criteria are applied. The easier option, **wildcards** operate as follows:

**Wildcards (global characters)**

Here are few examples:

- ? Corresponds to any individual character.
- . (period) Corresponds to a character chain.

This router group should route all significant alarm events from a given part of a plant (in this case the extract air fan).
Global characters allow the user to route all objects belonging to the designation portion Ahu'FanEx.

**User syntax "regular expression"**

More complex chain comparisons can be created with Regular Expression syntax. Valid syntax is as follows:

- .  corresponds to any individual character.
- x|y  Corresponds to either x or y
- [xyz]  Character set. Corresponds to any characters listed in the brackets.
-[^xyz]  Negative character set. Corresponds to any characters with the exception of characters listed within the brackets.
- [a-z]  Character range. Corresponds to any character within the given range.
-[^a-z]  Negative character range. Corresponds to any characters with the exception of characters within the given range.
- \  Take the next character.
- ^  Matches the start of the character chain.
- $  Matches the end of the character chain.
- *  Matches the previous character or partial expression 0 or multiple times.
- +  Matches the previous character or partial expression once or multiple times.
- ?  Matches the previous character or partial expression 0 or once.
- {n}  Exact match n times (n > 0).
- {n,}  Exact match at least times (n > 0).
- {n,m}  Matches at least n and maximum of m times (n <= m, n > 0)
- \d  Matches a number. Same as [0-9].
- \D  Matches a character not a number. Same as [^0-9].
- \s  Matches any spaces (spacebar, tab, carriage return, etc.).
- \S  Matches any character except spaces.
- \w  Matches any character forming a part of a word including underscore. Same as [A-Za-z0-9_].
- \W  Corresponds to any characters with the exception of characters in Word. Same as [^A-Za-z0-9_].

**Sites**

1. Select Sites tab.
2. Select sites in the Uprooted site drop-down box and click Add >>.
   The selected sites are displayed in the Routed Sites drop-down box.

![Sites tab](image)

**Remove**

You can delete sites with << Remove from the Routed Sites drop-down box.

**Alarm categories**

1. Select the Alarm Categories tab.
2. Select the categories in the Unrouted categories box and click Add >>.
   The selected categories are displayed in the Routed categories box.

![Alarm categories tab](image)
In the case of SCADA systems then there are entries, which you may use as criteria for your routing group.

**Remove**

You can delete categories with **<< Remove** from the **Routed Sites** drop-down box.

**Priorities**

1. Select **Priorities** tab.
2. Select priorities for routing this router group.

![Routing Group Properties](image)

**Events**

1. Select the **Events** tab.
2. Select the events and click **Add >>**. The selected events are displayed in the **Routed categories** box.

![Routing Group Properties](image)

(See Chapter 15, Appendix)

3. Click **OK** to save the data.

**Remove**

You can delete events with **<< Remove** from the **Routed Events** drop-down list box.

**Router text**

Routing via a routing text takes place in three steps:

I. Definition in the System Configurator.
II. Definition in the Object Viewer.
III. Assign in the Object Viewer.

Definition in the System Configurator.

1. Select the **Events** tab.
2. Click **New** and enter a corresponding routing text, e.g. intrusion.
3. Left-click to exit entry.
4. Click **Add >>**.
5. Click **OK**.

**Note**

When forming router subgroups (e.g.: Intrusion, intrusion in vault, intrusion ground floor), routing only works when you select the router texts. Routing does not support wildcards. Thus, when you select e.g. Intrusion, only this router group is routed to one receiver.

<table>
<thead>
<tr>
<th>Router text</th>
<th>Selected</th>
<th>Routing</th>
</tr>
</thead>
<tbody>
<tr>
<td>Intrusion</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Intrusion in vault</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Intrusion ground floor</td>
<td>No</td>
<td>No</td>
</tr>
</tbody>
</table>

**Definition in the Object Viewer:**

Start Object Viewer, and proceed as shown.

1. Click + to expand the browser.
2. Right-click and **Properties** to open the Properties dialog box.
3. Select the **Routing Text** tab and click **Configure… > New…**.
4. Enter a name, e.g. Police and a corresponding routing text, e.g. Intrusion.

5. Click **OK > OK > OK**.

**Assign in the Object Viewer.**

This must be repeated for all data points routed via a routing text.

1. Select the next data point with the browser.
2. Right-click and **Properties** to open the Properties dialog box.
3. Select the **Routing Text** tab and click **Configure…**.
4. Select the corresponding routing text.

5. Click **OK > OK**.
The used column displays the number of times the text is assigned to data points.

**Important:**

Text routing is accomplished via the *Routed Texts* list box in the System Configurator and the *Text* table in the Object Viewer.

The routing occurs between the *Text* table in the Object Viewer to the description for the data point. As a consequence, check that each routing text functions to the outside at least once!

**Note**

You can only delete text, when

*Used* = 0.

**Delete router group**

1. Right-click the Alarm Router Group to be deleted and select **Remove**.
2. Click **Yes**.

You can only delete a group when all references to it are removed from Alarm Router.

**Overview alarm receivers**

The following alarm receivers (or even receivers) are available:

- Printers
- Fax machine
- E-mail recipient
- File
- Pager
- Management station pop-up
1. Open the **System Configurator** in the Desigo Insight taskbar.
2. Click + to expand the browser.
3. Right-click and **Add** to open the assistants.
4. Create an alarm system.
5. Create an alarm receiver.
6. Link the alarm group with a receiver with the **Alarm Router**.

---

### Add a new alarm printer

1. Open the **System Configurator** in the Desigo Insight taskbar.
2. Open Desigo Insight Programs > Alarm Router > Alarm Printer by clicking +.
3. Right-click the **Alarm Printer** folder and select **Add**. The **Printer Receiver Assistant** opens.

   OR

   Right-click an existing printer and select **Copy**.

4. Define your printer.

   ![Printer Receiver Assistant](image)

   - **Receiver name**: Name of printer (appears on print-out)
   - **Device path**: Selected alarm printer
   - **Comment**: User-definable text (appears on print-out)
   - **...local line printer**: This check box should be selected if the alarm printer is a local line printer. (A remote printer cannot be configured as a **Line Printer**)
   - **Management station**: This is the management station that transmits the alarm to the printer.
   - **Message template**: File path for message template. The message template determines the contents and format of the alarm message. The name of the standard template is “RdxPrnEx.txt”. (For instructions on defining a new template, refer to the section under E-mail “Altering the appearance of messages”).
   - **Character substitution file**: File path for designation replacement file. The character substitution file replaces one ASCII character with other characters (e.g. ae instead of ë). A character substitution file is required for alarm printers (e.g. line printers) that cannot print special characters. (Template: sample.sub)

5. Click **Finish**. The new printer appears in the browser list.
6. To use the new printer you must direct a routing group to it, using Alarm Router, see “Route a new routing group to a new receiver”.

---
Before adding a new alarm printer in System Configurator, you must first install the alarm printer in Windows (Start > Settings > New Printers).

A single line printer prints alarms line-by-line until the page is full. (A line printer, by contrast, prints alarm messages line by line until the page is full.) In the case of a remote alarm printer we suggest that a special alarm routing group is created to route just urgent alarms to the remote printer.

A line printer (e.g. dot matrix printer) can only be operated locally from a management station. In many cases, a character substitution file may also be required.

### Create new pop-up window

1. Open Desigo Insight Programs > Alarm Router > Pop-up by clicking +.
2. Right-click the Pop-up folder and select Add.
   - The Properties Pop-up Receiver Properties dialog box opens.
   - OR
   - Right-click an existing pop-up and select Copy.
3. Define your pop-up window.

![Pop-up Receiver Properties dialog box](image)

- **Receiver name**: Pop-up receiver name (pop-up window), e.g. “Critical Alarms”.
- **Comment**: Free-flow text.
- **Management station**: Pop-up display location.
- **Control description**: Define display response (refer to next section).

4. Click Finish. The new pop-up appears in the browser list.
5. You must now use Alarm Router to route event Group(s) to this new receiver, see the section headed “Route a new routing group to a new receiver”.

### Edit appearance and sounds of pop-up windows

- You can set the contents as well as the type of display for a pop-up.
- 1. Open Desigo Insight Programs > Alarm Router > Pop-up by clicking +.
  2. Right-click the corresponding **pop-up** and select **Properties**.
     - The Properties Pop-up Receiver Properties dialog box opens.
   3. Click Customized. The Pop-up Control, Pop-up Scheme opens.
Define scheme

Scheme defines the content of the pop-up. Two schemes are defined by default.

Example System

1. Click **ADD** on the Scheme column to create a new scheme, OR
   
   Click **Properties** scheme to change a selected scheme.

2. Enter a clear designation in the **Name** field for the pop-up scheme.
3. Select desired contents in the **Available Fields** list.
   The **Available fields** use the same descriptors as are visible in Alarm Viewer and Log Viewer (**Alarm** tab).
4. Click Add >>.
5. Click ![up][down] to change pop-up display sequence.
6. Click **Hide Labels** to display just the values.
7. Define the display of the buttons in the same way.
8. Click **Preview** to check the pop-up appearance.
9. Click **OK** to exit the preview.
10. Click **OK** to save the scheme.
11. Click **OK** to save the pop-up window.

**Note**
If you have modified an existing pop-up scheme then it is implemented as soon as you restart Desigo Insight. If you have created a new scheme then you must allocate at least one alarm group to it, in order to see it in action (see below).

**Define control**
Control defines the pop-up response.

1. Click **ADD** on the **Controls** column to create a new scheme.
   OR
   Click **Properties** in Control to change a selected scheme.

![Pop-up Control](image)

2. Enter a clear designation in the **Description** field for the pop-up control.
3. Click Display pop-up window.
4. From the desired scheme from the **Pop-up scheme** drop-down list box.
5. Select **Centered** or **Custom** as the on-screen pop-up position.
6. Option: Click **Play sound** and select a WAV file. This WAV file plays as soon as the pop-up appears.
   The sound continues to play until the alarm is acknowledged when you click the **Play continuously** box.
7. Click **OK** to save the control.
8. Click **OK** to save the pop-up window.
The following table describes buttons available to the Alarm pop-up. They vary depending on the configuration of the pop-up window:

<table>
<thead>
<tr>
<th>Buttons</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plant Viewer</td>
<td>Opens the corresponding plant page in the Plant Viewer. The pop-up remains on top.</td>
</tr>
<tr>
<td>Alarm Viewer</td>
<td>Opens Alarm Viewer (filtered to display all alarms with a pop-up for pending alarms) and is used to reset the pop-up for pending alarms.</td>
</tr>
<tr>
<td>Silence</td>
<td>For switching the audio alarm. The alarm stays off until a new alarm or system event occurs.</td>
</tr>
<tr>
<td>Report...</td>
<td>For INTEGRAL only.</td>
</tr>
<tr>
<td>Instruction...</td>
<td>Displays the instruction &quot;Help...&quot; linked with the present alarm in a separate dialog box.</td>
</tr>
<tr>
<td>Acknowledge</td>
<td>Alarm can be acknowledged when the impacted site is linked and the alarm must be acknowledged.</td>
</tr>
<tr>
<td>Next display</td>
<td>When at least one additional message exists, display Next Display displays the next alarm pop-up.</td>
</tr>
<tr>
<td>Close</td>
<td>Close closes the alarm pop-up when no further message exists or Close All to close all messages.</td>
</tr>
</tbody>
</table>

Route alarms to a pager

Pager receivers follow a similar configuration in the System Configurator to e-mail receivers:

1. Define a “modem group”
2. Define a Pager system
3. Define a receiver on that system
4. Configure in Alarm Router

Defining a modem group

1. Open the System Configurator in the Desigo Insight taskbar.
2. Open the Desigo Insight management station folder by clicking +.
3. Right-click <Computer Name> for the corresponding management station and select Properties.
4. Select the Modems tab.

5. Select the corresponding modem from the list "Available Modems".
6. Select the Dial in and out.
7. Click Modem Groups.
8. Click Add...
9. Enter the group name in the Group Name field.
10. Click the Use selected modems only in the Modem Setting dialog box.
11. Select a modem from the Available modems list.

12. Option: Select the modem in the Selected Modems list and click Configure special settings. You can further modify the configuration. Desigo Insight settings thus override Windows settings (settings not visible in Windows). Click Use Default to reassume Windows settings.

13. Click OK (several times) to save the modem group.

Define a pager receiver

1. Open the System Configurator in the Desigo Insight taskbar.
2. Open Desigo Insight Programs > Alarm Router > Pagers > Pager Systems by clicking +.
3. Right-click the Pager Systems folder and select Add.

4. Configure the pager system.

   | System Name | Service provider, e.g. Swisscom (Applies only to Desigo Insight). |
   | Comment | Description |
   | Script file | Service providers configuration file. |
   | Max. attempts | Number of attempts to send message. |
   | Transfer | Checkbox selected: Apply the data from the service provider (Do not forget the release 0 for in-house plants), Checkbox is not selected: Dial properties explicitly entered. |
   | Country code/area code | Entries required if transfer was not selected. |
   | Area code | Telephone numbers |
   | Modem group | Select corresponding modem group (refer to steps on defining modem group). |

5. Click Finish to save the data.
Multiple script files are available adapted to various pager service providers (D1, D2 and E-Plus). It is possible to change these files with a text editor, but the knowledge required to this end is not within the scope of this handbook. Your Siemens representative will be able to assist you here if necessary.

**Defining a Pager receiver**

1. Open the **System Configurator** in the Desigo Insight taskbar.
2. Open Desigo Insight Programs > Alarm Router > Pager > Pager Receiver by clicking +.
3. Right-click the **Pager Receiver** folder and select **Add**.

4. Configure the pager receiver.
   - **Receiver name**: Name, e.g. my computer (applies to only Desigo Insight).
   - **Pager system**: Configure pager system.
   - **Comment**: Description
   - **Management station**: Corresponding management station.
   - **Identification**: The Pager ID depends upon the Pager provider; it may be for example the telephone number of the target mobile telephone where the Pager provider is to transmit an SMS text message to the receiver.
   - **Message template**: Corresponding configuration file (refer to message template).

5. Click **Finish** to save the data.

**Message template**

The message Template defines the actual content of the message. Reference files are located at: *(Installation drive)\Programfiles\Siemens\Desigo\Insight 6.0\Router\Pager.txt*

You can edit the file with a text editor, but you cannot change the system name.

<table>
<thead>
<tr>
<th><strong>System Name</strong></th>
<th><strong>Descriptive text</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>{ReceiverName}</td>
<td>Receiver name.</td>
</tr>
<tr>
<td>{ReceiverComment}</td>
<td>Receiver comment.</td>
</tr>
<tr>
<td>{SiteName}</td>
<td>Site name.</td>
</tr>
<tr>
<td>{DeviceName}</td>
<td>Device name</td>
</tr>
<tr>
<td>{Category}</td>
<td>Category</td>
</tr>
<tr>
<td>{EventText}</td>
<td>Event text</td>
</tr>
<tr>
<td>{UserName}</td>
<td>User name</td>
</tr>
<tr>
<td>{PrioText}</td>
<td>Priority text</td>
</tr>
<tr>
<td>{ObjectName}</td>
<td>Object name</td>
</tr>
</tbody>
</table>
Depending on the pager or SMS service, only a limited number of characters may be available for transmission. Thus, send a test message to determine if all characters are transmitted properly. If necessary, you may need to drop some information (e.g. system name) from your message file.

**Route alarms to e-mail receiver**

Your Desigo Insight management system routes alarm and/or event messages to an e-mail receiver. The e-mail system must support SMTP (Simple Mail Transport Protocol). Routing procedure is the same as other receivers:

1. Create an event routing group
2. Define an e-mail receiver system
3. Define addresses for the e-mail
4. Add the addressees as alarm receivers in Alarm Router.

The routing of event messages can thus depend upon:

- The type of event (via routing group definition)
- The priority of the event (via routing group definition)
- The time of day (via Alarm Router - Time Schedule)

Detailed information on the SMTP server is necessary to fully configure the receiver. An e-mail account is required for e-mail; you may use your own or ask your e-mail administrator to configure a new one especially for your Desigo Insight system.

**Define e-mail recipient**

1. Open the **System Configurator** in the Desigo Insight taskbar.
2. Open INSIGHT Programs > Alarm Router > E-Mail > E-Mail Systems.
3. Right-click the **E-Mail System** folder and select **Add**.
4. Configure the e-mail receiver system.

**System Name**
Name, e.g. my_e-mail
(applies only to Desigo Insight).

**Comment**
Description

**E-Mail Account**
- **Use default account:**
The Default Mail Account is often set up on a workstation using an e-mail application such as Microsoft Outlook Express.

- **Specify Account...:**
Configure account in the following dialog box.

5. Option: Click **Specify Account**.

Enter the following: if unsure, contact your e-mail administrator.

<table>
<thead>
<tr>
<th><strong>Server Name</strong></th>
<th>The server must support SMTP.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Port Number</strong></td>
<td>This refers to a TCP/IP port number, which is usually 25 if not encrypted. For an encrypted connection (SSL or TLS) the check box needs to be set and the default port is 465. Remark the port 587, which is often used by e-mail clients like Outlook, uses STARTTLS which is not supported.</td>
</tr>
<tr>
<td><strong>Connection timeout (SMTP)</strong></td>
<td>This refers to the minimum time specified before the connection is lost.</td>
</tr>
<tr>
<td><strong>User name and password</strong></td>
<td>An existing user name for the SMTP service. If you already use SMTP e-mail then you already have such an account.</td>
</tr>
<tr>
<td><strong>E-mail address</strong></td>
<td>This is appended to the e-mail as a “sender”; although the format must be as shown the actual address may be fictitious. This is because no-one actually replies to this sender.</td>
</tr>
</tbody>
</table>

**Tip**

How to determine the name of the server:
Open the MS Windows command interpreter (the DOS window in Windows)

Enter NSLOOKUP.

Enter SMTP.

6. Click Finish to save the data.

Define addresses for the e-mail

1. Open the System Configurator in the Desigo Insight taskbar.
2. Open Desigo Insight Programs > E-Mail > E-Mail Receiver by clicking +.
3. Right-click the E-Mail Receiver folder and select Add.

4. Configure the e-mail receiver.

Receiver name This is not the SMTP receiver name, rather a descriptor that is used in Desigo Insight alone.
E-mail system Select the system you created in the section above.
Comment A description may be added here; it has no bearing on the mail transfer.
To This must be a recognized addressee using the format shown.
Cc This is the usual “Copy” option allowing you to send an alarm message, for example to 2 people at once.
Subject Subject line appears in the e-mail header as usual.
Message template Two standard formats are delivered with Desigo Insight. They are described below.
Designation replacement file This is optional, and may translate extended ASCII characters into other characters.

5. Click Finish to save the data.

Instead of ADD, you can use the Copy option in the context menu (right-click).

How the message appears in your e-mail

Depending on your e-mail client application, the e-mail appears as follows (here using Microsoft Outlook):
The **From** field contains the e-mail address entered in the Mail Account window (see above). The **Subject** refers to the subject of the "E-mail receiver" definition, also above. The time stamp refers to the e-mail transaction, not the time of the event.

Opening the mail reveals:

**Alarm message**

<table>
<thead>
<tr>
<th>ApolloP</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>22/08/2002 07:41:37</td>
<td>XxAa’XxC101’XxPer’XxMVal’XxMV001</td>
</tr>
<tr>
<td>Text Priorität 3</td>
<td>AS101</td>
</tr>
<tr>
<td></td>
<td>2 Stufe 1</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Apollo:AS101’XxAa’XxC101’XxPer’XxMVal’XxMV001</td>
</tr>
<tr>
<td></td>
<td>Alarming ’Controller 101 ’Leistung ’Gruppe Mehrzustandswert ’Mehrzustandswert 001</td>
</tr>
</tbody>
</table>

**Alter the appearance of messages**

The appearance of the message at the e-mail receiver is governed by the "message template" selected during the e-mail receiver section. Reference files are located at: *(Installation drive)\ Programfiles\Siemens\Desigo\Insight 6.0\Router*

For example RdxPrnEx.TXT is:

**Alarm Message**

{ReceiverName}

{ReceiverComment}

{TimeStamp%d/%m/%Y %H:%M:%S}

{DeviceName} {Category} {EventText}

{EventText} {Pri-

{oText}}

{ObjectName} {Value} {UnitText}

{SystemDesignation}

{UserDesignation}

{ToDoText}

You can edit this message template with any text editor program, e.g. Microsoft Word (in text or HTML format). Formatting (justification, font, font size, color, tab settings etc.) is faithfully reproduced, provided that your e-mail client software supports them. Expressions in curly brackets "{}" are variables and cannot be translated. To display a complete list of all the variables available, open the file Sample.TXT or Sample.HTM in the same location. This also provides a brief description of the variables. Graphics (e.g. a logo) can also be incorporated, linked via an absolute path.

**Multiple e-mails of a single event message**

If you wish to transmit the same alarm message to multiple receivers via the same SMTP server, using multiple entries in Alarm Router (rather than the “Cc” option of an SMTP Mail message itself), then you should build in a delay between the messages:
Delay times can be entered in the **Routing Table**.

**Trouble shooting e-mail problems**

Log Viewer contains a message in the event of both successful and unsuccessful e-mail transmission from the Desigo Insight management station to the SMTP Server:

This should be checked first in the case of any problems.

**Add a new fax receiver**

The advantage of the fax receiver is that Desigo Insight functions with or without logged in user and messages can be sent day and night to any person, as long as the telephone line is connected and the fax operational.

To add a new fax receiver, start by checking that the Windows Fax Services are installed. From the desktop, click **Start>Settings>Control Panel**, Click **Add or Remove Programs>Add/Remove Windows components** and install Fax Services if necessary.

1. Click **Start>Control Panel**.
2. Click **Hardware and Sound > Add Devices** and install the Fax Services as needed.

1. Open the **System Configurator** in the Desigo Insight taskbar.
2. Open **Desigo Insight Programs > Alarm Router > Fax** by clicking +.
3. Right-click the **Fax** folder and select **Add**.
4. Click the **Fax Receiver** tab.
5. Configure the fax receiver.

<table>
<thead>
<tr>
<th>Receiver name</th>
<th>Name, e.g. my_fax (applies only to Desigo Insight).</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comment</td>
<td>Description</td>
</tr>
<tr>
<td>Management station</td>
<td>Corresponding management station.</td>
</tr>
<tr>
<td>Message template</td>
<td>Corresponding configuration file (refer to message template).</td>
</tr>
<tr>
<td>Designation replacement file</td>
<td>Corresponding implementation file.</td>
</tr>
</tbody>
</table>
6. Click **Next**.

![Image of Fax Receiver Wizard](image)

7. Configure the settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pass-through</td>
<td>Checkbox selected: Apply the data from the service provider (Do not forget the release 0 for in-house plants). Checkbox is <strong>not</strong> selected: Dial properties explicitly entered.</td>
</tr>
<tr>
<td>Country/region code</td>
<td>Entries required if transfer was not selected.</td>
</tr>
<tr>
<td>Area code</td>
<td>Entries required if transfer was not selected.</td>
</tr>
<tr>
<td>Phone number</td>
<td>Entries required if transfer was not selected.</td>
</tr>
<tr>
<td>Number of retries</td>
<td>Number of attempts to send message. Delay times between the individual attempts.</td>
</tr>
</tbody>
</table>

8. Click ![Image of Windows Fax and Scan dialog box](image). The Windows Fax and Scan dialog box opens.

9. Select **Tools > Sender Information**. Enter the information for the cover sheet.

![Image of Sender Information](image)

10. Click **OK** to save the data.

11. Click **New Fax** and follow the Fax Setup Wizard instructions under Windows 7.

12. Finish installation.
The Fax Management Console is a Windows 7 utility.

To modify the fax settings, click and in the Fax Client Console select **Tools>Fax settings…>Next.**

**Note**

The message template determines the contents and format of the alarm message. (For information on how to modify the message template, see “Altering the appearance of messages” in the e-mail section.). The program Microsoft Fax generates a line before the alarm message. The alarm message is also printed with a header and footer from Internet Explorer, which can be modified via the Explorer menu **File > Page Setup.**

**Trouble-shooting fax message transmission**

You can send a test fax page to the fax device to test functionality.

1. Open the **System Configurator** in the Desigo Insight taskbar.
2. Open Desigo Insight Programs > Alarm Router > Fax > Fax Name by clicking +.
3. Right-click the **Fax** folder and select **Properties.**
4. Click **Send test page** to transmit a test fax page.

During fax transmission, Windows displays a small window. In this example, the dialing process with the selected number is displayed. You can end the fax call at any time via the associated button.

**Add a new file receiver**

For control purposes or for eventual expanded alarm functions (is not part of delivered system), the alarm can be routed to a file.

1. Open the **System Configurator** in the Desigo Insight taskbar.
2. Open Desigo Insight Programs > Alarm Router by clicking +.
3. Right-click the **File** folder and select **Add.**
4. Configure the file receiver.

<table>
<thead>
<tr>
<th>Receiver name</th>
<th>Name, e.g. my_file (applies only to Desigo Insight).</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comment</td>
<td>Description</td>
</tr>
<tr>
<td>File path</td>
<td>Desire file location.</td>
</tr>
<tr>
<td>Max number of files</td>
<td>Checkbox selected: Limits the number of files that can be created.</td>
</tr>
<tr>
<td>Message value as prefix</td>
<td>Checkbox selected: The entered text is added before the file name.</td>
</tr>
<tr>
<td>Default file extension</td>
<td>The entered text is appended to the file name.</td>
</tr>
<tr>
<td>Insert in file</td>
<td>The entry is written to the same file.</td>
</tr>
<tr>
<td>Add time stamp</td>
<td>The date and time is added to the file name. Example: Rdx2004_06_01_15_10_26.txt</td>
</tr>
<tr>
<td>Management station</td>
<td>Corresponding management station.</td>
</tr>
<tr>
<td>Message template</td>
<td>Corresponding configuration file (refer).</td>
</tr>
</tbody>
</table>
5. Click **Finish** to save the data.

### 8.8 Routing alarms using the Alarm Router

**Alarm Router display**

Here we show the main Alarm Router view with the routing table displayed. In particular we see that the group “All Alarms” is routed to both a printer (“PRINTER-1”) and a pop-up service (“POP-UP-1”). We also note that both routes are enabled. The other routing tables “Receiver” and “Pending Jobs” can be displayed by clicking the toolbar buttons shown in the diagram.

![Alarm Router display](image)

### 8.8.1 Alarm Router functions

<table>
<thead>
<tr>
<th>Toolbar</th>
<th>Designation</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Print icon]</td>
<td>Print</td>
<td>Prints the table in the active window.</td>
</tr>
<tr>
<td>![Print Preview icon]</td>
<td>Print Preview</td>
<td>Displays full pages.</td>
</tr>
<tr>
<td>![Send User Message icon]</td>
<td>Send User Message</td>
<td>Send a user message to a receiver.</td>
</tr>
<tr>
<td>![Show routing table icon]</td>
<td>Show routing table</td>
<td>Opens the routing table for the selected management station.</td>
</tr>
<tr>
<td>![Show Receiver icon]</td>
<td>Show Receiver</td>
<td>Opens the receivers table.</td>
</tr>
<tr>
<td>![Show Pending Jobs icon]</td>
<td>Show Pending Jobs</td>
<td>Opens the pending jobs table.</td>
</tr>
</tbody>
</table>

### Routing table

The routing table shows the settings for the individual routing groups which determines the forwarding of event messages. There is one table per management station.

<table>
<thead>
<tr>
<th>Table column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Routing group</td>
<td>The Routing Group determines which event messages are forwarded. The Routing Group is defined in the system configurator.</td>
</tr>
<tr>
<td>Receiver / Schedule</td>
<td>The receiver determines where and how the event messages are issued. The receiver is defined in the system configurator (e.g. popup recipient). The Schedule determines multiple receivers that take effect at different times.</td>
</tr>
<tr>
<td>Enable</td>
<td>Enable determines whether or not this routing table takes effect.</td>
</tr>
</tbody>
</table>
Priority
Repetition
Repetition determines when and how often event messages are re-transmitted to the receiver.
Delay
Delay determines when and how long event messages are delayed transmitted to the receiver.
Comment
Text field.

Receiver table

| Receiver | The receiver determines the location and format for issuing event messages. The receiver is defined in the System Configurator (e.g. popup receiver). |
| Color | Color helps display the receiver in the schedule. Change color: Right-click the table field. |
| Backup Receiver | The backup receiver is employed when the regular recipient cannot be addressed. Change backup: Right-click table field. |
| Comment | Text field. |

The Receiver table shows possible recipients for event messages.

Pending Jobs table

| Job Number | Continuous number (assigned by the system). |
| Time | Job time. |
| Receiver | Receiver of forwarding. |
| Priority | |
| State | Forwarding state, e.g. pending. |

The Pending Jobs table displays all not yet forwarded jobs.

Schedule

The schedule determines which receivers are active at what time. Entry occurs in the Insight scheduler program.

8.8.2 Edit routing groups

Route a new routing group to a new receiver
In this case a routing group already exists and a new receiver has been created, such as a new alarm printer or alarm pop-up scheme.

1. Open the Alarm Router 📰 in the Desigo Insight taskbar.
2. Select Edit > Insert....
3. Select the desired routing group.
4. Select the Receiver option.
5. Select the target receiver type and name.
6. Click OK. The entry appears in the routing table.

Route event messages according to a time schedule

Normally, event messages (including alarms) are routed continuously to a receiver unless it is “disabled”.

Alternatively, routing can be done according to a time schedule, so that, for example, alarms are routed to a security printer outside of working hours, and at other times to a BACS room printer.

The time schedule involved is quite separate from the Desigo Insight Scheduler application described in a separate section. It may be used for any event receiver, not just printers.

Procedure overview:
1. Create a routing group.
2. Create an Alarm receiver.
3. Create a Time Schedule in Alarm Router
4. Assign the Time Schedule to the receiver

We illustrate the procedure by a specific example.
- A security printer is required to receive just high priority alarms between the hours of 1900 and 0800.
- During Christmas, it is sent to an email recipient as exception.

Creating a routing group
Creating an alarm receiver
Create schedule and exception

This follows the procedure as described earlier.
Follow the procedure described above.

1. Open the Alarm Router 📢 in the Desigo Insight taskbar.
2. Select Schedule > New Schedule…
3. Select Schedule and click OK.
4. Define a **schedule name**, e.g. weekend, and click **OK**.

5. Select the **Weekly Schedule** tab.

6. Right-click a weekday. Select **Add Period**.

7. Configure the period by:
   - Define receiver data.
   - Specify start day and time.
   - Specify end day and time.

8. Click **OK**.

9. Click **X** and then **Yes** to save the schedule.

---

Create an exception

1. Select the Overview Exception tab.

2. Right-click the corresponding date. Select **Add Period**.

3. Configure the period by:
   - Defining the new receiver.
   - Defining the start date.
   - Defining the end date.

4. Click **OK**. The exceptions are displayed in color in both calendar and overview.
5. Click [ ] and then Yes to save the schedule.

Assign the Time Schedule to an alarm group

1. Open the Alarm Router 📣 in the Desigo Insight taskbar.
2. Select the corresponding row.
3. Right-click in column Receiver / Schedule. Select Select Schedule….
4. Select Select Routing Group….
5. Select the desired routing group.
6. Click OK. The changed data is saved.

Routing event messages to alternate devices in time periods

Where you wish alarms to be switched between 2 or more devices, create a new Time Schedule as above, or open an existing one using the menu option Schedule > Open Schedule... Then simply add periods so that the entire weekly period is covered:

Example:
Receiver 1 from Monday through Friday from 7:00 until 18:00
Receiver 2 from Monday through Friday from 18:00 until 7:00
Receiver 3 from Friday 18:00 until Monday 7:00
The principle can be applied to any number of receivers or time periods but we suggest you keep it simple.
Disable routing to a receiver

Alarms for a router group can be suppressed so that it is not routed to the appropriate receiver.

1. Open the Alarm Router 🗓 in the Desigo Insight taskbar.
2. To disable the routing to a particular Alarm receiver, simply click the Enable box shown.

![Image of Alarm Router interface]

These messages are lost if additional alarms occur while the receiver is disabled. When the receiver is disabled the messages are stored in a clipboard and routed once the receiver becomes enabled.

Repeat configuration

The "Repeat" function of Alarm Router is required primarily for user with pagers and SMS. Its purpose is to make certain that a new alarm reaches the receiver without fail. To ensure that only new, incoming alarms are repeated, but not acknowledgements or resets, note the following procedure:

- Create a separate routing group for these functions.
- Only the following events must appear in this routing group:
  - Alarm High
  - Alarm Into
  - Alarm Low
  - Alarm NoFeedback
  - Alarm Trunk
  - Alarm Fault

Function of Enable alarm repetition:

The events shown in the routing group are repeated as often as specified and at the defined intervals.

Function of Repeat to-alarm events only as long the alarm remains unacked:

The current event is repeated only while the alarm remains in the "Unacknowledged" state. There are no further repeats when:

- The alarm is "active" but acknowledged.
- The alarm is no longer present (simple alarm)
- The alarm is no longer present and has been acknowledged (normal and extended alarms).

If the remaining alarm events (i.e. alarm acknowledge, alarm reset, alarm disable, alarm return to normal and unknown third-party events) are also to be forwarded, a separate routing group must be set up for this purpose.
1. Select the corresponding row.
2. Right-click the **Repetition** column.
3. Select **Enable repetition**.

![Configuration panel](image)

4. Select the checkbox **Enable repetition**.
5. Select the checkbox **Repeat to-alarm events only as long as the alarm remains unack**.
6. Configure the redial.

<table>
<thead>
<tr>
<th>No.</th>
<th>Number or redials, e.g. when the line is busy or not available. Only when the alarm is active.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Period [hh:mm]</td>
<td>Delay times between the individual attempts.</td>
</tr>
</tbody>
</table>

7. Click **OK**.

**Configure delay**

The "Delay" function in Alarm Router is required primarily for application with Pager/SMS. Its purpose is to enable a new alarm to be cleared before being forwarded to a pager/SMS. To ensure that the delay affects only new, incoming alarms, but not acknowledgements or resets, note the following procedure:

- Create a separate routing group for these functions.
  - Only the following events must appear in this routing group:
    - Alarm High
    - Alarm Into
    - Alarm Low
    - Alarm NoFeedback
    - Alarm Trunk
    - Alarm Fault

**Function of Enable delay:**

The events listed in the routing group are delayed by the period of time specified.

**Function of After delay, route to-alarm events only if the alarm is still unacknowledged:**

The current event is transmitted after a delay, if the alarm status is "Unacknowledged". It is not transmitted, if during the current delay:

- The alarm is "active" but acknowledged.
- The alarm is no longer present (simple alarm)
- The alarm is no longer present and has been acknowledged (normal and extended alarms).

If the remaining alarm events (i.e. alarm acknowledge, alarm reset, alarm disable, alarm return to normal and unknown third-party events) are also to be forwarded, a separate routing group must be set up for this purpose.
1. Select the corresponding row.
2. Right-click the **Delay** column.
3. Select **Enable delay**.

![Image](image1.png)

4. Select the checkbox **Enable delay**.
5. Select the checkbox **After delay, route to-alarm events only if the alarm is still unacked**.
6. Configure **Edit delay**.

<table>
<thead>
<tr>
<th>Period [hh:mm]</th>
<th>Delay time prior to routing the alarm to the receiver.</th>
</tr>
</thead>
</table>

7. Click **OK**.

---

Test pager

Described under “Routing alarm messages” below.

---

Create a back-up receiver

In the event that a receiver is not available (Fax machine off line, pager receiver unavailable etc.) then it is possible to create a back-up device. This receives events from the nominated routing group in the event that the primary device is unavailable.

This concept does not work for backing up remote or local printers; printer messages are transferred to Windows, which then handles all printer errors.

To create a back-up receiver, firstly create it under System Configurator using the normal procedure (see earlier).

1. Open the **Alarm Router** in the Desigo Insight taskbar.
2. Select **View > Receiver**.
   OR
   Click **Show receivers** to display existing receivers.

![Image](image2.png)

3. Right-click column **Back-up Receiver** in the rows for the corresponding receiver. Select **Edit Back-up Receiver**...
4. Select the receiver type and name.
5. Click **OK**.
Test routing of alarm messages

It is often useful to check if a new alarm route works, without actually triggering an alarm. This is the purpose of the “User message”.

1. Open the Alarm Router 📲 in the Desigo Insight taskbar.
2. Select File > Send user message….

![Send User Message Dialog](image)

3. Select the receiver type and name.
4. Select Message.
5. Enter a message in the text field.
6. Click Send. A user message is sent.

The test message should be received at the receiver. If not, check the Log Viewer for specific errors.

Delete queued tasks

If alarm tasks cannot be routed to receivers, they remain in the queue until either sent or manually deleted.

1. Click 📲 in the Desigo Insight taskbar to start the Alarm Router.
2. Select View > Open Tasks 📜.
3. Right-click the table Open Tasks.
4. Select one of the following:
   Delete all tasks
   Delete selected tasks
   Delete all tasks for selected receiver
   Hide all tasks for selected receiver
   Delete filter