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Introduction

About This Document
Purpose of this Document
This guide provides a technical guide for localising the MM8000 software application. Individuals performing these operations are expected to have prior expertise
in the field of security, at least a moderate level of familiarity with the Siemens
Building Technologies product line, and experience with the installation and configuration of security management systems.
Scope
This document applies to the MM8000 Management Station, version 3.20.
Target audience
This documentation is intended for the following users:
− Product Managers

Documentation resource information (New for MP4.15!)
A new document has been created to assemble in one place important information
regarding documentation resources. This document contains the following:
− Comprehensive definitions of the target audiences for Siemens FS DMS
documents
− Training program information including the Siemens intranet link
− A complete list of all available DMS8000 documents
− Instructions for how to obtain a document via the Siemens intranet using the
STEP Documentation Repository System
− A map of relevant documents for each target audience group
− Customer Support links & resources
− A glossary containing definitions of all terms and acronyms used in
DMS8000 documentation
To access the DMS8000 MP4.15 Documentation Resource Information Guide
(STEP #A6V10089056), go to the link and follow the instructions below:
https://workspace.sbt.siemens.com/content/00001123/default.aspx
1. Click on the "STEP WEB Client" image:
Choose "04 Fire -3F" from the "Product Segment" box and select “Activate filter”.
2. Select “All” in the Documents section of the Quick Search page and select “Advanced Search”.
3. Enter the document number in the “Brochure No.” field (A6V10089056) and
press “Enter”.
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Modification index
Versions

Date

Notes

MP4.15

06.2008

Corresponds to version 4.15 of MM8000 Management Station
Software

MP4.10

06.2007

Corresponds to version 4.10 of MM8000 Management Station
Software

MP3.20

06.2006

Corresponds to version 3.20 of MM8000 Management Station
Software

MP3.15

09.2005

Corresponds to version 3.15 of MM8000 Management Station
Software

MP3.12

06.2005

Corresponds to version 3.12 of MM8000 Management Station
Software

MP3.10-01

03.2005

Corresponds to version 3.10-01 of MM8000 Management
Station Software

MP3.10

12.2004

Corresponds to version 3.10 of MM8000 Management Station
Software

MP2.31

02.2004

Corresponds to version 2.31 of MM8000 Management Station
Software

MP2.30

10.2003

Corresponds to version 2.30 of MM8000 Management Station
Software

Disclaimer
We have checked the contents of this manual for agreement with the hardware and
software described. Since deviations cannot be precluded entirely, we cannot
guarantee full agreement. However, the data in this manual are reviewed regularly
and any necessary corrections included in subsequent editions. Suggestions for
improvement are welcome.
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1

Introduction
This is a guide to the localisation procedures for the MM8000 Management Station.
It provides the following information:
• General overview of the MM8000 localisation process (Section 2 at p. 7).
• Guide for the localisation activities using Alchemy Catalyst (Section 3 at p. 12).
• Details on localising XML-DB texts using XML editor (Section 4 at p.18).
• Guide for localising and customising the MM8000 default project (Section 5 at
p.28).
• Instructions about further localisation activities related to SMS and Pager character sets (Section 6 at p. 30).
• Guidelines about how to translate the on-line help files (Section 7 at p. 31).
If you encounter a problem in the localisation, or an inconsistency in this document,
please let us know so that we can better document the next manual. Please contact FS DMS support.

1.1

What is new in MP4.15
The localisation process has remained the same.

1.2

Documentation corrections in this edition
P. 4

About this document
New section about “Documentation resource information”
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2

MM8000 localisation overview
The following is a general overview of the MM8000 localisation process.

2.1

Localisation activity
What is localisation?
MM8000 is distributed by SBT FS DMS with English texts. The activity required to
translate the English texts and to customise the default settings is called localisation.
The MM8000 localisation process includes:
• Translation of MM8000 system texts used by the MM8000 user interface.
Note: The Composer system texts cannot be translated, and can be used in
English only. However, these English texts will not be visible to the final customers using the MM8000 system, unless they are authorised to access the
Composer configuration environment.
• Translation of MM8000 configuration tool models, which are applied to create
new set of points in a MM8000 project. For example, you use configuration tool
models to define the objects of a new CZ10, CS11, and so on.
• Translation of MM8000 point property texts. These texts describe the states of
the point properties such as Alarm, Fault, and so on.
• Customisation of MM8000 default project, used whenever a new MM8000
configuration is started. The default project can contain text and structure customisations.
• An optional localisation of the Pager and/or SMS character set can be carried
on under the supervision of the MM8000 Customer Support.
• Translation of MM8000 on-line help texts, a set of HTML pages that provide
information about the function and usage of MM8000.
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2.2

File formats
MM8000 software environment contains localised texts in various types of files.
These include:
• DLL files, which are extensions of the program files (.EXE). The MM8000 text
DLLs have been merged into two database files that can be handled by the Alchemy Catalyst application (see below).
− MM8000 MP 4.15 ENG.ttk (system texts);
− MM8000 MP 4.15 - Subsystem Tools ENG.ttk (configuration tool models).
• XLE files; this is the project file recognised by the XML-editor. Select it to open
the XML files to translate.
• XML files, also indicated as XML-DB or NPS database, which contain the point
property texts. These files can be edited with a specialised application that is
part of the MM8000 software installation, namely the ‘XML Editor.exe’ program
(see below). The use of other XML editors is not recommended.
• MDB files (MS-Access 2000 or later), located in the ‘MM8000’ subfolder and
containing a table including a list of Unicode characters and the corresponding
character to substitute for SMS and for Pager messages. Note that modifying
the standard character mapping in these files requires adequate technical skill
and a specific knowledge of the SMS or Paging system in use.
• On-line help files, containing the MM8000 project used to start a new Composer configuration (see Fig. 1 below). The default project can contain any customisation, including texts, a basic structure tree, example maps, and so on.
• Default.bak file, containing the MM8000 project used to start a new Composer
configuration (see Fig. 1 below). The default project can contain any customisation, including texts, a basic structure tree, example maps, and so on.

The “Default project” is
used to start a new
MM8000 configuration.

Fig. 1

Default project
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2.3

Localisation toolkit
The MM8000 localisation is supported by a toolkit that is provided upon request.
The toolkit is distributed in the MM8000 CD and includes the files illustrated below:

Fig. 2

Toolkit files

MM8000 Localisation toolkit files

Contents

A

<DIR> Default Project

Subfolder containing the MM8000 Composer project used
to start a new configuration.

B

<DIR> MM8000

Subfolder containing the SMS and Pager character set
files. Namely: ‘\Server\mappingUcs2Gsm.mdb’ and
‘\Server\mappingUcs2Pager.mdb’.
After the Catalyst data compilation, the same folder will
include the text DLL extracted from Catalyst database.
Note: the folder ‘MM8000 SubSystem Tools’ will also be
created by the compilation procedure.

C

<DIR> MM8000 Help

Subfolder for the CHM files (HTML compiled files) containing the MM8000 help texts.

D

<DIR> xml files

XML-DB (for NPS server) containing the MM8000 texts for
point properties.

E

AllSubsystem.txt

List file including the subsystem tools.

F

Build ZIP file.exe
and DLL and OCX files

Application to create the installable text set (LANGxxx.ZIP).
Note: the application also requires DLL and OCX files.

G

CatQS_ALL.exe

Setup file for Catalyst 4 Quickship application. This freeof-charge software can open .TTK data files and translate
texts.

H

Help.txt

List file including the on-line help modules.

I

MM8000 MP 4.15 - Subsys-

Catalyst data files for MM8000 Composer models texts.
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tem Tools ENG.ttk
J

MM8000 MP 4.15 ENG.ttk

Catalyst data files for MM8000 system texts.

K

MM8000 - XML Editor.exe

XML editor application. It is used to localise the XML-DB.

Tab.1.

2.4

Localisation Toolkit files

Localisation process checklist
Items needed
− A PC running Windows 2000 or XP and supporting the language you want to
translate to. On the PC, check the locale setting in:
’Start Æ Control Panel Æ Regional options Æ General tab/Windows locale’.
− Administrator username and password for the PC.
− The MM8000 MP4.15 CD.
Localisation checklist
1. Log in as Windows administrator.
2. Install MM8000 (refer to document ‘MM8000 Installation, Configuration, and
Commissioning’ and Release Notes).
3. From the MM8000 CD, copy the Localisation Toolkit files on a new folder on the
local disk. Do not use the Toolkit files on a CD-Rom.
4. Install Catalyst (see section 3 at p.12).
5. If you have any previous MM8000 Catalyst localisation, restore and update
(leverage) the older texts (see 3.2.2 at p.17).
6. Localise MM8000 system: in case of first localisation, create a new TTK file
(‘MM8000 MP 3.20 ENG.ttk’ Î ‘MM8000 MP 3.20 XXX.ttk’).
7. Extract MM8000 texts and generate DLL files 1 (see 3.2.3 at p.17).
8. If you have any previous Catalyst localisation for the Composer models, restore
and update (leverage) the older texts (see 3.2.2 at p.17).
9. Localise Composer models: in case of first localisation, create a new TTK file
(‘MM8000 MP4.15 - Subsystem Tools ENG.ttk’ Î ‘MM8000 MP4.15 - Subsystem Tools XXX.ttk’). For Catalyst functions, refer to section 3 at p.12.
10.Extract Composer models texts and generate DLL files (see 3.2.3 at p.17).
11.Localise the XML-DB texts (see section 4 at p.18).
12.Create the LANG-xxx.ZIP file (see Tab.1-F at p. 10).
13.Install the language files (<installation folder>\Utilities\Language installation\Language installation.exe)
14.Localise the default project (see 5.1 at p. 28).
15.If necessary, localise the Pager and/or SMS character sets (see 6.1 at p.30)
16.Translate the on-line help pages (see 7.1 at p.31).
17.Create the LANG-xxx:ZIP file (see Tab.1-F at p. 10).
18.Install the language files (<installation folder >\Utilities\Language installation\Language installation.exe)
19.Prepare a new MM8000 project in Composer.

1

Licensed Catalyst edition is required for exporting texts into DLLs (see 3.1 at p. 12).
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20.Download the project.
21.Run the localised MM8000.
22.Test the localised software and possibly repeat the steps 6 to 21 above for refining the localisation.
23.Send to FS DMS support the final localised toolkit.
24.The LANG-xxx.ZIP file can be added to the MM8000 setup CD for installing the
localised texts along with software in the program installation.
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Localising texts using Catalyst
This section is a guide for the localisation activities using Alchemy Catalyst.

3.1

Catalyst overview
Alchemy Catalyst
Catalyst is an integrated translation environment by Alchemy Software
(http://www.alchemysoftware.ie/). This application can extract (import) the texts
from EXE and DLL files, and create a database file (TTK) that can be used for a
comfortable translation, assisted by a guided interface and management tools.
When ready, translated texts can then be exported back to DLL/EXE files, which
can be installed on a computer for testing the localised software application.
Catalyst editions
Catalyst is available in 4 different editions (see also the Catalyst product list in
http://www.alchemysoftware.ie/products/productline.html). These editions are:
• Catalyst Translator/Lite Edition (previously called Quickship)
Included in the MM8000 localisation toolkit, this edition allows for translating the
TTK text databases, but not for exporting texts into DLL and testing the localised MM8000. In order to check the results it is necessary to ship the TTK files
to FS DMS support and wait for the exported DLL files.
Æ Catalyst Quickship V4.0 can be downloaded at:
http://www.alchemysoftware.ie/quickship/.
• Catalyst Translator
This edition is not included in the MM8000 toolkit, but is available for a moderate charge. This software enables you to translate the TTK text databases, to
export texts into DLL, and to test the localised MM8000.
• Catalyst Localiser
In addition to what is available in the Translator edition, the Localiser provides
more advanced tools for easy update of text versions, and more powerful tools
for text activity management.
• Catalyst Developer/Pro
This edition also supports tools for creating Quickship TTK databases.
Important notes:
– It is recommended to use the Translator or Localiser edition of Catalyst. Using
Quickship (at no cost) will not permit you to immediately verify the localised
software, and you will end up in a long and costly localisation process.
– Note that, starting from version 5, Catalyst software requires a license code that
can be requested via e-mail to the Catalyst support.
– Catalyst V4, V5, V6, and V7 can be used. For each version, we recommend
you to install the latest Service Release available on the web site
http://www.alchemysoftware.ie.

12
Building Technologies
Fire Safety & Security Products

019_DMS_MM8000_Localisation_ Eng_Guide_ MP4.15_A6V10062459_a_en.doc
06.2008

Localising texts using Catalyst
Training on Catalyst
Using Catalyst software is quite simple. Before using it extensively however, we
recommend that you run some training sessions (Web-based lessons). These are
available on the Internet at: http://www.alchemysoftware.ie/tutorials/index.html.

3.2

Localising MM8000 texts with Catalyst
Catalyst Text Translation Kits (TTK)
The MM8000 localisation items (texts, graphic symbols, and so on) are organised
in the following TTK files:
− MM8000 MP 4.15 xxx.ttk (system texts).
− MM8000 MP 4.15 Subsystem Tools xxx.ttk (configuration tool models).
Note: ‘xxx’ indicates the target language; English (ENG) is always available for
reference.

3.2.1

Basic Catalyst instructions
For both TTK files (system texts and configuration tool models, see above), proceed as follows:
Create your own TTK files
In Catalyst, open (File Æ Open) the original TTK file (‘…ENG.ttk’) and saves it (File
Æ Save as) in the same folder with a new name. We recommend the use the same
name, only replacing the ENG code with your own language code (e.g.: FRE for
French, SWE for, Swedish, etc.). See Fig. 3.

Fig. 3

Save the renamed TTK project
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Set target language
If you are running the Licensed Catalyst edition, then select your target language:
(see Fig. 4). This is not required in the Quickship edition.

Fig. 4

Target language setting

Navigation tree
Open the navigation tree as indicated in Fig. 5.

Editing field

Fig. 5

Open the navigation tree

This results in a tree view being displayed on the left hand side (see Fig. 6), showing a number of resource groups. The ones indicated by the priority sign (a red triangle ‘ ‘) have to be translated.
Î Texts marked with the symbol ‘ ‘ (reserved) must not be localised, please ignore them. Note also that the symbol may be removed and the associated text (or
value) modified; you should not do that!
Î Texts marked with the symbol ‘ ‘ (locked) must not be localised either, please
ignore them. Note also that the symbol may be removed and the associated text
(or value) modified; you should not do that!
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Fig. 6

Tree view in Catalyst

Translating text strings
Select the group in the tree, and translate the individual text strings that display on
the right hand side of the screen (see Fig. 7 below).

Fig. 7

Translating text strings

How to use the spelling checker
1. Choose Tools → Options → the General tab from the Catalyst menu.
2. Select your language under the Dictionary dropdown.
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Note: You should also select ‘Perform auto checking’ and ‘Hotkey aware’, as
these options will notify you if you misspell a word while you are working, and
will ignore ampersands (&) when spellchecking.
3. Select ‘OK’.
→ To quickly correct any misspellings while translating, click Edit →
QuickSpell, or press F3 to display a list of suggested corrections. Doubleclick a correction to replace the misspelling with the selected correction.
→ To check the spelling of a text string, click Edit→ Spell Check, or press
F4.
How to use a technical glossary
1. Choose Tools → Options → General from the menu.
2. Select the ‘Glossary’ tab within the Options property sheet.
3. Check the box beside ‘Glossary 1’ and select the glossary you wish to use.
Note: You can attach two glossaries, and you have the option to suggest from
the TTK you are currently working in. You also have the option to select ‘Update
glossary file with (TTK) translations on close of (TTK) file’. This will add new
translations in your TTK to your glossary file each time you close the TTK.
While translating or editing, to ensure correct and consistent terminology for your
translations, click Edit → Glossary, or press F2 to look up recommended translation suggestions while translating or editing text strings in objects
Localisation of menus and dialogs
Menus and dialog windows can be translated in WYSIWYG mode (‘What You See
Is What You Get’). The menu and the windows display exactly as they would appear in the software application when viewed by a user (and can be adjusted). Just
press F7 or the button shown in Fig. 8.

Fig. 8

Using WYSIWYG mode

How to enable automatic translation (replica option)
1. Choose Tools → Options → CATALYST Experts from the menu.
2. Select the ‘Replica’ tab within the Expert Options property sheet.
3. Check the box beside ‘Enable Replication’ and select ‘Interactive Replication’.
Note: Whenever you translate a text, the software will check whether the same
string is present in another position and propose a multiple translation.
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3.2.2

Updating texts from previous MM8000 release
Use the Leverage Expert to update the texts. Note that you will need the licensed
edition of Catalyst. Proceed as follows:
1. Start Catalyst.
2. Open the new 4.15 TTK in English.
3. Start the Leverage Expert command.
4. Select the previous TTK database in your own language.
5. Catalyst imports the older texts, leaving the new ones in English.

3.2.3

Extracting texts
This step is required to extract the localised texts and store them in the runtime
DLL files replacing the original English texts.
Note that only the licensed editions of Catalyst are enabled to extract texts and updating DLL files
The charged editions of Catalyst also allow you to export the translated texts into
the run-time DLL files. To export texts, do the following:
1. Select the top node on the tree.
2. Choose File → Extract section from the menu.
The destination directory should be the localisation folder. A set of localised
DLL files will then be created in the toolkit folder, ready to be compressed into
the language installation file.
→ The language installation file (ZIP file) is created by the program described in the Tab.1-F at p. 10.
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4

Localising point properties using XML Editor
This section deals with the localisation of the MM8000 point properties, contained
in the XML database (XML-DB).

4.1

XML-DB
The XML-DB database is made up of several files that contain the models of the
point representation of each control unit.

4.2

XML Editor
With the XML Editor, you can open the entire set of files and modify the text and
icon information.

4.2.1

Launching the editor
Starting XML Editor for localisation
You start the XML Editor launching ‘MM8000 XML Editor.exe’ from the Localisation
toolkit folder (see Tab.1-K at p. 10).
Note: the program must run under an account with administration rights.

When launched, the program takes a while before showing up on the screen.

4.2.2

Working with the editor
XML Editor menu
The XML Editor provides a Windows-standard interface. The main menu and the
toolbar are illustrated in Fig. 9.

Fig. 9

XML Editor interface
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The command list in the XML Editor menu includes:

Selection …
File Æ

Toolbar
Open

Open XML-DB

Save

Save information into XML-DB

Import old XML

-

New localised language

Edit Æ

Command

Import the localised XML-DB from a previous
MM8000 release. That will be automatically
updated to latest release.
Copy the original XML-DB into a new database,
thus creating a new language.

Backup

-

Compress and save the XML-DB
(available for MT8001 only)

Restore

-

Uncompress and load the XML-DB
(available for MT8001 only)

Exit

-

Quit XML Editor

Expand

Expand the sub-tree whose root is the selected
node

Collapse

Collapse the sub-tree whose root is the selected node

Replace

-

Replace a text through the entire database

Extended replace

-

Replace a text through a selected part of the
database

Find

Find a text in the database

View Æ

Toolbar

Help Æ

About XMLEditor

-

Enable the toolbar, just below the menu.
Show the ‘About’ window

XML Editor Project Tabs
The XML Editor is organised project tabs. The MM8000 Tab (Fig. 10) contains a
project tree including all the control units and the associated Data Points.
Each point can include the following items:
− Symbol ID: the associated graphic symbol number.
− Physical properties: texts describing the physical conditions of the point.
− Virtual properties: texts describing the calculated conditions of the point.
− Transaction properties: texts describing the transactions related to the point.
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Fig. 10

XML Editor: MM8000 project tab and project tree

Information on the screen is split up in four active columns, shown in white background, which contains the following:

Title

Contents

Name

For both Virtual and Physical Properties, this column lists the properties and, for
each of them, its conditions and commands.
Instead, in the Data Points tab, the subsystem list is given. Each subsystem
includes the affiliated data points.
In this column, a special icon ( ) shows up next to the name when the value has
not been modified yet; then, after the translation, a new icon is used ( ) to indicate that a final revision is required.
The icon can be cleared by right clicking the line, and then selecting the command ‘Icon reset’.

Original
(English)

Here the original property text in English is shown. This text cannot be edited.
In case of Data Points, the original icon number is shown.

Localised
(previous version)

This column is only used when a previous XML-DB release is imported. In this
case, the previous text (or icon number) is reported here. This value cannot be
edited and it is shown for reference only.

Localised
(current version)

This column contains the localised texts (or icons) that, initially in English, are
progressively translated. You can edit the text field in two ways:
1) Individually: select the line and then the field in this column (use a single
click) At that point you can replace or modify the field and then press Enter to
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confirm (see Fig. 11).
2) Sequentially: select the line (first mouse click) and then click on the editing
field just below the menu and the toolbar (see Fig. 12).
At that point, you can replace or modify the field and then press Enter to confirm.
The program automatically moves to the next line and select the text field for
editing.
Localised value is shown in green colour instead of black.
Note: Some texts are preceded by a plus sign (+), indicating that the condition is
inherited from affiliated nodes (e.g. element exclusions propagated to the parent
zone). In the translation, you can keep or change that type of sign.

Fig. 11

Individual text editing

Fig. 12

Sequential text editing
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4.2.3

Creating a new language
When starting a new localisation, you first have to copy the original XML-DB into a
new database. Use the ‘New localised language’ command and, when prompted,
confirm it.
This command results in the ‘Localised (current version)’ column being populated
by texts, which are initially the same as the original English. Also, all items are
marked with the ‘not-translated-yet’ sign ( ). See Fig. 13.

Fig. 13

4.2.4

Select ‘New localised language’ to start a new localisation

Translating Properties texts
The property texts are included in three sets of nodes: Virtual Properties, Physical
Properties, and Transaction Properties.
Virtual, Physical, and Transaction Properties
The Virtual Properties (formerly called Common Properties or CP) represent the
calculated conditions of the safety and security objects as determined by MM8000
out of the physical conditions. The virtual condition calculation is based on algorithms both local to each object and propagating the virtual conditions along the
structure tree.
The Physical Properties (formerly called Local Properties or LP) represent the individual conditions of the safety and security objects as mapped in the MM8000 database out of the incoming status messages. For each of them, the list of conditions, as well as the command texts should be translated.
For each Virtual and Physical Property, the text of both conditions and commands
should be translated.
The Transaction Properties represent the individual occurrences related to Access
Control (e.g. access granted). For each of them, a single text should be translated.
If you do not need a complete translation, you may limit the localisation to the
properties related to the control units and data points that you actually require.

Translation checklist
To translate texts, you have to:
1. Select the first numbered property in the Name column.
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2. Expand the sub-tree to show condition texts.
3. Select the first condition clicking on the line.
4. Press F2 or click the text in the ‘Localised (current version)’ column (individual
editing, Fig. 11)
-- or -click the editing field (sequential editing, Fig. 12).
5. Translate the text and confirm with Enter (Fig. 14).
6. Translate all conditions, repeating steps 3 to 5 for the other conditions.
7. Translate all commands, repeating steps 2 to 6 for all the commands.
8. Translate all properties, repeating steps 1 to 7 for all the properties.

Fig. 14

Editing text

The Replace command
Most of the XML-DB fields actually contain the very same texts (e.g. Alarm, Fault,
etc.). Therefore, the global replacement function offers a powerful way to translate
the entire database quickly and consistently.
Just start the command ‘Edit Æ Replace’ and then fill in the window that shows up
(Fig. 15). You can first try a single substitution (Replace) and then operate globally
(Replace All).

Fig. 15

Filling in the Replace window
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The Extended Replace command
This command allows for selected replacing based on various criteria:
• Object type: Text or SymbollD (the latter only for icons)
• Find What/Replace With: searching and replace texts or values
• Scope includes various options:
− Subsystem and Data Point: these fields allow you to limit the replacement
action to a Subsystem type or to a Data Point type of a subsystem
− Virtual / Physical / Transaction Properties: these fields allow you to limit the
replacement action to a property type only. The options available in the dropdown lists depend on the Subsystem and Data Point selection.
− Causes/Conditions and Commands: these fields allow you to limit the replacement action to specific status or command texts.

Fig. 16

Extended Replace window

24
Building Technologies
Fire Safety & Security Products

019_DMS_MM8000_Localisation_ Eng_Guide_ MP4.15_A6V10062459_a_en.doc
06.2008

Localising point properties using XML Editor

4.2.5

Localising Data Point Icons
The Symbol ID items do not contain any text to translate and might even be ignored during the first steps of localisation. However, later on, it may turn out to be
useful for modifying the icon associated to the data point. Although the icons may
be customised for each project in Composer, the possibility to change some of
them here allows defining general icons that will then apply to all the subsequent
projects.
Note that these icons will appear in the MM8000 pages and graphic maps whenever the associated Data Point is shown. They are also used by Composer in the
system structure tree.
The user interface for this function is very much the same as for the property texts.
Data Points are organised in groups related to the type of units or subsystems. You
will have to expand each of them, select the line and then click and modify the
value in the ‘Localised (current version)’ column.
Icon localisation checklist
To localise icons, you have to:
1. Select a group in the Name column.
2. Expand the sub-tree and select a Data Point.
3. Select the line named ‘Symbol ID’.
4. Click on the value in the ‘Localised (current version)’ column.
5. Select the new icon (Fig. 17).
6. Repeating the steps above for any other icon.

Fig. 17

Selecting a new icon
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4.2.6

Importing XML-DB from previous MM8000 release
XML files from previous versions can be restored into latest XML editor and then
integrated with the translation of new texts.
Use the editor command File Æ Import old XML-DB, then browse in the file system
and select the folder containing the previous XML-DB (the folder must include the
3.x files CPS.xml, LPS.xml, NodeTypes.xml, and TPS.xml). See Fig. 18 and Fig.
19.

Fig. 18

Starting import procedure

Fig. 19

Selecting folder containing old XML files

The import procedure will then process the old database and port it into the new
files. Old texts are shown in the central column ‘Localised (previous version)’ and
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also copied in the ‘Localised (current version)’ as much as possible. New texts that
are missing in the previous release are taken from the original database in English.

4.2.7

Save localised XML-DB and leave editor
You can close the XML editor by selecting File Æ Exit. There is no risk you can
lose the data you just entered: upon terminating the program, a window displays
like the one shown in Fig. 20.
If you want to save the changes to the XML-DB, click ‘Yes’; instead, if you want to
discard the latest modifications, select ‘No’. Clicking ‘Cancel’ results in aborting the
program termination and in the editor remaining active.

Fig. 20

Save XML-DB files
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5

Default project
This section tells you how to localise your default project, which is used as starting
point for any new MM8000 project.

5.1

Localisation of MM8000 default project
Default project file
The file Default.bak contains the project structure that is presented whenever a
new project is created (see Fig. 1, at p. 8). In order to simplify the creation of a new
MM8000 system, the default project already includes a number of standard objects.
After the translation and the installation of texts, you can prepare a localised project, and add any customisation you may want to use. You do this using the Composer tools.
When the project is ready, make a backup copy and rename the resulting
‘xxx.BAK’ file into the ‘default.bak’ file of the localisation toolkit. Then, run the
‘MM8000 Build ZIP File’ utility to include the default project in the installation kit.
Default project localisation checklist
1. Ensure you have localised the XML-DB (see section 4, at p. 18), created the
LANG-xxx:ZIP file and then installed the text using the ‘Language installation’
utility (see checklist in 2.4 at p.10).
2. Set Composer in Debug mode:
Launch the utility ‘ST_DebugYes.reg’ available in the folder <Installation
folder>\Utilities\Reg.
3. Start Composer and Restore 2 the standard default project included in the
‘…\MM8000 MP 3.20 - Localisation ToolKit\Default Project\Default.bak‘.
Alternatively, you may want restore the Default.bak project that you have customised for the previous MM8000 version and that you want now to port into the
new market package. In this case, you also need to run the ‘Project Update’ in
the ‘User data’ node (Supervision System Settings Æ MM8000 System Æ Logical Configuration Æ User Data).
More information on the configuration update from previous versions is given in
the MM8000 Release Notes.
4. Select the ‘User data’ node (Supervision System Settings Æ MM8000 System
Æ Logical Configuration Æ User Data) and, in the Node tab, launch the ‘Language Update’ command (see Fig. 21-A).
Æ This command will import the localised texts into the project.
5. Select the ‘Security’ node and reset to zero the parameter ‘Initflag’ that appears
in the ‘Children’ grid (see Fig. 22-A).
Note: You may have to scroll the grid list to the right until you reach the ‘Initflag’
field. For easier operations, you can also select a limited number of columns:
right-click on the property page and enable the desired columns in the ‘Properties’ dialog.
Æ Setting the Initflag to zero will result in the default project setting the current

2

The Composer Restore (as well as Backup) operation only works on local disk drives. Do not use network drives.

28
Building Technologies
Fire Safety & Security Products

019_DMS_MM8000_Localisation_ Eng_Guide_ MP4.15_A6V10062459_a_en.doc
06.2008

Default project
domain (as MM8000 security domain) and user name (as MM8000 administrator) when it will be opened.
6. Translate texts of the MM8000 objects.
Note: Under the Security – Users - Domain node, the default User Groups
should not be removed.
7. Customise the project adding folders, standard maps, users and so on.
8. Backup the project and close Composer.
9. Copy the project backup (the BAK file you just saved) in the ‘Default Project’
folder of the localisation took kit. Then, delete the previous default.bak file and
rename the latest backup into default.bak.
10.Set Composer back in standard operation mode:
Launch the utility ST_DebugNo.reg, available in the folder <InstallationDir>\Utilities\Reg.

Fig. 21

Language Update (A) for default project

Fig. 22

Setting Initflag (A)
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6

Further customisation activities

6.1

GSM and Pager character set
GSM and Pager devices usually handle an 8-bit character set that can create difficulties in relation with some national characters.
In order to address this problem, the MM8000 localisation kit includes two simple
MS-Access files: Ucs2Gsm.mdb and Ucs2Pager.mdb (related to SMS and
Pager, respectively) in order to provide the possibility to customise any number of
characters in the set applied in SMS or Pager messages.
Both files are located in the “<installation folder>\Server” subfolder and contain a
data table organised in 2 columns named:
− UCS (Unicode Character Set) and GMS
− UCS (Unicode Character Set) and Pager
Microsoft Access 2000 is required to open and modify the files. You can also use
a more recent version of MS-Access software, in that case, however, pay attention not to modify the general data structure.
The characters that require a customised conversion must be present in the table
both as Unicode and as the corresponding GMS/Pager code. Please refer to the
GSM/Pager device documentation.
In case of problem, we recommend you to contact FS DMS customer support.
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7

On-line help files
This section tells you how to localise the on-line help files, a set of compiled HTML
files (CHM) that contain the texts provided to the MM8000 operators when they ask
for help in the main menu or by pressing F1.
Note that no integrated tool is provided for the localisation of help texts and the
procedure requires technical skills adequate to handle HTML file editing and conversion, as illustrated here below.

7.1

Localisation of MM8000 on-line help
MM8000 help is based on Microsoft HTML Help, the standard help system for the
Windows platform. The MM8000 on-line help files are provided in the localisation
toolkit in the ‘MM8000 Help folder (see Tab.1-C at p. 10).). The list of files that
need to be translated includes (note that other files are present but do not contain
any texts):

#

Subfolder

Name

Contents

Type

1

01 Definition Of Terms\EventBar-01\

EventBar-01.chm

Analytical index

CHM

2

01 Definition Of Terms\EventBar-01\

Default.css

Cascading Style Sheet

3

01 Definition Of Terms\EventBar-01\

Index.htm

Introduction page

4

01 Definition Of Terms\EventBar-01\

Siemens_color_25.jpg

Siemens logo

5

02 Getting To Know\ PlantBrowser-02\

PlantBrowser-02.chm

Guide to the system

6

03 Open And Close\EventBar-03\

EventBar-03.chm

Login, Logout, and other
operator tasks
CHM

7

04 Procedures\EventBar-04\

EventBar-04.chm

Treating an event

CHM

8

04 Procedures\PlantBrowser-04\

PlantBrowser-04.chm

Browsers operations

CHM

3

4

CSS
HTML
JPG
CHM

In most of the cases, the file format is the compiled HTML (CHM files). In order to
translate the text in this type of files, you need to:
1. Copy the CHM files into a separate working folder.
2. Decompile the CHM files and get the original HTML format.
3. Translate the HTML files and (optionally) replace the pictures.
4. Compile the HTML again and get the CHM format again.
5. Check the translated help system by testing one CHM file at the time.
6. Replace the files into the MM8000 localisation toolkit.
7. Create the ZIP file and install texts in MM8000 (see general process at p.10)
8. Check the entire help system in MM8000
Step 2, 3, and 4 (de-compilation, translation/editing, and re-compilation) require
specific software utilities. We recommend the following:
3
4

Style sheet file for HTML pages in help files (CHM) projects.
Image included in the Index.htm’ page.
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Decompiling CHM files
You can use the free utility ‘KeyTools’, which can be downloaded at:
http://www.keyworks.net/keytools.htm. Start the program and follow the guided
menu selecting the Decompile option.
Editing HTML
HTML files can be modified using an editor that can modify texts without affecting
the tag structures. We recommend the use of RoboHelp HTML (Office edition,
charged), see: http://www.macromedia.com/software/robohelp/. Specialised HTML
editors are also usually OK, although not comfortable for the translation activity.
Instead, note that the format conversions operated by Microsoft Word (when opening and saving HTML files) does not work properly. Word may still be used as long
as the HTML to DOC/RTF conversion (and vice versa) is performed with external
tools.
Compiling HTML into a CHM file
The RoboHelp program can also provide the CHM compilation. Alternatively, you
can use the (free of charge) HTML Help Workshop by Microsoft, see:
http://msdn.microsoft.com/library/default.asp?url=/library/enus/htmlhelp/html/hwMicrosoftHTMLHelpDownloads.asp.
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